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Highlights 
Completely new environment for geoprocessing, modeling and scripting. Includes new dockable 

ArcToolbox window with comprehensive set of geoprocessing tools available in all applications for all types of 
data. Integrated model builder lets you link geoprocessing operations together and build models interactively. 
New command interface via the new dockable Command Line window. All geoprocessing functionality can be 
scripted using third-party scripting languages. Toolboxes can be stored in folders and geodatabases. 

New and improved tools for labeling maps and creating and editing annotation. Includes new Labeling 
and Annotation toolbars in ArcMap. New Label Manager lets you specify label properties without visiting layer 
properties dialogs individually. Annotation can now be stored in multiple annotation classes inside an annotation 
feature class, each with its own set of properties. This makes it easy to create different sets of annotation for the 
same features. New tools for converting coverage and CAD annotation to geodatabase annotation.  

Raster data can now be completely managed through ArcCatalog and is fully integrated into the 
geodatabase. Various improvements including new tools for building and working with raster catalogs in 
geodatabases, which now appear in ArcCatalog with their own icons and a special contents browser combining 
table and geographic view. New raster rendering options. Raster datasets and raster catalogs can now be 
stored in personal geodatabases. Raster data (such as digital photos of buildings, etc.) can be stored as raster 
attributes in geodatabase feature classes and standalone tables. 

Usability, performance and quality improvements in ArcMap. It's now easier and faster to manipulate 
layers and data frames in the Table Of Contents. Many other fixes. ArcMap starts up more quickly and it is 
quicker to launch the Add Data dialog. New export options added. The Print and Page Setup dialogs have been 
completely redesigned. ArcMap now supports layer-based masking via the Advanced Drawing Options dialog. 

Geodatabase scalability. There are many improvements to performance and scalability of the geodatabase 
in a multi-user workflow.  All multi-user geodatabase users will benefit from these performance gains. 

Geodatabase open data exchange using XML. You can export all or any part of a geodatabase, such as 
individual feature datasets, feature classes, and tables, to an XML file. Another user can then import the XML 
file into a geodatabase. Disconnected edits can also be transferred and checked-in using XML. This makes 
geodatabases completely open and interoperable because the XML specification will be published by ESRI.  

GPS toolbar is now standard in ArcMap. Before 9.0, the GPS toolbar was a separate free download. 

Composite address locators can now be defined for geocoding. A composite address locator references 
several other address locators and chains them together to provide 'fall back' geocoding across, for example, 
reference data for different areas or at different scales.  
 
Extensions  
 

New Maplex For ArcGIS extension. Lets you create high quality cartographic label placement. 

3D Analyst extension. Completely new ArcGlobe application for making stunning 3D visualizations. 
Enhanced 3D symbology and texture support lets you create realistic displays and animations. Hundreds of 
great looking 3D symbols, objects and textures included. Support for drawing 3D graphics and text in ArcScene.  

Publisher extension and ArcReader: New options for publishers including data packaging and time out. 
New customization options gives developers access to the controls behind ArcReader so they can be 
embedded in customized solutions on the desktop. ArcReader is now also supported on Sun Solaris. 

Spatial Analyst extension. Over 100 new functions exposed in the user interface. Full integration with new 
geoprocessing framework. File size limit for ESRI GRIDs removed, and other improvements. 

StreetMap extension. New route finding capabilities added. Enhancements to StreetMap USA dataset. 

New desktop and server deployment opportunities. At 9.0, two new products are available separately: 
ArcGIS Engine, for creating and deploying custom applications based on core ArcGIS functionality, and ArcGIS 
Server, for deploying server-based ArcGIS services and applications over intranets and the Internet.  
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Welcome to ArcGIS 9.0 
 
ArcGIS 9.0 is the next major release of ArcGIS. This release builds on previous releases and adds important 
new capabilities. We've also worked hard to improve quality and performance in a number of areas. This 
document guides you through the key new features of ArcGIS 9.0 compared to ArcGIS 8.x. 
 
 
Getting more information 
 

Look for the new ESRI Software Documentation Library CD that comes with the release. This CD provides 
the complete range of ArcGIS books in PDF format. 
 

Use the ArcGIS Desktop Help. You can launch this from the Windows Start menu or by choosing Help > 
ArcGIS Desktop Help in any of the ArcGIS applications. We have worked hard to improve the content and 
indexing of the help.  
 

You get detailed context sensitive help about tools, commands and dialogs as you use the software: 
 
- To get help on a command in a pulldown menu or a button in a toolbar, click the What's This tool   in the 

Standard Toolbar and then click the item.  
 
- To get help on a command in a context menu (menu launched by right-clicking something), highlight the 

command and press SHIFT+F1.  
 
- To get help on a control in a dialog, click the ? control at the top of the dialog and then click the control.  
 
- Some dialogs have a 'Help' or 'About...' button that launches a topic giving you quick information and tips. 
 
- To get help on a window, such as the Table Of Contents or the Identify Results window, first click inside the 

window and then press SHIFT+F1. 
 
- To get help on a control in a geoprocessing dialog you launch from the new ArcToolbox window, click in or on 

the control and then press the Show Help button to expand the help panel. When the help panel is expanded, 
you can click the Help icon at the top of the panel to launch the Desktop help topic for the tool.  
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Geoprocessing 
 
ArcGIS 9.0 presents a comprehensive set of geoprocessing tools that work with all the supported data formats, 
including geodatabase features. It also offers a completely new framework for working with these tools that 
enables you to launch them individually, combine them together in a visual modeling environment, write scripts 
in standard scripting languages, and run the tools as commands in a command line window. With this new 
geoprocessing environment, ArcGIS 9.0 completes the transition of ESRI's GIS tools to the desktop that began 
with the introduction of ArcGIS 8.0. ArcGIS 8.x provided a new framework for managing, sharing, mapping and 
editing data, along with a comprehensive new data model: the geodatabase. Now ArcGIS 9.0 completes the 
picture with a powerful new environment for putting that data to work. 
 
New ArcToolbox window 
 

In ArcGIS 8.x, ArcToolbox was a standalone application. At 9.0, ArcToolbox is now a dockable window 
integrated into all the ArcGIS Desktop applications. For example, when you run tools from the ArcToolbox 
window inside ArcMap, you can use the current map's layers as inputs, and the outputs can be added directly 
into the map as new layers.  
 

The geoprocessing framework is common to all the ArcGIS Desktop applications and is included with each of 
the ArcGIS products: ArcView, ArcEditor and ArcInfo. The number of geoprocessing tools you'll see in your 
ArcToolbox window depends on which product and extensions you are using: 
 
- ArcView and ArcEditor have the standard map based analysis tools commonly associated with project work.  
 
- ArcInfo is the primary platform for advanced GIS analysis and modeling and therefore provides the complete 

set of geoprocessing tools (around 200). If you install ArcInfo Workstation these tools include the 'Coverage 
Tools' toolbox, which contains the complete set of ArcInfo Workstation analysis, conversion and data 
management tools for use with coverage data.  

 
- More than 200 additional tools are provided by the ArcGIS extensions, such as ArcGIS 3D Analyst and 

ArcGIS Spatial Analyst. 
 
Here's what you will see in the ArcToolbox window if you're an ArcInfo user and you've installed ArcInfo 
Workstation and all the ArcGIS extensions released with 9.0: 
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When you look inside a toolbox, you'll notice that the tools it contains are usually organized into toolsets: 
 

 
 
Here's what you'll see in a toolbox: 

 
Toolset: a container for organizing the contents of a toolbox. 

 
Tool: runs an underlying function in the geoprocessing framework. 

 
Script: can be written in any COM compliant scripting language, such as Python, JScript or 
VBScript. An ArcInfo Workstation AML can also be added into a toolbox as a script. 

 
Model: you can view and edit these in the new integrated ModelBuilder window. 

You can re-organize and save the contents of the ArcToolbox window in any way you like. You can create 
your own toolboxes too. To add a new, empty toolbox into the ArcToolbox window, right-click the ArcToolbox 
entry at the top of the tree, and choose New Toolbox: 
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Once you've created a new, empty toolbox, you can add existing tools and scripts to it, and create models in it. 
For example to create a new model in the new, empty toolbox you've just added, right-click the toolbox to get its 
context menu and click the New Model command in the New pullright: 
 

 
 

Toolboxes you create can be stored as .tbx files in folders or stored directly in geodatabases. This makes it 
easy to manage, distribute and share custom tools, models and scripts. For example, all the tools created by a 
GIS department for use with a particular enterprise geodatabase can be stored in that geodatabase and 
accessed and updated centrally. It is very easy to 'package' models and scripts that you make as tools for 
others to use. When a user double-clicks on a model you've created, they'll see a dialog prompting them for the 
inputs. The user only needs to see the visual model or the actual script if they want to. In fact, several of the 
standard conversion tools provided in 9.0 are actually models or scripts that run underlying functions, which 
means you can easily inspect them to see how they work.  
 

An integrated Documentation Editor makes it easy to create documentation and metadata for models, scripts, 
and toolboxes you create. Documentation you create for models and scripts can be accessed via the Help panel 
of the dialog that appears when they are launched, or by right-clicking them in ArcToolbox and choosing Help. 
Documentation for toolboxes can be accessed by right-clicking them in ArcToolbox and choosing Help. 
Metadata for the contents of toolboxes can be accessed via ArcCatalog's Metadata tab. 
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Using the geoprocessing framework 
 

There are five ways to perform geoprocessing at 9.0, summarized in this table: 
 
Method Description Use To 

Tool dialog 

 

A form in which input data and other 
necessary parameters are defined. 
Full embedded context sensitive help 
is provided. 

- Run any geoprocessing tool from 
inside any application. 

- Get familiar with a tool and its 
parameters. 

Model  

 

An interactive visual model that links 
processes, data and parameters 
together. Models are created and 
edited in the integrated ModelBuilder 
window.  

- Build models, workflows and 
processes without scripting or 
programming. 

- Document or present a process. 
-  Explore alternative scenarios. 
-  Present methodology and workflow to 

others. 

Command Line 

 

Dockable Command Line window 
offering usage pop-ups for 
commands, auto-completion, etc. 

- Run tools quickly without launching 
their dialogs. 

- Useful shortcut for advanced users. 
- Already familiar to long term ArcInfo 

users! 

Script 

 

File written using a standard scripting 
language such as Python, Jscript or 
VB Script.  

- Automate repetitive tasks. 
- Full control of process based on any 

conditions, states, time delay, etc.  
- Brings the 'traditional' working 

environment for advanced GIS users 
to bear on the full range of ArcGIS 
Desktop functionality. Scripting is 
back! 

ArcObjects 

 

Geoprocessing objects can be 
accessed in the ArcGIS development 
environment to create custom tools 
and applications using COM 
compliant languages like Visual Basic 
6, Visual Basic .Net, C++, and C#. 

- Incorporate tools into new and 
existing applications. 

- Create custom dynamic link libraries 
that incorporate geoprocessing tools. 

- Create custom toolbox functions (DLL, 
EXE, or OCX). 
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Geoprocessing tools can be launched directly by double-clicking on the tool in the ArcToolbox window.  This 
will open the tool dialog so you can specify the necessary inputs and execute the tool: 
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You can also create models that will execute a sequence of geoprocessing functions. For example, an 
output data source that is projected in one function becomes the input for an overlay function, and so on.  
 

 
 
Models are viewed and edited using the integrated ModelBuilder window. The ModelBuilder window lets you 
drag and drop tools and data into the model diagram to build processes that can be connected into a logical 
flow. You can run a model from within the ModelBuilder window and inspect the flow of control. Models can also 
include scripts and other models as steps. You can save models in toolboxes and use them as tools or distribute 
them to other users. A model can also be exported from the ModelBuilder window as a script, so you can first 
build a process as a model, export it as a script, and then add additional automation or advanced flow of control. 
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Geoprocessing tools can also be used within scripts to allow the automation of repetitive processes or 
complex flow of control. Scripts have traditionally been the staple working environment of long term ArcInfo 
users. At 9.0 scripts are back! Scripts can include calls to geoprocessing tools, models, and other scripts. 
Scripts are easy to author in the COM compliant scripting environment of your choice, such as Python, 
VBScript, and JScript.  After a script is authored, it can be exposed to users as a standard tool and embedded in 
other models or scripts like any other tool. The script shown below is written in Python: 
 

 
 
Support for existing ArcInfo Workstation AML scripts via ArcToolbox has been improved at 9.0. Any AML can be 
added as a script in a toolbox at 9.0, not just those that execute Arc commands like in ArcToolbox 8.3. The only 
stipulation is that the AML start in the Arc module. The AML can then go to ArcEdit, ArcPlot, Grid, etc. Also, in 
ArcToolbox 8.3 the dialog for running an AML-based script was limited to one input field for all the arguments. At 
9.0, you can define individual parameters for AML-based scripts, like you can for any other tool, script or model 
you create. You can specify the parameter types and the system will validate input values against these. You 
can also add coded value or range domains to a parameter. The AML-based script you've created can then be 
used like any other geoprocessing tool: you can run it as a stand-alone tool from the ArcToolbox window, add it 
into a model as a processing step, run it from the geoprocessing Command Line window, or call it from another 
script. 
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The geoprocessing environment includes a dockable Command Line window. This window provides an easy 
way to run any tool, model or script. This command line makes repetitive tasks quick and easy, similar to 
command line executions in ArcInfo Workstation. Messages are shown in the lower part of the window to 
document the progress of tools run in any session. Tools can be re-executed by interacting with the window. 
Like the ArcToolbox window, the Command Line window is available in any ArcGIS Desktop application and can 
be docked into the application's window: 
 

 
 
In the upper panel, type the first few letters of a command and a scrolling list will popup containing the 
commands that match what you type. Once you've typed a command, its usage appears in a tip, and additional 
popup lists make it easy to fill in options and key words. You can also press F1 to access the full help topic 
about the command you are using.  
 
Right-click inside the upper or lower panels in the Geoprocessing window to access a menu of additional 
commands.  
 
You can use the Up/Down arrow keys on your keyboard to cycle between your recent commands. You can also 
recall a particular command by either right-clicking inside it in the lower panel and choosing Recall from the 
menu that appears, or simply double-clicking it.  
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A set of new spatial statistics tools are included with 9.0. You can find these in the 'Spatial Statistics Tools' 
toolbox in the ArcToolbox window: 
 

 
 
These tools work with all license types except for the following four tools which require an ArcInfo license: 
 
- Cluster/Outlier Analysis with Rendering 
- Hot Spot Analysis with Rendering 
- Count Renderer 
- Z Score Renderer 
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Labeling  
 
At 9.0 we've improved the user interface for labeling and provided new core functionality. In addition, a new 
labeling extension is available at 9.0. The Maplex for ArcGIS extension allows high quality cartographic label 
creation using advanced label placement and fitting techniques. Maplex uses an advanced conflict detection 
algorithm to automatically generate labels. There's a separate section in this document about the Maplex 
extension. 
 

 There's a new toolbar and some new dialogs for specifying and managing the labels drawn for layers. From 
View>Toolbars choose the new Labeling toolbar. Here's what the Labeling toolbar looks like: 
 

 
 

If you have installed the Maplex for ArcGIS extension, the Maplex commands will also appear in this new 
toolbar. There's not a separate toolbar for the Maplex extension. Here's what the Labeling toolbar looks like if 
you have installed the Maplex extension: 
 

 
 

 You can also access the new labeling commands via a new Labeling pullright that has been added into the 
context menu for a data frame: 
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The new Label Manager dialog  launched from the Labeling toolbar or the Labeling pullright lets you turn 
labeling on and off for any label classes in the layers in the active data frame, change the properties of any label 
class, and create, delete and copy/paste label classes. The Label Manager lets you specify labels for layers 
without repeatedly visiting their property dialogs. 
 

 
 
The Label Manager replaces the Labels tab in the Data Frame Properties dialog, which has now been removed.  
 

The Label Priority Ranking dialog  lets you rank the drawing priority of the label classes in the active 
frame. 
 

The Label Weight Ranking dialog  lets you control which labels will be placed when there are potential 
onflicts (overlaps) between features and labels. 

 
c

Layers still have a Labels tab in their Properties dialog, which has been enhanced to include controls for 
uickly specifying the main properties of the text symbol. 

 
q
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The Options command in the Labeling pulldown menu launches the new Labeling Options dialog. This 
contains a General tab with options that apply to both the standard and the Maplex label engine. If you have 
installed the Maplex extension and are using the Maplex Label Engine for the active data frame, a Maplex tab 
will also be present in the dialog containing options specific to Maplex. 
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In previous releases of ArcGIS there were no placement options for labeling polygons. 9.0 adds some of the 
most frequently requested options for polygon label placement. 'Straight' polygon labeling means that each label 
will be placed so that it follows the longest direction of the polygon being labeled. In the dialog below, the 
preview on the left changes according to which radio button option you choose on the right:  
 

 
 

At 9.0 a wider range of fonts is supported. The Font picker dropdown lists in ArcMap and all the other 
applications in ArcGIS have also been improved to better reflect the available fonts. In ArcGIS 8.x, we supported 
only TrueType and TrueType-based OpenType fonts, and we used two icons next to font names in the 
dropdown lists to indicate the font type: 
 

  Font is only available while printing 
 True Type font 

 
At 9.0 these icons have been replaced with this new set to reflect the range of fonts that are now supported : 
 

 Font is not available on this machine so type detection is impossible 
 OpenType font (TrueType-based, Type1-based and Type2CFF-based) 
 TrueType font (TrueType fonts, TrueType Collection and MultipleMaster) 
 Type 1 font 
 Raster-based font only used in the user interface (e.g. for the Table Of Contents or table window) 

 
If the Font dropdown list contains fonts with vertical metrics, such as those used to display Asian language 

text, a 'CJK Character Orientation' check box control is shown on the Text Symbol Selector and Text Symbol 
Properties Editor dialogs. This enables users to specify that the fonts will be drawn vertically. This control is 
completely hidden if these types of fonts are not present. 
 

Label placement options for line features have been grouped differently on the label placement properties 
dialog. 
 

Layer Properties dialog Labels tab: The Label Placement Options button on this tab has been renamed to 
Placement Properties to match the name of the dialog it launches. 
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Text formatting tags now work for curved annotation. 
 

Several new text formatting tags and attributes have been added at 9.0: 
 
- Scale attribute added to the existing FNT tag. This lets you adjust the size of the text relative to the current 

size. Specify a scale factor in percent (100% = regular): 
 

<FNT name= "Arial" size="12">This text is Arial 12 point.<FNT scale="200">This text is Arial 24 
point.</FNT></FNT>

 
- Width attribute added to the existing CHR tag to change the character width. Specify a width factor in percent 

(100% = regular): 
 

<CHR width="150">My text</CHR> 
  
-  _BOL, _ITA, _UND, _SUP and _SUB tags added to make text un-bold, un-italic, etc. Tags follow the rules of 

XML so you can't, for example, use the existing </BOL> tag to turn off bold for a text symbol whose base text 
symbol is already bold. To turn bold off you would use the new _BOL tag: 

 
This is bold if the base text symbol is bold<_BOL>, but this is not.</_BOL> 

 
The dialog launched by the Label tool  has been renamed from 'Labeling Options' to 'Label Tool Options'. 

 
The dialog for specifying a label expression has been renamed from Expression Properties to Label 

Expression and several improvements have been made: 
 
- The dialog that appears when you verify your expression has been improved it make it clearer what the actual 

results of your expression will be and to give you a WYSIWYG sample label that fully interprets the results of 
any text formatting tags in the expression: 

 

  
 
 Also, if you have defined an SQL query for your label class, the sample label that the dialog shows you now 

contains the values from the first feature in your feature class that matches the SQL query. In ArcGIS 8.x the 
verification dialog always used the first feature in the feature class, which was confusing when you created a 
label expression specifically to label values you expected to be returned by the SQL query you defined for the 
label class.  
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- There's now a Reset button that removes the current label expression and replaces it with the default label 
field for the layer. Press the Reset button if you want to clear or remove the current label expression. It's a 
quick way to start again with your expression. (If you just delete the current expression and press OK you'll get 
an error because there has to be an expression in this dialog, even if it is just the name of the default label 
field). 

 
- The Add button has been renamed to Append to better reflect what it does. To define a label expression in 

which two fields are appended together, double-click (or drag and drop) the first field in the list of fields to add 
it into the expression, then select the second field and press Append. 

 
- Double-clicking a field in the list no longer appends it to the end of your expression. Now when you double-

click a field in the list it gets inserted into the expression at the current cursor location. This makes it easier to 
build expressions and also better matches the behaviour of the Select By Attributes dialog.  

 
- You can now copy values out of the Show Values subdialog for pasting into the expression, etc.   
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Annotation 
 
ArcGIS 9.0 includes a number of improvements to the functionality and user experience for creating and editing 
geodatabase annotation. There is a new, more flexible model for storing annotation inside of a geodatabase that 
better suits your data modeling requirements. Also, annotation is fully integrated into the ArcMap editing user 
experience at ArcGIS 9.0. Both of these fundamental changes will increase productivity and make the creation 
and update of annotation features easier and more intuitive. 
 
  
Updating annotation feature classes to ArcGIS 9.0 
  
To take advantage of these improvements, you will need to upgrade your geodatabase version to ArcGIS 9.0 
and then update each annotation feature class within the geodatabase to include a new schema that is required 
when editing annotation in ArcMap.  
  
You can upgrade a personal geodatabase using ArcCatalog; this type of upgrade does not affect any data but 
makes some additions to the geodatabase system tables. For more information on how to upgrade a personal 
geodatabase in ArcCatalog, look in the ArcGIS Desktop Help index for 'upgrading, geodatabases' to get to the 
'Upgrading a geodatabase' help topic. 
  
The process for upgrading a multi-user geodatabase to ArcGIS 9.0 involves upgrading the ArcSDE software on 
the server. For more information on upgrading your multi-user geodatabase, see the 'ArcSDE Installation Guide' 
for your DBMS. 
  
Once you have updated the geodatabase to ArcGIS 9.0, you can then update the schema of each annotation 
feature class in the geodatabase to take advantage of these improvements. Before you do so, you should 
consider the design of annotation feature classes in your geodatabase data model and consider taking 
advantage of the new schema. For example, you can now create annotation classes or subtypes within an 
annotation feature class. This enables you to classify annotation features by theme or scale and reduce the 
number of feature classes within the geodatabase.  
  
To update the schema of your annotation feature classes, use the Update Annotation Feature Class tool found 
in ArcToolbox. You can find this tool in the Data Management Tools > Feature Class toolset. This will update the 
schema of the feature class and, optionally, each annotation feature within the feature class. The schema 
update will add additional fields to the feature class (Bold, Italic, Text, etc) and also ensure that there is a 
symbol within the symbol collection: without a symbol in the symbol collection you cannot use the improvements 
for constructing annotation features. 
  
If you decide that you want to take advantage of annotation subtypes, you can merge annotation feature classes 
together and create subtypes. To do so, use the Append Annotation Feature Classes tool found in ArcToolbox 
in the Data Management Tools > Feature Class toolset. This tool will merge annotation features from multiple 
classes into one annotation feature class and create the appropriate subtypes. If you use this tool within 
ArcMap, you can select features of a given scale or theme and append only those into the new feature class. 
  
 
Storing annotation 
 

The annotation in a geodatabase annotation feature class can now be stored in multiple annotation classes 
inside that feature class. Each annotation class has its own set of labeling properties, including expression, text 
symbology and placement properties. This enhancement saves you from having to define multiple annotation 
feature classes when you want to create different sets of annotation for the same features. You can create 
annotation classes in the New Feature Class wizard when you create an annotation feature class. If you are 
creating feature-linked annotation, you can specify the placement properties for the annotation in each 
annotation class: 
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You can also create annotation classes using the Convert Labels To Annotation command in ArcMap (in the 
context menu for a layer). If you have defined label classes for your layer, each of these label classes becomes 
an annotation class in the annotation that gets created.  
 
Annotation classes can be created and modified after you have created the annotation feature class by going to 
the new Annotation Classes tab in the Feature Class Properties dialog for an annotation feature class in 
ArcCatalog. 
 
When you add a layer based on an annotation feature class into a map, the different classes of annotation it 
contains are shown as entries underneath that layer in the Table Of Contents: 

 

 
 

When you create a new annotation feature class, the panels for specifying the annotation options have 
changed to accommodate new functionality.  
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For example, when you create feature-linked annotation you can now specify the label engine that will be used 
to generate the annotation placement. In the example shown below, the Maplex Label Engine in the Maplex for 
ArcGIS extension has been chosen to generate the annotation placement. The Maplex for ArcGIS extension is 
a new extension introduced at 9.0 that provides high quality cartographic label creation using advanced label 
placement and fitting techniques: 
 

 
 
Tip: You can view and edit an annotation feature class that uses Maplex label placement whether or not you 
have the Maplex extension. In the case of editing standard annotation (annotation that is not feature-linked) 
there's no difference. In the case of editing feature-linked annotation, ArcMap will automatically use the standard 
label engine when it needs to place new annotation if a Maplex license is not available.  
 
If you want to create an annotation feature class using Maplex label placement, or edit a feature-linked 
annotation feature class using Maplex to place new annotation, you will need to have the Maplex extension. 
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Annotation text symbol properties are now shown in the attribute table for a layer based on an annotation 
feature class, including Label string, FontName, Bold, Italic, and X/Y offsets. These fields support querying and 
are editable. You will also see these fields in ArcCatalog. The example below doesn't show all the fields: 
 

 
 

 Multi-part annotation is now supported in ArcGIS Desktop . This was previously only supported in ArcInfo 
Workstation. With multi-part annotation, each part of the annotation can be adjusted individually, providing better 
options for placing text. 
 

Symbols for annotation features are now stored in the geodatabase. Annotation symbols are specified on the 
Annotation tab in the Feature Class Properties dialog for an annotation feature class in ArcCatalog: 
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The Convert Labels To Annotation dialog in ArcMap has been overhauled at 9.0. When you choose to 
convert labels to annotation feature classes (the default), the list in the dialog lets you control the destination 
and properties of the annotation that will be created. Edit the output feature class names in the Annotation 
Feature Class column. Click the browse icon  in the Annotation Feature Class column to specify the 
destination geodatabase for the annotation. Click the Properties icon  to specify properties for the annotation 
class that will be created, including specification of a configuration keyword when storing data in ArcSDE.  
 

 
 

If you save an annotation layer as a layer (.lyr) file you'll notice that we've updated the icon used for 
annotation layer files so they use the same 'A' graphic in their icon as the annotation feature class: 
 

 Layer file referencing an annotation feature class 
 
Existing annotation layer files continue to use the old 'pencil' icon. If you want these files to use the new 'A' icon 
you have to recreate them. 
 

There are new tools for converting coverage and CAD annotation to geodatabase annotation. You can find 
these in the 'To Geodatabase' toolset in the Conversion Tools toolbox in ArcToolbox. 
 

There is a Append Annotation Feature Classes Tool that combines two or more annotation feature classes 
into a single annotation feature class. You can find it in the 'Feature Class' toolset in the Data Management 
Tools toolbox in ArcToolbox. 
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Displaying annotation 
 

When you add a layer based on an annotation feature class into a map, the different classes of annotation it 
contains are shown as entries underneath that layer in the Table Of Contents: 
 

 
 

By default, annotation layers now respect their drawing order in the Table Of Contents just like any other 
layer. You change this behaviour on the new Display tab in the Layer Properties dialog for an annotation layer 
(see below). 
 

A new Display tab has been added into the Properties dialog for a layer representing an annotation feature 
class. With this tab you can specify transparency, set up map tips, and create hyperlinks for annotation. You can 
also specify a layer to which the current annotation layer is associated. Specifying an associated layer links the 
visibility of these layers in the map. When the associated layer is turned on or off in the Table Of Contents, the 
annotation layer will also turn on or off. 
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 The Labels tab in the Properties dialog for a layer representing an annotation feature class has been 
replaced with a new Annotation tab: 
 

 
 

A new Symbology tab has been added into the Properties dialog for a layer representing an annotation 
feature class. This new tab lets you specify symbology that will override the symbology defined for the 
annotation feature class, without having to change the annotation feature stored in the geodatabase. For 
example, if the symbology of text is defined in the geodatabase as black, you can temporarily override this and 
make it red. 
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The Properties dialog for an annotation class listed underneath an annotation layer lets you review (but not 

change) the text symbol properties used to draw it. If the annotation layer is feature-linked, you can also review 
(but not change) the placement properties, SQL query and the expression used to generate new feature-linked 
annotation for the annotation class from the feature class the annotation layer is linked to: 
 

 
 
 
Editing annotation 
 

 There is a new user interface for editing annotation, presented in a new Annotation toolbar: 
 

 
 
The Edit Annotation tool    has been moved out of the Advanced Editing toolbar and into this new Annotation 
toolbar. The tools on the new toolbar are: 
 
-     Edit Annotation tool for working with existing annotation.  
 
-   Construction tools for creating horizontal annotation, angled annotation, and annotation using a 

leader line. 
 
- Annotation construction method dropdown list. Lets you specify the construction method for the newly placed 

annotation. The available choices are Horizontal, Straight, Curved, Leader Line, and Follow Feature. 
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- Annotation text string used when creating new annotation. Enter text here, then use the construction tools to 
place annotation on your map. Multi-line 'stacked' text is supported. To enter stacked text, holding CTRL and 
typing ENTER will move the cursor to the next line. 

 
- Annotation text symbol that will be used when creating new annotation. Symbols for annotation features are 

now stored in the geodatabase. This dropdown list shows all the available symbols defined for this annotation 
layer. Hovering over a symbol in the dropdown list will list its basic properties including font, font size, vertical 
alignment, and horizontal alignment. To add new symbols to this list you use ArcCatalog to open the feature 
class properties for the annotation feature class, and then look in the new Annotation classes tab.  

 
-    Unplaced Annotation Manager command launches a new dockable window that lets you find, list, and fix 

unplaced annotation. In the Unplaced Annotation window, use the Show dropdown list to pick an annotation 
feature class or a particular annotation class in that feature class. You can further refine the search criteria by 
checking the Visible Extent option. This option will constrain the search to errors that are within your current 
display extent: 
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There's a new Annotation tab in the Editor>Editing Options dialog for use when editing annotation: 
 

 
 

Two new commands have been added into the context menu for the Edit Annotation tool. These enable you 
to convert annotation between being composed of multiple parts (e.g. multiple words) or single parts: 
 
Convert To Multiple Parts 
Convert To Single Part 
 

A new command called Find Text has been added into the context menu for the Sketch tool  . This 
command picks up annotation text from the first selectable and visible feature found under cursor position on 
map. You can use this to quickly annotate features with feature-linked annotation. Keyboard shortcut is 
CTRL+W. 
 

New Keyboard shortcuts make annotation editing faster and easier: 
 

E Cycle between the Edit tool, Edit Annotation tool and the Sketch tool. 
 
A Activate the Current Text control on the toolbar (Sketch tool). 
 
F Toggle follow feature functionality for the currently selected annotation. (Edit Annotation tool). 
 
S Activate the Current Symbol control on the toolbar (Sketch tool). 
 
L Flip annotation while using Follow Feature construction method (Edit Annotation tool and Sketch tool). 
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O Open the options dialog for the Follow Feature construction method (Edit Annotation tool and Sketch 
tool). 

 
P Switch between perpendicular and parallel options while using Follow Feature functionality. (Edit 

Annotation tool and Sketch tool). 
 

The Overflow Labels command in the View menu has been renamed to Overflow Annotation. When you 
launch this window you can now press SHIFT+F1 while it is active to get help about it.  
 

When you edit annotation the Attributes window  launched from the Editor toolbar has a new look. The 
window is smaller, the most common controls are easily available, WYSIWYG editing is available for editing 
annotation text with most ArcGIS formatting tags, and you can choose a symbol from the annotation symbol list.  
 

 
 
There is also added support in this window for editing of multiple selected annotation. In the example below, 
three annotation features are selected on the map. When the layer name is selected in the tree on the left of the 
window, changes to any of the annotation attributes shown on the right will be applied to all three currently 
selected annotation features. When an individual annotation feature is selected in the list on the left, changes 
that you make will only be applied to that one feature. 
 

 
 
Note: Even though this window doesn't have a ? control in its title bar, you can get context sensitive help on any 
control in the Attributes window by highlighting the control with the mouse or by pressing the TAB key, and then 
pressing SHIFT+F1. (This way of getting context help works with almost any floating window in ArcMap that 
does not have a ? control). 
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Three new text drawing tools have been added into the ArcMap Draw toolbar that let you draw a paragraph 

text annotation: a graphic element containing text formatted like a paragraph. The text flows within the graphic 
shape. The resulting element has text properties and graphics properties, and some new properties for setting 
columns and margins to control how the text is positioned inside the graphic. These new properties are 
presented in a tab called Columns And Margins tab you'll find in the Properties dialog for one of these new 
graphic elements. 
 

 New Polygon Text tool 
 

 New Rectangle Text tool 
 

 New Circle Text tool 
 

 
 
To resize graphics created with these tools, select the graphic and use the handles to scale the graphic, or 
press the Edit Vertices command . 
 
These tools can be used to create graphic elements, annotation stored in the map document, and annotation 
stored in a geodatabase. These tools give the same dimension feedback in the ArcMap status bar, and have the 
same options for specifying their dimensions via the keyboard, that the Circle, Rectangle and Polygon tools 
have been given at 9.0.  
 

New curved leader lines: Two new curved leader lines are available for callouts. Select the Line Callout 
option when specifying the text symbol background for a text symbol drawn with the Callout tool to see these 
two new options: 

 
The New Annotation Target command in the Draw pulldown menu can no longer be used to create an 

annotation feature class in a geodatabase, and this command and the dialog it launches has been renamed to 
New Annotation Group to reflect this change. With this simplification, there are now two basic ways to create an 
annotation feature class in a geodatabase: create a new, empty annotation feature class in ArcCatalog, or use 
the Convert Labels To Annotation command to create an annotation feature class from a layer's labels. 
 

Follow Feature Options dialog (Edit Annotation tool context menu): new option added when working with 
feature linked annotation to use the placement properties defined in the annotation class. 
 

Two new commands have been added into the Advanced Edit Tools category in the Tools > Customize 
dialog in ArcMap. These give you additional ways to access two of the annotation construction types added at 
9.0:  
 
Construct Curved Annotation  
Construct Annotation Following Feature 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.0 COMPARED TO 8.X PAGE  33 

Raster data 
 
At ArcGIS 9.0 raster data can now be completely managed through ArcCatalog and the underlying ArcObjects, 
and is fully integrated into the geodatabase. This results in many improvements in the way that rasters are 
stored, managed and displayed in ArcGIS. With ArcGIS 9.0 terabytes of raster data (e.g., air photos, scanned 
maps, and satellite images) can be stored in a central enterprise geodatabase and accessed by multiple users 
simultaneously. Rasters can be mosaicked into a single raster dataset or managed as a series of tiles in a raster 
catalog. A new user interface for raster catalogs makes them easier to work with. 9.0 also provides the ability to 
associate raster data such as digital photos, etc with geodatabase features and by storing the rasters as 
attributes in fields of type raster. Fields of type raster can also be defined in standalone tables in geodatabases.  
 
The new geoprocessing framework at 9.0 contains a full set of tools for working with raster data. Using the 
framework, these new tools can be combined in models and scripts to automate your raster management tasks. 
In ArcToolbox, look in the Data Management Tools toolbox for the Raster toolset. Look in the Conversion Tools 
toolbox for the From Raster and To Raster toolsets. 
 
 
Raster datasets 
 

Raster datasets can now be added to personal geodatabases as well as enterprise (ArcSDE) geodatabases. 
 

Raster datasets added to a personal geodatabase are managed by the personal geodatabase rather than 
being actually stored inside the geodatabase like they are with ArcSDE geodatabases. The personal 
geodatabase automatically stores the raster data locally as IMG files in a folder named after, and located in the 
same folder as, the personal geodatabase. For example, if your personal geodatabase is called Canada, the 
folder containing the raster data that it manages will be called Canada.idb. This folder is managed directly by the 
geodatabase and does not appear in ArcCatalog.  
 

ArcGIS 9.0 introduces partial pyramid building for raster datasets stored in ArcSDE geodatabases, a major 
performance improvement from previous versions. Instead of rebuilding pyramids for the entire extent of the 
raster dataset, only the area affected by the data being loaded into the raster dataset (mosaic) needs to have it’s 
pyramids rebuilt. This facilitates easy raster dataset mosaicking because now even very large raster datasets in 
ArcSDE geodatabases can be updated easily. 
 

You can now perform mosaicing when you import a raster into a geodatabase. In ArcCatalog, right-click a 
geodatabase and look in the Import pullright for the Raster Datasets (Mosaic) command.  
 

Versioning and geodatabase raster data at 9.0: Raster data cannot be versioned at 9.0, but this is 
functionality that we hope to implement in the future. 
 
Note: Because fields of type raster (see the heading entitled 'Raster fields' later in this section for more about 
these fields) are stored in geodatabase feature classes and tables, and those entities themselves can be 
versioned, the raster data in this scenario does become a shallow version. The raster data of the parent version 
remains present as long as children versions of the data do not post any deletions or changes back to the 
parent. Addition of raster data also does not affect the parent version unless posting occurs. 
 

The ESRI GRID raster format is now able to hold more than 2.1 GB of data.  At 9.0, there is no limit to the 
amount of pixel data which can be stored using an ESRI GRID.  For very large imagery, however, the use of the 
enterprise (ArcSDE) geodatabase is recommended as large files/folders are difficult to manage and slow to 
process. 
 

There is now no limit to the number of ESRI GRIDs that can be added into a single ArcMap, ArcScene or 
ArcGlobe document. The limitation of 49 GRIDs in a single document has been removed at 9.0. 
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The raster dataset properties dialog in ArcCatalog now features a tree control that makes it easy to quickly 
browse through the various properties of a raster. The tree also gives access to options like building statistics: 
 

 
 

Additional rendering functionality is now available for drawing raster datasets. The Symbology tab in the 
properties dialog for a layer based on a raster dataset has been enhanced as follows: 
 
- Better management of how image stretch rendering is applied: based on the statistics from the whole image, 

the visible portion of the image (per display raster stretching), or user defined statistics.  
 
- A ColorMap renderer is now included to display raster datasets with built in colormaps. 
 
- New Import button adds the ability to import raster symbology properties from a layer (.lyr) file. A limitation at 

9.0 is that the Import button only imports the renderer settings. It doesn't change or set the renderer type. So 
for example if you import symbology from a raster layer which used the Stretch renderer, you have to already 
be in the Stretch renderer panel in the Symbology tab to import all the settings for this renderer correctly.  

 
- New ability to choose background values as an RGB composite value. 
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The Source tab in the properties dialog for a layer based on a raster dataset has changed to include part of 
the same tree control used in the raster dataset properties dialog in ArcCatalog: 
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You can now export raster data from a layer based on a raster dataset in ArcMap using the new Export Data 
command you'll find in the layer's context menu. You can either use the extent of the raster dataset represented 
by the layer or the current extent displayed in the data frame. You also have the option of exporting the data 
using the layer's current raster symbology: 
 

 
 

Several new raster dataset formats are supported at 9.0 (read-only): 
 
- JPEG2000 (i.e. GeoJP2 from MSI) 
 
- Integraph's CIT/COT 
 
- DIGEST ASRP/USRP 
 
- MrSID (generations 2 and 3). Note: the Export command Raster To MrSID outputs in MrSID generation 2 

format. 
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The Raster tab in the Options dialog accessed from the Tools pulldown menu in all the ArcGIS Desktop 
applications has been enhanced to provide additional settings via two sub-tabs:  
 

 
 
See the next points for more information about the main options presented in this tab. 
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The handling of raster file formats has been improved so that file formats are now specified in their own 
dialog launched from the General sub-tab on the Raster tab in the Tools > Options dialog. The Advanced menu 
button gives you the option of defining a new raster format by specifying a .dll (note: a .dll that requires 
additional helper .dlls may not be added using this option): 
 

 
 

The reprojection of raster data has been improved at 9.0.  By default, the software will automatically choose 
the most appropriate method of reprojecting your raster data, therefore ensuring that it is drawn in the display as 
accurately as possible. This same functionality is also present when reprojecting your raster data to a new 
output and loading raster data into a geodatabase using a different projection. 
 
ArcGIS provides two internal methods of displaying raster data projected on the fly: a simple algorithm and a 
more robust algorithm. The simple algorithm is based on a single polynomial transformation and it is fast, but it 
may not meet certain accuracy needs if the raster data covers large area, the raster is located at high latitudes, 
or the raster is being transformed between certain complicated projections. The more robust algorithm is a 
piecewise polynomial transformation, where the data is transformed block-by-block, therefore guaranteeing high 
accuracy. By default, ArcGIS will automatically switch to use the simple raster transformation method if it can 
achieve the same accuracy as the more robust raster transformation method. ArcGIS does this because highly 
accurate raster transformation methods require more processing time.   
 
To enable you to control this when rasters are drawn, a check box called 'Favor rendering speed over accuracy' 
has been placed onto the Tools > Options dialog on the Raster tab's General sub-tab. This box is unchecked by 
default. To ensure that raster data is drawn as accurately as possible, leave the box unchecked. The heavily 
optimized raster reprojection algorithm will take a few seconds longer to finish, but the result will be very 
accurate.  
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Check the 'Favor rendering speed over accuracy' box to increase the display speed of raster data which is 
projected on the fly. When the box is checked, the ArcGIS  will always use the very simple raster reprojection 
algorithm, ensuring that raster data is rendered as quickly as possible. Note: certain inaccuracies may occur, as 
this will not allow ArcGIS to automatically switch into the more robust algorithm. Only check the box when 
accuracy is not a high priority. 
 
To best illustrate this advance in raster reprojection technology, a 1 kilometer resolution NASA worldwide image 
is shown below.  ArcMap shows this raster in its native geographic coordinate system (GCS_WGS_84). 
(Imagery courtesy of NASA): 
 

  
 
A simple change to the map display's coordinate system changes the appearance of the raster data 
significantly, but very quickly and efficiently.  Below, the same data is reprojected into Sinusoidal: 
 

  
 
Additionally, raster reprojection clipping has been implemented, as shown below in a UTM Zone 11 projected 
coordinate system: 
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The dialog that prompts you about building pyramids when you add them into ArcMap, etc has been 
improved. You can now press Cancel to cancel the addition of the data and do nothing: 
 

 
 
 

In ArcGIS 8.x, when you attempted to display the properties dialog a raster layer that had many unique 
values, a message pops up if there are more than 2048 unique values. The message tells you that because of 
the excessive number of unique values, the Symbology tab will not have a Unique Values renderer, and the 
Fields tab and Joins and Relates tab will not be present in the layer properties dialog. At 9.0 the behavior of 
rasters with many unique values is still the same, but the pop up message is no longer displayed. 
 

The New > Raster Dataset command on a geodatabase in ArcCatalog now launches the Create Raster 
Dataset tool from the 9.0 geoprocessing framework. 
 

The Load Data, Build Pyramids and Calculate Statistics commands on a raster dataset in ArcCatalog now 
launch the tools for performing those operations from the 9.0 geoprocessing framework. 
 
 
Raster catalogs 
 

The handling of raster catalogs has been revamped in 9.0. Raster catalogs can now be created in personal 
geodatabases and ArcSDE geodatabases as geodatabase objects appearing with their own icons in 
ArcCatalog: 
 

 Raster catalog in geodatabase 
 
You can create a new raster catalog by right-clicking a geodatabase in ArcCatalog and choosing the 
New>Raster Catalog command.  
 
The footprints of each raster in a raster catalog are stored as polygon features with attribute information making 
it possible to perform spatial queries and selections for data management, corridor analysis, display, etc. 
 

When you create a new raster catalog in a personal geodatabase, the raster catalog's data isn't actually 
stored inside the geodatabase like it is if you create it in an ArcSDE geodatabase. Instead when you create a 
raster catalog in a personal geodatabase you choose whether the data will be managed or unmanaged by the 
personal geodatabase. You make this choice when you create a new raster catalog in ArcCatalog by setting the 
'Raster Management Type' option in the Create Raster Catalog tool: 
 
- If the raster catalog's data is managed by the personal geodatabase, the rasters in the catalog will be 

automatically stored locally as IMG files in a folder named after, and located in the same folder as, the 
personal geodatabase. This folder is managed directly by the geodatabase and does not appear in 
ArcCatalog.  
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-  
cilitates 

g creation and easy prototyping of managed solutions. Raster catalogs containing not-managed 
rasters are similar to traditional image catalogs where the raster is managed by the user and not the 
d

If the raster catalog's data is unmanaged by the personal geodatabase, the rasters in the catalog will be 
automatically referenced from the geodatabase to their disk location, linked by their pathname. This fa
quick catalo

atabase. 
 

New tools are provided for browsing and managing these new raster catalogs. When you select a raster 
catalog in ArcCatalog and view its contents in the Contents tab, an expandable geography preview panel is 
available to the right of the contents listing letting you view one or more of the rasters. An expandable query 
anel is also available at the bottom of the contents lists for selecting and previewing specific sets of rasters in 

the raster catalog. These tools facilitate management, display, and query of very large raster catalogs: 
 

p

 
 
If you are using Details view in the Contents tab, you can also right-click the column headings to display 

o manage raster datasets in a raster catalog, select them in Contents view and then right-click to get a menu of 

rcGIS 8.3 raster catalogs and file based (*.dbf, *.txt, and INFO) raster catalogs can still be used but they do not 
ha

additional detail column fields, such as the Shape_Area of each raster. 
 
T
commands, including Copy, Delete, Export, Build Pyramids, etc. 
 
To load raster datasets into a raster catalog, right-click the raster catalog in ArcCatalog and choose Load Data.  
 
A

ve any of the new geodatabase raster catalog functionality and are not shown with the new icons. 
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Raster Catalogs can now store rasters of varying type (3 bands, B/W, colormap…) within a single raster 
catalog.  Rasters within a raster catalog no longer have to be of the same type. A heterogeneous raster catalog 
can be rendered using different renderers for its members. Note that heterogeneous raster catalogs are not 
ideal for all applications and are not recommended if you are aiming for optimum performance. They tend to be
slower to draw, and the stretching on the image

 
s tends to be harder to control. This multiple type functionality is 

vailable though because it can be useful in particular situations. In general rasters of different type should be 

 

'll 
nd are applied to one or more raster 

ataset members of the raster catalog.  As multiple renderers can be used for raster catalog layers, raster 
ca

a
mosaicked together into single rasters. 
 
Since raster catalogs at 9.0 no longer have to be of the same type, you can specify multiple renderers when 
you use the Symbology tab in a Raster Catalog Layer's Properties dialog. The most appropriate renderer is
automatically applied to the appropriate raster in the raster catalog. The Symbology tab lists the renderers that 
are available for the contents of the raster catalog. You can edit this his list of renderers to add or remove 
various renderers. Only the renderers in the list can be used in rendering. In the available renderers list, you
see an asterisk next to each of the renderers that are currently active a
d

talog layers don't show their symbology in the Table Of Contents.   
 

Rendering of raster catalogs has been vastly improved. Raster catalogs have the same new rendering 
apabilities as raster datasets (see the Raster datasets section above for more about improved raster rendering 

 the Raster Catalog Layer Properties dialog, the Display tab lets you specify various options for viewing the 
contents of the raster catalog either as rendered rasters or just as a wireframe showing the footprint polygons: 
 

c
in 9.0).  
 
In
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As the footprints of the rasters in raster catalogs are polygon features, these raster footprints can be easily 
displayed and queried. You can open the attribute table of a raster catalog layer and work with these footprint 
polygons like any other features. 
 
This also makes it very easy to perform sub-setting of raster catalogs. In ArcMap, you can right-click a raster 
catalog layer and choose Export Data. The Export Data dialog lets you create a new raster catalog from some 
or all of the rasters: 
 

 
 
 
Raster fields 
 

The attribute tables of geodatabase feature classes and standalone tables in personal geodatabases and 
ArcSDE geodatabase can now contain fields of type raster. A raster type field can contain any supported 
image, picture or raster dataset, such as a digital photo of a feature, a scanned floor plan, etc. Raster fields are 
defined in ArcCatalog when you create a feature class or table in a geodatabase or add fields to it after it has 
been created. They are not supported for shapefiles/dBASE tables or coverages/INFO files. Only one raster 
field can be defined for a particular feature class or standalone table. If more than one field of type raster is 
needed a related table can be used. 
 

When you define a new raster field in a feature class or standalone table in a personal geodatabase, the 
raster field's data isn't actually stored inside the geodatabase like it is if you define it in an ArcSDE geodatabase. 
Instead when you define a raster field in a personal geodatabase you choose whether the data will be managed 
or not managed by the personal geodatabase. You make this choice by setting the 'Managed By GDB' property 
on the raster field to either Yes or No when you define it. 
 
- If the raster field's data is managed by the personal geodatabase, the rasters in the field will be automatically 

stored locally as IMG files in a folder named after, and located in the same folder as, the personal 
geodatabase. This folder is managed directly by the geodatabase and does not appear in ArcCatalog.  

 
-  If the raster field's data is not managed by the personal geodatabase, the rasters in the field will be 

automatically referenced from the geodatabase to their disk location, linked by their pathname.  
 

Once you've defined a raster field, you can add data into it in an edit session in ArcMap. In ArcMap, start 
editing in the normal way. Select the feature you want to add a raster to, click the Attributes button  in the 
Editor toolbar to open the Attribute Inspector widow and then click the > button next to the raster field. In the 
empty popup window that appears, right-click and then choose the Load command. This will open a dialog that 
lets you choose the raster to load. This is also how you replace an existing raster with a different one. To delete 
a raster, choose the Clear command: 
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When you identify a feature containing a raster field in any ArcGIS Desktop application or in ArcReader, you'll 
see a small button next to the raster field if a picture exists for the record: 
 

 
 
Click that button to see the raster in a small popup window: 
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Right-click in the popup window to see more options: 
 

 
Choose the View command (or just left-click in the pop-up window) to view the raster in a floating resizable 
window: 
 

 
 

You can also view the content of raster fields in Table window in ArcMap, ArcScene and ArcGlobe. In the 
Table window, first click inside the raster field to make the '>' button appear, then click that button to view the 
raster. In the Table window, records for raster fields that contain pictures are shown with the value 'Raster'. A 
record with an empty value for a raster field indicates that a raster has not yet been loaded into the field for that 
record. In the example below, the attribute table has been opened during an edit session in ArcMap, so the 
Load and Clear buttons in the context menu for the popup window are enabled.  
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Other ArcMap changes 
 
Quick ArcMap 9.0 tips 
 

When you add layers into ArcMap, they are now automatically selected in the Table Of Contents. This lets 
you find them easily and immediately perform operations on them all by right-clicking or using one of the 
shortcuts listed below. Added multiple layers and you just want to work with one of them? Click on the layer you 
want to work with to deselect the others. 
 

You can now drag/drop and copy/paste multiple layers in the Table Of Contents.  
 

You can now drag/drop and copy/paste multiple layers between two ArcMap sessions.  
 

You can now drag/drop and copy/paste data frames between two ArcMap sessions.  
 

To quickly duplicate layer(s) in a data frame: 
- Hold down CTRL and drag/drop them in Table Of Contents. 

 
To quickly activate a different data frame: 
- Hold down ALT and click its name in the Table Of Contents. 

 
To move layer(s) instead of copying them when you drag them between data frames or ArcMap sessions: 
- Hold down CTRL while you drag/drop 
 
To rename the selected item in the Table Of Contents: 
 - Press F2 

 
To expand/collapse all items at one level in the Table Of Contents hierarchy: 
- Hold down CTRL and click the +/- control next to any item at that level. If any items are currently      

selected, click the +/- control next to any selected item to just expand/collapse the selected ones). 
 

To expand/collapse an item in the Table Of Contents while you are dragging data: 
- Hover over the +/- control next to the item and wait a bit. 

 
To add data directly into a group layer: 
 - Right-click the group layer and choose the Add Data command. 

 
To give the Table Of Contents keyboard focus so you can use keyboard to navigate and interact with it: 
- Click anywhere inside the Table Of Contents or press F3 

 
To return keyboard focus to the map so key strokes are sent to the map instead of the Table Of Contents: 
- Click anywhere on the map or press ESC 

 
To turn on/off the currently selected layers in the Table Of Contents: 
- Hold down CTRL and click the check box next to any of them or press SPACE 

 
To open the properties of the selected item in the Table Of Contents: 
- Press ENTER 

 
To drop layer(s) so they come immediately after a group layer (without having to collapse the group layer): 
- Drag the layer(s) after the group layer and then move the cursor over to the left before you do the drop. A 

little vertical line at the left end of the horizontal 'drop' bar indicates which level in the hierarchy the layer(s) 
will be dropped into. 

 
To get a help topic about the Table Of Contents shortcuts, give it keyboard focus then press SHIFT+F1. 
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Geoprocessing in ArcMap at 9.0 
 
 

The new geoprocessing framework introduced at 9.0 is fully integrated into ArcMap. Geoprocessing tools can 
be run from inside ArcMap, either by launching them directly from the new ArcToolbox window or by entering 
them as commands in the new Command Line window. Layers and tables in your current map can be used as 
inputs to geoprocessing, and outputs can be automatically added to the map as layers. You can combine tools 
together in models and scripts and run these inside ArcMap. See the 'Geoprocessing' section of this document 
for more about the new framework.  
 
Tip: The information in this section is aimed at ArcMap users but is also useful for ArcScene users looking for a 
quick overview of how to perform geoprocessing. The information also applies to the new ArcGlobe application. 
(ArcScene and ArcGlobe come with the ArcGIS 3D Analyst extension). 
 

The ArcGIS 8x Buffer Wizard   has been removed from the Tools pulldown menu in ArcMap. 
 
The Buffer wizard is still available in the 'Tools' category in the Tools > Customize dialog. If you wish to use this 
wizard, you can add it into any ArcMap toolbar or pulldown menu from that dialog. One reason you may still 
continue to use the 8x Buffer Wizard is that it allows you to buffer graphics drawn on the map. 
 
Where to find the 8x Buffer Wizard operations in the ArcToolbox window at 9.0: 
 

Buffer at a specified distance or based on distances taken from a field: 
 'Analysis Tools' toolbox > Proximity > Buffer 
 
Buffer creating multiple rings: 
 'Analysis Tools' toolbox > Proximity > Multiple Ring Buffer 

 
Note: In the Buffer tool, the Side Type option is restricted to FULL and the End Type option is restricted to 
ROUND if you are using an ArcView or ArcEditor license. Setting the Side Type to be LEFT or RIGHT, and 
setting the End Type to be FLAT, are only possible if you are using ArcInfo. 

 
The ArcGIS 8x Geoprocessing Wizard   has been removed from ArcMap. It is no longer provided in the 

product.  
 
Where to find the 8x Geoprocessing Wizard operations in the ArcToolbox window at 9.0: 
 

Dissolve: 
 'Data Management Tools' toolbox > Generalization > Dissolve 
 
Merge:   
 'Data Management Tools' toolbox > General > Append 
 
Clip:  
 'Analysis Tools' toolbox > Extract > Clip 
 
Intersect: 
 'Analysis Tools' toolbox > Overlay > Intersect 
 
Union:  
 'Analysis Tools' toolbox > Overlay > Union 

 
Note: In the Union and Intersect tools only 2 inputs are allowed if you are using an ArcView or ArcEditor license. 
The ability to union or intersect more than 2 inputs is only available if you are using an ArcInfo license. 
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Quick overview of how to perform geoprocessing in ArcMap at 9.0 
 
1. In ArcMap, open the ArcToolbox window by clicking the Show/Hide ArcToolbox Window  button on the 

Standard toolbar. When you open the ArcToolbox window from inside ArcMap, any tools you launch from 
the window are able to access the layers and tables in your current map document, and to add their output 
back into the map for immediate display. You can run the tools from inside ArcCatalog too, but the tools 
won’t be able to access the contents of your map, only data sources in ArcCatalog. The ArcToolbox window 
is a dockable window and the first time you open it after installing ArcGIS 9.0 it will dock vertically into your 
ArcMap window. A convenient location for the window is docked underneath the Table Of Contents window. 
You can just drag and drop it to that location: 

 

  
 
 Tip: To undock the ArcToolbox window, click the bar at the top of it. Once undocked, the window will 

normally try to dock when you move it over the ArcMap window. To prevent a dockable window from 
docking, hold down CTRL while you move it. 

 
2. In the ArcToolbox window, double-click the tool you want to use.  
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 Tip: The screenshot above shows what you'll see in the 'Analysis Tools' toolbox if you are an ArcView user. 

By default, core ArcGIS tools that you are not currently licensed to use are hidden in the ArcToolbox 
window. To see tools that you are not licensed to use, right-click the 'ArcToolbox' entry at the top of the tree 
and uncheck the Hide Locked Tools command. All the tools providing operations found in the Buffer Wizard 
and Geoprocessing Wizard at ArcGIS 8x are available in ArcToolbox 9.0 for all product licenses (ArcView, 
ArcEditor and ArcInfo).  

 
3.  If you wish to perform the operation on a subset of the features in a particular layer, you can make the 

selection before or after launching the tool. The new geoprocessing tool dialogs are non-modal, which 
means that you can continue to work on your map while a tool is open. Unlike the ArcGIS 8x wizards, you 
can adjust your feature selection after you launch one of the new geoprocessing tools. The tool dialogs look 
at what features are selected at the time you execute the operation (i.e. when you press OK on a tool 
dialog), not when you launch the tool dialog.  

 
 When launched from inside ArcMap, the geoprocessing tools always respect the currently selected set of 

features. There's no option inside the geoprocessing tool dialogs to choose between using all the features in 
a layer or just the currently selected set. If a set of selected features exists for a feature layer you use as an 
input to a geoprocessing tool, that set of features will be used in the operation. If no set of selected features 
exists, all the features in the layer will be used.  

 
Tip: At 9.0, the set of selected features for a layer can contain 0 features. For example, if you use the 
Selection>Select By Attributes dialog and your query expression results in 0 features being selected in a 
layer, this establishes a selection set containing 0 features on that layer, and 0 features will be used by the 
next geoprocessing operation you perform on the layer. See 'Selection' in this section of this document for 
more information about changes to the feature selection logic at 9.0. 

 
4.  In the tool dialog that appears for the tool you chose, specify the input data and other parameters. To 

specify a layer in your map as an input, click the dropdown list to choose one of the layers from your active 
data frame: 

 

  
 
 To fill in input fields you can also drag and drop layers from ArcMap's Table Of Contents, click the Browse 

button and locate any dataset using the Catalog Browser, or type or paste in layer names or pathnames to 
datasets.  

 
 Tip: Click the Show Help button in the tool dialog to display the Help panel. This panel gives you an 

overview of the tool. To get help on individual controls in the dialog, simply click them. Help about the 
control you clicked on will appear in the help panel. Click the Help button at the top of the panel to launch 
the topic about this tool in the ArcGIS Desktop Help. 
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5.  While the operation is processing, a progress dialog appears. Once it has finished, a layer representing the 

output data will appear in the Table Of Contents. 
 
More geoprocessing tips for ArcMap users 
 

You can control various aspects of how geoprocessing works by choosing the Options command from the 
ArcMap Tools pulldown menu and going to the new Geoprocessing tab. Settings you make in this tab apply to 
all the ArcGIS Desktop applications (the Display / Temporary Data options don't apply to ArcCatalog).  
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If you want geoprocessing operations to overwrite existing outputs with the same name, check that option at the 
top of the tab. When this is checked, geoprocessing operations don't prompt you if an output already exists: they 
automatically overwrite the output. 
 
The 'Results are temporary by default' option at the bottom of the tab makes it easier to clean up unwanted 
output data, such as data representing intermediate steps in geoprocessing operations you perform. When this 
option is checked, a layer added into your map by a geoprocessing operation will be considered temporary by 
ArcMap. If you remove this layer from your map's Table Of Contents, ArcMap will automatically delete the data 
on disk that this layer represents when you close the map document or exit ArcMap. When you save your map 
document, any temporary layers remaining in the Table Of Contents automatically become permanent.  If you 
close the application without saving the document, the data for temporary layers remaining in the Table Of 
Contents is automatically deleted. Note: at the time of writing the temporary layer functionality is not working in 
ArcGlobe.  
  

In the Tools > Options dialog Geoprocessing tab, press the Environments button to launch a dialog that lets 
you specify additional settings for your geoprocessing work. For example, the Current Workspace setting in the 
Environment Settings dialog lets you specify a folder or geodatabase which will serve as the default location for 
inputs and outputs you specify in geoprocessing tools, which saves you having to specify a pathname if you 
type in the name of an input or output: 
 

 
 
You can also launch the Environments dialog from the context menu you get by right-clicking the 'ArcToolbox' 
entry at the top of the ArcToolbox window tree. These settings apply to the current map document you are using 
and get saved into that document. To temporarily override your current environment settings for a particular 
operation you run from a tool dialog, press the Environments button on the tool dialog and modify the settings in 
the dialog that appears.  
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To make it easy to re-execute operations you perform, open the Command Line window before you run the 
geoprocessing tools. You can open this dockable window by clicking the Show/Hide Command Line Window  
button on the Standard toolbar. When you run one of the geoprocessing tools from the ArcToolbox window, the 
underlying command executed by the tool will appear in blue in the message area in the Command Line 
window. Right-click the command to access a context menu: 

 

 
 
Choose Open from the menu to re-open the tool dialog for the operation you just performed.  
 
Choose Recall from the menu to put the command into the top part of the window so that you can make any 
adjustments to the options used, and then press RETURN to execute it.  
 

You can combine geoprocessing operations together in models and scripts to automate repetitive tasks or 
create analytical models. To create a model, first create a new, empty toolbox in the ArcToolbox window to 
contain the model. Right-click the 'ArcToolbox' entry at the top of the tree and choose the New Toolbox 
command. Then right-click the new toolbox that appears and choose the New Model command. An empty 
ModelBuilder window will appear: 
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You can now drag and drop layers from the Table Of Contents and tools from the ArcToolbox window into the 
ModelBuilder window to build your model. In the ModelBuilder window, use the Add Connection tool  to 
connect layers and tools. Double-click tools to launch their dialogs so you can enter values for their parameters. 
To run a model, press the Run button . 
 
For example, the following model takes two soil layers and performs a Union to create an output layer.  An 
Intersect is then performed on the output layer to create a new layer, Soils_Intersect. The Dissolve operation is 
then run on the output from the Intersect operation to create the final layer, Soils_Dissolve: 
 
 

 
 
When you create a new toolbox in the ArcToolbox window in ArcMap, that toolbox will belong to the map 

document you are currently working with. When you create a new map document or open a different one, the 
toolbox you created will not appear in the ArcToolbox window.  
 
To add a toolbox you have already created in another map document into the ArcToolbox window, right-click the 
'ArcToolbox' entry at the top of the tree and choose the Add Toolbox command. You'll be prompted to browse to 
the toolbox you want to add. The default location for new toolboxes you've already added into the ArcToolbox 
window is your 'My Toolboxes' folder. You can find this folder in ArcCatalog inside the 'Toolboxes' folder at the 
top level of the ArcCatalog tree. (The physical location on disk for your 'My Toolboxes' folder is specified in the 
Tools > Options dialog Geoprocessing tab). 
 
Changes you make to the contents of the ArcToolbox window are one of your geoprocessing settings. Your 
geoprocessing settings are: 

 
- the current choice of toolboxes in the ArcToolbox window and how they are expanded/contracted. 
 
- the current settings in the Environment Settings dialog (accessed by right-clicking the top of the ArcToolbox 

window and choosing the Environments command or by pressing the Environments button in the 
Tools>Options dialog). 

 
- the current variables defined in the Variable Manager (accessed by right-clicking inside the panel at the top of 

the Command Line window and choosing the Variables command). 
 
If you are using ArcMap (or ArcScene or ArcGlobe), geoprocessing settings you make apply to the current 
document you are working with get saved into that document. In this way, all the settings you make to perform 
geoprocessing on the data shown in a particular map are stored in that map. If you are using ArcCatalog, 
settings you make apply to ArcCatalog.  

 
Tip: If you create a map template (.mxt) with ArcMap, your current geoprocessing settings get saved into the 
template and will be used by any new map document that is created using that template. In this way you can 
create different map templates with different settings according to your needs.  
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Whenever you create a new ArcMap, ArcScene or ArcGlobe document, your default geoprocessing settings 
are used for the document (unless you are creating a new map in ArcMap using a map template that contains 
geoprocessing settings). Your default settings are also used by ArcCatalog. 
 
Your default geoprocessing settings are set in one of two ways: 

 
- Whenever you quit ArcCatalog, your current geoprocessing settings in ArcCatalog automatically become the 

default. 
 
- You can set the defaults manually by right-clicking the 'ArcToolbox' entry at the top of the ArcToolbox window 

and choosing the Save Settings To Default command. This command enables you to make your current 
geoprocessing settings become the default from whatever application you are in: 
 

 
  

If you change your default geoprocessing settings, you'll find that your changes are not reflected in documents 
you have already created. To load your latest default geoprocessing settings into existing documents, right-click 
the top entry in the ArcToolbox window and choose the Load Settings From Default command. For example, if 
you've customized the ArcToolbox window in ArcCatalog and you'd like this customization to appear in an 
existing map, use that command to load the default geoprocessing settings. 

 
Tip: Use the Save Settings To File and Load Settings From File commands to save and restore 
geoprocessing settings using an XML file without affecting your default settings. Those commands make it 
easy to transfer your geoprocessing settings between, for example, different ArcMap documents, or between 
ArcCatalog and an existing ArcMap document, etc. Using an XML file is also useful if you want to copy or 
distribute geoprocessing settings between machines or between users. 

 
A good way to familiarize yourself with how scripts work in the geoprocessing framework is to create a 

model and then export it as a script by choosing Export To Script in the Model pulldown menu. Also, you may 
notice that some of the tools in the ArcToolbox window actually run scripts, such as the Multiple Ring Buffer tool 
in the 'Analysis Tools' > Proximity toolset. To view the script for a tool based on a script, right-click the tool in the 
ArcToolbox window and choose Edit. The script will appear in a window: 
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Printing maps 
 

File> Page Setup command: this command have been renamed to Page and Print Setup. The dialog 
launched by this command has been renamed to be the 'Page and Print Setup' dialog. This dialog has been 
improved for easier use and now includes a page layout preview. This makes it much easier to ensure that the 
map will fit onto the selected printer page. Also, the printer properties have been moved from the Print dialog to 
the Page and Print Setup dialog and the Print Engine drop down list has been moved to the Print dialog. This 
makes setting up the page altogether more intuitive and makes it easier to create custom printer page sizes. 
The Output Image Quality setting has been moved out of the Page and Print Setup dialog and onto both the 
Print and Export dialogs to improve ease of use as well. 
 

 
 
In this dialog, the 'Same As Printer' option has been renamed to 'Use Printer Paper Settings'. When a map 
document is saved with the 'Use Printer Paper Settings' checked and then opened on a computer that is not 
connected to the same printer, ArcMap will automatically turn off the 'Use Printer Paper Settings' option so the 
map document will open properly. 
 
Also, the 'Scale Map Elements' option is now off by default. This makes it easier to share maps with others and 
move maps to other machines because if the printer referenced by the 'Use Printer Paper Settings' option is not 
available, the map will not be scaled by default.  
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The File>Print dialog has been improved in coordination with the new Page and Print Setup dialog. You now 
only need to select the Printer Engine and the Output Image Quality at print time. There is also a print layout 
preview so that you can ensure that the map will fit on the printer page. Printer properties has been moved to 
the Printer and Page Setup dialog, which makes creating customer printer page sizes easier: 
 

 
 
 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.0 COMPARED TO 8.X PAGE  57 

Table Of Contents 
 

The pulldown menu command for hiding and showing the Table Of Contents  has been moved into the 
Window menu. In this way, the core ArcMap commands that show and hide the dockable windows (the Table Of 
Contents, ArcToolbox & Geoprocessing windows) are in the same menu.  
 

To get help on the various keyboard shortcuts for working with the Table Of Contents that have been added 
in 9.0, click inside the Table Of Contents to give it keyboard focus and then press SHIFT+F1.  
 

The highlight used in the Table Of Contents to show the selected item(s) has been improved so that it no 
longer extends across the whole window.  
 

 
 
Note: to get the context menu for an item in the Table Of Contents you can still right-click on the item's name or 
anywhere to the right of the item's name. 
 

You can now tell when the Table Of Contents has keyboard focus. You'll see a dotted line around the 
highlighted area when it has keyboard focus. When the Table Of Contents has keyboard focus, you can use the 
new keyboard shortcuts (described below) to work with it. 

 
The horizontal insertion bar that appears when you are dragging layers over the Table Of Contents has been 

made smaller and more sensitive in 9.0. The bar now indents to reflect the position in the layer hierarchy at 
which the 'drop' will occur. For example, as you can see in the graphic below on the right, the insertion bar is 
indented in 9.0 to show that the current drop location is in a group layer. In addition, we've standardized the 
drag/drop cursor.  
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In 8.x, if you selected a symbol in the Table Of Contents that has no label (either by clicking on it or using the 
Up/Down arrows on the keyboard) there was no indication that the symbol was selected. This made it hard to 
use the Up/Down arrows to navigate through the Table Of Contents because you were always losing your place. 
We have fixed this in 9.0 so that when a symbol with no label is selected, a small area highlights (see below). 
When this area is highlighted you can now press F2 if you want to specify a label for the symbol. 
 

 
The Selection tab now appears in the ArcMap Table Of Contents by default. In ArcMap 8.x this tab was 

turned off by default. This tab lists all the feature layers in your active data frame and lets you choose which of 
these layers will be 'selectable' when you use the interactive selection tools. The Selection tab is more 
convenient than using the Set Selectable Layers dialog accessed from the Selection pulldown menu. In addition, 
layers are listed in bold in this tab if they currently have a selection set, and the number of features in this set is 
also shown.  
 
Tip: In the Selection tab, hold down CTRL and click on any check box to make all the layers selectable or not 
selectable. For more help on using the Selection tab, click inside the tab to give it 'keyboard focus' and then 
press SHIFT+F1. 
 
Note: If you have been using 9.0 Pre-Release, you may not see the Selection tab in ArcMap's Table Of 
Contents by default. 9.0 Pre-Release installed a registry setting controlling whether this tab appears or not, and 
in Pre-Release this was set to off by default. Installing ArcGIS 9.0 final won't change this registry setting if it 
already exists. To turn the Selection tab on, go to the Table Of Contents tab in the Tools>Options dialog. 
 

In the Tools > Options dialog, the TOC tab has been renamed to the Table Of Contents tab. When you use 
the options at the top of this tab to choose which tabs will appear in ArcMap's Table Of Contents, your choice of 
tabs is now saved for the application (i.e. in the Windows registry) instead of being stored in the map document. 
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In this way, your choice of Table Of Contents tabs will always be the same irrespective of which map document 
you are working with.  
 

In 8.x, there was no distinction in the Table Of Contents between group layers and layers such as  
ArcIMS image service layers and survey layers, etc, which can be expanded to view the individual sub-layers 
that they contain. Unlike the layers belonging to a group layer, the sub-layers don't have the full range of layer 
properties and cannot be dragged out of the layer they belong to: they are sub-layers rather than independent 
layers.  
 
To make this distinction clearer in the Table Of Contents, at 9.0 you'll see 'tree lines' when you expand a layer 
that contains sub-layers. The tree lines indicate that these sub-layers belong together and cannot be broken 
apart or used separately from the layer they belong to. The graphic below shows how the same Table Of 
Contents containing a group layer and an ArcIMS image service layer (CBI_Relief from the Geography Network) 
looks in 9.0 compared with 8.x: 

 
New keyboard shortcuts have been added for working with the Table Of Contents. You can use these when 

the Table Of Contents has keyboard focus. If these shortcuts don't seem to be working, click inside the Table Of 
Contents to make sure it has keyboard focus. 
 

- ENTER or F12 opens the currently selected entry's property dialog. 
 
- F2 renames the selected entry.  
 
- SPACE BAR turns drawing of the selected layer(s) on or off.  

-  SHIFT+F10 or Application key on Microsoft Natural Keyboard (or any other compatible keyboard) 
opens the context menu for the selected entry.  

 
- F11 activates the currently selected data frame. You can also hold down ALT when you click on a data 

frame's name to activate it.  
 
- Left/Right arrows or the +/- keys expand/contract the selected entry. 
 
- When the tabs at the bottom of the Table Of Contents have keyboard focus, Left/Right arrows switches 

between them 
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- F3 returns keyboard focus to the Table Of Contents from the map. This enables you to continue working in 
the Table Of Contents with the keyboard if an operation you performed put the keyboard focus onto the 
map. Clicking in the Table Of Contents also gives it keyboard focus. (We also provide a new command - 
Focus Table Of Contents - that can be put into a pulldown menu or toolbar to return keyboard focus to the 
Table Of Contents. You can add this into your ArcMap user interface in the normal way, through the 
Tools>Customize dialog. It is in the View category) 

 
- ESC returns keyboard focus to the map from the Table Of Contents. Clicking on the map also gives it 

keyboard focus. 
 
- SHIFT+F1 displays a help topic describing these shortcuts. 
 
 
It is now easier to expand/collapse multiple entries in the Table Of Contents. Hold down CTRL when you 

click on the expansion control next to a data frame or a layer to expand/collapse all of the entries at that level in 
the Table Of Contents hierarchy.  For example, if you hold down CTRL and click the expansion control next to a 
data frame, all the data frames listed in the Table Of Contents will be expanded or collapsed. If any of the 
entries are selected, and you CTRL+Click the expansion control next to a selected entry, only the selected 
entries will be expanded/collapsed.  
 

When you are dragging layers over the Table Of Contents, you can now expand and collapse any entry by 
hovering over its expansion control with the 'drop' cursor.  
 

There is now better Undo/Redo support for actions performed in the Table Of Contents. 
 

The Table Of Contents has been enhanced so that it doesn't flicker or redraw as much as it does in 8.x. 
 
 
Map documents 
 

The File>Page Setup and File>Print dialogs have been completely redesigned to clarify and streamline the 
process of setting up a map for printing. The Page Setup dialog and command has been renamed to Page And 
Print Setup to reflect the new design.  
 

The first time you open or save a file after making a new installation of ArcMap on Windows XP or Windows 
2000, the Windows file browser dialog that appears now defaults to looking into the 'My Documents' folder.  
 

 Two new commands have been added into the Layout toolbar: 
 

 
 
Toggle Draft Mode  - Toggles all the map elements such as data frames, legends, pictures, etc in your map 
between normal drawing mode and draft mode. In ArcMap 8.x draft mode was called 'fast drawing' mode and 
the only way to enable it was to check a box in Frame tab of the map element's Properties dialog. You can still 
do that, but this new command makes it easy to put all the frames into draft mode at once. In draft mode, the 
contents of the elements are not drawn. Instead, their frames are shown as light blue boxes labeled with the 
name of the element. Using draft mode makes it quicker to layout your map because you don't have to wait 
while the contents of frames, especially data frames, are drawn.   
 
Focus Data Frame  - Puts the active data frame into focus, making it the target for graphics and text you 
draw on top of it while you are in Layout view. The ability to put a data frame into focus has always been 
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available in ArcMap (by double-clicking a data frame in the layout). We've added this command to make it more 
obvious that this ability exists. Lets you work with graphics and text drawn on a data frame as though you were 
in Data view, while remaining in Layout view. The Focus Data Frame command is also available in the context 
menu that appears when you right-click a data frame on the page layout. When a data frame is in focus, a thick 
line will appear around it, compared to the thin dashed line you see around the active data frame: 
 
 Inactive Active In Focus 

 
The Focus Data Frame button remains depressed while the data frame is in focus. This provides an additional 
indication that the data frame is in focus which is useful in the situation where you are zoomed in on your layout 
and therefore can't see the edge of the data frame.  
 
To take a data frame out of focus, either click on the layout outside the data frame, or click the Focus Data 
Frame button again. 
 

 The Legend Wizard now defaults to include just those layers that are currently turned on in your data frame. 
We've also added a Remove All button (<<) to the wizard and the property dialog.  
 

 When you create a new map document, the 'Save thumbnail image with map' setting in the File > Map 
Properties dialog no longer defaults to being on. It is now off by default for new maps you create. This avoids 
the performance overhead of having to wait for the thumbnail to be regenerated whenever you save a map. If 
you want your map document to be saved with a thumbnail, turn this setting on. This setting is stored in the 
current map document, and this change has no affect on maps you have already created in 8.x: your existing 
maps will use the setting for this option that was current when you last saved the map. To prevent your existing 
maps from saving thumbnails, open each map and uncheck this option in the Map Properties dialog.  
 

 A new command called Pause Drawing  has been added into the Pan/Zoom category in the Tools > 
Customize dialog. This lets you temporarily suspend all drawing in ArcMap. You can add this command into any 
ArcMap pulldown menu or toolbar or you can use the Keyboard button in the Tools > Customize dialog to assign 
a keyboard shortcut to it. While drawing is suspended, you can continue to work with the program, but the 
display is not redrawn. This is useful if you want to make a number of changes to your map, for example, 
changing the symbology for a number of layers, without having the map redraw. Once you have made your 
changes, you can then choose this command again to turn drawing back on. This command works in both Data 
view and Layout view.   
 

 The contents of the View > Toolbar pullright are now sorted alphabetically to make it easier to find toolbars. 
The exception is the Main menu bar, which is always shown at the top of the list. 
 

In the Tools > Options dialog's Layout view tab, a check box option called 'Show dashed line around active 
data frame' has been added that lets you control whether the indication will be drawn showing you which data 
frame is currently active when your map contains more than one data frame. By default, when your layout 
contains more than one data frame, one of the data frames is shown with a dashed line around it to indicate that 
it is the active data frame: 
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The active data frame is the one to which commands that you use such as Add Data, Full Extent, Select By 
Attributes, Zoom To Selected Features, etc. will be applied when you are working in Layout view.  
This active data frame indication is not part of your map layout and does not appear on your map when you print 
it out. However, you may sometimes want to hide this indication, for example, if you want to view your map 
exactly as it will appear when printed. If you turn off the active data frame indication you can still see which data 
frame is active by looking in the Table Of Contents: the active data frame's name is always shown in bold. 
 

In the Tools > Options dialog, the Application tab has been renamed to the General tab and the tab called 
TOC has been renamed to Table Of Contents. This dialog also now remembers the last tab you were using 
instead of defaulting to either the Data view tab or the Layout view tab. 
 

 Your choice of which tabs appear in the Table Of Contents is no longer stored in the map document. Your 
choice of tabs and their order (which is set in the Tools > Options dialog) is still specified in the Tools > Options 
dialog but your choice is now stored at the application level and does not vary based on which map document 
you are using. 
 

The File>Export Map dialog has been improved to add an expandable Options panel. This makes it  much 
easier to browse and set the options for a particular output format.  Several new graphic export options and 
formats have been added, as well as an overall improvement of all the graphic exports. 
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New raster map export formats: 
 
- PNG 
- GIF (license may be required by user) 
 
When you export a map to a raster format, you can now: 
 
- See the exact size in pixels of the image you about to export 
- Write out a world file for any raster format 
-  Pick from various compression choices and color depths for all raster formats 
-  Specify transparent color for PNG and GIF formats 
- Specify 1-bit mask or threshold export 
 
Output image size is no longer limited for raster formats. 
 
New vector map export format: 
 
- SVG (compressed and non compressed forms) 
 
Layering is now retained in AI, PDF and SVG export so that graphical objects are conveniently grouped and 
named.  
 
Also font mapping is no longer required because read the information from the font file. Fonts are converted to 
appropriate format for embedding into exported file when it required. 
 
In ArcMap 8.x font embedding worked in a simple way: either the characters outlines (also known as Type3 
fonts) were embedded or we exported a polygon representation of the text string. In 9.0 we now embed fonts 
directly as Type1, Type42, TrueType or Type2CFF, depending on the source fonts and the requirements of the 
destination file format. 
 
CGM format was removed from ArcMap's Export Map functionality since problems associated with this format 
prevented any improvement and we received very little user demand for continuing to have this export format in 
ArcMap. 
 

Draw toolbar: Three new commands have been added into the Distribute pullright in the Drawing pulldown 
menu: Fit To Margins, Fit Width To Margins, and Fit Height To Margins. These commands work in Layout view 
and let you automatically size the currently selected map elements or graphics to fit them to the margins of your 
map layout. The commands use the printer margins if the 'Use Printer Paper Settings' is checked for the Map 
Page Size in the File>Page and Print Setup dialog. Otherwise they use the edge of the page. 
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Data frames 
 

 Data Frame Properties dialog: the Labels tab has been removed. Its functionality is now provided by the 
Label Manager dialog, along with separate Label Priority Ranking and Label Weight Ranking dialogs. You can 
access these dialogs via the new Labeling pullright in the context menu for a data frame.  
 

 
 
or via the new Labeling toolbar: 
 

 
 

 In 8.3, the edit cache can be used to improve the performance of editing, drawing and selection of 
geodatabase features during an edit session, especially those stored in an ArcSDE geodatabase. In 9.0, the edit 
cache has been renamed to the map cache and moved into the core ArcMap user interface because it now 
operates on geodatabase features either inside or outside an edit session. The map cache has no impact on the 
performance of other data types.  
 
In an enterprise environment, using the map cache can significantly improve the overall performance of the 
ArcGIS system by reducing the number of queries to the geodatabase, the number of features retrieved from 
the geodatabase, and the overall network traffic. Since retrieving features from the computer's memory is a fast 
operation, using the map cache will often result in performance improvements in ArcMap for editing, feature 
rendering, and labeling. 
 
- The new Map Cache toolbar (in 8.3 this toolbar was called the Edit Cache toolbar) lets you build and manage 

the map cache: 
 

  
 

A new command called Empty Map Cache  has been added into the toolbar. When you empty the map 
cache, features will be retrieved directly from the geodatabase instead of the memory on your machine. 
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- There is also a new Map Cache tab in the Data Frame Properties dialog: 
 

 
 
On the new Map Cache tab and toolbar we've clarified the terminology from what was used in the Edit Cache 
tab in the Editor Options dialog in ArcGIS 8.x so that they now talk about setting the minimum scale for auto-
cache, with the cache being automatically created except when the map is zoomed out beyond the minimum 
scale. 
 
 Data Frame Properties dialog Data Frame tab: if you use the fixed extent option for a data frame you now 

have the choice to specify the coordinates of the extent in degrees instead of map units. An Advanced button 
has been added next to the coordinates that gives you additional options for specifying the fixed extent 
coordinates.  
 

 Data Frame Properties dialog Extent Rectangles tab: Extent rectangles now default to having a red frame.  
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 The three reference scale commands in the context menu for a data frame have been moved into a pullright 
called Reference Scale to help make this context menu shorter: 
 

 
 

You can now drag/drop data frames up and down in the Table Of Contents. Hold down CTRL when you drop 
the data frame(s) to copy rather than move. Moving data frames in the Table Of Contents simply lets you 
change the order in which they are listed and no longer has an effect on the order in which they are drawn on 
the map. This fixes the issue in 8.x where new data frames you added at the bottom of the Table Of Contents 
unexpectedly appeared at the top of the Table Of Contents the next time you opened the map. You can still 
control the drawing order of data frames on the page by using the Bring To Front/Send To Back commands in 
the Drawing pulldown menu when you are in Layout view. 
 

The Copy command in the data frame's context menu in the Table Of Contents is no longer disabled when 
you are in Data view.  
 

When multiple data frames are selected in the Table Of Contents, you can now right-click one of them to 
access a menu that lets you perform operations like copy, remove, and turn all layers on/off, on all of the 
selected data frames at once: 
 

 
 

You can now drag/drop and copy/paste data frames between ArcMap sessions (i.e. between different map 
documents). Drag/drop between ArcMap sessions copies the entries being dropped. Hold down CTRL when 
you drop if you want to move rather than copy. 
 

Two new keyboard shortcuts speed up activating data frames from the Table Of Contents: 
 

- F11 activates the currently selected data frame. You can also hold down ALT and click on a data frame's 
name to activate it. 

 
In 8.x, if you right-click an inactive data frame in the Table Of Contents and choose certain commands such 

as Properties, Copy and Advanced Drawing Options, they operate on the active data frame instead. This has 
been fixed in 9.0.  
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In 8.x, if you copy/paste a data frame while you are in Data view, it gets pasted into the map as a graphic. 
This has now been fixed so that when you paste a data frame it always gets pasted into the map as a data 
frame, irrespective of which view you are in. 
 

Data Frame Properties dialog Annotation Groups tab: The buttons to the right of the annotation groups list 
have been standardized, to add Select All and Clear All buttons. You can also use the keyboard shortcut for 
selecting and clearing all the entries in a checkable list: CTRL + click on any check box in the list. You can now 
also double-click a grid in the list to see its properties. 
 

 
 

Data Frame Properties dialog Data Frame tab, under Extent options we have added an Advanced button to 
access additional options for setting a fixed extent. 
 

 
 
Pressing Advanced displays this dialog: 
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You can set your data frame extent to the extent of all, visible, or selected features in a layer, to the extent of 
graphics inside the data frame, or to a custom extent specified in display units or in decimal degrees. This gives 
you greater flexibility over determining a map extent. For example, you could set the extent to fit a particular set 
of features and even if you change the map scale the features would still fit the frame. Or you could draw a 
rectangle graphic that fits your data view, set the fixed extent to use the graphic and then both the data view and 
the layout view would show the same extent. These are just a couple of examples of the flexibility the advanced 
options can provide. 
 
These options are the same as the options for data frame clipping, but work slightly differently in that for setting 
the extent the minimum bounding rectangle of the chosen option is used. 
 
Another advantage of the advanced options is you could set the display units to a different unit from your map 
units and then set the fixed extent by the display units. For example, meters is very commonly used as map 
units, but you might find it easier to set your extent in kilometers or miles. 
 
 
Layers 
 

Layer Properties dialog Source tab: the Source details information now includes the actual name of the 
coordinate system in which the layer's data is stored, and the linear units, if known: 
 
8.3: 
 Projection: Transverse_Mercator  
 False_Easting: 500000.00000000 
 False_Northing: 0.00000000 
 Central_Meridian: -111.00000000 
 Scale_Factor: 0.99960000 
 Latitude_Of_Origin: 0.00000000 
 
9.0: (new items shown in bold): 
 
 Projected Coordinate System: NAD_1927_UTM_Zone_12N 
 Projection: Transverse_Mercator 
 False_Easting: 500000.00000000 
 False_Northing: 0.00000000 
 Central_Meridian: -111.00000000 
 Scale_Factor: 0.99960000 
 Latitude_Of_Origin: 0.00000000 
 Linear Unit: Meter (1.000000) 
 

You can now copy/paste and drag/drop multiple layers in the Table Of Contents. 
 

New commands have been added into the context menu for a data frame to make it easier and faster to work 
with layers.  
 

- Turn All Layers On/Turn All Layers Off: checks or unchecks all the layers in the data frame. This option was 
in 8.x but only as a keyboard shortcut (hold down CTRL and click any check box).  

 
- Select All Layers: selects all the layers in the data frame. This makes it easy to quickly select all the layers 

and then perform an operation on them, such as right-clicking and choosing Remove to remove all the 
layers. 

 
- Expand All Layers/Collapse All Layers: shows or hides the legends for all the layers in the data frame. 

(We've also added a keyboard shortcut for this action: to expand/collapse all the layers in a data frame, hold 
down CTRL and click the expansion box next to any of the layers). 
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When you drag/drop layer(s) inside the same data frame, you can now hold down CTRL when you drop the 
layers if you want to copy the layer(s) instead of moving them. This makes it easy to quickly duplicate layers.  
 

Drag/drop of layer(s) between different data frames in the same map now copies the layers instead of moving 
them. This makes it easier to duplicate layers, such as layers providing backgrounds, between data frames and 
then modify them. Hold down CTRL when you drop the layer(s) if you want to move them instead.  
 

Layers can now be dragged and dropped between different ArcMap sessions (i.e. between different map 
documents). Drag/drop between ArcMap sessions copies the entries being dropped. Hold down CTRL when 
you drop if you want to move the layer(s) rather than copy.  
 

When multiple layers are selected in the Table Of Contents: 
 

- you can turn them all on or off with one click: Hold down CTRL and then click on the check box next to any 
of the selected layers. If one or no layers are selected, holding down CTRL and clicking any check box will 
turn all the layers on or off, the same as it does in 8.x.  

 
- you can expand or collapse them all with one click: Hold down CTRL and then click on the expansion box 

(the + or - box) next to any of selected layers. If one or no layers are selected, holding down CTRL and 
clicking any expansion box will expand or collapse all the layers. 

 
When you add layers they are now automatically selected in the Table Of Contents so you can see where 

they are positioned. In the example below, geo_zipcode point and geo_states polygon have just been added to 
the map. This also enables you to immediately perform operations on the newly added layers without having to 
reselect them. For example, you can right-click any one of the selected layers and choose any command, such 
as Remove, Group, Zoom To Layers, etc, or hold down CTRL and click the expansion control next to any of the 
layers to expand or collapse them all.  
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In 8.x the context menu that appears when you right-click a group layer is the same as the one that appears 
when you select multiple layers and right-click. At 9.0 these are now two separate context menus.  
 

New commands have been added into the context menu you get if you select two or more layers and right-
click: 
 

- Turn On/Turn Off: checks or unchecks all the selected layers.  
 
-  Zoom To Layers: zooms the geographic extent encompassing the extents of all the selected layers.  
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Layer Properties dialog Fields tab: The user interface for specifying the field properties of a layer or a table 
has been improved to make it faster and easier: 
 

 
 
To hide or show fields, click their check box. Press Select All or Clear All to hide or show all the fields.  
 
To specify an alias for a field, type into the Alias column.  
 
To set the number format for a numeric field, click the button in the Number Format column. 
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Layer Properties dialog General tab: A description field has been added to the General tab for all layer types. 
This enables you to store comment or description text as a layer property. This has been implemented for most 
layer types, but not all. 
 

 
 

Layer Properties dialog General tab: When you use the 'Don't show layer when zoomed' option, the scale 
values you enter no longer disappear if you change your mind and use the 'Show layer at all scales' option. This 
lets you, for example, temporarily turn off scale-dependent drawing for a layer and then turn it back on later 
without having to re-type the scale values you originally entered. This has been implemented for most layer 
types, but not all. 
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Layer Properties dialog Labels tab has several enhancements. 
 
- Controls have been added into the Labels tab to let you quickly specify the font, size, color, etc of the text 

symbol. In 8.3 you had to press the Symbol button to specify these: 
 

  
 
-  When a layer is getting its labels from an expression instead of a single label field, you'll now see the text 

<expression> in the label field. This makes it clearer that an expression is being used: 
 

  
 

At 9.0, symbol level advanced drawing functionality has been improved and symbol level properties can now 
be defined at the layer and group layer level, rather than at the data frame level as in 8.3. In this way, these 
properties get saved with the layers when you create layer files, etc. Symbol level drawing enables you to take 
advantage of ArcMap's ability to 'join and merge' multi-layered symbols, such as those used for cased road and 
street symbology. You can now define symbol levels via commands added into the Advanced menu buttons on 
the Layer Properties dialog Symbology tab for feature layers. You can also now turn symbol level drawing on 
and off for a layer by using the new Use Symbol Levels command that has been added into the context menu 
for a feature layer. See the Symbology section in this document for more information about what's new in 
symbol level drawing. 
 

The size and shape of layer properties dialogs has been standardized so that they are all now roughly the 
same. This change is most noticeable with the group layer properties dialog and the ArcIMS image service layer 
properties dialog, which now are now sized and shaped more like the standard feature layer properties dialog. 
The property dialog for some layer types may still be larger than usual because one or more of their tabs need 
to be larger in order to accommodate all their controls.  
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Group layers 
 

It is now easy to create group layers that contain other group layers. This was possible in 8.x but required 
that you use layer files to do it. There are several ways now to create nested group layers: 
 

-  You can now drag/drop any group layer into any other group layer.  
 
-  You can now select any layers in the Table Of Contents, including group layers, right-click and choose 

Group. The Group command is now always enabled, regardless of what type of layers you selected. You 
can also select layers that are already in a group layer, right-click, and then choose Group to create a 
nested group layer.  

 
-  You can now right-click a group layer, choose New Group Layer, and then drag layers into the new, empty 

group layer that is created. 
 

We've added Add Data, New Group Layer, Paste Layer(s), and Ungroup commands into the group layer 
context menu, so it is much easier to rapidly assemble group layers and break them apart.  
 

 
 

When you drag layers to the end of an expanded group layer, you can choose whether the layers get 
dropped into the group layer or after the group layer.  
 
Normally, when you are dragging layers over the Table Of Contents, the insertion bar looks like this: 
 

 
When the insertion bar is at the end of a group layer, you'll see a small indicator drawn at the left end of the bar: 
 

 
This indicates that you have a choice about where the layers you are dragging are dropped: They can either be 
dropped into the group layer or after the group layer. When you see the indicator on the insertion bar, you can 
move the cursor either left or right to make your choice. The insertion bar will extend to the left as you drag the 
cursor to the left, and the indicator at the end of the bar shows you where the layers will be dropped in the 
hierarchy.  
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 In the Group Layer Properties dialog's Group tab you can now double-click any layer in the list to access its 

properties.  
 

At 9.0, symbol level advanced drawing functionality has been improved and symbol level properties can now 
be defined at the layer and group layer level, rather than at the data frame level as in 8.3. In this way, these 
properties get saved with the layers when you create layer files, etc. You can now define symbol levels for a 
group layer via the new Symbol Levels button that has been added into the Groups tab in the Group Layer 
Properties dialog. Any of the feature layers in the group layer can participate in the symbol level drawing, 
including those in nested group layers inside the group layer. See the Symbology section in this document for 
more information about what's new in symbol level drawing. 
 

You can now drag layers into a new, empty group layer. When you drag layers underneath an empty group 
layer, you can choose whether the layers get dropped after the group layer or into the group layer. When you 
see the insertion bar underneath the new group layer, you can move the cursor either left or right to make the 
choice.  
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Selection 
 

The Selection tab now appears in the ArcMap Table Of Contents by default. In ArcMap 8.x this tab was 
turned off by default. This tab lists all the feature layers in your active data frame and lets you choose which of 
these layers will be 'selectable' when you use the interactive selection tools. The Selection tab is more 
convenient than using the Set Selectable Layers dialog accessed from the Selection pulldown menu. In addition, 
layers are listed in bold in this tab if they currently have a selection set, and the number of features in this set is 
also shown. Using this tab can help you understand the change to the selection logic at 9.0 (see below).  
 
Tip: In the Selection tab, hold down CTRL and click on any check box to make all the layers selectable or not 
selectable. For more help on using the Selection tab, click inside the tab to give it 'keyboard focus' and then 
press F1 or SHIFT+F1. 
 
Remember that you can choose which tabs appear in the Table Of Contents and the order in which they appear, 
by going to the Tools>Options dialog and looking in the Table Of Contents tab in that dialog. In 9.0, your choice 
of tabs in the Table Of Contents is saved for the application (in the Windows registry) instead of being stored in 
the map document you are currently working on like it was in 8.x. In this way, your choice of tabs will always be 
the same in ArcMap irrespective of which map document you are working with.  
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The feature selection logic in ArcMap has changed at 9.0 to differentiate between the state in which a layer 
currently has 0 features selected, and the state in which a layer currently has no set of selected features.  
 
In ArcMap 8.x, these two states were not differentiated: a layer which had 0 features currently selected was not 
considered to have a set of selected features. The new geoprocessing framework at 9.0 makes this 
differentiation. Within a geoprocessing model or script, there's an important difference between steps that result 
in 0 features being selected versus there being no set of selected features. This determines whether 0 features 
or all features will be used in the next step. We have therefore updated ArcMap so that the selection logic is 
consistent with the geoprocessing framework. Performing a selection on a layer now always results in a 
selection set, even if that set contains 0 features.  
 
For example, suppose you use the Select By Attribute dialog and specify an expression which results in 0 
features in a layer being selected: 
 
-  In 8.x, the layer had no selection set and all the layer's features were available for the next geoprocessing 

operation you performed.  
 
-  In 9.0. there will be a selection set containing 0 features, and the next geoprocessing operation you 

perform will operate on 0 features, unless you first clear the selected set. So if you select wells with particular 
attributes and then buffer the wells that are selected, no wells be buffered if no wells meet your selection 
criteria, which is what you’d expect. In geoprocessing at 9.0, operations you perform on layers inside ArcMap 
always operate on the currently selected set of features, unless no selection has been performed, in which 
case they operate on all the features in the layer. 

 
A good way to understand this change is to look in the Selection tab in ArcMap's Table Of Contents:  
 
- In 8.x, layers listed in the Selection tab turned bold and showed you their number of selected features when 

they had 1 or more features selected. 
 
- In 9.0, layers listed in the Selection tab turn bold and show you their number of selected features when they 

have a selection set, that is, when they have 0 or more features selected.  
 
If a layer has a selection set and you want a geoprocessing operation to use all the features in that layer, simply 
clear the selected set of features first. Like in 8.x, there are two ways to clear the selected set of features: 
 
-  Use the Clear Selected Features command . Choose this command from the Selection pulldown menu and 

it will clear the selection sets for all layers. Choose this command by right-clicking a layer in the Table Of 
Contents to just clear the selection set for that layer.  

 
- Click on the map (or drag a box) with the Select Features tool  without selecting a feature. This will clear the 

selection sets for all layers. In other words, if you click on the map to deselect the currently selected 
feature(s), this clears the selected features. In ArcMap the Edit tool  works this way too.  

 
Note: If a layer currently has all of its features selected, and you choose Switch Selection, this does not clear the 
selected set. The layer will still have a selected set, but the number of features in it will be 0. 
 
Note: This change to the feature selection logic also applies to the 3D Analyst extension's ArcScene and 
ArcGlobe applications. 
 

A check box has been added into the Selection>Select By Attributes and Selection>Select By Location 
dialogs that enables you to restrict the list of layers from which you choose to select features to layers which are 
currently set as selectable. When this box is checked, the list will only contain layers that are currently set as 
selectable. You can set layers as selectable using the Selection tab in the Table Of Contents or by choosing the 
Set Selectable Layers command from the Selection pulldown menu. 
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By default, all the feature layers in a data frame are selectable, so checking this new check box has no effect on 
the length of the list of layers if you have not yet turned off some of the layers in the Set Selectable Layers 
dialog or Selection tab for this data frame. 
 

Selection>Select By Attributes: The Unique Values list is no longer populated automatically when you select 
a field in the Fields list (or in the Query Wizard accessed from the Select By Attributes dialog). This was done to 
improve performance, especially when working with large datasets, and because in most cases the list was only 
partially populated when the datasets contained more than a few hundred features. In 9.0 when you select a 
field from the Fields list, the Unique Values list remains empty until you press the Get Unique Values button. In 
this way you can choose whether or not you want to wait for a list of unique values to be obtained:  
 

 
 
A progress dialog will appear when you press Get Unique Values if the process needs more than a few seconds 
to complete. When the Unique Values list is fully populated, the Get Unique Values button will become disabled 
to indicate that the list is complete: 
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If you cancel the process before it is finished, you'll see a partial list of unique values, and the Get Unique 
Values button will remain enabled to indicate that the list is incomplete. 
 

Selection>Select By Attributes dialog: a control has been added underneath the Unique Values list that 
enables you to rapidly move through this list. Enter the first letter or number of the value, with or without quotes. 
As soon as you start typing ArcMap will try to go to the first value in the list matching what you typed in. 
 

Selection>Select By Attributes dialog: If you are working with a field that supports null values, it is now easy 
to build a query to select records that have or do not have null values. Null values are supported by fields in 
geodatabases and date fields in shapefiles/dBASE tables and coverages/INFO tables. When you select one of 
these fields in the Query Builder, you'll now see a NULL entry at the top of the Unique Values list if there is a null 
value in the values displayed by that list. If there are no null values in the list, you won't see a NULL entry at the 
top. You can double-click the NULL entry to add it into your query like any other value and use the IS operator to 
select null values. As you can see from the graphic above, we've added a button for the IS operator into the 
Query Builder. This query selects all the null values for a field in a geodatabase: 
    [POP1991] IS NULL 

and this query selects all the values in the same field that are not null:  
    [POP1991] IS NOT NULL 

 
Selection>Select By Attributes: The dialog now automatically determines the correct format for querying date 

fields based on the type of data you are querying. The format for date queries varies according to the data type. 
In 8.3 you always had to compose expressions for querying date fields manually. In 9.0 you will most of the time 
only need to click the date field, the operator, and then a value in the Unique Values list, to have the proper 
syntax generated automatically. For more information about date fields, look up the 'SQL reference' in the 
Desktop Help index, and in that help topic click on the 'Date' link 
 

Selection>Select By Attributes dialog: The SQL Info button has been removed from the dialog.  
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We've improved the Desktop Help for creating SQL queries. There's a new SQL reference topic containing 
an expandable list of SQL operators and functions. Choose ArcGIS Desktop Help from the Help pulldown menu 
in any of the Desktop applications and in the Desktop Help Index, look for 'SQL reference'.  
 
Note: most of the changes to the Selection>Select By Attributes dialog described in this section also apply to 
most other instances of the Query Builder dialog that you find throughout ArcGIS. 
 
 
Tables 
 

The Field Calculator dialog has been made larger to accommodate a longer and wider fields list. We've also 
added a Help button which includes some commonly used examples to calculate fields based on area, length 
and perimeter, etc: 
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You can now suppress the message that appears when you attempt to calculate field values outside of an 
edit session. To suppress the message, choose the Options command from the Tools pulldown menu in any 
Desktop application and uncheck the 'Show warning when calculating field values outside edit session box'. 
 

 
 

New automatic indexing option for join: When you perform a join and the join table you are joining to the 
target is a file-based table or a table in a personal geodatabase, ArcGIS will check to see if the join field you 
choose in this join table is indexed. If it is not indexed, you'll see the following message prompting if you'd like to 
have ArcGIS automatically index the join field: 
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When you perform a join and the join table you are joining to the target is in an ArcSDE geodatabase, ArcGIS 
will check to see if the join field you choose in this join table is indexed. If it is not indexed, it will display the 
following message advising you of this. Automatic indexing is not supported for ArcSDE geodatabases, but you 
or your database administrator could index the field manually in the database or in ArcCatalog to improve 
performance: 
 

 
 
We've added controls into the Tools > Options dialog Table tab that allow you to control whether automatic 
indexing occurs, and to suppress the ArcSDE warning message. 
 

The Open Table For Selected Features command that was available via the Tools>Customize dialog in 8.x 
has been removed. This command no longer worked correctly. The ability to choose what mode the table 
window uses when it opens is planned for a future release.  
 

The attribute tables of geodatabase feature classes and standalone tables in geodatabases can now contain 
fields of raster type. A raster type field can contain any supported image or raster file, such as a photo of a 
feature. You can view the content of raster fields in Table window, in the Identify Results window when you 
identify a feature, and in the Attribute Inspector window launched from the Editing toolbar.  
 
In the Table window, records for raster fields that contain pictures are shown with the value 'Raster'. A record 
with an empty value for a raster field indicates that a raster has not yet been loaded into the field for that record. 
Click a value in a raster field to make a small '>' button appear next to it, then click that button to view the picture 
in a popup window: 
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Right-click inside the picture popup or the value in the table to see a menu of additional options: 
 

 
 
The Load and Clear options in the menu are only enabled if you are currently editing the layer that contains the 
raster field. 
 
Choose the View command (or just left-click in the pop-up window) to view the raster in a floating resizable 
window: 
 

 
 
For more about raster fields, see the Raster data section of this document. 
 
 
Identify tool 
 

In response to customer suggestions, we've changed ArcMap's Identify tool so that when you select the tool 
in the Tools toolbar, the Identify Results window immediately appears. This enables you to select which layer(s) 
you want to identify from before you click on the map to identify a feature. This makes Identify more convenient 
if you don't want to simply use the default <Top Most Layer> setting. It also enables you to position the window 
conveniently on-screen so that it doesn't cover up the area you are looking at on the map. (The Identify tool in 
ArcCatalog doesn't open the window when it is selected because you normally only work with one layer in 
ArcCatalog's Preview window. At 9.0, the Identify tool in the 3D Analyst applications ArcScene and ArcGlobe 
also doesn't open the window when it is selected). 
 

We've removed the View>Identify Results command. Now that the Identify window automatically opens as 
soon as you select the Identify tool, there's no need for the separate command that enabled you to open the 
window before using the tool.  
 

In the Identify Results window, <Top Most Layer> is still the default option in the Layers dropdown. At 9.0 we 
have moved this option to the top of the list to make it more obvious that it is the default.  
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Identify Results window in ArcMap and all desktop applications: In the Identify Results window you can now 

click on field values for fields containing strings which are full URLs or full pathnames to documents to launch 
the URL or document that they point to. When you identified a feature, hover over the value for any field shown 
in the Identify Results window that contains a URL or pathname. The cursor will change to the 'hand' pointer to 
indicate that the value is 'hot'. (If the application cannot resolve the path to a document, the cursor won't change, 
and you'll get a 'file not found' message if you click on the value).  
 
URLs included as values must start with either http:// or https://. Paths must start with a disk drive or be a full 
UNC pathname. That's how the Identify window recognizes these values as being links. 
 
This enables you to include launch URLs and documents from fields in the Identify window without defining a 
hyperlink field in the layer's properties. You can have as many fields as you like containing URLs or pathnames 
to documents, and you can mix URLs and pathnames in the same field. The logic for recognizing these clickable 
URLs/paths is built into the Identify window and there's no layer or document properties to set. These links will 
work in any of the ArcGIS Desktop applications that have an Identify tool, even if those applications don't 
support field-based hyperlinks (i.e. ArcCatalog and ArcScene). They are also supported in ArcReader 9.0's 
Identify window if you publish your map document to a published map (.pmf) file using the ArcGIS Publisher 
extension. As these links are defined purely in the attribute table and don't require any accompanying layer file 
or map document, they are especially convenient: anyone who accesses the data will immediately be able to 
use the links via the Identify window of any ArcGIS Desktop application.  
 
Note: These new links accessed via the Identify window will not support the hyperlink base property in the File > 
Map Properties dialog: they have to be complete URLs or paths. This is for robustness and because not all 
ArcGIS Desktop applications support the hyperlink base property. The values of a field-based hyperlink (i.e. a 
hyperlink specified in the Layer Properties dialog Display tab and normally accessed using the Hyperlink tool) 
will only be clickable in the Identify window if they contain complete URLs or paths: they are not supported in the 
Identify window if they use the hyperlink base property. 
 

At 9.0 the attribute tables of geodatabase feature classes and standalone tables in geodatabases can now 
contain fields of raster type. A raster type field can contain any supported image or raster file, such as a photo 
of a feature. When you identify a feature containing a raster field, you'll see a small '>' button next to the raster 
field if a picture exists for the record.  
 
Click that button to see the raster in a small popup window: 
 

 
 
Right-click in the popup window to see more options. Choose the View command (or just left-click in the pop-up 
window) to view the raster in a floating resizable window. 
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Symbology 
 

 The Advanced Drawing Options dialog has a new Masking tab that lets you specify that the features in one 
or more layers be masked by the features in one more polygon layers in your map. To specify masking, first 
check the box at the top of the tab. All of the polygon layers in your current data frame are listed on the left side 
of the tab. From this list, choose which polygon layer(s) you wish to use to perform masking. Then in the list on 
the right, check which layers you want to be masked by the chosen polygon layer(s). (As with all checkable lists 
in ArcMap, hold down CTRL and click any box in the list to toggle all the entries on or off). If the layer that you 
would like to mask is not in the list on the right, it does not support masking. Layers that don't support masking 
include annotation layers and the layers inside group layers. 
 

 
 

 In 9.0 how you work with symbol level drawing has changed. In 8.3, symbol level drawing is a property of 
the data frame. In 9.0 symbol level drawing is now a property of the layers for which it is defined. This means 
that the symbol level drawing specification for a layer is saved with the layer if you save it to disk as a layer (.lyr) 
file, and 'travels' with the layer when you copy/paste or drag/drop it inside the same map document or between 
two map documents. 
 
You can still define symbol level drawing that includes symbols from multiple layers. Symbol level drawing is 
also now a property of group layers. Put all the layers whose symbols you want to include in the symbol level 
drawing specification into a group layer, and then define the symbol level properties for this group layer. 
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- If you open a map created with ArcMap 8.x when you are in ArcMap 9.0, you can still use the 8.x data frame-

based symbol level drawing functionality via the Symbol Drawing tab in the Advanced Drawing Options dialog. 
To get to this dialog, you still right-click a data frame and choose the Advanced Drawing Options command. 
When you open this dialog you'll see a new button at the top of the Symbol Drawing tab that enables you to 
upgrade your map document to use the new layer-based symbol level drawing functionality. We recommend 
upgrading your map documents to use this new functionality. 

 
- If you create a new map in ArcMap 9.0, it will automatically use the new layer-based symbol level drawing 

functionality. If you look in the Advanced Drawing Options dialog, you will no longer see a Symbol Drawing 
tab. 

 
- To access the new Symbol Levels dialog for a feature layer, open the layer's Properties dialog, go the 

Symbology tab, and click the Advanced menu button, and choose the Symbol Levels command.  
 
 To access the new Symbol Levels dialog for a group layer, open the group layer's Properties dialog, go to the 

Group tab, and click the Symbol Levels button.  
 
 To turn symbol level drawing on and off for any layer or group layer, right-click the layer and choose the Use 

Symbol Levels command.  
 
 If any of these commands are disabled, you are using a map document that was created in 8.x in which the 

symbol level drawing functionality is still tied to the data frame. To enable the commands, right-click the data 
frame, choose Advanced Drawing Options, and in the Symbol Drawing tab in the dialog that appears, click the 
Upgrade button. 

 
 Tip: If you'll be using the Symbol Levels dialog frequently, there's a Set Symbol Levels command you can add 

into the context menu for feature layers and group layers that lets you launch that dialog without having to 
launch the layer's Properties dialog first. Go to Tools > Customize and look in the Layer category to find the 
Set Symbol Levels command. 

 
- The new Symbol Levels dialog looks like the old Symbol Drawing tab in the Advanced Drawing Options 

dialog. The new dialog is more compact, and you can move multiple symbol levels up at down at once using 
the Up/Down arrows or by drag/drop: 
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 In the dialog there is also a new Advanced View, which gives you more control over the drawing order of 

symbol levels. Advanced View breaks each symbol into its component layers, and you can enter numeric 
values to specify where each symbol layer will be positioned in the draw order. This position is referred to as 
its symbol level. More combinations are possible in the Advanced View than in the Default View: 

 

 
 

In the Symbol Property Editor dialog, we've improved and standardized the buttons for manipulating the 
preview and the list of symbol layers to make them better match the same buttons found elsewhere in ArcMap 
(see next point for screenshot). 
 

It is now much easier and quicker to choose fonts and glyphs when editing the properties of character marker 
symbols and north arrows. All the glyphs in the selected font and subset are listed in a scrolling list, and you can 
click on any glyph to see an enlargement. Here's what the character marker panel in the Symbol Property Editor 
for a marker symbol looks like now: 
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Elements 
 

A new command called Unselect All Elements  has been added into the Edit pulldown menu. This 
unselects all selected text elements and graphic elements if you are in Data view and all selected text elements, 
graphic elements and map elements if you are in Layout view. This command has the same effect as simply 
clicking any location on the map where there's no element. In some situations where you are zoomed in close 
on the map, there may be no such location you can click because one of the selected elements fills the ArcMap 
window. In those situations, this command lets you unselect all the elements without having to zoom out. 
 

 Zoom To Selected Elements command added into Draw toolbar: 
 

 
This command zooms to the currently selected graphics, text or map elements in both Data view and Layout 
view. It is disabled if none of those items is currently selected. It has also been added into the Edit pulldown 
menu. In this way, the Edit pulldown now contains a group of commands for working with the selected elements 
on your map. We also added a matching icon to the existing Select All Elements command : 
 

 
 

The New Annotation Target command in the Draw pulldown menu and the dialog it launches have been 
renamed to New Annotation Group because at 9.0 this command can no longer be used to create annotation 
feature classes in geodatabases. The dialog has also been enhanced so that you can now specify all the 
properties for the annotation group you create without having to visit the Annotation Groups tab in the Data 
Frame Properties dialog to set these. You can associate your new annotation group with a layer and also set a 
scale range at which the annotation group will be drawn: 
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As in 8.x, when an annotation group is associated with a layer it will be automatically turned on or off when the 
layer it is associated with is turned on or off. With the changes we have made at 9.0, it is now much easier to 
create an annotation group associated with a layer. Simply choose the New Annotation Group command, type in 
a name for your new annotation group, choose which layer you want to associate it with, press OK, and then 
start adding text and graphics elements to your map using any of tools on the Drawing toolbar. The elements 
you draw are automatically added into your new annotation group. You can choose a different annotation target 
using the Active Annotation Target command in the Draw menu. 
 

When you draw rectangles, polygons, and circles their area is now shown in the status bar along with other 
dimensions. When you draw a line the length is shown. If you are drawing the graphics in Data view (or on top 
of a focused data frame in Layout view) the dimensions are shown in the data frame's display units. If you are 
drawing them in Layout view, they are shown in the layout's page units. In addition, you can enter coordinates 
and dimensions using keyboard shortcuts as described below: 
 
Rectangle tool:  
- The area, height and width are shown as you draw the rectangle. 
- Press c on your keyboard to type in a coordinates of a corner point. This can be either the start point or the 

ending point of the rectangle. 
 
Polygon tool: 
- The area and perimeter are shown as you draw the polygon. 
- Press c on your keyboard to type in a coordinates of the next vertex.  
- Press e on your keyboard to type in the coordinates of the last vertex. Press e and then just press ENTER to 

use the current location as the last vertex. 
 
Circle tool: 
- The area, circumference and radius are shown as you draw the circle. 
- A line representing the radius appears inside the circle as you draw it. 
- Press c on your keyboard to type in the coordinates of either the start point (center point) or the end point of 

the radius. 
- Press a on your keyboard to type in the area of the circle after the start point has been specified. 
-  Press r on your keyboard to type in the radius of the circle after the start point has been specified. 
 
Line tool: 
- The total length is shown as you draw the line. 
- Press c on your keyboard to type in the coordinates of a vertex. 
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- Press e on your keyboard to type in the coordinates of the last vertex. Press e and then just press ENTER to 
use the current location as the last vertex. 

 
Edit Vertices tool 
- When you edit the vertices of a polygon, its area and perimeter are shown in the status bar.  
- When you edit the vertices of a line, its total length is shown in the status bar. 
 
In addition, if you right-click a rectangle, polygon or circle, and choose Properties, you'll see a new Area tab in 
its Properties dialog. This shows you the area and perimeter of the graphic, and the coordinates of its center 
point. You can choose what units the area and perimeter are displayed in on this tab by using the dropdown lists 
of units: 
 

 
 

Three new text drawing tools have been added into the Draw toolbar that let you draw a graphic element 
containing text formatted like a paragraph. The text flows within the graphic shape. The resulting element has 
text properties and graphics properties, and some new properties for setting columns and margins to control 
how the text is positioned inside the graphic. These new properties are presented in a tab called Columns And 
Margins tab you'll find in the Properties dialog for one of these new graphic elements. 
 

 New Polygon Text tool 
 

 New Rectangle Text tool 
 

 New Circle Text tool 
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To resize graphics created with these tools, select the graphic and use the handles to scale the graphic, or 
press the Edit Vertices command . 
 
These tools can be used to create graphic elements, annotation stored in the map document, and annotation 
stored in a geodatabase. These tools give the same dimension feedback in the ArcMap status bar, and have the 
same options for specifying their dimensions via the keyboard, that the Circle, Rectangle and Polygon tools 
have been given at 9.0.  
 

A command called Create Text From Graphic Elements  has been added into the Page Layout category in 
ArcMap's Tools > Customize dialog, from where you can add it into any menu or toolbar. This command creates 
a text element with the same geometry as the selected graphics element(s). The new element that is created 
from this command has the same properties, such as columns and margins, as a text element created with one 
of the three new text drawing tools      added into the Draw toolbar in 9.0. This new command is useful 
when you want to create text elements based on graphic elements that you have already drawn on your map. 
 

New curved leader lines: Two new curved leader lines are available for callouts. Select the Line Callout 
option when specifying the text symbol background for a text symbol drawn with the Callout tool to see these 
two new options: 

 
 

Editing  
 

 The edit cache has been renamed to map cache and moved into the core ArcMap user interface because it 
now operates either inside or outside an edit session. Defining a map cache improves performance when you 
draw, edit, or select geodatabase features, particularly those stored in an ArcSDE geodatabase. 
 
- The Edit Cache toolbar has been renamed to be the Map Cache toolbar and all the commands it contains 

have been renamed to reflect the new name. 
 
- A new command called Empty Map Cache  has been added into the toolbar. When you empty the map 

cache, features will be retrieved directly from the geodatabase instead of the memory on your machine. 
 
-  The Show Map Cache command  has been enhanced to indicate the status of the map cache. Like the 8.x 

edit cache, the map cache only takes effect when your current display extent (i.e. the geographic extent you 
are currently viewing) is completely within the extent of the map cache. When your current display extent is 
completely within the extent of the map cache, the Show Map Cache command now turns green to show you 
that the map cache will be used.  

 

  
  
 When your current display extent is not completely within the extent of the map cache, the Show Map Cache 

command now turns red to show you that the map cache will not be used.  
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 As in 8.x, the Show Map Cache command is disabled if your current display extent is entirely outside the 

extent of the map cache: 
 

  
 
- The Edit Cache tab in the Editor > Options dialog has been moved into the Data Frame Properties dialog and 

renamed to the Map Cache tab. 
 
See the Data Frames section above for more about map cache. 
 

We've added icons to the Start Editing, Stop Editing and Save Edits commands in the Editor pulldown menu 
in the Editor toolbar. This makes it easier if you want to customize ArcMap by moving these  
commands out of the pulldown menu and into the toolbar to make them more easily accessible: 
 

 
 

The Disconnected Editing toolbar is still in the user interface but it has been removed from the Editor > More 
Editing Tools pullright. 
 

There is a new user interface for editing annotation, including a new Annotation toolbar and a new look for 
the Attributes window launched from the Editor toolbar when you edit annotation. See the Annotation section of 
this document for more information. 
 
 
Internet data 
 

When you add a layer based on ArcIMS image service layer into your map, the layer's entry in the Table Of 
Contents is no longer expanded by default. ArcIMS image service layers often have a large number of sub-
layers. This enhancement avoids the issue where adding an ArcIMS image service layer into your map caused 
a huge entry to immediately appear in your Table Of Contents. Now once you've added the layer, you can click 
the + sign next to it if you want to expand it to see a listing of its sub-layers. 
 

Working with ArcIMS image service layers: We've solved the problem where ArcIMS image service layers did 
not show up as layers in the Source tab of the ArcMap Table Of Contents. In 8.3 their sub-layers appeared in 
the Source tab, but not the layers themselves. 
 

Working with ArcIMS image service layers: We've solved the problem where expanding or collapsing the sub-
layers in a layer based on an ArcIMS image service was not saved when you saved your map document or 
saved the layer as a layer file.  
 

Working with ArcIMS image service layers: When you expand an ArcIMS image service layer in ArcMap's 
Table Of Contents, you'll notice 'tree lines' between the layer and its sub-layers. These tree lines indicate that 
these sub-layers belong together and cannot be broken apart or used separately from the layer they belong to. 
These lines have been added at 9.0 to help differentiate these types of layers from group layers. 
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Working with ArcIMS image service layers: Two new commands, Expand All Sub-Layers and Collapse All 
Sub-Layers have been added into the context menu for ArcIMS image service layers to make it easier for you to 
manipulate the often large number of sub-layers that these layers can contain. The keyboard shortcut for these 
commands is to hold down CTRL and click the +/- control next to any of the sub-layers. To expand/contract the 
currently selected (highlighted) sub-layers, hold down CTRL & click +/- control next to any selected sub-layer.  
 

Working with ArcIMS image service layers: ArcIMS image services are defined on the ArcIMS server by the 
publisher either using the map renderer/AXL that is built into ArcIMS, or using the ArcMap Server extension to 
ArcIMS that was introduced at ArcIMS 4.0. These two different types of ArcIMS image services behave the 
same way when they are added as layers into ArcMap but there are a few minor differences. At 9.0, ArcMap 
now correctly reflects these differences in its user interface. For example, in the Layer Properties dialog Layers 
tab for an ArcIMS image service layer that is rendered by ArcMap Server, the controls for re-ordering the sub-
layers in the service are now disabled, because this type of ArcIMS image service does not support that.  
 
At 9.0 the Data Type information in the Layer Properties dialog Source tab for an ArcIMS image service layer 
now reflects whether or not the service is being rendered on the server using the ArcMap Server extension. If it 
is, the Data Type is listed as 'ArcIMS ArcMap Image Service' or 'ArcMap Image Service'. If it is not, the Data 
Type is listed as 'ArcIMS Image Service'.  
 

Working with ArcIMS image service layers: In the Layer Properties dialog Advanced tab for an ArcIMS image 
service layer, the transparency options are now correctly disabled if the service you are working with does not 
support transparency. The ArcIMS Administrator has the option to exclude certain image types from being 
created by their service.  When image types that support transparency (GIF and PNG) are excluded, the 
transparency options for the ArcIMS image service layer will be disabled.  If no image type has been excluded 
by the ArcIMS Administrator, then the transparency functionality will be enabled and ArcMap will request a PNG 
output.  
 

At 9.0, ArcGIS Desktop adds support for services being served using ArcGIS Server, which is a new server 
product in the ArcGIS 9.0 family purchased separately from ArcGIS Desktop. You can connect to an ArcGIS 
server either locally or via the Internet. See the ArcCatalog section of this document for more about how you 
connect to ArcGIS Servers. You can add map services from ArcGIS servers into your maps. When you add an 
ArcGIS map service into ArcMap, you'll see an ArcGIS map service layer appear in your Table Of Contents. It 
represents the contents of a map that is being served up from an ArcGIS server. If you have already worked 
with ArcIMS image service layers in ArcMap, this new layer type will seem quite familiar, because they are very 
similar: You can add them into ArcMap in the same way and they look and work very similar when they are in 
ArcMap. The main differences between how these layers work in ArcMap are: 
 
- You can't change the drawing order of the sub-layers in an ArcGIS map service layer. (You can change the 

drawing order of the sub-layers in an ArcIMS image service layer by using the Up/Down arrows in the Layer 
Properties dialog Layers tab). 

 
- You can't select the features in an ArcGIS map service layer using ArcMap's selection tools and commands. 

So for example, if you look in the Set Selectable Layers dialog or the Select By Attributes dialog, you won't 
see these sub-layers listed. You can use the Identify tool and the Find command to query the sub-layers 
inside an ArcGIS map service layer. 

 
- You can't open the attribute table for the data in an ArcGIS map service layer.  
 
- The sub-layers inside an ArcGIS map service layer may have been grouped into a hierarchy by the author of 

the service. (These groups simply reflect group layers in the map document used to create the map service). 
These groupings make it easier to work with ArcGIS map services that contain a large number of sub-layers. 

 
When you expand an ArcGIS map service layer in the Table Of Contents you'll immediately notice 'tree lines' 
linking together the sub-layers it contains. For example, here's an ArcGIS map service layer called 'Gas Network 
Map'. It contains a number of sub-layers, some of which are grouped under the heading 'Local loop':   
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This tree lines show you that, like the sub-layers inside an ArcIMS image services layer, the sub-layers inside an 
ArcGIS map service layer belong to that layer and can't be moved out of that layer.  
 
Like the sub-layers contained in an ArcIMS image service layer, the sub-layers contained an ArcGIS map 
service layer don't provide all the functionality that ordinary layers have. If you right-click one of these sub-
layers, you'll notice that the menu that appears only has a few commands. You can use the Identify tool and the 
Find command to query the sub-layers inside an ArcGIS map service layer. When you look in the Identify 
window or the Find dialog, you'll see these sub-layers listed in the usual way (if they represent data that can be 
queried in those dialogs).  
 
Why don't ArcGIS map services support attribute tables and feature selection? An ArcGIS map service is 
designed to be literally a map service. It is intended to enable you to access a map that someone has published 
and 'embed' it into your own map as a layer and perform basic Find and Identify queries. It's not designed to be 
a whole collection of feature classes that you can work with. At 9.0, there is currently no equivalent in ArcGIS 
Server to the ArcIMS feature service. In future releases of ArcGIS Server there will be new services that allow 
you to work directly with data that is being published on an ArcGIS Server. An organization using ArcGIS Server 
can decide exactly how they want to serve their data, either as a map service with very restricted data query 
capabilities, or as data services, which will enable end users to work with the data directly as data sources in 
ArcGIS. 
 
To emphasize the similarity between ArcIMS image service layers and ArcGIS map service layers, ArcCatalog 
uses the same icon for layer files created to store either type of layer: 
 

  Internet map service layer (based either on an ArcIMS image service or an ArcGIS map service) 
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Linear referencing 
 

The new geoprocessing framework introduced at 9.0 contains a set of tools for performing linear referencing. 
In the new ArcToolbox window, look in the 'Linear Referencing Tools' toolbox (available with ArcInfo license 
only). 
 
At 9.0, the ArcGIS 8x Route Events Geoprocessing Wizard  (available with ArcInfo license only) has been 
removed from the ArcMap Tools pulldown menu. You can still find this wizard in the Linear Referencing 
category in the Tools > Customize dialog. If you still wish to use this wizard, you can add it into any ArcMap 
toolbar or pulldown menu from that dialog. Note: No development has been carried out on this wizard since 8.3, 
and no further development is planned. 
 
Here is where to look to find the operations performed by this wizard in the ArcToolbox window at 9x: 
 

Intersect: 
 'Linear Referencing Tools' toolbox>Overlay Route Events 
Union: 
 'Linear Referencing Tools' toolbox>Overlay Route Events 
Dissolve: 
 'Linear Referencing Tools' toolbox>Dissolve Route Events 
Transform: 
 'Linear Referencing Tools' toolbox>Transform Route Events 
Locate point features: 
 'Linear Referencing Tools' toolbox>Locate Features Along Routes 
Locate polygon features: 
 'Linear Referencing Tools' toolbox>Locate Features Along Routes 

 
 
GPS support 
 

The GPS toolbar is now standard in ArcMap. Before 9.0, the GPS toolbar was a separate free download. 
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Miscellaneous 
 

We have improved ArcMap's performance in a number of areas, notably the time it takes to start the 
application, launch the Add Data dialog, redraw the map after changes have been made in the Table Of 
Contents, and draw legends. 
 
Other areas where there is an improvement in performance include the time it takes to launch the Tools > 
Customize dialog, update the Table Of Contents, and select large numbers of graphics. 
 
We have also improved the logic ArcMap uses to determine whether or not the map needs to be drawn in 
response to changes or additions made to its contents. We've not eliminated the problem entirely at this release, 
but we have cut down on the number of unnecessary redraws you may experience.  
 

We have made a renewed effort to identify and track down random crashes and other error issues within 
ArcMap. We have made a lot of progress in addressing the issues that have been reported in this area. 
 

We have fixed the problem where long context menus, such as the context menu for a data frame in the 
Table Of Contents or the context menu for the Sketch tool, sometimes appeared with a scroll control, forcing 
you to scroll up and down through the menu to access all the commands. Long context menus now only scroll if 
they won't completely fit on the screen you are using. This will normally not happen unless you are using ArcGIS 
on a device with a particularly small screen or unless you customize the context menus to add a large number of 
additional commands).  
 

The Edit > Paste command (and the Paste button on the Standard toolbar), now lets you paste layers you 
have copied. Right-clicking a data frame and choosing the Paste Layer command, which has been renamed to 
Paste Layer(s) at 9.0, still works too. 
 

Working with versioned data: You can now sort columns in the Versions Manager. The Change Version 
dialog has changed, and now allows you to sort the list by any of its three headings: 
 

 
 

Overview window Properties dialog. You can now specify a background color for the Overview window. The 
option to browse for a reference layer has been removed from the dropdown list and standardized as a button to 
the right of the dropdown list.  
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Several new commands have been added into the Help pulldown menu for ArcMap and all the ArcGIS 
Desktop applications. These commands give you immediate access to ESRI support and training resources on 
the Web, including the ESRI Support Center, ArcObjects Online and the Virtual Campus. 
 

If you have used the English language version of ArcGIS Desktop 8.x on a platform running a non-English 
language version of Microsoft Windows, you may have seen some dialogs in which some user interface text is 
partially truncated. This is due to the wider system font that gets used for English text in Microsoft Foundation 
Class (MFC) -based dialogs on certain platforms, such as the Korean version of Windows NT 4. At 9.0 we have 
fixed over 50 text truncation problems.  
 

The Default Symbol Properties dialog has been improved. Separate buttons have been added for launching 
the Text Symbol Selector dialog for the default text symbol and the text symbol used in the default callout. You 
can now also specify the default properties for the callout itself: 
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Other ArcCatalog changes 
 
General 
 

We have improved ArcCatalog performance in a number of areas, notably the time it takes to start the 
application.  
 

We've added icons into the New pullrights accessed when you right-click items in ArcCatalog or use the File 
pulldown menu to help you differentiate between the various things you can create. For example, this is what 
you see if you are an ArcInfo user and you've right-clicked on a folder in ArcCatalog:  
 

 
 

The command for showing and hiding the Catalog Tree window has been moved out of the View pulldown 
menu and into the Window pulldown menu, so that all the commands for controlling ArcCatalog's windows are in 
the same place. It is also no longer a checkable command. Instead, it has been given an icon so that it can 
easily be added into the Standard toolbar if you want a rapid way to toggle the Catalog Tree on and off. 
 

When you right-click a map document (.mxd file) in ArcCatalog, you'll see a new Set Data Source(s) 
command. This launches a dialog that makes it easy to update or repair some or all of the references to file-
based data sources in the map. By default, this dialog creates a copy of the .mxd file.  
 
This command is also present if you right-click a published map (.pmf) file, although it is disabled if the publisher 
of the .pmf file chose not to provide full access to its contents in ArcGIS applications when it was published). 
 
The Set Data Source command cannot be used to update or repair references to data in ArcSDE geodatabases. 
 

The dialog you see if you right-click a map document and choose Properties has been standardized so that it 
now matches the one you see in ArcMap if you choose File > Map Properties. It has everything except for the 
Data Source Options (for setting relative or absolute paths). Data Source Options can only be set within 
ArcMap. 
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Data conversion tools 
 

At 9.0, new conversion tools are provided in ArcCatalog that make full use of the new geoprocessing 
framework. You'll see these tools in ArcCatalog in the Import and Export pullrights in the context menu that 
appears when you right-click data. Tools are provided for importing/exporting one item or multiple items. These 
tools can also be launched from the new dockable ArcToolbox window that's available in each of the ArcGIS 
Desktop applications. Like any tools in the new framework, the new conversion tools can be launched 
individually, run at the command line, used in scripts, or added into models. This makes it very easy to combine 
the tools with other functions and create complete conversion workflows.  
 

A new toolbar called the 'ArcView 8x Tools' toolbar has been added into ArcCatalog. To enable this toolbar, 
go to View>Toolbars in the usual way. This toolbar provides easy access to some of the ArcGIS 8x conversion 
tools commonly used by ArcView users. This toolbar is available for all license types, but its name reflects the 
fact that is particularly aimed at ArcView users.  
 

 
 
- Geodatabase to Shapefile and Geodatabase to Table are provided for convenience for those users who wish 

to use the 8x commands for these operations. We recommend that you use the new conversion tools provided 
at 9.0 instead of these commands. Access the new conversion tools by right-clicking data in ArcCatalog or via 
the new ArcToolbox window.  

 
- The Shapefile To DXF command is provided because it is available for all license types. You can also access 

this command by right-clicking a shapefile in ArcCatalog. If you are using ArcInfo, we recommend that you use 
the Export To CAD tool instead of this command. You can find the Export To CAD tool in the ArcToolbox 
window or by right-clicking any feature data in ArcCatalog. The Export to CAD tool supports converting to DXF 
and other formats. The tool is not available if you are using ArcView or ArcEditor. 

 
- The Shapefile to AGF, AGF to Shapefile, MIF To Shapefile commands are provided because no equivalent 

tools exists in ArcToolbox window at 9.0 for these operations.  
 
- The Import From Interchange File command (for importing export '.e00' files) and the SDTS conversion 

commands are provided because they are available for all license types. The ArcInfo versions of these 
commands are available in the ArcToolbox window at 9.0 in the 'Coverage Tools' toolbox, but they require an 
ArcInfo license, and the 'Coverage Tools' toolbox is only present if you have installed ArcInfo Workstation.  

 
You can launch these commands without having to first select the appropriate data in ArcCatalog. However, if 
you do select the data in ArcCatalog first, this data is automatically used to populate the input field(s) on the 
dialogs.  
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Note: The commands on this toolbar are from ArcGIS 8x and no development that has been carried out on 
them for 9.0. These commands do not participate in the new geoprocessing framework.  
 

Many of the ArcGIS 8x tools and wizards for performing data conversion are still available at 9.0. Some of 
these are presented in the new 'ArcView 8x Tools' toolbar described above. To see the full set of ArcGIS 8x 
conversion tools that are still available at 9.0, in ArcCatalog choose Tools > Customize and click on the 
Commands tab in the dialog that appears. You'll find the 8x tools and wizards in these categories: 
 
'ArcGIS 8x Conversion Tools' 
'ArcGIS 8x GeoDB Conversion Tools' 
 
You can drag and drop these ArcGIS 8x tools into any ArcCatalog toolbar, pulldown menu, or the context menu 
for the appropriate input data type. If you add ArcGIS 8x tools into toolbars or pulldown menus, some of them 
(not all) will only become enabled when data of the appropriate input type is selected in ArcCatalog's Contents 
tab.  
 
These 8x conversion commands are provided for convenience for those users who wish to use them. However, 
we recommend that you use the new conversion tools provided at 9.0 instead of these commands. Access the 
new conversion tools by right-clicking data in ArcCatalog or via the new ArcToolbox window.  
 
Note: The commands in these categories are from ArcGIS 8x and no development that has been carried out on 
them for 9.0. They are provided on an 'as-is' basis. These commands do not participate in the new 
geoprocessing framework.  
 
 
Internet data 
 

The Internet Servers folder in ArcCatalog has been renamed as the GIS Servers folder: 
 

 
 
The new GIS Servers folder contains connections to two types of servers: 
 
- ArcIMS servers: Apart from the icon used for these servers, these connections are unchanged at 9.0. 
 
-  ArcGIS servers: These are connections to servers created using the ArcGIS Server product, which is a new 

server product in the ArcGIS 9.0 family purchased separately from ArcGIS Desktop. You can connect to an 
ArcGIS server either locally or via the Internet. If you have the correct permissions, you can add new services 
to an ArcGIS server that you connect to locally. ArcCatalog provides tools for administering ArcGIS servers 
and their contents. 

 

 Connection to ArcIMS server 
 

 Connection to ArcGIS server over Internet 
 

 Connection to ArcGIS server over local area network (LAN). 
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In this example, connections have been made to three ArcIMS servers, a local ArcGIS Server, and an ArcGIS 
Server on the internet: 

 
 

In 8.3, a connection to the Geography Network ArcIMS server at http://www.geographynetwork.com was 
automatically installed by ArcGIS. At 9.0, this connection is still automatically installed but as you can see in the 
graphic above, we've renamed it to 'Geography Network Services hosted by ESRI'. This connection still points 
to http://www.geographynetwork.com. This new name better reflects the fact that when you look at the services 
available on this server, you don't see everything that's available in the Geography Network. It only contains the 
services in the Geography Network that are hosted by ESRI on that particular ArcIMS server. There are 
hundreds of additional services on the Geography Network that are not hosted by ESRI. To access these, use 
the Add Data From Geography Network command in ArcMap's File menu.  
 

When you look inside an ArcGIS server, you'll see the services it contains, the same way that you see the 
services that an ArcIMS server contains when you look inside it. The services you'll find inside an ArcGIS server 
at 9.0 are map services and geocoding services. 
 

 Map service 
 

   Geocoding service 
 
In this example, you can see that this ArcGIS server contains five map services: 

 
 
An ArcGIS map service is created by the person or organization publishing it using an ArcMap map document. 
All the layers in that map document will be in the ArcGIS map service but with this difference: when a user of 
ArcGIS Server creates a map service using an ArcMap document that contains multiple data frames, they 
choose which one of the data frames they want the service to primarily display when it is accessed via 
ArcCatalog. So each ArcGIS map service you access via ArcCatalog will display the contents of one data frame. 
(Custom applications based on ArcGIS map services can access all the data frames in the map service, not just 
the primary one). 
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There's a new Proxy Server tab in the Tools > Options dialog in ArcCatalog. The proxy server you specify will 
be used when you access services from any ArcGIS or ArcIMS server in any ArcGIS application.  
 
 
Metadata 
 

We have fixed the problem where attribute information was scrambled after converting data to a different 
format or dropping attributes in the middle of a table. 
 

Editing metadata in ArcSDE is now associated with data editing privileges in ArcSDE. You no longer need to 
be the owner of the data to edit its metadata. 
 

The Search dialog in ArcCatalog can now be used to search ISO metadata documents using all search 
criteria except dates. 
 

Improvements have been made to the ArcIMS Metadata Service for better scalability and performance. 
 

We have added additional sample applications to the ArcGIS Developer Kit and support site, including an 
exporter for generating templates and a custom page for entering data quality information with the ISO metadata 
editor.  
 

Note about support for metadata standards in ArcGIS 9.0: ISO 19115 has been finalized. Now a new 
standard, ISO 19139, is in development. ISO 19139 is the implementation specification for ISO 19115. It will 
define how ISO metadata should be stored in XML format; the new XML is much different than the format we 
use now. ISO 19139 is also pulling together several different TC 211 standards including spatial referencing, 
feature cataloging, data quality, GML, and part 2 of 19115, which adds remote sensing information. Groups that 
are requiring ISO metadata support are requiring support for ISO 19139 rather than 19115. We are already 
working on supporting ISO 19139 for the next release after 9.0. Because of this change in tack we haven't 
added pages to the ISO 19115 version of the metadata wizard for 9.0. When we support ISO 19139 we will 
provide translators that will let people migrate from their current FGDC and ISO metadata to the new standard.  
 

The Gazetteer Loader command from ArcIMS 4.0.1 is now provided with ArcCatalog to make it more readily 
available. To add this command into ArcCatalog's user interface, go into the Tools > Customize dialog and drag 
the command out of the Gazetteer category. This command lets you populate a gazetteer in an ArcIMS 
metadata service with records, enabling you to customize your gazetteer by adding places that are not included 
in the default gazetteer or trimming it down so it just contains places inside the area of interest covered by your 
metadata service. 
 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.0 COMPARED TO 8.X PAGE  103 

Geodatabases 

Scalability 
 

At ArcGIS 9.0, there are many improvements to performance and scalability of the geodatabase in a multi-
user workflow.  This means optimized queries and eliminating over usage of CPU and bandwidth.  All multi-user 
geodatabase users will benefit from these performance gains. 
 
 
Open geodatabase data exchange via XML 
 

You can export all or any part of a geodatabase, such as individual feature datasets, feature classes, and 
tables, to an export file in XML format. The file can include all the data or just the schema. You can then send or 
transfer the file to another user who can import the data into their geodatabase. Disconnected edits can also be 
transferred and checked-in using the export file.  
 
The XML schema used by geodatabases will be a published standard (much like shapefiles). This schema 
provides access to all geodatabase data types. This will allow other applications to import and export data in a 
geodatabase friendly format. This XML format is not engineered as a direct read format; rather it is a data 
exchange format. We would expect other applications to import the XML file to their native formats and then 
export back to XML format when editing.  The geodatabase exchange format will allow complete export; change 
only export (i.e. disconnected editing), and schema only export. By providing a way to exchange geodatabase 
information, users can publish data models and share geodatabase datasets in a completely open and 
interoperable environment. 
 
To export data from a geodatabase, in ArcCatalog right-click the geodatabase, feature dataset, feature class, or 
table you want to export and from the Export pullright choose the XML Workspace Document command. 
 
To import data from an export file, in ArcCatalog right-click the geodatabase you want to import into and from 
the Import pullright choose the XML Workspace Document command. 
 
 
Geodatabase conversion tools 
 

At 9.0, new tools are provided for importing to and exporting from geodatabases that make full use of the new 
geoprocessing framework. You'll see these tools in ArcCatalog in the Import and Export pullrights in the context 
menu that appears when you right-click a geodatabase, any type of data in a geodatabase, or any file-based 
data that can be converted into a geodatabase. Tools are provided for importing/exporting one item or multiple 
items. These tools can also be launched from the new dockable ArcToolbox window that's available in each of 
the ArcGIS Desktop applications. Like any tools in the new framework, the new conversion tools can be 
launched individually, run at the command line, used in scripts, or added into models. This makes it very easy to 
combine the tools with other functions and create complete conversion workflows.  
 
Tip: Most of the ArcGIS 8x tools and wizards for converting to and from geodatabases are still available at 9.0. 
In ArcCatalog choose Tools > Customize and click on the Commands tab in the dialog that appears. You'll find 
the 8x tools and wizards in the 'ArcGIS 8x GeoDB Conversion Tools' category. You can drag and drop any 
ArcGIS 8x tool into any ArcCatalog toolbar, pulldown menu, or the context menu for the appropriate input data 
type. If you add ArcGIS 8x tools into toolbars or pulldown menus, some of them (not all) will only become 
enabled when data of the appropriate input type is selected in ArcCatalog's Contents tab. Note: no new 
development has taken place on the ArcGIS 8x tools available via the Tools > Customize dialog since ArcGIS 
8.3 was released: these tools are provided on an 'as-is at 8.3' basis.  
 
 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.0 COMPARED TO 8.X PAGE  104 

New data types 
 

At 9.0, raster data is fully integrated into the geodatabase, with improvements in how raster data is stored 
and managed, and new tools for building and working with raster catalogs in geodatabases. Raster datasets 
and raster catalogs can also now be stored in personal geodatabases. See the Raster Data section in the 
document for more information.  
 
Geodatabase tools that previously only applied to feature data now also apply to raster data. For example, data 
in rasters and raster catalogs can be extracted using the Extract Data commands in the Disconnected Editing 
toolbar. Raster data can also be included in a check out, but changes to the rasters will not be checked in. 
 

You can now define fields of type raster. They are supported for feature classes and standalone tables in 
personal geodatabases and ArcSDE geodatabases. They enable you to store rasters such as digital photos in 
tables so they can be accessed across all the ArcGIS Desktop application via the Table window and Identify 
function. See the Raster Data section in the document for more information. 
 

Whenever you create a new table or feature class you select a data type for each field. GlobalID and GUID 
are data types new to 9.0 and store registry style strings that uniquely identify a feature or table row within a 
geodatabase and across geodatabases. Developers can use them in relationships or in any application 
requiring globally unique identifiers. 
 

Feature classes of type multipatch can now be created in geodatabases. Multipatch feature classes are 
used primarily to represent 3-D objects for use in the 3D Analyst extension. To create an empty multipatch 
feature class in a geodatabase, use the New Feature Class command in the usual way. When you get to the 
panel for defining fields, click the Shape field, and then set the Geometry Type property of the Shape field to 
Multipatch. Creating new multipatch feature classes in geodatabases doesn't require the 3D Analyst extension. 
 
 
Disconnected editing 
 

In 9.0 you can now edit data that has been checked out to a personal geodatabase if you have an ArcView 
license. In 8.3 you were not able to edit a check-out personal geodatabase with an ArcView license. Note that 
the same rules still apply regarding what you can and can't edit in the check-out personal geodatabase with an 
ArcView license as in the case of a non-check-out personal geodatabase. For example, topologies can't be 
edited with an ArcView license, but simple feature classes can be edited. 
 

New file format for transferring disconnected edits: In 8.3, if you didn’t want to check-in directly from the 
check-out geodatabase, you exported the changes only from the check-out geodatabase to a delta database, 
transferred the delta database, then checked in the changes from the delta database. Instead of exporting to a 
delta database, you can now export changes to a smaller XML file and transfer it. The changes can then be 
checked in from the XML file. 
 
 
Miscellaneous 
 

You can now define a cluster tolerance for Z coordinates in a topology.  
 

The documentation for specifying the X/Y Domain for new datasets when you use the Spatial Reference 
Properties dialog has been improved. You can find this new documentation in the ArcGIS Desktop Help and the 
printed documentation for working with geodatabases. You can also access it directly via an 'About Setting the 
X/Y Domain' button that you'll find on the X/Y Domain tab in the Spatial Reference Properties dialog.  
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Geocoding 
 

'Geocoding services' have been renamed to 'Address locators' throughout ArcGIS. The Geocoding Services 
folder in the ArcCatalog tree is now the Address Locators folder: 
 

 
In previous releases, we used the terms 'geocoding service' and 'locator' somewhat interchangeably. 'Locator' is 
the term that was used for developers, and 'geocoding service' was the term used in the user interface. This 
caused some confusion for people. Also, at 9.0 the ArcGIS Server product enables users to create geocoding 
servers that provide geocoding-based services. Renaming geocoding services to address locators in the ArcGIS 
user interface removes possible confusion between address locators on disk or in databases, and geocoding-
based services being served via ArcGIS Server. 
 

When you create an address locator you now have the choice to create a composite address locator that 
references several other address locators and chains them together. With a composite address locator you can 
perform 'one pass' geocoding using multiple address locators and their reference data. This lets you use 
separate address locators for different geographic areas or different levels of detail to provide custom 'fall back' 
strategies to maximize the number of addresses that can be successfully geocoded.  
 
For example, you can create a composite address locator composed of three separate locators that lets you 
geocode against very detailed street data for a county, fall back to a generalized street network if the address is 
not found, and finally fall back to Zip codes if the address is still not found. 
 
When you define a composite address locator you also can define selection criteria that control when particular 
address locators that participate in the composite locator will be used when you geocode. For example, a 
composite locator can be defined so that if the Country field in an address is equal to "USA", the address will 
geocoded by the StreetMap USA locator, while Canadian addresses will be sent to a different locator. 
 
To create a composite address locator, choose the 'Composite' locator style when you create a new address 
locator. 
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The example below shows a composite locator that comprises two address locators, one for each of two states. 
Selection criteria have been defined so that based on the value of the State field the address locator for the 
appropriate state is used: 
 

 
 

A new option is available in the Geocoding Settings tab of the Feature Class Properties dialog for 
geodatabase feature classes created by geocoding. The 'Add new records in unmatched state' check box lets 
you choose the state in which new records will be added. When this is checked, additional records added to this 
geodatabase feature class will be in an unmatched state. This option only applies to geodatabase feature 
classes that were geocoded using the 'Create dynamic feature class related to table' option in the Geocode 
Addresses dialog or Geocode Addresses geoprocessing tool. (The dynamic feature class option is only 
available when the address table and the geocoded feature class are in the same geodatabase. It is not 
available if the output is a shapefile). 
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Coordinate systems 
 
In addition to the enhancements listed here, many quality and performance issues have been addressed in this 
part of the software too.  
 

Additional map projections supported: 
 
- Fuller projection supported: We support the final version that was described by Buckminster Fuller in 1954. 

This projection converts the globe into a 20-sided figure called an icosahedron. 
 

 
 
- Local Cartesian projection supported: An improved version of the ArcInfo Workstation LOCAL projection. 

Unlike the Workstation version, the ArcGIS Desktop Projection Engine adds support for a scale factor, a 
rotation value, and false easting and false northing parameters. This is a specialized map projection that does 
not take into account the curvature of the earth. It's designed for very large-scale mapping applications. 

 
- Robinson ArcInfo supported: This is the same version of Robinson that's supported in ArcInfo workstation. 
 
- RSO (Rectified Skew Orthomorphic) projection supported. This is used for coordinate systems in Malaya and 

Borneo: 
 

 
 
- Cube map projection added. This is a faceted projection used behind the scenes by the ArcGlobe application 

in the 3D Analyst extension when it prepares data for caching. The world is projected onto a six-sided figure 
with square sides. Not normally used directly in mapping. May be suitable for educational purposes: 
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Support has been added for over 250 additional geographic transformations. These include: 
 
- Replacement of the state-level NTv2 files with the new national files for Australia. 
 
- NTv2 transformations files for France, the island of Grand Terre, and the area around Noumea in New 

Caledonia.  
 

New coordinate system (prj) files: 
 
- Over 300 geographic coordinate system files including ones for the Minnesota and Wisconsin county systems, 

planets and moons in the solar system, and many others from the European Petroleum Survey Group (EPSG) 
( http://www.epsg.org/ ) database. 

 
- Almost 1000 projected coordinate systems including the Minnesota and Wisconsin county systems, 3 degree 

Gauss-Kruger zones for China and Russia, EMEP grid systems, Lambert Azimuthal, and Lambert Conformal 
Conic systems for Europe, RSO systems for Malaya and Borneo, Australian ISG zones, UTM and large scale 
mapping zones based upon JGD2000, several US statewide zones, State Plane zones based on international 
feet, and more! 

 
 

http://www.epsg.org/
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Application development and deployment  
 
ArcGIS 9.0 provides a complete system for GIS application development. ESRI offers developers enormous 
flexibility in selecting a development platform for ArcGIS. ArcObjects is at the core of these choices, offering an 
integrated collection of GIS software objects written in C++. Developers can choose from four development 
environments (Java, .NET, C++, and Component Object Model [COM]). Until now, developers have only been 
able to customize the ArcGIS Desktop applications. At 9.0 developers also have the ability to deploy ArcGIS 
solutions as independent applications on the desktop or as Web services across the Intranet or Internet.  
 
Developers can choose from three deployment options: 
 
- ArcGIS Desktop: Custom applications deployed with the Desktop applications 
 
- ArcGIS Engine (separately available product, new at 9.0): ArcGIS Engine is a new developer product 

providing a powerful collection of embeddable mapping and GIS components for creating and deploying 
custom GIS and mapping desktop applications. With ArcGIS Engine developers can build solutions and 
deploy them to customers without requiring the ArcGIS Desktop applications (ArcMap, ArcCatalog) to be 
present on the same machine. Developers can create new applications or add dynamic mapping and GIS 
capabilities to existing applications. Solutions created using ArcGIS Engine can vary from simple map viewers 
to more sophisticated GIS applications for integrated data visualization, analysis, and management. ArcGIS 
Engine supports all the standard development environments including .NET, Component Object Model 
(COM), Java, and C++. The initial 9.0 release of ArcGIS Engine is available only on Microsoft Windows. More 
information: http://www.esri.com/arcgisengine

 
- ArcGIS Server (separately available product, new at 9.0): ArcGIS Server is a GIS enterprise application 

server that provides complete GIS capabilities throughout an organization while maintaining a centrally 
managed database. Mapping, geocoding, spatial queries, editing, tracing, and linear referencing are all 
examples of applications that developers can build using ArcGIS Server. These applications can be accessed 
by browser-based clients, custom applications built with ArcGIS Engine, and ArcGIS Desktop. ArcGIS Server 
supports all common development environments (Java, .NET, C++, COM). The initial 9.0 release of ArcGIS 
Server is available only on Microsoft Windows. More information: http://www.esri.com/arcgisserver

 
 ArcGIS Server 9.0 is designed primarily for enterprise information system developers and integrators who 

wish to build server-side GIS applications in either a client/server or web services environment. It is 
complementary to ESRI's two other enterprise application server products, ArcSDE, which is used to access 
spatial data in a commercial DBMS, and ArcIMS, which is used for high volume Internet geo-publishing.  

 
There's a new ArcGIS Developer website for 9.0 at: 

 
  http://arcgisdeveloperonline.esri.com
 
A shortcut to get to this site is to choose the ArcGIS Developer command in the Help pulldown menu of any of 
the ArcGIS Desktop applications.  
  
The ArcGIS 8.x ArcObjects Online website is still available at http://arcobjectsonline.esri.com
 

http://www.esri.com/arcgisengine
http://www.esri.com/arcgisserver
http://arcgisdeveloperonline.esri.com/
http://arcobjectsonline.esri.com/
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Licensing 
 

For the 9.0 release, the name of the License Manager has changed.  Previous versions of the software use 
the name ‘ESRI License Manager’.  ArcGIS 9.0 uses the name ‘ArcGIS License Manager’, which reflects the 
new vendor daemon used (ARCGIS).  The default port number for the new ARCGIS daemon is 27004 and the 
license file variable is ARCGIS_LICENSE_FILE=@<host>. 
 

At the 9.0 release, ArcIMS and ArcSDE software no longer use the FLEXlm License Manager.  At 9.0, these 
products as well as ArcGIS Engine, ArcGIS Server, and ArcView (Single Use)/ArcEditor (Single Use) all require 
that you register and authorize the software for use. 
 

ArcGIS Desktop and ArcInfo Workstation 9.0 cannot use an older version of the License Manager or pre-9.0 
license files.  To run ArcGIS Desktop and/or ArcInfo Workstation 9.0, you will need to upgrade your license file 
to a 9.0 license file.  To do so, see http://service.esri.com.  Once you have obtained your new file you can install 
the 9.0 License Manager from the Desktop or Workstation CDs. 
 

During the transition period you can maintain both an 8.x and 9.0 License Manager on one machine or you 
can separate them on two machines.  If you wish to use only one machine, then you must use your existing 8.x 
Hardware Key number to request your new 9.0 license file. 
 

ESRI will systematically generate 2 license files that will be sent back to you: 
 
- A 9.0 license file which will contain all the licenses you had on maintenance (licenses you were entitled to 

upgrade). 
 
- An 8.x license file, which will contain the number of licenses you did not have on maintenance (or which you 

chose not to upgrade). Should you upgrade all of your licenses to 9.0, this 8.x file will not be generated. 
 

While your organization is in transition you can continue to use your existing 8.x license file along with the 
License Manager you installed with 9.0. However, once the transition period is complete and all of your licenses 
on maintenance have been upgraded to 9.0 and installed you will need to either replace your existing 8.x license 
file with the new 8.x license file that was sent to you, or, if no 8.x file was sent, you will need to completely 
uninstall your 8.x ESRI License Manager. 
For example: Only some of your licenses are on maintenance: 

Software Name License Type Total Seats On Maintenance Maintenance Expiration 
ArcInfo Floating 5 3 10/31/04 

 
If you decide to upgrade all licenses (those on maintenance) to version 9.0, then ESRI will generate and send 
you: 
 
- A 9.0 file with 3 ArcInfo 9.0 licenses. 
 
- An 8.x file with 2 ArcInfo 8.x licenses 

 
For more information on these topics or any other portion of the License Manger please visit the License 

Manager Reference Guide found in the Documentation directory on your ArcGIS Desktop or ArcInfo Workstation 
9.0 CDs. 
 
 

http://service.esri.com/
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New extension: Maplex for ArcGIS 
 
Maplex for ArcGIS allows high quality cartographic label creation using advanced label placement and fitting 
techniques.  Using an advanced conflict detection algorithm, Maplex can place a larger number of labels in 
appropriate locations. If you need to produce cartographic labeling of the highest quality, the Maplex extension 
will save you many hours of intensive manual labeling time. The advanced label placement capabilities provided 
by the extension can also be used when you create and edit annotation feature classes in geodatabases. 
 

Maplex extends the standard label properties with advanced settings for placement and fitting.  Some of 
these properties include: 
 
- Automatic Font reduction 
- Automatic Label Stacking 
- Automatic Abbreviation 
- Boundary Placement 
- Repeating Labeling 
- Automatic Character Spacing 
- Control the label Overrun on features 
- Set Feature Weights 
- Set Boundary Weights 
- Draft or Production Quality placement 
- And many more… 
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Some examples of labeling generated with the Maplex for ArcGIS extension: 
 

   
 

    
 

The Maplex for ArcGIS extension is fully integrated into the new labeling user interface in ArcMap 9.0. The 
extension uses the same Labeling toolbar and Label Manager as standard ArcMap, with the addition of new 
label handling options and functionality not available in the standard labeling user interface. There's not a 
separate toolbar for the Maplex extension. Here's what the Labeling toolbar looks like if you have installed the 
Maplex extension: 
 

 
 
Tip: You can open a map document containing Maplex labels whether or not you have the Maplex extension. If 
you open a map document containing Maplex labels and you don't have the Maplex For ArcGIS extension, you'll 
simply get a message and the standard label engine will be used instead of Maplex to label the map. 
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The Maplex for ArcGIS extension is also fully integrated into the new annotation functionality in 9.0. When 
you create and edit annotation you can use Maplex to generate the annotation placement.  
 
In the screenshot below, a feature-linked annotation feature class is being created in a geodatabase in 
ArcCatalog, and the Maplex label engine has been selected to generate the annotation placement: 
 

 
 
Tip: You can view and edit an annotation feature class that uses Maplex label placement whether or not you 
have the Maplex extension. In the case of editing standard annotation (annotation that is not feature-linked) 
there's no difference. In the case of editing feature-linked annotation, ArcMap will automatically use the standard 
label engine when it needs to place new annotation if a Maplex license is not available.  
 
If you want to create an annotation feature class using Maplex label placement, or edit a feature-linked 
annotation feature class using Maplex to place new annotation, you will need to have the Maplex extension. 
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3D Analyst Extension  
 
At ArcGIS 9.0 the 3D Analyst extension presents new functionality in three major areas, 3D visualization, 3D 
symbology, and 3D geoprocessing. ArcGlobe is the next generation of 3D visualization.  ArcGlobe allows for 
many gigabytes of data to be seamlessly merged on the fly into a single fast visualization experience. Enhanced 
3D symbology includes true 3D symbols and realistic texture support.  Finally, there is a new set of 3D Analyst 
tools presented in the geoprocessing framework at 9.0.  
 
 
ArcGlobe 
 

The 3D Analyst extension includes a completely new application called ArcGlobe. ArcGlobe provides a highly 
interactive 3D visualization and analysis application for working with large and varied GIS data sets.  Using a 
special indexing structure, ArcGlobe allows users quickly navigate gigabytes and terabytes of GIS data without 
pre-processing the data.  ArcGlobe also integrates with the new ArcToolbox framework allowing tools, models, 
and scripts to be executed within this highly dynamic environment. 
 
ArcGlobe provides the same basic functionalities as ArcMap, excluding graphics, editing, and page layout.  This 
means users can: 
 
- Select by attribute, by location, or interactively 
- Identify features 
- Symbolize features 
- Extrude features to 3D 
- Use 3D Symbols 
- Navigate (equivalent of pan, zoom) 
- Find based on an attribute 
- Find based on an Address 
- Find based on a location using a global gazetteer 
- Rotate Globe 
- Interactive Fly/walk mode 
- Record Animation to AVI or QuickTime 
- Animate the display automatically 
- Integrate raster, vector, and terrain data, including data being served on the Internet 
- Display data on the surface, at specified elevation or on a different specified surface 
- Customize the application with VBA or COM 
- And much more… 
 
ArcGlobe and ArcScene, while engineered for different users, overlap in many areas of functionality.  ArcScene 
is good for small local projects with relatively small amounts of data.  ArcScene has more interactive tools and 
graphic support than ArcGlobe, making it ideal for some analysis and visualization tasks.  ArcGlobe focuses on 
using larger amounts of data and allows the user to seamlessly integrate all their data into a single globe based 
document.    
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Examples of dramatic visualizations created with ArcGlobe. The screenshot at the left on the bottom row 
shows a model created with the new geoprocessing framework with results displayed in ArcGlobe. The tight 
integration of modeling and 3D visualization is a new and very powerful feature of the 3D Analyst extension 
at 9.0. (Some data shown below courtesy of DigitalGlobe & NatureServer  (Natural Heritage Programs)). 
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3D symbols 
 

3D Analyst adds support for using 3D symbols. This allows you to represent GIS features with 3D symbology, 
such as using houses or cars for point features, grass or water texture fills for polygon features, and tubes or 
textured lines for line features. ArcScene and ArcGlobe both support these new 3D symbols.  In the standard 
symbol selector dialog you can choose various 3D symbol types: 
 
For Points: 
3D Character Marker: 3D Symbols from True Type fonts extruded 
3D Marker: Import of OpenFlight, 3D Studio, and VRML models 
3D Simple Marker: simple shapes 
 
For Lines: 
3D Simple Line:  Simple line shapes of tube, wall, and strip 
3D Textured Line:  Strip line with image texture (like a photo of a road) 
 
For Polygons: 
3D Texture Fill: Allows the user to pick an image to use as a fill pattern. (e.g., grass, water, pavement…) 
 
Additionally you can select from a variety of supplied 3D styles to choose from over 500 quality 3D objects.  
These styles include: 
 
- 3D Houses 
- 3D Skyscrapers 
- 3D Industrial buildings and equipment 
- 3D Basic shapes 
- 3D Street furniture (signs, lights, benches…) 
- 3D Trees (and shrubs) 
- 3D Vehicles 
 
Various 3D symbols and textures used in ArcScene 
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3D symbols including palm trees and textures on the buildings and ocean add 
realism to this ArcGlobe display. (Data Courtesy of the City and County of 
Honolulu) 
 

 
 
3D symbol property editor: 
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3D geoprocessing 
 

The 3D Analyst toolbar you are familiar with from ArcMap 8.x is still in the product (it is not provided in the 
new ArcGlobe application). However at 9.0 there is a new suite of geoprocessing tools for working with 3D data 
provided in the new geoprocessing framework. Use these tools to take full advantage of modeling, scripting, etc 
in your 3D analysis work. The new ArcToolbox window is available in ArcMap, ArcCatalog, ArcScene and 
ArcGlobe. For example, this means that for the first time you can perform your 3D analysis and data processing 
directly inside ArcCatalog.  
 
This screenshot shows the toolsets you'll find in the '3D Analyst Tools' toolbox at 9.0. Two of the toolsets have 
been expanded in the tree so you can see the tools they contain: 
 

 
 
For an introduction to the geoprocessing framework and its capabilities refer to the 'Geoprocessing' section of 
this document.  
 
For a quick overview of how to use geoprocessing written from the point of view of working with layers, see 
'Geoprocessing in ArcMap at 9.0' in the 'Other ArcMap Changes' section of this document. 
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Other ArcScene changes 
 

At 9.0, you can now draw 3D graphics and text directly onto scenes using the new 3D Graphics toolbar: 
 

 
 
Use 3D graphics and text to enhance your scenes or 3D maps. You can draw points, lines, polygons, and 3D 
text to make highlight parts of your scene. For example, you might define a study area by enclosing it with a line 
or polygon boundary or label buildings with text indicating their names: 
 

 
 

ArcScene has a new full screen mode, in which the application window surrounds are hidden. Press F11 to 
go into full screen mode. Press F11 again to leave full screen mode. This mode is also available in ArcGlobe. 
 

The change made to the feature selection logic in ArcMap at 9.0 also applies to ArcScene. See 'Selection' in 
the 'Other ArcMap Changes' section of this document for more information. 
 

There is now no limit to the number of ESRI GRIDs that can be added into a single ArcScene document. This 
enhancement also applies to ArcMap and ArcGlobe. The limitation of 49 GRIDs in a single document has been 
removed at 9.0. 
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ArcScene now supports stereo viewing. Stereo viewing provides added depth and realism to your 3D scenes. 
You can view your scenes in stereo by using red and blue stereo viewing glasses, using a polarized stereo 
shutter for your monitor in combination with specialized eyeglasses, or projecting the images in a scene and 
viewing the images with specialized eyeglasses.  
 
To specify stereo viewing, go to View > View Settings and choose the new Stereo View option in the Viewing 
Characteristics panel: 
 

 
 
 
Miscellaneous 
 

Feature classes of type multipatch can now be created in geodatabases. Multipatch feature classes are used 
primarily to represent 3D objects for use in the 3D Analyst extension. To create an empty multipatch feature 
class in a geodatabase, use the New Feature Class command in the usual way. When you get to the panel for 
defining fields, click the Shape field, and then set the Geometry Type property of the Shape field to Multipatch. 
Creating new multipatch feature classes in geodatabases doesn't require the 3D Analyst extension. 
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ArcGIS Publisher Extension and ArcReader 
 

Data Packaging: Allows the data presented in a map document to be clipped and centrally packaged for 
distribution with the published map (.pmf) file. Various options are provided for handling vector and raster data 
sources, including the ability to compress and lock vector data: 
 

 
 

Map Time out: Allows the map author to define an optional message to warn users the map may be out of 
date or they can block access altogether to a published map after a specified date. 
 

At 9.0, ArcGIS Publisher includes a programmable ArcReader control enabling developers to easily build and 
deploy ArcReader applications. Custom ArcReader applications can be built using the .Net and COM APIs. With 
this new access to the developer controls behind ArcReader, you can build your own ArcReader-based 
applications and embed them in customized solutions on the desktop. This level of customization is very simple 
and only provides the 10 or so underlying objects and functionalities provided in ArcReader. Developers do not 
have access to ArcObjects using this customization. 
 

New Set Data Sources command available when you right-click a published map (.pmf file) in ArcCatalog. 
This launches a dialog that makes it easy to update or repair some or all of the references to file-based data 
sources in the file. By default, this dialog creates a copy of the .pmf file. This command is disabled if the 
publisher of the .pmf file chose not to provide full access to its contents in ArcGIS applications when it was 
published. The Set Data Source command cannot be used to update or repair references to data in ArcSDE 
geodatabases. 
 

ArcReader's Identify Results dialog: If one of the fields of the layer you identify contains URLs or paths to 
documents, you can launch these links by clicking a small icon you'll see next to the field value. You can also 
open rasters stored in raster fields this way too. Rasters that you open are displayed inside a special generic 
raster viewer window. 
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ArcReader's Identify Results dialog: A new option has been added into the context menu that appears when 
you right-click the right-side of this dialog. This option lets you choose between having the fields listed in 
alphabetical order or in the order in which the fields occur in the data source of the layer you have identified. 
 

ArcReader is now also supported on Sun Solaris. 
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Spatial Analyst Extension 
 
ArcGIS 9.0 is a significant step forward for the Spatial Analyst. In addition to the return of the ModelBuilder 
graphical modeling interface, there are over 100 new functions exposed in the Spatial Analyst user interface. 
Many of these functions were previously only accessible through ArcObjects or Map Algebra. All of these 
functions are accessible in 9.0 through the geoprocessing framework, which provides access to tools in dialogs, 
command line, ModelBuilder, and scripting. 
 
The Spatial Analyst toolbar you are familiar with from ArcMap 8.x is still in the product, with a few improvements 
and bug fixes. If everything you need is in that toolbar you don't have to change to use the Spatial Analyst tools 
in the new geoprocessing framework. However, if you are someone who has never had quite enough analytical 
tools, always wanted to combine Spatial Analyst tools with tools from other parts of the software, wanted to write 
batch scripts without learning VisualBasic, or wanted to create process models that you can save, share, and 
rerun without going through every dialog again, then explore the new tools and user interface options available 
for Spatial Analyst! 
 
There's a new version of the Spatial Analyst tutorial that describes how to use the new functionality at 9.0. You 
can find this tutorial in PDF format on the ESRI Software Products Library CD that comes with the release. The 
file is called 'Spatial_Analyst_Tutorial_90.pdf'. 
 
 
Integration with Geoprocessing Framework 
 
The Spatial Analyst extension is fully integrated into the new geoprocessing framework. For an introduction to 
the geoprocessing framework and its capabilities refer to the 'Geoprocessing' section of this document. For a 
quick overview of how to use geoprocessing written from the point of view of working with layers, see 
'Geoprocessing in ArcMap at 9.0' in the 'Other ArcMap Changes' section of this document.   
 

As the new ArcToolbox window at 9.0 is available in ArcCatalog as well as ArcMap, you can now perform 
spatial analysis inside ArcCatalog. If you also have the 3D Analyst extension, you can also access the Spatial 
Analyst tools inside ArcScene and ArcGlobe. 
 

ModelBuilder, which first appeared in Spatial Analyst in ArcView 3 is part of the geoprocessing framework of 
9.0. ModelBuilder is now a fully integrated part of the ArcGIS package containing over 400 tools and working on 
every ArcGIS supported data type. It is a graphical modeling environment used to create, edit, run, and 
document spatial models, and is a very natural paradigm for Spatial Analyst users who often wish to string many 
tools together as a process to solve a complex problem.  
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Here is a site suitability model created in the ModelBuilder with the Spatial Analyst tools: 
 

 
 

Within the ArcToolbox folder, the Spatial Analyst tools are organized into functional groups as toolsets as 
shown below. 
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Within each toolset is a collection of tools for performing that type of analysis. All of the tools found in the 
Spatial Analyst toolbox require a Spatial Analyst license. Here are the tools available within each toolset: 
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The data management functions such as data conversion and import that have been part of the Spatial 
Analyst toolbar in the past, are now found in other toolsets that do not require a Spatial Analyst license. 
 

Tools for data conversion are found in the Conversion Tools toolbox: 
 

 
 

Tools for general raster data management such as geometric transformation, map projection, mosaicing, and 
loading raster data into a geodatabase are in the Data Management Tools toolbox under the Raster toolset and 
the Projections and Transformations > Raster toolset: 
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New or improved functions 
 
As you can see, there are a large number of tools available. Following are highlights of some of the most 
requested toolsets and tools. 
 

Hydrology – The hydrology toolset provides tools for analyzing terrain surfaces and modeling how water will 
flow across them. This includes tools for calculating the direction of flow, accumulation of flow, flow length, and 
delineating watersheds to name a few. Many of these functions have been available to Spatial Analyst users in 
the past through ArcObjects or sample tools. 
 

Groundwater – The groundwater toolset provides tools for analyzing the movement of groundwater, particles 
in the water, and their dispersion. It uses simple Darcian flow principles based on two-dimensional steady state 
flow. 
 

Generalization – The generalization toolset provides tools for simplifying and cleaning up raster data. These 
tools are often used for simplifying raster data before it is vectorized, but are also useful to the pure raster user.  
 

Interpolation – There are two new tools for interpolation in Spatial Analyst at 9.0. Natural Neighbors is an 
interpolation technique that has been part of the 3D Analyst and is very useful for creating a simple surface that 
reflects your actual data values. It is unique in that it uses linear interpolation between observation points and 
will therefore not create artificial peaks and valleys in your data. It is great for making an initial surface to see 
what your data look like before moving on to more advanced techniques. Topo To Raster is a specialized 
interpolation tool designed for the creation of hydrologically correct elevation surfaces for use in the hydrology 
tools described above. For Workstation ArcInfo users, this is an updated version of the TopoGrid command, 
based on ANUDEM. 
 

Distance – In addition to the distance tools that have always been part of Spatial Analyst, we have now 
added the PathDistance functions from ArcGRID. PathDistance is a special variation of CostDistance that allows 
calculation of surface distance instead of just planimetric distance, and allows input of vertical and horizontal 
factors such as slope or wind in the weighted distance calculation. 
 

Multivariate – The multivariate tools allow for the exploration of relationships between many different types 
of attributes from multiple input rasters. Spatial Analyst provides tools such as supervised and unsupervised 
classification and principal component analysis. 
 

Map Algebra – The map algebra toolset provides two tools for using the traditional GRID Map Algebra 
syntax inside the geoprocessing framework. The tools are primarily distinguished by their outputs and their use 
in ModelBuilder. The Single Output Map Algebra tool creates only a single raster output, and can have inputs to 
it and the output from it connected in a model. It is also very open in the type of inputs it can accept and has 
better syntax checking and error handling. The Multi Output Map Algebra can create one or many outputs and 
therefore can not be connected in a model. Its list of acceptable input types and syntax checking is less robust, 
much like the ArcGrid command line. 
 

Weighted Overlay – The weighted overlay tool, found in the Overlay toolset, is a tool for applying a common 
scale of values to diverse and dissimilar inputs in order to create an integrated analysis. It allows you to specify 
different weight values for dataset and classes within datasets, that are combined into a single output. This tool 
will save numerous steps and provide a better user experience for problems such as site selection and 
suitability analysis. 
 

Con – The Con tool, short for conditional, is found in the Conditional toolset. The Con function was a 
cornerstone of ArcGrid and can be very useful for testing conditions of input cell values and having complex 
control of the outputs. The Con tool is a simplified version of this, and the Map Algebra tools can provide all the 
power and flexibility you need. 
 

Tabulate Area – The Tabulate Area tool, found in the Zonal toolset, calculates the cross tabulated areas 
between two raster or feature datasets. 
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Extract Values to Points – The Extract Values to Points tool, found in the Extraction toolset is a unique and 
useful raster/vector tool. It is used to overlay point data on a raster, and transfer the value of the cells into a field 
in the attribute table of the point dataset. This is similar to the LatticeSpot command from Workstation, but also 
provides the option to get the cell value, or an interpolated value between cell centers if your are working with a 
continuous surface.  
 
 
Removed system limits 
 

2 gb file size limit removed – The file size limit for the ESRI GRID format has been removed. There is no 
longer a hard coded limit. For files near or larger than 2 gb, you will not be able to build a VAT or add additional 
attributes to the table. 
 

50 channel limit removed -  The limit on the number of inputs you could provide to a function at one time, 
commonly known as the channel limit, no longer exists. There is no hard coded limit to the number of inputs you 
can now provide to a Spatial Analyst function that takes a list of inputs. This also removes the limit on the 
number of Grids you could display in ArcMap  simultaneously. This also applies to ArcScene and ArcGlobe. 
 

32767 operations in a session limit removed – The limit on the number of Spatial Analyst operations you 
could perform in a session no longer exists. There is now no limit. 
 
 
What’s different from 8.3? 
 

Environments  – The Spatial Analyst toolbar has an Analysis Environment that is accessed from the Options 
on the toolbar. The geoprocessing framework at 9.0 also has a set of environment parameters. These two 
environments, although they have some similar parameters, are not connected. For example, setting a cellsize 
in the Toolbar > Options will not affect the cellsize when running a tool from the new ArcToolbox window, and 
vice versa.  
 
You specify the new environment settings by either going to the Tools>Options dialog for the application you are 
using, choosing the Geoprocessing tab and pressing the Environments button, or opening the ArcToolbox 
window, right-clicking the 'ArcToolbox' entry at the top of the ArcToolbox window, and choosing the 
Environments command. Both of these will launch the new Environment Settings dialog. 
 
If you use ArcMap, ArcScene or ArcGlobe, your environment settings apply to the current document you are 
working with and get saved into that document.  
 
If you use ArcCatalog, your environment settings apply to the all the work you perform in ArcCatalog. 
The current environment settings in your application can be overridden by environment settings specified as 
overrides in the model properties, and also by environment settings specified as overrides in the properties of 
any of the processes in the model. 
 
In the new Environment Settings dialog, the current workspace, default output workspace, output coordinate 
system, extent, and snap raster are found in the General Settings. Cellsize and mask are found in the Raster 
Analysis Settings. Parameters for loading rasters into the geodatabase are found in the Raster Geodatabase 
Settings. 
 

Reclassify  – A new precision option for setting numerical precision has been added to the Reclassify 
function. You'll see a new Precision button on the Reclassify dialog launched from the Spatial Analyst toolbar. 
Press this button to open the Precision sub-dialog (see illustration below). This Precision dialog is also 
accessible from the Reclassify tool in the new ArcToolbox window. 
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Expanded ArcObjects API 
 
There has been some reorganization and additions to the ArcObjects API for Spatial Analyst. 
 
First, the SAExtension is no longer cocreateable, now you should use the ExtensionManager to load and enable 
the Spatial Analyst license. 
 
Second, the objects have been reorganized into 3 object libraries, GeoAnalyst (for things that are not just 
Spatial Analyst), SpatialAnalyst (things licensed only to Spatial Analyst), and SpatialAnalystUI (the UI 
components of Spatial Analyst). 
 
And finally, there are several new objects, interfaces, and methods for the Spatial Analyst. 
 

GridTableOp  – This is a new object at 9.0 that includes the methods AddField, DeleteField, and Update. It is 
used to add and delete fields and do updates to the VAT of an ESRI GRID. 
 

RasterConversionOp  – This object has two new interfaces, IRasterExportOp and IRasterImportOp2. 
IRasterExportOp provides methods to export raster data to ASCII and floating point binary formats with the 
methods ExportToASCII and ExportToFloat, respectively. IRasterImportOp2 add the method 
ImportFromUSGSDEM, to import rasters in the USGS DEM format. 
 

RasterDistanceOp  – This object has a new interface, IDistanceOp2, to support the PathDistance functions 
explained above. The new methods in this interface are PathDistance, PathDistanceFull, PathAllocation, and 
PathBackLink. 
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RasterExtractionOp - This object has a new interface, IExtractionOp2 to accommodate the 
ExtractValuesToPoints methods described above. 
 

RasterInterpolationOp  – This object has a new interface, IInterpolationOp2 to accommodate the 
NaturalNeighbor and TopoToRasterByFile methods described above. 
 

RasterSurfaceOp  – This object has a new interface,  ISurfaceOp2 to accommodate changes to the method 
signature for Visibility. It now accepts a user defined refractivity coefficient. 
 

RasterTransformationOp  – This is a new object at 9.0 that includes methods for performing geometric 
transformations of raster data such as projection, warp, shift, resample, etc. 
 
 
ArcGIS Engine and ArcGIS Server 
 
Spatial Analyst functionality is available for the new ArcGIS Engine and ArcGIS Server products  
introduced at 9.0. Options are available for both ArcGIS Engine and ArcGIS Server enabling the use of the 
Spatial Analyst extension's ArcObjects developer components in those products. Developers using ArcGIS 
Engine with this option can create custom desktop applications containing embedded Spatial Analyst 
functionality. Developers using ArcGIS Server with this option can deploy server-based applications providing 
Spatial Analyst functionality across the enterprise or over the Internet. 
 
 
Documentation 
 
There have been extensive updates to the Spatial Analyst documentation to keep up with all the new 
functionality. 
 

As mentioned previously, there's a new version of the Spatial Analyst tutorial that describes how to use the 
new functionality at 9.0. You can find this tutorial in PDF format on the ESRI Software Products Library CD that 
comes with the release. The file is called 'Spatial_Analyst_Tutorial_90.pdf'. 
 

The conceptual information which had been scattered among many topics in the past has been reorganized, 
expanded, has new graphics, and now follows the functional organization of the geoprocessing toolsets. This 
pattern for the conceptual information is the same for all geoprocessing toolboxes and toolsets. 
 

The functional reference documents for the Spatial Analyst functions which appeared in 8.2 have been 
expanded to cover all the analysis tools available in the Spatial Analyst toolbar, geoprocessing tools, 
geoprocessing scripting, and map algebra. All function help is now fully cross referenced and has syntax 
examples for each use case. Now you can also launch the geoprocessing tool directly from the help page. 
 

For ArcObjects developers, there is also more complete coverage of the syntax and examples for the 
analysis tools available in the Spatial Analyst API. 
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Survey Analyst Extension 
 
A number of bug fixes and performance enhancements have been made for the 9.0 release. Here are the key 
improvements: 
 

Survey datasets no longer use an over-sized spatial grid, greatly improving performance during map 
navigation 
 

The least squares adjustment now works with 2D reference points. 
 

Data exchange bug fixes include the following: units for imported elevations are now converted correctly, 
TDS format system coordinates are now ignored, GSI format offsets are now imported and exported. 
 

Better developer support for data exchange, including a developer sample demonstrating how to create a 
new importer for data collector files, and demonstrating feature coding. 
 

Better processing feedback, such as the progress bars that indicate what is occurring during the import 
process, survey dataset creation, survey project creation, feature linking, and listing data in the Survey Explorer. 
 

The Compass Adjustment now computes the correct distance residuals. 
 

Making multiple feature classes un-survey aware, the message now appears only once. 
 

For the TPS computations, there are now two options to choose whether or not to compute elevation data, 
and whether or not to enforce limit-checking: 
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ArcPress Extension 
 

ArcPress for ArcGIS at ArcGIS 9.0 dramatically improves the user experience, performance, and quality of 
the output. ArcPress has been completely reengineered for 9.0, including a metafile interpreter and rasterizer, 
rewritten and brand new printer drivers, and a new user interface. 
 
ArcPress 9.0 will no longer support graphic export, and instead will focus on providing a great printing solution.  
At 9.0 all of the graphic export formats are now supported as part of the core ArcGIS system.  
 
The new rasterizer now interprets and processes the metafile directly whereas the previous ArcPress rasterizer 
required the metafile be converted to EPS. Because this conversion is no longer a requirement and the more 
efficient and robust rasterizer engine, ArcPress throughput power has been greatly improved.  
 
In addition, all of the ArcPress drivers have been greatly improved. ArcPress 9.0 now includes true halftone  
drivers for RTL CMYK, RTL monochrome, PCL CMYK and PCL monochrome. Everyone's most favorite driver, 
the RTL Device Dithered RGB (now simply called "RTL RGB") has been tweaked to improve quality and 
performance. In addition, ESRI is proud to announce that ArcPress 9.0 includes the PCL RGB driver which 
supports the following printers with outstanding picture and color quality: HP DesignJet 10ps, 20ps, 50ps, 500, 
800, 100, and 120. 
 
The File>Print>ArcPress Properties dialog has been improved to support the new printer drivers and improved 
color Adjustment options (for the halftone drivers). ArcPress will continue to automatically select the correct 
printer driver for the printer you have selected; if this can not be determined, you will be prompted to select one 
or to use the Windows printer engine. 
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ArcPress will now only show the output resolution(s) supported by the printer you have selected. This will 
eliminate any errors in selecting an unsupported output resolution. 
 
ArcPress 9.0 now includes a "Save Paper" option. This will force a rotation on the print out if it will fit on the 
printer paper. Note: If you are printing to a printer that is wider than 36" (for example, the HP DesignJet 5500)  
and it is loaded with 36" and you select Save Paper while printing an E/AO-sized map, the map may clip when 
printed because there is no way to detect what width paper you have loaded in the printer. 
 
The color adjustment options have also been improved for 9.0. They include Gamma, Brightness, Contrast and 
Saturation. A preview image is included to help visualize the changes. NOTE: color adjustments effect the total 
map. You cannot adjust the raster and/or vector data separately. 
 

 
 
- Gamma: this allows you to adjust the total color by using display gamma units. The default is set to 2.2. 
 
- Brightness: Based on the Hue-Lightness-Saturation model, brightness adds or subtracts a percentage of 

lightness to each pixel's color in the map. 
 
- Contrast: Changes the contrast between 0% and 200%. This percentage of contrast is applied to each pixel of 

color in the entire map on output. 
 
- Saturation: Based on the Hue-Lightness-Saturation model, saturation adds or subtracts a percentage of 

saturation to each pixel's color in the map. 
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StreetMap Extension 
 

At 9.0, we've renamed the 'StreetMap USA' extension to be the 'StreetMap' extension. We've made the 
extension name generic because the extension is now designed to support additional street datasets as well. As 
part of this change, we have dropped the separate StreetMap Europe extension product from ArcGIS at 9.0. 
Instead of having separate StreetMap extensions for different street datasets, our new model is that the single 
generic StreetMap extension provides the underlying support for whatever StreetMap data products become 
available.  
 
At 9.0 the ArcGIS StreetMap extension includes the StreetMap USA data from ESRI. The term "StreetMap USA" 
now only refers to the name of the US dataset we have created to be used with the ArcGIS StreetMap 
extension.  
 
ESRI envisions that in the future, ESRI distributors and other data providers will offer their own StreetMap 
datasets that can plug into and be used directly by the ArcGIS Desktop products (ArcInfo, ArcEditor, and 
ArcView) through the ArcGIS StreetMap extension.  For information on additional data options, consult your 
local distributor, or data provider. 
 

The ability to define a composite address locator that references multiple address locators and chains them 
together, which was part of the discontinued StreetMap Europe extension product, is a now a generic out-of-the-
box feature in core ArcGIS 9.0. ('Address locator' is the term used at 9.0 for what were called 'geocoding 
services' at 8.3). With a composite address locator you can perform 'one pass' geocoding using multiple address 
locators and their reference data. This lets you use separate address locators for different geographic areas or 
different levels of detail to provide custom 'fall back' strategies to maximize the number of addresses that can be 
successfully geocoded.  
 
StreetMap extension users can take advantage of composite locators. For example, the StreetMap USA 
address locator can be included in a composite address locator so that geocoding can be performed against 
StreetMap USA reference data and additional datasets in one pass.  
 
When you define a composite address locator you also can define selection criteria that control when particular 
address locators that participate in the composite locator will be used when you geocode. For example, a 
composite locator can be defined so that if the Country field in an address is equal to "USA", the address will 
geocoded by the StreetMap USA locator, but Canadian addresses will be sent to a different locator. 
 

In 8.x you could improve the appearance of your maps by turning on the symbol level advanced drawing 
options to take advantage of ArcMap's ability to 'join and merge' multi-layered symbols, such as those used for 
cased road and street symbology in the StreetMap USA group layer. At 9.0, this symbol level drawing 
functionality has been improved and symbol level properties are now defined at the layer and group layer level, 
rather than at the data frame level as in 8.x. This makes it much easier to use the StreetMap USA 9.0 group 
layer (both the standalone layer .lyr file and the group layer that's in the StreetMap USA map document .mxd), 
because the group layer now contains pre-defined, ready-to-use symbol level properties.  
 
In addition, at 9.0 symbol level drawing is now enabled by default for the StreetMap USA group layer: you no 
longer have to enable symbol level drawing manually when working with the layer. This means that you'll now 
see correctly 'joined and merged' cased line symbols out-of-the-box when you use the StreetMap USA .lyr and 
.mxd files.  
 

At 9.0, we've introduced route finding capabilities into StreetMap. You'll find the new Find Route command 
on the new StreetMap toolbar in ArcMap:  
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After installing ArcGIS, you can turn this toolbar on in the usual way by going to the View > Toolbars menu. The 
toolbar contains one command. The dialog launched by this command enables you to define the stops you wish 
the route to visit, find the best route, and then add the resulting route to your map as a graphic or shapefile-
based layer. You can define stops by entering addresses, using an interactive tool, or getting existing point 
graphics or point features on your map: 
 

 
 
You can choose between finding the quickest or the shortest route, and whether the stops are visited in the 
order you define or in an optimized order determined by the program to minimize the route. This dialog has the 
same look and feel as the Find Route dialog that comes with two existing ESRI products: ArcGIS Business 
Analyst extension and the ArcWeb Services For ArcGIS toolbar.  
 

What's new in the StreetMap USA dataset at 9.0.  
 
At 9.0 the data is delivered on a combined ESRI Data & Maps / StreetMap USA DVD. This contains all the 
StreetMap USA data as well as all the Data & Maps vector data. The StreetMap USA streets dataset was in 
StreetMap Feature Class/EDGE (*.edg) format at 8.3. It is now in SDC (Smart Data Compression) data format. 
SDC feature datasets and feature classes are shown with orange icons in ArcCatalog. 
 
Many updates were made to the values in the highway numbers field to create better highway connectivity in the 
streets data set. The StreetMap USA map document (.mxd file) has also been enhanced to include improved 
supporting basemap data. 
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Other software available separately 
 
ArcGIS Engine 
 
New at 9.0. ArcGIS Engine is a powerful collection of embeddable mapping and GIS components for creating 
and deploying custom GIS and mapping desktop applications. The ArcObjects software components provided in 
the product can be called from various programming interfaces such as .NET, Java, common object model 
(COM), and C++.  ArcGIS Engine consists of a software development kit and a redistributable runtime. In 
addition, application functionality can be extended by using optional functionality from ArcGIS Spatial Analyst, 
ArcGIS 3D Analyst, and ArcGIS StreetMap products.  
 

    
 
More information: http://www.esri.com/arcgisengine
 
 
ArcGIS Server 
 
New at 9.0. ArcGIS 9 introduces a new technology for supporting enterprise geographic information system 
implementations. ArcGIS Server is a GIS enterprise application server for deploying server-based GIS services 
and applications throughout an organization or over the Internet. ArcGIS Server is the first GIS enterprise 
application server that implements GIS business logic and centralized GIS processing in an information 
technology (IT) standards-based server environment. Supports key standards (Java, C++, .NET, COM, XML, 
SOAP and HTTP). 
 

    
 
More information: http://www.esri.com/arcgisserver

http://www.esri.com/arcgisengine
http://www.esri.com/arcgisserver
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ArcWeb Services for ArcGIS 
 
ArcWeb Services for ArcGIS enable you to access terabytes of rich content and capabilities without having to 
store or maintain the data yourself. The offered data comes from many of the world's leading commercial data 
publishers and, since you access it over the Web, it is always up-to-date. New functionality is provided in 
ArcMap based on these services, including: 
 
- Perform multi-point routing on street maps and obtain driving directions. 
 
- Get reports about any location you click on, such as census and flood statistics. 
 
- Display and query custom point databases that have been uploaded to an ESRI-hosted server. 
 
- Find places with a world gazetteer. 
 

   

   
 
Start by downloading the free ArcWeb toolbar. This will give you a free 30 day evaluation of everything offered 
by ArcWeb Services For ArcGIS. 
 

 
 
More information: http://www.esri.com/arcweb
 
Note: Version 1.1 of the ArcWeb toolbar works with ArcGIS Desktop 9.0. Version 1.0 works with 8.3 only.  

http://www.esri.com/arcweb
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Data Interoperability Extension 
 
The ArcGIS Data Interoperability Extension provides read access to more than 70 spatial data formats, including 
GML, XML, AutoDesk DWG/DXF, MicroStation Design, MapInfo MID/MIF and TAB, Oracle and Oracle Spatial 
and Intergraph GeoMedia Warehouse. The extension also provides the ability to export to more than 50 spatial 
data formats.  
 
In addition, the extension provides a semantic data translation engine with 150 specialized transformers to 
diagram and model custom spatial data formats.  These new formats and tools are integrated with the new 
geoprocessing and ModelBuilder framework found in ArcGIS 9.0 to allow easy data format manipulation within 
geoprocessing workflows and models. 
 
More information: http://www.esri.com/software/arcgis/extensions/datainteroperability/index.html

http://www.esri.com/software/arcgis/extensions/datainteroperability/index.html
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