Representations Tutorial
Exercise 1: Learning the fundamentals of representations 2
Exercise 2: Interacting with representation properties 8
Exercise 3: Performing edits with representations 18
Exercise 4: Working with free representations 24
Exercise 5: Using geoprocessing tools for representations 30
Representations Tutorial

In this tutorial, you will be introduced to representations, which allow you to symbolize geographic features with a set of rules that are stored with your data in the geodatabase. Representation rules can create and draw dynamic geometry that differs from the feature shape, allowing a complex depiction of features without impacting the spatial integrity of your data. Representations provide greater control over the precision and definition of the symbolization of your data.

A set of representation rules is collectively known as a feature class representation. Together, these rules define one way to symbolize the features of the feature class to which they belong. A feature class can support many feature class representations, thereby storing multiple ways to visualize its features for use on a variety of maps. Layers can be symbolized using the Representation category, which will access all the representation rules of a feature class representation present on the source feature class. An intuitive interface controls the rules in the feature class representation and the properties of each of those rules.

The easiest way to create a set of representation rules is to convert existing layer symbology to a feature class representation. Each symbol in the layer will become a representation rule in the new feature class representation. Rules can then be added or modified. Alternatively, a feature class representation and its associated rules can be built from scratch on the feature class in ArcCatalog™. An integer field is added to the feature class to link each feature to a representation rule.

Situations may arise where exceptions must be made to the rules to properly portray certain features on your map. Rather than break a rigid structure, each property of the representation rule can be overridden in a manageable way. Overrides are also stored with the data in the feature class, and the link to the rule is not broken. Overrides are edits that are made to feature representations inside an edit session using a set of representation editing tools. In extreme cases, the link to the rules can be broken altogether, and an independent free representation graphic can be created and manipulated. Although still spatially referenced, free representations no longer follow the rule structure dictated by the feature class representation.

This tutorial is composed of five exercises in which you will learn:

- The fundamentals of symbolizing data with feature class representations
- Ways to work with and modify representation rules
- How to override the representation rules for individual features
- How to work with free representations
- How to automate mapmaking processes with representation geoprocessing tools
In this exercise, you will examine a map that needs to be updated with new symbology. You will use feature class representations to do this. Feature class representations give you greater flexibility and control of your map symbology by storing complex, rule-based symbols in the geodatabase along with the map data. You will learn different ways to create a feature class representation within a geodatabase and how to convert symbolized layers into feature class representations.

Creating and modifying feature class representations require an ArcEditor™ or ArcInfo® license. You will need at least an ArcEditor license to complete the steps of this tutorial.

You might want to begin by copying the tutorial data to a local directory to which you have write access. These exercises modify the databases provided to you, so you should make backup copies of them before you begin so you or someone else can follow the tutorial in the future. C:\ArcGIS\ArcTutor\Representations is the default location for tutorial data.

Creating feature class representations in ArcMap

1. Start ArcMap™ from the Programs list on your Windows Start menu.
2. Open Exercise_1.mxd from C:\ArcGIS\ArcTutor\Representation\Exercise_1.
   You are looking at a topographic map of Austin, Texas. This map contains layers that are already symbolized for you. You will use representations to update and improve some of the symbology.
3. Right-click the RoadL layer in the table of contents (TOC) and click Convert Symbology to Representation. The Convert Symbology to Representation dialog box opens.
4. Examine all the default settings and click Convert. The Representation Name property is automatically populated with the name of the feature class plus _Rep. The RuleID Field is the name of the field that will store an integer value for a feature that references a particular representation rule that dictates how it will be symbolized. The default name for this field is RuleID. The Override Field is the field that stores any overrides to a representation rule for a feature. It is a BLOB field type. The default name for this field is Override. The Behavior When Representation Geometry Is Edited property tells ArcGIS where to store geometry edits made with the representation editing tools. These changes can be stored in either the Override field or the Shape field of the feature class. The new layer (RoadL_Rep) is added to the TOC. The original RoadL layer (symbolized with unique values) is still in the TOC below the RoadL_Rep layer.

5. Hold down the Ctrl key and click any check box in the TOC to turn all layers off. Check the RoadL and RoadL_Rep layers. Toggle these two layers on and off using the check boxes to visually compare how they are symbolized. You may want to zoom and pan in the map to see the differences and similarities.

6. Hold down the Ctrl key and click an empty check box in the TOC to turn all the layers on again.

7. Repeat steps 3 and 4 for the following layers:
   - RailroadL
   - TrailL
   - HydroL
   - BuildingA
   - WetlandsA

8. When you have finished comparing the new layer to the original layers, hold down the Ctrl key and click the seven original layers in the TOC to select them. Right-click one of the selected layers and click Remove to delete these layers from the map. Only the layers symbolized by representations (with _Rep suffixes) will remain.

Symbolizing layers with representations in ArcMap

1. Click the Add Data button and navigate to the BuildingP feature class (inside Representations_1.gdb, TopographicMap feature dataset). Click Add on the Add Data dialog box to add the feature class to the TOC.

3. Click the Symbology tab.
   You will see that the default renderer for newly added features in ArcMap is the Categories option. You will also see that there is a Representations option. This option is only available when a feature class has representations.

4. Click Representations in the Show list on the dialog box. You will see a list of the available feature class representations for BuildingP_Rep.

   ![Layer Properties dialog box]

   The Point Buildings representation rule is shown with its properties.

5. Click OK to close the Layer Properties dialog box.
   The buildings on the map are symbolized with the black square defined in the BuildingP_Rep representation.

6. Click the BuildingP feature layer in the TOC to select it. Click it again to highlight the name. Rename it by typing “BuildingP_Rep” to indicate to yourself that it is symbolized with representations.

7. Right-click the BuildingP_Rep feature layer and click Open Attribute Table.

8. Scroll right, if necessary, to see the Angle field.
   The Angle field contains values that define the angles of the buildings as they appear on the ground, relative to either geographic or arithmetic orientation. Although buildings are typically captured and modeled as simple point locations for topographic maps at this scale (1:24,000), it is cartographically desirable to portray them at their true orientation. You will use the values in this field to orient building symbols later in exercise 2 of this tutorial.

9. Close the attribute table of the BuildingP_Rep dialog box.

   **Preparing a feature class for a new representation in ArcCatalog**

   When working in ArcCatalog, you may want to create new representations for a feature class using existing symbology that you are familiar with. In ArcMap, the Layer Properties dialog box provides this information, whereas in ArcCatalog, the information about symbology is derived from a layer file. You can create layer files for your feature classes with symbology of your choosing for those times when you choose to create representations in ArcCatalog. In ArcCatalog, you can accomplish this through
ModelBuilder™, at the command line, with a script, with the Add Representation tool, or through the Feature Class Properties dialog box.

Create a feature class representation in ArcCatalog

1. Exit ArcMap and start ArcCatalog.
2. Right-click the feature class RoadP (inside the TopographicMap feature dataset, in Representations_1.gdb) in the Catalog tree and choose Properties.
3. Click the Representations tab on the Feature Class Properties dialog box.
   The list is empty because the RoadP feature class does not have any feature class representations. You will add one now.
4. Click New.
   The New Representation wizard opens. Note the similarities between this dialog box and the Convert Symbology to Representation dialog box in ArcMap you used earlier in this exercise.
5. Keep the default name RoadP_Rep and the default field names RuleID and Override.
6. Check the box to import representation rules from a layer file. Navigate to the RoadP layer.lyr in the Exercise_1 folder.
   You can import rules from any layer file. Checking this box allows you to choose where your representation rules come from.
7. Check the box to Assign rules to the features that match the layer file.
   This option is only available when the layer file you are importing rules from has the same source as the current feature class. Checking this option will assign representation rules to individual features.
   Your dialog box should look like the one below.
8. Click Finish.
   The new RoadP_Rep feature class representation appears on the Representations tab of the Feature Class Properties dialog box.
Examining feature class representation properties in ArcCatalog

1. With the Feature Class Properties dialog box still open, click RoadP_Rep on the window to select it, then click Properties.

   The Feature Class Representation Properties dialog box opens.

2. Click the General tab if necessary.

   The General tab shows the name of the feature class representation and the two field names, as well as the geometry editing behavior setting. This setting and the name of the feature class representation can be changed from this pane, but for this exercise, leave them as is.

   You can use the '?' button at the top of the dialog box to click any item on this menu to learn more about the components of feature class representations.

3. Click the Representation tab.

   This tab lists the representation rules that are part of the RoadP_Rep feature class representation, which currently has only one representation rule, Rule_1, that has the same black square symbol you applied to RoadP_layer.lyr.

   **Note:** You will notice that the symbol size is now 2.72 points instead of 4 points as before the conversion. Before conversion, the symbol was a character marker symbol. These symbols are stored as glyphs in a font. The envelope of the glyph is 4 points in size, whereas the symbol inside the envelope is actually 2.72 points. The symbol has converted correctly into a representation, even if the numbers seem unexpected. When you are in ArcMap, you can switch back and forth from the Representation renderer to the Features renderer to see that the new and old symbols are the same size.

4. Click the name of the representation rule, Rule_1. Once the text is selected, type “Road Caps” to rename the representation rule.

5. Click OK to close the Feature Class Representation Properties dialog box.

6. Click OK to close the Feature Class Properties dialog box.

7. With the RoadP feature class still selected in the Catalog tree, click the Preview tab and choose Table from the pull-down menu.

8. Examine the attribute table to see the two new columns that have been added: RuleID and Override. The RuleID field stores the numeric values associated...
with representation rules, in this case, representation rule 1. The Override field will store any feature-level exceptions you make to the representation rules during editing.


10. If you want to proceed to the next exercise, leave ArcMap open.

**Congratulations, you’ve completed exercise 1.**

Things created and accomplished in this exercise
- Created a layer for use in a representation
- Changed symbology for a layer in ArcCatalog
- Created a feature class representation in ArcCatalog
- Added a new representation
- Symbolized a layer with a representation in ArcMap
- Renamed a representation in symbology
- Converted symbology to representation in ArcMap
In this exercise, you will work in ArcMap to understand how to interact with feature class representations and how representation rules drive the way features are displayed on a map. You will start by learning how to add a representation rule to one of the feature class representations you created in exercise 1. You will learn to interact with marker, stroke, and fill symbology as defined by representation rules. You will learn how to modify representation rules by adding and modifying symbol layers and geometric effects.

As you work on this exercise, keep in mind that parameter values cannot be changed on the Layer Properties dialog box when an edit session is open. Parameter values can be set by the user or mapped to an explicit field.

**Examining representation rules**

1. Start ArcMap if necessary.
2. Continue with the map document from exercise 1 or open Exercise_2.mxd.
3. Ensure that the Editor and Representation toolbars are visible. If not, click the View menu, point to Toolbars, then check Editor and Representation.
4. Double-click RoadL_Rep in the TOC to open the Layer Properties dialog box.
5. Click the Symbology tab.
6. The RoadL_Rep layer is symbolized with the RoadL_Rep feature class representation, which contains four representation rules.
   These four rules have been translated from the four symbol categories present in the original symbolized layer from which the feature class representation was derived.
7. Click the third representation rule, Class 2, in the list. The right side of the dialog box shows the properties of that representation rule.
   The Class 2 representation rule consists of three stroke symbol layers, indicated by the three stacked tabs showing a stroke squiggle.
8. Click the first (topmost) stroke tab in the list of symbol layers.

This symbol layer includes the Dashes geometric effect to place red solid lines in alternating intervals along the linear geometry of the feature. This symbol layer is at the top of the symbol layer stack for this rule, so it is the last to draw and therefore appears above the other two symbol layers.
9. Click the second, then the third stroke symbol layer tabs in this representation rule.

Neither of these symbol layers includes a geometric effect. The bottommost symbol layer is a solid, thick black line and is the first to draw. The second symbol layer is a slightly thinner, white line. Together they give the appearance of a cased line symbol.

10. Click OK to close the Layer Properties dialog box.

11. Repeat steps 4 through 10, if desired, to see how other symbol categories were translated into representation rules when you created feature class representations in exercise 1.

**Adding new representation rules**

1. Click View>Bookmarks>1) Buildings.

2. Double-click BuildingP_Rep in the TOC to open the Layer Properties dialog box.

3. Click the Create New Rule button to add a new representation rule to the BuildingP_Rep feature class representation.

4. Click the Layer Options button and point to Units. Choose Points as the unit of measurement for the symbols.

5. Click the name of the new rule, Rule_2, to select it. Type “New Buildings” to rename it.

6. Inside the marker symbol layer, click the black square representation marker.
The Representation Marker Selector dialog box opens.

7. Click Properties.
   The Marker Editor opens with the black representation marker filling the canvas.
8. Use the Select Part tool to select the representation marker.
   A representation marker is made up of symbol layers and geometric effects just as representation rules are. This representation marker consists of a single fill symbol layer, filling the square with solid black.

9. Click the swatch next to the Color property in the fill symbol layer and choose a red from the palette that opens.
   The representation marker turns red.
10. Click OK to close the Marker Editor, then click OK to close the Representation Marker Selector dialog box.
11. Click the Size property text box. Type “2” and press Enter.
   The New Buildings representation rule is now symbolized with a marker symbol layer containing a 2-pt red square.
12. Click OK. A Warning dialog box appears. This warning is to let you know that the changes you are making to a rule will be stored in your database.

Click OK and view the results. Notice that the points are still symbolized with the default symbol. They are symbolized this way because their values in the RuleID field are all set to 1.

**Applying new representation rules to features**

1. Right-click the BuildingP_Rep layer in the TOC, point to Selection, then click Make This The Only Selectable Layer.

2. Start editing.

3. Select some of the buildings in the current view using the Select tool located on the Representation toolbar.

4. Open the Representation Properties dialog box using the button on the Representation toolbar.
5. Click the Representation rule pull-down list and choose New Buildings to apply to all the selected buildings.

6. Close the Representation Properties dialog box, save your edits, then stop editing.

7. Open the layer properties of BuildingP_Rep.


9. On the dialog box for Angle, type “45” for the angle value.

10. Click Apply and move the dialog box to see the changes.

Note that all buildings following this representation rule are now angled 45 degrees from horizontal.

11. Click the Display field overrides button. This will make the Angle parameter find its values from within the database.

Now you will learn how to set unique angle values for each building.
12. Choose the Angle field from the pull-down list to be the explicit field for the angle parameter.

Adding geometric effects to representation rules

According to new specifications for the map, the symbol for trails must change to a double dashed line instead of the single black line as found in the old map. To accomplish this task, you will add some geometric effects to the representation rules. Adding geometric effects does not alter the underlying geometry of your features; rather, they allow you more control over the way your features are symbolized.

1. Click View>Bookmarks>2) Trail and Swamp.

2. Make TrailL_Rep your only selectable layer.
3. Open the layer properties for TrailL_Rep.
4. Click the representation rule named Trail and click the stroke symbol layer.

13. Click OK.

Note that the buildings are now angled according to the values stored in the Angle attribute field of the data.
5. Click the (+) button to see the Geometric Effects dialog box.

6. Click Line input, then click Offset curve.

7. Click OK on the Geometric Effects dialog box to add a new dialog box to the stroke symbol layer, labeled Offset curve, as shown above.

8. In the Offset text box, type “0.5” for the value.

9. Add a new stroke layer to this representation rule by clicking the Add New Stroke Layer button as shown below. Notice that a new layer is added to the rule.

10. Type “0.5” in the Width text box.

11. You will now add a Line to Line Offset Curve effect to this new stroke layer, just as you did before in steps 5 and 6.

12. For this stroke layer, however, type “-0.5” in the Offset text box.

13. Click Apply to see the result on the map.
Geometric effects can be added to an individual symbol layer in a representation rule as you have just seen above. They can, however, be applied to all layers as well. To apply a geometric effect to all the symbol layers in a representation rule, it must be added as a global effect. You will learn how to make this happen.

14. Click the top-level tab to open the Global Effects dialog box. You will see a message indicating that there are no global effects at this time.

15. Click the (+) button on the right side of the dialog box to open the Geometric Effects dialog box.

16. Choose the Dashes geometric effect from the Line input section and click OK.

A new dialog box will be added to the Global Effects section of the representation rule. Note the default values provided for dash pattern symbology.

17. To change the values, type “3 1” in the Pattern text box. Be sure to include a space between the two numbers.

18. Click OK to see the result.

Notice that global effects override individual layer effects.
Adding markers to polygon symbology

1. Open the layer properties for WetlandsA_Rep.
2. Choose the swamp representation rule.

   In the original map, swamps are symbolized simply with the color Sodalite Blue. You will add a marker symbol layer to the representation rule to make the swamp symbology more user-friendly.

3. Click the Add new marker layer button.

Notice that a default symbol has been provided.

4. Click the square marker as shown above to open the Marker Selector dialog box.
5. Click the Swamp symbol from the Representation Marker Selector dialog box.

6. Click OK to close the Representation Marker Selector dialog box.

7. Type “3” in the Size text box to change the size.

   Notice that there is a Polygon center label in the marker layer. This is the default marker placement location. In this case, there would only be one marker added to the polygon. Instead, you will need to change the marker placement to something that puts a series of markers across the polygon.

8. Open the Marker Placements dialog box by clicking the arrow next to the placement label.
9. Locate the Polygon input category and choose Randomly inside polygon.

10. Click OK to close the Marker Placements dialog box.

11. Click OK to close the Layer Properties dialog box.

You can now see that there is a pattern of random swamp symbols.

12. If you want to proceed to the next exercise, leave ArcMap open.

13. If you want to return to this tutorial later, save this map document as Exercise_two.mxd and exit ArcMap.

Congratulations, you’ve completed exercise 2.

Things created and accomplished in this exercise
• Adding a new rule to a feature class representation
• Setting only one selectable layer
• Editing representation properties
• Choosing the type of unit measurement
• Interacting with the Representation Properties dialog box
• Mapping representation rules to explicit fields
• Adding a new marker layer to a representation rule
• Interacting with the Marker Placements dialog box
• Using the Marker Editor & Marker Selector dialog boxes
• Changing properties of a marker layer
• Adding a new stroke layer to a representation rule
• Changing properties of a stroke layer
• Interacting with the Geometric Effects dialog box
• Adding the Offset curve geometric effect & Dashes geometric effect
• Changing properties of geometric effects
• Adding global effects
Exercise 3: Performing edits with representations

Exercise 3 is about the editing experience. By editing feature representations, you will learn the impacts of modifying shapes and representation parameters and how they become overrides to the representation rules. You will interact with the selection and editing tools and see how both the appearance and properties of representations are changed.

In this exercise, you will be working with geometry and symbology overrides. The premise of the exercise is to show how edits can be made to representations without changing the underlying geometry of the features involved. You will note that when performing edits with Representation tools, there is “What you see is what you get” feedback. You can see what your edit will become before you release the mouse button.

Note: The results from your edits do not need to perfectly match the results pictured in the graphics of this tutorial. The goal is for you to get used to the expected behavior of the Representation editing tools. Practice with all the tools until you feel comfortable.

Editing feature representations

1. Continue with your current map document from exercise 2 or open Exercise_3.mxd found in the Exercise 3 folder.
2. Add the Representation toolbar and the Editor toolbar if they are not already present.
3. Click View>Bookmarks>3) Area Building.
4. Make BuildingA_Reps your only selectable layer.
5. Start editing.
6. Using the Select tool on the Representation toolbar, select the new building.

Note the rectangular selection box around it.
7. Rest the mouse pointer on any corner handle and when the cursor becomes an arrow, click and drag the arrow to resize the building.

**Note:** When resting the mouse pointer, the corner is very sensitive; you may see the tool change from an arrow symbol to a rotate symbol.

8. Once again, rest the pointer above a corner handle until the cursor becomes a curved arrow. Click and drag to rotate the building.

9. Click the Direct Select tool on the Representation toolbar.

Notice how the selection rectangle is no longer visible but the vertices defining the outline of the building are all selected. Hint: You can tell by the solid blue fill present in all the vertices.

10. Select one vertex by drawing a box around the vertex with the Direct Select tool. In this step, the graphic will depict the selection of a vertex in the upper left-hand corner of the polygon. You can select any vertex you like.

When you have done this, you will notice that only your selected vertex has a solid blue fill, while the other vertices have a white fill. This is designed to be a helpful visual clue to assist you when you are in an editing session.
11. Drag the selected vertex away from the others to reshape the feature.

12. Stop editing and save your edits.

13. Add the BuildingA feature class from the location where you have Exercise_2.gdb stored and use the default symbology that appears (your default color may be different). Note that the original shape has not changed even though the representation was edited.

14. Remove the newly added BuildingA feature class.

**Representation Properties dialog box: Drawing tab**

You will now work with the main tab on the Representation Properties dialog box, the Drawing tab. This tab looks just like the Layer Properties dialog box in that it lists the parameters of the representation rule for the selected feature. This dialog box provides an interface for changing the parameter values for your selected feature. The symbol layers in the representation rule for the selected feature cannot be changed.

1. Click View>Bookmarks>2) Trail and Swamp.
2. Make WetlandsA_Rep your only selectable layer.
3. Start editing and select a swamp polygon using the Select tool.
4. Open the Representation Properties dialog box to examine your selected feature. You will now create an override of the background color of the swamp.
5. Click the Color box below Solid color pattern. Choose any green color you like.

All other swamps in the map still follow the original rule, but this particular swamp has a color override. All other properties of the rule are still followed.
6. Click the paintbrush icon. It disappears and the background color of the swamp returns to blue. The override has been removed.

7. With the swamp still selected, choose the Bog representation rule from the drop-down list. The feature representation now follows the representation rule for a bog and is symbolized accordingly.

8. Click the Representation rule drop-down arrow again and choose Swamp to return the symbol to the original rule.

Keep the Swamp feature selected and the Representation Properties dialog box open as you proceed to the next step.

**Representation Properties dialog box: Tools tab**

You will now work with the other tab on the Representation Properties dialog box, the Tools tab. This tab lists geometry and other drawing properties of the selected feature or features that can be modified with the use of the currently selected representation edit tool. Any combination of geometry and drawing properties can be modified simultaneously using the current tool simply by checking the properties you want on and off.

The list of available properties varies with the representation edit tool that is currently selected. Any modifications to drawing properties made in this way will become overrides for the representation. Modifications to the geometry will be stored either in the Override field of the feature class if the representation was created with that option (as it was for this exercise) or in the Shape field if that option was chosen when the representation was created.

As you can see below, when features are selected, the Tools tab will indicate which representation edit tool is currently selected. When there is no representation edit tool selected, the Tools tab will appear as it does below left. For example, when the representation Resize tool is selected, the Tools tab will appear as it does below right.

Once you have completed this section of the exercise, you can return to the Tools tab, if you want, and try different combinations of the check boxes. In this section, you will be working with the Resize tool, and the goal is to change the appearance of the pattern symbology used in the Swamp
representation rule.

The X step and Y step properties determine the pattern of
the marker symbols as they appear within a polygon, where-
as the Size property determines the size of the marker sym-
bol. The Geometry property determines whether the shape
of the feature is adjusted. Keep in mind that changes to the
underlying geometry of the feature will only occur if your
representations were created with that option. Otherwise,
changes to the shape will be stored in the Override field.

1. Click the Tools tab on the Representation Properties
dialog box.
2. Click the Resize tool on the Representation toolbar.

For the swamp feature representation, you will see that
the parameters for Size, X step, and Y step are selected
by default. Leave these as they are and make sure the
Geometry option is unchecked.

This way, you will only resize the markers and not the
polygon.

Before:

3. Click and drag the Resize tool anywhere near (or on)
the swamp. As you drag the mouse pointer, you will see
a line to guide your change and see the swamp symbol
dynamically change. When you are satisfied with the
changes you have made, release the mouse button.

Note: Your result may vary dramatically from the one
depicted in this exercise—this is OK and should be
expected. The movement you make with your mouse
will be reflected on screen. Keep in mind that even a
little bit of movement can make larger than expected
changes on screen.

After:
The pattern of swamp symbols will become more or less dense, depending on the direction you dragged. The density is based on the X step and Y step parameter values. The size of the swamp symbol will be different after you have finished dragging the Resize tool. The Size parameter value is the basis for the size of a symbol.

4. Click the Drawing tab on the Representation Properties dialog box to see the overrides that you’ve just created. Note that the X step and Y step parameters have the paintbrush icon adjacent to them, indicating an override.

**Note:** Your results may vary and do not have to match.

5. Save your edits, then stop editing.

6. If you want to proceed to the next exercise, leave ArcMap open.

7. If you want to return to this tutorial later, save the map document as Exercise_three.mxd and exit ArcMap.

**Congratulations, you’ve completed exercise 3.**

Things created and accomplished in this exercise

- Resizing features using the Select tool
- Rotating features using the Select tool
- Reshaping features using the Select tool
- Reshaping features using the Direct Select tool
- Using the Drawing tab on the Representation Properties dialog box
- Using the Tools tab on the Representation Properties dialog box
- Creating an override
- Removing an override
- Using the Resize tool
Free representations are a powerful and flexible way to display complex features, but they need to be approached carefully. In exercise 4, you will learn how to make and modify a free representation to accommodate a complex cartographic challenge that cannot be accomplished using existing representation rules. A free representation is for a feature or a complex symbol that only appears once on a map. As such, it does not warrant an entire rule to itself. The choice to use free representations is made after you have answered no to the following questions:

Does standard ArcMap symbology achieve the result I want?

Does a representation rule help achieve the result I want?

Do geometric effects help achieve the result I want?

Do overrides help achieve the result I want?

For example: You want to change the shape and color of a single dash in a linear symbol.

ArcMap symbology will make the dashed line symbol, but you have very limited control over the dash pattern itself and no ability to change an individual component of a dash pattern.

A representation rule gives you control over a line with geometric effects that dynamically change the geometry of the line. Geometric effects provide you with control over the size of the dash pattern at any point along a line but no control over an individual dash.

Overrides provide further control over the representation property values of a single feature, but you still do not have control over the behavior of an individual dash.

As a representation rule, a dashed line is really a single line that is dynamically dashed. A free representation allows you to take control of the dynamic parts of the symbol by converting each dash into a unique geometry. You now have complete control over individual dashes.

The choice to create a free representation should not be taken lightly. You need to determine what you want from your symbology before creating a free representation.

In this exercise, you will work through two examples in which the creation of a free representation is beneficial to the symbology of the map. The first example will guide you through the dashed line scenario discussed here, and the second example will guide you through a scenario in which a new feature is created without being added as a new feature in the database. You will also learn how to use the Free Representation Editor.

Free representations—Example

In this example, you will learn how to interact with individual components of a symbol.

1. Continue with your current map document from exercise 1, 2, or 3 or open Exercise_4.mxd from the Exercise 4 folder.
2. Add the Representation toolbar and the Editor toolbar if they are not already present.
3. Click View>Bookmarks>4) Hiking Path.
4. Open the layer properties for TrailL_Rep.
5. On the Symbology tab, click the rule, Hiking Path.
   You will notice that the rule is composed of a single
stroke symbol layer with two geometric effects, Add control points and Dashes. The geometric effect is designed to place a dash pattern at sharp corners on the line.

6. Click OK to close the Layer Properties dialog box.

**Creating free representations**

1. Set TrailL_Rep as the only selectable layer.
2. Start editing and select a section of the Hiking Path with the Select tool.
3. From the drop-down menu on the Representation toolbar, click Free Representation and click Convert to Free Representation.
4. Open the Representation Properties dialog box and click the Drawing tab to see how a free representation is described in detail.
Examine the contents of the Drawing tab. The feature still has a representation rule only now it is a rule that is independent of the feature layer. Since it is an independent rule, your only access point to the rule is through the Representation Properties dialog box. The interface options are all the same as shown on the Layer Properties dialog box, but the rule you work with is only applied to the selected feature.

To begin working with individual components of a dashed line, you will need to convert the rule into separately editable pieces.

5. Close the Representation Properties dialog box.
6. From the drop-down menu on the Representation toolbar, click Free Representation and click Convert Effect to Geometry.

This will convert the dynamic dashes from the geometric effect to actual geometry that you can edit.

7. From the drop-down menu on the Representation toolbar, click Free Representation and click Ungroup Elements.

8. Zoom in to the topmost section of the selected feature.

9. Clear the selected features and select a new segment with the Select tool.

10. Open the Representation Properties dialog box.

Note that the entire line has been selected. This is a result of the Select tool acting as designed by selecting the multipart geometry of the line. As a representation rule, the line geometry was dynamically dashed but remained a single-line geometry. As a free representation, you have converted the single line into a multipart line and ungrouped the multipart line to
interact with individual dashes.

11. Clear the selected feature and select a segment with the Direct Select tool.

The Representation Properties dialog box now shows the selected segment. Each segment is treated as a separate rule.

12. Move the segment you have selected.

13. Use the Direct Select tool to select two vertices of a new segment.

14. Use the Direct Select tool to move the selected vertices.
15. Select another segment with the Direct Select tool.

16. Type “2” in the Width text box to resize the segment.

17. Select another segment with the Direct Select tool.

18. Click the color palette to choose a new color for the segment.
19. Clear your selected features.

You can now see that with a free representation, you can edit individual components of a single feature. It can be time consuming though, so free representations should be carefully considered before you incorporate them into your work. The reasons that you make the type of editing sessions detailed above will be your own and will vary from case to case. The key factor to remember is that you have the ability to make these types of changes.

- Ungrouping elements
- Selecting segments with the Direct Select tool
- Editing segments
- Adding a symbol layer to the free representation rule
- Editing in the Free Representation Editor
- Separating symbol layers

Congratulations, you’ve completed exercise 4.

Things created and accomplished in this exercise

- Adding Control Points and Dashes geometric effects
- Converting features to free representations
- Converting effects to geometry
Exercise 5: Using geoprocessing tools for representations

In exercise 5, you will learn how to use the geoprocessing tools for representations and gain insight into what tasks each of the tools can perform. The geoprocessing tools are used for the automation of tasks that would normally be performed manually. For this exercise, the tools will be run from an ArcCatalog session. Although the tools perform the same tasks in ArcMap, there are two key differences.

The first is the type of inputs accepted by the tool. In ArcCatalog, the geoprocessing tools for representations require a layer file as the input type, whereas in ArcMap, the tools accept either layer files or feature layers. The distinction is the location where the tool derives information about symbology. In ArcMap, the layer properties provide this information; in ArcCatalog, a layer file is used to provide that information.

The second difference is the spatial reference parameters required by the geoprocessing tools to complete, namely, the coordinate system and reference scale. In ArcMap, these inputs are derived from the data frame, whereas in ArcCatalog, these inputs are derived from the Cartography Settings on the ArcToolbox™ Environment Settings dialog box.

This exercise simulates a hypothetical workflow used in a map production environment. You will use the geoprocessing tools to add representations to selected feature classes, set the type of line caps for road features, add control points to roads and rivers to control their dash patterns, align buildings to roads, create bridges and tunnels, and determine where features are graphically overlapping each other. The tools may take some time to complete depending on the processing speed of your computer.

Using geoprocessing tools for representations

1. Start ArcCatalog and navigate to the Exercise_5 folder. You need to create layer files for some feature classes to use the geoprocessing tools: Right-click each feature class and choose Create Layer. Accept the default name and location for the layer file. This will be $\text{:}\text{ArcGIS\ArcTutor\Representations\Exercise_5}$.

   BuildingP (in the TopographicMap feature dataset)
   HydroL (in the Hydrography feature dataset)
   RoadL (in the TopographicMap feature dataset)
   RailroadL (in the TopographicMap feature dataset)

2. After each layer file has been created, open the properties of the layer file and set the renderer on the Symbology tab to Representations.

   Next, you will establish some settings to assist in your use of geoprocessing tools. These settings will control how your data is processed and the location where the results are saved.

3. Start ArcToolbox, right-click ArcToolbox, then click Environments.

4. Click Cartography Settings.

5. Choose Same as Input for the Cartographic Coordinate
System parameter.

6. Type “24000” for the Reference Scale parameter.

7. Click General Settings.

8. For the location of the Current Workspace, navigate to the location where you stored Exercise_5 and choose the TopographicMap feature dataset inside the Representations_5 geodatabase. This will be used as the default location for the output from geoprocessing tools.

9. Click OK to close the Environment Settings dialog box.

**Geoprocessing tools for symbology enhancement**

You will start by using some geoprocessing tools that are located in the Cartography Tools toolbox.

First, you will use a geoprocessing tool to change the line caps on some roads. You will use the Calculate Line Caps tool for this purpose. This tool is found in the Symbolization Refinement toolset.

1. Open the Calculate Line Caps tool.

2. Choose RoadL layer.lyr for the Input Features With Representations parameter.

3. Choose BUTT for the Cap Type parameter.


5. Click OK to run the tool.

Next, you will add control points to the roads and rivers. Control points are designed to enhance the symbology of your features when a linear feature makes a sharp turn. This functionality is useful when it is important to have a continuous pattern of solid dashes at corners.

You will run this tool twice: first on RoadL, then on HydroL. The Set Representation Control Point By Angle tool is located in the Symbolization Refinement toolset.

6. Open the Set Representation Control Point By Angle tool.
7. Choose RoadL layer.lyr for the Input Features With Representations parameter.

8. Type “135” for the Maximum Angle parameter.

9. Click OK to run the tool and run the tool again on HydroL using the same Maximum Angle parameter value of 135.

Next, you will align all the buildings on your map to nearby roads. The tool will select point features within a certain distance of linear features and rotate the points to the angle of the lines. You will run this tool twice: first with BuildingP against RoadL, then BuildingP against HydroL. This tool is located in the Symbolization Refinement toolset.

10. Open the Align Marker to Stroke or Fill tool.

11. Choose BuildingP layer.lyr for the Input Features With Marker Representations parameter and RoadL layer.lyr for the Input Features With Stroke Or Fill Representations parameter.

12. Type “5” for Search Distance. Make sure Points are set as the unit of measurement and PERPENDICULAR is set for the optional Marker Orientation parameter.

13. Click OK to run the tool and run it a second time to align BuildingP layer.lyr to HydroL layer.lyr.

Geoprocessing tools for complex features

You will create symbology for a situation in which you have information about the location for bridges and tunnels but no data. You know from some fields in your feature classes that you have roads crossing over rivers as well as roads and railroads crossing above and below each other. This information tells you that at those locations where two features intersect each other, one feature crosses above the other. For your maps, you want to use this information to create bridge and tunnel symbology.

The Create Overpass tool performs this complicated operation. This tool is located in the Symbolization Refinement toolset. There are a significant number of parameters on this tool, and care must be taken when entering values for all parameters. Some are required, and others are optional.
When the tool is complete, you will be able to symbolize your features in a way that clearly indicates one feature is crossing over the other. This is done using masks to hide one feature and a new linear feature class that provides the bridge or tunnel symbol.

Overall, this tool is designed to follow your lead in making a calculation for where overpasses will be created. You will indicate which features are above other features by setting the first two parameters.

1. Open the Create Overpass tool.
2. Choose RoadL layer.lyr for Input Above Features With Representations and HydroL layer.lyr for Input Below Features With Representations.

Next you will see the tool’s optional parameters. Without these parameters, the tool will complete as expected and create the masks you need to indicate which features cross over others, but it will only create the minimum required parts for overpass and underpass symbology. These optional parameters allow you to indicate how you want the overpass or underpass to look.

You can choose to enter a SQL expression to refine your selection. Without a SQL expression, the tool will process every feature in your feature class. Although there is nothing inherently wrong with this approach, it will take longer for the tool to complete. In this tutorial, the tool will complete in less than 30 seconds. Your computer speed may vary, so the elapsed time could be as long as two minutes.

For example, you may want to place a bridge at every location where a road crosses a river, or your data might not have an attribute field on which to make a refinement selection to make the tool process on a smaller set of data. As shown earlier, a data field indicates where a crossing occurs.

3. Type “2” for Margin Along and type “1” for Margin Across, then choose Points for both from the drop-down lists for the unit of measurement.

Following this, you will select your own locations for the mask feature class (Output Overpass Feature Class) and mask relationship class (Output Mask Relationship Class).

4. Type “Over_FC” and “Over_RC” for the names of the new feature class and relationship class.
5. Click the SQL button to open the Query Builder dialog box.
6. On the Query Builder dialog box, double-click `BridgeCategory` to add it to the SQL expression box, click the = button to add it to the SQL expression box, click Get Unique Values, then double-click the 1 bridge entry to add it to the SQL expression box.

7. Click OK to close the Query Builder dialog box.
8. Type “Bridge_FC” for the name of this new feature class.

9. Choose ANGLED from the drop-down list to indicate the wing type you want to use.

10. Type “1” and choose Points from the drop-down list to indicate the length of the wing ticks for your bridge or tunnel symbol.

Your dialog box should look like the one below.
11. Click OK to run the tool.
When the tool is complete, you will have created two new feature classes and a relationship class to use in your map to display bridges. The mask will be linked to RoadL with the relationship class.

Now you will create some underpasses at the locations where you know that railroads pass underneath roads. The process will be nearly identical to Overpass with a few minor differences, which will be pointed out as you proceed through this section.

12. Open the Create Underpass tool.

13. Choose RoadL layer.lyr for Input Above Features With Representations and RailroadL layer.lyr for Input Below Features With Representations.

14. Type “2” for Margin Along and type “1” for Margin Across, then choose Points in both cases for the unit of measurement.

15. Type “Under_FC” and “Under_RC” for the names of the new feature class and relationship class.

16. For the Expression parameter, click the SQL button and create the expression “RelationshipToSurface” = 3.

17. Click OK to close the Query Builder dialog box.

18. Populate the Output Decoration Feature Class parameter and type “Tunnel_FC” for the name of the new feature class.

19. Choose PARALLEL from the drop-down list for Wing Type.

20. Type “1” for the length of the wing ticks and choose Points for the unit of measurement.
Now that you have populated all the parameter values, your dialog box should look like the following:

21. Click OK to run the tool.

**Geoprocessing tools for finding graphic conflicts**

Now that you have run a series of geoprocessing tools on your data, the final step is to find out where your symbolized data is overlapping. The Detect Graphic Conflict tool will create a polygon feature class that you can use to visually locate incidents of overlap. Use this tool to identify the areas where buildings graphically overlap other buildings. This tool is found in the Graphic Quality toolset.

1. Use BuildingP layer.lyr for both the Input Features With Representations and Conflict Features With Representations parameters.

   The Output Feature Class parameter will automatically populate. Navigate to your data location instead.

2. Type “BuildingP_DGC” to change the name.

3. Type “5” for the Conflict Distance parameter and choose Points from the drop-down list.

4. Type “0” (zero) for the Line Connection Allowance parameter.

   Your dialog box should look like the one below.

5. Click OK to run the tool.
Once complete, you will have a polygon feature class that will indicate where features are graphically in conflict with others.

6. Exit ArcCatalog.

**Examining the results in ArcMap**

1. Start ArcMap.
2. Open Exercise_5.mxd.
3. Add the following feature classes from the TopographicMap feature dataset to the TOC:
   - Over_FC
   - Under_FC
   - Bridge_FC
   - Tunnel_FC
   - BuildingP_DGC
4. For both Bridge_FC and Tunnel_FC, set the symbology to a shade of black and the line width to 1 point. For the other feature classes just added, you can change their symbology to anything you like.
5. Click HydroL_Rep and open the Layer Properties dialog box.
6. Click the Symbology tab, click Layer options, then click Masking.
7. Click the check box for Over_FC.
8. Click OK to close the Advanced dialog box.
9. Click OK to close the Layer Properties dialog box for HydroL_Rep.
10. Click RailroadL_Rep and open the Layer Properties dialog box.
11. Click Layer options and click Masking.
12. Click the check box for Under_FC.
13. Click OK to close the Advanced dialog box.
14. Click OK to close the Layer Properties dialog box for RailroadL_Rep.
15. Make the layers Over_FC and Under_FC not visible.
Viewing the results in ArcMap

When you started exercise 1, your map looked like the one below.

There were no bridges, the buildings were not aligned to the roads, and the dash pattern symbology on the roads was not well developed.

Now that you have run all the geoprocessing tools, your map looks like the following:

1. Click View>Bookmarks> 5) Geoprocessing Results.

   Notice that the dash pattern on the roads has been adjusted, the result of using the Set Representation Control Point By Angle tool. The point buildings are now aligned to the roads, the result of the Align Marker To Stroke or Fill tool. Bridge and tunnel symbology has been added where the road crosses the river and the railroad, and this masks out the river and railroad symbology—all the result of the Create Overpass tool. Finally, the polygons from BuildingP_DGC indicate the areas where point buildings are graphically overlapping each other.

   Congratulations, you’ve completed exercise 5.

Things created and accomplished in this exercise

- Creating layer files in ArcCatalog
- Setting symbology to representations
- Setting environment settings for ArcToolbox
- Using the Calculate Line Caps geoprocessing tool
- Using the Set Representation Control Point By Angle geoprocessing tool
- Using the Align Marker To Stroke or Fill geoprocessing tool
- Using the Create Overpass geoprocessing tool
- Using the Query Builder dialog box
- Using the Create Underpass tool
- Using the Detect Graphic Conflict tool
- Using feature-level masking in ArcMap