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Highlights  

1. Better quality, productivity & documentation 
ArcGIS 9.2 features hundreds of productivity enhancements to make it quicker and easier to get results

across all areas of the product. We've reviewed your feedback and added many frequently requested features. 
A very large number of quality issues have also been addressed. Based on your comments, we've also 
improved the documentation and provided a powerful new search facility in the Desktop help system.  

 

2.  Easier to create & use geodatabase data  
You've asked us to make it easier for you to migrate your data to the geodatabase and deploy multi-user 

geodatabases with the ArcSDE technology. So at 9.2 we've enhanced the geodatabase so everyone can use 
it. We've improved the wizards and dialogs for creating data and eliminated the need to specify spatial 
domains and spatial indexes manually. The new file geodatabase format for single-user databases provides 
better performance than personal geodatabases, works across platforms, and has no overall database size 
limit. New lightweight ArcSDE database servers based on the Microsoft SQL Server 2005 Express Edition 
DBMS mean that anyone can set up a multi-user ArcSDE geodatabase and administer it using ArcCatalog. 

3  Comprehensive enterprise solution for your GIS data assets 
ArcGIS 9.2 lets you manage your enterprise GIS centrally as a strategic asset while making it easy for

people throughout your organization to access data for mapping, queries, visualization, and maintenance, 
including web and mobile access. Replication allows distribution of a single logical database across multiple 
geodatabases in different physical locations, with updates being performed at any location and then 
synchronized to all locations. There are also new capabilities for historical archiving, non-versioned editing, 
high precision cadastral fabrics, and terrain data. New mobile functionality allows devices to update and 
synchronize attributes and features over wireless connections. 

 

4.  Make great looking maps with cartographic representations 
9.2 introduces cartographic representations: a major step forward in digital cartography. Representations 

vastly extend the symbolization capabilities of ArcGIS and allow you to get exactly the look you want without 
having to export your map to a graphics package like Adobe Illustrator. You can store representations in the 
geodatabase for easy update management and re-use in multiple map products. A new suite of cartographic 
editing tools lets you edit the symbology for individual features without changing their underlying feature 
geometry, so special situations and any level of complex detail can be handled. 

5.  Easier to deploy GIS maps & applications over the web  
ArcGIS Server has been significantly improved at 9.2. A new web-based Manager makes it much easier to

administer, and you can publish new services such as high performance cached map services, 3D globe 
services, geoprocessing services, and KML. Application creation has been simplified with a new out-of-the-box 
web mapping application that supports multiple service layer types (ArcGIS, ArcIMS and OGC WMS) in the 
same map, geoprocessing tasks, and web-based editing. People can also access your services with the new 
free ArcGIS Explorer client and combine them with other data sources for visualization and analysis. 

 

6.  More powerful visualization, modeling & analysis 
9.2 gives you new ways to explore your data and communicate the results of your work, and makes it 

easier to understand temporal patterns and trends. There's a powerful new graphing engine, the ability to 
create animations in ArcMap and export them as videos, support for multi-dimensional netCDF data, and 
easier 3D visualization in ArcGlobe. ModelBuilder now supports iteration, looping, specifying layer symbology, 
and interactive input of features. There are many new core geoprocessing tools, a new batch mode, and full 
support for geoprocessing in ArcGIS Server and the ArcGIS Engine Developer Kit.  
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Overview  

Improved documentation 
 

 The 'What is ArcGIS' book has been completely updated and enhanced to tell the ArcGIS 9.2 story. 
 New search facility in the Desktop Help provides faster and more intelligent search. 
 Major improvements to Desktop Help topics including many new topics, animated tutorials, etc. 

 

Easier working with geodatabases 
Easier to create geodatabase data  

 Improved wizards and dialogs make it easier to specify coordinate systems and other key properties. 
 New XY tolerance property stored with feature classes provides consistent cluster processing throughout ArcGIS. 
 Feature data is now stored in double-precision coordinates, eliminating the need to specify XY domains manually. 
 Precision property replaced with new, easier to understand resolution property specified in coordinate system units. 
 Spatial indexes are now automatically created and maintained for you, greatly simplifying data management. 

New file geodatabase format  

 New file-based single-user geodatabase format with better performance and no overall database size limit. 
 File geodatabases support all geodatabase functionality except for multi-user editing and versioning.  
 File geodatabases work across platforms and can be created, accessed and updated on Windows and UNIX. 
 Highly efficient compression functionality enables read-only data to use 50% or less of normal disk space.  

Easier to use and deploy ArcSDE technology 

 ArcSDE now supports Microsoft SQL Server 2005 Express Edition, a lightweight full-featured free DBMS.  
 This new platform has been leveraged to provide two new ways to deploy ArcSDE technology. These make it quick 
and easy for anyone to get started using multi-user geodatabases and all the benefits of ArcSDE. 
 Personal ArcSDE technology comes for free with ArcGIS Desktop at the ArcEditor and ArcInfo license levels. It 
supports up to 4 concurrent users, 1 of who can edit the data at any time.  
 Workgroup ArcSDE technology is included in the new ArcGIS Server Workgroup product. It supports up to 10 
concurrent users, all 10 of who can edit the data at any time. 

Easier to manage and edit geodatabase data 

 New replication tools allow distribution of a single logical database across multiple geodatabases.  
 New historical archiving capabilities make it easy to store, query and manage database history. 
 Multi-user editing now possible without versioning with new short transaction editing option. GIS and non-GIS 
applications can share access to a common DBMS without the overhead of versioning. 
 New options for reconciling versions let you resolve all conflicts in favor of either the parent version or your edit 
session. New option to automatically save changes in all cases, which never notifies you of edits made by others. 
 You can now connect to an ArcSDE geodatabase using your operating system login username & password. 
 ArcSDE is now fully Unicode based, enabling data in multiple languages to be stored in the same dataset. 

Improved support for Oracle 

 New spatial type for Oracle for storing ESRI features. Oracle Locator or the Oracle Spatial extension are not 
required. Provides open access to simple features in geodatabases using ISO Multi-Media/OGC SQL statements.  
 You can now create multiple geodatabases within a single Oracle database instance. 
 Direct read and write support for Oracle Spatial GeoRaster. 
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Easier working with CAD data 
 

 Single icon for CAD files in ArcCatalog: A CAD drawing is now shown inside the CAD feature dataset.  
 The number of fields supported for CAD feature classes has been doubled (tripled for CAD annotation feature 
classes), letting you query, analyze, and symbolize your CAD data more effectively.  
 CAD layers can now be georeferenced using the Georeferencing toolbar, which allows you to move, rotate and 
scale your CAD layer using the mouse, and create control points, etc.  
 CAD features are now rendered by default using the display properties in the CAD drawing.  
 CAD annotation feature class rendering has been rewritten and includes full support for True Type fonts. 

 

Raster enhancements 
 

 Reads new formats: BSB, ERMapper ECW, HDF4, IDRISI, PCI, PCRaster, USGS ASCII DEM, X11 Pixelmap. 
 Writes new formats: GIF, Jpeg2000 (JP2), JPEG, PNG, Windows BMP. 
 Better raster attribute tables, including tables for ArcSDE rasters, table editing, and joins. 
 Georeferencing toolbar now supports ArcSDE raster datasets and adds new Adjust & Spline transformations. 
 Improved raster projection and transformation, including reading RPC information from vendor's TIFF files. 
 Orthorectification and panchromatic sharpening, both on-the-fly and with new geoprocessing tools. 
 New hillshading display option allows elevation rasters to be hillshaded without the Spatial Analyst extension. 
 Support for the new file-based geodatabase greatly improves performance of geodatabase rasters. 
 Set brightness, contrast and transparency for a group layer so it applies to all the raster layers in the group. 

 

New terrain data type for handling elevations and surfaces 
 

 Terrains let you store massive surface datasets, such as LIDAR elevation data, in the geodatabase.  
 Terrains provide optimized performance at multiple resolutions through the use of terrain pyramids that quickly 
retrieve only the data needed for the required level of detail in a given area of interest. 
 All users can view terrain datasets. The 3D Analyst extension is required to create them. 

 

Easier working with tables 
Support for Excel spreadsheets 

 Work directly with Excel spreadsheets in ArcGIS as tables. Excel files listed automatically in ArcCatalog.  
 Support for named ranges in Excel lets you access any specific range of cells in a spreadsheet as a table. 

Table window productivity enhancements 

 New Calculate Geometry dialog makes it easy to calculate area, perimeter, length, xy locations & centroids. 
 Turn fields on and off, specify field aliases, & change number format directly from table window.  
 New appearance properties enable long field names and long values like comments to wrap in the table window.  
 Print tables directly from the table window. 
 Navigate directly to features on the map by interacting with rows in the table window.  
 Many new shortcuts for working with and editing data in tables. 
 When table is showing just the selected records, you can now unselect records by clicking on them. 

 

Editing enhancements 
 

 New set of coordinate geometry (COGO) editing tools. 
 New attribute-driven editing workflow option and enhanced Construct Features command.  
 Multipatch features have basic editing capability. 
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ArcMap enhancements 
Better map navigation  

 New Go To XY command for navigating to and annotating coordinate locations you type in. 
 Mouse wheel support for zooming, panning and re-centering map reduces need to switch tools while working. 
 Full set of keyboard shortcuts for map navigation and new menu of shortcuts when you right-click map.  
 New option to customize exactly where on your map the Full Extent button zooms out to. 
 Easier to specify scale with new customizable scale control including support for relative scale input. 
 New viewer window lets you work at several scales simultaneously & compare multiple data frames side-by-side. 
 New My Places dialog gives quick access to frequently used addresses, locations & extents from any map or globe. 

Improved ability to find and identify 

 Enhanced Find dialog includes built-in web services for finding places and addresses. 
 New Find Nearby Places dialog lets you query web services to find places and information near any map location. 
 Enhanced Identify tool includes ability to drag a box, sort and hide fields, etc.  

Easier to select features 

 The Select By Attributes dialog now shows fields with their aliases and hides fields that are turned off.  

Easier to work with layers 

 Layer lists in dialogs now show feature type icons and are indented to show group layer structure.  
 Group layers have their own transparency, contrast and brightness properties and support the Swipe tool. 
 New Flicker command supports change detection and data comparison.  

Map document improvements 

 Enhanced Measure tool adds area & feature measurement, snapping, running total, etc. 
 New Map Properties option lets you make relative paths be the default for all new map documents you create. 

Better symbol drawing performance 

 Fill symbols with outlines in default ESRI style and others now draw up to 65% faster. 
 New ESRI_Optimized style provides additional fast drawing fill and line symbols.  

Accessing map services from the web 

 Full datum transformation support greatly increases accuracy and reliability of ArcIMS image services in ArcMap. 
 ArcIMS image service authors can now choose to block access to geometry from ArcMap and other clients. 
 OGC WMS services are now projected on the fly in ArcMap. Secure WMS services are now supported. 

 

New cartographic editing and finishing capabilities 
 

 Store symbology with the features in the geodatabase as 'representations' and edit the appearance and geometry 
of these representations on maps.  
 New graphic editing tools and a new suite of symbol effects give you complete control over map symbols. 
 Get cartographic results that previously required exporting maps to separate graphics programs. 

  

Printing and export enhancements 
 

 New ArcPress 'Universal' drivers provide native support for HP Designjet and EPSON wide-format printers. 
 Support for PDF layers lets you export maps to PDFs in which map layers and graphics can be turned on and off. 
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New visualization & analysis capabilities 
Animation enhancements 

 Animation now available in ArcMap. Create, playback, and export animations showing change over space and time. 

New graphing functionality in ArcMap 

 Completely new graphing engine with new options and powerful analysis and visualization. 
 Graph color can be synchronized with the symbology used to display layers. Graphs can also be animated. 
 Better handling of temporal data and time axes.  
 Dynamically linked feature selection between graphs, tables and maps. 

Integrate time into your GIS 

 Improved support for visualizing and analyzing temporal change, patterns and trends. 
 Support for netCDF time-based and multidimensional data. Can be displayed, graphed and animated. 
 New toolbox provides multidimensional geoprocessing tools. 

 

New geoprocessing & modeling capabilities 
 

 Desktop Help for geoprocessing concepts has been completely rewritten. 
 New batch mode lets you execute tools multiple times.  
 Large overlay capabilities now built into standard overlay tools so separate toolset no longer required. 
 New Results tab in ArcToolbox gives you easy access to all your geoprocessing history.  
 Drag tools into the Table Of Contents to create new, easy-to-use tool layers. 
 Many improvements to existing tools, including better Calculate Field and field mapping in Append tool, etc.  
 81 new core tools and over 40 new tools in various extension products, including high performance Spatial Join. 
 Uses native Python (no longer requires win32com extension) so Python scripts can now run on any platform. 
 ModelBuilder now supports iteration using list, series, and feedback loops. 
 Specify layer symbology as properties for input and output data in models.  
 Define features interactively on-the-fly as input to models.  
 New in-memory workspace for writing temporary feature classes and tables.  
 In-line variable substitution in models and command line. 
 Full support for geoprocessing with ArcGIS Server. Toolboxes can be published on the Web to provide 
geoprocessing services which can be accessed via ArcGIS Desktop, ArcGIS Explorer & custom web applications.  
 Full support for geoprocessing functionality in the ArcGIS Engine Developer Kit. 

 

Geocoding & routing enhancements 
Geocoding 

 Geocoding performance has been greatly improved with a general speed increase of 4x. 
 Address locators are now self contained and portable as they no longer need to access their reference data. 

Routing 

 New Find Route dialog in ArcMap, ArcReader and ArcGIS Engine provides free built-in support for routing and 
driving directions for the US, Canada, and Western Europe at all license levels.  

StreetMap routing 

 Support for barriers, trip planning, speed specification, and network restrictions such as vehicle weight or length.  
 StreetMap routing performance has been increased at least 3x. 
 Driving directions have been improved and now offer stop vicinity maps and turn-by-turn maps. 
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ArcCatalog and metadata support improvements 
 

 Rename ArcCatalog folder connections to hide long paths and customize appearance of Catalog tree. 
 The Set Data Source(s) command in ArcCatalog now supports updating references in map documents to ArcSDE 
geodatabases, coverages, tables, rasters, and all geodatabase data types including topologies, etc.  
 View metadata for any layer's data source directly from ArcMap or ArcGlobe without opening ArcCatalog. 
 New geoprocessing tools for metadata provide metadata export to ISO 19139 format, FGDC validation, etc. 

 

Customization and development 
Application Framework enhancements 

 Easier to find commands in the Tools > Customize dialog, and you can define keyboard shortcuts for tools. 

ArcGIS Desktop developer resources 

 Resources for Desktop developers have been separated into four unique kits: ArcGIS Desktop VBA Developer 
Resources, ArcGIS Desktop Developer Kit for Visual Basic 6, ArcGIS Desktop Developer Kit for Visual C++, 
ArcGIS Desktop Developer Kit for the .NET Framework. 

ArcGIS Engine Developer Kit 

 Support for additional extensions: Data Interoperability, Maplex, Schematics, and Tracking Analyst.  
 Many enhancements to existing controls, including mouse wheel navigation and context sensitive help. 
 Many new controls and dialogs provide the same new and enhanced functionality available in the Desktop at 9.2: 
Go To XY dialog, Measure tool, Identify tool, Find dialog, My Places dialog, Find Route dialog, animations, etc. 
 New engine-based Add Data dialog allows end users to add different types of data into maps and globes. 
 Support for feature editing enables development of editing applications via range of new editing controls. 
 Support for ink-based mark up enables a range of in-the-field applications on tablet PCs. 
 Support for subscription-based ArcWeb Services. 
 New dynamic display capability allows applications to be developed that can display large numbers of moving 
objects such as aircraft on-screen at sub-second refresh rates for command and control, etc. 
 .NET developer resources and tools have been integrated into the Visual Studio 2005 and Express integrated 
developer environments (IDEs). Many updates to the Java SDK and API. 

 

Data and services from ESRI 
Free services from ArcGIS Online 

 ArcGIS Online is a new family of web-based services and products for ArcGIS users that is being introduced after 
the 9.2 release. It includes a number of free web services providing basemaps, globes and reference overlays for 
use in ArcMap and ArcGlobe. 

Better integration of ArcWeb Services 

 Separate toolbar download no longer required to use the subscription-based ArcWeb Services in ArcGIS.  
 ArcWeb Services functionality fully integrated into all 9.2 products & exposed automatically once you are logged in. 

ESRI Data and Maps datasets 

 Adds 90 meter Shuttle Radar Topography Mission (SRTM) Global Digital Elevation Model (DEM) and shaded relief. 

StreetMap data support 

 Secure Feature Layer (SFL) support for SDC datasets provides data vendors with flexible copyright protection.  
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ArcGIS Server enhancements 
ArcSDE technology integrated into ArcGIS Server product  

 ArcSDE is now included as part of the ArcGIS Server product, which becomes our comprehensive solution for 
managing and serving geographic data both in a multi-user DBMS environment and over the web. 
 Available scaled to two levels, ArcGIS Server Workgroup and ArcGIS Server Enterprise. Basic, Standard and 
Advanced Editions provide different levels of functionality. 

Easier to manage ArcGIS Server 

 New ArcGIS Server Manager makes it easy to publish GIS services, create web applications and administer your 
server using a web browser. 
 Improved user interface for working with ArcGIS Server in ArcCatalog. New 'Publish to ArcGIS Server' wizard. 
 Contents of servers can be organized into folders which can be browsed in ArcCatalog. 

New ways to publish your GIS resources 

 Create new high performance map services cached for rapid display at specific scales. 
 Publish your ArcGlobe documents as globe services so people can visualize your data in 3D over the web. 
 Publish your geoprocessing workflows, models and toolboxes as geoprocessing services.  
 New geodata services support geodatabase replication, synchronization and data extraction over the web. 
 Easier to serve network analysis functionality 
 Extended interoperability allows data to be published in OGC WMS and Google Earth KML format. 
 Maplex extension-based high quality labeling is now supported when you publish a map service. 
 The Data Interoperability extension is now supported by ArcGIS Server. 

New client applications 

 Completely new, great-looking web mapping application provided out-of-the-box. Supports multiple map services, 
seamless panning, mouse wheel navigation and tasks, including tasks based on geoprocessing services. All 
configuration is done with a wizard in ArcGIS Server Manager so no web development expertise needed. 
 The same web mapping application and set of web controls is included with ArcGIS Server and ArcIMS, simplifying 
use, support, and development. Services from both products can be seamlessly integrated in one application. 
 Full support for ArcGIS Explorer, a completely new lightweight free desktop client introduced at 9.2. Users can work 
with maps or globes, and access your geoprocessing services as tasks. 

Web Application Development Framework (Web ADF) 

 Single generic Web ADF now supports ArcGIS Server and ArcIMS, and is included with both products. 
 Enhanced web controls provide support for multiple map services, map tips, geocoding, and more. 
 Improved documentation with new ArcGIS Server Help and Developer Help systems.  

What's new on the Microsoft .NET framework 

 Full support for Microsoft .NET Framework 2.0 and Microsoft Visual Studio 2005. 
 Complete ArcIMS API for the Microsoft .NET framework now part of Web ADF. This wraps all ArcXML functionality 
so you can create ArcIMS solutions without having to write ArcXML requests. 

What's new on the Java platform 

 9.2 introduces a set of Geospatial Enterprise JavaBeans (EJB) that perform services such as mapping, query, 
network solving, geocoding, etc, so that Java developers can now create applications in a pure Java API instead of 
having to use ArcObjects. 

Create mobile GIS applications 

 New Mobile GIS ADF for developing lightweight applications on handheld devices.  
 Supports integrated GPS, quick attribute updating during field inspection, field data collection involving the creation 
of features, and wireless synchronization. 
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ArcIMS enhancements 
New Web Manager  

 Web Manager makes it easy to create great-looking out-of-the-box web mapping applications. 

New out-of-the box web mapping application 

 The new web mapping application provided with ArcGIS Server is also provided with ArcIMS, so your applications 
have the same look and feel and can integrate services from both products. 

New Web Application Development Framework (ADF)  

 ArcIMS 9.2 introduces a Web Application Development Framework (Web ADF) providing consolidated access to 
ArcIMS, ArcGIS Server, ArcWeb Services, and OGC WMS services.  
 Same Web ADF and web controls used for both ArcGIS Server and ArcIMS. 
 Web ADF provides a full set of Web controls for the .NET Framework and Java platforms. 
 Complete ArcIMS API wraps all ArcXML functionality so you can create solutions without writing ArcXML requests.  

Other highlights 

 Better performance: The Spatial Server will now stop processing a request if the Application Server times out, so it 
is available more quickly for new requests.  
 Better data security: ArcMap users cannot download vector data unless ArcIMS has been configured to allow it. 
 Support for projections in the Spatial Server has been improved, including support for datum transformations. 
 ArcIMS ArcMap Server now supports the Maplex extension, definition queries, field aliases, and honors subtypes 
and domains. 
 Direct connect is supported in Author for accessing ArcSDE layers. 
 New Metadata Explorer. 
 Support for new geocoding styles. 
 The WMS Connector has OGC Styled Layer Descriptor (SLD) support. 

 

New free ArcGIS Explorer client  
 

 New lightweight GIS data viewer available as a free download. Supports 3D viewing of maps and globes. 
 Task-based user interface can be customized by developers to expose ArcGIS Server functionality. 
 Fuse data from different sources together to create custom visualizations. 
 Set of ready-to-use globes and base maps available. 
 Support for additional server-based data from ArcIMS, ArcGIS Server, OGC WMS and ArcWeb Services. 
 Support for shapefiles, file geodatabases, raster data, and Google Earth KML/KMZ. 

 

Extension enhancements 
3D Analyst (includes ArcGlobe and ArcScene) 

 New terrain data type lets you create multi-resolution surfaces from massive datasets such as LIDAR data. Terrains 
can be accessed read-only by all users without requiring the 3D Analyst extension. 
 New wizards in ArcGlobe makes it easier to handle newly added data and relocate globe documents and data. 
 Built-in address finding services for US, Canada & Europe, & support for additional services via ArcWeb Services. 
 New Go To XY & My Places dialogs, improved Measure & Identify tools, and ability to set effects for group layers. 
 Google Earth KML files can be added to ArcGlobe as layers. Layers can be converted into KML files. 
 ArcGlobe supports labeling and drawing graphics and text. Annotation and text labels can be draped on the globe.  
 Memory cache management has been enhanced and can be optimized for each data type. 
 Globes can now be published over the web as services using ArcGIS Server and accessed by various clients.  
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ArcScan 

 New tools for point to point tracing, shape recognition, and measuring raster distance. 
 New vectorization settings for specifying noise level and controlling how corners are resolved. 

Data Interoperability 

 Provides free support for OGC GML Simple Features data without need for Data Interoperability extension license. 
 Now based on Safe Software's FME 2006 release which supports Google Earth KML & OGC GML 3.1.1, etc. 
 Now supports ArcGIS Server & ArcGIS Engine. 

Geostatistical Analyst 

 New geoprocessing tools including Moving Window Kriging, GA Layer To Contour & GA Layer To Points. 
 New smooth interpolation option. 

Maplex 

 Placement quality and performance generally improved. Support added for leader lines.  
 Now supported by ArcGIS Server, ArcIMS ArcMap Server, ArcGIS Engine, and ArcGIS Publisher. 

Network Analyst 

 Route analysis supports start time specification, multiple routes, and parameterized attributes. 
 Directions window supports time windows, cumulative distance and time, scale control for inset maps. 
 Service areas can be trimmed and you can create services areas that do not overlap. 
 Reverse geocoding and snapping are supported when adding network locations to a map.  
 Easier to serve network analysis services using ArcGIS Server.  
 New Network Analyst developer controls in ArcGIS Engine including Directions window. 

Publisher and ArcReader 

 Support for Maplex so maps with high quality labeling can now be viewed and printed from ArcReader. 
 New ink-based mark-up toolbar for red-lining 
 Includes ability to Find addresses, perform routing & get driving directions in US, Canada & Western Europe. 
 New Go To XY dialog, My Places dialog, Measure tool, full-screen mode, ArcWeb Services support, and more. 
 Ability for ArcReader users to modify the map title that appears on page layout before printing. 

Schematics 

 New viewer window lets you work with schematics & geography side-by-side on-screen without using Layout view. 
 New Diagram Type Assistant makes it easier to create new types of custom schematic diagrams.  
 Now supports ArcGIS Engine and network datasets created with the Network Analyst extension. 

Spatial Analyst 

 New suite of solar radiation analysis geoprocessing tools, and new math tools. 
 Core 9.2 enhancements such as looping in models & support for netCDF data increase the power of this extension. 
 Using ArcGIS Server Advanced edition you can serve your analytical models and workflows over the web.  

Survey Analyst 

 New Cadastral Editor and cadastral fabric data model with which you can build and maintain a high precision 
cadastral land records system in the geodatabase. Cadastral fabrics can also be used to update the spatial 
accuracy of other GIS features that coincide with it. 

Tracking Analyst 

 Improved performance for large datasets, and streaming locations from local GPS connection now supported. 
 More options for symbolizing tracks including event labeling, directional vectors, smoothing, and more. 
 Support for ArcGIS Engine. 
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Documentation 

'What is ArcGIS 9.2' book 
 

The 'What Is ArcGIS' book has been updated and enhanced for 9.2. This book comes with ArcGIS Desktop and is 
also available as a PDF in your arcgis/documentation folder after you've installed the software. This book is a great 
introduction to ArcGIS 9.2, the concepts underlying the product, and how the different parts of the product work 
together, and is recommended both for existing users who are familiar with previous releases and for new users: 
 

 
 
 
Better search in Desktop Help 
 

A new search capability has been implemented in the ArcGIS Desktop Help at 9.2 to provide faster, more effective 
search. The new search engine provides natural language capabilities, and allows you to search using everyday 
language, including keywords, phrases, and questions. To use the new search, click the Search tab, type what you 
want to search for, then click the Ask button. The results are ranked by relevance: 
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You can customize your search by clicking the Options link under the search input box. By checking boxes in the list, 
you can include only the subject areas or products you want to search, and exclude the rest. Click the History link to 
view your previous searches. If you want to repeat the search, just click the link in the list. 
 

 
 
This new search capability is not available when you access the Web-based version of the Desktop Help. The Web-
based help has a search capability but it is not the same search engine available when you use Desktop Help locally. 
 
 
Better content in Desktop Help  
 

 Based on your feedback and requests, we have improved the content of the Desktop Help system and restructured 
it around key concepts and workflows. Each subject area now has its own high-level overview topic.  
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Try it now: Click the following link to launch the ArcGIS 9.2 Desktop Help on the Web: 
http://webhelp.esri.com/arcgisdesktop/9.2
 

The “Getting started” section of the help has been rewritten to provide additional topics on fundamental GIS 
concepts and how to work with the software, including tips and tricks, and descriptions of every toolbar: 
 

In the Desktop Help, see: Getting Started > Toolbars > Core ArcMap toolbars 
 

In the Desktop Help, see: Getting Started > Introducing ArcGIS Desktop > Tips and tricks 
 
 
Easier to get to the tutorials  
 

It’s easier to access the PDF workbooks for the ArcGIS Desktop tutorials. The PDFs are now automatically installed
with ArcGIS Desktop, and can be opened from links inside the help. You will still need to run the ArcGIS Desktop 
Tutorial Data Setup Program to install the 'ArcTutor' data used in the tutorials. A link from the Desktop Help welcome 
page takes you to the 'Tutorials' topic that contains links to all the tutorial PDFs.  

 

 
Animation clips showing you how to perform tasks in each of the tutorials have also been added to the help system. 

To view the videos, click the “Watch the tutorial” link on the main tutorial topic page, then click the segment you want to 
watch. Each of the tutorial video segments has additional text below it describing the actions in the segment. Searches 
with the new search engine will find matches in this text.  
 

In the Desktop Help, see: Getting Started > Tutorials > Tutorials 
 
 

ther O
 

When you launch the Desktop Help from the Help menu in any of the ArcGIS Desktop applications, it is now 
launched inside a separate process. This eliminates a number of issues that have been reported when the Desktop 
Help is launched in the same process as the application. It also means that when you launch the Desktop Help in this 

ay, it no longer 'stays on top' of the application window. w
 

The contents of Desktop Help topic pages are now always automatically expanded. This minimizes the amount of
licking you need to do to see everything on a page. (At 9.1, sections were always collapsed.) 

 
c
 

The Desktop Help window has been made simpler and more compact. We've removed the pulldown menus it used 
o contain. t
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Compatibility 

Geodatabase compatibility 
 

Existing geodatabases created using previous releases can be opened and used in 9.2 without being upgraded to
9.2. However, to take advantage of new functionality added at 9.2, existing geodatabases have to be upgraded.  

 

 
In addition to new functionality, ArcGIS 9.2 introduces a high precision data storage format for feature data in the 
geodatabase. Upgrading an existing geodatabase to 9.2 does not convert it to use this new format. Instead, once you 
have upgraded a geodatabase to 9.2, you can then upgrade the data it contains to use this new format using a new 
tool called Upgrade Spatial Reference. You can launch this tool by right-clicking a standalone feature class, feature 
dataset or raster catalog in ArcCatalog and choose the Upgrade Spatial Reference command. This tool is also 
available in ArcToolbox.  
 
ArcGIS 9.2 also introduces new tolerance and resolution properties for feature data in the geodatabase. Feature 
classes and feature datasets in any geodatabase you work with in ArcGIS 9.2 have these new properties, even if you 
have not upgraded the geodatabase to 9.2. However if you want to be able to specify the tolerance properties for new 
data you create in a geodatabase, you have to upgrade it to 9.2 first.  
 

In the Geodatabase Properties dialog General tab (accessed by right-clicking a geodatabase and choosing the 
Properties command), the Upgrade Status box now tells you the version of ArcGIS that the geodatabase belongs to. 
This makes it easier to manage your migrations. For example, here's what you see in 9.2 when you look at the 
properties of a personal geodatabase that was either created with ArcGIS 9.1 or was upgraded to version 9.1: 
 

 
 
Here's what you'll see after you upgrade this geodatabase to 9.2: 
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To upgrade a geodatabase to ArcGIS 9.2, use the Upgrade Geodatabase button in the tab shown above. This 
wo

ip: g, the 'Geodatabase tools' category contains a command called 
U the 

e. This 
ommand becomes enabled when you select a geodatabase in ArcCatalog that needs upgrading. 

rks with all geodatabases except for Enterprise ArcSDE geodatabases (i.e. geodatabases you connect to via the 
Database Connections folder in ArcCatalog). To upgrade an Enterprise ArcSDE geodatabase, see your ArcSDE 
installation guide. Upgrading an Enterprise ArcSDE geodatabase can only be performed by the administrator of that 
database.  
 

 In the Tools > Customize dialog in ArcCataloT
pgrade Geodatabase that you can add into any pulldown menu or toolbar in ArcCatalog. This command does 

same thing as the Upgrade Geodatabase button but can save time if you have a lot of geodatabases to upgrad
c

Once a geodatabase has been upgraded, it can no longer be accessed from an older version of ArcGIS. If this is a 
requirement, do not upgrade the geodatabase. You can still work with it in 9.2 but new functionality won't be available. 
 
 
Other compatibility 
 

Once you open and then save an existing ArcMap .mxd document, ArcGlobe .3dd document or ArcScene .sxd
document using ArcGIS 9.2 it can no longer be opened with earlier versions of the software because it will now reflect 
the new functionality added at 9.2. Similarly, new documents you create with 9.2 can also not be opened in earlier 
versions of the software. To save a copy of a document that has been created or edited in 9.2 so it can be opened in
version 8.3, 9.0

 

 
 or 9.1, use the File > Save A Copy command and choose the version you want to save to from the 

Save As Type dropdown list in the dialog. Saving a document back to 9.1/9.0 or 8.3 format removes functionality from 
that file that depends on the version it is being saved out from. For example, terrain layers, which are new in 9.2, are 
removed from map documents that you save back to an earlier version.  
 

Layer files (.lyr) that you create with 9.2 can also not be opened with earlier versions of the software. To create a 
layer file that can be opened in an earlier version, use the Save As Layer File command in the layer context menu in 
the application you are using and choose the version you want to save to from the Save As Type dropdown list in the 
dialog. As with documents, functionality that is not available in the version of ArcGIS you are saving the layer file for 
use with will be automatically removed. 
 

ArcReader .pmf files that you publish with the ArcGIS Publisher extension at 9.2 can't be opened with earlier 
versions of ArcReader. 
 

As mentioned above, once you upgrade a geodatabase to 9.2, it can no longer be accessed with an older version of 
ArcGIS. This includes any geoprocessing toolboxes contained in the geodatabase. Similarly, once you make a change 
to a file-based toolbox (.tbx file) in 9.2, it can no longer be opened in a 9.0 or 9.1. However, you can save a toolbox in 
a geodatabase or a file-based toolbox as a file-based toolbox that can be opened in 9.0 or 9.1 using a new command 
added at 9.2. You can access this new 'Save As 9.0/9.1' command by right-clicking any toolbox in ArcCatalog or in the 
ArcToolbox window.  
 
The contents of the file-based toolbox that is created by this command are not automatically modified to remove 
functionality that is not available in 9.0/9.1. So if the toolbox contains models that include functions added at 9.2, these 
models can be opened in 9.0/9.1 but they will need to be modified manually in 9.1 to remove those steps in order to 
run the model. 
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Geodatabases & ArcSDE 

 

Easier to create data 

The wizards in ArcCatalog for creating feature classes and feature datasets have been enhanced to make it easier to 
specify key properties like the feature type and coordinate system. 
 

When you create a new feature class in ArcCatalog, the first panel of the wizard now lets you choose what type of
feature class you want to create from a single dropdown list. Previously you had to go into the properties for the Shape 
field to specify the feature type (point, line, polygon, etc). The feature types shown in the dropdown list depend on the 
Desktop license you are using and where you are creating the data. The first panel of the wizard also now lets you 
choose whether the coordinates will have M or Z values. These were also previously specified as properties of the 
Shape field. The graphic below left shows the first panel of the wizard at 9.2. 

 

 
When you create a new standalone feature class, the wizard now includes a separate panel for specifying the XY 
coordinate system. Previously you had to go into the properties for the Shape field and use the Spatial Reference 
property to specify the coordinate system for a standalone feature class. The new panel shows you the contents of the 
Coordinate Systems folder in ArcCatalog and lets you browse the tree to the coordinate system you want to use. As in 
previous releases, a feature class inside a feature dataset always uses the XY coordinate system specified for the 
feature dataset, so at 9.2 you now see this same wizard panel when you create a new feature dataset. The graphic 
below right shows the new panel for specifying the XY coordinate system, in this case for a standalone feature class: 
 

    
 
Tip: As you can see in the graphic above right, some frequently used coordinate systems have been placed into the 
top level of the Coordinate Systems list so they can be accessed easily in the wizard. At 9.2, ArcCatalog lets you 
copy/paste or drag your most frequently used coordinate systems into the top level of the Coordinate Systems folder if 
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you have added it into ArcCatalog's tree. Coordinate systems that you have placed at the top level of the Coordinate 
Systems folder appear at the top level of the same list in the New Feature Class wizard and in all dialogs in ArcGIS 
that let you browse to coordinate systems. 
 

The panel in the wizard for specifying the database storage configuration keyword now only appears if configuration 
keywords are supported by the geodatabase you are working with. 
 

The panel for specifying fields in a new feature class or table now provides a wider and longer fields listing, and you
can use the mouse wheel to scroll up and down through the listing. If you click on the Shape field, you'll notice that this 
field has fewer field properties than it did at 9.1. Properties like whether the data contains Z and M values and the 
spatial reference are no longer specified from this panel. The Geometry Type field is still shown for compatibility 
reasons but its setting can no longer be changed in this panel. The number of grid levels shown now respects the type 
of data you are working with, so you'll only see three levels listed when all three are supported.  

 

 

 
 

If you click on a numeric field in the Fields panel, the Scale and Precision field properties are no longer shown if 
they are not supported by the geodatabase you are working with. So for example, if you create an integer field in a 
personal geodatabase feature class, you'll no longer see a Precision property for this new field. In 9.1 Scale and 
Precision properties were always shown even if the geodatabase being used did not require their use. Similarly, the 
panel no longer lists Blob and Guid as field types when you add a field to a shapefile or dBASE table, becaus
geodatabase field types are not supported by those formats. These same enhancements have also been made in the 
Add Field dialog you launch when you add a field to a table window in ArcMap, ArcGlobe or ArcScene. 

e these 

 
The new high precision data storage introduced at 9.2 eliminates the need to specify the XY domain manually when 

you create data.  
 
When you create a new standalone feature class or feature dataset in a geodatabase that has been upgraded to 9.2 or 
created with 9.2, the software now automatically calculates the appropriate XY domain for the coordinate system you 
chose, and the Min X, Min Y, Max X, Max Y values of this extent are no longer editable, or even shown to you, in the 
wizard. It also calculates an appropriate XY resolution value, but gives you the option of entering this manually. XY 
resolution is a new property that replaces the precision property used in earlier releases.  
 

Spatial indexes are now automatically created and maintained for you, greatly simplifying data management. This
removes the need to have to specify spatial index grid levels when you initially create data. See below for more 
information.  
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New XY tolerance property for feature data 

9.2 introduces a consistent and unified tolerance environment for specifying the tolerance used when geographic 
coordinates are processed by GIS operations. In previous releases, there was an internal geometry processing 
tolerance, a cluster tolerance used by geoprocessing functions specified in the Environment Settings, and a cluster 
tolerance used by topologies. At 9.2 all feature classes in the geodatabase have a new XY tolerance property 
specified when you create data. This is used consistently by all spatial functions.  
 
The XY tolerance is synonymous with cluster tolerance: the XY tolerance is an extremely small distance used to 
resolve inexact intersection locations of coordinates during operations such as topology validation, polygon overlay, 
buffering, clipping, etc. Coordinates whose distance from each other are within the XY tolerance of each other are 
considered equal ('clustered') and depending on the process being performed, one of these coordinates will be moved 
to the location of the other coordinate or a new location will be computed as an average distance between the 
coordinates in the cluster. XY tolerance is not used to generalize the coordinate geometry of individual features. 
Instead it is used to evaluate, clean up and manage the relationship between features whenever geometry is 
processed, so that coordinates that fall within very a small distance of one another can be integrated. Because 
coordinates can move in both X and Y by as much as the XY tolerance, this automatically resolves many potential 
problems in data creation and maintenance, such as extremely small overshoots or undershoots, sliver removal of 
duplicate segments, and coordinate thinning along boundary lines.  
 
The default XY tolerance is the equivalent of 1mm in the linear unit of the data's coordinate system on the earth 
surface at the center of the coordinate system. So if your coordinate system units are meters, the XY tolerance 
defaults to 0.001 meters. If your coordinate system units are feet, the default value is 0.003281 feet (0.03937 inches).  
 
When you create a new standalone feature class or a new feature dataset, you can normally just accept the default 
tolerance proposed by the wizard in the new tolerance panel. This gives good results in most scenarios. There are 
some situations where you may choose to specify the XY tolerance yourself. You may set a larger tolerance value for 
data that is known to have a lower level of coordinate accuracy, or you may set a smaller value for data that requires 
extremely high accuracy, such as a survey control network. The graphic below left is the tolerance panel in the New 
Feature Class Wizard. You can't change the XY tolerance after you have created the data. When you look at the 
properties of a feature class or feature dataset, the XY tolerance is read-only (below right). 
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When you create a new feature class in a feature dataset you won't see the tolerance panel in the wizard because 
feature classes in feature datasets use the XY tolerance specified for the feature dataset they belong to.  
 
 
XY tolerance and topology 
 

When you create a topology in 9.2, the cluster tolerance of the topology defaults to the XY tolerance of the feature
dataset in which the topology is being created. You can still specify a cluster tolerance for a topology at 9.2. This 
allows you to override the XY tolerance of the feature dataset to use a larger tolerance. But you can't specify a cluster 
tolerance for a topology that is smaller than the XY tolerance specified for the feature dataset. 

 

 
 
XY tolerance and geoprocessing 
 

When you perform geoprocessing in 9.2, the geoprocessing functions all default to using the XY tolerance property 
stored for the data being processed: 
 
- If the output is a new standalone feature class, a new raster catalog or a new feature dataset, the XY tolerance of 

the input will be used and will be set as the XY tolerance of the output. For tools that have multiple inputs (such as 
Intersect) the tolerance of the first input specified in the parameter list (i.e. the top most input in a geoprocessing tool 
dialog) will be used as the default.  

 
- If the output is a feature class inside an existing feature dataset, the XY tolerance of that feature dataset will be 

used. 
 
You can override the XY tolerance stored in the data so that the geoprocessing functions use an XY tolerance you 
specify instead. You can specify an XY tolerance in the Environment Settings dialog launched from ArcToolbox so that 
it applies to all your geoprocessing or in the Environments Settings dialog launched from a tool dialog so it applies to 
that one tool. When geoprocessing functions execute they look at the XY tolerance environment and if it has not been 
set they use the tolerance properties of the data. 
 
 
XY tolerance and your existing geodatabases 
 

Data in any geodatabase you work with at 9.2 has the new XY tolerance property even if you have not upgraded the
geodatabase to 9.2. When you look at the properties of a standalone feature class or feature dataset in a geodatabase 
that has not been upgraded you'll see a Tolerance tab showing the XY tolerance calculated by the software. However 
if you create new feature data in a geodatabase that has not been upgraded, the wizard does not give you the 
tolerance panel and you are not able to specify the XY tolerance manually. If you want to be able to specify the XY 
tolerance for new data you create in your existing geodatabases, you have to upgrade them to 9.2. 

 

 
 In the Desktop Help, see: Geodatabases and ArcSDE > An Overview of the Geodatabase > Feature class basics 

 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  20 



High precision data storage 

Prior to 9.2, coordinate data in the geodatabase was stored in 'low' precision as 32-bit (4-byte) integers. The range 
of possible integer values this provided meant there was essentially a trade off between the area your data covered 
(the XY domain), and the resolution with which it could be stored using a given coordinate system's unit of 
measurement. A large XY domain was only possible at a low resolution. Consequently, storing your data at high 
resolution demanded undersized domains which were often too small for many projected coordinate systems such as 
UTM or State Plane. You therefore had to carefully balance the XY domain extent and the resolution of the data
expressed by a precision property representing the number of system storage units for each unit of coordinate system 
measurement. Deciding how to specify the XY domain could often be quite involved, especially if your application 
demanded very high accuracy or you wanted to optimize the performance of Enterprise ArcSDE g

 as 

eodatabases.  
 
This situation changes at 9.2. At 9.2, geodatabase coordinates are now stored and processed in double precision 
(53-bit integers corresponding to an IEEE double-precision number). This double precision ('high' precision) data 
storage provides a much greater range of possible integer values and allows for very fine resolution while allowing 
your data to span the entire extent of any given coordinate system. With high precision data storage, the extent of your 
data is defined by the coordinate system and the resolution you choose, therefore eliminating the need for a user-
defined domain extent. This greatly simplifies the creation and maintenance of spatial data in the geodatabase and 
there is no need to strike a balance between domain extent and resolution since high precision storage offers both in 
unison. Double precision coordinates require only a negligible additional performance and storage overhead. 
 
When you create a new standalone feature class or a new feature dataset at 9.2, the software automatically calculates 
the appropriate XY domain for the coordinate system and resolution you chose, and the Min X, Min Y, Max X, Max Y 
values of this extent are no longer editable, or even shown to you, in the wizards, unless you create the data without 
specifying a coordinate system. If you leave the coordinate system as unknown when you create new data, the wizard 
can't determine the coordinate range required for data. In this case it uses a generic default XY domain but gives you 
the option of specifying these yourself in the wizard. 
 
 
New XY resolution property 
 

At 9.2, the precision value associated with the XY domain is replaced with a new property called XY resolution. This 
resolution value is easier to understand than the precision value used in previous releases because resolution is 
specified directly in coordinate system units. All coordinates stored in a feature class are snapped to an underlying 
coordinate grid or mesh. The XY resolution value specifies the cell size of the coordinate grid, so increasing the 
resolution value decreases the resolution of your data. XY resolution is the inverse of the precision value used 
previously.  
 
The default XY resolution value for data created in the new high precision data storage, or upgraded to use it, is the 
equivalent of 0.1 mm in the linear units of the coordinate system. So if your coordinate system units are meters, the 
resolution defaults to 0.0001 meters. If your coordinate system units are feet, the default value is 0.0003281 feet. This 
default resolution is precise enough for most data and does not restrict your extent like a low precision value specified 
in previous releases would.  
 
The default XY resolution for data that has not been upgraded to the new high precision data storage (see below for 
more on this) is the equivalent of 1 mm in the linear units of the coordinate system. So if your coordinate system units 
are meters, the resolution defaults to 0.001 meters. 
 
When you create a new standalone feature class or a new feature dataset in a 9.2 geodatabase, you can normally 
accept the default XY resolution. When you get to the tolerance panel in the wizard, the check box at the bottom of the 
tolerance panel for accepting the default resolution is checked. (The graphic below left shows the tolerance panel in 
the New Feature Class wizard). Unless you uncheck this box, you won't see the resolution panel in the wizard or be 
able to change the resolution. We recommend always accepting the default resolution unless there is a specific 
circumstance you want to handle. If you uncheck the 'Accept default resolution' box, you'll get the resolution panel next 
in the wizard. Setting a smaller XY resolution than the default can potentially increase data storage and processing 
time. (The graphic below right shows the resolution panel in the New Feature Class wizard): 
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You can't change the XY resolution after you have created the data. When you look at the properties of a feature class 
or feature dataset, the XY resolution is read-only. 
 
When you create a new feature class in a feature dataset you don't see the tolerance panel in the wizard and there's 
no option to specify the XY resolution. Feature classes in feature datasets use the XY tolerance and XY resolution 
specified for the feature dataset they belong to.  
 
 
High precision data storage and geoprocessing 
 

In addition to making it simpler to create data, the move to double precision also unifies geometry processing in
ArcGIS and simplifies the geoprocessing of large overlays.  

 

 
 
High precision data storage and your existing geodatabases 
 

Your existing geodatabase data uses the existing 32-bit 'low' precision data storage format. Data in this format can 
still be used throughout ArcGIS and you are not required to upgrade it to use the new high precision format, although 
this is recommended. 
 

Upgrading an existing geodatabase to 9.2 does not convert the data it contains to use the new high precision 
format. Instead, once you have upgraded a geodatabase to 9.2, you can then choose whether to upgrade the data it 
contains to use this new format.  
 
Each standalone feature class, feature dataset, and raster catalog in a geodatabase has its own spatial reference, so 
each also has its own precision status. You can upgrade all of these to use the new high precision format, or pick and 
choose among them. Feature classes inside a feature dataset don't have their own precision status because they use 
the spatial reference defined for the feature dataset.  
 
You upgrade data to use the high precision format using a new tool called Upgrade Spatial Reference. You can launch 
this tool by right-clicking a standalone feature class, feature dataset, or raster catalog in ArcCatalog and choosing the 
Upgrade Spatial Reference command: 
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The Upgrade Spatial Reference command is disabled if the geodatabase containing the data has not been upgraded 
to 9.2, or if the data you right-clicked is already in the new high precision format. The tool is also available in 
ArcToolbox, where it can be run in the new batch mode or included in scripts or models: 
 
 Data Management Tools > Database > Upgrade Spatial Reference 
 
When you upgrade a spatial reference, the tool shows you the default XY resolution that will be applied to the data (the 
equivalent of 0.1 mm in the linear units of the coordinate system, so 0.0001 meters if the data is in meters), and allows 
you to specify a different resolution manually if desired. Behind the scenes, the new high precision spatial reference 
grid will be meshed with the existing low precision grid. Each point of the original grid becomes a point in the new high 
precision grid. This means that actual data coordinate values are not affected by the upgrade. 
 

Once you have upgraded a geodatabase to 9.2, you are not required to upgrade the data it contains to high 
precision, although this is recommended. New standalone feature classes, feature datasets or raster catalogs you 
create in (or copy into) a geodatabase that has been upgraded to 9.2 are always stored in high precision format. New 
feature classes you create inside a feature dataset in a geodatabase that has been upgraded to 9.2 will have the same 
precision status as the feature dataset, so they can be either low or high precision. An existing geodatabase that you 
upgrade to 9.2 can therefore contain some data in low precision and some in high precision.  
 

If you work with a geodatabase in 9.2 that has not been upgraded to 9.2, all the data it contains and all new data
that you add to it will be in low precision. For example, if you copy a feature dataset that is in high precision from a 9.2 
geodatabase and paste it into a geodatabase that has not been upgraded to 9.2, the resulting feature dataset will be in 
low precision.  

 

 
Feature data in any geodatabase you work with at 9.2 has the XY resolution property, even if you have not upgraded 
the geodatabase to 9.2. The default XY resolution for geodatabases that have not been upgraded to 9.2 is 1mm for 
projected coordinate systems (so 0.001 meters if the data is in meters). 
 
When you create new data inside a geodatabase that has not been upgraded to 9.2, the wizard will include a panel 
prompting you to specify the XY resolution and XY domain of the data. (The graphic below shows this panel in the 
New Feature Class wizard). Like in previous releases, you can use the default XY domain or you can adjust the values 
according to whether you want to maximize the coordinate extent covered by the data or the resolution of the data. 
Remember that the XY resolution is the inverse of the precision value used previously. If you previously used a 
precision of 1000 to store coordinates to the nearest millimeter, you will now use an XY resolution of 0.001 meter 
instead. Unlike the precision value used in previous releases, XY resolution has a direct relationship with the XY 
domain. If the resolution value is increased, i.e. you specify a larger cell size for the underlying coordinate grid, this 
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results in the data being stored at a lower resolution, and so the XY domain automatically gets larger too, because a 
wider area can be stored if the data is stored at a lower resolution. 
 

 
 

Data you create or copy into new geodatabases created with 9.2 automatically use the new high precision format.  
 

You can look in the General tab of the Feature Class Properties, Feature Dataset Properties, and Raster Catalog 
Properties dialogs to find out whether they are stored in high or low precision.  
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Better support for M and Z coordinates 

ArcGIS has always supported M and Z values but support for them is improved at 9.2. Ms and Zs are additional 
numeric values that can be stored with every X, Y coordinate in a feature class. M values are most commonly used to 
store cumulative distance measurements along linear routes, such as highways, for which it is common for pavement 
conditions, speed limits, accident locations, and other properties and events to be referenced geographically by 
specifying their distance along the route (such as the highway milepost measurement system used by US departments 
of transportation) rather than as X, Y locations. Z values are typically used to store height above sea level but can be 
used to store other surface measurements such as annual rainfall or air quality. 
 
When you create a new feature class the first panel of the wizard now includes check boxes lets you choose whether 
the coordinates will have M or Z values. In previous releases these settings were specified in the fields panel as 
properties of the Shape field. The check box to store Z values will be disabled if Z values cannot be stored for the type 
of feature class you are creating. For example, dimension and annotation features can't have Z values. If you are 
creating a MultiPatch feature class, this box will be checked automatically and disabled, because MultiPatches are a 
3D feature class that require the use of Z values.  
 
 
Vertical coordinate systems for Z values 
 

ArcGIS 9.2 adds support for the definition and use of vertical coordinate systems. Vertical coordinate systems allow
you to accurately identify the origin, direction and linear unit of your Z data, making it easier to document and share 
feature data containing Z values. Over 90 predefined vertical coordinate system definitions are provided. You can find 
these in the Coordinate Systems folder in ArcCatalog in a new subfolder called Vertical (you can add the Coordinate 
Systems folder into ArcCatalog via a setting in the Tools > Options dialog). This folder is shown below left with some of 
its contents expanded. The graphic below right shows the properties of a vertical coordinate system, in this case 
NAVD 1988, the current gravity-related vertical coordinate system for heights that is used in the US: 
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The Direction parameter determines whether the z values are positive up (1.0), increasing against gravity, or positive 
down (-1.0), increasing with gravity. Depths would use the -1.0 value. 
 
When you create a new standalone feature class and check the box to say it will contain Z values you'll see a new 
panel for specifying the vertical coordinate system. When you create a new feature dataset you are always prompted 
to specify the vertical coordinate system that will be used by any feature classes created in that feature dataset for 
which Z values will be stored. (Specifying a vertical coordinate system for a feature dataset doesn't mean that the 
coordinates of the feature classes it contains will always have Z values). Here's the new panel for specifying the 
vertical coordinate system for a standalone feature class in which Z values are being stored: 
 

 
 
As with the horizontal (XY) coordinate system, you can change the vertical coordinate system of a standalone feature 
class or feature dataset after you have created it. You can only specify or change the vertical coordinate system if the 
XY coordinate system has been specified. 
 
Vertical coordinate systems are also supported for shapefiles. 
 
 
New tolerance properties for M and Z values 
 

Similar to the new XY tolerance, 9.2 introduces new tolerance properties for specifying how M and Z coordinates 
with very similar values will be handled during spatial processing. The M tolerance and Z tolerance are extremely 
small values that define the minimum distance between M values and Z values before they are considered equal 
('clustered') by spatial processing operations. Coordinates containing M or Z values whose distance from each other 
are within the M or Z tolerance of each other will be will be given the same M or Z value.  
 
The default M tolerance is 0.001 units. The default Z tolerance is the equivalent of 1 mm in the linear units of the 
vertical coordinate system used by the data, so if your vertical coordinate system units are meters, the Z tolerance 
defaults to be 0.001 meters. If no vertical coordinate system is specified, the Z tolerance value is 0.001 Unknown units. 
 
When you create a new standalone feature class and you specify that the coordinates will contain M or Z values, you'll 
get prompted to specify the corresponding M or Z tolerance. You can normally accept the default M and Z tolerances 
when you create data containing M and Z values.  
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When you create a new feature dataset, you always get prompted to specify the M and Z tolerances that will be used 
by any feature classes created in that feature dataset for which M or Z values will be stored. (Specifying M or Z 
tolerances for a feature dataset doesn't mean that the coordinates of the feature classes it contains will always have M 
or Z values). Here's the tolerance panel from the New Feature Dataset wizard: 
 

 
 
When you create a new feature class containing Z values in a feature dataset, you won't see the tolerance panel in the 
wizard because the Z tolerance specified for the feature dataset is used. When you create a new feature class 
containing M values in a feature dataset, the tolerance panel appears allowing you to specify a different M tolerance 
than the one used by the feature dataset). 
 
Like the XY tolerance, you can't change the tolerances for M and Z values once the data containing them has been 
created. Tolerances are always read only for existing data. 
 
 
M and Z precision becomes M and Z resolution 
 

Similar to the changes described above for the XY coordinates, M precision and Z precision used in previous
releases become M resolution and Z resolution at 9.2. Like the XY resolution, these define the resolution of an 
underlying coordinate grid or mesh onto which coordinates stored in the geodatabase are 'snapped'. The default Z 
resolution value is the equivalent of 0.1 mm in the linear units of the vertical coordinate system, so if your coordinate 
system units are meters, the resolution defaults to 0.0001 meters. The default M resolution is 0.0001.  

 

 
Like in previous releases, you can still specify an M domain and a Z domain when you create data to define the 
minimum and maximum values for these coordinates. The Z domain now defaults to a range determined by the vertical 
coordinate system you specify. Both the M and the Z domains can be reviewed and modified in the wizard when you 
create data. 
 

Like in previous releases, you can't change the resolution or domain for M and Z values once the data containing 
them has been created. These properties are always read only for existing data. 
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Easier to work with spatial indexes 

In previous versions, spatial index grid sizes for feature classes in ArcSDE geodatabases that use grid sizes 
(Oracle, SQL Server, and DB2) were not maintained by ArcGIS. The index could become less than optimal following
certain updates to the data, such as after you loaded or imported new features. As a result, you sometimes had to 
manually update the spatial index grid sizes if you were to keep the index in an optimal state. Knowing the best sizes
to set to set was not straightforward: the Calculate Default Spatial Grid Index geoprocessing tool returned only one gr
size, even if two or three would work bet

 

 
id 

ter.  
 
ArcGIS 9.2 provides enhancements that make working with spatial indexes easier. ArcSDE geodatabase feature 
classes no longer require a spatial index to display in ArcCatalog or ArcMap, and most importantly, the spatial index is 
now automatically updated for you in to ensure the spatial index is optimal.  
 
When you create an empty feature class with the New Feature Class wizard in an ArcSDE geodatabase that uses grid 
sizes, a spatial index is created with grid sizes 0,0,0 and left in an unbuilt state. (ArcSDE geodatabases based on 
Oracle Spatial or Informix RDBMS do not use grid sizes because they use an R-Tree for their spatial index). After 
loading data with the simple data loader in ArcCatalog or the Append tool, ArcGIS builds the spatial index as a final 
step of the loading process. It calculates grid sizes that are appropriate for the newly added features. If you import data 
from a personal geodatabase, shapefile, or coverage, or import CAD or SDC data, a spatial index is automatically 
computed for the new feature class.  
 
When you use the ArcCatalog Copy and Paste commands to copy a feature class from a personal to a file or ArcSDE 
geodatabase, the spatial index is automatically rebuilt. The spatial index is also rebuilt if you copy a feature class from 
Oracle Spatial or Informix. If you copy a feature class from a file or an ArcSDE geodatabase that uses grid sizes 
(Oracle, SQL Server, or DB2) to another geodatabase that uses grid sizes, the index is copied along with the source 
data and not recomputed. When you use a geoprocessing tool that creates a feature class, the features in the new 
feature class are examined and a new spatial index is automatically computed.  
 
When you save edits to a file geodatabase feature class in ArcMap, ArcGIS analyzes the spatial index. If grid sizes are 
set to 0,0,0, it automatically rebuilds the index with an appropriate grid size given the features that have just been 
added. This does not occur in ArcSDE geodatabases.  

 
When you do need to manually update the index, we've made this easier. The Feature Class Properties dialog 

Index tab now has a Recalculate button. When you click this button, ArcGIS computes optimal grid sizes for the 
feature class. When you click Apply or OK, the index is rebuilt with the new grid sizes:  
 

 
 
You can still set your own, custom grid sizes in the Feature Class Properties dialog if needed using the Edit button. 
The Calculate Default Spatial Grid Index geoprocessing tool now returns two or three grid sizes if they are determined 
to be better than a single grid size. 
 

 The only difference between 9.1 and 9.2 for spatial indexes in personal geodatabases is that the Grid 1 level (the 
only level supported by personal geodatabases) now defaults to 0 instead of 1000 in the New Feature Class wizard. If 
you leave this value as 0, it will default to 1000 once the new feature class is created.  
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Improved property dialogs for feature data 

The Feature Class Properties dialog includes tabs corresponding to the properties described above. A new XY
Coordinate System tab makes it much easier than in previous releases to review or change the coordinate system of a 
feature class (below left). A new Z Coordinate System tab showing you the vertical coordinate system is present if the 
feature class has Z values (below right): 

 

 

    
 
The Representations tab is another new tab at 9.2. It is used to store cartographic representations in the feature class. 
( See the 'Cartographic representations' chapter of this document).  
 

The Feature Dataset Properties dialog now also includes tabs for XY Coordinate System, Z Coordinate System,
Tolerance (below left), Resolution (below right) and Domain.  
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New file geodatabase format 

Until now, single-user geodatabases in ArcGIS have been personal geodatabases stored in Microsoft Access. 
Personal geodatabases satisfy basic requirements. However their performance slows markedly as the size of datasets 
stored in them increases, and they have a 2 GB overall database size limit. Accessing a personal geodatabase over a 
network concurrently with other users can present additional problems; performance slows further and data locks can 
stay around longer than you’d expect, blocking other users from accessing the data. 
 
ArcGIS 9.2 introduces an alternative, a new type of single-user geodatabase referred to as the file geodatabase. A file 
geodatabase stores datasets as a folder of files on your file system, much like you’d store a folder of shapefiles. 
Individual datasets can be as large as 1 terabyte and there is no overall database size limit. Compared to personal 
geodatabases, file geodatabases improve performance, store vector data more efficiently, and improve concurrency 
and multi-user access over a network. You can also optionally store vector feature classes and tables in a 
compressed, read-only format to reduce storage requirements further. File geodatabases are also fully supported 
across platforms. One of the driving forces behind introducing this format was to provide support on both Windows and 
UNIX. For example, you can use Java to create and access file geodatabases on UNIX. 
 

To create a file geodatabase, right-click a folder in the ArcCatalog tree view and click New, then click File
geodatabase. 

 

 
Personal geodatabases continue to be fully supported at 9.2. You can continue to create and work with personal 

geodatabases just as you always have. Personal geodatabases can be upgraded to 9.2 in the usual way so that you 
can use them with all the new functionality introduced at 9.2. 
 

Personal geodatabases and file geodatabases look the same in ArcCatalog, and the structure of the data within 
them is the same. You can easily move data from one to another with the Copy and Paste commands. You also work 
with them the same way, whether accessing data through ArcCatalog or ArcMap, or through ArcObjects as you
developing a custom application. The only exception to this is the syntax you use to perform a SQL query in ArcMap: 
there are some slight differences.  

’re 

 
 In the Desktop Help, see these topics: 

Mapping and visualization > Navigating and interacting with maps > Selecting features and graphics > About building 
an SQL expression 
Mapping and visualization > Navigating and interacting with maps > Selecting features and graphics > SQL 
reference 

 
File geodatabases store data efficiently in their default format, but by compressing feature classes and tables in file

geodatabases you can make them require significantly less disk space. The amount of compression possible depends 
on the data and can range from an insignificant amount to a ratio exceeding 10:1. Most file geodatabase data can 
compress by a ratio of 2:1 or better, meaning that a 100 MB feature class for example could compress down to 50 MB 
or less.  

 

 
Once compressed, a feature class or table looks the same in ArcCatalog and ArcMap as when it was uncompressed, 
and you work with it in the same way. The exception to this is editing: a compressed feature class or table is read-only 
and therefore cannot be edited or modified in any way, except for changing its name in ArcCatalog. Compressed 
feature classes and tables can be uncompressed to return them to their original, read-write format. To compress or 
uncompress a feature classes or table, right-click it in ArcCatalog and use the Compress File Geodatabase Data or 
Uncompress File Geodatabase Data commands. You can also access these commands by right-clicking the file 
geodatabase itself or a feature dataset it contains, in which case the operation will apply to all feature classes and 
tables inside the geodatabase or feature dataset. These two commands launch geoprocessing tools from the new 
Data Management > File Geodatabase toolset in ArcToolbox: 
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When you look at the properties of a feature class or table in a file geodatabase in ArcCatalog, a section at the bottom 
of the General tab tells you whether or not the feature class or table is currently compressed: 
 

 
 

File geodatabases are supported in all geoprocessing tools except for MakeQueryTable. At 9.2 file geodatabases 
don't support the QueryDef object used by the MakeQueryTable tool.  
 

For more information on the differences between a file and personal geodatabase in the Desktop Help, see: 
eodatabases and ArcSDE > An Overview of the Geodatabase > Types of geodatabases G

 

 

 
Putting your existing data into file geodatabases 

To convert a personal geodatabase into a file geodatabase you use the existing tools for working with 
odatabase data. There is nothing special about file geodatabase in this regard, except that they do have 
nfiguration keywords that customize the storage. Most users can use the default configuration keyword. The other 
nfiguration keywords are intended to be used by advanced users who want to invest t

ge
co
co ime to maximize performance 

r very large datasets. 

- e 

 
- ta from a personal geodatabase into a file geodatabase, we recommend using the normal ArcCatalog 

Copy and Paste commands. Copy and Paste is flexible because you can easily choose exactly what you want to 

atabase 
 geodatabase and choose Paste.  

 W
s of any range or coded values attribute domains 

that are referenced by the feature classes you are pasting. These attribute domains will be automatically pasted into 
the target geodatabase. Advanced users can also use this to choose the configuration keyword that will be used for 
each item. If your file geodatabase already contains data, this dialog will also warn you in red about any naming 
conflicts.  

 

fo
 

To turn an existing personal geodatabase into a file geodatabase, we recommend using the Export>XML Workspac
Document command to export the database to an XML file. You can then create a new, empty file geodatabase and 
use Import > XML Workspace Document to load the data from the XML file into this geodatabase. 

To copy da

copy. You can select everything in the personal geodatabase or just particular items such as a set of feature 
datasets that you want to work with. For example to copy a feature dataset from a personal geodatabase into a file 
geodatabase, first create a new empty file geodatabase in ArcCatalog, select the items in the personal geod
you want and choose Copy, and then go to the file

 
hen you paste geodatabase data in ArcCatalog a confirmation dialog appears. This lets you see the items you are 

about to paste. The confirmation dialog also shows you the name

To move shapefiles into a file geodatabase, you use the same method that you would use to move them to a 
personal geodatabase. You can select shapefiles in ArcCatalog, right-click and choose the Export > To Geodatabase 
command (use the 'Multiple' command to export multiple shapefiles at once). You can also find these tools in 
ArcToolbox under Conversion > To Geodatabase.  
 

In the Desktop Help, see: Geodatabases and ArcSDE > Building a geodatabase > Creating a geodatabase > 
Geodatabase migration > Migrating to the file geodatabase 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  31 



Easier to use and deploy ArcSDE technology 

ArcSDE is ESRI's data management technology for managing multi-user, transactional geodatabases using industry 
standard relational database management software (DBMS). Up to now, ArcSDE has been sold as a separate product. 
This changes at 9.2 in two respects:  
 
Firstly, the ArcGIS Server product introduced at 9.0 has been expanded to include ArcSDE, so when you purchase 
ArcSDE you now buy it as part of ArcGIS Server. ArcSDE is no longer purchased on its own as a separate product. 
This change makes ArcGIS Server at 9.2 our comprehensive solution for managing geographic data in a multi-user 
environment and deploying data and applications throughout organizations and across the Web. ( See the 'ArcGIS 
Server' chapter of this document).  
 
Secondly, at 9.2 the ArcSDE technology adds support for Microsoft SQL Server 2005 Express Edition, a lightweight, 
full-featured DBMS designed specifically for simple setup and administration. SQL Server Express is provided for free 
by Microsoft and we include it with ArcEditor and ArcInfo. SQL Server 2005 Express Edition is limited to run on 1 CPU 
(single or dual core within 1 socket) and utilize a maximum of 1 gigabyte RAM memory. The maximum total database 
size for SQL Server Express is 4 gigabytes. Security is based on your operating system/LAN's existing user 
authentication, so there are no separate database user names and passwords to administer. 
 
We have leveraged this new platform to make it much easier to deploy ArcSDE and get started using multi-user 
geodatabases, including a new Personal ArcSDE technology that is included for free with ArcGIS Desktop at the 
ArcEditor and ArcInfo license levels. With these changes, ArcSDE geodatabases readily scale from the personal and 
small team level, through to workgroups, and on up to extremely large enterprise geodatabases. These new support 
levels let organizations take full advantage of ArcSDE technology for any number of users, large or small, with one 
scalable data architecture that works from single user systems up to large enterprise wide systems.  
 
Here are the details about how ArcSDE technology is delivered at 9.2: 
 

Personal ArcSDE technology included free with ArcEditor and ArcInfo 
 

At 9.2, anyone using ArcEditor or ArcInfo can now set up and administer their own ArcSDE database server and 
create multi-user geodatabases. Personal ArcSDE supports all the advanced features found in ArcSDE such as 
versioning, archival history, multi-generational replication, and advanced dataset-level security. Personal ArcSDE 
uses the SQL Server Express DBMS included in Desktop at the ArcEditor and ArcInfo license levels, so no 
additional software or database administration expertise is required. All database administration is performed using a 
new set of dialogs in ArcCatalog.  
 
Personal ArcSDE database servers support up to 4 concurrent users, 1 of who can edit the data at any time. Use 
Personal ArcSDE to try out ArcSDE if you've not used it before. Or put it to work immediately on your small team 
projects. As with all ArcSDE geodatabases, ArcView users can view but not edit Personal ArcSDE geodatabases. 

 
Workgroup ArcSDE technology in the new ArcGIS Server Workgroup product 

 
At 9.2, ArcGIS Server is available scaled by capacity to two levels: ArcGIS Server Workgroup and ArcGIS Server 
Enterprise. The ArcGIS Server Workgroup product includes our new Workgroup ArcSDE technology. Like Personal 
ArcSDE, this is based on SQL Server Express and all database administration is performed in ArcCatalog, so it is 
very easy to deploy and manage.  
 
Workgroup ArcSDE database servers are licensed to support up to 10 concurrent users, all 10 of who can edit the 
data at any time. ArcGIS Server Workgroup is designed to be a low cost solution for small to medium sized teams 
and organizations. Each of the three editions of the ArcGIS Server Workgroup product (Basic, Standard, and 
Advanced) includes Workgroup ArcSDE.  
 
Enterprise ArcSDE technology in the new ArcGIS Server Enterprise product 

 
Enterprise ArcSDE technology is the traditional ArcSDE technology that runs on Oracle, SQL Server, DB2, and 
Informix and can scale to databases of any size and number of users, running on computers of any size and 
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configuration. Users provide their own DBMS license for this level of ArcSDE use. The DBMS is typically 
administered and managed by a database administrator (DBA) using ArcSDE administration commands and the 
standard tools provided by the DBMS being used. 
 
At 9.2, Enterprise ArcSDE technology is included in the ArcGIS Server Enterprise product. Each of the three editions 
of the ArcGIS Server Enterprise product (Basic, Standard, and Advanced) includes Enterprise ArcSDE. 

 
As in previous releases, an ArcEditor or ArcInfo license is required to create ArcSDE geodatabases and to create and 
edit data in them. ArcView users can read the data in ArcSDE geodatabases but cannot create or edit this data. 
 
 
Setting up and working with a Personal ArcSDE or Workgroup ArcSDE database server 
 

To setup a Personal ArcSDE database server, you run the Setup program that comes with your ArcGIS Desktop
installation media at the ArcEditor or ArcInfo license levels. To setup a Workgroup ArcSDE database server, you run 
the Setup program that is part of the installation media for ArcGIS Server Workgroup. Both of these setups install 
Microsoft SQL Server Express and give you administrator permissions. After running the setups, you are ready to 
connect to the new database server in ArcCatalog. 

 

 
A new Database Servers folder has been added into the ArcCatalog tree that enables you to connect to Personal 

and Workgroup ArcSDE database servers. In that folder, double-click Add Database Server, and type in the name of 
the computer that SQL Server Express has been installed onto and the instance name. In the example below, a 
connection a connection is being made to a Personal ArcSDE database server installed on a computer called 
'essinger2' and the server instance name is 'sqlexpress': 
 

 
 
The database server you connected to will appear in the folder: 
 

  
 

To create a new geodatabase on a database server, right-click it and choose the New Geodatabase command: 
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Other administration commands in that context menu include the Permissions command that lets you control which 
users can access the database server. Only users with administrator permissions can perform administration. 
 

Geodatabases are listed underneath the database server they belong to and you can browse down to the data they
contain in the usual way. In this example, four geodatabases have been created on the database server: 

 

 

 
 
Right-click on a geodatabase in a database server to access additional commands for administering the geodatabase: 
 

 
 

The Database Connections folder in ArcCatalog is unchanged at 9.2. This is still where you go in ArcCatalog to 
create or access connections to Enterprise ArcSDE geodatabases. (Enterprise ArcSDE servers cannot be accessed or 
administered via the new Database Servers folder). You can also create connections directly to geodatabases on 
Personal ArcSDE and Workgroup ArcSDE database servers in the Database Connections folder. The main benefit to 
doing this is if you are working with versioned geodatabases on your Personal ArcSDE or Workgroup ArcSDE 
database server. A connection to a geodatabase in the Database Connections folder points to a specific version of a 
geodatabase, so creating a database connection makes it easy to access to a particular version on a regular basis. 
 

In the Desktop Help, see these topics: 
Geodatabases and ArcSDE > Administering ArcSDE geodatabases > An overview of ArcSDE geodatabase 
administration 
Geodatabases and ArcSDE > Administering ArcSDE geodatabases > Different types of ArcSDE geodatabases 
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Data distribution using replication 

Many organizations require distributing copies of their data to regional offices so they may work on all or part of the 
geodatabase and submit updates back to the central office. In the past this was done by creating a copy on cd, dvd or 
onto an ftp site, and changes were coordinated so that the data at the central and regional offices were in sync. This 
distribution arrangement takes careful coordination and continuous communication between offices to keep the 
updates in order and the data synchronized. 
 
ArcGIS 9.2 introduces a solution to data distribution through a utility called geodatabase replication. New functionality 
in ArcCatalog and ArcMap allow you to create and manage replica copies of the geodatabase in whole or in part. 
These replicas can be distributed as necessary throughout an organization and are capable of coordinating data 
changes through a synchronization process. The model allows for synchronization of replicas even when working 
independently or in disconnected environments. Geodatabase replication supports the full data model, so geometric 
networks, topologies and relationship classes are all capable of being replicated. Two or more geodatabases can be 
synchronized with multiple generations of edits to each database. This extends the checkout/check-in model by 
allowing the checked-out version to be periodically refreshed from the master geodatabase and allowing multiple 
check-ins. Database changes are moved between the databases as changes to versions, and standard reconcile and 
post mechanisms are used to synchronize the changes. 
 
Through the implementation of geodatabase replication advanced workflows and scenarios become available. These 
workflows can be automated using new geoprocessing tools for replication. 
 

The Disconnected Editing toolbar in ArcMap has been replaced with a new Distributed Geodatabase toolbar. This
contains the functionality that was available previously but is now fully enhanced to include the new replication 
functionality: 

 

 

 
 
 

In the Desktop Help, see: 
 

 Geodatabases and ArcSDE > Data management workflows, transactions, and versioning > Managing distributed 
data > Understanding distributed data 
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Historical archiving 

In past releases of ArcGIS historical records were kept by creating a version of the geodatabase that would 
represent the data at a specific point in time. These historical versions would capture the entire geodatabase and if 
your requirements demanded frequent archiving then your database would become cluttered by maintaining multiple 
instances of the data.  
 
While these historical versions are still supported, ArcGIS 9.2 offers another method of maintaining a historical record 
of your ArcSDE geodatabase data called geodatabase archiving. With archiving you can select which features you 
wish to enable archiving on and you do not have to maintain a historical record of the entire geodatabase if it is not 
necessary. When archiving is enabled, updates are recorded and can later be queried to view the state of the feature 
throughout its history. You can connect to historical instances of the database and view how it looked at a specific time 
or see how it has evolved over time. This archive is created automatically as you update data changes and allows for 
historical records to be maintained at a frequency to suit your workflow. 
 

 
 
Historical archiving requires versioning, so is only supported in ArcSDE geodatabases. 
 

In the Desktop Help, see:  
 

Geodatabases and ArcSDE > Data management workflows, transactions, and versioning > Archiving data > 
Geodatabase archiving 
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Non-versioned multi-user editing  

Previously, a geodatabase could only be edited by multiple users if it had been versioned. This included all spatial
and non-spatial tables. This satisfied workflows requiring long transactions. Edits spanned as many edit sessions as 
needed, and changes were isolated from other database users, and no locks applied to the data you edit.  

 

 
While this presented few problems for GIS-only databases, it did create difficulties for some organizations that used 
the same database for GIS and non-GIS applications. Versions make integrating geographic data with third-party 
applications (those not created with software from ESRI) more difficult because any database constraints, triggers, and 
unique indexes you’ve set up in your existing applications don’t apply to versions. Versions can also add additional 
overhead if you only need to make simple changes to data that is not part of a topology or geometric network.  
 
At ArcGIS 9.2, multi-user editing is possible without versioning. We have added a short transaction editing model for 
simple feature databases that can be applied on a table-by-table (feature class-by-feature class) basis. In this way, 
both GIS and non-GIS applications can share access to a common DBMS without adding the overhead of versioning 
to those applications that do not need it.  
 
To perform non-versioned editing in an ArcMap edit session, specify in the Editor > Options dialog Versioning tab that 
you don’t want to edit a version of the data: 
 

 
 
You can then start editing in an ArcMap edit session, and perform individual operations on the data just as in any other 
edit session – adding, deleting, and updating records. When you save, changes commit as a single database 
transaction. Any constraints, triggers, and unique indexes you’ve set up apply. If you quit the edit session without 
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saving, the edits roll back. ArcGIS uses the underlying DBMS transaction model – rows lock as you edit them and the 
isolation level you set in the DBMS applies, just as in any standard DBMS transaction.  

 
Non-versioned editing is not available for feature classes in a topology or geometric network. You must edit these 
feature classes in a versioned edit session. 
 

In the Desktop Help, see: Geodatabases and ArcSDE > Data management workflows, transactions, and versioning 
> Working with non-versioned data > An overview of working with non-versioned data 
 
 
Versioned and non-versioned editing on the same data 
 

In a heterogeneous computing environment where you have a number of different departmental applications 
accessing the same database, you may require the ability to support both ArcGIS and third-party applications that 
were created without software from ESRI. An example of this is if you have one department that maintains the 
geographic data in the database with ArcGIS and another department that maintains customer records in the same 
database with a third-party application. The third-party application may not recognize versioned tables, and needs to 
apply DBMS constraints and triggers as transactions are made. At the same time, the other department needs to edit 
the geographic data in its own isolated version, not sharing the departmental edits until they are complete and 
approved. 
 
With these requirements in mind, ArcGIS now allows you to perform versioned editing on a feature class or table while 
retaining the ability to share edits with other applications. To enable this capability on a feature class or table, you 
register the data as versioned with the option to move edits to the base table. This option is available in the registration 
dialog.  
 
When you edit data registered this way, versions work the same way as they always have—changes are saved in the 
delta tables. The exception to this is the DEFAULT version. Whenever you save edits to the DEFAULT version, either 
by editing it directly or merging in changes from another version, the edits are saved in the base tables. The edits do 
not remain in delta tables as is the case when the Move edits to base option is unchecked.  
 
This allows all applications to work on the same database:  
 
- Applications written without software from ESRI can continue to access and modify data with standard transactions, 

even if it's being edited in the DEFAULT or another version at the same time.  
 
- Whenever ArcGIS or an application written with ArcObjects saves changes to the DEFAULT version or merges 

changes into the DEFAULT version, any unique indexes, constraints, and triggers defined on the data with the 
DBMS apply.  

 
- When one application modifies the data, the changes become immediately available to any other application 

accessing the data. Since changes to the DEFAULT don't store in delta tables, there is no need to adapt third-party 
applications with multi-versioned views so that they can read these tables.  

 
In previous releases of ArcGIS, you either registered data as versioned and edited versions of the data, or you left the 
data unversioned and directly modified the data source through an application written with ArcObjects. There was no 
way to manage data with both capabilities simultaneously. 
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New options for reconciling versions 

Reconcile is the operation you perform to check for conflicts before you merge a version into its parent version. A
conflict can occur when the same feature is updated in both the current version being edited and the target version. In 
previous versions, ArcGIS considered it a conflict even when different attributes were edited. If you considered a 
conflict to be one where only the same value was edited, you had no way to prevent these from being recognized as 
conflicts. With ArcGIS 9.2 you can now choose one of the following in the Reconcile dialog: 

 

 
- A conflict occurs when any attribute is updated 
 
- A conflict occurs when the same attribute is updated 
 
In previous versions, ArcGIS initially resolved conflicts in favor of the parent version representation. The only way to 
resolve a conflict in favor of the version you’re editing was to explicitly choose your edit session representation in the 
conflict resolution dialog. With ArcGIS 9.2 you can now choose to initially resolve all conflicts in favor of either the 
parent version or your edit session. If conflicts arise between your edited version and the target version when you 
reconcile, you can resolve these conflicts interactively in the new conflict resolution dialog box. When you resolve 
conflicts, you are deciding which representation of the features and attributes you want to keep.  
 
Regardless of what version you opted to reconcile in favor of—the target or your edited version—you can specify 
which representation to keep; either the pre-reconcile representation (how it appeared in your version prior to 
reconciliation), conflict representation (how it appears in changes made by another editor), or common ancestor 
representation (how the feature or attribute is in the target version).  
 
Conflicts can be resolved at several different levels: Field level (attribute), Row level (individual feature), Class level 
(entire feature class), and Root level (all conflicts in all feature classes and features for a particular reconcile 
operation). 
 
A new Conflicts dialog improves productivity by allowing you to easily visualize spatial conflicts in the pre-reconcile, 
conflict and common ancestor versions. Additionally the dialog reports which conflicts have been visited and gives you 
the ability to resolve conflicts at the individual attribute value: 
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Saving edits to a version edited by others 
 

Since you started editing a version, another user may have saved edits to the same version. When you save your
edits, ArcGIS must compare the representation in your edit session with the one in the database and reconcile any 
differences. This process is similar to the reconcile that takes place when you merge a version into its parent version, 
and contains similar enhancements at 9.2. You can now specify how you want conflicts defined, and whether to initially 
resolve them in favor of either the representation in your edit session or the representation in the database. You can 
access these options on the Versioning tab of the Editor > Options dialog (see above). 

 

 
There's an additional enhancement in the Editor > Options. In previous versions of ArcGIS, you could either choose 

to be notified of the other user’s edits so you can review the results of the merge, or you could have ArcGIS perform 
the reconcile, only notifying you if there are conflicts. ArcGIS 9.2 now provides a third option: “Automatically save 
changes in all cases” which never notifies you of the other user's edits. With this new option, ArcGIS always merges 
the two representations of the version. If there are conflicts, it resolves them according to the conflict resolution rule, 
which states whether conflicts resolve in favor of the edit session or the database. 
 
 

Improved support for Oracle 

New spatial type. 9.2 introduces a new spatial type for Oracle that allows SQL access to simple ESRI features
stored in Oracle using standard ISO Multi-Media/OGC SQL statements. This sort of access was already available to 
Informix and DB2 users through their spatial extension; this new spatial type extends the same sort of access to 
Oracle users. It gives you ArcSDE’s Binary schema performance and scalability with the flexibility of a standards-
conformant SQL interface to the spatial data. In 9.2 Service Pack 1, the ST_Transform function has been implemented 
for the spatial type for Oracle. ST_Transform lets you change the ST_Geometry of a layer into a different spatial 
reference using SQL by specifying a Spatial Reference ID. 

 

 
Multiple geodatabases in Oracle. At ArcSDE 9.2, you can create multiple geodatabases, within a single Oracle 

database instance. This allows Oracle users to manage different projects or departments whose work is completely 
independent of each other. Each Geodatabase is created within separate user schemas.  
 

Support for Oracle Spatial GeoRaster. Oracle introduced the Oracle Spatial GeoRaster data type in their 10g
release. ArcSDE 9.2 provides direct read and write ability for Oracle Spatial GeoRaster. As with Oracle Spatial vector 
data, ArcSDE is also able to read existing Oracle GeoRaster data that has been registered with ArcSDE. Users will be 
able to manage their Oracle Spatial GeoRaster data just as the regular ArcSDE raster data with a few exceptions: 
Oracle 10g R1 does not have compression support for their GeoRaster data. Any raster catalogs created using Oracle 
10g R1 Oracle Spatial GeoRaster data will be loaded as uncompressed data. If you are using Oracle 10g R2, 
compression support is available for your raster catalogs. Also Oracle Spatial GeoRaster does not support a partial 
update or mosaic operation on a raster value, only complete raster objects can be inserted or updated.  

 

 
 

Operating system authentication for ArcSDE 

In previous versions of ArcGIS in order to connect to an ArcSDE database you needed to supply a username and 
password. This meant that the network administrator had to set up a separate account for each individual, and had to 
manage these accounts. For large organizations this can prove to be a nuisance, especially since users most likely 
already have a log in name and password for their operating system. 
 
With ArcGIS 9.2 a more efficient method of connection is implemented called operating system authentication, or OS 
authentication. OS authentication is a method of connecting to an ArcSDE database by using your operating system 
log in username and password as credentials to authorize the connection. Since each user already has a unique 
identifier for logging into the system, this can be used to authenticate an ArcSDE log in. OS authentication is highly 
effective for internal web applications and corporate intranets. 
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Full support for Unicode 

Single and multi-byte characters (Unicode) are now fully supported throughout ArcGIS. This enables you to store 
strings in multiple languages in the same dataset. For example, places in Asia can be labeled with their local language 
name and English language name stacked on top of each other on a map. 
 

At 9.2 ArcSDE is fully Unicode based. Unicode applications utilize ArcSDE on Unicode databases without data loss
or character set restrictions. This allows ArcGIS Desktop, ArcGIS Server and ArcIMS to work in a multi-language 
environment with less risk of data loss.  

 

 
 

Support for IPV6 

The Internet is at the beginning of a change in its underlying protocol, from the classic Internet Protocol version 4 
(IPv4) to the new Internet Protocol version 6 (IPv6). While there are a number of advantages to IPv6, the most visible 
is the increased size of the address from 32-bits to 128-bits. This results in an exponentially greater number of 
available Internet addresses. ArcSDE 9.2 supports both IPv4 and IPv6 protocols. There is no action required on the 
part of the user or systems administrator. ArcSDE accommodates both protocols when supported by the network over 
which communication is occurring. 
 
 

ArcSDE administrators 

The syntax for the sdesetup command has changed in 9.2; it is now generic across all DBMSs. You will use the -d
option to specify the database with which you want to use ArcSDE: either DB2, INFORMIX, ORACLE9I, ORACLE10G, 
or SQLSERVER. For example, to install ArcSDE to be used with DB2 you would issue the following: 

 

 
sdesetup -o install -d DB2 -u sde 

 
Two new operations have been added to the sdedbtune command to help manage the contents of the DBTUNE 

table: alter and delete_data.  
 
The alter operation allows you to edit the value of a DBTUNE configuration parameter. For example, to change the 
value of the GEOMETRY_STORAGE parameter under the DEFAULTS keyword to use ST_GEOMETRY storage: 

 
sdedbtune -o alter -k DEFAULTS -P GEOMETRY_STORAGE -v "ST_GEOMETRY" -u sde 

 
The delete_data operation allows you to delete a configuration parameter or an entire configuration keyword and its 
parameters. For example to delete a parameter under a keyword: 

 
sdedbtune -o delete_data -k WKB_GEOMETRY -P UI_TEXT -u sde 
 

or to delete an entire keyword (all of its parameters): 
 
sdedbtune -o delete_data -k RASTER_DEFS -u sde -p sdepswd 

 
 
For details and complete command options, please consult the ArcSDE Administration Command Reference for 9.2. 
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CAD 

New CAD dataset organization 
 
We’ve changed the way CAD datasets are organized in ArcGIS. Previously, each CAD file was represented as two 
entries in the Catalog: as a CAD feature dataset and as a CAD drawing file. Now we have combined these two 
representations into one location – inside of the CAD feature dataset: 
 

 
 
This change is intended to reduce confusion and to make accessing the contents of a CAD file easier. This also 
reduces the number of entries that you will see when you browse a workspace that contains CAD data by half.  
 
 
Expanded attribute support 
 
We’ve expanded our support of CAD properties so you can have access to more information about your CAD 
drawings. These CAD properties are represented as fields in a CAD feature class’s attribute table. Having access to 
more attributes can help you query, analyze, and symbolize your CAD data more effectively.  
 
We have doubled the number of fields that are supported for CAD feature classes. For CAD annotation feature 
classes, this support has been tripled. In addition to providing more access to data, another objective for expanding 
attribute support is to achieve equivalence with other ArcGIS CAD tools, such as the geoprocessing Import from CAD 
tool and ARC/INFO Workstation’s CAD conversion utilities (DXFARC and IGDSARC).  Some key new fields: 
 
- Point rotation values – for blocks and cells 
- Elevation/Z coordinate value – for MicroStation elements 
- Line weight values – for DXFARC and IGDSARC users 
- Layer and entity drawing properties – not just feature specific (e.g., Color, EntColor, LyrColor, BlkColor) 
- Document name and path reporting 
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Easier to georeference CAD layers 
 
It is now easier to transform CAD layers to match the other features in your map. Previously, all CAD transformations 
were performed via the Layer Properties dialog Transformations tab , which involves typing coordinate values to define 
the transformation or browsing to a World File.  At 9.2 we have also implemented CAD layer support in the existing 
Georeferencing toolbar to provide a fully interactive alternative to using the Transformations tab: 
 

 
 
This allows you to move, rotate, and scale your CAD layer using the mouse. Additionally, you can add control points in 
the map with your mouse cursor and use snapping to ensure accurate control point placement (an edit session and an 
editable data source is required for snapping). You can also view and edit source and destination coordinates using 
the dialog launched from the View Link Table button in the Georeferencing toolbar: This dialog also lets you load and 
save world files: 
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Improved feature rendering 
 
We have improved CAD feature class rendering. Previously, CAD features were rendered using the same default 
method used for all other feature layers – Single Symbol. We now use the display properties that are inherent in every 
CAD drawing (‘CAD unique entity values’ category) and symbolize the data based on those values. In conjunction with 
a new CAD specific map style, we now render CAD features automatically using their original color, line-type, and line-
weight values when they are added to the map. 9.2 also adds support for the most commonly used line type symbols 
and will continue to add more support in future releases. 
 
We have also improved CAD annotation feature class rendering. Many CAD drawings contain text that use True Type 
Fonts. Therefore, we now set the fonts for those text entities using the same True Type Fonts that are supported in 
ArcGIS. This provides a more accurate representation of the CAD annotation and could help eliminate the need for 
you to modify the text symbols in ArcMap. Original CAD rendering can be restored in case symbols are modified. 
 
 
User interface standardization and improvements 
 
To ensure that the user experience is consistent with other data source types, we have standardized the CAD dataset 
and layer properties dialogs so they better match the ones for geodatabase feature datasets and classes. In addition to 
standardization, we have also improved the tabs that support CAD feature layer settings. We have redesigned the 
Fonts tab so that it reports more information about text styles that exist in your CAD drawing: 
 

 
 
We have also improved the Drawing Layers tab to ensure that long drawing layer names in the list are not cut off. We 
also support color and line type information per drawing layer: 
 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  44 



 
 
 
Other CAD enhancements 
 

Group layers are now used to represent CAD feature datasets when they are added to ArcMap. This provides a 
more efficient way to manage the contents of the dataset. It also saves space in the ArcMap Table Of Contents since 
the new CAD rendering displays significantly more symbols per feature layer. There's also a new button on the 
Drawing Layers tab that allows you to apply drawing layer visibility settings to the entire CAD feature dataset at one 
time. Previously, the settings for each CAD feature class had to be managed individually .  
 

Block attributes and tags are now supported as CAD annotation features. This is important for those who work with 
CAD drawings that contain these entities and elements and need access to this data. Along with the pertinent 
information they provide, they can also be important cartographic elements in a drawing. ArcGIS treats these features 
the same as text entities, so you can customize the appearance of their symbols as you desire.  
 

Drawing layer visibility settings can now be applied to all the feature classes of a CAD feature dataset via the ‘Apply 
to Dataset’ button located in the Drawing Layers tab. 
 

Improved Multi-line Text display with filtering of special characters and format codes. 
 

ArcGIS 9.2 adds support for AutoCAD 2007 DWG/DXF files. 
 

AutoCAD Custom Object proxy geometry is now supported as ArcGIS CAD features. Custom objects created with 
tools like Autodesk Civil 3D or Autodesk Map 3D are now read as ArcGIS CAD features. The tabular object data that 
may be associated with these custom AutoCAD objects and any special custom geometric representations are still 
locked away from the standard industry interoperability tools in a proprietary Autodesk encoding format. However, the 
included proxy geometry, defined by the authoring application for standard CAD users, is now used as the feature 
geometry in ArcGIS instead of simply omitting the feature. 
 
 
 

See the new CAD section in the Desktop Help: Data support in ArcGIS > CAD data. 
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Rasters 

Supported raster formats 
 

ArcGIS 9.2 can read raster data in these additional formats: 
 
- BSB (.kap) 
- ERMapper’s ECW (no need to download plug-in from ERMapper) 
- HDF4 
- IDRISI (.rst) 
- PCI  
- PCRaster 
- USGS ASCII DEM 
- X11 Pixelmap 
 
Note: ECW is not supported by ArcIMS and ArcGIS Server by default. Users need to purchase license through 
ERMapper, and then compile and install an ECW format driver to obtain ECW support for these two products. 
 

Performance has been improved for reading MrSID, Jpeg2000, RPF (CIB and CADRG) and some other formats 
 

ArcGIS 9.2 can write out raster data in these additional formats: 
 
- GIF 
- Jpeg2000 (JP2) 
- JPEG 
- PNG 
- Windows BMP 
 
 
Improved raster projection and transformation 
 

At 9.2, ArcGIS can manage orientation information from satellite imagery (QuickBird’s level 1B and level 2A 
products as well as IKONOS’s Geo-Ortho Kit product delivered as TIFF format). The RPC (rational polynomial 
coefficients) information associated with the TIFF images is now read and applied on-the-fly when displaying in 
ArcGIS. ArcGIS 9.2 can also store and preserve the orientation information with raster datasets or raster catalogs in 
any data sources, whether file-based or geodatabase raster. 
 

Raster data can now be projected on-the-fly faster and more accurately than ever. In 9.1, the Tools > Options dialog
Raster tab (launched from any Desktop application) had a check box option called 'Favor rendering speed over 
accuracy'. This has been removed at 9.2 because of the improved raster projection and transformation environment in 
this release. On-the-fly raster projections can now have half pixel accuracy or better. At 9.2, rasters support a 
collection of transformations, which means that raster projection on-the-fly, raster transformation and data frame 
rotation can all occur in any sequence. The Project Raster geoprocessing tool, which is used to create a permanent 
projected raster, is now faster and more accurate, and supports datum transformation and setting registration points. 

 

 
A new setting in the Tools > Options dialog Raster tab (launched from any Desktop application) allows you to 

specify that ArcGIS should use the geographic information stored in the world file, if present, instead of the AUX or 
header information when it accesses raster data. If AUX or header information is not present, ArcGIS will attempt to 
use the world file irrespective of whether this option is checked or not. Check this box if you would prefer ArcGIS to 
always use the world file instead of the AUX or header information where possible. This option was previously 
available solely as a registry setting and was not exposed in the user interface: 
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Orthorectification 
 

Orthorectification is now supported in ArcGIS. Orthorectification allows you to remove distortion from an image 
resulting from sensor location/orientation and ground elevation so that there is consistent scale across all parts of the 
image. Orthorectification is the process of stretching an image to match the spatial accuracy of a map. 
Orthorectification is supported for rasters which have RPC (rational polynomial coefficients) information associated 
with them. Imagery is usually supplied with this information already associated with it, such as the _rpc.txt file for 
IKONOS images and the .rpb file for QuickBird images. You can either orthorectify using a constant elevation or by 
using a DEM raster for the same location. You can find the orthorectification on-the-fly option in the Raster Layer 
Properties dialog Display tab. The check box is only enabled if the raster layer's data source has RPC information 
associated with it: 
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A new geoprocessing tool is also provided enabling you to write out a rectified raster. 
 
 Data Management > Raster > Create Ortho Corrected Raster Dataset 
 

In the Desktop Help, see: Data support in ArcGIS > Raster data > Raster display and visualization > Orthorectifying 
a raster dataset 
 
 
Georeferencing toolbar enhancements 
 

ArcSDE raster datasets can now be georeferenced using the georeferencing toolbar. The true convenience of being 
able to do this without reloading the new rectified raster data is offered through an enhancement made to the Update 
Georeferencing menu choice. Raster datasets can now be associated with a transformation list, which incorporates all 
transformations being applied to the raster. Previously, only single transformations were supported through world files 
and other information contained in AUX files. Now, users can associate a list of transformations with each raster 
dataset, thereby only resampling the raster data one time, rather than several; this will eliminate many concerns about 
resampling artifacts. 
 

ArcGIS has two new types of transformation capabilities; Adjust and Spline. Both of these new functions allow the
raster being georeferenced to be “warped” to a higher degree, thus abiding more closely to the user’s choice of control 
points/links. Lower RMS error values can usually be witnessed by choosing the Adjust transformation technique, and 
true rubber-sheeting can be attained (no RMS error values) when Spline is chosen as the transformation technique. 

 

 
 
Better support for raster attribute tables 
 

Any single band integer type raster dataset can now have a raster attribute table (RAT) associated with it, including 
rasters stored in ArcSDE. Depending on the raster format, some rasters have a native table that can be read and 
others can have a table built for them.  
 

Raster attribute tables can be edited in ArcMap and joins are fully supported.  
 

A new setting in the Tools > Options dialog Raster tab accessed in all ArcGIS applications lets you define the 
threshold number of unique values for which attribute tables will be built for rasters: 
 

 
 

The na ables (VAT). ArcGIS treats the VATs of 
ke the RATs of non-GRID rasters, VATs 

can now be used as input in geoprocessing tools that accept tables. Just like a RAT, you can add new fields to a VAT. 
For example, you can use the Add Field tool to add a field to RAT for a raster showing landuse, then edit the table to 
include names of landuse types such as Forest, Water, and Urban. 
 

tive raster attribute table of an ESRI GRID is a value attribute t
GRIDs in the same way as the raster attribute tables of non-GRID rasters. Li

Two new geoprocessing tools have been added for working with raster attribute tables: 
 
 Data Management > Raster > Build Raster Attribute Table 
 Data Management > Raster > Delete Raster Attribute Table 
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Panchromatic sharpening 
 

Panchromatic sharpening ('pan-sharpening') allows you to improve the spatial resolution of a low-resolution color 
multi-spectral raster by fusing it with a higher resolution greyscale/panchromatic raster (or raster band). This results in 
a multi-band raster dataset with the resolution of the panchromatic raster. This is especially useful because several 
imagery companies provide low-resolution multi-band images and higher-resolution panchromatic images of same 
scenes. Here's an example: 
 
Input 1: 
 
Original low resolution color image. 

 

 
Input 2: 
 

igh resolution greyscale image used 
n the color image. 

 

H
to sharpe

 
Output: 
 
Resulting pan-sharpened image 
combines the color of the first image 
with the resolution of the second 
image. 
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The new option providing on-the-fly panchromatic sharpening is available in the RGB composite renderer panel in the 
Raster Layer Properties dialog Symbology tab: 
 

 
 
A new geoprocessing tool is also provided: 
 
 Data Management > Raster > Create Pan-sharpened Raster Dataset 
 
This enables you to generate pan-sharpened raster datasets.  
 

In the Desktop Help, see: Data support in ArcGIS > Raster data > Raster display and visualization > Panchromatic 
sharpening 
 
 
Hillshading on-the-fly option  
 

A hillshade effect option is provided in the Raster Layer Properties dialog Symbology tab for the Classified and
Stretched renderers. Using a simplified hillshade algorithm, this option enables elevation data to be displayed with a 
hillshade effect and your specified renderer on the same layer, and allows you to quickly explore data without requiring 
the use of the Spatial Analyst extension to generate a separate hillshade raster dataset:  
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Data loading 
 

You no longer need to store all your raster data in one projected coordinate system, as the raster reprojection on-
the-fly has been enhanced greatly in terms of performance. Loading/storing of raw imagery with their orientati
parameters is also supported, rather than only being able to load previously rectified raster data.  

on 

Two new geoprocessing tools now allow the user to load entire directories and sub-directories directly into raster 
dataset mosaics or raster catalogs: 
 
 Data Management > Raster > Workspace to Raster Dataset 
 Data Management > Raster > Workspace to Raster Catalog 
 
Parallel loading abilities to raster catalogs are then easily accomplished by using more than one ArcGIS Desktop 
machine, loading into one raster catalog from a single data warehouse (one folder, or many subfolders). 
 

Before ArcGIS 9.2, the spatial reference of a raster dataset in a raster catalog had to be the same as the one 
defined in the raster column. This was challenging for states or regions that are located across multiple UTM zones. 
You had to create multiple raster catalogs where each catalog held images of the same projection; or project images 
into one coordinate system if all images were placed into a single raster catalog. 
 
At ArcGIS 9.2, a raster dataset in a raster catalog can have its own unique spatial reference, which can be different 
from the one defined in the raster column. This means that you can preserve the original spatial references of the 
images when storing them in a raster catalog. The footprints of the raster datasets are still stored in the spatial 
reference defined in the geometry column; and the spatial reference of the raster column, if defined, will be used for 
those datasets that do not have a spatial reference defined.  
 
When a raster catalog is displayed, the raster datasets will be projected on-the-fly to the spatial reference defined in 
the geometry column. To create this type of raster catalog, you must specify a known spatial reference for the 
geometry column. The spatial reference could be from one of the raster datasets it contains, or any pre-defined spatial 
reference supported by ArcGIS. Raster loading tools can preserve the spatial reference of a raster dataset during 
loading. The new tool Workspace to Raster Catalog tool has an option where you can choose to re-project the raster 
datasets during loading. Example: The state of Texas lies across UTM zones 13, 14 and 15. The DOQQ data (approx. 
17K images) are available in the three UTM zones. A raster catalog can be created to hold all images in their original 
spatial references. 
 
 
Geoprocessing tools 
 

In addition to the new geoprocessing tools mentioned above, the following new tools are provided for working with
rasters: 

 

 
 Data Management > Raster > Add Colormap 
 Data Management > Raster > Create Random Raster 
 Data Management > Raster > Delete Colormap 
 Data Management > Raster > Get Raster Properties 
 Conversion Tools > To Raster > Point To Raster 
 Conversion Tools > To Raster > Polygon To Raster 

Conversion Tools > To Raster > Polyline To Raster  
 
 
Geodatabase support 
 

ArcGIS 9.2 supports storing rasters in file geodatabases, the database format introduced at 9.2. File geodatabase 
raster support has a similar implementation as ArcSDE raster, where rasters are stored as tiles, but rather than being 
in a relational database management system, they are simply stored on disk. This storage type allows ESRI's 
enterprise geodatabase (ArcSDE) to transfer data to the file geodatabase in a much more simplified manner, which 

oosts performance and ease of use.  b
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Personal geodatabase rasters in ArcGIS 9.2 now support more compression types (JP2000, JPEG and LZ77). 
 

Both personal geodatabase and file geodatabase raster catalogs support the unmanaged raster type, where the 
files on disk are simply referenced from the raster field within the geodatabase.  
 
 
Pixel Inspector 
 

The Pixel Inspector  is a new tool available in the Tools > Customize dialog Commands tab in the Raster 
category that you can drag into any toolbar. This tool lets you display an array of pixel values from a raster layer.  
As you click on the map with this tool, the Pixel Inspector window shows the array of pixel values. The bottom of the 
dialog contains a dropdown list so you can choose which raster layer to inspect. Tabs below the pixel array allow you 
to view the raw pixel values of any band, or the rendered values: 
 

 
 
 
Setting transparency, contrast and brightness 
 

Group layers now have their own transparency, contrast and brightness properties. In this way, you can set these
properties for all the layers in a group layer to control how they will be displayed without having to visit each layer 
individually. This is particularly useful when you want to change these settings for a large number of raster layers.  

 

 
Contrast and Brightness fields have been added into the Layer Properties dialog Display tab for a raster layer. You 

have always been able to change the contrast and brightness of a raster layer using the Effects toolbar (3D Effects 
toolbar in ArcGlobe and ArcScene) but you've not been able to input contrast and brightness values directly into a 
raster layer's property dialog: 
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The Raster Catalog Layer Properties dialog Display tab also now has input controls for Contrast and Brightness in 
addition to the existing transparency control. 
 
 
Other 
 

New vector to raster conversion geoprocessing tools: 

 
 

Conversion Tools > To Raster > Point To Raster 
 Conversion Tools > To Raster > Polygon To Raster 
 Conversion Tools > To Raster > Polyline To Raster 

 
These tools give you more control over the value assigned to a cell in the output raster when there is more than one 
feature falling into the cell. For example when converting polygons to a raster you can now choose the polygon falling 
in the cell center, the polygon of maximum area within the cell, or assign the value based on a priority list.  
 

Raster layers in ArcMap, ArcGlobe and ArcScene created as temporary layers with a geoprocessing tool now have 
an option to make them permanent. You can find the Make Permanent command for raster layers in the Data pullright 
in that context menu. This command is enabled if the raster layer is a temporary layer created with a geoprocessing 
tool or by a command in the Spatial Analyst toolbar. Choosing this command launches the Catalog Browser enabling 
you to save the file. The command is disabled if the raster layer is not a temporary layer. (In ArcGIS 9.1, this command 
was only present and enabled in the context menu for a raster layer if the layer was a temporary layer created by a 
command in the Spatial Analyst toolbar). 
 

The Raster Viewer window launched from the table window and Editor>Attribute window now has a button for 
flashing the feature on the map that the raster belongs to. This button makes it very easy to see the feature on the map 
that the raster belongs to.  
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Terrains 

ArcGIS 9.2 introduces terrains - a new way to store massive datasets containing elevation or other surface data in 
the geodatabase. Elevation and surface measurements such as LIDAR (Light Detection and Ranging - a remote 
sensing system used to collect topographic data) and side scan SONAR (used to collect ocean floor data) can contain 
several hundred thousand to many billions of points. Until now integrating these huge datasets into GIS and generating 
3D surfaces from them has been difficult. Terrains let you store very large point-based datasets in the geodatabase 
and produce high quality, accurate surfaces on-the-fly for display and analysis at varying resolutions as demanded by 
your application. A terrain is a multi-resolution, TIN-based surface stored in the geodatabase built from measurements 
stored as features.  
 

 The 3D Analyst extension is required to create terrains. The extension is not required to view terrains.  
 

Terrains can be stored in any geodatabase (personal, file, or ArcSDE). Similar to a topology, a terrain resides in a 
feature dataset and references the feature classes in that dataset. Rules control how these participating feature 
classes are used to model the terrain. In addition to mass point such as LIDAR data, terrains can reference feature 
classes providing other surface elements such as break lines and other photogrammetrically derived features, lakes, 
streams, obscured or areas with no data, study area boundaries, etc. A terrain references this measurement and 
feature data. It doesn’t actually store a surface as a raster or TIN. Rather, it organizes the data for fast retrieval and 
derives a surface on-the-fly. Here's a terrain stored inside a feature dataset called 'topography'. The feature dataset 
includes all the feature classes that participate in the terrain: 
 

 
 

Terrains achieve high performance at multiple resolutions through terrain pyramids that quickly retrieve only the 
ata necessary to construct a surface of the required level ofd

use
 detail for a given area of interest. Coarser pyramids are 

d at smaller scales to boost performance. Terrain pyramids are similar to raster pyramids but are based on vector 
measurements and are used when the surface is read for analysis and well as for display. 
 

To create a terrain, you first assemble the feature classes that will participate in it. With the new tools provided at 
9.2, ArcGIS is capable of reading a wide variety of surface measurement formats, including LAS, the LAS is an 
industry standard file format for the interchange of LIDAR data: 
 

 
 
To s have been assembled, right-click the feature 
dataset containing the data and choose the New>Terrain command. This command is disabled if the 3D Analyst 

xtension is not enabled. You can also create and manage terrains using new geoprocessing tools: 

launch the wizard for creating a terrain once the feature classe

e
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Tools are provided for converting terrains to rasters and TINs: 
 

 
 

Terrains can be edited and modified over time. Terrains stored in ArcSDE can be versioned. As with other data 
types, versioning offers a powerful approach for editing data in multi-user environments and deriving 'what if' scenarios 
that can be stored and edited simultaneously in the database. 
 

Terrains can be displayed and read by ArcMap and ArcGlobe at all license levels. ArcScene does not support 
terrains because it only supports static representations: it doesn't support dynamic use of levels of details and 
pyramids. 
 

Terrains are supported in ArcGIS Server. 
 
 

In the Desktop Help, see: Data support in ArcGIS > Terrains > What is a terrain dataset? 
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Tables 

Excel support 

Excel files (.xls) are now supported directly in ArcGIS as read-only tables. Excel files are shown in ArcCatalog and 
you can expand them to see the individual worksheets and named ranges they contain: 
 

 
 
Excel worksheets are always shown with a dollar ($) sign at the end of their name in the Catalog tree. 
 

Tables based on Excel data can be used like other tables in ArcGIS with the exception that they can't be edited 
from inside ArcGIS, and fields can't be added, deleted, calculated, etc.  
 

ArcGIS determines the data type contained within fields by inspecting the first 8 rows underneath each field name. If 
4 or more rows are found to contain numbers, the field becomes a number field and any text entries will become nulls. 
 

The first non-empty row in an Excel worksheet or named range of cells is treated as containing the field names for 
the data in the columns below it. So for example, the third row in this worksheet is the first non-empty row: 
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and so it provides the field names for the data in the worksheet: 
 

 
 

Excel files often contain titles and other information in addition to the columns containing data which mean that the
first non-empty row in the file is not the one containing the field names for the data you want to access: 

 

 

 
 
In this case, you don't have to reformat these files in order to use them in ArcGIS. Instead you can define a named 
range in Excel that references the data you want to treat as the rows and columns of a table. To define a named 
range, select the area containing the field names and data, and enter a name for this area in the box at the left side of 
the Excel Formula Bar: 
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ow when you access this Excel file in ArcGIS you'll see the named range you created listed as one of the tables it N
contains: 
 

 
 
and when you open the table, it will contain just the data in that range: 
 

 
 
Named ranges make it easy to access specific data in Excel worksheets. You'll frequently find that Excel files crea
by financial departments, etc al

ted 
ready have named ranges referencing the pertinent tabular data they contain. 

 
 
 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  58 



Calculating fields 

When you right-click a field in a layer attribute table, there's a new Calculate Geometry command that opens a 
log that makes it easy to calculate the field to be the area, length, perimeter, x location, y location, x centroid, or y

centroid of the features in the layer. As part of this enhancement, the existing Calculate Values command has been
renamed to be the Field Calculator command: 
 

dia  
 

 
 
The Calculate Geometry command launches this dialog which lets you choose the property to calculate and the 
coordinate system and units to be used by calculation: 
 

 
 
T
ty

he Calculate Geometry command works with any numeric or text field. For the most precise results, use a 'double' 
pe field, with the desired number of decimal places. If you use an integer field the result will be rounded up to a 

hoose format, etc so it is easy to make a 

Remember that geometry calculations in ArcGIS are planimetric (i.e. take place in projected space, not spherical or 
te system being used 
 (GCS) such as WGS 

whole number. If you use a text field you can include unit abbreviation, c
ready-to-use field for labeling. 
 

geodesic space). You can only calculate the area, length or perimeter of features if the coordina
is a projected coordinate system (PCS). If the data source uses a geographic coordinate system
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1984, and is therefore unprojected, you can use the projected coordinate system of the data frame to perform the 
calculations. Alternately, you can project the data source. 
 

The Field Calculator has always respected the currently selected records in the table, so only the currently sele
records are calculated. At 9.2 this works the same way but we've added a check box option to the bottom of t

cted 
he Field 

alculator to make this more obvious (see below). You can also override this behavior by unchecking the box if some 
records are currently selected but you want to calculate values for all the records. 
 

C

A new menu in the Field Calculator dialog lets you choose how fields will be listed. This menu is accessed via a 
small control to the right of the fields list, or by right-clicking the fields list. This menu gives you the option of listing 
fields with their field aliases instead of their underlying field names. When you choose this option, the fields list 
respects field alias properties when you are working with layers and tables. This has been requested frequently 
because many of you use field aliases to make cryptic field names more user-friendly or to make long ArcSDE field 
names more manageable. The Show Field Aliases option is turned off by default in 9.2 so there is no immediate 
change to your familiar workflows. Choosing to show aliases in this dialog has no effect on the expression syntax. 
Field aliases are not shown or supported in the expression itself. If you double-click a field shown with its alias, it will 
still be added into the expression with its actual name and the required [  ] field delimiters.  
 
Another option in this menu lets you choose how the fields are sorted in the list. By default the fields are still listed in 
their original order in the data source so there is no immediate difference to 9.1. Choosing Sort Ascending or Sort 
Descending can make it easier to quickly locate the field you want. In the example below the fields list has been 
changed to be sorted in ascending order and to show the field aliases: 
 

 
 
The sorting and field name options you choose remain in force whenever you use this dialog or others that offer the 
same options: the Select By Attributes dialog, all Query Builder dialogs, and the Label Expression dialog.  
 

The Field Calculator now respects field visibility properties. Fields that have been turned off for the layer or 
tandalone table you are working with are no longer listed in this dialog. You turn fields off in the Layer Properties or s
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Table Properties dialog Fields tab or via the table window (a new capability in 9.2). This makes it easier to work with 
have chosen to work with appear in the dialog. data sources that have a large number of fields because only fields you 

 
The Field Calculator has been modified so that you now double-click a field to add it into the expression. Previou

you single-clicked. This made it hard to use the keyboard in the fields list and was inconsistent with other dialogs. 
 

sly 

The message that appears if you calculate a field outside of an edit session now has a check box so you can easily
turn the message off. To turn the message back on after turning it off, use the setting in the Tools > Options dialog 
Tables tab. 
 

 

When you use the Field Calculator on a text field, a warning message now appears if truncation occurs because the 
fi
f
eld length is too small to hold the calculated values. Truncated values are flagged with an asterisk * so you can easily 
ind and fix them if necessary. (9.3 will feature a registry key so you can prevent the asterisk from appearing): 
 

 
 
 
 

Customizing a table's contents 

Turn fields on and off, specify aliases, etc directly from the table window 
 
When you are working with a table window, you no longer have to open the Layer Properties dialog Fields tab if you 

ant to change which fields are shown, their aliases and their number format. 
 
w

To turn a field off, right-click the field's name in the table window and choose the new Turn Field Off command. 
Turning a field off in the table window is the same as unchecking it in the Layer Properties dialog Fields tab: 
 

 
 
Want to breeze through your tables turning unwanted fields off even faster? Hold down CTRL and double-click a field 
name to turn that field off. To turn all the fields on again, choose the new Turn All Fields On command in the table 
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window's Options menu. This is the same as going to the Layer Properties dialog Fields tab and choosing Select All. 
All the fields in the data source will be turned on. This command is disabled if no fields are currently turned off. 
 

To specify an alias for a field, right-click the field's name in the table window, choose the new Properties command, 
and type into the Alias box. This new Field Properties dialog also lets you turn the field on or off, make the field the 
primary display field, change its number format if it is not a string field, and review (not change) the field's other data 
properties, such as its precision, etc: 
 

 
 
 
Easier to work with column widths in the table window 
 

In the table window, fields are shown in columns. You've always been able to drag the column dividers between 
fields left and right to change their width, including dragging dividers so that fields are completely hidden. However in 
revious releases it was not p possible to automatically reset the column widths to undo changes you made, and it was 

and in the table 
t are completely 

n because their column has been dragged to have no width. The Restore Default Column Widths command 
sn't reset the field order, so if you have dragged and dropped fields around in the table window, this reordering is 

re

hard to tell whether any fields were hidden in the table. A new Restore Default Column Widths comm
indow's Options menu resets all the columns to their default widths. This also reveals any fields thaw

hidde
d
p

oe
served when you use the command. 

 
If a field has been completely hidden in the table, you'll now see a thicker column divider at that position. This 

akes it easy to see where one or more fields ham ve been hidden. If several fields have been hidden at that position, 
ou'll see an even thicker divider: y

 
 
To unhide a hidden field, drag the thick divider to the right, or double-click on the divider. (At 9.2 we have fixed the bug 
where double-clicking on the divider for a hidden field turned that field on in the Layer Properties dialog Fields tab). To 
reveal all hidden fields, use the new Restore Default Column Widths command in the Options menu. Completely hiding 
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fields in the table window is useful because it lets you choose how you want the table to appear without turning fields 
off completely which would prevent them being listed in dialogs. Want to hide fields very rapidly? Hold down CTRL and 
SHIFT and double-click a field name to hide that field. 
 
 
New appearance options for the table window 
 

A new setting in the Table Appearance dialog (see below) launched from the Options menu button in the table 
window lets you choose to indicate the primary display field in the table window by adding a special character after its 
name. If you want to be able to see which field is being used as the primary display field in this way, turn this option on 
and choose the character you'd like to use (the default is a pound sign #). By default, this option is turned off so you 
won't see any difference unless you turn this option on.  
 

Two new settings in the Table Appearance dialog let you control the height of the column heading row at the top of 
the table window and the height of the cells in the rows. By default, your tables will look the same as they do in 9.1: 
 

 
 

y increasing the % values you can increase the height of the cells in the table B window. If the height you specify for the 
er Height o  enough space in a cell to accommodate additional lines, the content of 

eader or ce eds the current width of the column. This is useful if the fields in your 
ong names o  be able to read them without having to work with a very wide table. 
the cell height is useful if your table contains long text fields, such as description or comment fields, to make 

s easier to rea

 the example below, the column header height has been set to 340% and the cell height to 450%: 

Column Head r Cell Height provides
the column h ll value will wrap if it exce

l t totable have r aliases, and you wan
Increasing 
these field d.  
 
In
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If you want the options described above to be used for all the new table windows you open, specify them in the 
o ed in 

 

ata in a table 

T ols > Options dialog Tables tab. Settings you turn on in that dialog don't apply to tables you have already open
your existing map, globe and scene documents. 
 

 

Working with the d

N
 

avigate around your map directly from a table  

A number of new commands have been added into the context menu you get if you right-click the grey cell to the 
left of a record. These include commands that let you navigate quickly on the map to the features listed in your table: 
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- The  To, Pan To commands show you the feature whose record you right-clicked Flash, Zoom . These commands 
king at features before deciding if you want to select them. 

ded the e

 
Zoom To Highlig en you are in Show Selected Records mode and you 
have highlighted some of the records (i.e. made them turn yellow). This command is disabled when you are in Show 
All Records mode (because you can't highlight features in that mode).  

don't change the selection, so they are useful for loo
 
- We've ad xisting Zoom To Selection command into this menu for easy access. You can right-click any 

record to access this command (the record doesn't have to be currently selected).  

hted is a new command that is enabled wh- 

 
In addition to these new commands, two navigation shortcuts have been added if you want to navigate to features 

very rapidly from a table: 
 

Double-click the grey cell to the left of a record = select that record and zoom to its feature on the map 

CTRL + double-click the grey cell to the left of a record = select that record and pan to its feature on the map 
 
If you are in Show Selected Records mode, these shortcuts highlight the feature instead of selecting it, so you can use 
them to quickly navigate around your set of currently selected features without changing that set.  
 

The following keyboard shortcuts are provided so you can navigate to the feature represented by the current record 
without using the mouse. These are especially useful when combined with other shortcuts like using the arrow keys or 
ENTER to move up and down through the records sequentially because they enable you see where the feature you 
are currently editing or reviewing in the table is located:  
 
CTRL + 8  Flash current feature 
CTRL + =  Zoom to current feature 
CTRL + P Pan to current feature 
CTRL + I Identify the current record 
CTRL + SHIFT + = Zoom to selected features 
 
You can also open the context menu described in this section by pressing the Application key . 
 

All the navigation commands and shortcuts are disabled if the table you are working with is not the attribute table of 
a feature layer.  
 
 
Use the mouse wheel in a table 
 

You can now use the mouse wheel to navigate through a table. When you roll the mouse wheel in the ArcGIS 
Desktop applications at 9.2, the roll applies to the window that the cursor is currently hovering over. There's no need to 
click inside the table first to make it active before you use the mouse wheel. When the cursor is over a table window, 
you can perform these operations: 
 
- Roll the mouse wheel to scroll up and down.  
- Hold down SHIFT and roll the wheel to scroll sideways.  
- Hold down CTRL and roll the wheel to zoom in and out on the table. This is particularly useful if you want to see the 

big picture when you reorder fields in a table by dragging them left and right. 
 
 
Sorting tables 
 

You can now double-click a column header (field name) in the table window to sort the table. This is a useful 
shortcut you can use instead of right-clicking a field and choosing one of the two sorting commands.  
 

When you are in Show Selected mode in a table, the sorting you choose is retained if you add records to the 
selected set or remove records from it. For example, if you sort the selected set of cities on a population field, holding 
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down SHIFT and clicking on additional cities o
orrectly into the sort order in your table.  

n the map to add them to the selected set will insert their records 
c
 
 
Easier to add fields 
 

The Add Field dialog launched from the Table window is now more intelligent. When you use this dialog to add a 
n  Precision 

r 
type when you add a field to a shapefile. 

umeric field to a personal geodatabase or file geodatabase, it no longer prompts you to define the Scale or
of the new field. These field properties aren't supported by those data types.  
 
Similarly, the dialog no longer lists Blob as a field type when you add a field to a coverage or shapefile, and no longe
lists Guid as a field 
 

The enhancements described above have also been applied to the Fields tab in the Feature Class Properties dialog 
and Table Properties dialog in ArcCatalog, so you no longer see those unsupported field properties when adding fields 
in ArcCatalog.  
 
 
Navigating around inside a table  
 

In 9.2, when you open a table window it is automatically given keyboard focus, so you can immediately start 
navigating around inside it with the keyboard. Previously you had to click inside the table first to give it focus. 
 

These existing shortcuts have been improved: 
 

   When you use the arrow keys to go left or right, they now wrap back to start of same record when 
you get to the end of row, and vice versa. 

ENTER  Now goes to the cell below the current one in the same field instead of the cell to the right. 
AB  When you press TAB to go to the cell to the right, it now wraps around to the first cell of next T

record when you get to end of row. 
 

These new shortcuts have been added:  
 
HOME Go to the first cell in the current row (same as existing CTRL + left arrow). 

ND Go to the last cell in the current row E (same as existing CTRL + right arrow). 

h Find dialog. 

 

SHIFT + ENTER Go to the cell above current cell. 
CTRL + F  Launc
CTRL + G Go to a record number. This launches a small dialog into which you type the record number to go 

to. This works the same as typing a record number into the box at the bottom of the table window 
but doesn't require the use of the mouse: 
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Selecting and unselecting records 
 

You can now select a range of records in a table by clicking the first record in the desired range and then holding 
SHIFT and clicking the last record in the range. This Windows standard method of extending a selection was not 

previously supported in the table window. You can now also use SHIFT + SPACEBAR or SHIFT + 
down 

 or  to extend a 
block selection using the keyboard. 
 

"Hands-free" record selection: When you are viewing a table in Show All Records mode, you can use the 
Select/Unselect command in the context menu accessed by right-clicking the grey cell to the left of any row to add a 
record to the selected set, or remove a record from it, without holding down SHIFT or CTRL. Using the Select/Unselect 
command retains your existing selection and either adds the record you right-clicked to the selected set or removes 
the record from it.  
 

Press SPACEBAR to select or unselect the current record. In Show Selected Records mode this shortcut highlights 
or unhighlights the record. This shortcut makes it easy to work through a table using the down arrow or the ENTER key 
selecting records you want to work with. Use CTRL + SPACEBAR to select or unselect a record with the keyboard if 
you are in edit mode).  
 

We've made it easier to quickly clear the selected set while in the table window. Click the top left hand corner of the 
ble window to clear the selection:  ta

 

 
 
You can also press CTRL + BACKSPACE to clear the selection. CTRL + SHIFT + A also clears the selection. 
 
As shown in the graphic above, you can SHIFT + click the top left hand corner to select all records. The keyboard 
shortcut for select all records is CTRL + A. You can CTRL + click the top left hand corner to switch the selection. The 
keyboard shortcut for switch selection is CTRL + U.  
 
If you are in Show Selected Records mode, these shortcuts apply to the set of highlighted records (i.e. the subset of 

e've also added the Clear Selected command into the context menu you get if you right-click the grey cell to the left 
o

records shown in yellow). 
 
W
f any row. This command always clears the selected set irrespective of which mode you are in. 

 
When you are working in Show Selected Records mode, you can now remove records from the selected set to 

refine your selection by interacting directly with the table. Previous when you were in Show Selected Records mode 
there was no way to remove records from the selection via the table. 
 
-  To remove one record from the selected set, right-click the grey cell to the left of the record and choose Unselect 

t record from the selection using the keyboard, press BACKSPACE (this shortcut is not 
available if you are in edit mode).  

 
 To remove multiple records from the selected set, first highlight the records you want to remove and then right click 
the grey cell to the left of any record and choose Unselect Highlighted. Highlighting records and then unselecting 
them makes it easy to refine your selection because you can choose which records you want to unselect and review 
them in the table before unselecting them. You can use any of the new shortcuts described above, such as using the 
SPACEBAR to highlight records while you navigate up and down through the table with the arrow keys. 

 

from the context menu.  
 
- To remove the curren

- 
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For example suppose you need to find the 5 wireless repeater locations with the best signal strength in a particular 
area. First select all the wireless repeater locations in that area on your map, then open a table and view these 

 
s 

records in Show Selected Records mode. Double-click on the signal strength field to sort them in descending order. 
Now highlight record number 6 through to the last record in the table using SHIFT + Click or by dragging over these
records. Finally right-click and choose Unselect Highlighted. Sorting is preserved when you add or remove record
from the selection. 

 
To switch between Show All Records and Show Selected Records modes using the keyboard, press CTRL + TAB.  

 
You may want to quentially through a table reviewing each record and seeing where its feature is located on work se  

ER moves down to the cell below your current location in 
le ele rd, and unselects the one you began on if it was selected. Rather hard to describe but when 

o

E

the map. A new shortcut at 9.2 facilitates this: CTRL + ENT
e tab , s cts that recoth

y u try it you'll see that it lets you work sequentially through a table selecting each record one by one. Try combining 
this with one of the new table to map navigation shortcuts described above such as CTRL + P for pan to current 
feature. SHIFT + CTRL + ENTER does the same thing in the opposite direction. 
 
 

asier to copy data 
 

To copy records from a table for pasting into other applications, such as Excel, first select the records you want to 
copy, right-click the grey cell to the left of any record, and choose the new Copy Selected command. This command
just copies the tabular re

 
cord data, not the geographic features associated with the records. For this reason, you can't 

aste copied records back into the table window. You can also press CTRL + SHIFT + C to invoke this command. (To 
 an 

his new Copy Selected command replaces the Copy Records command that was in the context menu for a 
standalone table in the Table Of Contents Source tab. That command, which did not respect your selected set, has 
been removed at 9.2.  
 

p
copy and paste features in a layer you are editing, use the Copy and Paste commands in the ArcMap window in
edit session in the usual way).  
 
T

You can now copy the contents of the current cell with the keyboard using CTRL + C or CTRL + INSERT.  
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New shortcuts for editing the data in a table 
 

You can now press CTRL + SHIFT + E to start or stop editing (same as using the Start Editing and Stop Editing 
command in the Editor pulldown menu). 
 

These existing shortcuts have been improved so you can choose whether you want to work down through the 
current field or across the record as you edit values: 
 
ENTER Finish editing current cell and go down to the next cell below in same field. Matches Excel. 
TAB Finish editing current cell and go across to next cell to the right in same record. Wraps 

around to next record below when you get to the end of the row.  
 

With the new CTRL + ENTER shortcut you can work sequentially down through a table editing each value in a field 
hile at the same time seeing where the feature represented by the current record is on the map. This shortcut works 

ne you just updated. 
L + ENTER does the 

ame thing in the opposite direction. 

w
the same as pressing ENTER but it also selects the next record you land on and unselects the o
n this way you can see the feature you are currently editing selected on the map. SHIFT + CTRI
s
 

You can use the new Delete Selected command to delete the currently selected records (and their features if you 
r

 

a e working with a layer). This command is in the context menu accessed by right-clicking the grey cell to the left of 
any record. The Delete Selected command is disabled if you are not in an edit session.  
 
Like in previous releases, the keyboard shortcut for deleting the selected records is DELETE. An additional shortcut at 
9.2 is CTRL + D. In Show All Records mode, this deletes the currently selected records(s) the same as DELETE. In 
Show Selected Records mode, this deletes the currently highlighted (yellow) records in your selection, providing a
useful way to delete a subset of the features in your current selection. 
 

These additional new shortcuts have been added:  
 
SHIFT + INSERT  Paste the contents of the clipboard into the current cell. (CTRL + V is already supported). 
CTRL + Z and CTRL + Y Undo/Redo edits to a record. 
 

If you are editing a value in a text field, you can press SHIFT + ENTER to insert a line feed into the string to make it 
occupy more than one line (for example, to use as stacked text for labeling or annotation). At 9.2 you can now see 
these multiple line text strings in the table window by setting the cell height to 200% or more in the Options > 
Appearance Properties dialog as described earlier.  
 

It is now easier to paste data into vertical consecutive cells in a column when you are populating a table. This can 
save time if you are updating an existing table and want to use information in other applications, such as Excel and 
Word. For example, you may want to use Excel to assemble and spell check updates to an existing field in an ArcMap 
table and then simply paste the values from Excel into the table instead of loading the Excel table into ArcMap and 
joining it to your table.  
 
In this example, these four consecutive cell values in a column in an Excel spreadsheet will be pasted into four 
consecutive cells in a field in an ArcMap table. First select the cells in Excel as a block and copy the block to the 
clipboard: 
 

 
 
Next right-click the first cell at the top of the vertical block of consecutive cells in ArcMap and choose Paste: 
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The values get pasted into the field in the same order they appeared in the Excel file: 
 

 
 
This functionality was available in previous releases but at 9.2 we have fixed the issues it had. 
 
 

rint tables directly without creating reports P
 

You can now print tables directly from the table window, without having to create a report or add the table to your 
a

ptions menu. Records that are currently selected or highlighted in the table are printed in bold by 
d  the defaults, go to the Advanced Options tab in the Print 

ride the font size specified in the Appearance dialog. 

m p layout. In the Options menu for a table, choose the new Print command. The table will be printed as it appears 
on-screen. Tables are printed using the current font, font size, and font color specified in the Appearance dialog 

ccessed from the Oa
efault. To see additional printing options or to override
ialog. For example, the font size setting lets you overd
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Creating reports 
 

The Reports pullright in the Tools pulldown menu that contains the commands for creating reports has been added 
to the Options menu in the table window. This makes it more convenient to make reports containing data from the 

tab
in

le you are currently working with. 
 

The first panel of the Crystal Report Wizard has been improved to make it easier to work with: The layer list is now 
much larger, includes feature type icons and reflects any group layers in your Table Of Contents organization. A rad
button option has been ad

io 
ded so you can restrict the layer listing to layers that are checked as selectable in the Table 

f Contents Selection tab. Buttons have been added for selecting all and clearing all check boxes. In addition, when 
you press Next the wizard no longer prompts you if the 'Use selected records' box is checked but one or more of the 

yers you checked do not have any features selected. In these cases, the wizard now just automatically uses all the 

O

la
features in those layers. Finally, the wizard now automatically increments the default name of the output geodatabase 
into which the data your report will be saved if a geodatabase with that name already exists: 
 

 
 
 
 

Other 

New shortcuts for opening and closing tables  
 

When you right-click a feature layer and choose Open Attribute Table, this opens the table in 'Show all records' 
mode. At 9.2 there's a new command called 'Open Table Showing Selected Features' that opens the table window 
directly in 'Show selected records' mode. You can find this in the Selection pullright when you right-click a feature layer 
in the Table Of Contents. The command is disabled if no features are currently selected. 
 

To open the table window for a layer or table in the Table Of Contents, hold down CTRL and double-click it.  
 

Press CTRL + T or CTRL + ENTER to open the table windows for the currently selected layer(s) or table(s) in the 
Table Of Contents.  
 

These new keyboard shortcuts are also supported:  
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CTRL + T in table window 
CTRL + SHIFT + T 

Minimizes the window.  
Toggle all currently open tables between displayed and minimized state. Makes it 
easy to hide all the tables you have open and then show them again. 

CTRL + SHIFT + TAB  Toggles between the currently open tables when you have multiple open. 
CTRL + SHIFT + F4   Close all currently open tables.  
 

 

 
Working with a small table window 

It is easier to work with table windows when you make them small to fit next to your map on screen. In 9.2, if the 
ptions menu button is hidden due to the width of the table window, a small control appears at the bottom right hand O

corner of the window. You can click this control to access the Options menu: 
 

 
 
Y u can y 'grey space' at the bottom of the table to access the Options menu.  

To open the Options menu using the keyboard, press CTRL + Application key

o  also right-click any of the empt

 .  
 

To sw CTRL + TAB. This enables you to 
switch modes even if the buttons at the bottom of the table for switching modes are hidden.  
 
 
Add XY Data & Add Route Events dialog now tell you if resulting layer has limitations 
 

itch between Show All Records and Show Selected Records modes, press 

The T ools > Add Route Events commands now inform you if the layer that will 
be created in your map will have restricted functionality because the input table it is being created from does not have 
an je el files (new in 9.2) and OLE DB data, such 
as non-  OLEDB. A new check box added to both dialogs lets you turn this 
notificat
 

ools > Add XY Data command and T

Ob ct-ID (OID) field. This will be the case with text files (txt files), Exc
registered Oracle files accessed through
ion message off: 

 
 
Layers created from tables that don't have an Object-ID field have certain restrictions: their features can't be selected 
on the map, you can't start an edit session, and relates can't be defined. The message mentions the simplest way to 
handle this issue: after you've created the event layer from a table with no Object-ID field, export the data to a feature 
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class and then add the exported data to the map as a new layer. Saving the event layer's data to a feature class writes 
ut an Object-ID field. Click on the check box in the dialog with the ? tool to get more information about this. 

 

proved properties dialog for standalone tables 

o

 
Im
 

Standalone tables added into ArcMap, ArcGlobe and ArcScene now have General and Source tabs in their 
Pr

 
er or not the table has an Object-ID (OID) field. Standalone tables that don't have Object-ID 

elds, such as text files (txt files), Excel files (new in 9.2) and OLE DB data, such as non-registered Oracle files 
ccessed through OLEDB, have some limitations when they are used to create XY and route event layers (see the 

at type of table data source is being used: 

operties dialog. To open the Properties for a standalone table, right-click the table in the Table Of Contents Source 
tab and choose Properties. The details in the Source tab enable you to see the name and location of the table's data
source. They tell you wheth
fi
a
section above). It also lists wh
 

 
 
 
New number format 
 

You can now specify that the data in a numeric field represents a direction: 
 

 
 
 
How to find out about tables shortcuts while you are working in a table 
 

To get a list of tips and shortcuts while you are working with a table window, click inside the window to give it 
the 

ght the command in the menu and press SHIFT + F1 to get context sensitive help about it. 

keyboard focus and then press F1. (You can also find a list of tips and shortcuts in the ArcGIS Desktop Help and at 
end of this document). To find out whether a particular command you access regularly via a menu in the table window 
has a shortcut, highli
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Editing  

New COGO functionality 

 
ArcGIS 9.2 has a new set of coordinate geometry (COGO) functionality for ArcEditor and ArcInfo users. COGO 
provides a number of different methods for creating features from surveyed bearings, distances, and angles. This is 
commonly used when creating land records databases. 
 
New COGO toolbar and changes to the Advanced Editing toolbar 
 

There is a new COGO toolbar available at 9.2 that contains commands specific to creating COGO features as well 
 commands on the COGO toolbar are available for ArcEditor and as querying and interacting with COGO features. The

rcInfo licenses only.  A
 

 
 

 Displays the Traverse window 

 Displays the 2-Point Line window, so you can construct a 2-point line using COGO methods 

 Create a line at a specified distance and perpendicular from a selected line 

 Construct a cul-de-sac from a street centerline 

 Splits the selected feature proportionally 

 View and change the current direction offset and distance factor 

 Displays the COGO Report window 

 Reports the COGO area and other information for selected lines 

 Reports missing parameters for curves 

 Splits selected line features into new 2-point line features 

 Updates the COGO attributes from the geometry of the selected features 
 

As part of the new COGO enhancements, we've made the following changes to the Advanced Editing toolbar: 

ting Traverse command , Proportion command , and Inverse command  have been moved from the -  The exis
Advanced Editing toolbar into the new COGO toolbar to consolidate the coordinate geometry functionality. 

-  The Inverse command  has been renamed to Update COGO Attributes. 

- The existing Copy Features tool , Fillet tool , Generalize command  and Smooth command  can now be 
used with an ArcView license, so at 9.2 all the controls on the Advanced Editing toolbar can be used with ArcView. 
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Here's the Advanced Editing toolbar at 9.2: 
 

 
 
 
Interactively setting the ground to grid correction 
 

When you enter direction and distances when editing, you can specify a ground to grid correction that is applied to 
y 

 

the values you enter. New at 9.2 is the Ground To Grid window that allows you to interactively set the correction b
clicking points on the map. 
 

New construction tool 
 

The Line Intersection tool is a new tool that finds intersections between two lines you click. The lines will be split at 
th

n be either at explicit locations in the middle of both lines or at implied intersections along 
xtensions to one or both lines. You can use this tool to cleanup intersections you create with other commands such 
s Cul-de-sac and Copy Parallel. 

 

ommands for creating COGO Boundaries 

e location where you click the mouse. There can be many potential intersections between the lines features and the 
intersection points ca
e
a

 
C
 

There are three new commands for creating COGO boundaries in your land records database.  
 
2-Point Line Window - The 2-Point Line window creates line features from COGO descriptions you read from a survey 
plan. This window works similar to the existing Traverse window but allows you to enter lines more quickly. You simply 
n

 in 

d centerline. Once 
ou have created your centerline, you enter the radius and other parameters for the cul-de-sac and new line features 

are created in the target line layer.  

Offset Line window - Occasionally land boundaries are described in a "strip description" survey plan, which describes 
boundaries on either side of a specified centerline. This is used to describe easements or right of ways in land records. 
The Offset Line window lets you create an edit sketch from selected lines. After you enter a start distance, which you 
read from your survey plan, you can add offset points by setting a distance along the selected line, an offset distance, 
and the side you want the offset point to be on. Each offset point is added to the end of the edit sketch. 
 
 
Reporting on COGO lines 
 

eed to enter a start point and the parameters for the line you are creating. The start point can be a point you enter 
from an X and Y, a point you click on the map, or the end of an existing lines in your database. The lines are created
the target line feature class. 

ul-de-sac Command - The Cul-de-sac command is used to create cul-de-sac lines from a selecteC
y

One important pre-phase required before you enter COGO boundaries, is examining the existing boundaries in the 
geodatabase and determining how accurate they are. Over time as you build your parcel layers, each new parcel that 
gets added could require the boundaries to be adjusted. Understanding how the existing parcels fit together is 
essential for guiding you on how you fit new parcels. There are three new 9.2 commands that help you with this task.  
 
COGO Report window - use the COGO Report window to measure COGO directions and distances for features in 
your database, as well as the directions and distances between points in your map.  

COGO Area command - The COGO Area comman  allows you to calculate the grid area and perimeter of selected 
nes as well as the legal area described by the COGO attributes of the line features. 

indow lets you determine the characteristics of a curve from two 
nown parameters. 

d
li

C
k

urve Calculator window - The Curve Calculator w
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Managing COGO lines 
 

There are several new commands and updates to existing commands, that allow you to manage COGO lines: 
 

plit into COGO Lines - A new command at 9.2, the Split into COGO Lines coS mmand on the COGO toolbar is used to 
split sel vertex into new features. You will get one new feature for each vertex in a selected line. 

 fields. 

pdate COGO Attributes - The command was named Inverse at 9.1. It calculates the COGO description for selected 
nd populates the COGO fields. At 9.2 you will be warned if any of the existing features already have their COGO 

 Editor toolbar allows you to merge COGO lines and 
update the COGO attributes. When you select lines that form either a single continuous straight line or a circular arc, a 
checkbox appears that allows you to Merge into a single COGO line. The resulting feature has a shape with a single 

ve COGO attributes, you can also update them by checking the Update 
OGO attributes option. 

 

OGO attributes to line features 

ected lines at each 
The new features are created in the current target layer. If the target layer and the selected lines are the same feature 
class, the selected lines are deleted and new features are created. COGO descriptions are created if the target layer 
has COGO

U
lines a
fields populated. 

Merge command - The Merge command on the Editor menu of the

line or circular arc segment. If the features ha
C

 
Writing C
 

The following commands write COGO descriptions to the COGO attributes of a line feature class: 

Merge command - Merges two or more selected features into a single feature. If you select lines that are entirely 
straight or curved and they have COGO fields, you can update the COGO descriptions. 
Traverse window - Create a feature from a series of COGO descriptions that form an open or closed traverse. This 

ate a symmetrical or asymmetrical cul-de-sac from a street centerline. 
rtion command - Split the selected line into a number of segments. 

COGO Report - List the COGO descriptions for lines and features in the map. 
Split Into COGO Lines command - Split the selected lines at every vertex and update the COGO fields. 

GO descriptions for selected lines from the feature geometry. 

only writes COGO descriptions when you use the Create 2-Point Line Features task. 
2-Point Line window - Create a COGO line feature from a COGO description. 
Offset Line window - Create COGO line features from a strip description or right of way plan.  
Cul-de-sac Command - Cre
Propo

Update COGO Attributes command - Calculate CO
 

Also for 9.2, we've changed the way specific editing commands and tools copy COGO values from existing 
features. The following commands will clear the COGO attributes for features when they are copied attributes: 

Copy Parallel command - when your target is the same as the selected lines, the existing attributes can be copied to 
the new features. 
Split command 
Split tool 

Extend tool 

Extend fix 

 ArcMap Settings utility to change, lets you 
c

Merge command - where you don't use the Update COGO attributes option. 
Line Intersection tool 

Trim tool 

Trim fix 
 

 setting in the registry, which you can use the /arcgis/utilities/AdvancedA
ontrol whether or not the COGO attributes are always cleared for the commands above. 
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Enhancements to existing editing functionality in support of COGO 
 

Traverse Window - The Traverse Window now remembers the previous location you loaded a traverse file from. 
 
The “+” and “/” keys on the numeric keypad can be used to tab forward and backward between the controls in the 
Traverse Window. This improves your productivity when you are entering traverses.  

r 
cebar is a shortcut to zooming to a course. Courses flash when you navigate with the arrow 

eys. 
 

he Traverse Window now responds to when ground to grid correction changes, the courses in the traverse are 
mediately modified based on the ground to grid settings. 

 
Navigation commands have been added to the context menu for courses. Now you can zoom to a specific course o
the entire traverse. Spa
k

T
im
 

Proportion Command - We have made several productivity enhancements to the Proportion command. At 9.2 you 
ca  to n reorder the lengths you have added. You can also add duplicates of a highlighted length—this gives you a way
easily break your line into segments the same length. 
 

Sketch Tool - The Sketch Tool now honors the ground to grid correction when it writes the direction and distance of 
the sketch segment. 
 
 

In the Desktop Help, see: Editing and data compilation > COGO > An overview of COGO 
 

ing  after creating a new feature 
 

Enter  attributes

You can turn on a new setting on the Attributes tab of the Editing Options dialog so you will be prompted to enter 
attributes into the Attributes dialog after any editing operation that results in new features, in either all layers or just 
specific ones in your map. As soon as you complete a sketch or an operation resulting in new features, the Attributes 
dialog pear eed to close the dialog before you can do anything else with ArcMap. will ap . You will n
 

 
 
Turning on this setting will be most useful when:  
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- 

- You are creating new features and want to attribute them immediately. This is especially true when you are creating 
a few new features at a time, and they have known attributes or subtypes.  

 
This setting applies to using the Create New Feature edit task, cutting, mirroring, splitting, intersecting, buffering, or 
exploding features, and using topology functions such as Planarize Lines, Construct Features, and the Create Feature 
error fix.  
 
 

Other editing enhancements 

Your geodatabase does not allow features to have null attribute values. When prompted, you can edit and replace 
null values before the new feature is stored in the geodatabase.  

 

Copy Parallel command enhanced 
 

The Editor menu > Copy Parallel command has been enhanced to ensure that the parallel lines are copied to the 
side you want and work better with multiple selected lines. Arrows are now drawn to show you the direction of the 
selection.  
 

 
 
You use a new dropdown list to specify whether you want the lines copied on the left or the right of the originals, so 
you no longer enter a negative offset distance to copy a line to the left. Multiple selected lines can now be treated as a 
single line, even if the directions of the lines are different. You can choose to create a single new line, or one feature 
for each line in the selection: 
 

 
 
 
Construct Features command enhanced 
 

The dialog that appears when you click the Construct Features button on the Topology toolbar has changed to 
clarify and let you choose the outcome of the operation. If you have set a polygon layer as the target on the Editor 
toolbar, you will see new options on the Construct Features dialog box. You can now choose whether you want to 
create new features or split existing features: 
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These changes do not apply when a line layer is the target, so in that case the dialog box remains similar as in 
previous releases. However, at 9.2 you have the option to replace the target features also in the selection. 
 
 
Split and Divide commands enhanced 
 

The Editor > Split command, which allows you to split a line into two lines using a distance, percentage, or M value 
e start or end point of the line, now shows arrows on the feature to indicate the line’s direction. These 

ows will help ensure that the line is split from the proper orientation. 
from either th
arr
 

The Editor > Divide command, which allows you to create new line or point features by dividing a line, now has an 
ption to delete the origino

 
al selected line after it is divided.  

 
Editing multipatches  
 

Multipatch features can now be edited in ArcMap like other feature types. This provides a basic level of editing for 
multipatches. The ArcGIS editing environment for mul ch editing focuses on whole feature management. That is, 
y  can  delete, and copy multipatch features, as well as define and populate attributes for the 
features
 
M ltipat d to represent anything from simple to complex objects including spheres, 
c s, a
 

tipat
ou  move, rotate, scale,

.  

u ch features are 3D features use
ube nd buildings.  

In th ures e Desktop Help, see: Extensions > 3D Analyst > 3D features > Editing 3D multipatch feat
 
 
Improved mark-up and Tablet PC support 
 

The tools on the ArcMap Tablet toolbar are used to draw digital ink and highlighting on your map, as well as to 
recognize handwriting as text and complete editing tasks. The Tablet toolbar looks the same as it did in 9.1, but ink 
functionality and options have been enhanced at 9.2. At 9.2, the Tablet tools are no longer a separate component of 
the ArcGIS setup program and are installed on all Desktop machines. (Previously, non-Tablet PC users had to choose 
to install Tablet PC support.) While many of the tools on the Tablet toolbar can be used on any computer, the text and 
gesture recognition functions are only available on a Tablet PC. The ArcMap Tablet Options dialog has been renamed 
Ink Settings, and some new options have been added.  
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You can now use four new gestures to pan the map in a particular direction on a Tablet PC: 
 
Gesture Map navigation task 

 
Pan up 

 
Pan down 

 
Pan left 

 
Pan right 

 
These gestures are available with the Pen and Highlighter tools, and can also be used with the markup tools in 
ArcReader. You can turn on or off the ability to use these gestures on the Ink Settings dialog. 
 

You can now use the Eraser tool to remove ink from any ink element in your map, inclu
een converted to graphics. The Eraser tool can be applied to all ink on your map when b

ding ink that has already 
oth of these two options are 

 

to 

 be able to erase highlighter ink, 
since it always converts to graphics. The default finish option has been changed from ‘Manually’ to ‘Automatically finish 
and commit as graphic.’ This change will help you take advantage of the new Eraser functionality. 
 
 
Non-versioned multi-user editing 
 

b
set as follows: ink is committed automatically and the ‘Only erase active ink sketch’ setting is not checked. If either the
manual finish or the ‘Only erase active ink sketch’ option is checked, the Eraser tool will only work on active ink 
sketches that have not been committed as graphics. Like at 9.1, you will need to re-activate ink graphics if you want 
erase ink from them. You will also not be able to convert ink that has been recognized as text and erase it with the 
Eraser tool. Therefore, if you have ink set to automatically convert to text, you will only

With ArcGIS 9.2, you can now edit data in ArcSDE geodatabases without having to first create a version of the data. 
See the Non-versioned Multi-user Editing section in the 'Geodatabases and ArcSDE' chapter of this document. 

 
 
Attributes window 
 

In the tree on left of the Attributes window, when you right-click a layer's name the Zoom To command is available 
in the context menu so that you can zoom to all the selected features in that layer. The Unselect command is also now 
present in the context menu so you can unselect all that layer's features. 
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ArcMap  

Navigating 

New Go To XY command lets you find coordinates on the map 
 

The new Go To XY command  in the Tools toolbar opens a dialog that makes it easy to enter coordinate 
locations, navigate to them, and draw them on the map.  

 
 
A menu in the dialog lets you choose the units you'll be specifying the coordinates in. Your data frame's map units are 
listed first (meters in the example below) along with several other common formats: 
 

 
 
Once you've entered the coordinates, click one of the buttons across 

e location and flash it:  
the top of the dialog or press ENTER to pan to 

th
 

 
 Pan to the location 
 Zoom to the location 
 Flash the location 
 Draw a point at the location 
 Draw a point at the location labeled with its coordinates 
 Draw a call out pointing at the location showing its coordinates 
 Return to a location you've already entered in this session by choosing from history list. 

 
Get context sensitive help on the Go To XY button in the Tools toolbar (by clicking it with the What's This ? tool from 

the Standard toolbar) to find out more about the supported coordinate entry formats. 
 

The Go To XY command is in ArcMap, ArcGlobe and ArcReader. It is also an ArcGIS Engine control, so if you are a
developer creating applications using ArcGIS Engine, you can easily include it in your applications. 
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Navigate maps with mouse wheel 
 

You can now use the mouse wheel to zoom and pan, so you can navigate without having to change tools.  
 

Roll wheel forward =  Zoom out 
Roll wheel forward + CTRL =  Zoom out at finer increment 
 

Roll wheel back =  Zoom in 

 

then rolling the wheel. There's no need to click 

Hold down wheel & drag mouse =  Pan 
Hold down wheel & drag mouse + CTRL =  Zoom in on area you define 
 
Single-click mouse wheel =  Center  
Single-click mouse wheel + CTRL =  Center & zoom in 
 

Roll wheel back + CTRL =  Zoom in at finer increment 
 
These operations work in Data View and Layout view. In Layout view they apply to the page by
default. In Layout view hold down SHIFT when you use the mouse wheel to navigate the data 
frame instead of the page.  

 
When you roll the mouse wheel in the ArcGIS Desktop applications at 9.2, the roll applies to the window that the cursor 
is currently hovering over. So for example, if you are working in the Table Of Contents or in a table window, you can 
zoom the map in and out by just moving the cursor over the map and 
on the map first to make it active. You can reverse the zoom in/zoom out convention used by the mouse wheel. To 
change this setting, go to the Tools > Options dialog and make your choice at the bottom of the General tab: 
 

 
 
If you are using the 3D Analyst extension, you'll find the same setting in the Tools > Options dialog in both ArcGlobe 
and ArcScene so you can choose your preferred zoom in/out mouse wheel roll direction for each application. 
 
Tip: If you would prefer rolling the mouse wheel forward and back to scroll the map up/down like it did in 9.1, you can 
override the default 9.2 behaviour by specifying a new Windows registry setting that we have added support for in 9.2 
Service Pack 3. For example, you may have used ArcMap 9.1 with a mouse with a 'tilt' wheel that can be tilted from 
side to side in addition to being rolled, enabling you to pan in four directions. Using a tilt wheel mouse to pan in four 
directions in ArcMap 9.2 doesn't work by default because rolling the mouse wheel zooms in/out instead of scrolling 
up/down. Here is the DWORD registry setting you can add into the Windows registry: 

HKEY_CURRENT_USER\Software\ESRI\ArcMap\Settings\MouseWheelScroll 
  
Giving this registry key a value of 1 tells ArcMap to scroll the map when you roll the mouse wheel. When this registry 
setting has not been specified, or when it has a value of 0, rolling the mouse wheel will zoom in/out, the default 
behaviour at 9.2. Behaviour involving single-clicking or holding down the mouse wheel is unaffected by this registry 
setting. This registry setting is not recognized by ArcMap 9.2 prior to Service Pack 3. 
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Temporarily change any tool into a navigation tool by holding down a key 
 

Hold down one of these keys on the keyboard to temporarily turn your current tool into a navigation tool: 
 
Z =  Zoom In tool: Single-click or drag a box 
X  =  Zoom Out tool: Single-click or drag a box 
C  =  Pan tool: Single-click or drag 
B  =  Continuous Zoom/Pan tool: drag up/down with left mouse button held down zooms in/out, right button pans. 
 
These shortcuts work in Data View and Layout view. In Layout view they apply to the page by default. Hold down 
SHIFT as well to apply it to the data 
ince ArcGIS 8.x when an editor tool wa

frame instead of the page. (Note: The Z, X and C shortcuts have been available 
s selected. At 9.2 they now work with any tool that is selected).  

 
Tip for developers: If a custom tool you have developed needs to override one of these built-in global keyboard 
shortcuts, implement the IToolKeys interface on your tool and use the OverrideKey method to return True for all the 
shortcut keys the tool will handle. 
 
 
Other navigation enhancements when using the mouse 
 

s

Pan  tool: single-click now centers the data frame at location you clicked. Layout Pan  tool: single-click now 
centers page at location you clicked. 

When the Zoom In tool, Zoom Out tool, or Pan tool is active, F6 toggles between these three tools. F6 also toggles 
between the corresponding three layout tools as well when you are in Layout view. 

Continuous Zoom/Pan  tool (which can be added into any toolbar from the Pan/Zoom category in the Tools > 
Customize dialog Commands tab): single-click with right mouse button now centers map at location you clicked. The 

ol now works on the page by default when you are in Layout view. In Layout view hold down SHIFT to operate on the 

a 

to
data frame instead. You can also temporarily turn any tool into this tool by holding down the B key on your keyboard. 
(This tool is particularly useful if you want a dynamic zoom in/out capability when you are using the input device on 
laptop keyboard instead of a mouse). 
 

Hold down ALT and click the name of a layer in the Table Of Contents to zoom to the extent of that layer. 
 
 
Better support for map navigation with the keyboard 
 

The arrow keys on the keyboard scroll the map in the direction you press (unless a graphic or map element is 
selected, in which case they nudge that element like they’ve always done).  
 

The HOME and END keys page map left/right. PAGE UP and PAGE DN page map up/down. 

The - and + keys zoom out and in (same as the Fixed Zoom Out  and In  buttons). The < and > keys zoom go 
back to previous extent or forward to next extent. 
 

The INSERT key takes you to the full extent.  Pressing CTRL + TAB switches between data frames when your m
contains multiple, making each one active in turn. 
 

ap 

At 9.2 keyboard shortcuts can now be defined to invoke any interactive tool, such as the Zoom In tool, Edit tool, etc. 
To

o find out whether a particular tool or command you access regularly has a shortcut, get 
ontext sensitive help about it by clicking the What's This tool 

 specify a keyboard shortcut for a tool, go to Tools>Customize and click the Keyboard button. 
 
 
Tip: To get a list of these navigation shortcuts while you are working with ArcMap, click inside the Table Of Contents to 
give it keyboard focus and then press F1. You can also find a list of tips and shortcuts in the ArcGIS Desktop Help and 
at the end of this document. T
c  in the Standard Toolbar and then clicking the item. To 
get context sensitive help on a command in a context menu, highlight the command and press SHIFT + F1. 
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Quick access to useful shortcuts by right-clicking map 
 

ArcMap 9.2 gives you easy access to map navigation commands and other useful shortcuts when you right-click the 
ap in Data view. Right-clicking the map gives you this new menu containing a set of commonly used commands:  m

 

 
 
The menu includes some new commands that operate at the location you right-clicked. These new commands enable 
you to perform an intera g your current tool. For example, 
sup  the Tools toolbar and you'd like to 

efore you go ahead and add it to the selected set. Instead of revisiting the 
w just right-click that feature and choose Identify from the menu, 

with rre

nu to add additional commands from the pulldown menus into it as 
sho ize, check the Context Menus entry in the Toolbars 
list, and then us that appears. For example, at 9.2 we removed 

u to add that command back in. 

Tip:  Application key

ctive operation, such as identifying a feature, without changin
pose you are selecting features on the map with the Select Features tool from

find out more about a particular feature b
Tools toolbar to switch to the Identify tool, you can no

out changing the tool you are cu ntly using. 
 
You can also customize this new context me

rtcuts. To customize this context menu, choose Tools>Custom
look for the Data View Context Menu in the list of men

the Add Data command from this menu to keep it short. But if you are used to accessing Add Data by right-clicking the 
map you can customize this men

  You can also access this menu, and any other context menu, by pressing the  which is 
available on Windows-compatible keyboards. SHIFT + F10 can also be used on keyboards without an application key.  
(These are standard Windows shortcuts and not specific to ArcGIS). 
 
Tip: This menu doesn't appear if you right-click the map in Data view when you are using certain tools, like some of 
the editing tools, that have their own specialized context menus. However you can customize the existing context 
menus of those commands to include any of the commands in the new context menu.  
 

The Zoom To Selected Elements command has been added into the menu that appears when you right-click any 
map element in Data View or Layout View. For example, in Layout view right-click a data frame and choose this 
command to fit the entire data frame into your display. 
 

The Zoom To Whole Page command has been added into the menu that appears when you right-click the page or 
any map element in Layout View. This provides a quick way to see the whole layout in your display. 
 

The Go Back, Go Forward, Cut, Copy, Delete commands have been added into the menu that appears when you 
right-click the page in Layout view, making it easier to get to these commands when you are working on a layout.  
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Customizable Full Extent 
 

You can now choose where the Full Extent command  takes you. Full Extent is perhaps the most useful 
igation command because in one click it zooms you out so you can see everything in the map, such as the whole 

, 

ull Extent button will take you, or any user accessing your map, 
h

nav
state or your entire study area. However, this extent often zooms you further out than you expected. For example
suppose you are using a map of France that includes some data sources that cover the whole world. In 9.1 pressing 
the Full Extent button always zooms you out to the whole world, which may be inconvenient if you just want to work 

ith France. In 9.2 you can now control where the Fw
w en it is used in ArcMap, ArcReader, an ArcGIS Engine application, or ArcGIS Server application. 
 
You can customize the full extent for each data frame in your map. Look in the Data Frame Properties dialog Data 
Frame tab to set this new property: 
 

 
 
If you don't set this property, there's no difference from 9.1: By default the Full Extent command will be extent of all the 
layers in the map. To set this property, click the 'Other' radio button and then press the Specify Extent button. The 
following dialog appears giving you several ways to specify the extent you want to use for full extent: 
 

 
 
Note: This same dialog also appears when you use the existing options in the Data Frame Properties dialog Data 
Frame tab to specify a fixed extent for the data frame or to clip its contents. We've added a new Current Visible Extent 
radio button option to this dialog to make it more obvious how you set the extent to be the current extent of the map. 
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Tip: Customizing Full Extent doesn't affect other commands, such as Zoom To Layer. For example, if you've specified
a custom Full Extent for a data frame, you can still right-cl

 
ick any layer in the Table Of Contents and choose Zoom To 

ayer to see the full extent of that layer, even if this extent is larger than the custom full extent you've specified for the 
d

overing a city and you'll be spending a few days editing the parcels in one area of the city. If you set the Full Extent to 
be the extent of the area you are working in, you can use the Full Extent button as a very quick way to zoom to that 
area instead of always zooming out to the extent of the entire city. Once you've finished your edits you could change 
Full Extent to be the next area of work, and so on. 
 

L
ata frame. 

 
Tip: One way to use this functionality is to simplify map navigation when you are editing. Suppose you have a map 
c

The USA and World templates accessed via File>New have been updated to take advantage of the new custom full 
extent property described above. Now when you use a template such as Northeastern USA, if you zoom in on the 
map, and then press the Full Extent button you get taken to the full extent of the subject of the map, the North Eastern 
USA, as you'd expect, not the full extent of the USA, even though the data used in the map covers the whole USA. The 
custom full extent property is specified in the View>Data Frame Properties dialog Data Frame tab, and can be modified 
or reset to the default there. 
 
We've also changed the reference scale on the templates to be <none> to make them easier to use as the basis for 
interactive maps and a wider range of printed maps. With this change, the size of the symbology and labels remain the 
same as you zoom in and out instead of being sized relative to the reference scale. 
 
 
Easier to specify scale 
 
We've standardized and improved how scale is specified in ArcMap and fixed the inconsistencies where some dialogs 
required that scale be input in a particular format.  
 

In the Scale control in the Standard toolbar, and in all dialogs i
 scale values using almost any format, including relative formats (such a

n which you specify scale, you can now type or paste 
s "1 mile = 2.5 inches"). When you specify a 

ptions: 

in
scale in a relative format, it is automatically converted to absolute format (such as 1:25,344). A variety of formatting is 
supported to make it easy to copy and paste scales into the scale control without modification. Here are the o
 
In absolute format, the "1:" prefix and thousand separators can be present or absent: 

1:1,000,000 1,000,000 1:1000000  1000000 

An ute format: y character or word can be used as the separator in absol

1:25000 1 - 25000  1 to 25000 1/25000 

You can use the following unit abbreviations in relative format:  

in   pt   ft   yd   mi   nm   mm   cm   m   km   dd   dm 

You can also specify units using their full name in relative formats. The scale control recognizes units by the first part 
of their names, so it doesn't care whether unit names are plural or not. You can type any characters after the first part 
of the names shown here:  

inch  poin  feet  yard  mile  naut  mill  cent  mete  metr  kilo  decima  decime 

V

1 to 1,000,000   One to 1,000,000     One inch = 5 miles 

alues can be specified in any order: 

1:1,000,000       1,000,000:1 1 in to 5 mi 5 miles to 1 in 

"One" can be given as a number or a word: 

Any word or character can be used for "equals" in relative formats. A space isn't required between a numeric value and 
the units abbreviation or name: 

One inch = 5 miles      1in  equals  5mi         1inch = 5miles       5 mi to 1 in     
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When you type scales into the scale combo, they are now displayed at the top of the scales list rather than the 
bottom to make them easier to access.  
 

 
 
As in previous releases, the 'scale history' of scales you've entered is maintained for the duration of your current 

n. If you want a particular scale to appear in your scales list permanently, use the new <Customize This 
in the dropdown list described next. 

ArcMap sessio
List...> option 
 

You can now customize the pre-defined scales that appear in the scale dropdown. In this way you can add scales 
ly as permanent entries in the scale list, so it is easy to access them. When you look in the Scale 

e Standard toolbar at 9.2, you'll see a new <Customize This List...> option. Choosing this option 
ale Settings dialog. The Add Current button adds the data frame's current scale into the list. The 

re the factory default list of scales. The Save button lets you save your scale list to a file so 
eone else can use it to customize their scale list. The Scale Format tab in this dialog lets you 

ustomize how the scales appear: 

that you use frequent
dropdown on th
displays the new Sc
Reset button lets you resto
that, for example, som
c
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The customization you specify in the Scale Settings dialog is reflected in all your ArcMap sessions (it is stored in the 
Windows registry). It is not stored in the map document.  
 

The scale dropdown list in the Standard toolbar is now used in all dialogs in which scale is specified. When you 
specify scale in any dialog in ArcMap, you now have easy access to your 'scale history' of scales you've typed in 
during your current session, along with the pre-defined scales in your list, including any customizations you've made: 
 

 
 
You'll also see these two additional options in the dropdown list: 
 
<None> - Choose this option to clear the scale so that no scale is used. In previous releases you had to enter a sc

of 0 to clear the scale. As a shortcut to choosing <None> from the list you can type in 0, none or <None>. 
 
<Use Current Scale> - If you choose this option, the current scale of the active data frame as it is displayed in the 

current view will be automatically inserted into the field. Th

ale 

is makes it very easy to set the scale to be the same as 
the current scale you are working at. So if you choose this option when the current scale of the data frame in your 
map is 1:45,678, that value will appear in the scale field.  

 
We now prevent unnecessary decimal places that appear in many dialogs. We only show decimal places for scales 

when the scale is larger than 1:100 (e.g. 1:23.456). At scales smaller than 1:100 the scale is rounded up to the nearest 
whole number, and maps are drawn at the rounded up scale. 
 

When the Scale control in the Standard toolbar is disabled, such as when you first start ArcMap, or if the data in the 
map doesn't have spatial reference information, we show the scale as <None> instead of 0:0. The Scale control also 
no longer shows the scale as a negative in any situation. In previous releases, the Scale control sometimes reported 
the scale as being negative when the map contained certain combinations of data with unknown or incorrect spatial 
reference information.  
 

Advanced users can use a Windows registry setting to specify that the scale control should display scales in relative 
format (e.g. 1 inch = 2.5 miles) instead of converting relative scales that you type in into absolute format (e.g. 1:63,360) 
like it does by default in 9.2.  
 
Here is the registry key that lets you control this: 
 
HKEY_CURRENT_USER\Software\ESRI\ArcMap\Settings\Scale Format 
 
If you don't see this registry key, start ArcMap, choose the Customize This List command in the scale control, and then 
make a change in the Scale Settings dialog that appears and press OK. This will write out this string registry key with 
the following default values: 
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format=0, sep=:, puv=1.000000, pu=1, equals= = , mu=5, cf=, cap=false, abbr=false, rev=false,  

Here's what the different parameters mean: 
 
format:  Format used by scale control: 0 = absolute scale, 1 = relative scale. 
sep:  Separator character for absolute format, i.e. ":" in 1:50,000. (Set automatically via Scale Settings dialog). 
puv:  Page unit value for relative format, i.e., "1" inch. 
pu:  Page units for relative format: uses values from the esriUnits enumeration (see separate list below). 
equals:  The equals sign or text string used for relative format.  
mu:  Map units for relative format: uses values from the esriUnits enumeration (see separate list below). 
cf:  Leave this blank or delete: not currently used. 
cap:  Capitalize units.  
abbr:  Abbreviate units.  
rev:  Reverse the absolute format, i.e., 10,000:1 (Set automatically via Scale Settings dialog). 
 

sriUnits enumeration used for pu and mu: 

1

o

specifies that scale will be displayed in the format: 1 in = 10 mi. 
 
While the scale is displayed in relative format, you can still enter the scale in absolute format, and it will be immediately 
converted to relative format for you. You can also enter scale in relative format in different units than you specified in 
the registry key, and the scale will be converted automatically to use the units you specified. 
 
 
 
Magnifier window enhancements and new viewer window 
 
ArcMap 9.2 has been enhanced to make it easier to browse and edit data at multiple scales simultaneously. 
 

 

e
 
1  - esriInches 
2  - esriPoints 
3  - esriFeet 
4  - esriYards 
5  - esriMiles 
6  - esriNauticalMiles 

  - esriMillimeters 7
8  - esriCentimeters 
9  - esriMeters 

0 - esriKilometers 1
1 - esriDecimalDegrees 

12 - esriDecimeters 
 
F r example, setting the registry key as follows: 
 
ormat=1, sep=:, puv=1.000000, pu=1, equals= = , mu=5, cap=false, abbr=true, rev=false f

 

In 9.1 the magnifier window launched by the Magnifier command in the Window pulldown menu had a mode called 
'snapshot' that turned the window into a live view that let you interact with your data at a different scale than the main 
ArcMap display. In snapshot mode you could move the magnifier window to the side of your map so you can see 
detailed data in the window while also looking at the larger geographic context in the main ArcMap display. At 9.2 
we've retained this ability but have made it easier to access in the user interface and easier to use.  
 
Snapshot mode has been renamed to be 'viewer' mode to make it clear that it is a live view. When you are in this 
mode we now simply call the window a viewer window.  

A new command called Viewer in the Window pulldown menu lets you launch a viewer window. This command 
launches a viewer window at the same scale as your map with its extent centered on the center of your map. You can 
then move the window, resize it, zoom in or out on it, etc. 
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A new tool called the Create Viewer Window tool  has been added into the Data Frame Tools toolbar: 
 

 
 
This tool makes it easy to open a viewer window showing you a specific area on your map. Select the tool and then 
drag over the area on your map you would like to view in more detail. A viewer window will be launched displaying that 
extent.  
 
Like the Window > Magnifier command, the new Window > Viewer command and the new Create Viewer Window tool 
are disabled in Layout view. 
 

The window used for the viewer and magnifier has been given a toolbar. The menu for the window can now be 
accessed by clicking a button to the right of the toolbar (previously this menu could only be accessed by right-clicking 
the title bar of the window). Some new commands have also been added into the menu to enable you to pan and 
zoom a viewer window to match the location shown in the main ArcMap display, and vice versa. 
 
In the magnifier window, all the buttons in the toolbar are disabled except for a combo box that lets you specify the 
magnification percentage used by the window. At 9.2 the magnification percentage you choose is persisted at the 
application level in the registry so it will be used as the default the next time you open a magnifier in any ArcMap 
session. The percentage combo box automatically turns into a scale combo box if you choose the option in the 
Properties dialog to specify the magnification as a scale. As you can see from the window's menu, you have the option 
to turn a magnifier window into a viewer window: 
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In the new viewer window, all the buttons in the toolbar, and the new commands in the menu, are enabled: 
 

  
 
The Pan Map To Viewer Location and Zoom Map To Viewer Location commands in the viewer window's menu let you 
re-center the main ArcMap display to match what is shown in the viewer window, so if you find an important detail 
while working in a viewer you can easily center the main ArcMap display on that location. Similarly, the Pan Viewer To 
Map Location and Zoom Viewer To Map Location commands let you re-center the viewer to match the main ArcMap 
display. For example, if you use the Go To XY dialog to center the main ArcMap display on a particular location, and 
you want to see this location in your viewer window, simply choose the Pan Viewer To Map Location command.  
 
Tip: When you right-click inside a viewer window with most ArcMap tools, the new context menu of shortcuts 
described earlier in this section of the document gives you access to commands like Zoom To Selected Features. 
 

You can use the new mouse wheel navigation shortcuts inside a viewer window. As rolling the mouse wheel zooms 
the window the cursor is over, simply move the mouse over the viewer window before you roll the wheel. 
 

You can open multiple viewer windows. In this example, two viewer windows have been opened so that different 
locations can be compared in detail while the main ArcMap displays shows the general geographic context: 
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If you are using a dual monitor configuration you can put a viewer window onto the second monitor so it doesn't 
overlap your main ArcMap display. The example below shows a dual monitor configuration in which a viewer window 

as been opened on the second monitor and maximized to provide a large scale uncluttered view of the area currently h
being edited. Editing can be performed in both displays and graphic feedback shown while you edit appears 
simultaneously on both displays. To maximize a viewer window, double-click its title bar: 
 

 
 

In 9.2 Service Pack 2, we have introduced the ability to use viewer windows to work with multiple data frames side-
by-side. Previously, if your map document contained more than one data frame, the only way to work with the contents 
of these data frames simultaneously was to switch to Layout view and arrange the data frames on the layout page. In 
9.2 before Service Pack 2, if you opened a viewer window and then activated a different data frame in your map 
document, the viewer window was automatically closed. With Service Pack 2, viewer windows remain on-screen if you 
activate a different data frame, enabling you to work with multiple data frames side-by-side.  
 
In this example, a viewer window is being used to compare two data frames showing different data for the same area: 
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When you work with an inactive data frame in a viewer window, you can easily make the viewer show the same 
location that is currently displayed in the active data frame in the main ArcMap window. The set of commands in the 
iewer window's menu described earlier for zooming and panning the viewer window to match the main ArcMap 

 you can use the commands to update the location shown in the active 
 

n, but you can't edit graphics or features. If 
 

o

 this example, four viewer windows have been arranged on-screen so that four different sources of street data for the 
ame area can be compared. Each viewer window is showing the contents of one data frame in the map document: 

v
window also work across data frames. Similarly,
data frame in the main ArcMap window to match the location shown in any of your viewer windows showing inactive
data frames. 
 
There are some restrictions on which operations you can perform inside a viewer window that is displaying an inactive 
data frame. You can generally perform map navigation, query, and selectio
a tool can't be used on an inactive data frame displayed in a viewer window, the cursor will change when you hover 
ver the viewer to show you that the tool is not available. There are no restrictions on the operations that can be 

performed inside a viewer window displaying the active data frame. 
 
In
s
 

 
 
The ability to work with multiple data frames side-by-side in ArcMap can be useful for analysis, historical change 
assessment, data evaluation, and other applications where you want to be able to see different datasets for the same 
area side-by-side, as opposed to working with all the data in one data frame, or working with multiple map documents.  
 
Tip: There are two existing shortcuts that make it easy to work with multiple data frames: CTRL + TAB switches 
between the data frames making each one active in turn. (If you want to be able to do the same thing by pressing a 
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button on-screen, add the Activate Next Data Frame command into any toolbar from the View category in the Tools > 
 frame in the Table Of Contents activates that data frame. 

If you use the Schematics extension, you can use a viewer window to work with a schematic side-by-side with the 
geography it represents without having to work in Layout view. 

Customize dialog). ALT + click on the name of a data
 

( See the 'Schematics' chapter of this document). 

N p 

 
 

ew My Places dialog lets you store frequently used locations & access them from any ma
 

The My Places command  in the Tools pulldown menu launches a new dialog that gives you immediate access to 
your favorite or most frequently locations regardless of which map document you are working with. Unlike bookmarks, 
our places list is stored in a separate file on your computer, not in the map document or globe document you are 

working with. You can use your list of places to navigate around your map, and add the places to your map as 
graphics. You can also add point locations such as addresses and places as input locations into the route finding 
dialogs and the Network Analyst window directly from the My Places dialog. 
 
The My Places command has also been added to ArcGlobe and ArcReader, so all these applications use the same 
common list of places, so adding a place in one application makes it available in the others. 
 
You can add any place, address, or feature that you find using the Find dialog into the list by right-clicking it and 
choosing Add To My Places from the menu that appears. You can also add selected features, selected graphics and 
your map or globe's current extent into the list by using the options in the Add From button in the My Places dialog. In 
the My Places dialog, right-click a place to access additional commands: 
 

y
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L

sing the Load and Save buttons, you can save some or all of your places to a file to share them with other users or 
r them between different computers. (The ability to save a subset of your places to a file has been added in 9.2 

Service Pack 2. Prior to that you can only save all of your places to a file). 
 

ike in the Find dialog at 9.2, single-clicking a place in the My Places dialog flashes it on your map or globe, and 
double-clicking pans to it and then flashes it.  
 
The file in which your list of places is stored is:  
C:\Documents and Settings\<user name>\Application Data\ESRI\Controls\Commands\MapNavigation\myplaces.dat 
 
U
transfe

The My Places command is an ArcGIS Engine control, so if you are a developer creating applications using ArcGIS 
Engine, you can easily include it in your application. When the My Places dialog is used in an ArcGIS Engine 
application it access the same list of places as the ArcGIS Desktop applications. 
 
 
Advanced setting for controlling how panning works 
 

In 9.2 when you pan a map you can immediately commence another pan without waiting for the first one to 
complete redrawing the display. The first pan gets interrupted by the next, so you don't have to wait.  
 
You may prefer to be able to do several successive pans without interrupting the drawing by adding a slight delay to 
the pan function via an optional registry setting. The delay tells ArcMap to wait for a specified number of milliseconds 
after a pan before starting to redraw the map to see if another pan is started. This can make the pan function smoother 
and less 'jumpy', especially when your maps contain a large number of layers because it allows you to do multiple 
small pans before the display starts to redraw. However because it adds a delay it does slow down the time it takes for 
a single pan to complete. For this reason, there is no delay by default. 
 
To add a delay to the pan function, you can add the following DWORD value registry setting into the Windows registry: 

p behaves as normal if it 
 

 
HKEY_CURRENT_USER\Software\ESRI\Display\Scroll Delay 
 
Specify the number of milliseconds delay as a decimal number. A delay of 400 or 500 is suggested if you want this 
behavior. To have no delay, either set the value to 0, or delete the registry setting. ArcMa
doesn't find this registry setting. This setting is not exposed in the arcgis/utilities/Advanced ArcMap Settings utility but it
is mentioned in the ArcGIS Desktop Advanced Settings Registry Keys.doc that is in that folder. 
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Finding and identifying 

Find dialog enhancements make it easier to find places and addresses 
 

A new Places tab has been added to the Find dialog in ArcMap (previously this functionality was only available in 
 for 

 
en searching for places in the full extent of your map or just the current visible extent.  

ArcGlobe and ArcReader). This provides access to the free ESRI World Gazetteer web service and lets you search
places by name anywhere in the world. Anyone with an internet connection can use this service. A dropdown list in the
tab lets you choose betwe
 

 
 
Tip: In the Find dialog, click the ? tool and then click the Place Name control to read about how to specify state names 
and provinces, etc. 
 

Up to now, finding addresses in ArcMap has required that you first load an address locator into your map document, 
such as the ESRI StreetMap USA locator, your own file-based locator, or your own geocoding service running on 
ArcGIS Server. These are still fully supported, but at 9.2 the Find dialog Addresses tab now contains some free 
address locator web services by default that let you find addresses in the USA, Canada and more than 15 European 
countries. All you need to use these is an internet connection: 
 

 
 
Note: the free address locator web services provided in the Find dialog can't be used in the Geocode Addresses dialog 
to perform bulk geocoding of addresses in tables. 
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The experience for working with the re
et when you right-click a result ha

sults you find in the Find dialog has been improved. The context menu you 
s been enhanced to add a Pan To command so you can center the map on the 

a  
lected 

g
p rticular location without changing your map's scale. In the Places tab and the Addresses tab you can also annotate
your map with point graphics, labeled point graphics, or callouts showing the location you found. If you have se
multiple results in the Find dialog, the commands in the context menu operate on all the selected results. This graphic 
shows the context menu you get if you right-click a place in the new Places tab: 
 

 
 
The Add To My Places command lets you add any feature, place or address that you find into the My Places dialog 
(described in the previous section). The Find Nearby Places command lets you find places that are near the location 
you right-clicked. See below for more about the Find Nearby Places functionality. 
 
In addition to the menu accessed by right-clicking a result, the following shortcuts are also available. 
 
- Single-click an entry in the results list to flash it on the map. 
 
- Double-click an entry to pan to it and flash it. 
 

In addition to the free services for finding places and addresses that appear in the Find dialog, other more 
cialized place and address services are available. If you are an ArcWeb Services subscriber and you have already 
ed in to your account via the new Tools > Online Services > Sign in to ArcWeb Services command, you can 
ss additional, premium services in the Find dialog

spe
sign
acce . See the 'Data & services from ESRI' chapter in this 
document. 
 

The Find dialog is now resizable. In this way, you can make it smaller instead of closing it if it gets in the way of your 
map. If you make the dialog very small you may not be able to use all of the fields it contains, but you can still work 
with the results you have found. 
 

The Find dialog enhancements described above are in ArcMap, ArcGlobe, and ArcReader (with the exception of 
certain commands in the results context menu that may not apply in a particular application, such as Create Bookmark 
in ArcReader). The Route Locations tab (which lets you find linearly referenced locations such as highway mileposts 
along route features) is only found in ArcMap.  
 

The Find dialog used in ArcMap, ArcGlobe and ArcReader at 9.2 is an ArcGIS Engine control, so if you are a 
developer creating applications using ArcGIS Engine, you can easily include the Find dialog in your applications to 
provide users with the 9.2 Find functionality and user interface.  
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New dialog for finding nearby places 
 

At 9.2 a new dialog called Find Nearby Places is provided that lets you find different types of places near any 
location on your map. The places you can find are provided by several free web services, including a World Cities 
service and a more detailed USA Cities service. When you find places, they are sorted in order of how near they are to 
our origin location, and their distance from the origin is one of the columns shown in the results list. You can right-

sults to navigate to them or add them to your map as graphics.  
y
click the re
 
To launch this dialog, choose Tools > Online Services >  Find Nearby Places. You can also launch this dialog by 
right-clicking a result in the Find dialog. In the example below, the dialog has been used to find cities within 100 miles 
of a location in France: 
 

 
 
This dialog is also available in ArcGlobe, ArcReader and as an ArcGIS Engine control.  
 
In addition to the free services, if you are an ArcWeb Services subscriber you'll have access to specialized premium 
place services in this dialog, including business, demographic, and traffic information. etc. See the 'Data & services 
from ESRI' chapter in this document. 
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Improved Identify tool 
 

When you click on the map with the Identify tool, the Location field shows you the x, y coordinates of the location 
you clicked. You can now choose the units with which these coordinates are displayed and you can select the 
o

n
c ordinates and copy them. When you click on a feature in the left hand side of the Identify dialog, the Location field 
ow gives you the x, y location of that feature (in the case of a point feature) or the x, y location of that feature's 

centroid (in the case of a line feature, polygon or annotation feature). The current map units of your data frame are 
shown in bold in the units list: 
 

 
 

When you right-click a feature in the left side of the dialog, the menu has several new commands that make it e
to work with features you have identified. You can now sort the features and remove unwanted ones from the dialo
Copy Record copies all the attributes of the feature you right-clicked: 
 

asier 
g. 
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If you right-click in the right side of the Identify dialog, you'll see a new menu of commands. In this menu the Copy
command copies the contents of the cell you right-clicked, so you can use it to copy either the field name or the value
that field has. The Copy S

 
 

elected Field(s) command copies the field name and field value for all of the currently 
elected fields in the list. For example, if you want to copy four fields and their values and paste them into Excel, select 

them in the right side of the Identify dialog and choose Copy Selected Field(s): 
s

 

 
 
You can also hide unwanted fields to simplify the listing by selecting the field(s), right-clicking and choosing the Hide 
Field(s) command. Use Show All Fields to unhide fields that you have hidden. Hiding fields in the Identify dialog is 
temporary and only affects your current Identify session. It does not affect which fields are shown or not shown in any 
other dialogs or when you open the attribute table window for the layer. The View Hyperlink command is enabled if the 
value for a field is a complete URL or path to a document and the View Raster command is enabled if the field is of 
type raster. In both cases you'll also see a clickable icon next to the value. 
 

The Identify dialog now lists related records in the left side of the dialog with the record's value for the default 
primary display field for the related data source. At 9.1 Identify always listed related records with the record's Object-
ID. For example, here's what you see in 9.1 if the features in a States layer are related to a Cities layer and you 
expand the relate after identifying Nebraska to see its related cities: 
 

 
 
At 9.2 you see the cities listed with the default primary display field selected automatically by ArcGIS based on the 
names of the fields in the related data source. In this case, it uses a city name field as the primary display field: 
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In and 
ort Ascending command. Note: It is a limitation of the Identify dialog that it will only use the default 

rimary display field to list related records. So for example if you go into the Table Properties dialog Fields tab for the 

 

the example above the related cities were also sorted in the tree on their name by right-clicking one of them 
choosing the new S
p
related table and choose a different primary display field, your choice is not respected by the Identify dialog. 

You can now drag a box with the Identify tool to identify all the features inside it. Whether you click or drag with the 
entify tool, you can hold down either SHIFT (or CTRL) if you want to identify features without clearing away the Id

urrent contents in the Identify window. When you hold down SHIFT (or CTRL), a small plus sign now appears in the 

 

c
Identify cursor to show that you are in 'add' mode. 

In the right side of the Identify dialog, you can click the top of the Field or Value column to sort the attributes o
lumn. Click on a field to select it. When a field is selected, it will remain visible in the right-side of the dialog as you 

entify additional features from that layer or switch between features from that layer in the left side of the dial
akes it easy to compare the attributes for multiple features especially when the layer has a large number of fields.  

n that 
co
id og. This 
m
 

The improved Identify tool is in ArcMap, ArcGlobe and ArcReader. It won't be supported in ArcScene or ArcCatalo
hich will both continue to use the same Identify tool they had at 9.1. The improved Identify tool is an ArcGIS Engine 
ntrol, so if you are a developer creating applications using ArcGIS Engine, you can include it in your applications. 

g, 
w
co
 
 

Selecting features 

When you create a selection layer (right-click a layer in which features have been selected and choose Selection > 
a 
s 
u 

selected set of features. For example, you may want to create a selection layer 
from one set of features in a layer, then switch the selection so that the unselected features become selected, and 
then create another selection layer.  
 

Create Layer From Selected Features) this operation no longer clears the selected set of features in your layer. So if 
layer has 10 features selected and you create a selection layer to represent those 10 features, the original 10 feature
will still remain selected in your map. In ArcMap 9.1 they were automatically deselected. This enhancement allows yo
to perform another operation on the 

The way that layers are listed in the Table Of Contents Selection tab and the Selection > Set Selectable Layers 
dialog has been improved so that the listing shows you how the layers are organized into groups. Feature-based 
sublayers of ArcIMS image services in which features can be selected are also now correctly grouped under the 
service they belong to: 
 

 
 
You can toggle all the layers in the data frame to be selectable or not by holding down CTRL and clicking on the check 
box next to any layer, irrespective of where the layer is in the hierarchy shown in the tree. 
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Th
 

e Open Attribute Table command and the Properties command have been added to the menu that appears if you 
right-click a layer in the Selection tab, along with a new command that lets you open a table window directly in Show
Selected records mode: 
 

 
 
This context menu is now a separate menu that you can customize via Tools>Customize. (In previous releases, this 
context menu was the same as the Selection pullright in the layer context menu). So at 9.2 you can add any 
ommands from the layer context menu into this menu. c

 
You can also now open the properties of any layer listed in the Selection tab by double-clicking it or highlighting it in 
the list and then pressing ENTER or F12. Another useful shortcut is hold down CTRL and click any expansion +/- sign 
in the tree to expand or contract all of the groups in the tree (this shortcut is also available in the Display tab). 
 
Tip: You can make one layer selectable and make all the other layers unselectable in one go by right-clicking the layer 
and choosing the Make This The Only Selectable Layer command that was added at 9.1. This command is available in 
all the tabs in the Table Of Contents, not just the Selection tab. In situations where you just want to make one 
particular layer the only selectable layer, this command saves you having to visit the Selection tab or Set Selectable 
Layers dialog.  
 

The Clear Selected Features command has been added into the ArcMap Tools toolbar so you can now clear all 
feature selections at any time with one-click: 
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The Selection > Select By Attributes dialog and other dialogs that use the Query Builder control have been 

-  Fields that have been turned off for the layer or table you are working with are no longer listed in this dialog. In other 
words, the dialog now respects field visibility properties. You turn fields off in the Layer Properties or Table 

window (a new capability in 9.2). This makes it easier to work with data 
ecause only fields you have chosen to work with appear in the dialog. 

 

ption of listing fields with their field 
 

g 
s 'Depth last recorded (cm)' has been added into the expression, where you see the 

enhanced so that: 
 

Properties dialog Fields tab or via the table 
sources that have a large number of fields b

- A new menu in the dialog lets you choose how fields will be listed. This menu is accessed via a small control to the 
right of the fields list, or by right-clicking the fields list. This menu gives you the o
aliases instead of their underlying field names. When you choose this option, the fields list respects field alias
properties when you are working with layers and tables. This has been requested frequently because many of you 
use field aliases to make cryptic field names more user-friendly or to make long ArcSDE field names more 
manageable. The Show Field Aliases option is turned off by default in 9.2 so there is no immediate change to your 
familiar workflows. Choosing to show aliases in this dialog has no effect on the expression syntax. Field aliases are 
not shown or supported in the expression itself. If you double-click a field shown with its alias, it will still be added 
into the expression with its actual name and its field delimiters. In the example shown below, the field list is showin
aliases and the field with the alia
field's actual name not its alias: 

 

 
 
- As you can see in the example above, you can now also choose how the fields are sorted in the list. By default th

fields are still listed in their original order in the data source so there is no immediate difference to 9.1. Choosing Sort 
Ascending or Sort Descending can make it easier to quickly locate the field you want.  

 
The sorting and field name options you choose remain in force whenever you use this dialog or others that o
same options (the Field Calculator and the Label Expression dialog). These enhancements also apply to ArcGlobe, 
ArcScene, the query builder in the geoprocessing

e 

ffer the 

 environment (when working with a layer) and custom dialogs that 
se the Query Builder COM object. u
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The Selection > Select By Attributes dialog and Selection > Select By Location dialogs both have check boxes 
let you choose to only show s

that 
electable layers in the layers dropdown list. At 9.2 if you check this box ArcMap now 

members this setting between sessions. In this way, you can check this box once and it will be checked whenever 
you use this dialog. Previously if you checked the box, the applications didn't retain this setting between sessions. This 
makes it easier when you are working with a document containing a large number of layers and you have made the 
layers that you want to be able to query selectable by checking them in the Table Of Contents Selection tab (or in the 
Selection > Set Selectable Layers dialog). This setting also a s to ArcGlobe and ArcScene.  

re

pplie
 

You can now copy statistics out of the Selection Statistics dialog by selecting the values and then right-clicking: 
 

 
 

The Selection > Select By Location dialog's layout has been improved to provide more space for the checkable list 
f layers from which features will be selected. The checkable list of layers uses the new standard layer list control that 

ad  in one click. A Help button has also been added. The 
preview graphics have been removed but they are still available in the 'Using Select By Location' topic in the Desktop 
Help. (This enhancement also applies to ArcGlobe and ArcScene): 
 

o
presents layers organized into the same group or composite layers as the Table Of Contents. An OK button has been 

ded so you can execute a query and dismiss the dialog
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Working with layers 

Easier to choose layers in dialogs 
 

A lot of dialogs in ArcMap contain a dropdown list that lets you specify which layer you want to perform an operati
on. At 9.2 we have updated this dropdown list to make it easier to work with: 
 

on 

nd 

r contains. 

 If the layer names a

he new control looks like. In this particular dialog, group layers aren't valid inputs so the name of the 
roup layer is shown in grey text: 

- The dropdown layer list now shows you which layers belong to group layers or layers such as ArcIMS image 
services, so the list matches the way that the layers are organized in your Table Of Contents. You can expand a
contract the list to quickly access the layer you want to use. 

- Each layer is listed with its layer icon from ArcCatalog so you can easily see what type of data each laye

- re very long, a horizontal scroll bar at the bottom of the dropdown list lets you scroll the listing 
sideways. 

 
Here's what t
g
 

 
This improved layer dropdown list is also used in ArcGlobe and ArcScene. 
 
 
Set transparency, contrast and brightness for group layers 
 

Group layers now have their own transparency, contrast and brightness properties. In this way, you can set these 
properties for all the layers in a group layer to control how they will be displayed without having to visit each layer 
individually.  
 
When you set a transparency, contrast or brightness property for a group layer to be anything other than 0%, this 
overrides the existing setting for that property in each layer in the group which has that property. If you have set one of 
these properties for the group layer but decide you want all the layers inside to group to use their own settings instead 
of being overridden by the group layer's setting, simply change the group layer's setting back to be 0%. So for 
example, if the group layer's transparency is 0%, the layers in the group will each be drawn using their own 
transparency setting. In this way, you can switch between setting transparency at the group layer level or using the 
transparency settings of the layers in the group. 
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You can set these properties for a group layer by either using the Effects toolbar (in ArcGlo
olbar is called 3D Effects): 

be and ArcScene this 
to
 

 
 

 by going to the new Display tab in the Group Layer Properties dialog where you can type the values in: or
 

 
 
In both the Effects toolbar and the Display tab, the controls for specifying contrast and brightness are disabled if your 
group layer currently does not contain any layers that support these properties. Contrast and brightness are only 
supported by certain layers, such as raster layers and CAD drawing layers. All layers support transparency. 
 
This enhancement applies to ArcMap and ArcGlobe. ArcReader also now supports group layer transparency via the 
Layer Effects toolbar. 
 
Labeling and annotation enhancements 
 

Label Manager dialog: new Summary button: Click this button to generate a summary analysis of your labeling 
rules. The summary will point out potential problems with your labeling rules that may impact labeling performance, 
map readability, and the ability to convert labels to annotation. 
 

The Label Expression dialog (accessed from Layer Properties dialog Labels tab) has been enhanced to make it 
easier to work with the fields list. 
 
- Fields are no longer listed in multiple columns and the horizontal scroll bar lets you scroll to see the ends of long field 

names. This makes it easier to work with long names. 
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- A new menu in the dialog lets you choose how f
This is the same menu that has been added into the 

ields are listed, including the ability to list fields using their aliases. 
Select By Attributes dialog. See the Feature Selection section 

above for details: 
 

 
 

Converting labels to annotation: The ability to append annotation into an existing feature-linked annotation featur
class has been

e 
 added to the convert labels to annotation process. This gives you the ability to create feature-linked 

nnotation in multiple conversion processes when producing annotation for specific extents and still store the 
nnotation in one feature class. The way that developers convert labels to annotation has also been simplified. 

a
a
 

The dialog launched by the Annotate Selected Features command accessed by right-clicking a layer has been 
en  

 the new Select All 
nd Clear All buttons, or use the shortcut of holding down CTRL and clicking on any check box in the list. 

 

hanced to make it easy to quickly select all or none of the annotation feature classes that are listed. In previous
releases each item would have had to be checked or unchecked individually. You can either use
a

The Label Priority Ranking dialog now shows you which group layer each layer belongs to. The dialog is also now 
resizable. (This dialog is launched from the Labeling toolbar or from the Labeling pullright in the context menu for a 
data frame). 
 
 
Choose how hyperlinks are shown 
 

You can now choose whether hyperlinked features will be highlighted on maps when the Hyperlink tool  is 
selected. If they are highlighted, you can also choose which color will be used. You can find this setting in the ArcMap 
Tools > Options dialog General tab. Like all the settings in the General tab, this setting applies to all your ArcMap 
sessions and is not stored in your map document. The default for this setting is to highlight the features in blue: 
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Improved handling of different geographic coordinate systems 
 

We have improved the dialog that appears in ArcMap to warn you that the data you have added to the map uses a 
different geographic coordinate system (GCS) than the one used by the data frame. Here's the dialog you get in 9.2: 
 

 
 
- The wording in the dialog has been improved to remove the implication in the old dialog that ArcMap always 

automatically chooses a geographic transformation for you to handle the transformation between the GCS of the 
data you are adding and the GCS of the data frame. There is only one situation where ArcMap does this: if the two 
GCS involved use the NAD27 and NAD83 datums and the data is in the lower 48 US states, then the 
"NAD_1927_To_NAD_1983_NADCON" transformation is chosen automatically. This transformation shouldn't be 
used if the data covers Alaska and Canada. The warning dialog still appears even when this transformation is 
chosen automatically. 

When you add multiple datasets into ArcMap and one or more of them use a different GCS than the data frame, the 
ta 

just review the current transformations used by the map so you can make any adjustments or 
additions immediately. 

 

ied for the particular GCS to GCS combination that is involved or not. 

ote: You may have turned this warning dialog off in which case you won't notice these enhancements. If you want to 
is warning you can launch the \Program Files\ArcGIS\Utilities\AdvancedArcMapSettings.exe utility and check 

m Warning check box in the Miscellaneous tab.  
 

 
- 

warning dialog appears just once, instead of appearing repeatedly for each dataset. The dialog now lists all the da
sources involved and gives the name of the GCS each one uses.  

 
- You can now launch the Geographic Coordinate Systems Transformations dialog directly from the warning dialog to 

choose, modify or 

 
- The 'OK' and ' OK To All' buttons on the old dialog have been replaced a simple 'Close' button to make it clear that

you are not choosing whether or not to add the data. The data always gets added, irrespective of whether there's a 
transformation specif

 
N
restore th

e Datuth

These enhancements have also been made in ArcGlobe. The wording in the warning message box is now specific to 
whether you are using ArcMap or ArcGlobe. 
 

In the Geographic Coordinate Systems Transformations dialog, the list of available pre-defined transformations for 
e selected GCS to GCS pair no longer defaults to the first entry listed. Instead if now defaults to <Noneth

redu
>. This 

ces the chance of an unsuitable transformation being used without the user's knowledge. This enhancement is 
also reflected in ArcGlobe. 
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New Zoom To Make Visible command 
 

A new command called  Zoom To Make Visible has been added to the context menu you get if you right-click a 
layer in ArcMap. (This same command has been in ArcReader since 8.x). The command is enabled if the layer has a 

ntly not being drawn because of the map's scale. Choosing the command zooms the 
h the layer will become visible. ArcMap chooses the nearest scale to the map's current 

cale at which the layer will become visible. The center point of the map is maintained during this zoom.  
 

scale visibility range and is curre
map in or out to a scale at whic
s

 
 
Th kes it easier to zoom your map to a scale at which the 

a o this was to inspect the layer's scale range propertie
is ma selected layer will become visible. Previously the only 

w y to d
m tch it our 
map, be
 
 
S ipe
 
These c
 

s and then manually change the scale of the map to 
a . Using the Zoom To Make Visible command doesn't mean you will necessarily see the layer's features on y

cause you may be looking at part of the map in which none of these features are located. 

w  tool enhancements 

hanges also apply to the Swipe tool in ArcGlobe and ArcReader. 

The 
 

Swipe tool now works on group layers.  

The 
hold dow is lets 
you imm e what is underneath a particular layer without having to drag the mouse to swipe left/right or 
up/down h is a full display swipe that repeats 
au oma
 
 

w Flicker command 

Swipe tool has a new option for swiping the full display. Select the tool then hold down CTRL (or SHIFT) and 
n the left mouse button to reveal what is underneath the layer being swiped across the full display. Th
ediately se
. See the information about the new Flicker command below too, whic

t tically. 

Ne
 

The new Flicker command in the Effects toolbar in ArcMap automatically flickers the layer chosen in the layer 
dropdown list on and off using the time interval specified in milliseconds in the control next to it: 
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Flicker is particularly useful for temporal change detection
ifferent times of the same location), data quality compar

 (especially of satellite images or air photographs taken at 
ison, and other analysis where you want to see small 

if
g 

d
d ferences between very similar looking layers. Very fast rates of flicker can be used to make differences between 
layers appear to 'jump out' due to the optical effect of the eye being attracted to changes between rapidly alternatin
displays (an effect also exploited by the early experiments in cinematography).  
 

The Flicker command is in ArcMap and ArcGlobe (3D Effects toolbar). It is also an ArcGIS Engine control, so if you 
are a developer creating applications using ArcGIS Engine, you can easily include it in your applications.  
 
 
New credits property for layers 
 

A new property called 'credits' has been added into the Layer Properties dialog General tab. This provides a place 
where you can specify copyright, legal, or any other acknowledgement information about the data in the layer: 
 

 
 
This is supported in ArcMap and ArcGlobe by most layer types. 
 
With this new property, this information is easily available if you share a layer with others as a layer file, or share or 
publish your map or globe document. If you publish a map using ArcGIS Server, this information is published too, so it 
is available in client applications such as ArcGIS Explorer when your map service is accessed. If your map service is 

ssed in ArcMap, the credits fields for the layers it contains are read-only, so that e user accessing your service 
a

r the data frame is used as the overall credit information for the 
s

acce
c

th
n't change them. 

 
To specify credits information for data represented in a particular data frame, the credits property has also been added 
into the Data Frame Properties dialog (see the Map Documents section below). When you publish a map document 
with ArcGIS Server, the credits information specified fo
re ulting map service. 
 
 
Other 
 

The Convert Features To Graphics command (right-click a feature layer or a data frame to access) no longer 
unselects the selected set of features in your input layer. So for example, if you select a set of features for a layer and
then convert these features to graphics, the features in the layer will now remain selected after the graphics have b
reated. This makes it easier to comple

 
een 

te workflows where you want to retain the selected set of features, such as 
witching the selected and unselected features and then converting those features to graphics.  

c
s
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Map documents 

Improved Measure tool 
 

ArcMap 9.2 features a new Measure tool  in the Tools toolbar with its own compact popup dialog that lets you 
e

 on a running total for all the 
asurements you make. Measurements are displayed inside the dialog instead of in the status bar so it is easy to 

d paste them into other apps. 

m asure lines and areas. You can also click on features to get their area, length, etc. An option in the dialog lets you 
choose to snap to features as you define the line or area to be measured. The snapping tolerance is fixed at 8 pixels 
on the display. You can choose the units for the measurements, and also turn
me
copy an
 

 
 

 Measure a line. Double-click to complete the line.  
 Measure an area. Double-click to complete the polygon. This button is only enabled if your map is using a 

projected coordinate system. It is disabled if the coordinate system is geographic or unknown. 
 Click on a feature to measure its length (line), perimeter and area (polygon or annotation) or x y location (point 

 makes it easy to measure features in your map without having to trace over them. feature). This option
 Turn on snap-to-feature mode. In this mode, the line you define to measure length or area will automatically 

 corners of two buildings, measure the distance along part 
of a street, the distance between two point features, or the area of part of a parcel. Hold down CTRL while you 
draw in this mode to snap anywhere along line and polygon features instead of just to vertices. For example, 
holding down CTRL enables you to measure the width across the middle of a straight-sided polygon such as a 
building footprint, by snapping to the edges of the polygon even though there are no vertices in those 
locations. 

snap to the nearest vertices in line or polygon features, or to the nearest point features. The snapping radius is 
8 pixels. This enables you to perform very accurate measurements between or along features. For example, 
you may want to measure the distance between the

 Turn on a total showing the total of all the measurements you make. 
 Choose the distance and area units you want to use. The Measure tool (starting at 9.2 Service Pack 3) 

remembers the units you choose between your ArcMap sessions. 
 Clear the dialog. 

 
Like in the Measure tool at 9.1, you can hold down SHIFT when you measure a line to get a geodesic distance 
measurement. By default if the data frame is using a projected coordinate system, 2D Cartesian mathematics is used 
to calculate distances, so the measurement reflects the projection of the 3D data onto the 2D surface, and does not 
take into account the curvature of the earth. You can hold down SHIFT while measuring to get the geodesic distance 
instead. This is calculated using the spheroid/ellipsoid of the data frame's projected coordinate system's geographic 
coordinate system. If the data frame is using a geographic coordinate system and the display units are linear, the 
measurements are geodesic by default and you don't have to hold down SHIFT.  
 

The improved Measure tool is in ArcMap and ArcReader (for published 2D maps). At 9.2, the 3D Measure tool that 
was introduced in ArcReader at 9.1 for measuring published 3D globes has been added into ArcGlobe where it 
replaces the existing Measure tool.  
 

The Measure tools for maps and globes are ArcGIS Engine controls, so if you are a developer creating applications 
using ArcGIS Engine, you can easily include them in your 2D and 3D applications. 
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Enhanced map document properties dialog 
 

The File > Map Properties command, which launches the Properties dialog for the map, has been renamed to File > 
Document Properties to make it clearer that these are the properties of the .mxd file (not the properties of the data 
frame), and to match ArcGlobe and ArcScene. 
 

A new read-only File field has been added to the ArcMap File > Properties dialog showing you the full path and 
name of the your current .mxd file. In other words this field shows you the ArcObjects Path Property. You can drag 
over this text, right-click and then copy it to the clipboard which makes it easy to paste the pathname into emails, 
documents, or into the layout as text, etc. 
 

 
 

The Title field has been fixed to eliminate the bug where saving the map document reset the field to the name of the 
mxd file if you typed in your own title. The Title field now correctly defaults to the name of the .mxd file, but you can 
enter any text into this field to provide a title for your map. This text in this field is used automatically when you use the 
Insert > Title command when you are in Layout view. 
 

In the File > Document Properties dialog > Data Source Options subdialog there is a new check box option that lets 
you choose what the default path option will be for file-based data sources in new map documents you create.  
 
Leave this new option unchecked for new map documents to default to using absolute paths, as they did in previous 
releases. Check this box for new map documents to default to using relative paths. This setting is stored in the system 
registry for the application and does not affect the current map document you are working with, or your existing map 
documents. It just determines which of the two radio buttons in this dialog will be selected by default for maps you 
create from this point in time onwards. 
 
 
Support for degrees decimal minutes as display units 
 

You can now specify the display units for a data frame to be Degrees Decimal Minutes.  
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Improved coordinate display in status bar 
 

We have widened the area used for coordinate display in the status bar at the bottom of the ArcMap window. 
 

The area in the status bar used to display the location of the cursor in page units when you are working in Layout 
View is now no longer shown when you are working in Data View. In previous releases this area was shown, but 

ts, etc in remained blank while you were in Data View. This change provides more space for messages, measuremen
the status bar while you are in Data View. 
 

You now have more control over how coordinates are displayed in the status bar. You can choose the number of 
decimal places and you can turn on thousand separators and zero padding: 
 

 
 
When the display units are degrees minutes seconds (DMS) the number of decimal places in this dialog controls how 
many decimal places are used to show the seconds. When the display units are degrees decimal minutes (new in 9.2), 

e setting controls the number of decimal places used to show the minutes. 
 
These settings are stored in the current map document (.mxd file) and apply to all the data frames in the map. 
 
Tip: These settings also control the feedback you get in the status bar when you draw graphics with the tools in the 
Draw toolbar. To control the feedback you get when you edit features in an edit session, you use the settings in the 
Editor > Options dialog General tab and Units tab. 
 

th

The number of decimal places with which coordinates are displayed in the status bar now defaults to 3 decimal 
places for new map documents you create. This setting is stored inside each map document, so your existing map 
documents will still default to using 2 decimal places. To change an existing map document to use more decimal 
places for the coordinate display, go to the Tools > Options dialog Data View tab shown above. 
 
 
Grids and graticules 
 

Six new reference system styles have been added to the default ESRI.style file to make it easier to specify Military 
Grid Reference System (MGRS) and US National Grid as grids. The ds were supported previously but you had to 
create new styles for them manually in the Style Manager: 

se gri
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To use one of these new styles, in the View > Data Frame Properties dialog go to the Grid
grid to use of one these new styles, select the grid from the list and press the Styles butt

s tab. To change an existing 
on. To create a new grid using 

ne of these styles, press the New Grid button. If wizards are turned on (Tools > Options dialog General tab), use the 
w

s button. If wizards are turned off, choose the style 
ou want to use when the Reference System Selector dialog appears after you press the New Grid button. 

 

o
izard that appears to create a new grid (press Next to go through the wizard and then press Finish, it doesn't matter 

what settings you choose in the wizard) and then press the Style
y

There are now more options for specifying intervals for graticules. When you define graticules for a data frame 
(Data Frame Properties dialog Grids tab) you now have the option to specify the graticule intervals in decimal degrees 

r degrees and decimal minutes instead of degrees minutes and seconds. Degrees minutes and seconds is still the 
d
o
efault. You can find the new options in the Reference System Properties dialog Intervals tab: 

 

 
 
Note that these options aren't available in the Grids and Graticules wizard. If you launch the wizard to create a new 
graticule, intervals are specified in degrees minutes and seconds, but you can use the other options once you have 
created the graticule by opening the graticules properties dialog. (To use the Reference System Selector dialog 
instead of the wizard when you define a new grid or graticule, uncheck the 'Show wizards when available' box in the 
Tools > Options dialog General tab. 
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Coordinate system GCS_Assumed_Geographic no longer assigned to shapefiles 
 

The shapefile format originally did not support coordinate system metadata. The ArcView GIS 3.x software allowed 
hapefiles to be projected on-the-fly if it determined that from the range of coordinates that they were in longitude, 

ple transition from the ArcView GIS software to ArcGIS, a similar procedure was implemented in 
rcMap. If a shapefile had coordinate values that looked like latitude and longitude values, a 'dummy' or 'fake' 

t 9.2, we have stopped assigning shapefiles this dummy coordinate system. Now that shapefiles have full support for 
coordinate system metadata, it is a much better practice for the software to no longer make assumptions about the 
actual coordinate system being used. So in 9.2, you no longer see shapefiles with GCS_Assumed_Geographic_1.  
 
If you have any data whose metadata lists this coordinate system, please realize that the data does not have a valid 
coordinate system. You should check with the data provider or colleagues to see if you can identify the correct 
coordinate system, and define the data as such. You can use the geoprocessing environment to define the projection 
for multiple shapefiles. You may still see GCS_Assumed_Geographic_1 being used by data that was created by 
exporting or converting shapefiles that used it. We recommend that you, similarly, update the projection information for 
any data like that to use a valid coordinate system. 
 
 
ArcMap can now automatically open your most recently used map 
 

s
latitude. To help peo
A
coordinate system was temporarily assigned to the data in ArcMap. This dummy coordinate system, called 
GCS_Assumed_Geographic_1, used the NAD 1927 datum. Using an assumed datum is problematic because if the 
data really uses a different datum, it causes some confusion and inaccuracy. 
 
A

The ArcMap Start Up dialog has a new 'Load last map on startup' check box option that lets you tell ArcMap to 
automatically reopen the last map you were using when it starts. If you check this box, ArcMap will load your last map 
the next time it starts and display a message box while that map is loading that lets you press ESC and return to the 
Start Up dialog. By pressing ESC and unchecking the option, you can return to normal operation. 
 
 
Map graphics and elements 
 

A common request has been to provide the ability to name an element on a map or page so that code can be used 
to search for specific elements and perform operations on them. In ArcView 3 this was done through an object tag. In 
ArcMap elements using the ElementProperties base class (which is almost every ESRI element) have two properties 
CustomProperty (a variant) and Name (a string) that can be used for this purpose.  
 
At 9.2 we have exposed this Name property in the properties dialog for all map elements and graphics in the Size and 
Position tab. In this way names can be specified directly through the user interface. Developers can take advantage of 
this by being able to find and manipulate elements by name: 
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The anchor point (see the graphic above) is the location on an element from which the x and y positions are 
ent has its own anchor point. Elements that can resize automatically in response to 

ends and scale bars, will keep their anchor point in place. For example, if you set the 
anchor point of your legend to the lower left the legend will expand or contract while keeping the lower left corner 
anchored to that spot. This applies when elements resize automatically in response to changes in the map and when 

 it will still resize in 
el setting, all 

le

measured. At 9.2 each elem
changes in the map, such as leg

editing the size and position values in this dialog. When you resize an element by dragging handles
hichever direction you drag the handles. Previously, the anchor point used to be an application levw

e ments used the same anchor point, and automatic resizing ignored the anchor point and always resized from the 
lower left. 
 

When you use the drawing tools on the Draw toolbar you now press SHIFT + F6 instead of the C key to enter the 
coordinates of a vertex by typing it in, because at 9.2 the C key is now the key you hold down to turn any tool into the 
Pan tool. The ability to draw by entering coordinates has also been added to the Ellipse tool and the Marker tool. For 
xample when you use the Marker tool to draw a point on the map you can press SHIFT + F6 or E to type ie n the 
oordinates. When you use the Rectangle Tool you can press SHIFT + F6 or E to define the two corner points. 

y tool by clicking it with the What's This tool from the Standard toolbar to find out 
h

c
 

ip: Get context sensitive help on anT
w at shortcuts are supported specifically by the tool. (This help won't include generic shortcuts for map navigation that 
are available irrespective of which tool is currently active). 
 
 
Improvements to map templates accessed via the File > New dialog 
 

In the USA templates, the polygons in the 'United States' layer have been given a border so you can still see st
boundaries if you turn off the separate 'State Boundaries' layer. 
 

ate 

In the USA and World templates, graphics have been given a Label Weighting of None instead of High in the 
Labeling toolbar > Label Weight Ranking dialog so that drawing graphics on the maps, such as lines and study areas,
don't cause labels to be suppressed in their immediate area. 

 

 
In the USA and World templates, custom full extents (see earlier in this chapter) have been applied to the data 

frames so that when you press the Full Extent button you get taken to the extent of the region that the map is intended 
to show, not the extent of all the data in the map. 
 
 
Drawing Errors window 
 

The Drawing Errors window that appears if a layer cannot be drawn correctly is now much smaller and appears in 
ow, to make it less obtrusive. You can enlarge the window if you want to read 

the entire error message. This same window is also used for any errors that occur during export, printing, or print 
Advanced users can suppress the Drawing Errors window using a new check box in the 

MapAdvancedSettings.exe utility. In that utility, go to the Data Frame/TOC tab to find the new check 

roperties dialog  

the lower right corner of the ArcMap wind

preview. 
arcgis/utilities/Arc
box. 
 
 
Data Frame P
 

The layout of the Data Frame Properties dialog Coordinate System tab has been improved so there is more space 
oordinate system details and the coordinate system tree. The coordinate system tree has been fixed so 

aining folders now list those folders correctly (together as a group at the top of the list rather than 
ically with the coordinate systems). The coordinate system details listed in this tab now include the 

ta frame's Projected Coordinate System and the datum of the Geographic Coordinate 
d by the data frame's Projected Coordinate System.  

for the list of c
that folders cont
sorted alphabet
linear units used by the da
System use
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 A new property called 'credits' has been added into the View > Data Frame Properties dialog General tab. This 
provides a place where you can specify copyright, legal, or any other acknowledgement information about data or ma
represented in a data frame: 
 

p 

 
 
This complements the 'credits' property that has been added into the Layer Properties dialog General tab. If you are 

reparing a map document for publication and you want to include copyright information, you can choose whether to 
dd it into the Data Frame Properties to specify copyright for the whole map, or to specify it for each individual layer, or 

p
a
both. 
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Symbology 

Advanced symbology and symbol editing with cartographic representations 
 

Whether you are making maps for reports and presentations, creating publication quality cartographic products, or 
publishing onto the web, you want to make great looking maps. 9.2 vastly extends the symbolization capabilities
ArcGIS with

 of 
 the introduction of cartographic representations. Representations allow you to get exactly the look you 

want without having to export your map to a graphics package like Adobe Illustrator. Using representations not only 
eliminates that step, it also allows map designers to store their work in the geodatabase for easy update management 
and re-use in multiple map products. See the 'Cartographic representations' chapter of this document. 
 
 
Faster drawing fill symbols 
 

All fill symbols with outlines in the ESRI default style, and a number of other styles, have been changed so that they 
ead of cartographic line symbols for their outlines. This change yields a drawing 

lygon data of up to 65% in many cases, with an average improvement 
symbol in the ESRI default style now draws 65% faster than 

ta.  

ing performance than cartographic line symbols because cartographic lines 
 caps and joins, dot dash patterns, etc. In symbols where these additional 

 a simple line symbol instead provides faster drawing performance. Cartographic 
ties and for additional line quality. Existing fill 
rticular appearance for their outline are not 

 this change and continue to use a cartographic line symbol in 9.2. 

rted reduced drawing performance after simply 
on feature class to ArcMap, the default symbol 
us releases, if you changed the color of the 

e are: 

ivic 

n 

now use simple line symbols inst
performance improvement when working with po

ample, the solid blue Lake of almost 25%. For ex
previously with our test da
 
Simple line symbols have better draw

s linesupport additional properties such a
roperties are not being used, usingp

line symbols are only needed where you require the use of these proper
ymbols that take advantage of cartographic line symbols to provide a pas

affected by
 
This solves the issue in ArcMap where people have sometimes repo
selecting a polygon symbol with a different color. When you add a polyg
t is drawn with always uses a simple line symbol for its outline. In previoi
symbol by double-clicking it and choosing a different symbol from the Symbol Selector, this could reduce performance 
because the commonly used symbols in the default style used a cartographic line symbol for their outline. This is no 
longer a problem now that cartographic line symbols used for fill outlines have been replaced with simple line symbols 
where this change could be made without changing the appearance of the symbol. 
 

he styles impacted by this changT
 
C- 

- Conservation 
- Environmental 
- ESRI (the default style) 
 Forestry -

- Geology 24K 
- Hazmat 
- Ordnance Survey 
- Petroleum 
- Public Signs 
- Real Estate 
- Soils Euro 
- Survey 
 Transportatio-

- Utilities 
 
When you use the Symbol Selector in 9.2, the symbols you see will reflect this change. There are no additional steps 
you need to perform in order to start using the faster drawing fill symbols.  
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This change does not affect your existing map documents or layer files, so your existing maps and layers will continue 
to use the symbols you have already assigned to them. Remember that when you assign symbols to features, these 
symbol definitions are stored in the map document (or layer file if you save a layer out to disk) and there is no link ba
to the contents of the style files. If you wa

ck 
nt to take advantage of the faster drawing fill symbols in your existing map 

ocuments and layer files, you will have to update the symbology used in them. You can either replace the existing fill 
isting 

d for drawing speed 

d
symbols with the same symbols from one of the 9.2 styles affected by this change, or you can simply edit the ex
fill symbols to replace any cartographic line symbol outlines with simple line symbol outlines.  
 
 
New style provides symbology optimize
 

A new style called the ESRI_Optimized style is provided at 9.2. This is a version of the ESRI default style that 
contains line symbols and fill symbols that are designed to perform while still maintaining a close visual appearance of 
their counterparts within the default ESRI style. The performance improvement is up to 65% in many cases. The fill 
symbols in the ESRI_Optimized style use simple line symbols for their outlines instead of cartographic line symbols. 
The picture fill symbols make use of emf files instead of the bitmaps that are used in the ESRI default style. The line 
symbols, as well as line fill symbols, use fewer layers and reduced widths to make up the performance improvements. 
There are a few symbols where the performance could not be improved and these were dropped from the optimized 
version of the ESRI style. 
 
 
New classification method 
 

A new classification method called geometrical interval has been added to the Classification dialog accessed from 
the Layer Properties dialog Symbology tab when you work with graduated colors or symbols. This method creates 
class ranges based on intervals that has a geometric sequence based on a multiplier (and its inverse). It creates these 

als by minimizing the squa  sum of elements per class; this ensures that each interval has an appropriate 
er of values within it and the intervals are fairly similar. This algorithm was specifically designed to accommodate 

interv re
umbn

continuous data. It produces a result that is visually appealing and cartographically comprehensive. 
 

In the Desktop Help, see: Mapping and Visualization > Symbolizing data > Applying symbology > Standard 
classification schemes 
 
 
Other 
 

When you import symbology into a layer from another layer, the problem where the import sometimes doesn't 
match fields with aliases correctly has been fixed. 
 
 
 

Accessing map services from the web 

Improved support for ArcIMS image services  
 

In previous releases, ArcMap sent no datum transformation information in requests it made to ArcIMS when 
accessing image services. At 9.2, support for projections has been upgraded in the ArcIMS Spatial Server. Many 
projections that did not work at all or worked incorrectly are supported. In addition, if a service uses a datum 
transformation, the datum transformation will be honored. ArcMap now takes advantage of these improvements 
because it now includes a datum transformation string in FEATURECOORDSYS and FILTERCOORDSYS tags in the 
GETIMAGE request made on the ArcIMS server. As a result, ArcMap will then receive an image from the ArcIMS 
server that has been properly transformed. This greatly increases the accuracy and reliability of working with ArcIMS 
image services inside ArcMap. 
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There may be instances where there is in error on the server or an erroneous transformation set in the services map 
configuration file, or maybe even an issue with the data and it’s assigned coordinate system that causes spatial 
inaccuracy. 
 

With ArcIMS 9.2, map service authors can now choose to block the ability of a client application such as ArcMap 
and ArcGlobe to access the geometry (the actual vector feature data) from an ArcIMS image service. Prior to ArcIMS 
9.2, feature data could be extracted from an ArcIMS image service in various ways, which was problematic in 
situations where the map service was designed specifically to allow client applications to view the map but not access 
the underlying data. At 9.2, ArcIMS map service authors can now choose to prevent geometry data from being 
extracted.  
 
What this means for you as an ArcMap or ArcGlobe user, or a user of a published map or globe in ArcReader, is that 
when you access certain ArcIMS image services, certain functionality will not be available to you and will be disabled 
in the user interface of the program you are using. When you access an ArcIMS image service that restricts access to 
its geometry, the functionality that is now disabled includes: 
 
- Export 
- Geoprocessing 
- Buffering (Buffer Wizard) 
- Flash (Identify & Find results) 
- Set/Create Bookmark (Identify & Find results) 
- Select by Location 
- Create Selection Layer 
- Change Selection symbol 
- Zoom to (Selection & Find results) 
- Pan to (Selection & Find results) 

if output image type supports transparency) 
Change selection color (if output image type supports transparency) 

 a 

ect 
 information regarding server restrictions: Disabled Output 

ypes and Forbidden Requests: 

 
Functionality that is still available with these restricted services include: 
 
- Identify 
- Select by Attribute 
- Selection rendering (
- 
 
ArcIMS services which have geometry blocked can be identified in the service layer properties Source Tab. There is
new attribute within the Data Source information called “Query Results”. This attribute will state whether the query 
results from this service “Do not include geometry” or “Include geometry”. If you see “Do not include geometry” exp
certain restrictions. The Source Tab also includes additional
T
 

 
 
If ArcMap does not have access to the feature’s geometry, all rendering will be done by the ArcIMS server impacts 
your ability to select ArcIMS image service features, how you can render this selection and how you can interact with 
this selection. 
 
First, the ArcIMS server can restrict the kind of images it generates. If this restriction includes both png and png8, 
which support transparency, the ArcIMS server is sending ArcMap an image type that does not support transparency. 
In this case you will not be able to see selected ArcIMS image service features in your map. (Note: you will also not be 
able to give the background of the service transparency - this functionality will be disabled in the service layer’s 
properties Advanced Tab). The reason for this is ArcMap needs to request a 2nd image from the server. This image is 
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limited to the selected features and is overlaid on the map. Since it is overlaid, the image needs to be transparent so 
that you can see features in the map that are not selected. You can still select features and view them in the layer’s 
attribute table. 
 
The second limitation concerns the rendering of the selected features. Since all the rendering in this case is done by 
the ArcIMS server, rendering options are limited by what the server supports. In this case, only the selection color can 
be changed. The “with this symbol” radio button in the Selection Tab of the ArcIMS service sub layer’s properties 
dialog will be disabled.  
 
Lastly, when using a 9.2 ArcIMS image service where the query results do not include geometry, you will not be able to 
perform map navigation tasks based on the selection. This includes, Zoom To, Pan To or creating spatial bookmarks. 
This also goes for the same and similar commands found in the context menus for Identify and Find results. These 
commands will be disabled in this case. 
 
Tip for ArcIMS administrators: To restrict an image service as described above, you use the new parameter 
provided in ArcIMS 9.2 called ‘returngeometry’, in the conf uration files for the ArcIMS query server (aimsqs.cfg) and 
the ArcIMS ArcMap Server (aimsamsrv.cfg). This parameter blocks a feature’s geometry from being returned to a 

ig

client as part of a response to a query request. This parameter has no affect on image requests. S
documentation for ArcIMS 9.2 for more about this. 

ee the 

 
When you add an ArcIMS image service into ArcMap or ArcGlobe, the legends for all of the sublayers in the service 

Catalog), and then expand its entry 

       

are now hidden by default in the Table Of Contents. Some ArcIMS image services have a large number of sublayers 
so this enhancement reduces the size of the entry that appears in the Table Of Contents when you initially expand the 
entry for a new ArcIMS image service. So for example, when you add an ArcIMS image service into a map (in this 
ase the Calif_Watershed service from the Geography Network connection in Arcc

in the Table Of Contents, the legends for the sublayers are hidden by default: 
 

 
 
Tip: Don't forget you can hold down CTRL and click on any expand/contract box next to a sublayer to show or hide all 
of the legends in any map service or group layer in one click.  
 
  
Support for new high performance cached map services from ArcGIS Server  
 

At 9.2 all ArcGIS client programs (i.e. ArcMap, ArcGlobe, ArcReader, ArcGIS Engine applications, etc) can now 
take advantage of the new high performance cached map services that can be served using ArcGIS Server at 9.2.  
 
These cached map services dramatically improve the rendering speed of complex maps. A cached map service serves 
a collection of map tiles that have been created in advance and organized by scale levels in a directory hierarchy. 
These services are designed to provide very fast drawing, especially when they are displayed at the scales at which 
they have been cached. Connecting to a cached map service is the same as connecting to other ArcGIS Server map 
services, whether the connection is via a LAN or over the internet. You connect to the server using the Add ArcGIS 
Server command in the GIS Servers folder in the Catalog tree, and then browse to the map service you want to add. 
  
When you have added an ArcGIS map service to ArcMap, you can tell whether or not it is a cached service by looking 
at the new 'Map Service Type' field in the Data Source details list in the Layer Properties dialog Source tab. This 
indicates whether the map service is cached or not. When a service is cached the details window will also indicate the 
scales in which the service has been cached and the resolution of each pixel at each scale.  
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One functional restriction when using cached map services is that you can't turn the sublayers contained in th
on or off. If you attempt to do this, you'll get a message. You can turn the layer representing the service on and off, but 
not its sublayers. You also can't turn the labels of the sublayers in a cached map service on or off. In the Data Source
details listed above, the new 'Restriction' field highlights this restriction to make sure the en

e service 

 
d user of the service in 

rcMap is aware of it. 
 

 
lisher). ArcGIS Desktop is able to 

quest images from cached map services at map scales that are between the scales specified by the cache. In these 
c

A

All the other functionality that can be performed on non cached ArcGIS map services such as Identify and Find can be
performed on cached map services (unless they have been restricted by the pub
re
ases, the client, ArcGIS Desktop, generates a new image by down-sampling map tiles (or rasters) from the next 

largest (represented by the smaller number) cached scale. 
 
For example, the cached map service “cached_service” has three caches: one at 1:32,000,000, another at 
1:16,000,000 and the final one at 1:8,000,000. Here is the service displayed at 1:16,000,000.  
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When zoomed out to 1:25,000,000, the display is down-sampling the map tiles from the next largest cache scale, the 
1:16,000,000 cache. Therefore, the labels and symbology appear smaller: 

 

 
 

As you zoom past the last cache, in this case 1:8,000,000, labels and symbology will appear larger: 
 

 
 
When an ArcGIS application connects to a cached map service a new directory, esrimapcache, is created under the 
current user’s temp directory (ex: C:\Documents and Settings\<username>\Local Settings\Temp\esrimapcache) and a 
local map tile cache is created. This local cache greatly improves performance.  
 
A button has been added into the Layer Properties dialog Advanced tab that enables you to clear this local cache. For 

may be working with a map service that is occasionally updated on the server by its publisher. By example you 
clearing your local cache you can ensure that ArcMap will get the most up-to-date version of the service the next time 
your map is drawn. You might plan on doing this prior to printing out the map. You may also decide to clear the local 
cache because you need to maximize the amount of free disk space you have: 
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The Clear Cache button has no effect if you are working with a map service that is not cached. You can look in the 
Source tab of the Layer Properties dialog for information about whether the service you are working with is cached or 
not. The Clear Cache button is also present when you access a map service in ArcGlobe. 
 

You can now tell what capabilities a map service you are connecting to via the Internet provides by looking at the 
new 'Operations allowed' field in the Data Source details list in the Layer Properties dialog Source tab. See the graphic 
at the start of this section. The three possible map service capabilities are: 
 
- Map (ability to display the service) 
- Query (ability to use the Identify tool t s) 
- Dat dialog Fea d on the
 

hen you connect to a map service via a Local Area Network (LAN) connection, all operations are always allowed, so 

o obtain the attributes of feature
tures tab to find features basea (ability to use the Find ir attributes) 

W
the Operations Allowed field isn't present.  
 

When you add an ArcGIS Server map service into ArcMap or ArcGlobe, the legends for all of the sublayers i
ervice are now hidden by default in the Table Of Contents, the sa

n the 
me way that they are for ArcIMS image services and 

MS services. 
s
W
 

 All ArcGIS Server map services accessed through ArcCatalog or the Catalog Browser (Add Data dialog) are now 

o make 

OGC (Open Geospatial Consortium, Inc) WMS (Web Map Service) is an OpenGIS standard specification for 
interactive mapping based on requesting map images from a server over the Internet. OGC WMS client support, which 
has been available in ArcGIS Desktop since 9.0 SP2, allows you to access these services over the Internet and add 
them to your maps and globes as layers. ArcGIS 9.2 supports OGC WMS 1.2.  
 

listed as being 'map services' in the Type column in the ArcCatalog Contents view and in all properties dialogs. 
Previously they were called 'mapservers'. The same change has been made to the names of ArcGIS services t
the distinction between the servers you connect to and the services that are available on these servers. 
 
 
Improved OGC WMS support 
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ArcMap now supports transparency on all WMS image formats. Previously, transparency was only supported for 
GIF and PNG formats. 9.2 adds BMP and JPG format. Transparency is enabled by default when you work with WMS 
services, and by default the background color is used as the transparent color. 
 

One of the biggest limitations of using OGC WMS in ArcGIS Desktop has been the inability to view WMS layers in a 
coordinate system not supported by the WMS server. At 9.2 we’ve changed how ArcMap handles WMS layers. WMS 
layers are now handled internally as a raster layer. This allows ArcMap to draw WMS layers irregardless of what 
coordinate systems are supported by the WMS server. WMS services are now automatically projected on the fly just 
like any other data source. Identify is fully functional in all coordinate systems provided that the WMS server supports 
GetFeatureInfo in the first place. You are still informed what coordinate systems are supported by the server. This 
information is available in the Source Tab of the WMS Sub Layer Properties dialog in ArcMap and in the WMS Service 
Properties dialog in ArcCatalog.  
 

ArcCatalog now supports connecting to WMS services being served from web servers on which authentication has 
been enabled. The Add WMS Server dialog now has inputs for user name and password that you can fill in when you 
connect to such a WMS server: 
 

 
 

eb servers protected with certificate-based security are also supported (in which case a dialog will popup with W
information about the certificate). 

 

 
 
Adding data into applications from GIS portals 

The 'Add Data From Internet' pullright in the File menu in ArcMap has been removed at 9.2. The commands it 
contained are still available via the Tools > Customize dialog. 
 
The primary function of this pullright was to add live services from the Geography Network into ArcMap. It was also 
used to add links to websites based on ArcIMS Metadata Explorer, from which live data can be added into ArcMap. 
Portal websites URLs launched from this pullright had the parameter 'mode=arcmap' appended to notify the website 
that 'Add to ArcMap' buttons were to be added next to any live services displayed in search results. 
 
The pullright has been removed at 9.2 because it was not clear enough to many users which websites could be added 
into this pullright, especially as a number of important GIS portals, such as the US federal government's Geodata.gov 
system, don't utilize the 'mode=arcmap' parameter. The pullright also did not provide the ability to add services based 
on OGC WMS into ArcMap.  
 
The recommended way to add live services from any GIS portal into ArcMap, ArcGlobe or ArcGIS Explorer is to find 
the connection information in the detailed information or metadata provided in the portal for the service and use that to 
establish a connection to the server.  
 
For example, here's the connection information for an ArcIMS service available in the Geography Network. To make a 
connection, you copy and paste the map server URL into the Add ArcIMS Server dialog in ArcCatalog or into the Add 
Content panel in ArcGIS Explorer, and then access the service called OCTOP. 
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The example below, from the Geodata.gov portal, shows the connection information for a service in OGC WMS format. 
You can copy and paste this string into the Add WMS Server dialog in ArcCatalog or the Add Content panel in ArcGIS 
Explorer to connect to this service. 
 

 
 
Note to ArcIMS Metadata Explorer users: you can still launch your Metadata Explorer-based website in 'ArcMap aware' 
mode by simply appending the parameter ?mode=arcmap to the end of its URL. This will ensure that 'Add To ArcMap' 
buttons appear next to any live ArcIMS services shown in the website. However, due to a technical issue in ArcMap at 
9.2 resulting from a third party software compiler, the 'Add To ArcMap' button does not work correctly. We cannot 
guarantee that a fix for this will be available in a 9.2 service pack. (This issue was another motivation for removing the 
Add Data From Internet pullright at 9.2). 
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Cartographic representations 

ArcGIS 9.2 introduces a new way to symbolize features using representations. With representations you can store 
symbology with your features in the geodatabase, and edit the appearance of these symbols on your maps without 
having to modify the geometry of the actual features being represented. Multiple representations can be stored for a 
feature class, enabling you draw the same features with completely different symbology, including edits you have 
made to individual symbols, on different maps.  
 
A new layer symbology option is available to symbolize layers with a representation, a new interface is provided for 
configuring individual symbols within a representation, and a new set of editing tools are included to modify the 
appearance of features symbolized with representations.  
 
Representations in ArcMap let you control the appearance of features in a way that previously required exporting your 
map to a dedicated graphics program. For example, you can symbolize line features with representations to have more 
control over dashed-line symbology: 
 

   
 

Lines with a regular dash symbol: 
Ambiguous joins at line ends 

 
Lines symbolized by a representation: 

Proper joins at line ends managed 
automatically 

 

 
You can interactively manage the 
appearance of individual dashes 

 
Representations can be created and edited with an ArcEditor or ArcInfo license. Representations can be displayed 
using any license level. Only geodatabase feature classes can store representations. Representations are not 
supported for other feature data, such as shapefiles. 
 
 
New Representations layer symbology option 
 
ArcGIS 9.2 includes a new layer symbology option for symbolizing a feature layer with stored representation 
information. A new Representation category appears in the Symbology tab in the Layer Properties dialog. The 
Representation category is only listed for layers whose data sources contain one or more representations. 
Representation information is stored with the layer's data source in a feature class representation. A single feature 
class can have multiple representations to support a variety of maps from a single data source: 
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Convert existing symbology to representations 
 
To create representations for an existing layer, right click the layer in the ArcMap Table of Contents and choose the
new Convert Symbology to Representations command. This creates a new feature class representa

 
tion for the layer's 

ata source and translates the current symbology into representation symbology that you can edit with the new tools: 
 
d

 
 
The Convert Symbology to Representations command is disabled if you are not using ArcEditor or ArcInfo or if the 
layer's data source is not a point, line or polygon feature class in a geodatabase. 
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New Representations tab on the Feature Class Properties dialog in ArcCatalog 

R
tations. 

sentations can be associated with a 
ingle feature class, so that the same data can be portrayed uniquely on different map products. You can also use this 

tab to create new representations, delete existing representations, and import representation rules from other 
representations: 
 

 
epresentation symbology information is stored in additional columns added to your geodatabase feature class. A new 

Representation tab is available in ArcCatalog on the Feature Class Properties dialog for working with represen
Here you can see a list of all of the feature class's representations. Multiple repre
s

 
 
 
Representation rules 
 

You display representations using representation rules rather than standard ArcGIS symbols. A new dialog is 
rovided to interact with the individual properties that make up a representation rule. Existing ArcGIS symbols can be 
onverted to representation rules through the symbology to representation conversion process. 

Re
he basic building block of the representation rule and can be one 

f three types: marker, line, or fill. A representation rule must have at least one symbol layer, but may have many to 

Geometric effects are optional components of representation rules. Geometric effects alter the geometry of features 
dynamically at draw time to achieve the desired appearance, without affecting the underlying shape of the feature 
itself. This means that a complex view of the data can be achieved without affecting existing spatial relationships. For 
example, you can use the Dashes geometric effect to draw one line layer with a dash pattern, and use the Offset 
Curve geometric effect to draw the entire line representation away from the feature geometry. Geometric effects can 
apply to just one symbol layer, or globally to all symbol layers in a representation rule. Geometric effects work in 
sequence, so the dynamic result of one geometric effect becomes the input for the next: 

p
c
 

presentation rules are made up of symbol layers and geometric effects that work in sequence to define how a 
feature will appear on your map. Symbol layers are t
o
support complex depictions. 
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Representation properties can be mapped to fields in the feature class's attribute table: 
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Using overrides and editing representations 
 

A representation rule defines how a set of features in a feature class will be drawn. Representations allow an 
exception to be made to the representation rule in a manageable way to accommodate features whose circumstances 
warrant special treatment. For example, a single building or set of buildings could be changed to be symbolized in red 

ith a white outline. These changes are stored and maintained in the geodatabase as overrides.  
 
Geometry can also be overridden using representations. Geometry overrides allow you to modify feature geometry on 
your maps without affecting the geometry source features, which you may be using for other purposes (e.g. analysis, 
other mapping). Overrides can be further modified, or easily removed at a later time to re-apply the representation rule 
to the feature.  

 
Representations allow you to change the spatial location or shape of features or properties of representation rules. For 
example, you can change the location of a line symbol to avoid an overlap with a nearby symbol, and you can edit one 
of the individual dashes in a dashed line and move it to improve the line's appearance. A set of representation editing 
tools is provided specifically for making these types of modifications. Representation editing tools are found on the 
Representations toolbar: 
 

w

 
 
Representation edits are stored in the extra columns added to a feature class to store representation information, and 
these edits are available for any map on which the features are shown. To use the representation editing tools: add a 
feature class that has representations to ArcMap, on the layer properties dialog's Symbology tab choose to symbolize 
with one of the representations, start Editing (using the Editing toolbar), show the Representations toolbar, select a 
tool, and perform your edits. 

 
al 

tion. For example, a line feature may be represented by a series of 
arkers spaced equally along the length of the feature. You can convert this line to a free representation and then 
anually delete or reposition individual markers to resolve conflicts with other map features or text: 

 
In extreme cases where a feature requires a unique or complex rendering, its representation can be converted into a
free representation, which gives you full artistic control of its appearance, even to the point of modifying the individu
graphic elements that make up the representa
m
m
 

   
 

Original representation 
 

Free representation 
 

Free representation with repositioned 
markers 
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Representation geoprocessing tools  
 

New geoprocessing tools have been added for working with representations. 
existing Cartography toolbox in three new toolsets: Graphic Quality, Representa

These tools can found be in the 
tion Management, and Symbolization 

Refinement. All the tools in the Cartography Toolbox require an ArcInfo license: 
 

 
 
Here's an example of one of these representation geoprocessing tools, the Detect Graphic Conflict 
llows you to detect where the representation symbology of one or more feature classes overlaps o

tool. This tool 
n a given map, 

e

h  it. 

a
ven if the underlying spatial geometry of the features does not overlap. Previously, identifying graphic conflicts on a 

symbolized map involved a time-consuming manual examination of features either on screen or on a plotted map.  
 
T e graphic on the left is before using the Detect Graphic Conflict tool. The graphic on the right is after using
 

 
 
 
 

In the Desktop Help, see: Mapping and Visualization > Using cartographic representations > Getting started with 
presentations > An overview of representations 

 
To open the Representation Tutorial PDF workbook from the Desktop Help, go to the 'Getting Started > Tutorials > 
Tutorials' page. 

re
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Exporting & printing maps 

Support for layers when exporting to PDF 

When you export a map to a PDF, the resulting PDF now contains native PDF layer information reflecting the layers 
in the map. Anyone using Adobe Acrobat Reader version 6 or higher to view the exported PDF can turn the layers in 
the PDF on or off via the Layers control in Acrobat Reader. This makes exporting maps to PDF format even more 
useful as a way to distribute maps because now people viewing your PDF can choose what they want to see in the 
map for on-screen use or for printing.  
 
Each layer in your map that is turned on at the time you export it becomes a layer in the resulting PDF. Each 
annotation group in the map is also shown as layer so that end users can turn the graphics drawn on top of the map on 
and off. In the example below, the three red labeled rectangles are in an annotation group called 'Test sites': 
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Other export enhancements 
 

A new Picture Symbol option has been added into the File > Export Map dialog. This lets you choose how the 
ymbols in layers will be handled. You can specify that picture symbols be handled by either rasterizing them or tracing 

them as vector symbols: 
 

s

 
 
The main benefit of this is that it preserves the vector data below the picture symbols. Before this change, any map 
that used a picture symbol symbology that originated as a .bmp file had to be rasterized on output. Vectorizing the 
ymbol results in much higher output qus ality. 

 

Printing enhancements 

 
 

New ArcPress 'Universal' drivers for HP and EPSON. Created in conjunction with the printer vendors, these drivers 
provide native support for HP DesignJet and EPSON wide-format printers with the ArcPress printer engine. 
 

"Print to File" is now enabled when using the "Scale Map to Fit" and "Tile Map" printing options. 
 

ArcMap no longer polls the printer multiple times when you open a document. 
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Visualization & analysis 

Animation 

Until now, the ability to create animations in ArcGIS has been limited to the 3D Analyst extension (ArcGlobe and 
ArcScene). ArcGIS 9.2 introduces the ability to create animations in ArcMap. Using the new Animation toolbar in 
ArcMap, you can create visualizations that might, for instance, animate data through time, make layers transparent or 
turn them off to reveal layers underneath, or alter the view by zooming in and out or panning the display.  
 
Animations can be run in the ArcMap window or they can be exported to standalone video files and played separately: 
 

 
 
 

nimating through time 
 
A

We’ve added the capability to animate through time in all three applications (ArcMap, ArcScene and ArcGlobe) 
thr

ported.  

 

he

ough the addition of a Time Layer track. Any data with a date or value field in the attribute table can be animated 
through time. Feature classes, raster catalogs, netCDF data, and charts are sup
 

Other improvements 
 
T se additional enhancements apply to all three applications (ArcMap, ArcScene and ArcGlobe): 
 

Keyframes can be deleted on the Time View tab of the Animation Manager, and time can be added to the beginning 
r b. 

 
o  the end of an animation in the Animation Manager's Time View ta

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  135 



A keyframe can be added adjacent to an existing one on the Keyframes tab of the Animation Manager.  
 

An animation can be played by setting up the number of frames to display.  
 

Animations can be exported with a set duration.  
 

The Create Group Animation dialog has been improved with new layer visibility options. 
 

Animations are now supported in the ArcGIS Engine Developer Kit. 
 

(ArcMap only). Graphs in ArcMap can be animated. For example, you can create an animation that shows the map 
content and/or extent changing while one or more graphs illustrating the same changes update dynamically. 
 

(ArcGlobe only) You can now publish your animations over the web with ArcGIS Server. When you publish a globe 
 service with ArcGIS Server, the animation tracks in the document are also available in the document as a globe

ervice (s See the '3D Analyst' section of this document for more information). 

raphs 

 
 
 

G

A new graphing engine has been added to ArcMap providing more options and better support for interactive analysis 
and visualization using graphs. The Tools > Graphs > Create command launches a new wizard: 
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Graph types 
 

The graph types below are supported in the new graphing engine: 
 

 
 

Each graph type can be displayed with a 3D effect if desired.  
 

The Histogram is a type of bar graph that shows the frequency distribution of a dataset. The range of the values
split into equal-sized classes, called 'bins', and for each bin, the frequency (number of values it contains) determine
the bar height. 

 is 
s 

 
Box plot (or Box-and-Whisker plot) graphs are an effective way of examining the statistical distribution of values 

between different datasets. (See below left). 
 

It is easier to overlay graphs together in the new graphing engine. Any number of overlays can be defined and each 
ne has the full set of graph properties. In the example on the right below, a bar chart and an area chart have been 
verlain, both drawn with a 3D effect: 

o
o
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Appearance & Color 
 

Graphs can now use the same colors as the symbology used for a layer. The screenshot below shows a chart using 
e same colors as the features in the map in represents: th

 

 
 

More control over the printing of graphs, including a Print Preview dialog. 
 

Set the transparency of individual series for Area and Histogram graphs. 
 

Many types of fills and gradients”are available for graph components. 
 
 
Data handling and representation 
 

You can plot data from several different datasets on the same graph. Each plot is called a “series”. 
 

The order of series and functions can be changed. 
 

Select a different field as the independent variable for certain graphs. For vertical bar, line, and area graphs, the 
independent variable is the X field. For the horizontal versions of these, it is the Y field.  
 

Sort (rank) the fields for bar, line, area, and pie graphs. 
 

The independent axis can be labeled with other fields. 
 

Axes can be independently logarithmic, allowing semi-log and log-log plots. 
 

Better handling of temporal data and time axes. You can use time as a graph axis and have its display dynamically 
updated between months, days, hours, minutes, and seconds as you zoom in. 
 

Mathematical functions (previously called 'trends') for any available series can be plotted. The following new 
mathematical functions are available: Count, Cumulative, Exponential Moving Average, Exponential Trend, Median, 
Mode, Moving Average, Root Mean Square, Standard Deviation, Trend, and Variance. 
 

No restriction on the number of overlay lines. Overlay line graphs can be created from any field of any available 
dataset. 
 

Graphs can be included in animations created in ArcMap. 
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Dynamic feature selection 
 

You can choose how a graph will represent the selected set of features using these options in the New Create 
Graph wizard: 
 

 
 

Better feature selection linking between maps, tables and 
raph is immediately rep sented in each of these views (like it did 

graphs. Selecting features on the map, in a table or in a 
re in ArcView 3.x). In the example below, features 

h
g

ave been selected by dragging a box in the graph, and this feature selection is immediately reflected on the map and 
in the table: 
 

 
 
Graph Manager 
 

The Graph Manager has been improved. It is now modeless and resizable, and displays the name of the source 
yers and cally by name and by graph type: la tables for each of your graphs. Graphs can be sorted alphabeti

 

 
 

Graphs can be exported to some additional formats. 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  139 



Compatibility of existing graphs 
 

Graphs created with the new graphing engine and your existing graphs can co-exist in the same map document. 
our existing graphs can still be opened, modified, and so on. The existing Y  Create Graph wizard is still available via 
e Tools

graphin tation are: Bubble, Polar, and High-Low-Close. If needed, these types can still be generated by 
using th
 

th  > Customize dialog Commands tab in the DataGraph category. Graph types not available in the new 
g implemen
e old Create Graph wizard. 

 
In the Desktop Help, see: Mapping and Visualization > Working with graphs and reports > Looking at data with 

graphs > About looking at data with graphs 
 
 
 

Time 

There have been enhancements to man
ultidimensional data, and to make it easie

y areas in ArcGIS 9.2 to improve its capabilities with temporal and 
r to integrate the variable of time into the GIS. Together, these 

or new types of data (such as the multidimensional netCDF data and feature 
istory stored in the geodatabase), improvements in display and visualization with improved animation and graphing, 
nd improved iterative analysis capabilities with the addition of looping and batch processing to the geoprocessing 

framework and ModelBuilder.  
 
 
NetCDF data support 
 

m
enhancements let you integrate time more easily into your GIS visualization and analysis. This includes analyzing 
historical change, understanding recurring patterns at different time scales (such as annual, seasonal, and diurnal 
changes), and predicting likely trends and iterations in the future.  
 

hese enhancements include support fT
h
a

ArcGIS 9.2 adds support for netCDF data. This is a binary data format commonly used for storing temporal and 
multidimensional data, especially in atmospheric, climate, and oceanographic applications. It is used for both 
observational data as well as storing the results of numerical models, such as large scale weather forecasting or 
climate change models. It can be displayed, graphed, animated, and used in analysis, like any other data source. You 
can also export GIS data to netCDF. 
 
A new Multidimension geoprocessing toolset is provided at 9.2 for creating and working with data in the netCDF 
format. The tools for reading netCDF data allow you to create raster layers, point feature layers, and table views of 
netCDF data by selecting a variable of interest and the desired dimension variables, such as which dimension should 
be mapped to the x axis, y axis, or time. ArcGIS reads and writes the CF convention of netCDF, including a definition 
of how to store map projection information, which is critical to its effective use in a GIS. netCDF layers and netCDF 
table views can be used just like other layers and table views. They use the same display renderers, can be included 
in graphs and animations, and used as input to geoprocessing tools. You can also export native raster, raster catalog, 
feature, and table data to netCDF format.  
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If a netCDF file contains multiple variables, you can
dimensions for each variable. 
 
Variables in netCDF files can be used in various wa

 create layers for each variable and for various combinations of 

ys. For example, from the wind direction variable (wind by x, y, and 
time) you could create the following layers and tables in ArcMap: 
 
- A raster of wind direction for a given time. 

 given time. 
 the entire time period (overlapping points). 
e. 

- A table of wind direction, time, x, and y. 
 a given x and y pair. 

rection and temperature data 
r DFD). Two layers have been defined, 
ne to show wind speed and direction, the other to show the temperature: 

 

- A point feature class of wind direction for a
- A point feature class of wind direction over
- A table of wind direction, x, y for a given tim

- A table of wind direction, time for
 
For example, the screenshot below shows a netCDF dataset with wind speed, wind di

om the US National Weather Service's National Digital Forecast Database (Nf
o

 
 

In the Desktop Help, see ' Data support in ArcGIS > netCDF: multidimensional, time series data > An overview of 
netCDF data > What is netCDF data ' in the Desktop Help. 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  141 



Other enhancements related to time 
 

Graphs: Graphing has been greatly improved at 9.2. It is now possible to use time as a graph axis and have 
display dynamically updated between months, days, hours, minutes, and seconds as you zoom in. Graphs can now 
also be animated and synchronized with the map. 

its 

See the separate section above.  
 

Animation: At 9.2 the ability to create animations has been added into ArcMap. Previously, animation was only 
available in ArcGlobe and ArcScene in the 3D Analyst extension. The Animation Manager has been enhanced to 

port temporal animation, so that you can synchronize the display of multiple layers on the same time interval or 
time step. Feature classes, raster catalogs, and netCDF data can all participate in a temporal animation. In addition to 
animating maps, scenes, and globes, it is also possible to now animate graphs and synchronize their update with the 
time display of the map. 

sup

See the separate section above.  
 

Looping and iteration in models: The geoprocessing framework and ModelBuilder now have the ability to perform 
g and iteration. This enables the output of a process be the input to a previous process in the same model. Batch 

cessing is now also supported. These capabilities are critical to temporal analysis where you may have 50 time 
s that all need the same processes applied to them. 

loopin
pro
step See the 'Geoprocessing' chapter of this document. 
 

Historical archiving of data: The new geodatabase archiving capability introduced at ArcGIS 9.2 makes it easier 
to maintain, query and analyze the historical record of changes to features over time without working with versions. 
You can connect to historical instances of the database and view how it looked at a specific time or see how it has 
evolved over time. See 'Geodatabases and ArcSDE' chapter of this document 
 

Tracking Analyst extension: The ArcGIS Tracking Analyst extension provides tools for playback and analysis of 
time series data. Tracking Analyst helps visualize complex time series and spatial patterns and interactions and 
integrating this data into the GIS. Tracking Analyst deals with the location of moving objects, such as hurricanes, 
vehicles, aircraft, etc whereas netCDF data handles continuous phenomena such as temperature that vary constantly 
over time and space. At 9.2 Tracking Analyst offers improved support for very large historical datasets, support for 
date and time stored in separate fields and more. See the Tracking Analyst section of this document in the 
'Extensions' chapter. 
 
 
 

Other 

A number of additional enhancements have been made that improve the analysis capabilities of ArcGIS: 
 
 
Random data generation 
 

Random data is used in sensitivity analysis, simulation and stochastic modeling. The following new geoprocessing 
tools are provided for random data generation: 
 

Data Management Tools > Raster > Create Random Raster 
Creates random rasters based on a variety of distr

 
ibutions, from Normal to Binomial. The tool also 

respects the new Random Number Generator environment setting that gives you the flexibility to set one of 
three random number generators (Mersenne Twister, ACM599, and Standard C). This tool is ideal for use with 
looping models (new in 9.2) that analyze error, sensitivity or seek to model processes. 
 

 Data Management Tools > Feature Class > Create Random Points 
Places a user specified number of random points within a specified extent. A variety of options gives you the 
power to place points within features of another feature class and base the number of random points placed 
on a field or a number. 
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Spatial Statistics 
 

In the Spatial Statistics geoprocessing toolbox, the following tool has been added: 
 
 Spatial Statistics Tools > Analyzing Patterns > Multi-Distance Spatial Cluster Analysis (Ripley's K 

function) 
This tool analyzes features at multiple distances and scales to see where spatial processes causing clustering 
are most pronounced. 

 
The following spatial statistics tools have also been enhanced: Mean center, Central feature, Hot Spot Analysis, 

Cluster Outlier, Spatial Autocorrelation, and High/Low Clustering tools 
 
 
Spatial Analyst extension 
 

At 9.2, the ArcGIS Spatial Analyst extension adds new geoprocessing tools for solar radiation, three new math 
tools, and more. See the Spatial Analyst section in the 'Extensions' chapter of this document. 
 
 

eostatistical Analyst extension G
 

The ArcGIS Geostatistical Analyst extension provides a variety of tools for spatial data exploration, identification of 
ata anomalies, optimum prediction, evaluation of prediction uncertainty, and surface creation. At 9.2 this extension 
dds smooth interpolation, moving window kriging and more. 

d
a See the Geostatistical Analyst section in the 
'Extensions' chapter of this document. 
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Geoprocessing 

Working with tools 

New batch mode for tools 
 

When you right-click a tool in ArcToolbox you'll see a new Batch command:  
 

  
 
This command opens the tool for batch processing. The tool's parameters are exposed as cells in a grid and you can 
fill in the cells with a variety of methods, such as typing, pasting, browsing, by opening the tool dialog, or filling with 
values from cells above or below using the context menu: 
 

 
 

In the Desktop Help, see: Geoprocessing > Using geoprocessing tools > Batch processing > An overview of batch 
processing 
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New Results tab in ArcToolbox w
 

indow 

The new ArcToolbox window Results tab makes it easy to review and re-use the geoprocessing steps you've 
performed in your current and previous sessions. It's a record of everything you've done. You can see each operation 
you've performed, including all inputs, outputs and messages:  
 

 
 

ou can right-click any operation and open the tool dialog so you can re-execute it, remove it from your results, or 
atically deletes all of its output data: 

 

Y
delete it, which also autom
 

 
 
You can m the Results tab, such as adding an input or output into the ArcMap Table Of 
Content
 
The his nged at 9.2, but the Results tab is a richer and more convenient 
environ r geoprocessing history. 

 also drag and drop objects fro
s or ModelBuilder.  

tory toolbox in ArcCatalog remains uncha
ment for working with you
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New to
 

ol layers 

9.2 introduces the ability to drag a tool from ArcToolbox into the ArcMap Table Of Contents to create a tool layer. A 
tool laye p layer that provides a convenient new way to use a tool. Outputs from the tool are 
listed as ntents, and you can right-click on the tool layer to open the tool dialog. The 
parame cute the tool and the symbology of the outputs are stored as properties of the layer, making it 
easy to he new results. 
 

r is a special type of grou
 sublayers in the Table Of Co

ters used to exe
re-execute the tool and display t

               
 
 

In th ng > Using geoprocessing tools > Tool Layers > An overview of tool layers 
 

apabilities 
 

e Desktop Help, see: Geoprocessi

 
Large overlay c

9.2 h  imposed by computer memory when doing analysis and feature manipulation. The 
nion, Intersect, Identity, Dissolve, Feature to Polygon tools, and the new Spatial Join tool will work with millions of 

emory you have. Use the new Spatial Join tool instead of the 
spatial j ccessed by right-clicking a layer in ArcMap if you are performing spatial join 
between ts. This new tool offers dramatically better performance and reliability compared 
with the ng tools makes it easy to automate repetitive or complex workflows involving 
spatial j ripts. 
 
 
More p  

as removed limitations
U
features and are not limited to the amount of computer m

oin option in the Join dialog a
 very large or complex datase

 dialog, and as a geoprocessi
oin as part of models and sc

latform flexibility
 

In scripting, native Python support for the Geoprocessor object has been exposed. Native Python is not dependant 
d ger need to add the win32com extension to run your 

ython scripts. This gives you flexibility of platform choice, and also enables support for geoprocessing in ArcGIS 

 
 managed class called the geoprocessor. In 

ost cases, .NET developers would interact with this assembly rather than the Geoprocessing assembly which 

t 9.1 (supported at 9.2 as well): 
import win32com.client 
gp = win32com.client.Dispatch(“esrigeoprocessing.gpdispatch.1”) 

 
At 9.2: 

import arcgisscripting 
gp = arcgisscripting.create() 
 

 

on Win
P

ows or the Python Win32com extension, so you no lon

Server and in the ArcGIS Engine Developer Kit. 

The Ge
m

oprocessor assembly is a .NET specific assembly containing a

exposes geoprocessing objects via COM.  
 
A

Executing tools using ArcObjects has been simplified with the introduction of the IGeoprocessor interface. The 
existing technical papers on writing new tools at the ArcObjects level have been expanded, and more detailed samples 
have been provided. 
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Calculate Field tool now supports script expressions 
 

You can now use both VBScript and Python to write script expressions in the Calculate Field tool. A new dropdown 
control in the tool lets you choose between these, and if you choose Python you can specify additional Python code in 
an optional code block: 
 

 
 
The Field Calculator dialog launched from this tool has also been enhanced so it is now the same as the one that is 
launched from the table window, including full support for VB Script and advanced expressions written using the pre-
logic script block in the dialog. These enhancements enable you to use Calculate Field to calculate areas, length, 
perimeters, xy locations and xy centroids. You can use either the VBScript or Python for calculating these values.   
 
 
Other improvement for working with tools 
 

The performance of cursors in scripting has been greatly improved. New options added for limiting the fields 
returned and sorting the returned values. 
 

Hundreds of issues have been corrected as reported by you in our technical support and user forums. 
 

Performance has been improved for many tools, including Add XY, Frequency, and Summary Statistics. 
 

Greater control over field mappings has been introduced for those tools that update fields, such as the Append tool 
and Table To Table tool. 
 

The Make Permanent command in the context menu for a feature layer in the ArcMap Table Of Contents has been 
moved into the Data pullright in that context menu to reflect that you don't normally need to use this command. 
 

Numerous new scripting methods for file management have been added. 
 

INFO is now supported as a valid output table type. 
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New tools 

81 new core tools have been added. Core tools are those delivered with ArcView, ArcEditor, and ArcInfo product 
censes. The new core tools are listed below. For details about these about these tools, consult the Help for each tool. 

nalysis tools 
Create Thiessen Polygons 
Spatial Join (use this tool instead of the spatial join option in the Join dialog to get maximum performance) 

 
Cartography tools 

Add Representation 
Align Marker To Stroke Or Fill 
Calculate Geodesic Angle 
Calculate Line Caps 
Calculate Polygon Main Angle 
Calculate Representation Rule 
Create Overpass 
Create Underpass 
Detect Graphic Conflict 
Drop Representation 
Remove Override 
Select Feature By Override 
Set Layer Representation 
Set Representation Control Point By Angle 
Update Override 

 
Conversion tools 

ESRI Metadata Translator 
ArcIMS Metadata Publisher 
Point To Raster 
Polygon To Raster 
Polyline To Raster 
USGS MP Metadata Translator 
XSLT Transformation 

 
Data Management tools 

Add Colormap 
Add Global IDs 
Adjust 3D Z 
Aggregate Polygons 
Build Raster Attribute Table 

erline 
Compare Replica Schema 
Compress File Geodatabase Data 
Create Custom Geographic Transformation 
Create File Geodatabase 
Create Fishnet 
Create Ortho Corrected Raster Dataset 
Create Pan-sharpened Raster Dataset 
Create Random Points 
Create Random Raster 
Create Replica 
Create Replica Foot Prints 
Delete Colormap 

li
This list does not include new tools in ArcGIS extensions. 
 
A

Calculate End Date 
Calculate Value 
Collapse Dual Lines To Cent
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Delete Raster Attribute Table 
Export Acknowledgement Message 
Export Data Change Message 
Export Replica Schema 
Feature Compare 
File Compare 
Generate Globe Server Cache 
Generate Map Server Cache 
Generate Map Server Cache Tiling Scheme 
Get Raster Properties 
Import Message 
Import Replica Schema 
Merge Branch 
Raster Compare 
Re-Export Unacknowledged Messages 
Simplify Building 
Simplify Polygon 
Synchronize Changes 
Table Compare 
Tin Compare 
Transpose Time Fields 
Uncompress File Geodatabase Data 
Upgrade Spatial Reference 
Workspace To Raster Catalog 
Workspace To Raster Dataset 

 
Geocoding tools 

Rebuild Address Locator 
Rematch Addresses 

 
Multidimension tools (new toolbox for NetCDF data) 

Feature To NetCDF 
Make NetCDF Feature Layer 
Make NetCDF Raster Layer 
Make NetCDF Table View 
Raster To NetCDF 
Select By Dimension 
Table To NetCDF 

 
Samples 

CAD to Feature Class with Attribute of Nearest Point 
 
Spatial Statistics tools 

Calculate Distance Band from Neighbor Count 
Multi-Distance Spatial Cluster Analysis (Ripley's K Function) 

 
Over 40 new tools have been added to various extension products, such as Spatial Analyst and Network Analyst. 

For details on these tools, consult the What’s New sections for these extensions.  
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Working with models 

Iteration in models 
 

ModelBuilder now supports lists, series, and feedback looping to enable
sing both lists and series: 

 iteration in models. Below is an example of 

 
u

 
 

List and series properties are specified for inputs in the General tab of the new Properties dialog for variables. In 
this example, an input to a buffer has been defined as a list of inputs. 
 

 
 

In the Desktop Help, see: Geoprocessing > Automating your work with models > Model iteration > An overview of 
model iteration 
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Specify layer symbology for model inputs and outputs 
 

In the ModelBuilder, the new Properties dialog for variables contains a Layer Symbology tab if the variable 
represents data. This enables you to specify how inputs and outputs will be symbolized when they are added to maps 
and globes and store these properties in the model. Symbology is defined by importing it from a layer in your current 
do

 this example, the layer symbology for the output of a clip is being defined. The dropdown list in the dialog shows all 
th

cument or a layer file (.lyr file).  
 
In

e polygon layers from the current map document: 
 

 
 
Specifying the layer symbology for inputs lets you control, for example, how an input layer will be drawn in ArcMap if it 
is added to the display. It is also used to specify the appearance of features that are defined interactively as input to a 
model (see the next section below). 
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Define features interactively on-the-fly as input to models.  
 

 In 9.2 you can add interactive feature input into your models so that when the model is run you or the end user o
the model can draw features on-the-fly and have them used as input to the model. For example, you can cre
buffer model that lets you draw a line on the map that the model will then buffer. A new 'feature set' variable type has 
been added that enable you to specify interactive inputs.  
 

f 
ate a 

ou can specify a feature set input in the Data Type tab of the new Properties dialog for variables. This tab also lets 
disk or existing dataset that will be used to provide 

e schema and symbology of the features in this feature set: 

Y
you choose the layer in the current document, layer file (.lyr file) on 
th
 

 
 
Here's what you see when you run this model. Click the drawing tool in the dialog to draw the input features. You can 
also specify the attribute values for these features (a pop up window appears to let you enter values): 
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New in-memory workspace 
 
You can now write feature classes and tables to an in-memory workspace. This can greatly improve the performance 
of models, especially when writing intermediate (scratch) data. Data you write to the in-memory workspace can be 
copied to disk using the Copy Features or Copy Rows tools. In memory workspaces are also how the interactively 
defined features described in the previous section are stored in current map document. 
 

In the Desktop Help, see: Geoprocessing > Automating your work with models > Model concepts and terms > 
Intermediate data and the scratch workspace 
 
 
In-line variable substitution in models and command line 
 

In-line variable substitution allows you to use the value of another variable in any parameter text. The example 
below shows a model using the scratchWorkspace environment variable in an output pathname. To substitute a 
variable, you enclose the variable name in percent signs (%). This allows you much greater flexibility in defining 
parameter values in models and in the command line. 
 

In the Desktop Help, see: Geoprocessing > Automating your work with models > Model concepts and terms > In-
line variable substitution 
 
 
Other 
 

You can customize the appearance of your model by substituting images for tools and variables. In addition, you 
an change many of the symbology properties for individual elements, such as shape, color, and font. 

 
c

In the Desktop Help, see:  
Geoprocessing > Automating your work with models > Using ModelBuilder > Model appearance: Using pictures for 
elements 
Geoprocessing > Automating your work with models > Using ModelBuilder > Model appearance: Display properties 

 
You now get a tooltip if you hover the cursor over a tool in the ModelBuilder toolbar. 
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Geoprocessing with ArcGIS Server 

All geoprocessing tools are available on ArcGIS Server. This means that all geoprocessing functionality is now 
vailable cross-platform. This greatly extends your options in deploying geoprocessing-based applications.  a

 
Toolboxes can be served using ArcGIS Server to create geoprocessing services that enable users to access 

ge
 the Publish To ArcGIS 

erver command. All the tools in the toolbox you publish become geoprocessing services: 
 

oprocessing functionality over the Web or over your LAN. If you are connected to an ArcGIS Server in ArcCatalog 
with administrative privileges, you can right-click any toolbox and publish it to the server using
S

 
 
 

Geoprocessing services can be used in ArcGIS Desktop, the free ArcGIS Explorer client (new at 9.2) and web 
applications. In ArcGIS Desktop your users can add a server-based toolbox directly into ArcToolbox by using the Add 
Toolbox command and browsing to the server the toolbox belongs to. 
 
In ArcGIS Explorer, your users can access geoprocessing services as tasks and work with them in the task panel:  
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service, because that could involve sending a very large volume of data. However, publishers can create a 
geoprocessing service based on a custom script that includes an input variable of type file that allows end users to 
sp  

Asynchronous outputs are always saved on the server. Client applications can either retrieve the features 

ssed across the Web. 

returned is limited by the Maximum Records property set during publishing. 

lbox Results tab to check 
n the status of these processes. Icons in the Results tab show you whether the process is executing 

When you run a geoprocessing service the main local inputs that can be sent to the server are interactively defined 
features. For example, you cannot browse to a local shapefile or feature class and send that across the Web to the 

ecify .zip files as input. When such a service is accessed, the model will access and unzip the file and then use it as
input. 
 
Output from running a geoprocessing service can be of two types: 
 
- 

themselves or access the results as an ArcGIS map service if they have been published to the server. During the 
publishing phase, the publisher sets the maximum number of records that can be returned to the client (Maximum 
Records property). This can prevent extremely large results from being pa

 
- Synchronous outputs are always returned to the client. As with asynchronous outputs, the number of features 

 
When you access and run a geoprocessing service in Desktop, you can use the new ArcToo

, pending o , 

Geoprocessing in the ArcGIS Engine Developer Kit 

etc. 
 
 

9.2 provides full support for geoprocessing functionality in the ArcGIS Engine Developer Kit. Applications you create 
with the ArcGIS Engine Developer Kit can now include any underlying geoprocessing functionality.  
 
The ArcGIS Engine Runtime at 9.2 includes the geoprocessing framework. The geoprocessing tools available to 
custom ArcGIS Engine applications depend upon the license the application is using. ArcGIS Engine applications can 
run ArcView level GP tools and edit shapefiles and personal geodatabases using an ArcGIS Engine Runtime or 
ArcView license. ArcGIS Engine applications can run ArcEditor level geoprocessing tools and edit enterprise 
geodatabases using an ArcGIS Engine Runtime with Geodatabase Update extension or ArcEditor license. In order to 
run an ArcInfo level tool, an ArcInfo license is required.  
 
 

Improved documentation for geoprocessing 

The Geoprocessing section of the ArcGIS Desktop Help has been reorganized and rewritten. The new conceptual 
topics make extensive use of graphics to show you concepts, examples, and procedural steps. 
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Geocoding & routing 

Geocoding 

Improved geocoding performance 

y depending on the type of addresses and how they are 

 
The speed for creating address locators and geocoding addresses is greatly improved. In general geocoding is now 
approximately four times faster. You can geocode about 1 million addresses per hour on a PC with a Pentium 4 or 
aster processor and 1 GB memory. The performance may varf

stored in the databases. 
 
 
Working with address locators  
 

Once created, address locators are now independent of their reference data. You can move or copy Address 
Locators to new workspaces without copying or being concerned about the location of the reference data. Address 
locators may require more disk space depending on the size of the reference data.  
 

When you create an address locator, the reference data will be standardized on the fly and the locator will store the 
tandardized attributes of the reference data. Moreover, the geocoding rule base will also be stored in the locator. This 

 build an address locator based on a geocoding rule base that has been modified. You can 
s locator to others without packing the geocoding rules.  

T

s
option is helpful if you
distribute this addres
 

hese two functions can be disabled in the new Advanced Locator Properties dialog. This dialog is accessed from a 
new Advanced button you'll see on the Address Locator Properties dialog: 
 

 
 

You can now create address locators directly in a file folder workspace or inside a geodatabase. The Address 
Locators folder in the ArcCatalog tree is no longer used and has been removed. To create a new address locator, 
right-click on a folder or a geodatabase, and select the New > Address Locator command. You can also copy, delete, 
or rename address locators in ArcCatalog.  
 

Address locators now support metadata. In ArcCatalog, select an address locator and click the Metadata tab to view 
the metadata. 
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Existing address locators created can still be used for geocoding but many additional features, such as embedded 
d rule bases, are no longer supported on pre 9.2 locators, so we recommend that you migrate your 

sktop Help describes how to migrate your existing address locators to 9.2. 
S h 

New address locator styles 
 

standardization an
ll existing locators to 9.2. A topic in the Dea
ee: Geocoding and address management > Building an address locator > Migrating address locators created wit

ArcGIS prior to version 9.2. 
 
 

New address locator styles supporting nationwide geocoding using multiple zone fields including city, state, and ZIP 
have been added. Here are the styles you can use for creating nationwide address locators: 
 

US Alphanumeric Ranges with City State ZIP and AltName 
US Alphanumeric Ranges with City State ZIP 
US Hyphenated Ranges with City State ZIP and AltName 
US Hyphenated Ranges with City State ZIP 
US Streets with City State ZIP and AltName 
US Streets with City State ZIP 
 
 

New Match_addr string in geocoding candidates list 
 

The new Match_addr field displays the address that is actually geocoded and located based on each returned 
andidate. This information is particularly helpful if the input address is geocoded to a candidate that does not match 
xactly. For example, 201 New York St can be matched to the location of 301 New York St on the candidate of 301-
81 range street segment. In other words, Match_addr is the location that ArcGIS will use to represent the address you 

typed in if you choose that particular candidate. This field is only shown in the candidate list in the Find dialog and the 
Interactive Review dialog: 
 

c
e
3

 
 
 
New Geocoding geoprocessing tools 
 

Two new geoprocessing tools have been added to the geocoding tool box.  
 
 Geocoding Tools > Rebuild Address Locator 
 
 Geocoding Tools > Rematch Addresses 
 
Address locators can be rebuilt to reflect changes in the reference data. This tool only applies to address locators 
created with ArcGIS 9.2. The Rematch Addresses tool allows you to rematch addresses in a geocoded feature class. 
 
Some tools have been removed at 9.2 because they are no longer applicable due to the changes to address locators. 
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New built-in routing & driving directions capabilities 

At 9.2 a new Find Route dialog is provided in ArcMap, ArcReader and ArcGIS Engine that enables you to perform 

dialog doesn't require that you have access to any locally installed StreetMap datasets, so it makes it easy and 
onvenient to perform routing.  

 
The dialog supports routing in North America (USA + Canada) and Western Europe, and is also provided in ArcReader 
and ArcGIS Engine, so end users of your published map documents and custom ArcGIS applications can now easily 
get routes and print driving directions too. It is not supported in ArcGlobe.  
 
In ArcMap and ArcReader the new routing dialog is accessed by choosing Tools > Online Services > 

routing and get driving directions using built-in access to a set of free online services. All you need to use these is an 
Internet connection. No account or sign-in is required. Unlike the existing StreetMap Find Route dialog, the new Find 
Route 
c

 Find Route.  
 
The new routing dialog also supports ArcWeb Services. If you are an ArcWeb Services subscriber and you are 
currently signed in, you'll see additional premium routing services in the Find Route dialog. 
 

he following screenshots show the new Find Route dialog being used to find a driving route across Western Europe, T
and to investigate two potential tourist bus routes in San Diego, California: 
 

 
 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  158 



 
 
 
Tip: Remember that performing routing with the new Find Route dialog doesn't demand that your map contain any 

a

nhancements to the StreetMap routing dialog 

p rticular layer representing streets or transportation. Routing services are self-contained which means you can add 
routes to any map and get driving directions, irrespective of what data is represented in your map.  
 
 

E

At 9.2 we have continued to enhance the StreetMap  Find Route dialog in the StreetMap toolbar available in 
ArcMap. The StreetMap Find Route dialog works with StreetMap file-based routing services and, since ArcGIS 9.1, 
has been provided free at all ArcGIS Desktop license levels.  
 
The entry level StreetMap USA dataset, address locator, and routing service are part of the free ESRI Data And Maps 
data collection that is provided with ArcGIS Desktop, ArcGIS Server, and ArcGIS Engine. Additional StreetMap data 
products offering more current data with improved address and routing accuracy can also be licensed from ESRI: 
StreetMap Pro and the more frequently updated StreetMap Premium cover the USA and Canada, and StreetMap 
Premium Europe covers more than 20 European countries. The StreetMap products provide a multi-scale, high quality 
cartographic basemap, the ability to find addresses individually, high performance batch geocoding of addresses in 
tabular form, and multi-stop route finding. The StreetMap products can also be used with the Network Analyst 
extension as a multi-purpose, ready-to-use transportation network. For more about the StreetMap Pro and StreetMap 
Premium products, see: http://www.esri.com/data/streetmap/index.html
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Barrier support 
 

A new tab in the StreetMap Find Route dialog provides support for defining b
going through certain locations. Barriers are shown on the map with red crosses

arriers so that you can prevent routes 
 (you can change this symbol in the 

Options tab). Barriers make it easy to generate routes to reflect current traffic or emergency situations, and also to 
perform what-if scenarios for planning and route design: 
 

 
 
 
Trip planning 
 

A new trip planning option has been added to the Options dialog. Here is the new Trip Planning Settings dialog 
accessed from the Find Route dialog Options tab: 
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Support for specifying speed and restrictions 
 

The new speed and restrictions options enable you to investigate different scenarios and better model the 
transportation conditions in your areas of interest. The ability to specifying speed and restriction is dependent on 
attributes in the StreetMap data you are using and is not supported in the free, entry level StreetMap USA data. 
 
The ability to specify speeds has been added via a new Speeds button on the Find Route dialog Options tab. This lets 
you display the various road classifications defined in your street dataset network and assign typical travel speeds to 
them: 
 

 
 
Network restrictions enable you to include parameters such as vehicle type, weight, length and others in route 
calculations for more accurate results. These parameters determine whether a particular street segment is passable or 
not. Supported restrictions are: Boolean (either true or false), such as restrictions on certain types of vehicles on 
certain streets, 'MaxAllowed' restrictions, such as vehicles exceeding a certain height not being allowed, and 
'MinAllowed', such as vehicles not able to reach a certain minimum speed not being allowed. Restrictions can be strict, 
which can never be violated, or relaxed, which may be violated if there is no alternative. Here is the dialog launched by 
the Restrictions button in the Find Route dialog Options tab. This lets you control the restrictions that are being used: 
 

 
 
 
Other 
 

Route calculation performance has been increased 3+ times. 
 

Support for complex turns: Multi-part turn restrictions are now supported by the routing engine. 
 

Driving directions have been enhanced in a numb f ways to improve usability, flexibility and output: 
 

er o
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- Directions now offer enhanced printing options including stop vicinity maps and turn-by-turn maps. 
 

g directions (feet, yards, miles, kilometers, meters).  

s when street name does not change. This situation occurs when a street turns at an 
e does not change. A turn instruction generated, for example, "Turn right at State St 

to stay on SR 154": 
 

- Support for different distance units in drivin
 
- Reports turns at intersection

intersection, but the street nam

 
 
-  Recognizes U-turn on divided roads so that they are reported as a single U-turn instruction, rather than two left turns.

In the example below, directions will contain the following instruction: "Make U-turn at Ash St and go back on 
Brookside Ave": 

 

 
 
- Reports toward street in first directions item: Adds ‘toward <intersection street name>’ to the first item in directions 

for better driver orientation. Example: "Go North on New York St toward State St". 
 
- Makes use of signpost information in the source data: Adds target street/highway name and destination city na

from sign information as contained in source data. Example: "Take ramp to CA-299 West toward Central Redding / 
Eureka". 

me 

- 
 

Driving directions are now provided in HTML format compared to the plain text used in 9.1. 
 
- Text now appears in the directions saying whether the destination is on the left or on the right of the street (see the 

step highlighted in red below: 
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The StreetMap Find Route dialog now remembers the address locator that you specify in the dialog's Options tab 

for finding the addresses of locations you click on. When you open the StreetMap Find Route dialog it automatically 
ads the locator (usually one of the StreetMap locators) you used last into the current map document. Tip: Opening 

to browse for 
lo
this dialog is therefore an easy way to load a StreetMap address locator into a new map without having 
he locator on disk. t

 
Configurable U-turn policy: The StreetMap Router API has been extended to support setting a backtrack policy 

which affects how the solver processes u-turns. 
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ArcCatalog & metadata 

ArcCatalog enhancements 

Renaming folder connections 
 

You can now rename folder connections in ArcCatalog. This makes it easier and more convenient to access data 
with both ArcCatalog and the Add Data dialog launched from ArcMap. Now you can not only add folder connections 

ur most frequently used folders, you can also give these connections shorte more useful names. In this 
ay, folder connections work more like shortcuts or bookmarks to data. By default, ArcCatalog gives you folder 

pointing at yo
w

r, 

connections for the drives on your computer: 
 

  
 
To get quicker access to your frequently used folders on these drives and on network drives, you can create new 

 
 

folder connections. In the example below, a number of folder connections to data on the D:\ drive and on a network 
drive have been created, and the connection to the C:\ drive has been removed. (Tip: You can drag any folder you see
in the Contents tab in ArcCatalog onto the 'Catalog' node at the top of the catalog tree to quickly create a connection in
the tree to that folder): 
 

 
 
Here's what the same folder connections look like after being renamed in 9.2 to give them shorter names: 
 

 
 
To e or select it and press F2. You can rename any folder 
onnection, including connections to read-only folders on network drives. A folder connection works like a shortcut, so 
naming cted too. To see the target folder of a folder 

 rename a folder connection right-click it and choose Renam
c
re a connection doesn't change the name of the folder it is conne
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connection you've renamed, select it and look in the status bar. When you select a folder connection the status bar 
shows you the full path of the folder that the connection points to.  
 
 
Coordinate systems 
 

You can n
ArcCatal

ow drag/drop or paste coordinate systems into the top level of the Coordinate Systems folder in 
og. In previous releases, you could use Windows Explorer to copy coordinate systems into the top level of 

our arcgis/coordinate systems folder but it wasn't possible to do this in ArcCatalog. If you drag and drop a coordinate 
sy pied 
y

stem from a subfolder in the Coordinate Systems folder into the top level of that folder, it automatically gets co
rather than moved (no need to hold down CTRL when you drag and drop) so the contents of the subfolders are 
preserved. 
 

 
This enhancement can save a lot of repetitious clicking down through the Coordinate Systems sub folders. Copying 
coordinate systems into the top level of this folder makes it easy to select them when you specify coordinate systems 
in dialogs. For example, when you select a coordinate system in the XY Coordinate System tab in the Feature Dataset 
Properties dialog in ArcCatalog, coordinate systems you've put at the top level of the Coordinate Systems folder are 
accessible in the Catalog Browser directly without having to browse down into the sub-folders in that folder: 
 

 
 
Note: The Coordinate Systems folder is hidden in the ArcCatalog tree by default, but you can turn this folder on via the 
Tools>Options dialog General tab. When this folder is turned on it now gets sorted correctly in alphabetical order 
instead of appearing between Database Connections and Database Servers like it used to. 
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In the Coordinate Systems\Projected Coordinate Systems folder, there's a new sub-folder for the A

(ARC) equal arc-second projection system. This projection system underpins various military raster d
ADRG, CADRG) and is designed to tessellate seamlessly across the globe. The projection system d

rc Raster Chart 
atasets (ASRP, 
ivides each 

hemisphere into nine zones of ten degrees of latitude to minimize distortion and uses a rectangular coordinate 
projection based on the WGS84 datum: 
 

 
 

In the Coordinate Systems\Projected Coordinate Systems\World folder, there are two new World coordinate 
ystems that use the Goode Homolosine projection: 

 
  Goode Homolosine (Land) 

s

  
    Goode Homolosine (Ocean) 
 

ArcGIS 9.2 adds support for the definition and use of vertical coordinate systems. Over 90 predefined vertic
coordinate system definitions are provided in the new Coordinate Systems\Vertical Coordinate Systems folder. (

al 
See 

the 'Better support for M and Z coordinates' section in the 'Geodatabases & ArcSDE' chapter in this document). 

 
 

Other 
 

You can now sort data listed in ArcCatalog's Contents tab by the feature type of the data using a new optional 
column you can add into the listing. To add this column, go to the Tools>Options dialog Contents tab and click the Add 
button. In the dialog that appears, choose Feature Type. This will add this new column into the list of available 
olumns. Check the Feature Type column to turn it onc

n
. Note: if you are installing ArcGIS onto a machine which does 

ot currently have ArcGIS installed, you'll see the Feature Type column already in the list, and you won't have to press 
the Add button to add it in. 
 

You can now press ENTER to open the currently selected item in the Contents view in ArcCatalog (i.e the right 
hand side of the ArcCatalog window). So for example, to open the properties of a feature class in a feature dataset 
i  want to look at the properties for and l sted in Contents view, use the arrow keys to navigate to the feature class you
ress ENTER.  p

 
When ArcCatalog starts up, it looks for the contents of the Database Connections and Database Servers folders in 

 
in addition to 

:\Docume
 
In this wa e connections to ArcSDE geodatabases (.sde files), 
OLE DB c w at 9.2) into the All Users folder to ensure that all 

rs ses. ArcCatalog already looks for the connection 
les belonging to the GIS Servers folder (.ags, .ims, .wms files) in both locations. For example, the connection called 

this system folder:  
 
C:\Documents and Settings\All Users\Application Data\ESRI\ArcCatalog\ 

this folder: 
 
C nts and Settings\<user_login>\Application Data\ESRI\ArcCatalog 

y, system administrators can place the files that defin
onnections (.odc files) and database servers (.gds files ne
who use this computer can get access to the same databathe use

fi
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'Geography Network Services hosted by ESRI' that comes with ArcGIS Desktop is installed into the All Users location
when you install ArcGIS Desktop so that it is always available irrespective of who is logged onto the machi

 
ne. 

All 
e to copy the underlying connection file into that location manually using Windows Explorer. 

 
Note: When you create a connection in the Database Connections, Database Servers, or GIS Servers folder in 
ArcCatalog, it always gets saved into the <user_login> location. If you want the connection you created to be in the 
Users location, you hav
 

The Set Data Sources dialog you can access by right-clicking a map document in ArcCatalog has been enhanced 
so that it works with ArcSDE geodatabases, file geodatabases and coverages. Support has also been added for 
tables, rasters and all geodatabase data types (including topologies, etc). For example it is now easier to use it to 

ansition from personal geodatabases to file geodatabases. Assuming the schemas are the same and feature 
ataset/feature class names are identical, you can now simply right click a map document and change all paths to 

redirect personal geodatabase paths to file geodatabase paths. If the feature dataset and feature class names are 
r from the dialog and point to the new feature 

 
Note: The Set Data Sources dialog has the limitation that it removes certain additional properties from the map 
do stom toolbars), graphs, and table window appearance 
properties lly only recommended preparing map documents for publication or for 
advanced d a note to the top of this dialog to describe the limitation: 
 

tr
d

different, it still works but you have to explicitly open the Catalog Browse
dataset/feature class name.  

cument: customizations (VBA code, UI controls and cu
. For this reason the dialog is rea
 users. At 9.2 we have adde

 
 
You can also now resize the Set Data Source(s) dialog, which makes it easier to work with long paths. 
 

The Tools > Options dialog Proxy Server tab has been renamed to be the Connections tab. Starting with 9.2 
Service Pack 2, you use the Internet Options in the Windows Control Panel to specify proxy server and https/SSL 
connection information, and ArcCatalog automatically uses these settings for all your GIS Server connections. You 
only need to enter information into the Connections tab if your proxy server requires authentication, in which case you 
simply specify the user name and password in those two fields in the tab. 
 

Graphics layer files now have their own icons in ArcCatalog. Your existing layer files based on these data types 
won't be shown in ArcCatalog with these icons. Only new graphics layer files you create will adopt the new icons.  
 

 2D graphics layer created in ArcMap            3D graphics layer created in ArcScene or ArcGlobe 
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Metadata 

View metadata from ArcMap, ArcGlobe and ArcScene without launching ArcCatalog 
 

You can now access metadata about any layer's data source directly without having to open ArcCatalog. Right-clic
any layer in the T

k 
able Of Contents and choose the new View Metadata command from the Data pullright: 

 

 
 
Choosing the View Metadata command opens the metadata for the layer's data source in a new floating Metadata 
window. This window works the same as the Metadata tab in ArcCatalog. It also enables you to choose the stylesheet 
you want to view the metadata with. Each time you use the View Metadata command, a separate instance of the 
Metadata window appears. This makes it easy to compare the metadata for different layers. In this screenshot, 

etadata for two layers has been opened: m
 

 
 

If t  

isabled, or if you don't have 
w

able you to include these functions in scripts, batch 
rocesses, and models to automate metadata handling. 

he data source of the layer you access metadata for does not have metadata created for it yet, the View Metadata
command will automatically initiate metadata creation if the option to 'automatically create metadata' is enabled in the 

rcCatalog Tools>Options dialog Metadata tab (it is enabled by default). If that setting is dA
rite access to the data source's location, the Metadata window will show you the standard message that metadata 

cannot be created. 
 
Tip: If you'll be using the new View Metadata command frequently, you can customize the Layer context menu using 
the Tools>Customize dialog to move the command out of the Data pullright and into the main part of the context menu. 
 
 
New geoprocessing tools for working with metadata 
 
These tools provide new metadata functionality and also en
p
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Support for ISO 19139 format: You can export your existing FGDC or ESRI-ISO format metadata into a 

standalone XML file in the new ISO 19139 format. This tool also enables you to convert an XML document in ISO 
19139 format to ESRI-ISO format so that it can be loaded into an ArcIMS metadata service. The ESRI Metadata 

ranslator can be customized to support any metadata profile or standard, for example, a regional profile of ISO 
19
T

139: 
 
 Conversion Tools > Metadata > ESRI Metadata Translator 
 

l metadata management in ArcGIS for 9.2. Note: There are no changes to the editors or synchronizers or interna
 

Validate FGDC metadata: Lets you validate FGDC metadata using the USGS Metadata Parser tool (MP) which is
now included with Desktop: 
 
 

 

Conversion Tools > Metadata > USGS MP Metadata Translator 
 

Publish XML metadata to an ArcIMS metadata service: 
 
 Conversion Tools > Metadata > ArcIMS Metadata Publisher 
 

Support for XSLT style sheet: You can now transform an XML metadata document using an XSLT style sheet 
na d export the result to a standalone file. For example, before publishing metadata to an ArcIMS metadata service, 

you might transform it using an XSLT style sheet: 
 
 Conversion Tools > Metadata > XSLT Transformation 
 
 
Other 
 

You can now create standalone XML files directly in ArcCatalog using the new File > New > XML Document 
omc mand when you are working in a folder. This makes it easier to create metadata templates. To edit an XML file 

after creating it, select it in the Catalog tree, switch to the Metadata tab, and launch the Metadata Editor from the 
Metadata toolbar. 
 

When you browse the contents of an ArcIMS metadata service in ArcCatalog, the Contents view has been 
enh data document. You can now see which documents you own, 
whi other document properties in the Details list on the Contents tab: 
 

anced to include new information about each meta
ch documents are public or private, and 

 
 

 You can also change a metadata document's public/private property by right-clicking it and using two new commands
in its context menu: Change To Public and Change to Private. 
 

See the 'ArcIMS' chapter in this document for what's new in the ArcIMS metadata service.. 
 

The File > Print command in ArcCatalog has been renamed to File > Print Metadata to make it clear that this only 
lets you print metadata and is only enabled when you are using the Metadata view. 
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Customization & development 

ArcGIS Desktop application framework 

In the Tools > Customize dialog the Macros, Menus, New Menu and UIControls categories are now grouped 
together at the end of the categories list and enclosed in [ ] brackets to make them easier to find and make it clearer 
they are special categories. See graphic below). 
 

A new option has been added into the Tools > Customize dialog and Tools > Customize > Keyboard dial
it faster to find a particular command in the commands list. You can type a command name or any part of a command
name into the new 'Show commands containing' field. The Commands list will immediately be restricted to the 
ommands in the currently selected 

og to make 
 

category that match or contain the text string you typed in, and the Categories list 
 in 

c
will be restricted to categories containing commands that match or contain the text string you typed in. For example,
this screenshot the Commands list only shows commands containing the string 'zoom', and the Categories list only 
hows categories containing commands like that: s

 

 
 
To return to seeing all of the commands and categories, clear the 'Show commands containing' field.  
 

ote: Irrespective of what you enter into the field, the four special categoriN es Macros, Menus, New Menu and 
IControls are always shown in the categories list on the left (and if you are using the Customize Keyboard dialog, the 

ries list on the left). 
U
Macros category is always shown in the catego
 

Keyboard shortcuts can now be defined to invoke any interactive tool, such as the Zoom In to
pecify a keyboard shortcut for a tool, go to Tools>Customize and click the Keyboard button to la

ol, Edit tool, etc. To 
unch the Customize 

e
s
K yboard dialog. Tools are now listed in the Commands section of that dialog. 
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The list of context menus accessed via Tools>Customize is now sorted alphabetically to make it easy to find context 
me enu, go to Tools>Customize and check 
the e list.  
 

nus so you can customize them. To customize the contents of a context m
box next to the 'Context menus' entry in th

If you reduce screen resolution or change dual monitor setting during an application session, any floating toolbar or 
doc s out of the screen area, will now be brought back into the viewable screen area when you 

ggle its visibility. If you reduce screen resolution between application sessions then they will be bought back into the 
v  application. 
 

kable window that i
to
iewable screen area the next time you start the

A f issues relating to toolbars becoming stacked. 
 
 

ArcGIS Desktop developer resources 

rcGIS 9.2 fixes a number o

A

- ArcGIS Desktop VBA Developer Resources 
isual Basic 6 

- ArcGIS Desktop Developer Kit for Visual C++ 

ls 

t 9.2, the ArcGIS Desktop developer resources have been separated into four unique Developer Kits. 
 

- ArcGIS Desktop Developer Kit for V

- ArcGIS Desktop Developer Kit for the .NET Framework 
 
Each of these developer kits include a detailed help system for ArcObjects along with sample code, developer too
and other documentation to help you customize and extend the ArcGIS Desktop applications. 
 
The ArcGIS Desktop Developer Kit for the .NET Framework supports development with Visual Studio 2005 and 
includes several Visual Studio project templates, wizards, commands and code snippets to help with programming 
ArcObjects and .NET. 
 

For the latest information, including how to migrate and upgrade your code, see the 'What's new in ArcGIS Desktop 
.2 for .NET developers?' page in the ESRI Developer Network (EDN) website's ArcGIS documentation library at:  9

http://edn.esri.com
 
 

ESRI Developer Network (EDN) 

At 9.2, the ESRI Developer Network (EDN) includes: 
- ArcGIS Engine Developer Kit 
- ArcGIS Engine Runtime  
- ArcGIS Server Workgroup 

- ArcWeb Services 

- Java Developer Kit  

- ArcGIS Server Enterprise 
- ArcIMS 

- .NET Developer Kit  

- C++ Developer Kit  
 

At 9.2, EDN has an option to add an ArcView single use license (with the 3D Analyst, Spatial Analyst and Network 
Analyst extensions). You can purchase this option at any time during your current EDN subscription at price that is a 
ubstantial discount over buying these products separately. s

 
Additional developer content has been added to the EDN library in the form of technical articles, samples, developer 

scenarios, and more. See the EDN website: http://edn.esri.com
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ArcGIS 9.2 Engine Developer kit 

A e 
s). 

proved with complete Engine support offered on Linux Red Hat 4, Solaris 9, 
0 and SUSE 9. 

 

t 9.2, ArcGIS Engine increases developer productivity by providing out of the box coarse grained components in th
form of new extensions, API's, controls, commands and tools, together with focused software developer kits (SDK
Cross platform support has also been im
1

 
New extensions for ArcGIS Engine 
 
A key focus of the 9.2 release for ArcGIS Engine was the addition of some more advanced extensions. The new 
extensions to ArcGIS Engine Runtime: Data Interoperability, Maplex, Schematics, and Tracking Analyst, follow the 
existing Engine Runtime extension pricing and licensing model.  
 

Data Interoperability: The ArcGIS Data Interoperability extension for ArcGIS Engine Runtime provides real data 
inte on includes direct data access, transformation, and 
export c ns to dynamically fuse together various data sources. 
The Da d via the 
extensio
 

roperability tha st work  with all the major formats. The extensi
apabilities and enables custom ArcGIS Engine applicatio

ta Interoperability license is needed when a custom application requires the functionality expose
n. This functionality is exposed to developers through the DataInterop assembly, new at 9.2. 

M nt and labeling. Without the Maplex 
exte ritizes label placement based on which layer a feature is in. This 
powerfu many layers to be prioritized equally and independently. This 
function aplex assembly, now available in ArcGIS Engine. 
 

ap
nsion, the baseline labeling functionality, prio

lex: Maplex allows for automation of high-quality cartographic text placeme

l and flexible extension allows features from 
ality is exposed to developers through the M

Trac ion, allows your application to explore, visualize, and analyze 
change es tracking of temporal data from GPS and other tracking 
and mo es data. This functionality is 
exposed  Engine. 
 

king Analyst: The Tracking Analyst extens
relative to time and location. The extension provid
nitoring devices in real time and includes the playback and analysis of the time seri
 to developers through the Tracking assembly, now available in ArcGIS

Sche  ability to manage and view network data in a wide variety of 
geo-sch ematic 
assemb
 
 
New a
 

matics: The Schematics extension, provides the
ematic and schematic representations. This functionality is exposed to developers through the Sch
ly, now available in ArcGIS Engine.  

ssemblies at 9.2 

ADF contains the .NET base classes, component category unique IDs (CATIDs), and utility classes that were 
previously delivered in the ESRI.ArcGIS.Utility assembly that has been deprecated for the 9.2 release. Also includes 
the following new base classes: BaseCommandBar, BaseMenu, BaseToolbar, CustomLayerBase, and 
GlobeCustomLayerBase.  
 

ADF.Connection contains .NET classes to establish connections with ArcGIS Server and ArcIMS services. Also 
provides a set of classes to manage fail-over and round-robin properties of a connection  
 

Animation contains objects to work with animations in ArcMap, ArcScene, or ArcGlobe. An animation in ArcMap, 
ArcScene or ArcGlobe is composed of animation tracks (AGAnimationTracks) which are further composed of 
keyframes (AGAnimationKeyframes) of the same type. Each keyframe stores properties of the animation objects. 
When an animation is played, keyframes are interpolated and the interpolated properties are then applied to the 
animated objects to create the dynamic visual effect.  
 

ArcWeb provides objects to access a Simple Object Access Protocol (SOAP) based collection of ArcWeb Services. 
ArcWeb Services communicate with any local application that can connect to the Web and understand Extensible 
Markup Language (XML). ArcWeb Services use a SOAP wrapper to transfer information back and forth to a local client 
application using hypertext transfer protocol (HTTP).  
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Controls provides access to all ArcGIS Engine Controls (LicenseControl, MapControl, PageLayoutControl, 
GlobeControl, SceneControl, ToolbarControl, TOCControl, SymbologyControl) and all out of the box Arc
commands, menus, palettes and multi-items. All controls, commands and HookHelper objects have been moved f
the ControlsCommands, 3DAnalyst, and GlobeCore assemblies to the new Controls library.  
 

GIS Engine 
rom 

DataSourcesnetCDF provides objects to access a netCDF file as a workspace and to create a raster layer, feature 
layer or table view from a netCDF.  
 

GeodatabaseExtensions contains objects to aid in the creation, management, and use of terrain datasets and 
adastral fabrics (see the Survey Analyst chapter in this document).  c

 
Geoprocessor and Geoproce

eoprocessing tools available to cu
ssing: ArcGIS Engine Runtime at 9.2 includes the geoprocessing framework. The 
stom ArcGIS Engine applications depend upon the license the application is using. 

A

 

mbly containing a managed class called the geoprocessor. In 

g
rcGIS Engine applications can run ArcView level GP tools and edit shapefiles and personal geodatabases using an 

ArcGIS Engine Runtime or ArcView license. ArcGIS Engine applications can run ArcEditor level geoprocessing tools 
and edit enterprise geodatabases using an ArcGIS Engine Runtime with the Geodatabase Update extension or an
ArcEditor license. In order to run an ArcInfo level tool, an ArcInfo license is required.  
 

he Geoprocessor assembly is a .NET specific asseT
most cases, .NET developers would interact with this assembly rather than the Geoprocessing assembly which 
exposes geoprocessing objects via COM.  
 

Publisher: The Publisher Library was extended for the ArcGIS 9.2 release to include an ActiveX Control (the 
ArcReaderGlobeControl) for viewing Published Map Files (PMF's) authored in ArcGlobe. Prior to the ArcGIS 9.2 
release, the Publisher Library contained a single ActiveX Control (the ArcReaderControl) that enabled viewing of 
Published Map Files authored in ArcMap. The term PublisherControls refers collectively to the ArcReaderControl and 
the ArcReaderGlobeControl. 
 
 
Enhancements to existing developer assemblies 
 

Carto exposes the new cartographic representation functionality. Custom applications can view and work with 
cartographic representations using an ArcGIS Engine Runtime or ArcView license; however, creating or editing a 
cartographic representation requires an ArcGIS Engine Runtime with Geodatabase Update extension or an ArcEditor 
license. In addition, the following layer factories have been added to the Carto library:  

- CadastralFabricLayerFactory 
- EngineCadAnnotationLayerFactory  
- EngineCadFeatureLayerFactory  
- EngineCadLayerFactory  
- EngineCoverageAnnotationLayerFactory  
- EngineIMSLayerFactory  
- EngineNetworkLayerFactory  
- EngineTopologyLayerFactory  
- EngineWMSMapLayerFactory  
- FeatureLayerFactory  
- netCDFLayerFactory  
- RasterCatalogLayerFactory  
- RasterLayerFactory  
- TerrainLayerFactory  
- TinLayerFactory  

 
DataSourceRaster includes a new set of components that perform raster transformations such as polynomial 

transformation, RPC transformation, Coordinate transformation, and Spline transformation. In addition, APIs to build
nd retrieve raster attribute tables for all raster data sources are now available and the SaveAs ca

 
pability has been 

e
a

xtended to enable saving to raster formats such as PNG, JP2, BMP, JPG, PCRaster, X11 PixelMap, and file 
geodatabase.  
 

Display provides new components for editing feature class representations so that cartographic editing and 
finishing maps is a more convenient process. A representation is symbology stored in the geodatabase for each 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  173 



feature. Representation rules define how a
ymbology rather than standard ArcGIS symbol

 set of features in a feature class will be drawn, using representation 
s. New symbols called Basic symbols (BasicMarkerSymbol, 

ert 

atures as they are drawn on your map, without affecting their underlying shape or spatial relationships. 
r cEffects (width, dash style, simplify options, etc), 

ee representation graphic.  
 

resentations. Representation is 
ure class results in the 

ddition of two new fields (RuleID and Override) to the feature class. A new workspace extension called 
Extension maintains information about representations present in a workspace. 

presentationClassName, RepresentationClassNames, and Representation are some of the 
e

usin
 
Geo systems to 
vec
 
A spa ce is composed of two parts. The first includes the horizontal and vertical coordinate systems. The 
sec
datas rest (xy, z, and m) and the precision or scale values. The maximum 
prec  low 
prec ). 
The he 
reso d. 
The
 
The s rence coclass now supports ISpatialReferenceResolution and ISpatialReferenceTolerance interfaces. 
With
valid a nterest for a projected or geographic coordinate system. Use 

patialReferenceFactory.ConstructHighPrecisionSpatialReference to create a high precision version of an existing 
w precision spatial reference.  

is now supported for vector data including shapefiles and feature classes. A 
v stem includes information on the origin and linear unit of z coordinates of a dataset. The 

patialReferenceFactory3.CreateVerticalCoordinateSystem method to instantiate a predefined vertical coordinate 
sy CoordinateSystemEdit.Define to create a custom vertical coordinate system. Set or retrieve the 
ertical coordinate system on a spatial reference with ISpatialReference3.VerticalCoordinateSystem.  

rologyOp2 and ILogicalOperatorOp2, have been added to the 
e, GPValueTableType, GPDomain and few other objects have been 

alystUI assembly to SpatialAnalyst assembly.  
 
 

n ontrols 

s
BasicLineSymbol, BasicFillSymbol) are provided with ArcGIS 9.2. In addition, methods are provided to conv
standard ArcGIS symbols to Basic symbols. Basic symbols are then used along with GeometricEffects to define 
RepresentationRules. GeometricEffects are special processes that allow you to dynamically alter the geometry of 
fe
G aphicAttributes enable you to define attributes for Geometri
MarkerPlacements (X, Y offsets), Basic symbols (patterns, strokes, etc), and feature class representation properties 
(visibility). Features can be displayed using the feature geometry or shape overrides from the representation or as a 
fr

GeoAnalyst added two new interfaces: IInterpolationOp3 and IRasterNeighborhood2.  
 
Geodatabase components have been added that create and manage feature class rep
ymbology stored in the geodatabase for each feature. Creating new representations for a feats

a
RepresentationWorkspace

epresentationClass, ReR
n w classes added to this library.  
 
GeodatabaseDistributed now provides components for geodatabase replication and a high level object model for 

g this functionality with ArcGIS Server.  

etry now enables the creation om f high precision spatial references and supports vertical coordinate 
tor data, including shapefiles and feature classes.  

tial referen
ond includes storage and processing parameters for a dataset. Prior to this release storage parameters for a 

et were defined by the domains or area of inte
ision value was 2147483647 if a domain had an extent of 1. This type of spatial reference is now called
ision. A high precision spatial reference, new at 9.2, has a maximum precision value of over 9000 trillion (9E15
 spatial reference concept of precision is difficult to understand so a new concept of 'resolution' is now in use. T

tion is the inverse of thelu  precision and directly reflects the data's accuracy. Tolerance values are also supporte
y are used with all geometric and relational operators.  

patial refe
 the ISpatialReferenceResolution.ConstructFromHorizon method, you can automatically set the xy domain to the 

rea of i
IS
lo
 

ertical coordinate system metadata V
ertical coordinate sy

IS
stem. Use IVertical

v
 
SpatialAnalyst added two new interfaces, IHyd

patialAnalyst library. All GPValue, GPDataTypS
moved from SpatialAn

E hancements to existing c
 

LicenseControl: upda
 

ted with new ArcGIS Engine Runtime extensions and licensing levels.  

MapControl: mouse wheel and keyboard display navigation has been enabled. 
 

PageLayoutControl: mouse wheel and keyboard display navigation has been enabled.  
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TOCControl (Table of Contents control): enhanced with the following:  

p  

 

- Getting and setting the selected layer  
- Layer drag and drop from ArcMa
- Layer re-ordering by drag and drop  
- Copying layers  

T
s for vertical orientation, transparency, background color, and shading  

- Sup
- Hidde lbarControl is not large enough to display all items  
- Sup
- Toolb tte of tools  

arMenus and ToolbarPalettes  
- Cus
- Sup
- Persis nd loading ToolbarControl items  
- Context s lp tool enables your users to get popup context help about any control in a toolbar 

 
 
New controls, commands and tools 
 

oolbarControl: now includes the following:  
- Appearance propertie

port for XP themes  
n items menu when Too

port for multi-item objects on ToolbarMenus  
arPalette object providing a popup pale

- Right to left Toolb
tomizable ToolbarMenus and ToolbarPalettes  
port for buddy swapping  

ting a
ensitive he

A
you s. The Engine-based Add Data dialog doesn't require ArcCatalog objects 
and doesn ssed. Users 
choose what the s, personal 
geodataba
support makes i alog, 
such as ArcSDE  
data that a user
 

dd D
r users to add data into Engine application

ata command: this addresses the number one enhancement request for the Engine by providing a way for 

't use the Desktop Add Data dialog framework, so data at any folder location can be acce
y want to add from the options on the left of the dialog. Shapefiles, file geodatabase

ses, web services (ArcIMS, ArcGIS Server, WMS), rasters, and layer (.lyr) files are supported. Layer file 
t possible for users to add data types that are not supported directly via the other options in the di

eodatabase data. S g upport for layer files is also convenient because it enables you to define how the
 adds into an Engine application will appear. 

 
 
This dialog is also exposed in the Desktop environment via the Tools > Customize dialog where you can find the 
command in the new 'Generic' category. When the dialog is launched from ArcGIS Desktop, it automatically contains 
an additional option on the left hand side called 'All Types'. This option provides full access to the entire ArcCatalo
tree and makes the dialog have the same functionality as the standard Add Data dialog. T

g 
he 'All Types' node isn't 

available when the dialog is launched from ArcGIS Engine. 
 

 The Symbology Control provides access to the contents of style files and custom symbology. The control displays 
the contents of one symbology style class at any one time (for example, marker symbols or color ramps) and allows 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  175 



the selection, removal and preview of individual symbols. Selected symbols can be used to up
application, such as a layer's renderer, an element's symbol, or cartographic marginalia s
arrows.  
 

date part of an 
uch as scale bars and north 

New set of QT Controls for cross platform development include QT widgets for Windows, Linux and Solaris and 
GTK widgets for Windows. 
 

Full Screen command: toggle
 

s between full screen and windows mode.  

Map and Globe commands and dialogs: these provide the same new and enhanced functionality that has been 
introduced into Desktop at 9.2: Go To XY dialog, My Places dialog, Find dialog, Find Route dialog, Find Nearby Places 
dialog, Identif en y, Measure, Swipe, Flicker, Bookmarks, etc. A command for adding KML data from the Internet has be
added for use with the GlobeControl. 
 

Ink commands: provide ink markup pens, highlighters and erasers, together with a find ink command. In addition 

Pens: Create graphics on a map using various pen widths 
Erasers: Erase part or all of a sketch using various eraser widths 
Highlighter: Emphasize areas with various semitransparent colors 
Find Ink: Lets you search for graphics in a graphics layer 

 

the EngineInkEnvironment object manages the ink environment used by these commands and any custom commands 
you create.  

 Ink tools: 

ArcWeb Services commands: provide commands for signing in to and managing an ArcWeb services account. 
Support for ArcWeb Services provides additional premium services in the Find dialog Addresses tab, Find Route 
dialog and Find Nearby Places dialog. 
 

Editing commands: provide commands for managing an edit session (starting, stopping, saving), managing 
selected graphics or features (cut, delete, copy, paste, move), managing the snapping environment, editing attributes, 
sketching and displaying sketch properties and a context enu for managing the current sketch (direction, deflection, 

ngth, endpoint, midpoint, vertex, streaming, absolute xy, delta xy). In addition the EngineEditor object manages the 
diting environment used by these commands and any custom commands you create. Editing commands do not 

require additional license and the data sources editable depend on the level of Engine runtime license. ArcGIS Engine 
applications can edit shapefiles, personal geodatabases, and file geodatabase with these commands using an engine 
runtime or ArcView license. ArcGIS Engine applications can edit ArcSDE geodatabase data using an engine runtime 
with a geodatabase license or ArcEditor license.  

Editing tools:  
Edit Tool: Select feature/vertex for modification 
Sketch Tool: Create point or vertex for polyline, polygon 
Editing Target: Provide a list of layers that user can choose as current editing target 
Attributes Editing: Show attributes window for user to edit attributes 
Edit Sketch properties: Edit sketch geometry properties by inputting value 

Editing context menu commands/shortcuts: 
Snap To Feature 
- Endpoint  (CTRL + F5): Snap to endpoint 

p to Edge 
Direction  (CTRL + A): Sketch based on direction 
Deflection  (CTRL + F): Sketch based on the direction of last segment 
Length  (CTRL + L): Specify segment length 
Change length: Change segment length 
Absolute X, Y  (F6): Specify next vertex by X, Y 
Delta X, Y  (CTRL + D): Specify next vertex by the difference from last added vertex 
Streaming Checkbox (F8): Turning on streaming will automatically add points 
Delete Sketch  (CTRL + Delete): Delete current sketch 
Finish Sketch  (F2): Finish current sketch 
Finish Part:  Finish current sketch as a geometry part 

m
le
e

- Vertex  (CTRL + F6): Snap to vertex 
- Midpoint  (CTRL + F7): Snap to midpoint 
- Edge  (CTRL + F8): Sna
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Network commands
networks (route, closest facility, service area, OD cost matrix) and displaying directions. In addition the 
EngineNetworkAnalystEnvironment object manages the network environment used by these commands and any 

: provide commands for managing network locations (creating, selecting, moving), solving 

custom commands you create. Custom ArcGIS Engine applications must have a Network extension checked out in 
order to use these commands.  
 

Schematics commands: provide commands for managing schematics diagrams (create, update, save), managing
schematics elements (edit, move, select) and managing label and symbol size. Custom Arc

 
GIS Engine applications 

ust have a Schematic extension checked out in order to use these commands.  m
 
 
Dynamic display support 
 

Developers applications can take advantage of dynamic display support, a completely new capability introduced at 
.2 that enables a map display to display large numbers of moving objects at sub-second refresh rates, all while 

s

, an ArcGIS Engine application is dynamically displaying the continuously updated location of hundreds 
f aircraft, along with associated identification information: 

 

9
ustaining smooth and uninterrupted navigation and support for GIS data query. This capability is available within 

ArcMap and ArcGIS Engines so it can be used and configured using ArcObjects and supported development 
environments in both ArcMap and the MapControl. 
 
In this example
o

 
 
GIS applications often require the ability to display information with frequent refresh rates. This information must be 
rapidly updated without interruption, including animating moving objects, updating the location, orientation, size, status 
and attribute information, particularly in critical Command and Control (C2) applications. Up to now the ability to handle 
very rapid refresh rates for large numbers of dynamic objects has been limited.  
 
This enhancement brings dynamic display capabilities to ArcObjects, allowing smooth pan, zoom, rotation, navigation 
and display of dynamic graphics through the use of OpenGL display rendering and fast refresh rate technology. 
Dynamic display allows the display performance required of real-time applications, while using the existing query and 
editing tools and layer functionality of ArcObjects. 
 
The DynamicMap can be enabled using the IDynamicMap Interface that is implemented by the Map CoClass. The 
Map CoClass is implementing the interface IDynamicMap. Use the interface IDyanmicMap to enable or disable the 
DyanmicMap (which is the dynamic display). When enabled, the dynamic display is creating an OpenGL rendering 
context to draw the basic map layers, and on top of the base layers, draws the dynamic layers. 
 

For updated information on implementing dynamic display, along with sample code, see the ESRI Developer 
Network (EDN) SDK documentation and look under Building solutions with ArcGIS Engine using .NET > Working with 
ArcGIS Components > Mapping and Visualization > Working with the map display > Dynamic Display. 
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Ch

 initialization at application start time using the 
icenseControl or the AoInitialize 

anges to the licensing model 
 
All custom ArcGIS Engine applications must perform license

object. Any existing 9.0 or 9.1 custom ArcGIS Engine applications not containing 
se initialization will fail when run on the 9.2 platform.  

L
licen
 

ArcGIS Desktop 9.2 can now run Engine Applications 
You can now run your Engine Applications on a Desktop machine. Basically if you want to run an Engine Application 

p installed, you need not install the Engine Runtime to run your applications.  and you already have a 9.2 Deskto
 

API support 
ArcGIS Engine Developer Kit has been divided up into several toolkits for building and deploying custom ArcObjects 
based solutions based on individual API’s. This includes .NET Developer Kit, C++ Developer Kit, COM Developer Kit 
(VB6 and VC ++) and Java Developer Kit. See below for what's new in each of these. 
 
 
.Net Developer Kit 
 

Developer resources and tools have been integrated into the Visual Studio 2005 and Express integrated developer 
environments (IDEs) to make developing ArcGIS Engine applications easier. These include:  

- Code Converter: wizard that converts Visual Studio projects and solutions built against ArcGIS 8.3 to work with 
ArcGIS 9.2. You can convert either the projects in the current solution, or use the batch option to convert many 
solutions or projects at a time.  

- Project templates: help you quickly get up and running with your ArcGIS Engine application.  
- New item templates: provide a simple, quick way to create common customizations such as commands and 

tools.  
- Code snippets: small sections of ArcGIS code that perform common tasks and can be pasted into your project 

using Visual Studio's Insert Snippet feature.  
- Add ArcGIS Class: wizard that creates a .NET class for a range of typical ArcObjects components.  
- Add references: dialog enabling you to add ArcGIS references to your project based on product, functional 

area, or feature area.  
- Component Category Registrar: registers classes in the current project to ESRI component categories.  
- License Initializer: selects which ArcGIS product and extension licenses your application will initialize upon 

startup.  
- ArcGIS Toolbox Reference: creates a managed assembly for your custom ArcGIS Toolbox of geoprocessing 

tools.  
 
 
C++ Developer Kit 
 

C++ API Updates 
 

QT support 
 

C
 

 
OM Developer Kit (VB 6 and VC++) 

Tools and Add-ins: 
- Modified Automatic references Add-ins 
- Geoprocessing Help Add-in 

 
 
Java Developer Kit 
 

ArcGIS Desktop 9.2 is a superset of Engine Runtime. It now lays down the files necessary for running Java 
applications (along with the arcobjects.jar). You can use the boot strapping mechanism explained in the Deployment 
doc to locate the “arcobjects.jar” when deploying to the ArcGIS Desktop machines. 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  178 



 
Java API Updates: 
- Update Visual Beans to make use of Control customize dialog. 
- Improved Java samples. 
- More technical documents and Walkthroughs. 

- Support for casting and instanceof - No need for QI (use of proxy classes). 

s. It can be used to generate Java 
classes for the custom model or tool. 

- IDE Integration: 
- Bundled Eclipse with integrated samples for out of box experience. 
- New templates to quickly create applications by going through a series of wizards. The templates included 

are: 
Routing  
Basic Viewer 
Geocoding  
UI Samples  

- ArcObjects help bundled with Eclipse. 
- The above features can be added to any Eclipse Version 3.1 or greater by using ArcGIS Engine Plug-ins. 

- Improved SDK structure and Content: 
- Improved javadoc: 

- Unnecessary constructors have been removed and generally improved content. 
- Samples: 

- New Domains - Tracking, Network Analyst, Geoprocessing and samples showcasing the new 
control and tools. 

- Executable jars available for the samples. You can find the jars in the sample/bin folder and simply 
execute them to run the applicatio  

- Samples have been provided to highlight each of the following or they are used within the templates 
in Eclipse: 

e 

- Symbology Dialog, Attribute Table, Select By Location, Query Dialog, Buffer Dialog and Find Dialog are 
introduced as samples to use and view in code. 

nents palette in design time; drag and drop in IDE when 

 
Linux/Solaris support 

- Updated Engine Runtime for Java (9.1 functionality). 
- No Java Developer Kit resources. 

- GeoProcessing: 
- The GeoProcessing library implements the Geoprocessing framework in addition to the base set of 

Geoprocessing tools.  
- "ToolGenerator" to creates Java tools from custom tools or model

n.

Measure, Identify and Find 
More navigation tools for Glob
Editing Tools. 
Tools for Network Analysis 
Tools for Sketching 
Tools for connecting to ArcWebSymbologyControl 

- Visual Components 

- Eclipse plug-in to view a UI Samples compo
creating an engine application. 

 

 
Moved to MainWin 5.04 at 9.2. 

 
 
 
For the latest information, see the 'What's new for ArcGIS Engine developers at 9.2?' page in the ESRI Developer 

etwork (EDN) website: N
http://edndoc.esri.com/arcobjects/9.2/CPP_VB6_VBA_VCPP_Doc/Cpp/new_92_win.htm
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Data & services from ESRI 

ArcGIS Online 

ArcGIS Online is a new family of web-based services and products for ArcGIS users. Powered by ArcGIS Serv
ArcGIS Online offers ready-to-use live content and capabilities, such as basemaps, globes, and overlays. It also
provides on

er, 
 

line data delivery and hosting services. 

Th nd 
 

e free services provided by ArcGIS Online include street maps, imagery, shaded relief, topographic base maps, a
overlays containing place names and boundaries: 
 

   
 

     
 
For more information on ArcGIS Online and to access the free map documents and services , see 
ttp://arcgisonline.esri.comh
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Improved ArcWeb Services integration into Desktop 

ArcWeb Services from ESRI are subscription-based services that give you access to premium GIS data from 
leading commercial data publishers, such as GlobeXplorer, NAVTEQ, Meteorlogix, and Tele Atlas and a collection of 
high performance, reliable GIS services providing additional capabilities and functionality.  
 
ArcWeb Services subscribers get a user name and password that enables them to access the services. New users 
can register for a free evaluation subscription. ArcGIS Desktop users who subscribe to ArcWeb Services can work with 
these services directly in their applications. ArcWeb Services can also be included in web mapping applications, 
custom ArcGIS Engine applications, maps and globes published with ArcGIS Publisher, or embedded in applications 
using the ArcReader Control.  
 

Support for ArcWeb Services in ArcGIS Desktop was previously provided by the 'ArcWeb Toolbar For ArcGIS' 
which was available to ArcWeb Services subscribers as a separate free download. In 9.2 support for ArcWeb Services 
has been built into ArcGIS Desktop and there is no longer a separate toolbar that has to be downloaded. ArcWeb 
Services subscribers can access the services from ArcGIS Desktop out-of-the-box without having to install or 
download anything else. 
 

A new ArcWeb Services folder is available in ArcCatalog that makes it easy to access the various data services 
available to you as an ArcWeb Services subscriber. This folder is hidden in ArcCatalog by default but you can turn it on 
by going to the Tools > Options dialog General tab and checking it in the list you'll see there. The first time you connect 
to this folder, you'll be prompted for your ArcWeb Services user name and password. After you sign-in, you'll see all 
the available data services listed. ArcWeb data services are all in ArcIMS image service format: 
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As an ArcWeb Services subscriber, you also have access to a set of additional specialized services in ArcMap, 
rcGlobe or ArcReader. The new Tools > Online Services pullright in all three applications contains commands for 

 

A
signing in to and managing your ArcWeb Services account: 

 
 
After you have signed into ArcWeb Services you'll see the additional specialized services in these dialogs: 
 
- the Find dialog's Addresses tab 
- the Find dialog's new Places tab 
- the new Find Route dialog 
- the new Find Nearby Places dialog 
 
In the example below, the TrafficCast Inc. real-time traffic i formation service is being accessed in the Find Nearby 
Places dialog to find the latest tr ffic accidents or construction delays within 5 miles of downtown Los Angeles. You 
can work with the incidents that are returned by selecting one or more of them in the list and then right-clicking. The 
menu that appears has commands or navigating to the incid nts, adding to your map as graphics or callouts, etc:  
 

n
a

 f e

 
 

To find out more about ArcWeb Services and get a free evaluation see: http://www.esri.com/arcwebservices
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ESRI 'Data & Maps'  

At ArcGIS 9.2, an updated version of the ESRI Data & Maps datasets, ESRI 'Data & Maps 2006', is available. The 
ESRI Data & Maps 2006 media kit contains five DVDs and is included for free with ArcGIS Desktop and Server. 
 

New dataset: 90 meter Shuttle Radar Topography Mission (SRTM) dataset. This dataset includes the SRTM 
Global Digital Elevation Model (DEM) with all void areas filled, as well as a shaded relief derived from the DEM. Here 

re two screen shots of the SRTM data. The shaded relief on the left is part of the Island of Hokkaido and the map on 
the
a

 right shows elevation along part of the Tajikistan-Afghanistan border: 
 

     
 
 

Many U.S. datasets have been updated to their mo rrent version. These include the Tele Atlas Census 
boundary and landmark layers, and the National Atlas layers. 
 

st cu

Updates to datasets at the world level include updates for 2005 to the Country population values, the Political 
Organizations table, the AND (Automotive Navigation Data) basemap layers for Europe, and the Demographic and 
socioeconomic thematic data at the NUTS (Nomenclature of Units for Territorial Statistics) 0, 1, 2, and 3 level. In 
addition, updates have been made to many of the data layers for Canada and Mexico, and other datasets. 
 
 

StreetMap data support 

The Smart Data Compression (SDC) format is an encrypted and highly-compressed format used by commercial 
data vendors who distribute street data for geocoding and routing with various ESRI software products. The ability to 
create data in SDC format is provided via a separately available kit. 9.2 introduces Secure Feature Layer (SFL) 
support in SDC datasets. This greatly expands support for flexible data copyright protection. SFL provides data 
vendors with a system for distributing data and protecting access to it through a matrix of licensing options. An SFL 
SDC dataset can be protected for access by geography, layer, attribute, time window, and mode (mapping, routing, 
and geocoding) as well as being protected from export. 
 
SFL functionality is controlled by a single digital license file which can be generated and delivered by ESRI, ESRI 
international distributors and data partners. End users of published data can license additional data access such as 
adding new geographies or modes or extending the data license period by simply requesting and installing a new 
license file. End users can review their current access rights via a new Security tab in the Layer Properties dialog for 
SDC data layers that are protected with SFL that have been added into ArcMap. 
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ArcGIS Server 

Introduction 

ArcGIS Server changes significantly at 9.2. With the release of ArcGIS 9.2, ArcGIS Server becomes a complete, 
integrated GIS server that supports spatial data management, mapping, and spatial analysis across distributed 
ystems.  s

 
The ArcSDE technology has been integrated into ArcGIS Server to provide a single comprehensive solution for 

ArcGIS Server 9.2 is available scaled to two levels: ArcGIS Server Workgroup and ArcGIS Server Enterprise. The 
ArcGIS Server Workgroup product includes our new Windows-only Workgroup ArcSDE technology, which offers a new 
way to deploy and manage ArcSDE geodatabases, using SQL Server Express as the DBMS and with all the database 
administration performed directly in ArcCatalog. The ArcGIS Server Workgroup product is designed to be a low cost, 
easy-to-install multi-user geodatabase solution for small teams and departments that also includes the full range of 
web-based GIS functionality provided at 9.2. ArcGIS Server Enterprise features our existing Enterprise ArcSDE 
technology that supports Oracle, DB2, SQL Server, and Informix databases on a range of platforms. 
 

managing geographic data in a multi-user environment and deploying data and applications throughout organizations 
and across the Web. ArcSDE is no longer purchased on its own as a separate product. To purchase ArcSDE, you now 
urchase ArcGIS Server.  p

 

At 9.2, we've made it much easier to serve maps and other GIS resources over the web with ArcGIS Server and to 
build web applications that access your services without writing any code. We’ve created a new web browser-based 
tool, ArcGIS Server Manager, that makes it easy to setup and administer your server, publish GIS services, and create 
web mapping applications, including applications that combine services from ArcGIS Server, ArcIMS, ESRI ArcWeb 
Services, and OGC WMS servers.  
 

ArcGIS Server 9.2 also greatly expands the web-based GIS functionality in the product. You can now dramatically 
improve the performance of your map services by caching them for rapid display at specific scales. You can now 
publish 3D globes, geoprocessing services that allow users to run models and workflows on the server, and geodata
ervices that enable users to perform database replication and synchronization. 9.2 also introduces out-of-the-box 
eb-based editing functionality and the ability to publish data in OGC WMS and Google Earth KML formats. The 
troduction of the new free ArcGIS Explorer client at 9.2 provides a new way to distribute your maps and globes to 

stom tasks that you develop. 

ls, full support for Microsoft .NET 
Framework 2.0 and Microsoft Visual Studio 2005, a set of Geospatial Enterprise JavaBeans (EJB), and more. ArcGIS 
S

rcGIS Server editions  

 
s
w
in
allow users anywhere to visualize and interact with your data, including accessing cu
 
Many enhancements have been made for developers, with numerous new contro

erver 9.2 also introduces a completely new framework for developing mobile GIS applications including support for 
integrated GPS, attribute and feature editing and wireless synchronization.  
 
 

A

ArcGIS Server 9.2 offers a scalable line of server product editions built on a common set of technology components 
that are distinguished by both functionality and capacity.  
 
The functionality in ArcGIS Server is provided via three different editions. See the diagram on the next page. 
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ArcGIS Server 9.2 functionality 

 

Replication
- Geodata services for replication 

Client applications 
-  Web mapping applications 
- ArcGIS Explorer 
- ArcGIS Desktop  

Application development 
- Web ADF (.NET & Java) 

and check in/out over web to 
ArcGIS Desktop clients 

Mapping 
- Map services 
- Geocoding services 
- OGC WMS support 
- Maplex support  
3-D services 
- Globe services 
- KML support 

- Custom ArcGIS Engine apps 
- Standard WMS and KML clients 
Geoprocessing 
- Geoprocessing services & tasks 
-  ArcView level GP tools only 

Basic Edition Standard Edition Advanced Edition 

Replication 
- Geodata services for replication 

and check in/out over web to 
ArcGIS Desktop clients 

Web-based GIS Web-based GIS Web-based GIS 

Optional server extensions 
- Network Analyst 
- Data Interoperability 

Optional server extensions 
- Network Analyst 
- Data Interoperability 
- Spatial Analyst 
- 3D Analyst 

Replication 
- Geodata services for replication 

Client applications 
-  Web mapping applications 
- ArcGIS Explorer 
- ArcGIS Desktop  

 level GP tool support 
- Full spatial analysis capabilities 

with optional extensions 

Web-based editing 
- Editing dialog in web mapping 

- Geospatial Enterprise Java 

and check in/out over web to 
ArcGIS Desktop clients 

Mapping 
- Map services 
- Geocoding services 
- OGC WMS support 
- Maplex support  
3-D services 
- Globe services 
- KML support 

- Custom ArcGIS Engine apps 
- Standard WMS and KML clients 
Geoprocessing 
- Geoprocessing services & tasks 
-  ArcInfo

application 
Application development 
- Web ADF (.NET & Java) 

Beans (EJB) 

ArcGIS Mobile ADF 
- Mapping with integrated GPS 
- Field data collection 
- Wireless synchronization 

Mobile GIS 

Geodatabase management 
 and editing 

or or ArcInfo on 
eate & edit data 

-  Multi-user access
- Requires ArcEdit

the Desktop to cr

ArcSDE 

Geodatabase management 
-  Multi-user access and editing 
- Requires ArcEditor or ArcInfo on 

the Desktop to create & edit data 

ArcSDE 

Geodatabase management 
-  Multi-user access and editing 
- Requires ArcEditor or ArcInfo on 

the Desktop to create & edit data 

ArcSDE 
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Each of these three functional editions is provided at two separate levels, scaled according to capacity: 

A
 socket with 

nterprise. This provides the greatest capacity and can scale to databases of any size and number 
 on computers of any size and configuration. It includes Enterprise ArcSDE technology, the 

 outlines the full differences between these levels. 

 
 
So for example, the lowest cost ArcGIS Server configuration is ArcGIS Server Basic edition at the Workgroup level. 
This gives you the Workgroup ArcSDE technology so you can create multi-user geodatabases on one machine that up 
to 10 concurrent users can access and edit. This configuration doesn't allow you to serve maps, etc, to the web.  
 
At the other end of the scale, our most comprehensive and powerful ArcGIS Server configuration is ArcGIS Server 
Advanced edition at the Enterprise level. This gives you unlimited capacity to serve geographic data and tasks 
throughout your organization, over the web, and onto mobile devices, with the complete range of functionality including 
web-based editing and ArcInfo-level spatial analysis. 
 

 
- rcGIS Server Workgroup. This runs on Windows only and includes Microsoft SQL Server 2005 Express Edition, 

which is the DBMS supported by ArcSDE at this level. This is limited to run on a single computer (1 CPU
one or two cores).  

 
- ArcGIS Server E

of users, running
traditional ArcSDE technology that runs on Oracle, SQL Server, DB2, and Informix. This can run on one or more 
computers. The base license is for 2 sockets, with additional licensing in increments of 1 socket. 

 
he diagram belowT

ArcGIS Server 9.2 capacity 

The remainder of this chapter describes what's new with publishing services and applications on the web with 
ArcGIS Server. See the 'Geodatabases and ArcSDE' chapter in this document for more about what is new in 
geodatabase management with ArcSDE at 9.2.  

ArcGIS Server 
Workgroup 

ArcGIS Server  
Enterprise 

Oracle, DB2, SQL Server, 
SQL Server Express Informix DBMS for ArcSDE 

Windows Windows, Solaris, Linux Operating system 

Maximum concurrent 10 Unlimited 
users on ArcSDE 

1 
Unlimited 

(Base license = 2) 
Sockets 

(Single or dual core) 

4 GB Unlimited ArcSDE database size 

1 GB Unlimited ArcSDE memory limit 

Direct Connect 
Direct Connect and Application 

Server ArcSDE configuration 

Unlimited Number of users over the 
Web 

Unlimited 
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Easier server administration 

You can use the new ArcGIS Ser
dminister your server. You’ll find the Manag

ver Manager to publish GIS services on the web, create web applications, and 
er to be an easy way to accomplish everything you need to do with 

A
a

rcGIS Server. The Manager runs inside a web browser and includes access to the ArcGIS Server Help system: 
 

 
 

In 9.2, you can organize the contents of your ArcGIS server into different folders.  
 

ArcCatalog has also been updated at 9.2 to make it easier to connect to ArcGIS servers and create services on 
them. One of the things you’ll immediately notice when you connect to your ArcGIS server is that you’re now asked 
what type of connection you want to make: 
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The format of the URL you use to connect to ArcGIS servers over the Internet has also been simplified. You no 
longer have to specify .agsx, etc. All you have to type in is http://<server>/arcgis/services, e.g. 
 
   http://www.example.com/arcgis/services 

 server in ArcCatalog, you'll see the services and the optional folders that they may be 
ant to connect directly to an individual folder on a server when you connect to it in ArcCatalog, 

end /<folder name> after /services, e.g. 

ple.com/arcgis/services/world 

 
When you connect to a
organized into. If you w
simply app
 
  http://www.exam 
 

To make it easier to publish your GIS resources, such as your maps and globes, to the server, there’s a new 
ublishing wizard in ArcCatalog. Simply navigate to the document you want to publish and right-click ip t. You’ll see the 

new option to publish it to the server: 
 

 
 
In the wizard that appears, just fill in the name of the ArcGIS server you want to publish to (that you’ve connected to as 
a manager), provide a name and folder location, and enable the GIS functionality, or capabilities, you need: 
 

 
 
 

New ways to publish your GIS data 

Previous versions of ArcGIS Server only allowed you to create map services and geocoding services. At 9.2 you 
c

and 
an also create globe services, geoprocessing services, and data management services called geodata services. In 

addition to these new service types, map services now have capabilities to support network analysis and the WMS 
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KML specifications. 9.2 also introduces the ability to publish high performance map services by caching them for use 
at particular scales. 
 
 
High performance cached map services 
 

You can now greatly improve the drawing speed of map services you publish by creating caches for them. The map
cache consists of pre-created images of the map service at specific scales. These image

 
s are stored on the server and 

turned to clients that want to draw the map service. Map services with a map cache will draw much faster than those 
ithout a cache because the server simply returns one or more pre-created images to the client instead of dynamically 

t.  

og. 

re
w
creating one at the time of the reques
 
To create a cache for a map service, you use the new Caching tab in the Map Service Properties dialog in ArcCatal
This lets you specify the different scales at which you'd like the service to be cached: 
 

 
 
New tools are also provided in ArcToolbox for creating map caches for a map services. 
 
 
Globe services  
 

ArcGIS Server now supports publishing globe documents (.3dd) over the web as globe services. Users can access 
e, ArcReader, and ArcGIS Engine applications built with the Globe control. 
apping applications built with ArcGIS Server Manager). Globe services are 

c

ever, you  need the 
D  ArcGIS Desktop in order to author globe documents using ArcGlobe. 

 
The client is particularly 
pow liver interactive globes containing exactly the content you want onto the Internet, whereas 
solu
wor n 
aug ssing 
serv es enables advanced analysis and workflows to be performed directly in the 3D client. 

globe services in ArcGIS Explorer, ArcGlob
Globe services are not supported in web m(
ached for high performance using the caching mechanism of ArcGlobe, which is carried over to the server. Globe 

services also contain the animation tracks present in the globe document that was published. 
 

he 3D Analyst extension is not required on ArcGIS Server in order to publish globe services. HowT
3 Analyst extension on

 ability to publish globe services to the web for access with the new free ArcGIS Explorer 
erful. This lets you de
tions like Google Earth are limited to a single standard globe onto which additional content is added. In other 
ds your users can choose between a variety of application-specific globes containing particular datasets, and the

ent these globes by add additional data sources. Plus, ArcGIS Explorer's ability to access geoprocem
ic
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Ge
 

oprocessing services 

G
be r
erv s tasks. Geoprocessing services can 
ls

Ge
 

eoprocessing is a fundamental part of every phase of GIS. Now, the functionality available in the ArcToolbox can 
un on servers and served over the web as geoprocessing services. End users can access your geoprocessing 
ices in web mapping applications and in the new ArcGIS Explorer client as

a o be accessed inside ArcGIS Desktop by adding them into the ArcToolbox window. 
 
 

odata services 

A at 
geo  performed. A geodata service may be published 
for a ding ArcSDE geodatabases, personal geodatabases, and file geodatabases. 
 
Wh a map document that has a layer with a 

eodatabase connection. If you start with a map document, enable geodata access support on a map service by 
, the service can be used to 
tion. If you choose to publish a 

in 
 

 geodata service allows access to a geodatabase through the LAN, WAN, or Internet using ArcGIS Server so th
atabase replication, synchronization and data extraction can bed
ny type of geodatabase inclu

en publishing a geodata service, you can start with a geodatabase or 
g
checking the Geodata Access capability when you publish the map. Once published

ccess a geodatabase remotely and perform operations such as replica synchronizaa
map document with a geodatabase connection, you can perform geodata service operations on the data published 
the map service from ArcGIS Desktop. For example, you can add the data from the map service to ArcMap and then
use the distributed geodatabase toolbar to create replicas and extract the data. 
 
 
Network Analysis support: routing, closest facility, and service area analysis 
 

You can publish map documents containing network analysis layers to create map services with network analysis 
apabilities. Use these services to perform routing, closest facility and service area network analysis. You can enable 

e by checking the Network Analysis capability when you publish the map. 
er at 9.1, but it required a lot of custom code.  

support 

c
network analysis support on a map servic

ou could perform network analysis with ArcGIS ServY
 
 

ML K
 

ArcGIS Server now outputs KML, enabling the server to communicate with KML clients such as Google Earth. You 
an enable the KML output on a map service by checking the KML capability when you publish the map. 

 

c
 
 
WMS support 

ArcGIS Server now outputs OGC WMS versions 1.0.0, 1.
ith WMS clients. You can enable the WMS output on a ma

1.0, 1.1.1, and 1.3.0, enabling the server to communicate 
p service by checking the WMS capability when you 

p

t

w
ublish the map.  

 
 
O her 
 

The ArcGIS Data Interoperability extension (see separate section in this document) is now available with ArcGIS 
Server. The ArcGIS Data Interoperability extension provides real data interoperability that works with all major vendor 

nd open GIS formats and is dynamically updated to add additional formats or variations as they becoma e available. 
T S he extension enables GIS users to dynamically fuse together various data sources within ArcGIS and allows ArcGI
users to exchange data with other GIS users in many formats as well. 
 

The Maplex extension enables high quality automatic placement of labels. Map documents published to the server 
that contain labels generated by Maplex will now display with those labels intact. 
 

Map services published with ArcGIS Server can contain cartographic representations. 
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New client applications for Server 

Web mapping applications 
 

ArcGIS Server 9.2 makes it easy to create web mapping applications using the geographic information on your 
erver. The ArcGIS Server Manager contains a great looking ready-to-use application template that you can quickly s

configure through Manager’s easy-to-use wizard interface, which requires no web development expertise. Here's what 
the application looks like: 
 

 
 
Supporting controls like the table of contents, overview window, etc are presented in collapsible side panels that can 
be

 
 

 easily hidden away if end users want a full screen view of their map. Various tools and shortcuts are provided, 
including click-and-drag to pan the map, using the scroll wheel on the mouse to zoom in and out, and expandable 
popup map tip windows for finding out about points of interest. The application supports high performance drawing with
seamless panning.
 

You also use Manager to choose and configure the functionality you want your application to include. These are 
presented in the tasks panel in the application. For example, the application shown above presents a number of tasks
in its top left hand corner. The

 
 task panel provides one place from which all the additional functionality exposed in your 

application can be launched, keeping the application's interface simple and uncluttered. 
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Manager comes with out-of-the-box tasks tha
an before to add functionality to your appli

t you can incorporate into your application. This makes it much easier 
cation. You can configure these tasks to make them specific to your 

p

h

th
a plication and your data. ArcGIS server includes ready to use tasks for: 
 
- finding map features, addresses and places 

- querying attributes 

- editing 

-  geoprocessing 
 
Each task has its own specialized dialog. When you configure tasks you link them up to the underlying services that 
they'll access. For example, each geoprocessing task you define accesses a geoprocessing service. 
 
T e screenshot below shows the panel for the editing task: 
 

 
 

Previou
can combi ces on a single map allowing you to seamlessly integrate map services running on the 

sly, ArcGIS Server allowed you to build a web application that displayed a single map service. In 9.2 you 
ne multiple map servi
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same serv or 
example, ith one running on an ArcIMS server. You 
can add s  OGC WMS services. 
This inclu ided by ESRI as ArcWeb Services. 
 

er or different servers. Transparency is supported so you can overlay and 'fuse' different map services. F
you can combine a map service running on an ArcGIS server w
ervices from any ArcGIS server or ArcIMS server into your application, along with any
des the various services prov

This sa ion template is included with ArcIMS at 9.2, greatly simplifying the use, support 
and devel cations. Tasks based on ArcIMS functionality are included but the editing task and 
tasks bas rvices require the use of ArcGIS Server. 
 
 
New Arc

ArcGIS Ex be 
services t plorer is fast and easy, with smooth and seamless panning and 

ng. Users can combine your services with other sources of data. ArcGIS Explorer lets users work in both 2D and 
D. ArcGIS Explorer also supports a range of different tasks, with support for tasks based on geoprocessing services. 

me web mapping applicat
opment of your web appli
ed on geoprocessing se

GIS Explorer client 
 

plorer is a new lightweight desktop client that makes it easy for users to access map services and glo
hat you publish. Working with ArcGIS Ex

zoomi
3

See the 'ArcGIS Explorer' chapter in this document for more details. 

 

upport for accessing and using ArcGIS map services has been improved in the ArcGIS Desktop applications (

 

ArcGIS Desktop client enhancements 
 
S See 

ng services you publish with ArcGIS Server can be added into the 
ew server-based toolboxes. This includes support for models that 

ccept graphical input. So for example, you can publish a spatial analysis model as a geoprocessing services that 
A

the 'ArcMap' chapter in this document). Geoprocessi
ArcToolbox window in the Desktop applications as n
a

rcGIS Desktop users can access over the web and run from the ArcToolbox window in which they draw features on 
the map and have these used as input to the model. See the 'Geoprocessing' chapter in this document. 
 
 

Developing applications with ArcGIS Server 

Sin d ArcIMS 
 

gle Web ADF works across ArcGIS Server an

T ork (ADF) has been completely re-architected at 9.2. Previously, the Web 
ADF
and A b Services from 
ESRI can also be incorporated into applications (requires appropriate licensing from ESRI). In this way, the Web ADF 
provides one framework for building web applications and services no matter what services you need to use. This 
simplifies your development experience because you can focus on what you want to deliver to users and not worry 
about which server is hosting the services you need to include in your application. 
 
 
New and enhanced web controls 
 

he Web Application Developer Framew
 only supported building applications with ArcGIS Server. Now the Web ADF includes support for ArcGIS Server 

rcIMS and is part of both products. OGC WMS services are also supported. The range of ArcWe

As part of the new Web ADF, a number of new controls have been added to support the development of 
applications using the framework provided by the new web mapping application. The functionality encapsulated in the 
web controls makes it easy for you to develop your own applications. Here's a list of some of the new controls: 
 

Map Tips control  
Displays information about points on your map when you hover the mouse over them. 
 
Navigation control  
A new navigation control incorporates pan and zoom functions within a single control. You can use this control 
instead of or in addition to the classic pan and zoom controls that are typically placed on the toolbar. 
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Geocode component  
Simplifies access to a geocode service allowin
on any supported GIS server. 

g a web application to locate addresses. Supports geocode services 

 
ZoomLevel  

 Provides a set of levels, or map scales, representing different extents the map control can zoom to, corresponding
to the scales at which the map services being used have been cached.  

 
The existing controls have been enhanced and rewritten, including the following changes: 

ow supports displaying multiple map services. The map services are transparently overlaid and appear as group 
the 

croll wheel on the mouse, and keyboard navigation shortcuts. 

able of Contents control  
yers.  

 
 

 
Map control  
N
layers in the table of contents. The map control also supports continuous, seamless panning, zooming with 
s
 
T
Now supports the display of multiple map services as group la

Support for existing ArcGIS Server 9.0 and 9.1 web applications 
 

Because the ArcGIS Server web application architecture has been completely re-defined, the new web mapping 
applications are completely different from those you built with 9.0/9.1. However, this doesn't mean you can't run
applications you've already built. ArcGIS Server includes runtime support for existing applications and they'll continu
to work as you expec

 the 
e 

t. But, there is no longer any IDE or documentation support for the 9.0/9.1 applications. When you 
dit one of your existing applications in 9.2, you'll still see the 9.0/9.1 web controls in that application, you just won't be 
ble to create new applications with those controls because they're no longer available by default in the Toolbox; only 

the new web controls are there. 
 
 
Changes on specific platforms 
 

e
a

The next two sections of this chapter tell you what's new on the two ArcGIS Server platforms: Microsoft .NET and 
Java. 
 
 
 

ArcGIS Server for the Microsoft .NET framework 

Web Application Developer Framework (ADF) 
 

Microsoft Visual Studio 2005 IDE Integration: The Web ADF web controls, templates and Developer Help have 
all been completely integrated with Microsoft Visual Studio 2005. 
 

Complete ArcIMS API for the Microsoft .NET Framework: The ArcIMS API wraps all ArcXML functionality into a 
complete .NET solution for ArcIMS devel rt of the Web ADF, the ArcI contains classes that allow 
ou to drill down into ArcIMS services a ou make available in your web applic tions. This means that you can 
reate ArcIMS solutions completely in the .NET Framework, without having to write ArcXML requests. 

opers. As pa MS API 
 th t y ay

c
 

New graphic display capabilities: The Web ADF now supports the ability to draw graphic elements on the map 
ontrol. See the GraphicsLayer class in the ESRI.ArcGIS.ADF.Web assembly for more information. 

 
c
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Developing custom server components 
 

Previously, the recommended way to efficiently execute your custom GIS functions on the server was to create a 
simple utility COM object in VB, C++, or .NET that encapsulated the majority of the fine-grained ArcObjects work and 
exposed a single coarse-grained method that a web application could call. Now, you can alternatively create a server 

ility COM objects, server object 
xtensions are registered and configured with specific server objects and are not meant for ad-hoc use or use with an 

e

oftware Installation 

object extension that extends the server object itself with your custom code. Unlike ut
e
mpty server context. 

 
The main advantage of creating a server object extension is that doing so allows the server to initialize and manage 
the extended functionality along with the core server object. Thus, developers don't need to initialize server object 
extensions in their own code. Also, if the functionality required by a server object extension is costly to acquire, such 
as connecting to a database, this cost is paid only once when the server object and its associated extensions is 
initialized. 
 
 
S
  

.NET Framework Support: ArcGIS Server for the Microsoft .Net Framework requires the Microsoft .NET 
Framework 2.0. 
 

Install: A new install feature named Web Applications has been added. The Web Applications feature adds to your 
web server the ability to create and manage Web Mapping Applications, ArcGIS Explorer Maps and GIS Web 

ervices. The ArcGIS Server Manager is installed with the Web Applications feature. S
 

ArcGIS Server Post Install: The ArcGIS Server Post Insta
e wording has been changed and there is a new dialog for creatin

ll has been renamed to GIS Server Post Install. Some of 
g a GIS Server Web services account. This 

a
th
ccount is used by your Web server to connect to an ArcGIS server in order to process Web service requests. You will 

need to specify the exact same account for your GIS Server Web Service account in the GIS Server Post Install and 
the Web Applications Post Install. 
 

Web Applications Post Install: A Web Applications Post Install has been added. This post install will prompt for 
e name of your ArcGIS Server Instance (“arcgis” by default) and the name of your ArcGIS server. You will also need 
 provide the GIS Server Web Services account that you specified during the GIS Server Post Install. If you are 

software on a single machine, you should choose the Existing Local or Domain 
e account that was created during the GIS 

 
 

rcGIS Server for the Java platform 

th
to
installing all of the ArcGIS Server 
Account during the Web Applications Post Install and specify the sam
Server Post Install.  
 

A

Web Application Developer Framework (ADF) 
 

Support for Java 5.0: Java version 5.0 is now supported. The Web ADF components are now certified to run in 
ap at support Java 5.0. 
 

plication servers th

Support for Eclipse and Sun Java Studio Creator: ArcGIS Server for the Java Platform provides tight integration 
w se plug-ins give developers a very rich programming 
ex ated help, wizards, code snippets, importable samples and templates for building ArcGIS-based 
w
 

ith plugins for Eclipse and Sun Java Studio Creator IDEs. The
perience with integr

eb applications. 

Web Graphics API: The Web Graphics API is a pure java library for adding graphics to a Map Control. This API is 
useful for building red-lining capabilities into your GIS applications. It supports points, lines, polygons and text and a 
number of different symbols. 
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Geospatial Enterprise JavaBeans 
 

At 9.2 ArcGIS Server for the Java platform introduces
that perform GIS tasks such as mapping, geodata queryi

 a set of out-of-the-box Geospatial Enterprise JavaBeans™ 
ng, network solving, geocoding, print-layout management, 

and more. Enterprise JavaBean (EJB) technology is the server-side component architecture for the Java 2 Platform, 
Enterprise Edition (J2EE) platform. EJB technology enables rapid and simplified development of distributed, 
transactional, secure and portable applications based on Java technology. The Geospatial EJBs support the EJB 2.1 
sp

e Web ADF for Java didn’t provide. The Web ADF provided a hook into ArcObjects, and Java developers had to 
velopers 

ecification. 
 
Until now, Java developers have had to learn ArcObjects in order to perform more sophisticated GIS operations that 
th
program in ArcObjects. Now, with these new EJBs, we are exposing more GIS functionality so that Java de
can manipulate these directly with a pure Java API instead of programming in ArcObjects. 
 

This suite of Geospatial Enterprise JavaBeans make all the functionality of the ArcGIS MapServer and 
GeocodeServer objects available to J2EE enterprise applications. These capabilities are available on a transactional 
basis for on-demand queries. Here are the capabilities that are supported: 
 

Mapping: 
- Export MapServer Object maps as images at any given map extent/scale. 
- Export MapServer Object maps as images at a given image size (reasonable). Supported image formats 

will be png, jpg, bmp, wbmp, gif, png24. 
- Export MapServer Object maps as images in any of the ArcGIS Server supported image formats. 
- Compute the distance between 2 points on a map. 
- Coordinate System Conversion and Map Projection Transformation support. All projections, spheroids and 

datums supported by ArcGIS. 
- Convert a map coordinate to a screen location. 
- Convert a screen location to a map coordinate. 
- Return references to a layer or a collection of layers in a map. 
- Get information about the bean’s MapServer Object. 
- Get the dimensions of the MapServer Object. 
 
On-demand performance is rated at 7 map images/second, 16 vector maps/second, and 25 coordinate 
systems and/or map transformations/second on Windows 2000, 1.7GHz dual processor Pentium III with 
1GB RAM. 

 
Queries: 

- Perform query/Identify actions against layers in a map. 
- Return a field value of a given feature on the map. 
- Return feature objects in a given layer of a map. 
 

Geocoding: 
- Geocode a single address, using any of the ESRI-supported geocoding styles. This will support full 

address inputs as well as partial address inputs. The addresses can be an intersections.  
- Available on transactional basis for on-demand queries. 
- Geocode multiple addresses, synchronously. 
- Geocode a list of addresses in “batch” mode, asynchronously.  
- Return a list of candidates for an address. 
- Display the geocoding results in a map image provided by the MapServer EJB. 
- Reverse geocode a point to generate an address or zone name conventions. These could be centroids of 

regions or zones. 
 

On-demand performance is rated at 30 geocode requests/second on Windows 2000, 1.7GHz dual processor 
Pentium III with 1GB RAM. 

 
Network Analysis/Routing: 

 
The Routing EJB provides a convenient API that performs the following functions utilizing the 
NetworkAnalyst API: 
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- Solving transportation networks, and support for all solvers featured in the Network Analyst extension. 
- Managing stops and barriers along transportation networks. 
- Determining geographic regions (“trade areas”, for example) based on travel time. 
- Finding the shortest path. 
- Dijkstra routing. 
- Point-to-Point routing. 
- Multipoint routing. 
- Multimodal routing. 
- Support for considering real-time traffic and weather impedances. 
- International border crossing. 
- Support full address inputs for origin/destination. 

 
On-demand performance is rated at 7 route calculations per second on Windows 2000, 1.7GHz dual 
processor Pentium III with 1GB RAM.  
 

 
Command-line administration of your GIS Server 
 

Administrators of the ArcGIS Server system can now take advantage of a JMX-based command-line interface for 
starting, stopping, and configuring services. Because it is a JMX implementation, these administration tools can plug 
into other standard Java-based enterprise administration console systems. 
 
 
Developing custom server components 
 

A new utility has been added to the Server SDK to allow for programmers to write custom extensions to ArcObjects 
and the Server in a COM-compliant language, and expose these customizations as Java objects. 
 
 
Solaris and Linux Support 
 
The experience for both GIS professionals and developers for the Linux and Solaris platforms has been greatly 
improved at 9.2: 
 

- Re-designed installation and configuration experience. 
- Improved quality of performance, stability and installation user experience. 
- Improved SDK and documentation. 
- Pure UNIX-based user authentication to the system. The Windows PDC is no longer needed. External users of 

the system are now stored in an LDAP server and are no longer required to be OS-level users. 
 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  197 



New Mobile GIS ADF  

The Mobile GIS Application Development Framework (ADF) is a software development kit for mobile devices. The 
framework is intended for developers creating lightweight, easy-to-deploy, server-oriented applications that have a 

The Mobile GIS ADF can extend 

- You can embed a map in your mobile application. 

data can be captured and updated when connected or disconnected from the server. 

robust, responsive, and rich user experience on the client device used in the field. 
your mobile business application in the following ways: 
 

 
- Spatial and tabular 
 
- Edits in the field and in the office can be synchronized when connected. 
 
- GPS location can be captured or used as a navigation aid. 

 
The Mobile GIS ADF field editing model allows users to edit both existing versioned and unversioned databases 

tabases. The ADF can be deployed to two families of clients - Windows 32-
and Windows Mobile devices like Pocket PC and Windows CE devices. The 

Mobile ADF allows the development of occasionally connected applications on both platforms. With the Mobile ADF, 
us

stored in the server-side ArcSDE geoda
based clients like laptops or Tablet PCs 

ers have the ability to survive network outages without losing their work. Application logic can specifically be 
designed around sometimes connected scenarios for mobile computers as well as always connected scenarios for 
desktop computers. 
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Administering your ArcGIS server 

Setting the capacity for a server object container (SOC) machine  
 

The maximum number of instan
As more instances get created, mo

ces a SOC machine can host depends on the amount of memory on that machine. 
re memory is consumed. As SOC machines have a finite amount of memory, there 

is a finite number of instances that they can host. Now, you can manually control the maximum number of instances 
that can be 
A y 

run on a SOC machine by setting its capacity. Capacity is exposed as a property of a SOC machine in 
rcCatalog and can be set programmatically through the server API as well. In many cases, you don't need to worr

about setting capacity. However, in the event that you notice memory problems on a given SOC machine, one reason 
may be that you're running too many instances on it. In this case, you can set the maximum number of instances 
though its capacity. 
 
 
Accessing server log files programmatically  
 

While you could always view the contents of the server log files on disk with a text editor, you can now 
 a 

ogs 

s  

programmatically retrieve the contents. A new property, ServerLog, of the IServerObjectAdmin2 interface provides
reference to an IServerLog interface. The IServerLog interface allows you to query and retrieve records from the l
n disk. o

 
 
Pre-creating instances of non-pooled service
 

You can now set the minimum number of instances to create on initialization for non-pooled services. Just like 
pooled services, pre-created non-pooled services are immediately available for client use. By pre-creating services, 

mentation  

you can reduce the start up time for client applications that access them because the client doesn't have to wait for the 
server to create the object if one is already available. 
 
 
 

Better server docu

The ArcGIS Server Administrator and Developer Guide book has been replaced at 9.2 with the online ‘ArcGIS 
erver Help’ and ‘Developer Help’ systems.  

 
launch either from the Start menu or directly from 

ArcGIS Server Manager. 

rehensive source for information about the server. In addition to all of the information 
contains details on how to develop applications. You can launch Developer Help 
hin Visual Studio 2005. It includes the following sections: 

- Getting started 
- Migrating Applications 

eloping Mobile Applications using the Mobile ADF 
- Developer APIs 

S

- The ArcGIS Server Help is Web-browser-based help that you can 

 
- The Developer Help is the comp

from the ArcGIS Server Help, it 
from the Start menu, or from wit

- Developing Web Applications using the Web ADF 
- Dev

- Developer scenarios 
- Samples 
 
All of the ArcGIS Server developer documentation is now available on the ESRI Developer Network (EDN) web

at 
site 

http://edn.esri.com. Information provided on EDN connects you to code samples, the latest documentation, 
iscussion forums, and much more. d
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ArcGIS Explorer  

A c bles anyone to access GIS data over the Internet, work with it in 
3 nalysis drawn from the range of geoprocessing 
c
 
ArcGI
geo t 
usin
serv , etc. End-users working with ArcGIS Explorer 
can ices or on local data, 
incl
 
Ge imply 

r GIS Explorer is a new, free application that ena
D, integrate it with web and local data, and perform queries and a
apabilities found in ArcGIS. 

S Explorer is fully integrated with ArcGIS Server and is a great way to deliver the maps, globes and 
processing services that you publish with ArcGIS Server to users around the world. You can assemble the conten
g data from your own servers or from any other GIS services accessible on the web: ArcGIS services, ArcIMS 
ices, ESRI ArcWeb Services, OGC WMS, Google Earth KML/KMZ
 further customize their display by adding additional layers based on any of those serv
uding shapefiles, file geodatabase data, and a wide variety of raster files.  

oprocessing services appear as tasks in the ArcGIS Explorer user interface, enabling users to go beyond s
browsing to using and analyzing data. 
 

       
 

       
 
For m sexplorer.comore about ArcGIS Explorer and to download the program, go to: http://www.arcgi
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ArcIMS 

Creating web mapping applications 

Ne
 

w Web Manager 

A r creating web mapping applications. The Web Manager provides step-by-
step in cess of building web mapping applications. The Web Manager has the 
s

 

rcIMS 9.2 introduces a Web Manager fo
structions that guide you through the pro

ame look and feel as the new ArcGIS Server Manager. The ArcIMS Web Manager comes in two versions ArcIMS 
Web Manager for the Microsoft .NET Framework, and ArcIMS Web Manager for the Java Platform. 
 
 
New web mapping application 

At 9.2, ArcIMS utilizes the same new out-of-the-box web mapping application template that is included with ArcG
Server. So wh

IS 
ether they include services from ArcGIS servers or ArcIMS servers or both, your web apps can have the 

ame appearance and behaviour. The web mapping application supports seamless panning, zoom with the mouse 
wh ents with symbology, and a task panel presenting the 
add ality, such as searching for attributes, 
are elopment 
exp
 

s
eel, keyboard navigation, a fully functional table of cont
itional functionality you choose to include. Tasks based on ArcIMS function
included. All configuration is performed using a wizard in the ArcIMS Web Manager, so no web dev
ertise is required. 
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The web mapping application lets you combine multiple map services onto a single map allowing you to seamlessly 
integrate map services running on the same server or different servers. Transparency is supported so you can overlay 

 can add ArcIMS image services, ArcGIS Server map services and any OGC 

 
 

and 'fuse' different map services. You
WMS services into your application. 

New Web ADF 

At 9.2, ArcIMS in
integrated support fo

cludes a new Web Application Developer Framework (Web ADF). The new Web ADF includes 
r both ArcIMS and ArcGIS Server and is part of both products. Like Web Manager, the Web ADF 

is available for the Microsoft .NET Framework and for the Java Platform. When using the Web ADF, you can work with 
image services, services from ArcGIS servers, OGC WMS services, and ESRI ArcWeb Services  
 

s a developer, you have access to a full set of mapping-related Web controls and an API that wraps ArcXML 
func t from Web 
Man
con
 
Th ding Getting 
Started guides, detailed API discussions, Scenarios and Samples, and Library References. 
 
 
Web ADF for the Microsoft .NET Framework 
 

A
tionality. Since the Web Mapping Application is built using these components, you can take the outpu
ager into an Integrated Development Environment (IDE) and modify the output. You can also use the Web 

trols and build your own application from scratch.  

e Web ADF includes comprehensive online support via the ESRI Developer Network (EDN), inclu

The .NET 2.0 framework is required. Visual Studio 2005 or Visual Studio Web Express Edition must be installed to 
work with the Web controls and templates.  
 
The Web ADF also includes a .NET ArcIMS API, which replaces the .NET Link. The API has an object model that 
comprehensively wraps all ArcXML functionality. The exception at ArcIMS 9.2 is that Metadata elements are not part of 
the API.  
 
 
Web ADF for the Java Platform 
 

The Web ADF for the Java Platform uses Java Server Faces (JSF), which provides the framework for the Web 
controls and tasks. The Web ADF uses the Java Connector for communication with ArcIMS services. While developers 
can use any IDE that supports JSF, the recommended IDE's are Eclipse or Sun Studio Creator.  
 

For those who use Metadata Services, a new, ready-to-use Metadata Explorer application based on the Web ADF 
for the Java Platform is provided for accessing Metadata Services.  
 
 

Spatial Server 

The Spatial Server has been updated to improve performance and stability. The following enhancements have been 
made.  
 

Image services and ArcMap image services will not include geometry by default in the response to a 
GET_FEATURES request if the output mode is binary. With this change, ArcMap cannot be used to download vector 
data served in ArcIMS without the knowledge of the service provider. ArcIMS administrators have the option to allow 
geometry when the output mode is xml or newxml, to allow geometry for all cases, or to disallow geometry for all 

ses.ca See the 'ArcMap' chapter in this document.  
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The Spatial Server will stop processing a request if the Application Server times out. This should make Spatial 
Server instances available more quickly for new requests.  
 

Support for projections has been upgraded.  
- Many projections that did not work at all or worked incorrectly are supported.  

- If a service uses a datum transformation, the datum transformation will be honored, even if the request does not 

 

- More datum transformations are supported.  

include any datum transformation information.  

The following improvements have been made for data support.  
- To support faster service creation time of very large ArcSDE Raster catalogs, a server parameter has been 

er 
rows are loaded by demand when that portion of image is first requested.  

ries using IN 
and OR.  

  
- On Solaris platforms, the 256 file handle restriction has been removed.  

added to disallow preloading the entire catalog into a cache. The initial service creation time is less and rast

- Support was added for using attribute indices with shapefiles. This improves performance of que

- Querying shapefiles with mixed case field names is supported.  
- Query responses return geometry of polygon features containing a hole correctly.

 
Additional font directory locations for the Spatial Server can be specified. This allows the Spatial Server to 

utomatically locate ESRI fonts, system fonts, and other fonts in a specified directory.  
 
a

Spatial Server log files have been updated.  
- Log files can now be output in XML and CSV format in addition to the existing text format..  
- The time logged in Spatial Server log files is synchronized with the local system time.  
 

ArcMap Image Services support the following ArcMap functionality:  
- Reading file geodatabases  
- Maplex labeling  
- Cartographic representations  
 

ArcMap Image Services have the following improvements:  
- Domain descriptions, Subtype descriptions, and field aliases set in the ArcMap document or geodatabase are 

- Definition queries are supported in requests. Layers containing the results of a definition query can be 

 layers are identified when requesting service information.  
 

returned in query responses. The GET_FEATURES request must included outputmode="newxml".  

dynamically rendered using SIMPLERENDERER.  
- Annotation, multipatch, and group

When using Extract Server, if there are no layers to extract in a request, an error message is returned instead of 
returning an empty zip file.  
 

Support has been added for new geocoding styles: World Cities
with City, State and Zip.  

 with Country, US Cities with State and US Streets 

 
 

Administrator 

Dynamic logging can be enabled and disabled from the ArcIMS Administrator Tools menu without restarting. 
 
 

Author 

 Direct connect is supported in Author for accessing ArcSDE layers.  
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Metadata Services 

 M the Web ADF for the Java Platform. Existing JSP-based Metadata 
Explorer a
Explorer sam eenshot of the new Explorer: 
 

etadata Explorer has been updated to use 
pplications will continue to work with ArcIMS 9.2, but the Metadata Explorer and Advanced Metadata 

ple included in ArcIMS 9.1 are no longer available. Here's a scr

 
 

 In the Metadata Service configuration file, you can set the following attribut
hen the Metadata Service tables are create

es:  
d in the database.  

cuments uncompressed in the database.  
- A DBTUNE keyword to use w

o- A toggle to store metadata d
- A custom XPath index definition file.  
 

 Search results can be ordered by the d
est to oldest or oldest to newest.  

ate when the metadata documents were published or updated, either from 
ewn

 
 N unique constraint placed on the Doew metadata services have a 

b
cUUID column in the Metadata Service business 

tabl le. This eliminates the possibility of duplicate records.  
 

e and its associated deleted ta
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 Contents of the feature class associated with a Metadata Service can be previewed, but not copied or pasted, in 
rcCatalog.  

 
A

 The CSW Connector has the following new features:  
ector to support alternative CSW profiles.  

similar to the WMS and WFS Connectors.  
een added for two CSW profiles: OpenGIS® Catalogue Services Specification 2.0 - 

ile for CSW 2.0 and OGC Catalogue Services - ebRIM (ISO/TS 15000-3) 
profile of CSW.  

- It is easier to extend the conn
- The connector has a new Web administration page, 
- Support has b

ISO1915/ISO19119 Application Prof

 
 New RDBMS support for Metadata Services includes SQL Server 2005 and SQL Express with Advanced Services 

ith either Enterprise ArcSDE or Workgroup ArcSDE.  
 
w

 The following changes have been made to the gazetteer:  
 

ovided on a separate disk with the ArcIMS product. The data 
ed directly from the disk or copied locally.  

l as U.S.-only subset of the gazetteer places.  
- ArcSDE export files containing pre-loaded Gazetteer Metadata Services continue to be provided along with 

E export files have been improved; they continue to be provided with the ArcIMS 

 

Connector 

- Data to support a Gazetteer Metadata Services is pr
can be access

- A world gazetteer is provided as wel

shapefiles containing the source gazetteer data.  
- Scripts for loading the ArcSD

install.  
 

WMS 

The WMS Connector has OGC Styled La
to define symbolization of a map. The XML f

yer Descriptor (SLD) support. SLD uses a Styled Layer Descriptor XML file 
ile must follow the SLD schema as defined in the OGC Styled Layer 

Description Implementation Specification. You can use your own XML file or reference an XML file at a different 
location. The file reference must be included in the WMS GetMap request URL or as an embedded XML fragment.  
 

Requests to WMS-enabled services will honor the datum transformation parameters set in the service.  
 

A problem with messages about invalid SRS values in GetMap requests has been resolved.  
 

WFS Connector 

The WFS Connector has OGC Filter encoding support. With Filter support, you can describe a set of features on 
which to operate. The OGC Filter is defined in the "OGC Filter Encoding Implementation Specification".  
 
 

ArcXML 

The following are some highlights for ArcXML.  
 

- Support has been added for requesting acetate objects such as a scale bar in a separate image.  
- The scale dependency set for a layer or label can be requested as a relative scale rather than units per pixel.  
- For Image Services, the relative scale of the map can be requested along with the image.  
 

For a complete list of updates to ArcXML, refer to the ArcXML Programmer’s Reference Guide.  
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Internationalization/localization 

For the Metadata Explorer, locales that use a comma for a decimal delimiter will function correctly for searches.  
 

ArcXML builder for meta
 

data requests can be localized like the other map ArcXML builders.  

The layer name can be internationalized in the Active X Connector.  
 

Gazetteer Search can work correctly on locales that use a comma as a decimal delimiter (European locale).  
 

Able to render TIFF images using a comma as the decimal in the world file on non-English locales.  
 

Additional font directory locations for the Spatial Server can be specified. This allows the Spatial Server to 
utomatically locate ESRI fonts, system fonts, and other fonts in a specified directory.  

 
a

The WFS Connector has been internationalized.  
 
 

Documentation and online help 

ArcIMS documentation is accessible from one location and has been enhanced with new content and better 
organization. On Windows, the documentation is accessible from the Start menu. The list includes the ArcIMS Help, 
Errors and Warnings, ArcXML Programmer's Reference Guide, Metadata Services, WMS Connector, WFS Connector, 
and customizing guides.  
 

An overview section has been added that provides steps for creating a successful ArcIMS site.  
 

Checklists have been added that focus on best practices for ptimizing ArcIMS services and administering your site.   o
 

The Web ADF's have documentation installed when the respective ADF is installed. This documentation is separat
from the main ArcIMS documentation.  
 
 

e 

ArcIMS 9.2 installation notes 

Versions 9.0 and higher of ArcIMS must be registered before they can be used. The end result of the registration 
process is an authorization file that is used to enable the software for use. All users must obtain a 9.2 authorization
ile to enable ArcIMS 9.2, even if you had an author

 
ization file for an earlier release.  f

The Windows ArcIMS installation is separated into three parts. The first is for the core components such as the 
administrative tools and the server components. The others are for the Web ADF for the Microsoft .NET Framework 
and the Web ADF for the Java Platform. All features needed to support these frameworks have been moved to the
own setup programs.  
 

ir 

The UNIX and Linux ArcIMS installation id separated into two parts: one for the core components of ArcIMS and 
one for the Web ADF for the Java Platform.  
 

The documentation for the Web ADF for the Java Platform is on a separate CD and is installed separately.  
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A separate CD containing gazetteer data for Metadata Services is included with ArcIMS. This CD is in its own folder 
and is not part of the media kit.  
 

The core ArcIMS installation features for all platforms have been reorganized and offer the following:  
- Administration components including Author, Designer for the HTML, Java Custom and Java Standard Viewers

Administra
, 

tor, and Service Administrator  
- Manager that was included with ArcIMS 3.x, 9.0, and 9.1 has been removed from ArcIMS. Use the stand-

alone versions of Author, Designer, and Administrator instead.  
- Server components including the Application Server, Spatial Server, ArcMap Server, and Servlet Connector  
- Metadata solutions including connectors and applications  
- WMS, WFS, ActiveX, and ColdFusion Connectors  

- The .NET Link has been removed. It has been replaced by the ArcXML object library as part of the Web 
ADF for the Microsoft .NET Framework.  

 have been removed.  

- The Java Connector has been moved and is part of the Web ADF for the Java Platform.  
- Samples and tutorial data  

- World datasets from the sample data
 

The Web ADF for the Microsoft Framework CD contains the following:  
- ArcIMS Web Manager for the Microsoft .NET Framework  
- Web Application Developer Framework for the Microsoft .NET Framework, including the runtime components 

eand the software develop r kit. The ArcXML object library is part of the software developer kit.  
 

The Web ADF for the Java Platform CD contains the following:  

- Java Connector  
- Metadata Explorer  

 

- ArcIMS Web Manager for the Java Platform  
- Web Application Developer Framework for the Java Platform  

ArcIMS 9.2 ships with J2SE Runtime Environment 5.0 Update 6 on Windows, Solaris, and Linux, J2SE Runtime 
Environment 5.0 Update 3 on HP-UX, and J2SE Runtime Environment 5.0 on AIX.  
 

The Data Delivery Extension (DDE) is supported only on Windows platforms. For all other platforms, please contact 
SAFE Software.  

 

Platform, web server, and servlet engine updates 

New platform support:  
- RHEL (Red Hat Enterprise Linux) 4.0 
- HPUX 11.23 (PA-RISC)  

 
Support removed for 
- RHEL (Red Hat Enterprise Linux) 3.0 

 
Newly supported servlet engines and web servers for PC-Intel Windows:  
- Apache 2x with Tomcat 5.5  
- Oracle 10g R2 (10.1.2.0.1)  
- Sun Java System (Sun ONE) Application Server 8  
- WebLogic 9  
- Websphere Application Server 6.0  

 
Newly supported servlet engines and web servers for Sun Solaris:  
- Apache 2x with Tomcat 5.5  
- Oracle 10g R2 (10.1.2.0.1)  
- Sun Java System (Sun ONE) Application Server 8  
- WebLogic 9  
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- Websphere Application Server 6.0  
 

Newly supported servlet engines and web servers for Linux-Intel Red Hat:  
- Apache 2x with Tomcat 5.5  
- Oracle 10g R2 (10.1.2.0.1)  

- Websphere Application Server 6.0  
 

- Sun Java System (Sun ONE) Application Server 8  
- WebLogic 9  

Newly supported servlet engines and web servers for Linux-Intel SUSE:  
- Apache 2x with Tomcat 5.5  

 
Newly supported servlet engines and web servers for HP:  
- Apache 2x with Tomcat 5.5  
- Oracle 10g R2 (10.1.2.0.1)  
- Sun Java System (Sun ONE) Application Server 8  
- WebLogic 9  
- Websphere Application Server 6.0  

 
Newly supported servlet engines and web servers for IBM AIX:  
- Apache 2x with Tomcat 5.5  
- WebLogic 9  
- Websphere Application Server 6.0  

 
For a list of all supported platforms, servlet engines, and Web servers, see the System Requirements for ArcIMS 

document. 
 
 

Deprecation Notes 

As ArcIMS adds new features and functionality, older components are marked for depre
that a particular feature is completely supported but may be removed i
re from ArcIMS unless there is a new feature to replace it. 

cation. Deprecation means 
n a future release. Features are not normally 

moved 

eatures deprecated in ArcIMS 9.2 
 

 
F

The following features are deprecated in ArcIMS 9.2. They continue to be fully supported; however, they may be 
removed in a future release: 
 
- ArcSDE connection administration in the Service Administrator (not the entire Service Administrator)  

Java Viewer API for use with the Java Custom Viewer. Note: The Java Custom Viewer itself is not being deprecated.  
- ActiveX Connector  
 
Features removed from ArcIMS 9.2 
 

- 

The following features have been removed from ArcIMS 9.2: 
 
- Browser-based ArcIMS Manager available in ArcIMS 3.x, 9.0, and 9.1. You will need to use the Author, Designer, 

and Administrator applications. For remote management, the Service Administrator is available. This Manager 
should not be confused with the ArcIMS Website Manager, which is a new feature.  

- Metadata Explorer and the Advanced Metadata Explorer sample are no longer available from the setup. They have 
been replaced with a new Metadata Explorer that takes advantage of features in the Web ADF for the Java Platform.  

- The ArcXML elements AVIMSWORKSPACE, MOIMSWORKSPACE, GET_USER, and PUT_USER.  
- World and cities shapefiles from the sample data.  
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Extensions 

3D Analyst  

ArcGlobe enhancements 
 

When you add data into ArcGlobe, a new wizard now appears to help you make key decisions about how the data 
should be handled in ArcGlobe: 
 

 
 
This wizard reduces the amount of time it takes to create a 3D view and provides instruction on which properties are 
mportant for different layer types. The panels that appear in thi e wizard vary with the type of data being added. The 
wizard doesn't appear if the data being added has no 3D options or if it already has 3D display properties, such as a 

-

layer file (.lyr) file already created with ArcGlobe. 
 
This wizard is turned on by default but you can disable it using a check box on the wizard. If you disable it you can re
enable it using an option in Tools > Options dialog Messages tab. 
 

The order of the tabs in the ArcGlobe Table Of Contents has been changed so that the Type tab is now the first tab, 
instead of the Display tab. The new tab order is Type, Display, Source. This was done to highlight that a layer’s type 
(Floating, Draped or Elevation) is the most important property for displaying it in ArcGlobe. You also define the draw 
order of all draped layers on the Type tab. 
 

The same improvements to ArcMap's Find dialog have been made in ArcGlobe too. This includes the ability to find 
ddresses in the USA, a Canada and more than 15 European countries using new web services that are built into the 

r 
 

inder tab in the Find dialog has been renamed to be just the Places tab and it uses a new place finding service with 
improved performance. 
 

dialog. All you need to use these is an internet connection. This enhancement means that you can now search fo
ddresses without having to load an address locator into your globe document first. In addition the ArcWeb Placea

F

The same improvements to ArcMap's Identify tool have been made in ArcGlobe too. Both applications now use the 
same ArcGIS Engine-based Identify tool. 
 

The Swipe tool in the 3D Effects toolbar now works on group layers and now supports holding down CTRL (or 
SHIFT) and the left mouse button to swipe the full display instead of having to drag the mouse.  
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The new Flicker command in the 3D Effects toolbar automatically flickers the layer chosen in the layer dropdown list 

on and off using the time interval specified in milliseconds in the control next to it. Flicker is particularly useful for 
temporal change detection (especially of satellite images or air photographs taken at different times of the same 
location), data quality comparison, and other analysis where you want to see small differences between very similar 
looking layers:  
 

 
 

The Clear Selected Features command has been added into the Tools toolbar to match ArcMap and enable you to 
clear the selected set with one click at any time. 
 

The Go To XY command has been added into the Tools toolbar. This launches the same dialog as the new 
command added into ArcMap's toolbar. 
 

At 9.2, the 3D Measure tool  that was introduced in ArcReader at 9.1 for measuring published 3D globes has 
een added into ArcGlobe where it repla s the existing Measure tool.  

 
b ce

ArcGlobe now supports drawing graphics on a globe. The new Globe 3D Graphics toolbar lets you draw points, 
lines, polygons and text on a globe. This is the same toolbar that is already present in ArcScene: 
 

 
 
Like graphics in ArcScene, graphics in ArcGlobe can be organized into different graphics layers which appear in the 
Table Of Contents Type and Display tabs. Graphics layers from both ArcGlobe and ArcScene can be saved to disk as 
layer (.lyr) files and shared. Graphics layer files are self-contained - they contain the graphic elements and don't 
reference a separate data source like other layer files. 
 

When you right-click a 3D graphic element, there are three globe-specific options: Rasterize Graphic, Billboard 
Graphic, and Illuminate Graphic,  
 
- The Rasterize Graphic option allows you to drape a graphic element on the surface of the globe such that it follows 

the terrain of the globe.  

nts to utilize the globe lighting properties such that the 

 
- The Billboard Graphic option allows you to billboard the 3D text graphic elements or points symbolized with 3D 

symbols. Billboarding the graphic element keeps the element aligned to the screen such that it faces the camera at 
all times.  

 
 The Illuminate Graphic option allows the 3D graphic eleme-

element is rendered with realism. For example, based on the sun lighting, this option will cast realistic shadows on 
the 3D graphic elements. 

 
Google Earth KML and KMZ files can now be added into ArcGlobe as layers. These are the file formats used in 

oogle Earth for storing placemarks, features, 3D objects and other location-basedG
K

 information. KML stands for 
eyhole Markup Language. A KMZ file is a zipped version of a KML file that can contain custom images, symbols, etc. 
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KM inally L and KMZ files do not appear in ArcCatalog. This screenshot shows a KMZ file of the Acropolis that was orig
created as a Sketch-Up model displayed inside ArcGlobe: 
 

 
 
To add local KML or KMZ data into ArcGlobe, use the Add KML Data command on the new KML toolbar. To add KML 
directly from the internet or from a local server, use the Add KML Network Link command: 
 

 
 

he usual way to add KML is the Add KML Data command. For example, if you have a local KML or KMZ file that 
c this into your 
lobe.  

ML and KMZ layers are similar to WMS layers and other web service based layers in that they can contain a large 
and KMZ, this contents tree can sometimes be 

xtremely large. For this reason, KML and KMZ layers are shown in the ArcGlobe Table Of Contents as single entries, 
indow dockable window you can open if you want to review or interact with the 

ontents tree. You can show and hide this window using the command in the KML toolbar. In the KML Contents 
ts tree to interact with them, including the ability to replay 

ML tours: 

T
ontains network link information to other resources on the web, use the Add KML Data command to add 

g
 
K
number of individual elements or nodes arranged in a tree. With KML 
e
and there's a new KML Contents w
c
window you can right-click the different nodes in the conten
K
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You can create KML files from layers and maps using two new geoprocessing tools: 
 

3D Analyst Tools > Conversion > To KML > Layer To KML  
 3D Analyst Tools > Conversion > To KML > Map To KML 
 

ArcGlobe now supports labeling. Turning labels on for a feature layer in ArcGlobe works the same as it does in 
r e the Label Feature command, or go to the Layer 
r of the globe. Both annotation feature classes and 

e t labe sterized, on to the globe. This screenshot shows a USA States annotation feature class 
ped u can see, this includes draped halos and leader lines: 

A cmap: you right-click the layer in the Table Of Contents and choos
operties dialog Labels tab. You can now drape text on the surface P

t x ls can be draped, or ra
ra on the globe. As yod

 

 
 

The option to specify a Globe cache for group layers has been included in 9.2. When you create or add a group
layer into ArcGlobe, you have the option to also create a cache it. The group layer cache can be calculated in

 
 two 

 

ied in from 
rcMap. You'll see the new options in the group layer Properties dialog: 

 

ways. The first option is to consolidate the existing child layer caches into a single rendering pass. This option is best 
when the child layers already have mature caches and represent a variety of display resolutions. The second option is
to create a single rasterized image of all the child layers, thereby creating a single cache for the entire group layer. 
This option is best when the child layers operate as a single unit, such as a background group layer cop
A
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and in a new dialog you can access via a new Group Cache Settings c
ayer in the Table Of Contents Display tab:  

ommand accessed by right-clicking a group 
l
 

 
 

ArcGlobe now has a draft mode. While you are in draft mode, the rendering and navigation speed of the 3D view is 
improved by reducing the quality of the view without invalidating any cached data or modifying any layer properties. 
Press the new button in the Tools toolbar to enter draft mode: 
 

 
The button turns orange while you are in draft mode. 
 
Draft Mode operates as a set of overrides. Properties are not changed within the layer itself, but rather applied after 
each layer is read. The improvement in rendering speed will vary depending upon the layer types in the document and 
the current symbology properties. 
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Draft Mode is particularly useful during the initial design of a camera animation. Often, you have already spent a great 
deal of time developing the 3D view, but now find you need to move swiftly around the view to place camera 
keyframes. Rather than having to turn off layers or temporarily change symbology, you can enable Draft Mode to 
develop and preview your fly-through with faster performance. Then simply disable Draft Mode when you are ready to 
create the final video.  
 
You can configure draft mode using new options at the bottom of the Tools > Options dialog Level Of Detail tab: 
 

 
 

Memory cache management has been enhanced. Memory caching refers to assigning an amount of physical 
memory (RAM) for use by ArcGlobe. For optimum performance you can now set the amount of memory assigned for 
each type of data used. In the Tools > Options dialog Cache tab, press the Advanced button to launch the new 
Memory Cache dialog: 
 

 
 
For example, if your 3D view contains many elevation data sources and very few 3D features, you can allocate more 

AM for the elevation layers. Often an ArcGlobe document that is performing poorly can become very interactive 
through well defined memory cache settings. It is important to note that the settings defined in this dialog will apply to 
this document and all future ArcGlobe documents opened.  

R
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Hardware compressed textures. Multipatch features often have textures – images or repeating patterns on each 

face of the 3D object. A common example is 3D buildings, which can display either a digital photograph or simply a 
peating window pattern on each face of the multipatch. Reducing the in-memory requirements to render the textures 

w
re

ill free up machine resources and improve the display performance for the layer. 
 

New texture down-scaling capability. You can reduce the volume of texture pixels (texels) that are sent to the 
lass by downscaling the resolution of textures. For instance, a 640x480 
wering its in-memory size by a factor of 4.  

 

om texture to texture. For example, a repetitive window texture will absorb a greater reduction in resolution than that 
f a shop

exture do to render the textures will 
er can optionally choose to 

port the layer to a new feature class.  

graphics card to render a multipatch feature c
xture can be downscaled to 320x240, thus lote

The amount of downscaling that can be applied to a texture without greatly reducing the quality of the display will vary 
fr
o  sign.  
 
T wnscaling is applied as a layer property. Reducing the in-memory requirements 
free up machine resources and improve the display performance for the layer. The us
persist the reduced texture resolution when using geoprocessing tools to ex
 

TINs are now supported in ArcGlobe as elevation layers. 
 

New d  completed ArcGlobe documents 
t for those publishing globes documents to the 

ternet or 

he comm cument and can be found in the Tools > 
Customize dialog Command tab in the File category. You can drag this command into any pulldown menu or toolbar.  
 

eployment wizard. The Deployment Wizard is designed to as
and their disk caches to new locations. This will be of particular interes

sist you move

in LAN using ArcGIS Server. 
 
T and to launch the globe deployment wizard is called Deploy Do

ESRI ArcWeb Services are now supported inside ArcGlobe. If you are an ArcWeb Services subscriber, you sign 
can into ArcWeb Services from the new Online Services pullright in the Tools pulldown menu. Once you are signed in, 
you'll see additional premium services in the Find dialog Places tab, the Find dialog Addresses tab, and the new Tools 
> Online Services > Find Nearby Places dialog. This matches the way that ArcWeb Services are exposed in ArcMap 
and ArcReader at 9.2. In addition, you'll be able to add layers based on ArcWeb Services into ArcGlobe from the new 
ArcWeb Services folder in the ArcCatalog tree. See the 'Data & services from ESRI' chapter in this document. 
 

New bonus controls available in the Tools > Customize dialog Commands tab in the Globe category. You can add 
these into any toolbar: 
 

 Look Around tool 

 Fixed Line of Sight tool 

 Return To North command 
 

More keyboard shortcuts are now supported when you are working in the ArcGlobe Table of Contents: 
 
- Expand/Collapse multiple items via CTRL-Click 
 
- ENTER or F12 opens the currently selected item's property dialog. 
 
- F2 renames the selected item.  
 
- SPACE turns drawing of the selected layer(s) on or off.  
 
- ESC returns keyboard focus to the map from the Table Of Contents.  
 
- CTRL + SPACE toggles all layers on and off if you press it when one layer is highlighted in the TOC. 
 
-  F1 gives you a list of tips and shortcuts for working with ArcGlobe 
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ArcObjects developers using the GlobeControl can now can have two or more globes on a single application 
window, looking at different documents and having their own navigation properties. Previously you could only have one 
GlobeControl per form.  
 

You can save ArcGlobe documents (.3dd files) and layer files (.lyr files) so they can be opened and used in 
ArcGlobe in ArcGIS 9.0 and 9.1. This makes it easy to share those files with other ArcGlobe users who have not yet 
upgraded to ArcGIS 9.2. 
 
-  To save a globe document from ArcGlobe 9.2 so it can be used in 9.0 and 9.1, use the new Save A Copy command 

in the File pulldown menu. At the bottom of the dialog that appears, choose 'ArcGlobe 9.0 Documents (*.3dd)' from 
the Save As Type dropdown list. This will save a copy of your current map document in 9.0 format.  

 
- To save a layer file from ArcGlobe 9.2 so it can be used in 9.0 or 9.1, right-click the layer in the Table Of Contents 

and choose the Save As Layer File command. At the bottom of the dialog that appears, choose '9.0 Layer files (*.lyr)' 
from the Save As Type dropdown list. This will save the layer file in 9.0 format. 

 
You can now set contrast, brightness and transparency on group layers in the 3D Effects toolbar, the same as in 

ArcMap. 
 
Before a raster catalog is displayed in ArcGlobe, the program scans through all the raster datasets inside the catalog 
to find out their cell size. This typically slows down the caching and display of raster catalogs. At 9.2 a new setting in 
the Tools > Options dialog Raster tab in ArcGlobe lets you specify that the cell size of the first raster dataset in a raster 
catalog should be used by ArcGlobe as the cell size for all the other raster datasets inside the catalog. Check this 
option if you typically work with raster catalogs that contain raster datasets that all have the same cell size. In this way, 
ArcGlobe will only scan the first raster dataset in raster catalogs and the performance of display and caching will be 
optimized. If the raster datasets in your raster catalogs typically have differing cell sizes, then checking this option is 
not recommended. It is unchecked by default: 
 

 
 
This option applies to all your ArcGlobe sessions and is not used or available inside ArcMap, ArcScene or ArcCatalog 
because these applications don't have the caching mechanism used by Globe. 
 

 3D graphics layers saved as layer files at 9.2 use this new icon: 
 

 3D graphics layer 
 
3D graphics layers didn't have their own distinctive layer file icon in previous releases. Your existing 3D graphics layer 
files won't be shown in ArcCatalog with this new icon. Only 3D graphics layer files created with 9.2 will have the new 
icon.  
 

New fog effect property on the Globe Properties dialog Background tab. If you enable the fog effect, you'll see an 
atmospheric haze when you are in surface navigation mode and the observer is looking up at an oblique angle to the 
horizon. Enabling fog will mask distant objects and makes the display more realistic. 
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ArcGIS Server can now serve globes 
 

You can now publish globes documents to the web as globe services using ArcGIS Server. Globe services are 
cached for high performance using the caching mechanism of ArcGlobe, which is carried over to the server.  
 
Unlike a map service, users accessing a globe service can choose which layers available in the service they wish to 
access, so they can access all of the layers it contains or just some of them. Here's what a globe service looks like if 
you access it in ArcCatalog. The service has been expanded to expose the different layers it contains: 
 

 
The following clients can access globe services: 
  
- ArcGIS Explorer  
- ArcGlobe 
- ArcReader  
- GlobeControl in ArcGIS Engine 
 
Globe services also contain the animation tracks from the globe document that was published to the server, so a user 
accessing your globe service over the web can also play back your animation. Playing animations that were published 
in globe services is not currently supported in ArcGIS Explorer. To access the animation in a globe service, you have 
to add the globe service itself into the ArcGlobe, rather than one of the individual layers contained in the service. 
 
ArcGIS Server Standard and Advanced editions support publishing globes ( See the 'ArcGIS Server' chapter in this 
document for information about the different server editions). The 3D Analyst extension is not required on ArcGIS 
Server in order to publish globe services. However, you will require the 3D Analyst extension on ArcGIS Desktop in 
order to author globe documents using ArcGlobe.  
 
 
Serve your 3D Analyst geoprocessing models to the web with ArcGIS Server 
 

ArcGIS Server can be used to publish 3D Analyst geoprocessing tools and models as geoprocessing services that 
e accessed by users in web mapping applications, ArcGIS Explorer, and ArcGIS Desktop. This provides a 
etely new way to deliver your 3D processes and analytical visualization to a wider audience. You'll need ArcGIS 

Server Advanced Edition and the 3D Analyst extension on your server. 

can b
compl

See the 'ArcGIS Server' and 'Geoprocessing' 
chapters of this document. 
 
 
Enhancements made to both ArcGlobe and ArcScene 
 

A lot of dialogs in ArcGlobe and ArcScene contain a dropdown list that lets you specify which layer you want to 
perform an operation on. At 9.2 we have updated this dropdown list to make it easier to work with: 
 
- The dropdown layer list now shows you which layers belong to group layers or layers such as ArcIMS image 

services, so the list matches the way that the layers are organized in your Table Of Contents. You can expand and 
contract the list to quickly access the layer you want to use. 

 
- Each layer is listed with its layer icon from ArcCatalog so you can easily see what type of data each layer contains. 
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-  If the layer names are very long, a horizontal scale bar at the bottom of the dropdown list lets you scroll the listing 
sideways. 

 
Here's what the new control looks like. In this particular dialog, group layers aren't valid inputs so the name of the 
group layer is shown in grey text: 
 

 
 

You can now access metadata directly from ArcGlobe and ArcScene without having to open ArcCatalog. Right-click 
any layer in the Table Of Contents and choose the new View Metadata command from the Data pullright. Choosing the 
View Metadata command opens the metadata for the layer's data source in a new floating Metadata window. This 
window works the same as the Metadata tab in ArcCatalog. It also enables you to choose the stylesheet you want to 
view the metadata with. 
 
If the data source of the layer you access metadata for does not have metadata created for it yet, the View Metadata 
command will automatically initiate metadata creation if the option to 'automatically create metadata' is enabled in the 
ArcCatalog Tools>Options dialog Metadata tab (it is enabled by default). If that setting is disabled, or if you don't have 
write access to the data source's location, the Metadata window will show you the standard message that metadata 
cannot be created. 
 

A check box has been added into the Selection>Select By Attributes and Selection>Select By Location dialogs that 
enables you to restrict the list of layers from which you choose to select features to layers which are currently set as 
selectable. When this box is checked, the list will only contain layers that are currently set as selectable.  
 

 
 
You can set layers as selectable by choosing the Set Selectable Layers command from the Selection pulldown menu. 
 
By default, all the feature layers in a data frame are selectable, so checking this new check box has no effect on the 
length of the list of layers if you have not yet turned off some of the layers in the Set Selectable Layers dialog. 
 

As described in the map navigation part of this document, at 9.2 rolling the mouse wheel gets applied to whichever 
part of the user interface the cursor is currently over. In this way, you can just move the cursor over the map and then 
roll the wheel to zoom in or out, irrespective of which window or dialog has keyboard focus. For example, this makes it 
easier to use the mouse for zooming in and out on a globe because you no longer have to make the main ArcGlobe 
window active after you've been working in the Table Of Contents in order for your wheel roll to be applied to the 
globe. 
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You can now reverse the zoom in/zoom out convention used by: 
 
- the mouse wheel 

- dragging with right mouse button with the Navigate tool  

 - the Zoom In/Out tool 
 
To change this setting, go to the ArcGlobe or ArcScene Tools>Options dialog and look at the bottom of the General 
tab. Both applications have this setting and setting it for one sets it for the other. 
 

 
 
For example, if you want ArcGlobe and ArcScene to match the convention used by the new mouse wheel support 
added to ArcMap in 9.2, change this setting to use the "Zooms In" option instead. 
 

3D graphics layer files now have their own distinctive icon in ArcCatalog (see above). 
 

Improved support for animations:  
 
- New Time layer, Map layer, and Map View animation types 
 
- New layer visibility options in group layer animations 
 
- Improved developer experience with new animation objects 
 

In the Table Of Contents in ArcScene or ArcGlobe: 
 

Hold down ALT and click the name of a layer in the Table Of Contents to zoom to the extent of that layer. 
 
Click inside the Table of Contents to give it keyboard focus and press F1 to get a list of tips and shortcuts. 

 
 
Terrain datasets 
 

ArcGIS 9.2 introduces a new terrain data type that enables you to store massive surface datasets, such as LIDAR 
and SONAR data, in the geodatabase. The 3D Analyst extension is required to create terrain datasets. The extension 

 not required to view terrainsis . See the 'Terrains' chapter of this document. 
 

The interactive tools in the 3D Analyst toolbar in ArcMap can be used on terrains. 
 
 
3D geoprocessing enhancements  
 

The 3D Analyst Tools > Conversion toolset has been reorganized and a number of new conversion tools have been 
added (in addition to the terrain conversion tools mentioned above). The new conversion tools are: 
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 3D Analyst Tools > Conversion > From Feature Class > FeatureClass Z To ASCII 
 3D Analyst Tools > Conversion > From Feature Class > MultiPatch Footprint 
 3D Analyst Tools > Conversion > From File > ASCII 3D to Feature Class 
 3D Analyst Tools > Conversion > From File > Import 3D Files 
 3D Analyst Tools > Conversion > From File > LAS to Multipoint 
 3D Analyst Tools > Conversion > From Raster > Raster Domain 
 3D Analyst Tools > Conversion > To KML > Layer To KML 
 3D Analyst Tools > Conversion > To KML > Map To KML 
 3D Analyst Tools > Conversion > Layer 3D To Feature Class 
 

Other new 3D geoprocessing tools are: 
 
  3D Analyst Tools > TIN Creation > Delineate TIN Data Area 

  3D Analyst Tools > TIN Surface > Decimate TIN nodes 

  3D Analyst Tools > TIN Surface > Extrude Between 

  3D Analyst Tools > TIN Surface > TIN Difference 

  3D Analyst Tools > TIN Surface > TIN Polygon Volume 
 

Changes to existing geoprocessing tools: 
 
   3D Analyst Tools > Functional Surface > Interpolate Shape 
  Method parameter added 
 
   3D Analyst Tools > Functional Surface > LineOfSight  
  Now accepts 2D line input and utilizes attributes for parameters 
 
   3D Analyst Tools > Functional Surface > Surface Spot 
  Method parameter added 
 
   3D Analyst Tools > TIN Surface > Interpolate Polygon To Multipatch 
  Now outputs surface area too 
 
 
 

ArcScan  

New tools 
  

 Point To Point Tracing tool: This new tool in the ArcScan toolbar vectorizes raster linear features by tracing the 
shortest path between two or more points that you specify on the target raster. It is similar to the vectorize trace tool 
but can be more efficient as the trace does not stop at raster intersections between the two specified points. Use this 
tool when you need to vectorize a relatively long raster line that may have few raster intersections or a logical path 
such as a stream. If you need more control over the precise direction of the trace then use the vectorization trace tool. 
  

 Shape Recognition tool: This new tool in the ArcScan toolbar allows you to capture features such as building 
outlines or similar structures that may be represented as circular, rectangular or orthogonal shapes in the raster. 
Previously you would have to trace or snap or vectorize the raster to obtain one of these features. This new tool allows 
you to simply click once inside the feature to vectorize the approximate shape into the current editor target. 
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 Measure Raster Distance tool: This is a bonus tool you can add into the ArcScan toolbar. It allows you to 

measure a distance in raster pixels for the current raster target on the display. It is useful in determining pixel distances 
for parameters such as gap closure tolerance in the vectorization settings dialog. This tool is not present on the 
ArcScan toolbar by default but can be found under the ArcScan category in the Tools>Customize dialog Commands 
tab. This functionality was previously available as a developer sample. 
  
 
New vectorization settings 
  

Noise level: This parameter sets the roughness or noise threshold for features in the raster. Raster linear features 
may be rough or noisy due to poor quality line work on the source map or the map may have been scanned at a low 
resolution.  
 
The noise level determines how much noise to ignore during a vectorization process. Setting this value to high may 
result in some features being missed while setting it too low will result in noise being picked up as features. 
 
The following diagrams depict a noisy raster feature overlaid with a vectorization preview showing the effects of 
differing noise levels. 
  
Vectorization with low noise level:                                  Vectorization with high noise level: 

                                        
Resolve corners: The resolve corners settings allows you to control how ArcScan will recognize and resolve corners 

during vectorization functions. When enabled, ArcScan will assume that any bend in a raster linear features less than 
the corner angle (also specified on the vectorization settings dialog) should be treated as a sharp corner during 
snapping, tracing and automatic vectorization. This is usually important while capturing information from parcel or 
engineering plans that feature right angle or similarly sharp corners. Enabling this option will make ArcScan operations 
slower however and should be generally disabled while working with contour or polygon features. 
  
  
New raster cleanup operations 
  

Four new raster morphological operations have been added to the raster cleanup menu, which offer you additional 
ways to cleanup a raster prior to vectorization. 
 
- Erosion decreases the thickness of all raster features. Features may be deleted during this operation if the value is 

set too high. 
 
- Dilation is the opposite of erosion in that it will thicken raster features. This is useful to give better definition to thin 

raster features that you so wish to capture. 
 
- Opening is erosion immediately followed by dilation. This operation tends to “open” small gaps and spaces between 

touching objects in an image. It also can delete thin lines. It is useful to quickly remove features you may not want to 
capture such as thin grid lines in the source map. 

 
- Closing is dilation immediately followed by erosion. It is used to "fill-in" any cracks in the image and to “close” small 

gaps and spaces between touching objects in an image.  
 
Opening and closing create an image that is simpler and has fewer details than the source one. 
 
Tip: Remember that since 9.1, the ArcScan for ArcGIS extension can now be used by ArcEditor and ArcInfo users at 
no additional charge. The ArcScan extension is installed when you run the ArcGIS Setup using the Complete or 
Custom installation options. ArcView users still have to purchase a license if they wish to use the ArcScan extension. 
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Data Interoperability 

Free support for OGC GML Simple Features 
 

If you install the Data Interoperability extension, you can now use it to access OGC GML Simple Feature data 
without needing to have a Data Interoperability extension license. This free support provides this functionality: 
 
- OGC GML Simple Feature access  
- OGC GML Simple Feature import/export  
- OGC GML Web Feature Service access for Simple Feature based services  
  
Support for the full list of formats and additional functionality provided by the extension, such as custom formats and 
custom tools built using Workbench, require that you have a license for the Data Interoperability extension. 
 
Tip: To install the Data Interoperability extension, use the Complete option when you install ArcGIS Desktop 9.2, or 
use the Custom option and enable the extension in the list of extensions. If you have already installed ArcGIS Desktop 
9.2 without the extension and now want to install it to try the free GML Simple Features support, run the Setup 
program again and choose the Modify option to add the extension. 
 
 
Support for ArcGIS Engine and ArcGIS Server 
 

The functionality of the Data Interoperability extension is now available for ArcGIS Engine and ArcGIS Server as 
extensions for those products. This allows any of the extension's data handling and support capabilities to be 
embedded in custom desktop or server-based applications. 
 
 
Based on Safe Software FME 2006 
 
The Data Interoperability 9.2 extension is based on the FME 2006 product release by Safe Software, and benefits from 
the new functionality added in this new product release: 
 

Workbench improvements: 
 
- Ability to publish parameters to use multiple times 

- Build custom transformers from reusable workbench workflows 

- Shared Directories: a shared environment to allow multiple users access to custom formats and custom transformers 
from a central location 

- New numbered counters show how many features passed through each link in the Workbench canvas 

 
New formats:  

 
Read/Write: 

Access Database (ADO) 
ESRI File Geodatabase 
Google Earth Data Exchange (KML) 
MapInfo TAB (replaces old MapInfo TAB reader) 
Tabular Data 
 

Read: 
ESRI ArcGIS 9.x Layer  
 

Write:  
GML 3.1.1 (read access was added at 9.1 Service Pack 1) 
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New Transformers: 

 
AreaOnAreaOverlayer  
AreaSmoother  
Bufferer  
CommonSegmentFinder 
ConvexHullReplacer 
KMLStyler 
Labeller 
LineOnAreaOverlayer 
LineOnLineOverlayer 
SchemaMapper 
SectorGenerator 
SpatialRelator 
TopologyBuilder 
 
 The Quick Import and Spatial ETL tools (see below) support the new file geodatabase format introduced in 9.2. 
 
Note: The 9.1 version of the extension was based on FME 2004. The 9.1 Service Pack 1 version was based on FME 
2005.  
 
 
New Spatial ETL Tool 
 
At 9.1, you had the option to create three different types of custom interoperability tools, Import, Export and Transform. 
At 9.2, we have consolidated these three options into a single tool called Spatial ETL Tool.  
 

 
 
The Spatial ETL Tool retains the functionality of the original tools. Tools built in previous versions will be forward 
compatible, meaning you can run them without modification, or you can edit the tool in Workbench, which will allow 
you to upgrade the tool to a Spatial ETL Tool.  
 
More information about the Spatial ETL Tool is available in the online help for ArcGIS 9.2, or in chapter three of the 
Data Interoperability Tutorial. 
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Geostatistical Analyst 

Geostatistical Wizard enhancements 
 

The weights that are used in the different interpolation methods are now displayed in the Geostatistical Wizard: 
 

 
 

The semivariogram can now be exported as a table or as a raster for further analysis: 
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The Geostatistical Wizard now supports smooth interpolation. The graphic below on the left shows kriging 

interpolation with a circular searching neighborhood using a radius of 20 feet. The graphic on the right shows the 
kriging prediction using the smooth interpolation option: 
 

    
 
In smooth interpolation, the search neighborhood creates an outer ellipse and an inner ellipse. All the points within 
these three ellipses are used in the interpolation. The points that fall outside the smaller ellipse but inside the largest 
ellipse are weighted using a sigmoidal function with a value between zero and one that you can specify. 
 

The first panel of the Geostatistical wizard now uses the improved dropdown layer list described in the ArcMap 
chapter of this document. There is also better support for working with long field names in the wizard. 
 
 
New geoprocessing tools 
 
A number of new geoprocessing tools have been added into the Geostatistical Analyst Toolbox. All the Geostatistical 
tools in the toolbox can also now be used in scripting to automate and customize a variety of applications. 
 

A geostatistical layer is created using the complete input dataset. The kriging parameters can be adjusted or left as 
the initial default values that are automatically determined by the Geostatistical Wizard. This new geoprocessing tool: 

 
 

Geostatistical Analyst Tools > Moving Window Kriging 
 
lets you create a new feature class by recalculating the Range, Nugget and Partial Sill semivariogram parameters 
based on a smaller neighborhood. When the data is non-stationary, you must estimate a heterogeneous 
semivariogram. In other words, use a moving window centered on the location to be predicted and create a 
semivariogram for each local neighborhood: 
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You can now create a new geostatistical layer
an was used for the original layer: 

 from an existing one using a different input dataset or field variable 
th
 

Geostatistical Analyst Tools > Create Geostatistical Layer  
 

 
 

The new Semivariogram Sensitivity tool lets you automatically vary the Nugget, Partial Sill and Range parameters 
to perform a sensitivity analysis: 
 
 Geostatistical Analyst Tools > Semivariogram Sensitivity 
 

Other new tools added: 
 
 Geostatistical Analyst Tools > Calculate Z-value 
 Geostatistical Analyst Tools > GA Layer To Contour 
 Geostatistical Analyst Tools > GA Layer To Points 
 Geostatistical Analyst Tools > Get Model Parameter 
 Geostatistical Analyst Tools > Neighborhood Selection 

 Geostatistical Analyst Tools > Set Model Parameter 
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Maplex 

Added support for Leader Lines to Maplex: Leader lines are now taken into account during the labeling process 
resulting in less ambiguity in label-feature relationships. Text positions are produced to avoid crossing leader lines. 
 

Minimum feature size:  A new minimum feature size property has been added to allow users the ability to specify 
the minimum size feature that will be labeled. This option is available for polygon and line labels and allows users to 
reduce visual clutter on map by quickly specifying the smallest feature that should receive a label: 
 

 
 

Polygon offset: Additional control over the offset labeling of polygons has been added. When combined with the 
improved functionality for leader line placement, this option results in clearer label placement for polygon labels: 
 

 
 

The Maplex extension is now supported by ArcGIS Server and ArcIMS ArcMap Server. This allows web-based 
applications to display high Maplex labels. 
 

The Maplex extension is now supported by ArcGIS Engine so embedded applications can take advantage of 
Maplex label placement for high quality mapping. 
 

The Maplex extension is now supported by the ArcGIS Publisher extension. Maps containing layers with Maplex 
labeling properties can now be published via the Publisher extension and viewed using ArcReader. 
 

Quality: The placement quality, performance, and scalability of the Maplex label engine have been improved. 
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Network Analyst 

Route analysis enhancements 
 

You can now specify the start time that the route is to begin. This is useful when using time windows to control the 
time you want the vehicle to start. It's also useful if you simply want your directions to display the running time starting 
at the time specified. 
 

You can now solve a problem containing multiple routes. With each stop, you can now specify the route name that 
the stop belongs to. When the solver is executed, it generates routes between stops with the same route name for 
each unique route name. The Network Analyst Window has also been enhanced to display the stops per route name: 
 

 
 

You can now create network datasets referencing signpost tables to improve the quality of directions. This is 
specified in the network dataset directions property pages. Signpost tables enable the generation of user-friendly 
directions such as "Take exit 123 on I-15 north towards Las Vegas". 
 

The Directions window has been improved in several ways. 
 
- The cumulative distance and time (based on the Route's start time) 
-  Time window support, including wait time and time violations 
-  The ability to turn off columns within the window 
- Adjustable inset maps and ability to change the default scale 
- A print option to print exactly what is shown within the window. 
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The renderer property page for the route layer's Stops has been enhanced to look like other renderer property 
pages. As part of being more consistent with the other renderers, it allows you to turn on/off symbols, reorder the 
symbols, and change their label in the table of contents. 
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At 9.2, you can now have a network dataset attributes with parameters defined on them. This is useful because the 

evaluators assigned to these attributes can use the parameters to determine the attributes value. This makes it 
possible to have a tunnel height restriction that will return restricted only if the vehicle height is more than the tunnel 
height.  
 
To specify these you use ArcCatalog’s network dataset creating wizard to add a parameter to an existing attribute. For 
example, a parameter called Vehicle Height could be added to a Height restriction attribute.  
 

   
 
To use these parameterized attributes, create a network analysis layer in ArcMap and bring up its properties and use 
the Analysis Settings tab to specify their use. For example, to use the height restriction, check it on in the properties 
page and then use the Attributes Parameter to specify the value for the current vehicle height. The evaluator for the 
Height restriction can then use this parameter value to return the restriction status. The value of the Vehicle Height 
parameter can be changed any time during analysis by bringing up the properties of the network analysis layer or 
using a geoprocessing tool. 
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Service area analysis enhancements 
 

You can now trim the outer service area polygon by a specified distance. This is useful in rural locations where 
there may be large areas with roads that you don't want to be included in the service area polygon.  
 
Here is an example of the outer service areas being trimmed within 100 meters of the corresponding streets. 
 

 
 
You can find the new trimming option in the Network Analysis Layer Properties dialog Polygon Generation tab: 
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There is now an option to create service area polygons that do not overlap. This is useful in cases where there are 
multiple facilities and you need the area of each polygon to be generated based on the "closest" facility.  
 
This option is also specified in the Network Analysis Layer Properties dialog Polygon Generation tab (see above) 
 
Here is an example of non-overlapping service areas based on 3 facilities: 
 

 
 
 
Better control over how network analysis layers are drawn 
 

You can now change the order in which the individual layers (e.g. Stops, Barriers) inside a network analysis layer 
are drawn using a new tab called Layers that has been added into the Network Analysis Layer Properties dialog.  
 
You can also use this tab to access the properties of the layers in an analysis layer directly to specify symbology, etc 
without having to close the Network Analysis Layer Properties dialog. Tip: double-click on a layer in the list to access 
its properties:  
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Network analysis layers now provide full support for the symbol levels, enabling you to specify the precise drawing 

order and join/merge behaviour of the symbols used in the layer, the same as you can for a group layer containing a 
set of feature layers. (In 9.1 you could specify symbol levels for the individual layers inside an analysis layer, but you 
weren't able to specify symbol level behaviour encompassing all the layers inside an analysis layer. You access the 
Symbol Levels dialog for a network analysis layer via a button on the new Layers tab (see above). 
 

A new Reset Symbology dialog lets you change the symbology of all the sublayers in a network analysis layer at 
once instead of visiting them each individually. You can reset the symbology to the default based on the specified color 
(for example if you want the default symbology in pink) or you can chose another analysis layer to import the 
symbology from. Right-click an analysis layer in the Table Of Contents to access the Reset Symbology command that 
launches this dialog: 
 

 
 
 
Adding network locations to a map 
 

The search tolerance now starts small and expands up until the maximum search tolerance is reached. Therefore, 
you can specify a large search tolerance for cases where a network location may be far away from a source feature, 
but if the majority of your locations are close to a source feature, performance locating those features will be good. 
 

Reverse geocoding is now supported when you are adding network locations. With this option, network locations 
you add by clicking on the map are named by their street address rather than "Graphic Pick X" or "Location X". These 
street addresses are obtained by reverse geocoding using an address locator specified in the new Location Names tab 
in the Network Analyst > Options dialog launched from the Network Analyst toolbar: 
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You can specify that network locations should be snapped to a network source. You can also snap them a specified 

distance from the source if you need an offset to model the side of street for curb approach. This is useful if you want 
your network locations a uniform distance from the actual feature it's referencing. These options can be configured in 
the new Location Snap Options tab in Network Analyst > Options dialog:  
 

 
 
 
Geoprocessing  
 

Derived output parameters have been added to more network analyst geoprocessing functions so you can string 
processes together more effectively. 
 

A new geoprocessing tool: 
 
 Network Analyst Tools > Analysis > Update Analysis Layer Attribute Parameter 
 
is provided to set or update the network attribute parameter value for a network analysis layer. This tool is useful for 
those network attributes that have parameters defined on them. This tool can be used to repeatedly change the value 
of a parameter before solving a network analysis layer. 
 
 
ArcGIS Server support 
 
ArcGIS Server now exposes network analysis web services. You are able to publish map documents that contain 
network analysis layers.  
 
This allows you to create server applications which perform route, closest facility, and service area network analysis 
via a web service: 
 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  234 



 
 
You could perform network analysis with ArcGIS Server at 9.1, but it required a lot of custom code.  
 
 
ArcGIS Engine Developer Kit components 
 
ArcGIS Engine now includes developer controls similar to those in ArcMap that allow users to easily create 
applications that perform network analysis. This includes the buttons on the Network Analyst Toolbar as well as the 
Network Analyst Window and the Directions Window: 
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Publisher and ArcReader 

Publisher 
 

The data packager supports packaging data into a file geodatabase. This fixes several issues with the data 
packager because the capacity of file geodatabases is greater than that of personal geodatabases. Compression has 
been changed to use the file geodatabase compression that is part of 9.2. 
 

When a map is published, you can now specify a title for the map using a new command called Publisher Map Title 
you can find in the Publisher pulldown menu in the Publisher toolbar. This title can be modified in ArcReader by the 
end-user of the published map. The ArcReader user will only be able to modify the Publisher map title if the Publisher 
has enabled that functionality. Additionally, the ArcReader user can only change the text of the publisher map title, all 
the other settings such as placement, text size, and font, are determined by the publisher of the map. 
 

Specific PMFs can now be customized because template settings are embedded. Currently you have to create a 
customized ArcReader template file (.art) and then load that file into the embedded settings dialog, but in the future 
you will be able to edit the settings directly from the embedded settings dialog. 
 

The Maplex extension is now supported by the ArcGIS Publisher extension. Maps containing layers with Maplex 
labeling properties can now be published via the Publisher extension and viewed using ArcReader. 
 

If the map or globe document you are publishing contains layers based on ArcWeb Services, a new setting in the 
Publisher > Settings dialog lets you control whether users of the resulting PMF will require their own ArcWeb Services 
login, or will use the username and password stored with the layer in the document: 
 

 
 
This check box is only enabled if you are currently signed in to ArcWeb Services via the Tools > Online Services > 
Sign In To ArcWeb Services command at the time you publish your document 

 
 
 
ArcReader 
 

New full-screen mode button. You can use this button or press F11 to maximize the viewing area. Full screen mode 
eliminates the application title bar, the table of contents, and the Windows taskbar, if applicable.  
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Additional 3D navigational tools. The new tools are Look Around, Fixed Line of Sight, and Return To North.  
 

 
 
In addition to new tools, others have been revamped to provide additional functionality – such as the zoom/pan to tool. 
These new tools provide the ability to set the observer at a specific location, and rotate the rest of the scene/globe 
around them, or rotate them to have a 360 degree view of the area. 
 

You can now edit the map title shown on the page layout prior to printing a map (if the publisher has enabled this). 
 

New Go To XY command. (Same one that has been added to ArcMap at 9.2). ArcReader users can now navigate 
to coordinate locations they type in.  
 

Improved Measure tool. (Same one that has been added to ArcMap at 9.2). Allows for 1-button click to measure 
features, areas, snap to features while measuring, and keep a sum of all measurements taken. Measurement units can 
now be changed through this new dialog. Additionally, the measurements remain in the small dialog and can be copied 
out to a text file. 
 

The same improvements to ArcMap's Find dialog have been made in ArcReader too. This includes the ability to find 
addresses in the USA, Canada and more than 15 European countries using new web services that are built into the 
dialog. All you need to use these is an internet connection. This is the first time that ArcReader has supported the 
ability to find addresses. ArcReader users can navigate to addresses they find, annotate their map with them, and add 
them into the new Tools > My Places dialog for future access. In addition the ArcWeb Place Finder tab in the Find 

as been renamed to be just the Places tab and it uses a new place finding service with improved performance. 
 

dialog h
 

The same new  Find Route dia
enabling all ArcReader users to perf
Western Europe. In ArcReader, look

log that has been added into ArcMap has also been added into ArcReader, 
orm routing and generate driving directions out-of-the-box for the US, Canada and 
 for the new Tools > Online Services > Find Route command. See the 

'Geocoding and routing' chapter in this document. 
 

Markup functionality has been added to ArcReader so that you can work with PMF-based maps in the field make 
otes and annotation. This includes pen, highlighter and eraser tool, all of varying widths, to use for markup. The 

markup gets saved automatically upon closing the PMF file to a .pmfink file in the same directory as the map. 
 

n

ArcReader now supports the following map navigation shortcuts when working on a published map: 

g mouse =  Pan 
Hold down wheel & drag mouse + CTRL =  Zoom in on area you define 

 
Roll wheel forward =  Zoom out 
Roll wheel forward + CTRL =  Zoom out at finer increment 
 
Hold down wheel & dra
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Click mouse wheel =  Center  
Click mouse wheel + CTRL =  Center & zoom in 
 
Roll wheel back =  Zoom in 
Roll wheel back + CTRL =  Zoom in at finer increment 
 

Note: Due to a technical issue, in ArcReader you have to right-click the map before you can roll the mouse wheel to 
zoom in or out. 
 

All toolbars in ArcReader are now on by default.   
 

The Transparency command has been removed from the right-click menu for layers in the TOC and moved into a 
ew Layer Effects toolbar.  

 
n

The scale control in ArcReader supports the same enhancements to how scale is input that have been added into 
p's scale control at 9.2. You can now type or paste in scale values using almost any format, including relative 

formats (such as "1 mile = 2.5 inches"). When you specify a scale in a relative format, it is automatically converted to 
absolute format (such as 1:25,344). A variety of formatting is supported to make it easy to copy and paste scales into 
the scale control without modification

ArcMa

. See the 'ArcMap' chapter of this document for more information. 
 

ESRI ArcWeb Services are now supported inside ArcReader. If you are an ArcWeb Services subscriber, you sign 
into ArcWeb Services from the new Online Services pullright in the Tools pulldown menu. Once you are signed in, 
you'll see additional premium services in the Find dialog Places tab, the Find dialog Addresses tab, the new Tools > 
Online Services > Find Route dialog and the new Tools > Online Services > Find Nearby Places dialog. This matches 
the way that ArcWeb Services are exposed in ArcMap and ArcGlobe at 9.2. If you open a PMF containing layers 
referencing ArcWeb Services, you'll be prompted to enter your ArcWeb Services user name and password in order to 

ss these services, unless the publisher of the PMF chose to include their own ArcWeb Services user name and 
password in the document at the time they published it. 
acce

See the 'Data & services from ESRI' chapter in this 
document. 
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Schematics 

Builder 
 

Schematics 9.2 provides a new schematic builder named Network Dataset Builder that works with network datasets 
provided by the Network Analyst extension. The builder allows the generation of schematic diagrams from any network 
layer containing a network analysis result such as a route, a service area or a closest facility. 
 
 
Rules 
 

At ArcGIS Schematics 9.1, a set of predefined rules were provided and were used to simplify or add new elements 
(for example, containers) during the generation process of your schematic diagrams. In 9.2, the Node Reduction By 

riority and the Node Reduction By Flow rules are enhanced to filter elements based on a specified SQL filter from the 
w version of 

e Node Reduction By Priority can also be based on an extended criteria that determines which nodes will be reduced 

 

P
schematic element class to be reduced. This rule allows for a node reduction by feature attribute. The ne
th
or not. This extended criteria is implemented by a custom component. 

ArcGIS Schematics 9.2 provides two new rules: Spatial Query rule and Route Node Reduction rule. 

he new Spatial Query rule allows the addition of new schematic elements of one or more schematic element types. 
 Location query and is based on the spatial positioning of elements 

lative to another schematic element type. 

he new Route Node Reduction rule has been specifically developed to reduce nodes contained in schematic 
 can be applied on any type of 

chematic diagram. It works with degree two nodes (a node with only 2 connected links) along a route and allows you 
some particular nodes related to a given schematic element type 

ave been removed along the route while preserving the topology. 

Schematic Layout Algorithms 
 

 
T
Behind the scene, this rule is using the Selection by
re
 
T
diagrams generated from a network layer containing a resulting route. The rule
s
to generate schematic diagrams after all nodes or 
h
 
 

The new Reduce Vertices schematic layout algorithm is now available. It removes vertices displayed along 
schematic links according to the angle that separates the segments incident to the vertices and the length of the 
segments that compose the links regarding to the longest segment. If neither the condition based on the segments 
length nor that based on the angle formed by the incident segments is verified, vertices are kept. 
 

Until now, if you wanted to pre-define the parameter values to be used for the schematic layout algorithms, you 
needed to implement a custom component that set these parameter values and initialize that component when the 
schematic project opens. With Schematics 9.2, schematic layout algorithm property values can be set per diagram 
type. You can decide which schematic algorithms will be available, set the default parameter values and decide 
whether or not to lock the user’s ability to change the algorithms’ parameters. You can also reorder the list of the 
schematic layout algorithms in the Layout Task dropdown list per diagram type. 
 
All these specifications can be done within Schematics Designer from the new Layout Task tab that is now available 
when a diagram type entry is selected in the Designer tree. 
 

 When a schematic layout algorithm property page is editable for a diagram type, even if default parameter values 
are specified in the Schematics Designer application, users can override the default parameter values in a map 

ocument (MXD) that contains diagrams of this type. The new parameter values for the schematic layout algorithm are 
saved within the MXD. 
d
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Working with schematic diagrams in ArcMap 
 

As described in the ArcMap chapter of this document, in 9.2 Service Pack 2 the viewer windows introduced in 9.2 
have been enhanced so that you can use them to work with the contents of inactive data frames side-by-side on-
screen with the active data frame shown in the main ArcMap window. This enables you to work with a schematic 
diagram side-by-side with the geography it represents without having to work in Layout view.  
 
In the example below, two schematic diagrams have been created to represent the features in the data frame called 
Geography shown in the main ArcMap window. Each schematic is in its own separate data frame displayed inside a 
viewer window: 
 

 
 
The Schematics commands and tools have been updated in Service Pack 2 so that you can use them to perform 
operations on schematics displayed inside inactive data frames in viewer windows.  
 
To work with geography and a schematic side-by-side, first activate the data frame containing the data you want to see 
in a viewer window. Now choose the Viewer command from the Window pulldown menu to open a viewer window. 
Finally, activate the data frame you want to work with in the main ArcMap window. The viewer window you opened will 
remain on-screen, allowing you to work with both data frames. (In the Desktop Help, see: Extensions > Schematics > 
Working with ArcGIS Schematics > Viewing schematic diagrams > Viewing schematic diagrams in ArcMap). 
 
Tip: There are two shortcuts that make it easy to work with multiple data frames: CTRL + TAB switches between the 
data frames making each one active in turn. (If you want to be able to do the same thing by pressing a button on-
screen, add the Activate Next Data Frame command into any toolbar from the View category in the Tools > Customize 
dialog). ALT + click on the name of a data frame in the Table Of Contents activates that data frame. 
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A new command called Mark Crossing is available in ArcMap from the Schematic Editor pulldown menu. Clicking 
lay of crossing marks where two schematic links cross each other. When 
 algorithm detects the horizontal and vertical links that cross each other at a 

right angle in the active schematic diagram. The algorithm then marks the detected intersections with a bridge symbol 
placed on the horizontal links. 
 

this menu lets you turn on or off the disp
turning on the crossing marks display, an

A new command called Copy Layout is available in ArcMap that enables you to copy the layout of one diagram to 
another diagram. To use the command, in the Schematic toolbar, first set the Active Diagram to the target diagram. 

hen in the Table Of Contents, right-click the source diagram layer and choose Copy Layout from the context menu. 
This will copy the layout of the elements and labels from the source to the target. 
T

 
A new command called  Zoom To Make Visible has been added to the context menu you get if you right-click a 

schematic layer in ArcMap. The command is enabled if the layer has a scale visibility range and is currently not being 
drawn because of the map's scale. Choosing the command zooms the map in or out to a scale at which the layer will 
ecome visible. ArcMap chooses the nearest scale to the map's current scale at which the layer will become visible. 

(This same command has been added for most layer types at 9.2). 

 

b

 

Working with schematics in ArcCatalog 
 

Right-clicking a schematic dataset from the Catalog tree displays the Export menu. Selecting To Geodatabase 
allows you to export the selected schematic dataset to another geodatabase. You can choose to export only the 
schematic project definition or to also include the schematic diagrams contained in the input schematic dataset.  
 

Schematic diagrams can also be exported to shapefiles or to features classes in a geodatabase. This operation can 
easily be done from the ArcCatalog tree by right-clicking the schematic diagram you want to export, selecting the 

n, then select To Shapefiles for exporting it to shapefiles or To Geodatabase for exporting it to a 

chematics Designer 

Export functio
geodatabase. 
 
 
S
 

At 9.2 there is a new Diagram Type Assistant that guides you in creating new diagram types. 
 

Forgetting to associate a newly created element type with a diagram type, forgetting to specify the origin and 
xtremity node for a link element type are very common oversights while you are customizing your schematic project 
arameters. Schematics Designer 9.2 integrates a process that checks your parameters when you save the schematic 

project. A dialog containing a list of warnings ordered by critical levels opens and invites you to check and modify the 
parameters specified. 
 

e
p

Schematic layout algorithm parameters management impacts Schematics Designer GUI: the new Layout Task tab 
is now available when a diagram type is selected in the Designer tree. This tab lets you specify the parameters and the 
algorithm availability for each diagram type. 
 
 
Schematics Dataset 
 

With Schematics 9.1, schematic datasets only resided in a Geodatabase (SDE or Personal). Schematic datasets 
can now be created and stored in a File Geodatabase. 
 
 
Schematics Engine 
 

 The Schematics 9.1 extension only existed in its full version. With ArcGIS 9.2, you can limit the install to 
Schematics Engine which is the Schematics core without the Schematics UI part. This will allow developers to use 
Schematics as a part of their ArcGIS Engine applications. 
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Spatial Analyst 

 
New geoprocessing tools for spatial analysis 

 
New Solar Radiation geoprocessing toolset containing these tools: 

 
 Spatial Analyst Tools > Solar Radiation > Area Solar Radiation 
 Spatial Analyst Tools > Solar Radiation > Points Solar Radiation 

 Spatial Analyst Tools > Solar Radiation > Solar Radiation Graphics 

These tools let you calculate direct, diffuse, and global solar radiation at point locations or across a landscape. The 
basic inputs are a DEM and the time configuration, such as a start and end time/date, and interval for calculation such 
s hourly, daily or weekly.  

The graphic below displays the output from the Area Solar Radiation tool showing the amount of incoming global 
radiation (direct+diffuse, WH/m2) for a given time period (red are high values, blue are low). 
 

 

a
 

 
 

New math geoprocessing tools: 
 
 Spatial Analyst Tools > Math > Diff 

Compares two rasters on a cell by cell basis, returning a value of 0 where they are the same, and the value of 
the first input when they are not. 

 
 Spatial Analyst Tools > Math > InList 

Determines on a cell by cell basis which values from the first input are contained in a list of other inputs. 
 
 Spatial Analyst Tools > Math > Over 

Compares two rasters on a cell by cell basis, returning the value of the first input where it is non-zero, and the 
value of the second input where it is zero 

 
New overlay geoprocessing tool: 

 
 Spatial Analyst Tools > Overlay > Weighted Sum 

Overlays several rasters multiplying each by their given weight and summing them together. The inputs to 
Weighted Sum can be floating point, in contrast to the existing Weighted Overlay tool, which only works with 
integer values.  
 
 

provements to existing tools 
 
Im

These existing geoprocessing tools have been improved: 
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 Spatial Analyst Tools > Zonal > Tabulate Area 
This tool now supports feature class data as inputs for zone and class data. It also fully supports the use of 
string fields for the zone and class data. 

 
 Spatial Analyst Tools > Local > Combine 

The way that this tool creates output field names has been enhanced. In some cases, temporary rasters 
needed to be created and these names were carried over such as "Z_Z_Zc41, Z_Z_Zc42...”.  The output now 
reflects the names of the input rasters used and handles cases of different raster formats and duplicate 
names.  

 
The Histogram tool  in the Spatial Analyst toolbar now uses the new graphing functionality added at 9.2. 

Histograms created with this tool will now match the colors being used to display the layer. See the separate section 
on graphing in this document.  
 

 
 
 
Serve your Spatial Analyst geoprocessing models to the web with ArcGIS Server 
 

You can now publish your spatial analysis workflows and models over the web as geoprocessing services that can 
be accessed by users in web mapping applications, ArcGIS Explorer, and ArcGIS Desktop. This provides you with a 

etely new way to deliver spatial analysis functionality both inside and beyond your organization. You'll need 
ArcGIS Server Advanced edition and the Spatial Analyst extension on your server
compl

. See the 'ArcGIS Server' and 
'Geoprocessing' chapters of this document. 
 
 
Other 9.2 enhancements of particular interest to Spatial Analyst extension users 
 

Full support for ESRI GRID Value Attribute Tables (VATs) and new Raster Attribute Tables (RATs) supported for all 
e band integer raster datasets. singl See the 'Rasters' chapter of this document. 

 
Three new vector to raster conversion tools have been added at 9.2 to give you more control over how values are 

ed to cells in the output raster when there is more than one vector feature falling into the cell. assign See the 
'Geoprocessing' chapter of this document. 
 

Two random data generation tools have been added for use in sensitivity analysis and simulation. See the 
'Geoprocessing' chapter of this document. 
 

ModelBuilder now supports list and series processing, iteration (looping) and batch processing. See the 
'Geoprocessing' chapter of this document. 
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Survey Analyst 

New
 

 Cadastral Editor 

The goal of the Survey Analyst extension is to improve the spatial accuracy of GIS data and to provide information 
about the accuracy of this data. At 9.2 Service Pack 3 we introduce a major enhancement to this extension. With 
Service Pack 3, the Survey Analyst in , but now also includes a new Cadastral Editor 
and new cadastral fabric data model.
 
- The Survey Editor is the same tech e Survey Editor includes a set of focused tools 

for defining and maintaining accurately measured co servations from total station 
e

- T l Editor includes the functionality, standard data model, and common workflows you need for building 
a dastral land re

 
Ma ystem build the base map for the other layers within the GIS. 
Pa  are b ntry. The accurate coordinate 
da s land descriptions to improve 
spa ase. rovides a framework and data model for efficiently 
performing these workflows.  
 

cludes the existing Survey Editor
 

nology as was available at 9.1. Th
ordinates based on field ob

quipment. 
 

he Cadastra
nd maintaining a ca cords system (a cadastral fabric). 

ny geographic information s s use cadastral records to 
rcel and cadastral databases
ta available from new technologie

uilt through coordinate geometry and plan data e
 and techniques can be combined with recorded 

tial accuracy in the geodatab  The new Cadastral Editor p

The Survey Analyst product licens or. They can 
be installed separately or together, a y 
technologies. You will see the name the Tools > 
Extensions dialog. Checking the box vey Analyst extension in that dialog enables whichever editors 

ave been installed. In the example below, both editors have been installed: 
 

e covers both the existing Survey Editor and the new Cadastral Edit
nd can also be used separately or together as complementary surve
of the editor(s) you install listed under the Survey Analyst entry in 
 next to the Sur

h

 
 

The Cadastral Editor works with
tinuous integrated surface of c

 a new type of parcel dataset, called a cadastral fabric. A cadastral fabric is a 
con nn g the complete survey record for an area of land.  
 
Dim bric ar nge in the survey record, for example, a parcel split 

r resurvey. Parcel boundary line dimensions in the cadastral fabric match the dimensions on the survey record. 
cords are retained as historic, thus always preserving the original 

d to each other by connection lines, for example, connection lines across 
ads. Because each and every parcel is either linked or connected, a seamless network of connected parcel 

boundaries, or cadastral fabric, is formed. Parcel lines have endpoints, which are the parcel corners. Parcel corner 
points are common between adjacent parcel boundaries, establishing connectivity and maintaining topological integrity 

o ected parcels, representin

ensions in the cadastral fa e edited in response to a cha
o
Parcels that are edited or replaced by new survey re
survey record. Parcel polygons are also linke
ro
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in po
share coincident geometry. 
 
Cad a
 

 the network. In the geodatabase, to logy is the arrangement that defines how point, line, and polygon features 

astral fabrics are stored in feature d tasets: 

 
 
The cadastral fabric acts as a basemap for overlying GIS feature classes. Feature classes such as building polygons 

l boundaries. The result is that GIS features are correctly aligned 

 

and utility lines are constructed in relation to parce
with the cadastral fabric. 

Here are the key elem  cadastral technology: ents of the new
 
-  as recorde subdivisions. 
 
- e spatial accuracy of the fa al record information from parcels using a least 

orithm designed by survey
 
- d. 
 

users.  

- Provides a COGO coverage equivalent in the geodatabase 
 
- Tracks the lineage of parcels based on their legal record end & start dates. 
 
- Manage subsets of the data as cadastral jobs.  
 
- t of interactive tools, including p
 

Provides a base-map for parcels d by cadastral surveyors through deeds and 

Improves th bric by processing the leg
squares alg ors.  

Spatially update GIS feature layers that coincide with the fabric on deman

- Extensible data model familiar to ArcGIS 
 

New se arcel construction tools: 
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In the Desktop Help, see: Extensions > Survey Analyst > Cadastral Editor 
 
 

 WHAT'S NEW IN ARCGIS 9.2 - PAGE  246 



 WHAT'S NEW IN ARCGIS 9.2 - PAGE  247 

Tracking Analyst 

Improved performance for very large historical datasets. 
 

A new Tracking Analyst Tools toolbox is available containing the following tools. 
 

 
 
You can add this toolbox into ArcToolbox from the System Tools folder. The first tool allows you to work with temporal 
data where the date and time is stored in separate fields. The second one allows you to create tracking layers, so that 
this process can be integrated into scripts, models, and batch processes. 
 

New Settings command in Tracking Analyst pulldown menu launches a Global Settings dialog. 
 

New Step Through Tracks tool in the Tracking Analyst toolbar allow you to step forwards or backwards through a 
series of events in a track displaying information for each event: 
 

 
 
You can also display up to six attributes for an event graphically on the map. As you step through events the 
information on the map will change based on the event selected: 
 

 
 

Adds the ability to use tables when building custom actions 
 

Events can now be labeled: 
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The most current event for a track can have unique symbology so that it stands out from the rest of the events: 
 

 
 

Tracking Analyst now supports directional vectors. Based on the current speed and heading you can display an 
arrow showing the projected direction and time the next event may occur: 
 

 
 

Smooth tracks – New line algorithm can be used to smooth the track path eliminating spikes at sharp turns: 
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Now supports local GPS connection. 
 

You can copy events to the clipboard to be pasted into other applications. Choose from three formats: text, XML 
and GML. 
 

The ArcObjects interface has been improved to allow developers to build real-time connections (outside of Tracking 
Server). 
 

The extension now supports ArcGIS Engine providing new ways to deploy tracking layers. 
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  Summary of map navigation shortcuts in ArcMap 
 

Panning  
Click mouse wheel: Center map at location you clicked 
Hold down mouse wheel: Pan map 

Hold down  Temporarily switch to Pan tool. Single click centers. Drag pans 

 
Page map left / right / up / down 

 
Scroll map left / right / up / down 

Single-click with any pan tool: Center map at location you clicked 
 

Zooming  
Roll mouse wheel: Zoom in / out. Direction can be customized in Tools>Options dialog. 
CTRL + roll mouse wheel: Zoom in / out at finer rate 
CTRL + click mouse wheel: Center map and zoom in at location you clicked 

CTRL + drag mouse wheel: Zoom in on box you define 

Hold down  or  Temporarily switch to Zoom In or Zoom Out tool 

Hold down  
Temporarily switch to Continuous Zoom / Pan tool. Drag up / down 
with left mouse button to zoom in / out. Right mouse button pans 

 
Zoom out / in 

 
Other  
Right-click map in Data View: Access new context menu of shortcuts to commands 
Hold down SHIFT while in 
Layout view: 

Apply map navigation with mouse wheel, Z X C B keys, or 
Continuous Zoom/Pan tool to data frame instead of layout page 

 Put keyboard focus onto map from Table Of Contents 

 Put keyboard focus onto Table Of Contents from map 

 Refresh map 

 Toggle between Zoom In, Zoom Out, & Pan tools when one is active 

 Toggle Pause Drawing mode 

 Activate selected data frame in Table Of Contents 

 Full extent 

 Previous extent / next extent 

CTRL + TAB: Switches between data frames when there is more than one 
CTRL + click check box next  
to layer in Table Of Contents: 

Turn all layers on and off. CTRL + SPACE does the same when 
layer is selected in Table Of Contents 

ALT + click data frame in TOC: Activate this data frame 
ALT + click layer in TOC: Zoom to this layer's extent  
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Summary of tables shortcuts 
  
Opening and closing tables 

CTRL + double-click layer or table Open table window for the layer or table you clicked in Table Of Contents. 
CTRL + T or CTRL + ENTER  Open table window for currently selected layer/table(s) in Table Of Contents.  
CTRL + T in table window  Minimizes the window.  
CTRL + SHIFT + T  Toggle all tables between displayed and minimized state (show/hide all) 
CTRL + SHIFT + TAB   Toggles between the tables you currently have open.  
CTRL + SHIFT + F4  Close all currently open tables.  

 
Working with fields 

Right-click field name Get context menu of field commands. 
Choose Properties in context menu See field's data type and specify alias and numeric format. 
Double-click field name Sort on this field. 
CTRL + Double-click field name Turn field off. Same as unchecking it in the Layer Properties Fields tab. 
CTRL + SHIFT + Double-click  Hide this field (same as dragging its column so it has no width). 
Double-click column divider Reveals hidden field if the divider is next to a hidden field.   

 
Navigating around a map from a table 

Right-click grey cell Get context menu of navigation and other commands. 
Double-click grey cell Zoom to this feature and select it exclusively. 
CTRL + Double-click grey cell  Pan to this feature and select it exclusively. 
CTRL + 8  Flash current feature. 
CTRL + =  Zoom to current feature. 
CTRL + P Pan to current feature. 
CTRL + I Identify the current record. 
CTRL + SHIFT + = Zoom to selected features. 
 

Navigating around inside a table 
   Go left or right. Wrap back to start of same record at end of row. 
 or ENTER  Go to the cell below. 
 or SHIFT + ENTER  Go to the cell above. 

HOME or END Go to the first or last cell in the current row 
CTRL +  or  Go to the first or last cell in the current row. 
TAB  Go to the cell to the right. Wraps around to next record below at end of row. 
SHIFT + TAB  Go to the cell to the left. Wraps around to next record above at start of row. 
CTRL +  or  Go to the first or last cell in the current column. 
CTRL + HOME or END Go to first cell in first row or last row in last row.  
CTRL + F  Launch Find dialog. 
CTRL + G Go to a record number.   
Application key  Open the row context menu.  
CTRL + Application key  Open the Options menu. 
Right-click bottom part of table Open the Options menu. 
 

Copying data from a table 
CTRL + C or CTRL + INSERT  Copy the value in the current cell to clipboard. 
CTRL + SHIFT + C Copy selected records to clipboard. 
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Selecting and unselecting records 
CTRL + click on a record Add it to the selected set (or remove it if it is already selected). 
SHIFT + click on a record Extend the selection from currently selected record(s) to the record you click. 
SHIFT + SPACEBAR or  or  Make block selection. 
CTRL + TAB  Switch between Show All Records and Show Selected Records mode. 
SPACEBAR Select or unselect the current record (highlights or unhighlights if in Show 

Selected Records Mode). In editing mode shortcut is CTRL + SPACEBAR. 
BACKSPACE Remove the current record from the selection in Show All or Show Selected 

Records Mode. Not available if you are editing the table. 
CTRL + ENTER Go to next record and select it. Unselects the one you began on if it was 

selected. Lets you work sequentially through a table selecting each record. 
SHIFT + CTRL + ENTER  Go the previous record and select it. 
Click top left corner of table  Clear the selected set (highlighted set in Show Selected Records). 
SHIFT + click top left corner  Select all records. 
CTRL + click top left corner Switch selection. 
CTRL + BACKSPACE  Clear the selected set. 
CTRL + A Select all records. 
CTRL + SHIFT + A Clear the selected set. 
CTRL + U Switch selection. 

 
Editing the data in a table 

CTRL + SHIFT + E Start or stop editing . 
F2 Edit contents of current cell. Press again to finish editing cell. 
ESC Cancels editing the current cell and restores the original value. 
ENTER Finish editing cell and go down to the next cell below in same field. 
TAB Finish editing cell and go across to next cell to the right in same record. 

Wraps around to next record below when you get to the end of the row.  
CTRL + ENTER Same as ENTER but selects the next record too so you can see it on map.  
CTRL + V or SHIFT + INSERT  Paste the contents of the clipboard into the current cell.  
CTRL + Z and CTRL + Y Undo/Redo edits to a record. 
DELETE  Delete currently selected record(s). 
CTRL + D In Show All Records mode, deletes currently selected records(s). In Show 

Selected Records mode, deletes the currently highlighted (yellow) records in 
your selection. 

SHIFT + ENTER Inserts a line feed into a text string when you are editing it (for example, to 
use as stacked text for labeling or annotation).  

 
 

Some extra Desktop tips 
 
-  Click inside the Table Of Contents window or the table window and press F1 to get a list of shortcuts for that window. 

- Get context sensitive help on any command in any menu: highlight the command and press SHIFT + F1. Get context 
sensitive help on any toolbar button by clicking on it with the What's This ? tool in the Standard toolbar. Context help 
will tell you what it does, why it becomes disabled, and what shortcuts are available for it.  

- Measure tool (except for globes): Hold down CTRL to snap to any part of a line instead of only to vertices when are 
measuring in 'snap to features mode'. To get geodesic measurements when you measure lines, hold down SHIFT. 

- Drawing tools in ArcMap's Draw toolbar: To type in coordinates for vertices, press SHIFT + F6. Press E to type in the 
last vertex in a rectangle, line or polygon. To type in the radius or area when you use the Circle tool, press R or A.  

- Make it easier to access bookmarks by choosing Tools > Customize and then dragging the Bookmarks pullright out 
of the View menu and into the main menu bar. This will turn it into a new pulldown menu called Bookmarks. 
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