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Welcome to ArcGIS Desktop 9.1 
 
ArcGIS 9.1 introduces a new extension, the ArcGIS Network Analyst extension, adds important new capabilities, 
and improves quality. This document guides you through what is new in 9.1 compared to 9.0.  
 
Highlights (core) 

More geoprocessing tools for ArcView and ArcEditor users. Licensing for geoprocessing tools has been 
enhanced so that if functionality is available in the core ArcGIS user interface for a particular license level, its 
corresponding geoprocessing tool will now be available at the same license level. This provides ArcView users 
with almost 50 more tools than they had access to at 9.0, and ArcEditor users with 70 more.  

New geoprocessing tools. A Merge tool has been added into the Data Management \ General toolset that 
lets you combine multiple inputs into a new output. A new system toolbox called Samples can be added into 
your ArcToolbox window. This provides tools for performing overlays on very large datasets using a new tiling 
scheme, new conversion tools for raster and CAD data, and a tool for defining coordinate systems in batch. 

StreetMap USA data and functionality can now be used by everyone free of charge. The StreetMap 
extension has become part of the core functionality in ArcGIS Desktop, ArcGIS Engine and ArcGIS Server, and 
is no longer a separate extension. This enables all ArcGIS users to perform nationwide geocoding and routing 
with the StreetMap USA data that comes with ArcGIS. Street data for other countries is available separately. 

ArcPress can now be used by everyone free of charge. The ArcPress extension has become part of the 
core functionality in ArcGIS Desktop and is no longer a separate extension. ArcPress is a rasterizer that 
supports high-quality printing on a wide range of printers. 

ArcView users can now create and edit subtypes in personal geodatabases. Subtypes are subsets of 
features in a feature class or records in a standalone table that share the same attributes. 

All linear referencing functionality is now provided for ArcView and ArcEditor users. ArcView and 
ArcEditor users can now use the full range of linear referencing functionality, including creating routes, editing 
routes, and performing geoprocessing on linear referenced data.  

Improved quality. ArcGIS 9.1 includes all the quality improvements from the 9.0 service packs. Additional 
quality improvements and user interface enhancements have been made in a number of areas. 9.1 also 
includes support for Open Geospatial Consortium, Inc (OGC) Web Map Service (WMS) data, which was 
originally introduced in ArcGIS 9.0 Service Pack 2.  

Backwards compatibility of files. You can now save map documents (.mxd files), layer files (.lyr files) and 
scenes (.sxd files) so they can be opened in ArcGIS 8.3. Maps, layer files, scenes, and globes created in 
ArcGIS 9.1 are directly compatible with ArcGIS 9.0. 
 

Highlights (extensions) 

New ArcGIS Network Analyst extension. This new extension lets you create, manage and analyze 
transportation networks to solve problems such as finding routes, closest facilities and service areas. The 
extension includes interactive tools in ArcMap along with geoprocessing tools for scripting and modeling. 
Network Analyst applications can be delivered using ArcGIS Engine or put on the web with ArcGIS Server. 

New release of ArcGIS Schematics extension. With this extension you can generate schematic diagrams 
representing the connectivity of linear and network data in your GIS. This new release features tighter 
integration with the ArcGIS Desktop environment and adds the ability to store schematic datasets in the 
geodatabase. It is now part of the ArcGIS Desktop setup and therefore no longer has to be installed separately. 

ArcGIS Publisher now lets you publish ArcGlobe documents. The ArcGIS Publisher extension is now 
supported in ArcGlobe, enabling you to publish ArcGlobe documents (.3dd files) as PMF files so they can be 
viewed with ArcReader. New 3D navigation tools have been added to ArcReader to support viewing globes.  

ArcScan. This extension can now be used by ArcEditor and ArcInfo users free of charge. 
Maplex for ArcGIS. This extension can now be used by ArcInfo users free of charge. Significant 

improvements have also been made to the scalability, performance and quality of the Maplex labeling engine. 
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Compatibility and Migration 
 
Files 
 

Map documents (.mxd files), layers (.lyr files), scenes (.sxd files) and globes (.3dd files) that you create or 
modify in ArcGIS 9.1 are directly compatible with ArcGIS 9.0. You can share these files with people using 
ArcGIS 9.0 without performing additional steps, and 9.1 files that are modified in 9.0 can still be used in 9.1. 
 
The only exception to this is that layers based on new data types added at 9.1 will not be present if you open a 
9.1 .mxd in 9.0. The new data types added at 9.1 belong to extensions: network datasets created with the new 
ArcGIS Network Analyst extension, and schematic datasets created with the new release of the ArcGIS 
Schematics extension.  
 

You can now save map documents, layer files, and scene documents so they can be opened and used in 
ArcGIS 8.3. This makes it easy to share those files with other users who have not yet upgraded to ArcGIS 9.x.  
 
-  To save a map document from ArcMap 9.1 so it can be used in 8.3, use the new Save A Copy command in 

the File pulldown menu. At the bottom of the dialog that appears, choose 'ArcMap 8.3 Documents (*.mxd)' 
from the Save As Type dropdown list. This will save a copy of your current map document in 8.3 format.  

 
 You will find the same command in the File pulldown menu in ArcScene so that you can save a copy of your 

scene into 8.3 format. ArcGlobe doesn't have this command because that application was introduced at 9.0. 
 
- To save a layer file from ArcMap 9.1 or ArcScene 9.1 so it can be used in 8.3, right-click the layer in the Table 

Of Contents and choose the Save As Layer File command. At the bottom of the dialog that appears, choose 
'8.3 Layer files (*.lyr)' from the Save As Type dropdown list. This will save the layer file in 8.3 format. 

 
There are some limitations associated with this new feature that may require some preparation and planning, 
especially if you would like to use it to share maps that reference geodatabase data with 8.3 users. 
 
Saving a map document, layer or scene to 8.3 does not necessarily mean that the data referenced by that file 
will be accessible by 8.3. When you save a file to 8.3 format, the source data referenced by that file is not 
changed or affected by this procedure. No automatic data conversion takes place. This means that if the file 
references data that is not supported in 8.3, this data will not be drawn when you open the file in 8.3. You will 
see broken links in 8.3 for layers that reference data sources that are not supported in 8.3.  
 
Data sources not supported in 8.3 include: 
 
- Data sources that were introduced into the product in the 9.x releases, including raster datasets in personal 

geodatabases, 9.x raster catalogs in geodatabases, ArcGIS Server map services, and Open Geospatial 
Consortium, Inc (OGC) Web Map Service (WMS) layers.  

 
- Data sources in geodatabases that have been upgraded in 9.x.  
 
For example, suppose your map references data in a personal geodatabase or enterprise geodatabase that was 
upgraded in 9.x to take advantage of new database functionality introduced at 9.x. You can save your map so it 
can be opened in 8.3, but 8.3 won't be able to draw the data in the 9.x geodatabase. This is because 
geodatabases upgraded in 9.x are not backwards compatible to 8.x. File-based data sources such as 
shapefiles, coverages and file-based rasters don't present a problem in this regard.  
 
In certain situations you may need to do some data conversion before saving your document to 8.3 format. For 
example, you might choose to export data from 9.x geodatabases to shapefiles before saving to 8.3 format. 
 
When you use the new File > Save A Copy command in ArcMap or ArcScene to save a 9.x document to 8.3 
format, a dialog appears listing any layers in your current document that 8.3 won't be able to draw: 
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An additional area to be aware of when you save files to 8.3 format is how map and layer properties are treated. 
When you save a map document, layer or scene to 8.3, the format of the file is changed to eliminate properties 
not available in the 8.3 version of the product. This can result in certain properties or settings you may have 
specified in 9.x being lost or converted back to a similar setting available in 8.3.  
 
For example, in ArcMap 9.0 we added a description property to feature and raster layers that enables you to 
store comments about the layer in a Description box in the General tab of the Layer Properties dialog. Suppose 
you have entered a description about a layer and now you save the map document to 8.3 format (or you save 
the layer as a 8.3 layer file). When you open that 8.3 .mxd or .lyr file in ArcMap 8.3 you won't see this 
description. You don't expect to see it because 8.3 doesn't support these descriptions for layers. However, if you 
now open that 8.3 file in 9.0, the description you originally entered won't be there anymore either, because the 
process of saving the file in 8.3 format eliminated that property. So bear in mind that some work may be lost if 
you save a 9.x file in 8.3 format and then start working with it again in 9.x.  
 
Properties added in 9.x that are not supported in 8.3 include: 
 
- Symbols and symbol properties new to 9.x. For example, 3D symbols are converted to 2D symbols. 
 
- Maplex Labeling Engine properties. Data frames labeled with the ESRI Maplex Labeling Engine will be labeled 

with the ESRI Standard Labeling Engine. 
 
- The Colormap renderer for rasters. Rasters symbolized with the 9.x Colormap renderer are symbolized with 

Unique Values in 8.3. 
 
- Certain coordinate systems that were added at 9.0. 
 
Visual Basic for Applications (VBA) code is retained and is not altered when a map document or scene is saved 
to a previous version. Therefore, you may need to convert references to ArcGIS 8.3-compatible object libraries. 
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For more information and tips about saving to previous versions, see the 'ArcMap > Getting Started > Saving To 
Previous Versions of ArcGIS' section in the ArcGIS Desktop Help, or look up 'Save A Copy' in the ArcGIS 
Desktop Help Index. 
 
To review the changes to ArcGIS that occurred between 8.3 and 9.0 to take into account when you use the 
Save A Copy to 8.3 format functionality, see the 'What was new in ArcGIS Desktop 9.0' section in the ArcGIS 
Desktop Help or the document entitled 'Whats_New_In_ArcGIS_Desktop_90.pdf' in your arcgis / documentation 
folder. 
 
 
Geodatabases 
 

Geodatabases are directly compatible between 9.0 and 9.1. You can access and edit 9.0 geodatabases in 
9.1 without upgrading them, and geodatabases that you create, modify or upgrade in 9.1 can be accessed and 
edited in 9.0.  
 
There is one situation in which you will need to upgrade a geodatabase from 9.0 to 9.1: The new ArcGIS 
Network Analyst extension gives you the option of creating network datasets in geodatabases. If you want to 
create network datasets in an existing geodatabase you must upgrade the geodatabase to 9.1 in order to do 
this.  
 
The new release of the ArcGIS Schematics extension stores schematic datasets in the geodatabase. 
However you don't need to upgrade existing 9.0 geodatabases to 9.1 in order to add schematic datasets into 
them. 
 
Geodatabases (both personal and ArcSDE) that you upgrade to 9.1 can be accessed and edited in 9.0. (Note: 
This is a feature we have implemented specifically for the 9.1 release. It is not a general change to how 
geodatabase upgrades work, and for technical reasons we do not plan on providing this feature for future 
releases.) 
 
Note: Although you can use 9.0 to edit geodatabases that have been upgraded to or created with 9.1, you 
should avoid using 9.0 to edit feature classes that participate in network datasets created with the 9.1 Network 
Analyst extension. Because 9.0 does not recognize network datasets, editing the network's participating feature 
classes may render it unusable.  For example, connecting to a 9.1 geodatabase with a 9.0 client and deleting 
the system junction feature class of a network dataset, will result in any 9.1 client being unable to open the 
network dataset. ArcGIS 9.1 prevents these types of edits and ensures the network dataset and its feature 
classes are edited in a consistent manner. 
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Geoprocessing 
 

 Licensing for geoprocessing tools has been changed to remove the inconsistencies present in 9.0 in which 
some functionality could be performed in the core user interface but not performed in the geoprocessing 
framework with the same level of licensing. With this change, if functionality is available in the core GUI for a 
particular license level, its corresponding geoprocessing tool will now be available at the same license level. 
Compared to 9.0, this licensing change provides ArcView users with nearly 50 more tools and ArcEditor users 
with 70 more tools. This makes it easier to create and share scripts and models for many important 
geoprocessing work-flows: 
 
Licensing level Number of tools at 9.0 Number of tools at 9.1 
ArcView   97 144 
ArcEditor  99 169 
 
If you are an ArcView user, here are the tools you can use in 9.1 that were not available to you in 9.0: 
 
Tool Toolset 
Select Analysis Tools \ Extract  
Table Select Analysis Tools \ Extract  
Summary Statistics Analysis Tools \ Statistics  
Compact Data Management \ Database  
Add Coded Value To Domain Data Management \ Domains  
Assign Domain To Field Data Management \ Domains  
Create Domain Data Management \ Domains  
Delete Coded Value From Domain Data Management \ Domains  
Delete Domain Data Management \ Domains  
Domain To Table Data Management \ Domains  
Remove Domain From Field Data Management \ Domains  
Set Value For Range Domain Data Management \ Domains  
Table To Domain Data Management \ Domains  
Calculate Default Cluster Tolerance Data Management \ Feature Class  
Calculate Default Spatial Grid Index Data Management \ Feature Class  
Integrate Data Management \ Feature Class  
Delete Features Data Management \ Features  
Assign Default To Field Data Management \ Fields  
Add Attribute Index Data Management \ Indexes  
Add Spatial Index Data Management \ Indexes  
Remove Attribute Index Data Management \ Indexes  
Remove Spatial Index Data Management \ Indexes  
Add join Data Management \ Joins  
Remove Join Data Management \ Joins  
Save To Layer File Data Management \ Layers and Table Views  
Select Layer By Attribute Data Management \ Layers and Table Views  
Select Layer By Location Data Management \ Layers and Table Views  
Add Subtype Data Management \ Subtypes  
Remove Subtype Data Management \ Subtypes  
Set Default Subtype Data Management \ Subtypes  
Set Subtype Field Data Management \ Subtypes  
Get Count Data Management \ Table  
Create Feature Dataset Data Management \ Workspace  
Create Folder Data Management \ Workspace  
Create Personal GDB Data Management \ Workspace  
Calibrate Routes Linear Referencing Tools  
Create Routes Linear Referencing Tools  
Dissolve Route Events Linear Referencing Tools  
Locate Features Along Routes Linear Referencing Tools  
Overlay Route Events Linear Referencing Tools  
Transform Route Events Linear Referencing Tools  
Cluster/Outlier Analysis with Rendering Spatial Statistics Tools \ Mapping Clusters  
Hot Spot Analysis with Rendering Spatial Statistics Tools \ Mapping Clusters  
Central Feature Spatial Statistics Tools \ Measuring Geographic Distributions  
Collect Events with Rendering Spatial Statistics Tools \ Utilities  
Count Rendering Spatial Statistics Tools \ Utilities  
Z Score Rendering Spatial Statistics Tools \ Utilities 
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If you are an ArcEditor user, here are the tools, in addition to the ones listed above for ArcView users, you can 
use in 9.1 that were not available to you in 9.0: 
 
Tool Toolset 
Compress Data Management \ Database  
Check In Data Management \ Disconnected Editing  
Check In From Delta Data Management \ Disconnected Editing  
Check Out Data Management \ Disconnected Editing  
Export To Delta Data Management \ Disconnected Editing  
Simplify Line Data Management \ Generalization  
Smooth Line Data Management \ Generalization  
Create Relationship Class Data Management \ Relationship Classes  
Table To Relationship Class Data Management \ Relationship Classes  
Analyze Data Management \ Table  
Change Privileges Data Management \ Table  
Add Feature Class To Topology Data Management \ Topology  
Add Rule To Topology Data Management \ Topology  
Create Topology Data Management \ Topology  
Remove Feature Class From Topology Data Management \ Topology  
Remove Rule From Topology Data Management \ Topology  
Set Cluster Tolerance Data Management \ Topology 
Validate Topology Data Management \ Topology 
Alter Version Data Management \ Versions 
Create Version Data Management \ Versions 
Delete Version Data Management \ Versions 
Post Version Data Management \ Versions 
Reconcile Version Data Management \ Versions 
Register as Versioned Data Management \ Versions 
Unregister as Versioned Data Management \ Versions 
 
To see if a particular tool is now available for your licensing level, simply open the ArcToolbox window after you 
have installed 9.1. By default, tools that are not available for your license level are not shown in ArcToolbox. To 
see all the tools, including ones that are not available for your license level, right-click the top level entry in the 
tree and uncheck Hide Locked Tools. Tools that are not available are shown with a lock icon. 
 

At 9.1 all linear referencing functionality is now available at all license levels, including all the geoprocessing 
tools in the Linear Referencing toolbox. 
 

A new Merge tool has been added into the Data Management \ General toolset in ArcToolbox. This tool, 
available at all license levels, combines multiple input features into a new feature class. It has a powerful field 
mapping option that gives you complete control over the output’s field definitions. 
 

A new toolbox called Samples is provided at 9.1. This provides a number of useful tools including overlay 
tools that operate on very large datasets, and utilities to facilitate these operations. The tools for overlaying large 
datasets overcome system memory limitations by using an adaptive partitioning scheme to tile the data being 
processed. Each tile contains data that can be processed within the system's available memory. The Samples 
toolbox also contains some new conversion tools for raster and CAD data, and a new batch tool for defining 
coordinate systems for multiple datasets.  
 
To add the Samples toolbox into your ArcToolbox window, right-click the ArcToolbox entry at the top of the 
window and choose Add Toolbox and then browse to the Toolboxes \ System Toolboxes folder to find the 
toolbox. Some of the tools in the Samples toolbox require an ArcInfo license.  
 
For more information about the Samples toolbox, see the 'Geoprocessing tool reference > Samples toolbox' 
section of the ArcGIS Desktop Help. The topics in the 'Geoprocessing tool reference > Samples toolbox > 
Analysis tools' section describe the new overlay functionality for large datasets. 
 

A new command called 'Geoprocessing' has been added into the ArcToolbox category in the Tools > 
Customize dialog in ArcMap. You can drag and drop this new command from that dialog into any pulldown 
menu or toolbar in the usual way. This command launches a window that makes it easy to access the most 
commonly used geoprocessing tools provided by the geoprocessing framework, including Append, Buffer, Clip, 
Intersect, Union, etc. This is particularly useful for users who only use geoprocessing tools occasionally and 
don't usually need access to the full range of tools accessible in the ArcToolbox and Command Line windows. 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.1 COMPARED TO 9.0 PAGE  9 

ArcMap  
 
General 
 

The Pause Drawing command, which was introduced at 9.0, has been added to the standard interface as a 
new button next to the Refresh button at the bottom of the ArcMap window: 
 

 
 
The new default keyboard shortcut for Pause Drawing is F9. You can customize this keyboard shortcut in the 
usual way via the Tools > Customize dialog. This shortcut, like F5 for Refresh, works when the map has 
keyboard focus. 
 

The message that appears if you add data with no spatial reference to ArcMap has been enhanced. If you 
add multiple data sources into ArcMap at once and one or more of them don't have a spatial reference, the 
message now lists the name of each of the data sources involved: 
 

 
 

The way that ArcMap handles error messages that occur while data is being drawn has been improved. 
When one or more layers can't be drawn in a data frame for any reason, a resizable window opens up listing the 
error message for each layer involved. You can leave this window open while you investigate the issue. To 
prevent the errors from appearing, turn the layers off in the Table Of Contents, or remove them from your map. 
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When you zoom in or out in ArcMap, the scale displayed on the Standard toolbar now updates to reflect the 

new scale of the map before the map starts to redraw. In this way, if you press ESC to stop drawing the map, 
the scale shown for the partially drawn map is correct. It also saves you having to wait for the map to redraw 
before being able to see what the new scale is. 
 
 
Map documents 
 

Backwards compatibility: You can now save map documents so they can be opened and used in ArcGIS 8.3. 
Use the new Save A Copy command in the File pulldown menu. At the bottom of the dialog that appears, 
choose 'ArcMap 8.3 Documents (*.mxd)' from the Save As Type dropdown list. You can also save layer files 
from ArcMap 9.1 so they can be used in ArcMap 8.3. Right-click the layer in the Table Of Contents and choose 
the Save As Layer File command. At the bottom of the dialog that appears, choose '8.3 Layer files (*.lyr)' from 
the Save As Type dropdown list. Map documents or layer files created or modified in 9.1 are directly backwards 
compatible with ArcMap 9.0. You can share these files with people using ArcMap 9.0 without performing any 
additional steps. For more information, see the 'Compatibility and Migration' section of this document. 
 

Legend Properties dialog: You can now change the text symbol used by multiple legend items using new 
controls added into the Items tab. With these controls, you can change the text symbol of all the items in the 
legend or just the ones you have selected in the list. A dropdown list of options lets you choose which parts of 
the legend items you want the text symbol to be applied to: 
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Selecting features 
 

Select By Attributes dialog/Query Builder: The layout of this dialog has been improved to provide more space 
for long field names and long unique values. Long field names no longer get truncated in the list of fields, so 
when the field names are wider than the fields list and the horizontal scroll bar appears, you can now scroll to 
the right and see the complete field name. A vertical scroll bar has also been added to the expression box. 
These changes are also reflected on all other Query Builder dialogs in the product. 
 
An OK button has been added to the Select By Attributes dialog so you can run a query and dismiss the dialog 
in one click. The Query Wizard button and the wizard it launched have been removed from Select By Attributes 
dialog: 
 

 
  

Do you often want to just make one feature layer selectable in your map and make all the other feature layers 
unselectable, such as before you start using the Edit tool to edit a particular layer's features? In 9.1 you can do 
this very easily without having to go to the Selection tab in the Table Of Contents or the Selection > Set 
Selectable Layers dialog. Just right-click the layer, look in the Selection pullright and choose the new 'Make This 
The Only Selectable Layer' command. This command is accessible from all the tabs in the Table Of Contents. 
 

A new command called 'Pan To Selected Features'  has been added to the Selection pulldown menu and 
the Selection pullright in the context menu for a feature layer. This centers the map on the currently selected 
features without changing the map's scale. This is particularly useful if you are selecting individual features via a 
query or in a table and you want to see where the features are without changing the scale of your map. 
 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.1 COMPARED TO 9.0 PAGE  12 

Tip: When multiple features are selected, the Pan To Selected Features command centers the map on the 
center of a rectangular envelope that encompasses all the features. When you use this command you therefore 
won't necessarily see all of your currently selected features, because they may be too far apart for them all to 
appear on your map at its current scale. 
 

The Table Of Contents Selection tab is now easier to read when features are selected. The number of 
selected features is still listed but not the text that used to say "features selected": 
 

 
 
The tab also now updates correctly when you select features in Layout view. 
 

In the Selection category in the Tools > Customize dialog, the control that was previously called 'Combination 
Method' has been renamed to 'Interactive Selection Method'.  
 
 
Identify tool 
  

You can now copy values and field names out of the Identify Results window. Right-click a value or field 
name and choose Copy: 
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You can now choose which option the Identify tool will default to the first time you use it in a session. 
Previously there was no way to control the default, and the tool always defaulted to <Top Most Layer>. To 
change the default, go to the Tools > Options dialog in ArcMap. You can find the setting in the General tab. This 
setting applies to all ArcMap sessions. It also applies to ArcScene and ArcGlobe (these applications use the 
setting specified in ArcMap's Tools > Options dialog). 
 
Note: If you have already used the Identify tool in your ArcMap session prior to using the new option in the 
Tools > Options dialog to change the default, you may notice that if you use the Identify tool again in the same 
session, it doesn't use the default you chose. This is because once you use the Identify tool in a session, the 
tool remembers which option you used for the duration of the session, and doesn't normally revert to its default.  
 
Tip: The <Selectable layers> option in the Identify Results window can be useful as your default because it 
restricts identify to the same set of layers that the interactive selection tools operate on. In this way you can use 
the Selection tab in the Table Of Contents or the Selection > Set Selectable Layers dialog to specify exactly 
which layers you want to identify. 
  

You can now quickly expand the tree on the left side of the Identify Results window so it is easier to work with 
features from multiple layers. Like in the Table Of Contents, you can now hold down CTRL and click any +/- 
control in the tree to expand or contract all the nodes at that level.  
 

If you use the arrow keys to navigate up and down through the tree on the left side of the Identify Results 
window, the features now flash in the map as you select them. In 9.0 they only flashed if you clicked on them in 
the tree with the mouse. 
  
 
Hyperlinks  
 

The Hyperlink tool now respects the selection tolerance specified in the Selection > Options dialog. 
 

You now get a message if you click on a hyperlink to a document that cannot be found. 
   

The dialog that pops up when multiple hyperlinks are found is now easier to use. This dialog can be resized 
and its size and position are remembered for the duration of your session. If hyperlinks from multiple features 
are found at the point you clicked, each hyperlink is listed with the primary display field value for the feature it 
belongs to. If hyperlinks from multiple layers are found, the names of the layers are also shown in the list.  
 

You can now prevent ArcMap from always adding a separator between the hyperlink base you specify for 
field based hyperlinks in the File > Map Properties dialog and the value of the hyperlink field. By default, ArcMap 
adds a forwards slash / in the case of a hyperlink to a URL and a backwards slash \ in the case of a hyperlink to 
a document. You can now override this default so that no slash is automatically added after the hyperlink base. 
You can find this setting by launching the AdvancedArcMapSettings.exe utility (from your arcgis \ utilities folder) 
and looking in the Miscellaneous tab. Overriding the default makes it easier to work with long paths and URLs.  
 
For example, if you wanted to use the hyperlink base setting with long URLs such as:  
 

http://www.example.com/index.cfm?parameter=1234 
 

you previously had to specify http://www.example.com as the base and store everything that comes after that, 
i.e. index.cfm?parameter=1234, in the hyperlink field, which is an inconvenient value for a field. By overriding 
the default you can specify most of the URL as the base: 
 

http://www.example.com/index.cfm?parameter= 
 

and just store the last part of the URL, 1234, in the hyperlink field. If you override the default, ArcMap will still 
retain the slash if the hyperlink base specified in your Map Properties dialog ends in a slash character. So if you 
override the default you can still add a slash manually to the hyperlink base. Note: this setting only applies to 
your machine and is not stored as a property in the map document you are working with.  
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Exporting data 
 

In the Export Data dialog accessed by right-clicking a feature layer in the Table Of Contents and choosing 
Data > Export Data, we have added a new radio button option. This lets you specify that the coordinate system 
of the output feature class will be the same as the coordinate system of the feature dataset you export the data 
into. The Export Data dialog has always supported this functionality, but this option was not shown explicitly in 
the user interface.  
 

  
 
When you specify a feature class in a feature dataset as your output, this option has to be used. If you use the 
Browse button in the dialog and specify a feature class in a feature dataset as your output, the dialog will 
automatically choose the option for you and disable the other two: 
 

 
 

The browser launched from the Export Data dialog for both feature layers and raster layers now remembers 
the last location into which you exported data, and defaults to that location when you launch it. This location is 
persisted between ArcMap sessions and is used exclusively for exporting data from layers in the Table Of 
Contents. 
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New Swipe tool 
 

A new tool called Swipe  has been added into the Effects toolbar: 
 

 
 
The Swipe tool is used to interactively reveal layers beneath the layer you chose to swipe. This tool makes it 
easy to quickly see what is underneath a particular layer without having to turn it off in the Table Of Contents. 
 
To use the tool, choose the layer you want to swipe from the Layer dropdown in the Effects toolbar. Then move 
the cursor over the map. You will notice that the cursor changes based on whether you are hovering over the 
top, bottom, left or right of the map. This lets you choose the direction you would like to swipe the layer. Now 
hold down the left mouse button and drag. This will swipe the layer in the direction you were hovering over. The 
tool only works in Data view. (This tool is also available in the 3D Effects toolbar in ArcGlobe.) 
 
 
Tables 
  

Long field names no longer get truncated in the Field Calculator. A horizontal scroll bar has been added to 
the fields list to better support working with long fields. A vertical scroll bar has been added into the expression 
box and very long expressions now wrap inside the box.  
 
 
Expressions 
 

The Load and Save buttons on all dialogs that let you load and save expressions, such as Select By 
Attributes/Query Builder, the Field Calculator, and the Label Expression dialog, now have their own dedicated 
'last-used' folder location. The dialogs launched by these buttons now always default to the folder you used last 
to save or load an expression. This makes it easy for you to keep all your expressions in one place, such as a 
separate folder you keep just for this purpose, or the folder containing data for the project you are currently 
working on. 
 
 
Annotation groups 
  

It is now much easier to work with multiple annotation groups in a data frame. The <Default> annotation 
group no longer has to be turned on for you to select or edit elements in other annotation groups. In addition, the 
contents of the <Default> group no longer get selected when that group is turned off in the Data Frame 
Properties dialog Annotation Groups tab. For example, in ArcMap 9.0 the Edit > Select All Elements command 
selected all the annotation in the <Default> group, even when that group was turned off. This is fixed in 9.1. 
 
 
Symbology 
 

Classification dialog: The median value has been added to the classification statistics. In addition, a number 
of options that were never implemented have been removed from the dialog, such as the custom min/max 
options and the Advanced Statistics button. 
 
 
Reports 
 

ArcGIS 9.1 includes the latest release of Crystal Reports™: Crystal Reports Version XI For ESRI. 
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Editing 
 

We have renamed the Network Editing toolbar to be the Geometric Network Editing toolbar. This is to make it 
clear that this toolbar is for working with geometric networks, and is unrelated to the new Network Analyst 
extension and the network datasets that extension enables you to create.  
 
 
Versioning 
 

The Conflicts dialog now uses an object’s row identifier as the primary display key field instead of the layer’s 
primary display field when listing conflicts. In the example below, the Primary Overhead class’s row identifier 
values are listed and row 97332 is highlighted. The row's attributes are displayed in the lower half of the dialog. 
In addition, the Conflicts dialog now uses domain values when displaying column attribute values in each of the 
three property columns (Conflict, Edit, and Pre-Edit). For example in the dialog below, the field Conductor Level 
shows the domain values 'Middle' and 'Bottom' instead of the actual attribute value of 1 and 2: 
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Table Of Contents 
 

If you are manipulating the Table Of Contents using the keyboard there is a new keyboard shortcut that 
makes it easy to toggle all the layers in a data frame on or off. When one layer is highlighted (selected) in the 
Table Of Contents, press CTRL+SPACE BAR. This does the same thing as holding down CTRL and clicking 
the check box for a layer.  
 
Tip: To give the Table Of Contents keyboard focus, click inside it or press F3. To see a help topic describing all 
the shortcuts for the Table Of Contents, click inside it and then press SHIFT+F1. 
 
Tip: Want to turn all the layers on or off at once but can't remember all these shortcuts? Right-click the data 
frame and use the Turn All Layers On and Turn All Layers Off commands that were added at 9.0. 
 
 
Data frames 
 

We have improved the following pair of commands that are accessible in the View category in the Tools > 
Customize dialog: 
 
    Activate Next Data Frame 
    Activate Previous Data Frame 
 
These commands are not in the default ArcMap user interface. If your maps tend to contain a lot of data frames, 
it can be useful to add these commands into any toolbar or pulldown menu. They provide a quick way to cycle 
through the data frames in your map making each one active in turn. They work in both Data View and Layout 
View. The default keyboard shortcut to cycle forward through the data frames is CTRL+TAB (which you can 
customize via Tools > Customize in the usual way). This keyboard shortcut is available when the map has 
keyboard focus even if you don't add these commands into your user interface. 
 
Note: Two redundant commands with the same name that were accessible in the Page Layout category in the 
Tools > Customize dialog have been removed from the product. If you added those commands into your user 
interface, you should use the ones from the View category instead. 
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Geodatabases 
 
For information about geodatabase compatibility at 9.1, see the 'Compatibility and Migration' section of this 
document. 
 
 
Subtypes 
 

Subtypes can now be created and edited with an ArcView license in personal geodatabase feature classes 
and tables. 
 
Subtypes are subsets of features in a feature class or records in a standalone table that share the same 
attributes. For example, the streets in a streets feature class could be categorized into three subtypes: local 
streets, collector streets, and arterial streets. Creating subtypes can be more efficient than creating many 
feature classes or tables in a geodatabase. Subtypes also make editing data faster and more accurate because 
default attribute values and domains can be set up. Subtypes are defined on the Subtypes tab of the feature 
class properties dialog and table properties dialog in ArcCatalog and also with the ArcToolbox tools in the Data 
Management > Subtypes toolset. For more information, look in the ArcGIS Desktop Help Index for 'subtypes, 
described'. 
 
 
Annotation 
 

Annotation feature classes containing multiple classes of annotation can now be created and edited with 
ArcView in personal geodatabases. Previously, ArcView only had read-only access to annotation feature 
classes with multiple annotation classes due to their reliance on subtypes.  
 
Annotation classes allow you to organize the annotation within an annotation feature class. For example 
different types of features can be annotated differently (such as with a different font). These different classes 
can be turned on or off individually in the ArcMap Table Of Contents. Annotation classes also greatly enhance 
the annotation editing experience. For more information, look in the ArcGIS Desktop Help Index for 'annotation, 
classes' and then choose the 'Annotation in the geodatabase' topic. 
 

The Update Annotation Feature Class tool in the ArcToolbox Data Management Tools \ Feature Class toolset 
can now be used on versioned feature classes. The option to 'Populate Attribute Fields' must be unchecked. 
The schema of the feature class will be updated in this case, but the new annotation fields will not be populated. 
Attribute values for a feature will remain blank until the feature is edited. 
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Raster Data 
 
Raster catalogs 
 

 The geodatabase raster catalog has a footprint (geometry field) representing the rectangular extent of the 
raster dataset item. In some cases, this footprint may not be up to date. This tends to happen when the raster 
datasets were inserted into the geodatabase with the ArcSDE API command SDERaster instead of with ArcGIS 
Desktop or ArcObjects. When the SDERaster command is used to insert raster datasets into an enterprise 
geodatabase raster catalog, the footprint will remain empty since SDERaster is not aware of the footprint 
column in the raster catalog schema. These footprints need to be up-to-date, since raster catalog items with 
empty footprints are not viewable in ArcGIS. The new Update Footprints command at 9.1 will update the 
footprints of the selected raster catalog items with the corresponding rectangular extent of each raster catalog 
item. To access this command, right-click on the geodatabase raster catalog. 
 

 
 
The Update Raster Catalog Footprint dialog lets you choose which footprints to update. If you define a query 
and check the 'Update empty footprints only' box, then only the empty footprints that satisfy the query will be 
updated: 
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ArcGIS 9.0 provided the ability to display geodatabase raster catalogs as a time series.  At ArcGIS 9.1, you 
can now order the time series by any column in the raster catalog, and choose whether this will be in ascending 
or descending order. These controls have been added into the Raster Catalog Layer Properties dialog Display 
tab. Raster catalog items will be printed in the same order in which they are displayed on the screen. This 
functionality is also useful for raster catalogs with partially overlapping raster dataset items: 
 

 
 
 
Copy Raster tool 
 

The Copy Raster tool has a new parameter that lets you specify which pixel type to use in the target location 
when copying a raster dataset. This parameter determines what the bit-depth of the output raster dataset will be. 
By default, the target pixel type is the same as the input pixel type. There will be no rescaling of the raster 
values when a different pixel type is chosen. If the pixel type is demoted (lowered), the raster values outside the 
valid range for that pixel depth will be truncated and lost: 
 

 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.1 COMPARED TO 9.0 PAGE  21 

Saving the statistics of the current display extent 
 

In 9.0, one of the display options you have is to apply a contrast stretch to continuous raster data based on 
the statistics of the raster dataset. This increases the visual contrast of the raster display. If you have stretched 
the entire histogram of your raster dataset and you find that certain areas still are not displaying with enough 
contrast, you can create a stretch based on the subset of pixels that are participating within a portion of the 
display's extent. This option calculates the stretch statistics from the pixels in the current display extent, rather 
than the entire raster dataset. Each time the display extent (or location) changes, the raster dataset will 
potentially display in a different way, because the contrast stretch calculated for the cell values in the display will 
potentially change. In 9.1 we have therefore added the ability to save the stretch statistics of the current display 
extent to an XML file. The statistics in this file can be loaded back into the renderer when you use the 'From 
Custom Settings' option to define the stretch statistics, which will then be used for the entire raster, regardless of 
how the display changes. 
 
You will see the Save as XML button on the Raster Layer Properties dialog Symbology tab when you are using 
the Stretched renderer with the Statistics option set to 'From The Current Display Extent'. Saving the statistics 
as an XML file saves the statistics of each of the bands in the current display extent: 
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OGC WMS Data 
 

Support for OGC (Open Geospatial Consortium, Inc) WMS (Web Map Service) data was added into ArcMap 
at 9.0 Service Pack 2. This section tells you how to get started using OGC WMS and what is new in 9.1. 
 
OGC WMS is an OpenGIS® standard specification for interactive mapping based on requesting map images 
from a server over the Internet. OGC WMS client support in ArcGIS allows you to access these services over 
the Internet and add them to your maps as layers. OGC WMS services work in a similar way to ArcIMS image 
services. (In ArcGIS 8.3, OGC WMS client support was provided by the OGC Interoperability Add-On for 
ArcGIS, a free download. That add-on is now obsolete and is not supported in ArcGIS 9.0 or 9.1). 
 
To connect to an OGC WMS service in 9.x, go to the GIS Servers folder in ArcCatalog (or in the Add Data 
dialog) and double-click the Add WMS Server command: 
 

 
 
In the dialog that appears, specify the full URL to the service. (To see a list of some sample OGC WMS URLs  
you can use in this dialog, click the ? control at the top of the Add WMS Server dialog and then click inside the 
URL field in the dialog. You can right-click the help topic that appears to copy the sample URLs.) If the 
connection is successful, an icon representing the server will appear in your GIS Servers folder: 

 Connection to WMS server 

Double-click this icon to see the WMS service it contains. (Unlike connections to ArcIMS servers and ArcGIS 
servers, WMS connections only contain one service): 

 WMS service 

You can now add this service into your map or globe. Note: The layers in a WMS service only support a limited 
set of coordinate systems, depending on how the service has been configured by its author. When you add a 
WMS service to a map, the current coordinate system of your data frame may not be supported by one or more 
sublayers in the service. These sublayers will be shown with disabled check boxes in the Table Of Contents. If 
you find that the WMS service does not draw when you add it to ArcMap, right-click the layer and choose the 
Change Coordinate System command. This command lets you change the coordinate system of your data 
frame to one that is supported by the WMS service(s) it contains. 
 
For more information, see the 'ArcMap > Creating Maps > Adding data from a GIS Server' section in the ArcGIS 
Desktop Help, or look for 'WMS' in the ArcGIS Desktop Help Index. 
 

At 9.1 support for OGC WMS services has been extended to ArcGlobe. 
 

When you use the Add WMS Server command in the GIS Servers folder, you no longer have to manually add 
the required ? or & character at the end of the URL you specify. If you enter a URL without the required 
character at the end, ArcCatalog now automatically adds it for you when you make the connection. 
 

The Change Coordinate System command now works in Layout view in ArcMap. 
 

Using the new floating Drawing Errors window at 9.1 (see the description under the General heading of the 
'ArcMap' section in this document), it is now easier to assess the drawing errors encountered when accessing 
certain OGC WMS services. WMS services sometimes cannot be drawn because the spatial reference 
information or other important information included in the service may be incomplete or incorrectly formatted. 
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Linear Referencing 
 

All linear referencing functionality is now available to users holding an ArcView license and above, including 
all the geoprocessing tools in the Linear Referencing toolbox. 
 
Along with the ability to display and query routes and events, this now allows ArcView users the ability to create 
and edit routes, which was previously only available to ArcEditor and ArcInfo users.  
 
ArcView and ArcEditor users can now also perform geoprocessing functions on linear referenced data, which 
was previously only available to ArcInfo users. 
 
 
 
 
 

Documentation 
 

We have continued to improve the ArcGIS Desktop Help and its index. 
 

When you install the ArcTutor tutorial data, this now includes the tutorial documents in PDF format. You can 
find the PDFs that accompany the data in the new ArcTutor \ Tutorial_Docs folder after you have installed 
ArcTutor. 
 

In addition to the existing ArcGIS Desktop Help system that comes with the product, at ArcGIS 9.1 we are 
introducing ArcGIS Desktop Help Online, an Internet-based version of the ArcGIS Desktop Help system. ArcGIS 
Desktop Help Online is integrated with the ESRI Support Center and provides up-to-date information. 
ArcGIS Desktop Help Online is accessible from the Help menu in any ArcGIS Desktop application. It is also 
accessible via the ESRI Support Center.  
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New Extension:  ArcGIS Network Analyst 
 

The ArcGIS Network Analyst extension is new at 9.1. This extension lets you create, manage and analyze 
transportation networks. You can create network datasets from shapefiles and geodatabase data. You can also 
perform network analysis on Smart Data Compression (SDC) data, the format used for ESRI StreetMap data. 
The extension includes a Network Analyst toolbar containing interactive tools for use in ArcMap, along with new 
geoprocessing tools for scripting and modeling.  
 

The ArcGIS Network Analyst extension supports four key network analysis functions: 

 
- Find best routes. You can choose which network   - Find closest facilities. Includes the ability to  
 attributes define the best route and generate   handle multiple incidents and facilities, and  
 directions with turn-by-turn maps that can be printed:  define cutoffs based on travel time, etc: 

    
 
- Find service areas. Finds areas that fall within a   - Create Origin-Destination Cost Matrices.  
 certain travel time, distance, or cost from a facility.   These are tables showing travel time, distance, or  
 Areas can be analyzed to assess accessibility,    cost from each origin to each destination. This data 

capacity, competition, etc:   can be symbolized to reveal patterns and trends: 

     

 
Network Analyst-based applications can be delivered using ArcGIS Engine or deployed across the Web with 

ArcGIS Server. 
 
To learn more about the ArcGIS Network Analyst extension, see the 'Extensions > Network Analyst' section of 
the ArcGIS Desktop Help. 
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Schematics  
 

This new release of the ArcGIS Schematics extension features tighter integration with the ArcGIS Desktop 
environment and the geodatabase. The ArcGIS Schematics extension is now part of the ArcGIS Desktop setup 
and no longer has to be installed separately. 
 

The ArcGIS Schematics extension allows you to generate schematic diagrams representing the connectivity 
of linear and network data in your GIS. With the extension, you can work with schematic representations and 
geographic representations in the same environment, and combine them together for visualization, mapping and 
analysis. The main industries that use schematics are electric, gas and water utilities, energy transmission and 
pipelines, telecommunications, and transportation. Other possible applications include supply chain 
management, stream network analysis, and even wildlife migration. The extension also enables you to develop 
and deliver a variety of custom applications based on schematic data. 
 
A set of ready-to-use standard schematic layout algorithms is included with the extension. Layout algorithms 
can also be customized. Here are some examples of schematics created from GIS data in ArcMap: 

 
Utility network displayed with the smart tree  Electrical backbone displayed with the main ring  
layout algorithm:     layout algorithm: 

  
 
Gas pipeline displayed as a geo-schematic (shows Schematic of a retail distribution supply chain with 
actual point locations but simplifies connecting lines): factories, warehouses, distributors and retail outlets: 
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In this new release of the extension, schematic diagrams can be added to data frames in ArcMap as 
schematic layers that appear in the Table Of Contents. This makes it easier to integrate geoschematics and 
geographic representations. It also makes it easier to create layouts containing schematic diagrams. 
 

 In ArcCatalog, diagrams can be organized into folders inside schematic datasets that are stored and 
managed in the geodatabase. Schematics can be shared across the enterprise in ArcSDE geodatabases.  
 

 
 

Schematics Designer, the standalone utility that lets you customize your schematic project parameters, has 
been enhanced to support the configuration of schematic datasets. Builders and rules are provided that make it 
easier to customize your schematic diagrams definitions with a minimum of configuration steps: 
 

 
 
 
To learn more about the ArcGIS Schematics extension, see the 'Extensions > Schematics' section of the ArcGIS 
Desktop Help.  
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3D Analyst  
 
ArcGlobe 
 

Globe documents (.3dd files) or layer files created or modified in ArcGlobe 9.1 are directly backwards 
compatible with ArcGlobe 9.0. You can open 9.1 globes in 9.0 without performing any additional steps. 
 

The ArcGIS Publisher extension is now supported inside ArcGlobe. This enables you to publish ArcGlobe 
globe documents as published map files (*.pmf files) so they can be distributed with the free ArcReader viewer. 
To publish globes for use in ArcReader you need to have the 3D Analyst extension and the ArcGIS Publisher 
extension. For more information, see the 'Publisher and ArcReader' section of this document. 
 

A new command called Pause Data Caching  has been added to ArcGlobe. When this command is 
selected, data caching will be temporarily suspended in the application. While data caching is suspended the 
application will render the current level of detail in the display but it will not attempt to generate new levels of 
detail while performing any navigation operation. This is useful if you want to navigate to a specific location in 
your globe view but do not want the application to generate all levels of detail up to that point. For example, 
while using datasets with large extent and high resolution in oblique view, if you only want to see the maximum 
level of detail for certain areas you can pause the data caching, navigate to the area of interest using any of the 
navigation tools and resume data caching, by selecting the command to achieve the maximum resolution. This 
command can also be used to suspend data caching if you want to make a number of changes to your layers 
properties in the application. For example, you can change symbology for a number of layers, without having the 
application redraw. Once you have made your changes, you can then choose this command again to turn data 
caching back on.  
 

A new tool called Orbital Fly  has been added to ArcGlobe. You can find this tool in the Viewer category in 
the Tools > Customize dialog, from where you can drag it into any toolbar. This tool looks down from an orbiting 
object, whereas the existing Fly tool  gives you the forward looking view from a flying object. When the Orbital 
Fly tool is selected, a control panel pops up allowing you to control altitude, pitch, direction, and speed: 
 

 
 
You can also use the mouse to direct the flight. Single-click to start and stop. Move the mouse to fly. Speed is 
controlled by the speed you move the mouse. You can also press ESC to stop flying. 

A new tool called Swipe  has been added into the 3D Effects toolbar: 
 

 
 
The Swipe tool is used to interactively reveal layers beneath the layer you chose to swipe. This tool makes it 
easy to quickly see what is underneath a particular layer without having to turn it off in the Table Of Contents. To 
use the tool, choose the layer you want to swipe from the Layer dropdown in the 3D Effects toolbar. Then move 
the cursor over the globe. You will notice that the cursor changes based on whether you are hovering over the 
top, bottom, left or right of the globe. This lets you choose the direction you would like to swipe the layer. Now 
hold down the left mouse button and drag. This will swipe the layer in the direction you were hovering over.  
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The height range limitation that existed for 3D vector data has been removed. This means you can now have 

3D feature data that goes beyond 16km above or below the globe surface. This makes it easier to work with 
data such as flight paths.  
 

ArcGlobe now supports viewing OGC WMS services. OGC WMS is an OpenGIS® standard specification for 
interactive mapping based on requesting map images from a server over the Internet. OGC WMS services work 
in a similar way to ArcIMS image services. Support for WMS services was added into ArcMap and ArcCatalog at 
9.0 Service Pack 2. For more information, see the 'OGC WMS data' section in this document. 
 
 
ArcScene 
 

 Backwards compatibility: You can now save scene documents so they can be opened and used in ArcGIS 
8.3. Use the new Save A Copy command in the File pulldown menu. At the bottom of the dialog that appears, 
choose 'ArcScene 8.3 Documents (*.sxd)' from the Save As Type dropdown list. You can also save layer files 
from ArcScene 9.1 so they can be used in ArcScene 8.3. Scene documents or layer files created or modified in 
9.1 are directly backwards compatible with ArcScene 9.0. For more information, see the 'Compatibility and 
Migration' section of this document. 
 
 
ArcGlobe and ArcScene  
 

The list of 3D model formats that can be imported for use as 3D marker symbols in ArcGlobe and ArcScene 
has been expanded to include SketchUp (*.skp) from @Last Software. SketchUp is an affordable and easy to 
use program for creating 3D models of buildings and other geographic features. SketchUp models can be 
imported directly for use as 3D marker symbols. They can also be saved as 3D features in a geodatabase. 
 

The changes made to ArcMap's Identify Results window apply to ArcGlobe and ArcScene too: You can now 
copy values and field names out of the Identify Results window by right-clicking them. The Identify Results 
window respects the default setting for the Layers option at the top of the window that you can specify by going 
into ArcMap's Tools > Options dialog General tab. You can now also quickly expand the tree on the left side of 
the Identify Results window so it is easier to work with features from multiple layers: click any +/- control in the 
tree to expand or contract all the nodes at that level.  
 

The Make Permanent command available in ArcMap for working with temporary feature layers resulting from 
geoprocessing operations has been added into ArcGlobe and ArcScene. Right-click a temporary feature layer 
and choose Data > Make Permanent. To get help on this command, highlight it in the menu and press 
SHIFT+F1. 
 
 
Geoprocessing 
 

The optional output TIN parameter in the EditTin geoprocessing tool has been removed because support for 
the argument in ModelBuilder was problematic. If you don’t want to modify your original input TIN, use the Copy 
tool (found in the Data Management \ General toolset) to copy your TIN, and then edit the copy using EditTin. 
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Publisher and ArcReader 
 
Publisher 
 

 The ArcGIS Publisher extension is now supported in ArcGlobe enabling you to publish ArcGlobe globe 
documents (.3dd files) as published map files (*.pmf files) so they can be distributed with ArcReader. To publish 
globes you need to have the 3D Analyst extension and the ArcGIS Publisher extension. Globes published as 
.pmf files can be viewed by anyone with ArcReader. Support for viewing published globes is standard inside 
ArcReader at 9.1 and no additional software is required.  
 
Published map files containing a globe are shown with a slightly different icon when you browse to them in 
ArcCatalog or Windows Explorer: 
 

 .pmf file containing a map 

 .pmf file containing a globe 
 
When you publish a globe, you can include ArcGlobe animation files (*.aga files) with it. ArcReader users will be 
able to view these animations using ArcReader's built-in globe animation viewer. To create animation files, first 
create an animation in ArcGlobe and then choose the Save Animation File command from the pulldown menu in 
the Animation toolbar. To specify which animation files to include in the globe when it is published, open the 
Publisher toolbar in ArcGlobe, choose the Settings command and in the dialog that appears use the controls in 
the Contents tab to specify the animation file(s). 
 

The Map Contents Summary dialog is now resizable.  
 
 
ArcReader 
 

As described above, ArcReader now supports globe documents published from ArcGlobe. New 3D 
navigation tools have been added to ArcReader to support viewing globes. You can also choose the new View > 
Animations command to launch the built-in animation viewer. This lets you view animation files included with the 
globe when it was published. 
 

The ArcReader toolbars have been modified to accommodate the new 3D tools: 
 
- The Data toolbar has been modified so that it just contains tools for working with data such as Identify, Find, 

Measure, etc.  
 
- Tools for navigating, such as Zoom In, Zoom Out, Full Extent, etc have been moved into a new Navigation 

toolbar.  
 
- Tools that only work with globes are presented in a new Globe toolbar. The Globe toolbar is only shown if you 

are viewing a .pmf containing a globe. 
 

A new tool called Zoom In/Out  has been added into the Navigation toolbar. When you are working with a 
map or a globe you can use this to zoom in and out on the center of the map by holding down the left mouse 
button and dragging toward you or away from you. When you are working with a globe, you can also drag with 
the right mouse button to zoom in/out more smoothly with a finer degree of control. 
 

A new tool called Swipe  has been added into the Data toolbar. The tool is used to interactively reveal 
layers beneath the layer you chose to swipe. This tool makes it easy to quickly see what is underneath a 



 
 

WHAT'S NEW IN ARCGIS DESKTOP 9.1 COMPARED TO 9.0 PAGE  30 

particular layer without having to turn it off in the Table Of Contents. Choose the swipe layer by opening the 
dropdown list next to the tool and double-clicking a layer. Then hold the left mouse button down and drag the 
pointer on the display to reveal layers underneath the swipe layer. This works with both maps and globes. 
 
(This tool has also been added into the Effects toolbar in ArcMap and the 3D Effects toolbar in ArcGlobe. ) 
 

The ArcWeb Place Finder service has been added into the Find dialog  enabling you to look up places by 
name and navigate to them in the map. 
 

You can now change the transparency of layers by right-clicking them in the Table Of Contents and choose 
the new Transparency command. 
 
 
 
 
 

StreetMap  
 

The ArcGIS StreetMap extension is now part of the core functionality in ArcGIS Desktop, Engine and Server 
and is no longer a separate extension. There is no longer an option to install StreetMap when you install 
ArcGIS, and you will no longer see a StreetMap entry in the Tools > Extensions dialog in ArcMap or ArcCatalog. 
The StreetMap functionality is provided free of charge for all ArcGIS license levels.  
 
This enables all ArcGIS users to perform nationwide geocoding and routing with the StreetMap USA data that 
comes with ArcGIS. No license is now required to use this data. You can find the data in the ESRI Data & Maps 
media kit that comes with ArcGIS. Other street data is available separately for other countries.  
 
There is no change to the StreetMap user interface. The Find Route dialog, added into ArcMap at 9.0, is still 
presented in the StreetMap toolbar. For more information, see the 'ArcMap > Working with StreetMap data' 
section of the ArcGIS Desktop Help. 
 
 
 
 
 

ArcPress 
 

 The ArcPress for ArcGIS extension is now part of the core functionality in ArcGIS Desktop and is no longer a 
separate extension. There is no longer an option to install ArcPress when you install ArcGIS, and you will no 
longer see an ArcPress entry in the Tools > Extensions dialog in ArcMap. The ArcPress functionality is provided 
free of charge for all ArcGIS license levels.  
 
ArcPress is a rasterizer for printing maps. It converts maps into bitmap images at a specified resolution for high-
quality prints on a wide range of printers. For more information, see the 'ArcMap > Laying out and printing maps 
> Printing with ArcPress' section of the ArcGIS Desktop Help. 
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ArcScan  
 

The ArcScan for ArcGIS extension can now be used by ArcEditor and ArcInfo users at no additional charge. 
ArcView users still have to purchase a license if they wish to use the ArcScan extension. 
 
The ArcScan for ArcGIS extension provides tools and commands that support the conversion of raster data to 
vector features. For more information, see the 'Extensions > ArcScan' section of the ArcGIS Desktop Help. 
 
 
 
 
 

Maplex  
 

The Maplex for ArcGIS extension can now be used by ArcInfo users at no additional charge. ArcView and 
ArcEditor users still have to purchase a license if they wish to use the Maplex extension. 
 

We have made significant improvements to scalability, performance, and quality of the labeling engine used 
by the Maplex extension.  
 
Maplex lets you perform quality cartographic placement of labels. For more information, see the 'Extensions > 
Maplex' section of the ArcGIS Desktop Help. 
 
 
 
 
 

Data Interoperability  
The ArcGIS Data Interoperability extension, a new extension introduced after the release of 9.0, is now part 

of the ArcGIS Desktop setup and so no longer has to be installed separately. A license still has to be purchased 
to use this extension. 
 

A number of quality improvements have also been made. 
 
The ArcGIS Data Interoperability extension allows you to integrate a wide variety of spatial data formats into 
your GIS. For more information, see the 'Extensions > Data Interoperability Extension' section of the ArcGIS 
Desktop Help. 
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