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Overview  

General 
 

 Support for 64-bit processors. ArcGIS is now certified to run on the Intel and AMD 64-bit processor families 
 Continuing efforts to improve quality throughout the product, including new crash reporting mechanism 
 New resource centers and blogs from ESRI specialists make it easier to get information and insights online. 
 Other documentation improvements include completely overhauled Desktop Help index 

 

Data management 
 

The geodatabase & ArcSDE 

 PostgreSQL is now supported by ArcSDE 
 Improved conflict and change detection management: Merge Geometries and Version Differences viewer 
 Distributed Geodatabases: One-way replication to file and personal geodatabases 
 Core geodatabase quality improvements 

Editing 

Easier to place points in sketches without switching to the Sketch tool. 
New keyboard shortcuts make it quicker to work with errors in the topology error inspector. 

Tables 

 Improved tables sorting including new dialog for sorting tables on multiple fields. 
Joining tables no longer drops field aliases. Definition queries are handled correctly when joining. 
 You can now view the properties of joins and relates, such as the name and location of joined tables. 
 Identify dialog has new option to respect field properties like primary display field when viewing relates. 
 You can open the properties and attribute table of a layer directly from the Identify dialog. 
Usability improvements in table window include ability to toggle between showing aliases and actual field names. 

Raster data 

 WCS Server and client support in ArcGIS. 
 Better support for NITF and HDF images 
 Improved color correction 
 Easier to clip rasters when exporting them. 

 
 
 

Mapping 
Working with maps  

 New Convert Graphics To Features dialog lets you create features without editing. 
 Improved bookmark support including reordering bookmarks and exporting between maps. 
 Export Raster dialog now lets you clip to a graphic you've drawn such as a study area rectangle. 
 Easier to get the dimensions of graphics that you draw with improved properties dialogs and status bar. 
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 New option to see and input scale in relative format (e.g. 1 inch =  x miles). 
 Pause Labeling command lets you temporarily turn off labels to improve performance while you work. 

Geocoding 

 Easier to review and rematch geocoding results.  
 New reverse geocoding tool lets you click on the map and get addresses. 

Legends 

 Legends on layouts and in the Table Of Contents now automatically use lighter colors for transparent layers. 

Cartographic representations 

 WYSIWYG 
 New Geometric Effects 
 New Marker Placement Styles 
 Improve Carto Rep editing tools 
 Improve existing GP tools  (including geocompare) 
 Add several new tools (Add control pts at intersection) 
 Export to XML, CAD 

Printing and exporting 

 More quality improvements, especially in PDF export and PDF functionality. 

Accessing GIS data on the Web 

 Performance improvements when accessing ArcGIS Server, WMS and  
 Cached ArcGIS Server map services look better with improved resampling when working at non-cached scales. 
 New choices for how cached map services are cached locally, including option not to cache any data locally. 
 Improved KML 2.1 support 

 
 

Geoprocessing & analysis 
General improvements 

 New “Start ModelBuilder” button on the Standard toolbar. 
 Overhauled all the error messages with links to new 'Tool errors and warnings' section in Desktop Help. 
 Tool progress bar improved to give better status report. 
 New option to control how long results are kept in the Results tab 

Model and Script tool enhancements 

 Parameters have filters that specify the set of allowable inputs. 
 Python scripts can be run in-process, significantly reducing execution time. 
 New arcgisscripting.create(9.3) option allows Python scripts to make better use of native Python types, such as lists 
and Booleans. 
 Script tools can have custom validation logic. This allows your script tools to behave just like system tools. 

Server enhancements 

 Feature Sets and Record Sets allow you to input feature classes and tables. 
 Better error checking when publishing tools. 
 Improved performance 

Analysis and spatial statistics 
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 More powerful proximity tools. 
 Generate Spatial Weights tool 
 Scatterplot Matrix graph 
 Ordinary Least Squares Regression (OLS) tool 
 Geographically Weighted Regression (GWR) tool 

 

Putting GIS on the Web 
 

 Improved documentation for installing and managing ArcGIS Server and creating web services 
 Many improvements in the Server Manager. 
 Many new features in the Web Mapping Application including better navigation, printing, etc. 
 New on-demand caching option generates cache on your server as your service is accessed by users 

 
 

Mobile GIS 
 

 Out of the box applications: ArcGIS Mobile Editor and ArcGIS Mobile Management Console 
 Mobile SDK. 

 
 

Application development 
ArcGIS Engine 

 Improved dynamic display support including better display caching, support for feature selection, continuous 
zoom/pan/roam tools, and performance improvements. 
Improved programmatic editing capabilities including ability to create edit tasks, set the layer being edited 
(TargetLayer), and access the sketch geometry 
 Better incorporation of business rules and logic by listening for editor events: check for digitizing errors, and check 
that digitized point falls within a particular polygon 

 

NET SDKs (Desktop & Engine) 

Java SDKs 

 Support for JDK 6  
 Improved IDE Integration: Support new version of Eclipse 3.3, upport for NetBeans (server-only), create integrated 
focused tools, add class templates for the 4 or 5 top tasks 
 Fill key javadoc gaps as identified by incidents logged with ESRI Support 
 Improvements in the ArcObjects Library Overview topics 
 JavaScript REST docs 
 MXDEditor Tool 
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Enhancements to ArcGIS Extensions
3D Analyst (includes ArcGlobe and ArcScene) 

 Improved support for KML 2.1, includes COLLADA support, Screen overlays, network links (KML Server) etc. 
 Many usability enhancements to ArcGlobe including better bookmark managemebt 
 New geoprocessing tools: PointFileInfo: (mass point QA/QC) 
 InterpolateShape and LineOfSight updated to support terrains 
 Add 3D analysis/geometry operators for developers: IProximityOperator3D, IRelationalOperator3D, IArea3D, 
IPolyline3D 

Data Interoperability 

 Updated to use the latest FME engine 

Geostatistical Analyst 

Exporting GA layers to raster datasets is faster 
Moving Window Kriging is 28x faster 
Gaussian Geostatistical Simulation tool  
Geostatistical Analyst available in ArcGIS Server and ArcGIS Engine 

Maplex 

 More control over polygon labeling 
 Vertical text placement 
 Contour Labeling 
 Support  geological maps (better dip and strike labeling) 
 River labeling improvements 
 Handle holes in polygons 
 Boundary labeling improvements (repetition) 

Network Analyst 

 Vehicle Routing Problem VRP Solver provides the ability to generate routes for a fleet of vehicles 
 Global Turn Evaluators 
 Function Evaluator 
 Faster shortest path algorithm  
Incremental OD cost matrix computation 

Schematics 

 New viewer window lets you work with schematics & geography side-by-side on-screen without using Layout view. 
 Improved diagram to feature export: now exports all attributes.  
 Geo-Linear Dispatch layout algorithm improved. 
 New Geo-Partial Overlapping Link algorithm and Expand Link Rule algorithm. 

Spatial Analyst 

 IDW with large input data. 
 Spline with Barriers. 
 New Contour tool honors faults. 
Combine tool is 40x faster.  
Fill tool is 45x faster. 
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Survey Analyst 

 New Cadastral Editor and cadastral fabric data model with which you can build and maintain a high precision 
cadastral land records system in the geodatabase. Cadastral fabrics can also be used to update the spatial 
accuracy of other GIS features that coincide with it. 

Tracking Analyst 

 Globe / Dynamic Display support 
 Helper functions for Developers: Monitor data rates, Total message counts, Track counts, Connection Status 

 

 WHAT'S NEW IN ARCGIS 9.3 - PAGE  7 



General 

Support for 64-bit processors 

 
Starting at 9.2 Service Pack 3, ArcGIS is now certified to run on the Intel and AMD 64-bit processor families, such 

as the Xeon64 and AMD64. Note that the Intel Itanium processor is not supported. At Service Pack 3, the supported 
64-bit Windows operating systems are Windows XP 64-bit and Windows 2003 Server 64-bit. ArcGIS 9.2 Service Pack 
3 runs as a 32-bit application on these 64-bit Windows platforms, and so can take advantage of some of the 
performance benefits of the 64-bit environment.  
 

ArcGIS Desktop, ArcInfo, ArcEditor, ArcView, and ArcReader on 64-bit  
ArcGIS Desktop is a native 32-bit application and runs as a 32-bit application on 64-bit (x64) Microsoft Windows. In 
addition to Windows, ArcReader is also supported on Linux and Solaris. ArcReader on Solaris is supported in a 64-
bit environment. ArcReader on 64-bit Linux has not been fully certified yet, but testing so far has been successful. 
 
ArcGIS Server and ArcIMS on 64-bit  
ArcGIS Server and ArcIMS are native 32-bit applications. They have both been certified running as a 32-bit 
application on 64-bit (x64) Microsoft Windows. Web server support is based on the web server vendor’s support of 
64-bit Microsoft Windows. Check with your web server vendor if the web server is supported on 64-bit Microsoft 
Windows. In addition to Windows, ArcGIS Server and ArcIMS are supported on Solaris and Linux. ArcGIS Server 
and ArcIMS are both supported in a Solaris 64-bit environment. ArcGIS Server and ArcIMS on 64-bit Linux are not 
completely tested, however test results so far has been successful. ArcIMS is also supported on IBM AIX and HP 
HPUX. ArcIMS has not been certified with either operating system in a 64-bit environment.   
 
ArcGIS Engine on 64-bit  
ArcGIS Engine is a native 32-bit application and is has been certified running as a 32-bit application on 64-bit (x64) 
Microsoft Windows. In addition to Windows, ArcGIS Engine is supported on Solaris and Linux. ArcGIS Engine is 
supported in a Solaris 64-bit environment but has not yet been fully certified in a Linux 64-bit environment.   
 
ArcSDE on 64-bit  
ArcSDE is available as a native 64-bit application for Sun Solaris (Oracle and DB2), HP HPUX (Oracle and DB2), HP 
Tru64 (Oracle), and IBM AIX (Oracle and DB2). On Windows, ArcSDE is a native 32-bit application and has now 
been certified running as a 32-bit application on 64-bit Microsoft Windows. DBMS support is based on the DBMS 
vendor’s support of 64-bit Microsoft Windows. Check with your DBMS vendor if the DBMS is supported on 64-bit 
Microsoft Windows. ArcSDE is a 32-bit application on Linux for both Oracle and DB2. ArcSDE for Oracle on Red Hat 
Linux is only supported on a 64-bit chip set if the Linux OS and Oracle DBMS are both 32-bit. ArcSDE for DB2 has 
not been tested on a 64-bit Linux environment. 

 
The existing License Manager and associated hardware key used for concurrent use licenses of ArcView, ArcEditor 

and ArcInfo does not work on 64-bit machines running Windows XP Professional 64-bit. You can obtain new Sentinel 
drivers and a License Manager patch that adds support for that 64-bit environment. For more information, and to get 
the patch, please see Knowledge Base article 30385: 
 
http://support.esri.com/index.cfm?fa=knowledgebase.techArticles.articleShow&d=30385
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Crash handling 

ESRI is committed to improving the quality of ArcGIS. One of the most important issues with quality is when the 
application crashes, because this causes you to lose your work. We investigate all reports of crashes as fully as we 
can, and continue to gather information about them. Some crashes are caused by third party extensions and DLLs that 
don't work correctly with the latest version of the software or particular new types of data. We work to minimize these 
issues. At 9.3 ArcMap now has a crash report mechanism that automatically captures information about the crash that 
will enable us to investigate and address the issue. If a crash occurs, you'll see a new dialog with information about 
how to report the crash to ESRI.  
 
 
 

Resource centers 

At 9.3 we are introducing resource centers for each product. These are websites that centralize all the various 
online resources related to a particular product in one easy to find location. The resource centers include links to the 
web help for the product, blogs, online data you can access, etc. 
 

ArcGIS Desktop Resource Center: 
http://resourcesdev.esri.com/arcgisdesktop/index.cfm?fa=home
 
ArcGIS Explorer Resource Center: 
http://resources.esri.com/arcgisexplorer/index.cfm?fa=content

 
You can also launch the resource centers from menu commands in the applications themselves. 
 
 

We have introduced some new cross-product learning centers and blogs. These are great places to get expert 
advice, tips, and other useful information about particular areas of GIS: 
 
ESRI Mapping Center: 
http://mappingcenter.esri.com
 
ESRI Geoprocessing Center: 
http://resourcesdev.esri.com/arcgisdesktop/index.cfm?fa=showgeo
 
 
 

Documentation 

The Desktop Help index has been completely overhauled to make it easier and faster to get to topics.  
 
New index entries have also been added such as 'overview', 'lists' and 'FAQ' to give you fast access to particularly 
useful types of topics in the help. 
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Improved handling of layer files 

Layer files (.lyr files) are now shown with yellow icons in Windows Explorer, Outlook, Windows Desktop, etc. 
Previously lyr files were not registered to ArcGIS applications at all and were shown with no icon.  
 

Double-clicking a layer file in Windows Explorer, Outlook, Windows Desktop, etc will automatically launch ArcMap 
and show you the layer if ArcMap is not already open. If ArcMap is already open, the layer is automatically added into 
that session. If the layer file contains content that can only be displayed in ArcGlobe, then ArcGlobe will be launched 
when you double-click the layer file. 
 

You can now open layer files directly from web pages, such as the layers page in the new ArcGIS Desktop 
Resource Center. You can access this page by choosing the new File > Add Online Data command in ArcMap or 
ArcGlobe, or by going directly to:  http://resourcesdev.esri.com/arcgisdesktop/index.cfm?fa=content_layers
Clicking a layer file on a web page will add it into your current ArcMap session, or will launch ArcMap if it is not 
currently running. Layers with globe-only content automatically launch ArcGlobe if it is not currently running. 
 

These enhancements make it much easier to distribute layer files, especially if you are serving online services using 
ArcIMS or ArcGIS Server that you wish to make available easily for users working with ArcMap or ArcGlobe. You can 
add your layer files to any web page to make the immediately available for use in their Desktop applications. Users 
with 9.2 can right-click these layer files and download them locally to use them.  
 
If you are using 9.3 to create map documents and layer files for other Desktop users to access, remember to save 
these files so that users with earlier versions of ArcGIS can access them. Use the File > Save A Copy command in 
ArcMap or ArcGlobe to create map and globe documents that can be accessed by users of earlier version, and when 
you create layer files look in the file type dropdown list in the Save As Layer File dialog. If your map or layer contains 
ArcGIS Server content, you should save it in 9.2 format. If you map or layer contains ArcIMS format, you should save it 
in 9.0 format. 
 
When you use 9.3, layer files created with any version of ArcGIS Desktop can be opened or added to your open 
ArcMap session.  Behind the scenes, at 9.3 layer files are actually registered to a program called 
ArcGISAppLauncher.exe. This program determines how ArcGIS Desktop should handle a layer file when it is 
launched, and makes sure that if you have ArcMap and ArcGlobe installed, the layer file gets sent to the correct 
application. 
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Data management 

Enterprise ArcSDE enhancements 

PostgreSQL support in Enterprise ArcSDE 
 

ArcSDE now supports PostgreSQL 8.2.3. The ArcGIS Server Enterprise Edition for PostgreSQL installation 
includes the installation files for PostgreSQL 8.2.3 as well as the ArcSDE 9.3 component. 
 

ArcSDE geodatabases in PostgreSQL will use ST_Geometry storage for vector data by default. Users can also 
install PostGIS 1.2.1.1 and use the PostGIS storage type, needing only to alter their GEOMETRY_STORAGE 
DBTUNE parameter. 
 
ArcSDE for PostgreSQL geodatabases offer all the same functionality as other ArcSDE geodatabases. 
 
Support for SQL Server Express with Advanced Services for ArcSDE Personal and Workgroup geodatabases—9.3 
ships with the installation for SQL Server Express with Advanced Services SP2. Existing ArcSDE database server 
users can upgrade their SQL Server Express instances. This will allow users to use ArcSDE Personal or Workgroup 
geodatabases with ArcIMS Metadata Services. 
 
 
DB2 z/OS support in Enterprise ArcSDE 
 

At 9.3, you can create ArcSDE geodatabases in DB2® for the IBM® Z series main frame operating system (referred 
to as DB2 for z/OS®). DB2 for z/OS offers tighter security and increased availability than DB2 on Windows, Unix, or 
Linux and is, therefore, often used by the banking, insurance, and brokerage industries. Version 9 of DB2 z/OS, 
released in March of 2007, is the first version of DB2 for z/OS to include spatial data support.  
 
Having the ability to create ArcSDE geodatabases in a DB2 database on the z/OS platform allows users of this 
database type to add a spatial component to their applications that takes advantage of the rich functionality of ArcGIS 
software. At this release, direct connections to the database are supported but ArcSDE service connections are not. 
DB2 for z/OS does not support the use of Net Search Extender at this time, so the creation of ArcSDE XML columns is 
not supported at this ArcGIS release. Note also that database administrative tasks such as updating indexes must be 
performed using the tools provided by DB2. 
 
 
Enhancements to Informix support 
 

ArcSDE XML support—Allows users to create ArcSDE XML columns using the text search DataBlade module 
products available for Informix Dynamic Server. These include the Excalibur Text Search (ETX) DataBlade module in 
Informix version 9.4 and above and the Basic Text Search (BTS) DataBlade module available with Informix version 11. 
 
The ability to create ArcSDE XML columns allows users to perform full-text searches on the contents of the XML 
column and makes the use of ArcIMS metadata services and the ArcGIS Portal Toolkit possible for ArcSDE for 
Informix users. 
 

Improved raster storage—A new DBTUNE configuration parameter allows users to specify a BLOBspace for the 
storage of raster block data. This parameter can be set under the DEFAULTS configuration keyword to specify a 
location for all raster block data or users can create their own configuration keywords that include this parameter, 
which they can specify when creating certain raster datasets. For example, the parameter could be set to store raster 
data in a BLOBspace named rasterblobspace, as shown below. 
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BLK_LOB_STORAGE  "IN rasterblobspace" 
 
This helps users avoid reaching the space limitation on Informix DBspaces of 16,775,134 data pages per table 
fragment. 
 

Edit versioned data through multiversioned views using the SQL API—In previous ArcGIS releases, ArcSDE for 
Informix users could create multiversioned views to read versioned data, but they could not edit the data using SQL 
through these views. At 9.3, the necessary database triggers are implemented that allow users to edit versioned data 
through multiversioned views. 
 
 
Enhancements to Oracle support 
 

Starting at 9.2 Service Pack 1, the ST_Transform function has been implemented for the spatial type for Oracle. 
ST_Transform lets you change the ST_Geometry of a layer into a different spatial reference using SQL by specifying a 
Spatial Reference ID. 
 

New installations of the ArcSDE component for Oracle will use ST_Geometry as the default vector data storage 
type. 
 

To allow current users to migrate the geometry storage of existing datasets to the ST_Geometry type, a new 
operation—migrate—has been added to the sdelayer command. Users can specify this command along with the 
ST_GEOMETRY configuration keyword to convert feature classes from LONG RAW (SDEBINARY), 
SDO_GEOMETRY, or BLOB (SDELOB) storage to ST_GEOMETRY storage: 
 
sdelayer -o migrate -l divisions,shape -k ST_GEOMETRY 
 

A migrate operation has also been added to the sdetable command to allow users to migrate Oracle LONG RAW 
attribute fields to BLOB. The keyword specified must contain an ATTRIBUTE_BINARY parameter set to BLOB. 
 
sdetable –o migrate –t distribution –k DEFAULTS 

 
For details on using the sdelayer or sdetable commands, consult the ArcSDE Administration Command Reference 
provided with the ArcSDE component of ArcGIS Server Enterprise edition. 
 

An operation has been added to the sdesetup command to allow for the deletion of geodatabases created in the 
schema of user’s other than SDE. Syntax for the sdesetup command with the delete operation is as follows: 
 
sdesetup -o delete -d {ORACLE9I|ORACLE10G} [-H <sde_directory>] [-u 
<ArcSDE_admin_user>] [-p <ArcSDE_admin_password>] [-i 
<master_geodatabase_service>:<user_schema>] [-N] [-q] 
 
The following rules apply to using this operation: 
 
- When you delete a geodatabase, there can be no other users connected to any of the geodatabases—the master 

SDE geodatabase or any user-schema geodatabase. 
 
- There can be no data registered to ArcSDE in the geodatabase. That means that prior to deleting the geodatabase, 

you must remove any of the data that has been registered with ArcSDE (in other words, has an entry in the 
TABLE_REGISTRY system table and related system tables). This includes data in other schemas that is registered 
to the geodatabase that will be deleted. For example, if the SDE user owned a table that was registered to a 
geodatabase owned by user yuge, it would also have to be unregistered or removed from the geodatabase owned 
by yuge. 
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Personal ArcSDE & Workgroup  

SQL Server Express 2005 with Advanced Services SP2 
 

9.3 ships with the installation for SQL Server Express 2005 with Advanced Services SP2. Existing ArcSDE 
database server users can upgrade their SQL Server Express instances. This will allow users to use ArcSDE 
Workgroup geodatabases with ArcIMS Metadata Services. 
 
 
Personal ArcSDE included in the Engine developer kit 
 

Additionally, the ArcGIS Engine Developer Kit at 9.3 includes the SQL Server 2005 Express installation and the 
ArcSDE Personal geodatabase Post Installation wizard to allow Engine developers to use ArcSDE Personal 
geodatabases as a data source. 
  
 

Additional compatibility for direct connections 

 
Beginning with ArcGIS 9.3, you can make a direct connection from any ArcGIS 9.3 client to a 9.3, 9.2, 9.1, or 9.0 

ArcSDE geodatabase. 
 
The following shows which versions of the client software can make a direct connection to which versions of the 
ArcSDE geodatabase: 
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Upgrading your Geodatabases in ArcGIS 9.3 

You can choose to optionally upgrade a geodatabase to ArcGIS 9.3 to take advantage of the following new 
functionality that is available only on 9.3 Geodatabases: 
 
- Creating a Terrain with the new Window Size pyramid format  
 
- Creating a Network Dataset with an attribute that uses the new Global Turn Delay and Network Function evaluators 
 

 
 
To upgrade your Geodatabase to ArcGIS 9.3, use the Upgrade Geodatabase button on the geodatabase properties 
tab (shown above). This works with all geodatabases except for Enterprise ArcSDE geodatabases (i.e. geodatabases 
you connect to via the Database Connections folder in ArcCatalog). 
 
To upgrade an Enterprise ArcSDE geodatabase, see your ArcSDE installation guide. Upgrading an Enterprise ArcSDE 
geodatabase can only be performed by the administrator of that database. 
 
Tip: In the Tools > Customize dialog in ArcCatalog, the 'Geodatabase tools' category contains a command called 
Upgrade Geodatabase that you can add into any pulldown menu or toolbar in ArcCatalog. This command does the 
same thing as the Upgrade Geodatabase button but can save time if you have a lot of geodatabases to upgrade. This 
command becomes enabled when you select a geodatabase in ArcCatalog that needs upgrading. 
 
Once a geodatabase has been upgraded, it can no longer be accessed from an older version of ArcGIS.  The 
exception to this rule is ArcGIS 9.2 SP5, which can connect to 9.3 Geodatabases but will not be able to open, edit or 
create Terrains and Network Datasets containing the before mentioned new functionality available with ArcGIS 9.3. 
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If you need to connect to your geodatabase using an earlier release than 9.2 SP5, do not upgrade the geodatabase.  
You will still be able to access and edit your Geodatabase using ArcGIS 9.3 with the following constraints: 

- ArcGIS 9.3 will prevent you from creating Terrains with the new Window Size pyramid in a 9.2 Geodatabase  

- ArcGIS 9.3 will prevent you from creating a Network Dataset that uses the new Global Turn Delay evaluator in a 9.2 
Geodatabase  

 
 
 

Versioning  

Interactive conflict resolution dialog 
 
A new option available in the conflict dialog allows you to merge the geometries of separate versions if two editors 
have edited the same feature. The option to merge geometries is available when there is a conflict concerning the 
Shape field. If two editors both edit the geometry of the same feature, but do not edit the same area of that feature (as 
seen in the graphic below) then they have the option to resolve the conflict by merging geometries and accepting both 
edits. This improves the overall conflict management experience, especially for large polygon and polyline features 
such as water mains or coastlines, or when editing across administrative boundaries. 
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Conflict and change detection management 
 
A highly requested enhancement has been for a way to determine changes between a version and its ancestor, or 
another version, without having to do a reconcile or be in an edit session. With this in mind a new button has been 
added to the Versioning Toolbar called Version Changes which opens the Version Changes viewer. 
 

 
 
When opening the Version Changes viewer you choose another version to compare changes with. The Version 
Changes viewer (shown in the graphic below) lists all inserts, updates, and deletes made to the version since the last 
time it and the version you chose were identical. It allows you to view and compare these changes in a similar fashion 
to the interactive Conflicts dialog box. You don't have to be in an edit session to open the Version Changes viewer and 
changes can be viewed before versions are reconciled. 
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Replication 

At 9.3 the one way geodatabase replication model has been extended to include file and personal geodatabases. Now 
when creating one way replicas, the destination may be an ArcSDE geodatabase, a file geodatabase, or a personal 
geodatabase. 
 
This allows you to leverage one way replication implementations such as production-publication scenarios or those 
that require mobile users in the field. A broader range of scenarios can be accommodated with this model since the 
child replica doesn’t need to be versioned or have SDE technology. 
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Editing  

Editing and sketch tools 
 
The context menu for all sketch construction tools on the Editor toolbar tool palette contains the Snap To Feature, 
Absolute X,Y, Delta X,Y, and Direction/Length commands. This enhancement allows you to place a point in the sketch 
using these commands without having to switch to the Sketch tool. The keyboard shortcuts used to invoke these 
commands are also available to all sketch tools. 

 
 
The Arc and Tangent sketch tools allow you to enter a fixed radius value when constructing a curve. You can press R 
to set the radius value, then press Tab to cycle through the possible curve solutions. 
 
The Split tool on the Editor toolbar now provides feedback to indicate where a line will be split. As you move your 
pointer near the line, you'll see a marker on the line (shown in black in the graphic below) at the place where it will be 
split. In addition, your pointer must be within the snapping tolerance distance for the split to be performed. Previously, 
you could click anywhere on the screen to split a feature when the Split tool was active, possibly resulting in splitting 
the feature in the incorrect spot. The snapping tolerance is defined on the General tab of the Editing Options dialog 
box: 

 
 
You can pan to selected features using the context menu for the Edit tool and in the Attributes dialog box. You can 
also identify any selected feature by right-clicking it with the Edit tool and clicking Identify: 
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The Clip command on the Editor menu now allows you to clip polygon features that touch or are within a buffered 
distance of a selected feature. This command has been enhanced to use any selected feature, including a CAD 
feature, to clip your polygons. Previously, the selected feature had to be editable and in the same workspace as the 
features being clipped.  
 
The Fillet tool on the Advanced Editing toolbar has been improved with better onscreen feedback, allowing you to 
better see and construct the fillet line. The Fillet tool is used to create a curved line that is tangent to two line features. 
In the graphics below, the black line is the new fillet curve to be created between the red lines 
 
Fillet tool at ArcGIS 9.2.                    Fillet tool at ArcGIS 9.3 

        
The ability to enter a distance units abbreviation to specify units different from the map units has been added to more 
editing tools. For example, if your map units are meters, but you want to type a measurement in feet, simply type the ft 
abbreviation after the value: to enter 10 feet, type 10ft. In addition to the many tools and commands that already allow 
distance units abbreviations, you can now use them when: 
 

 setting the snapping and stream tolerances on Editing Options dialog box > General tab 
 typing a value for the radius using the Circle tool on the Advanced Editing toolbar (press the R key to type 

a radius) 
 setting an offset value for the Advanced Editing toolbar’s Smooth and Generalize commands 

 
When constructing an edit sketch with the Sketch tool, the sketch’s segment length, total length, direction, units, 
perimeter, and area (depending on the type of feature) are shown in map units in the status bar at the bottom of the 
ArcMap window. You need to hold down the A key to see the area when sketching a polygon, since area is not 
calculated automatically to maintain performance. Similar information is shown in the status bar now when creating 
features with the Circle and Rectangle tools on the Advanced Editing toolbar: 
 

 
 
When working in layout view, the onscreen feedback you see when you show a feature’s vertices by pressing the V 
key or when you select or move features now appears at an appropriate size. In some cases, such as when you have 
a reference scale set and zoom the layout page, vertices or feedback lines may have appeared too large onscreen in 
previous releases. 
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Topology 
 
New keyboard shortcuts have been added to the Error Inspector dialog box. You can now navigate the list of errors 
and access commands on the context menu using just your keyboard. Below are the new shortcuts: 
 
Up and Down arrows: Move up and down through the rows 
Z or Spacebar: Zoom to the selected error 
P: Pan to the selected error 
F: Select the parent features causing the error 
D: See a description of the topology rule 
X: Mark the error as an exception 
E: Mark the exception as an error. 
 
The split topology error fix respects the split policies that have been set up for the feature class and assigns attributes 
accordingly. 
 
You can now hold down Ctrl and click any check box to check or uncheck all the boxes in the Show Shared Features 
dialog box. 
 
When you hover over a feature with the Topology Edit tool active, pressing V will now display its vertices. Seeing the 
vertices enables you to use snapping more effectively when editing topology.  
 
The number of selected topology elements is displayed in the status bar when using the Topology Edit tool. This is 
particularly helpful if you are zoomed out but multiple selected topology elements appear visually as a single element 
at that scale: 
 

 
 
 
Editing features with z-values 
 
Z-values are maintained and assigned more logically when editing features in ArcMap. For example, extending a line 
will now extrapolate the z-value for the new vertex. In previous releases of ArcGIS, the z-value was assigned 0 by 
default. For more information on how ArcMap assigns z-values when editing, see the ArcGIS Desktop Help topic, 
“Editing features that have z-values.” 
 
In addition to the out-of-the-box z-editing enhancements, developers can enable a z-editing experience in ArcMap that 
includes additional methods of assigning and manipulating z-values. This allows you to capture z-values directly from 
an elevation surface such as a TIN or terrain. This functionality is available by writing your own code or installing a 
developer sample from the ArcGIS Desktop SDK. To learn more, see http://edn.esri.com
 
 

Tables and attributes 

Joined tables can now display Field Aliases or Database Field Names 
 

You will now have the option to create a joined table that either displays the “qualified field names” or the field 
aliases in the table.  Previously in ArcMap, a joined table always displayed fields with the Table Name as a prefix to 
the database field name.  This option can be set in two different places:  1) In the Table Appearance dialog, which is 
accessed from the Options menu in the attribute table.  2) In the Tables tab, in the Options dialog accessed from the 
Tools > Options menu. 
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Using the setting in the Tools > Options dialog Tables tab defines how you want fields to be handledfor all new tables 
you open in ArcMap.   
 
So you can now decide how you want your fields to look, for example:  City.db4 or  db4  
 

 
 
Use the CTRL+Right-Click on a Field Name to toggle between Field Names and Aliases in the Table.  On the 
keyboard you can use -  CTRL+SHIFT+N 
 

Bugs fixed along with this enhancement: 
 
- Field properties (alias, visibility, numeric settings) being dropped after a join is created or removed 
 
- Field properties being dropped after creating or removing a Definition Query 
 
 
Joins and Relates can now be created or removed within the Attribute Table 
 

You can now create or remove a join from the Options menu in the Attribute Table.  
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New option to respect field properties when accessing related records via the Identify 
dialog 
 
When you right-click an entry in the left hand side of the Identify dialog in ArcMap,  ArcGlobe, ArcReader and Engine 
applications, you'll see a new checkable option that lets you choose whether or not the Identify dialog will show related 
data using the field properties (primary display field, field aliases, field visibility and number formatting) of the table or 
layer that represents that related data in your data frame. This is a long requested enhancement because previously 
you could not control how related data accessed in Identify is displayed. You can find the new option in the context 
menu you get if you right-click any entry in the tree on the left-hand side of the Identify dialog: 
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The new option is off by default, so users will see no difference between 9.2 and 9.3 unless they check this new 
option. The setting is stored in the registry for the application. If you access related data while this option is checked 
on, and the related data is not represented in your map by a table or a layer, the fields are listed in the usual way 
because there are no field properties available for Identify to use. If multiple layers represent the related data when the 
option is turned on, an entry appears in the Identify dialog's tree under the relate for each of these layers so you can 
choose which one to use to view the related data. Note: Definition queries in the table or layer providing the field 
properties are still not respected by the Identify dialog with this enhancement  
 
 
Open properties dialog and attribute table for layers directly from Identify dialog 
 

When you have identified a feature in the Identify dialog you can now launch the properties dialog and attribute 
table of the layer it belongs to directly from the Identify window without having to go and find the layer it belongs to in 
the Table Of Contents: 
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This can speed up your work when your map contains a large number of layers. For example, if you see a feature on 
the map that you would like to change the symbology, labeling or attribution for, you can simply identify it to find out 
what layer it belongs to, and then right-click the layer to open the layer properties dialog or attribute table in order to 
make any desired changes to the layer. 
 
These commands are not available in ArcReader or Engine applications as there is no corresponding attribute table or 
layer properties control in those applications. 
 
. 
Advanced sorting in Tables is now supported 
 

A new Advanced Table Sorting dialog lets you designate sorting on up to 4 fields at once. To access this dialog, 
right-click any field in the table window and choose the new Advanced Sorting command: 
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You can unsort a table by using the advanced sorting dlg and select (none) for all the sorting criteria or you can press 
Shift-Ctrl-U which will also unsort the table. - the advanced sorting dialog will always show you the field names exactly 
as you see them in the table headings. 
 
Shortcut to open this dialog: SHIFT + Double-click any field name in the table window. 
 
 
See properties of joins and relates   
 
In the Joins and Relates tab in the layer and table properties dialogs, you can now review the properties of joins and 
relates, so it is easy to see the name, location and type of any source tables that are joined or related to your table. 
These properties are read-only. 
 
 
Sorting of tables is persisted 
 

ArcMap now remembers how you sort tables that you have opened, so that you don't have to re-sort them when 
you open them. Sorting a table window is persisted with the map document. 
 

Sorting is retained when you toggle between all and selected view. 
 

You can sort in selected view and then switch to all and all view is sorted accordingly as well. 
 

When selecting multiple columns in the table view and then select to sort ascending or descending then the 
selection order will be maintained. (not right to left order). 
 
 
Calculate Geometry dialog supports more properties 
 

When you are working with line features, the Calculate Geometry dialog now gives you the option of calculating the 
x,y coordinates of the start and end points of the lines. 
 

 WHAT'S NEW IN ARCGIS 9.3 - PAGE  25 



 
 
To access the Calculate Geometry dialog, right-click a field in the table window. 
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New Reselect Highlighted command 
 

A new command called Reselect Highlighted has been added to the context menu you get if you click the grey 
space to the left of any row in the table window. This command becomes enabled when you are working in Show 
Selected mode. In that mode, Reselect Highlighted selects the records that are currently highlighted (i.e. shown in 
yellow in the table) and unselects all the other records. This enables you to refine the selected set by limiting it to the 
records you have highlighted. First highlight the records in the selection you want to keep. Then choose this command 
to reselect them. This command is disabled if you are not in Show Selected mode or if you are in Show Selected mode 
and no records are currently highlighted (yellow).   
 

 
 
 
Shortcut: You can press CTRL + SHIFT + R to invoke this command. Press F1 when the table window is active to 
see all the available keyboard shortcuts. 
 
Tip: Want to make your table wrap long field names and cell values around like in the screenshot above? In the table 
window, click the Options menu button, choose Table Appearance, and then set the Column Header Height and Cell 
Height to be, for example, 225% 
 
 
Field Properties 
 

You can access the properties of a field in the table window by right-clicking it's name and choosing the Properties 
command added in 9.2. The Field Properties dialog is useful because it lets you define an alias for the field, set the 
field's number properties, etc without leaving the table window. The following new shortcuts have been introduced in 
9.3 for that command so you can get to the Field Properties dialog more rapidly: 
 

ALT + Double-click field name  Open Field Properties dialog for field you clicked. 
CTRL + SHIFT + P  Open Field Properties dialog for the selected field. 

 
The following new shortcuts let you toggle between seeing field aliases or the underlying field names in the table 

window: 
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CTRL + Right-click field name Toggle showing aliases on/off for all fields in the table  
CTRL + SHIFT + N  Toggle showing aliases on/off for all fields in the table  

 
 
Tip: To get a list of all the shortcuts available in the table window, click inside the window to give it keyboard focus and 
then press F1.  To find out whether a particular command you access regularly via a menu in the table window has a 
shortcut, highlight the command in the menu and press SHIFT + F1 to get context sensitive help about it. (You can 
also find a list of tips and shortcuts in the ArcGIS Desktop Help and at the end of this document). 
 
 
Easier to see when the functionality of table or event layer is restricted 
 

The controls on the Definition Query tab of the Table Properties dialog and Layer Properties dialog are now 
disabled if you are working with a table or event layer (layer based on a table containing XY or route event data) where 
the tabular data source does not have an Object-ID (OID) field: 
 

 
 
 
 
Quickly bring up Fields Properties Dialog using shortcut – ALT+Right-Click on a Field Name 
 

This allows you to quickly access the Field Properties Dialog used for changing aliases, field visibility, numeric 
settings, etc. 
 
 
Microsoft Excel 2007 worksheets are now directly supported in ArcGIS. 
 

You can now directly access worksheets and Named Ranges defined in Excel 2007 in ArcMap or ArcCatalog.  One 
particular advantage of this that users are excited about is that you are no longer limited to ~65,000 records as you 
were in Excel 2003.  Excel 2007 worksheets can support 1,000,000 rows. 
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Raster data 

Raster formats  
 

ArcGIS 9.3 supports NITF and HDF subdatasets 
 
Hierarchical Data Format (HDF) and National Imagery Transmission Format (NITF) both have the capacity to store 
multiple images (subdatasets) within one file. These subdatasets represent images taken in different bands, or at 
different times and angles or photographs of objects.  
 
ArcGIS 9.3 supports these formats and allows you to display the subdatasets and also extract subdatasets from the 
file to create standalone raster datasets. 
 
When adding an HDF or NITF file that contains subdatasets into ArcMap, you will be prompted with the following 
dialog box:  
 

 
 
From this dialog box you can choose to select one subdataset to display as a raster layer, or select multiple 
subdatasets to display as a group of raster layers. 
  
A standalone raster dataset can be created from any of the subdatasets by adding it to the map and using the Export 
Data command.  
 
The Extract Subdataset geoprocessing tool is also available as a method for creating standalone raster datasets from 
HDF or NITF subdatasets. This is useful for scripting or batch processing purposes. 
 

An NITF may also contain Computer Graphics Metafile (CGM), these GCM graphics will be added as graphics 
layers when the NITF raster dataset is added into ArcMap. 
 
 

ENVI format is supported 
ArcGIS 9.3 now supports ENVI format. ENVI is read-only in ArcGIS, writing to ENVI format is available for developers 
only.  
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Creating a raster mosaic from a raster catalog 
 

A new geoprocessing tool has been added to aid in creating raster mosaics. The Raster Catalog to Raster Dataset 
tool allows you to create a new raster dataset by mosaicking all or a selection of items from a raster catalog.  
 
The new Raster Catalog to Raster Dataset tool also offers enhanced workflow for creating mosaics. For creating a file 
based raster mosaic, the recommended workflow is to first create an unmanaged raster catalog containing the rasters 
you wish to mosaic. Then use the Raster Catalog to Raster Dataset tool to mosaic that raster catalog to a new raster 
dataset. This workflow is more efficient than using the pre-existing Mosaic to New Raster tool.   
 
The existing workflow is to create an empty raster dataset and then use the Workspace to Raster Dataset tool to fill 
that empty dataset with a mosaic. This is still the recommended method for creating a raster dataset in an ArcSDE or 
File Geodatabase if the inputs are raster datasets. 
 

A new command has been added to the context menu of the raster catalog layer called Mosaic Raster Catalog. This 
command opens a dialog box similar to the Export Data dialog box, from which you choose mosaicking and output 
options to create a new raster dataset. The new dataset can be a mosaic of the entire raster catalog or of selected 
rasters.  
 
The dialog also supports clipping the output with the current data frame or a selected graphic, offering an easy method 
to clip a portion of a raster catalog. 
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Image color balancing and matching 
 

In order to create a seamless mosaic, ArcGIS 9.3 provides color balancing and color matching capabilities.  A Color 
Correction tab has been added to the Properties page of the raster catalog layer. You can perform color balancing and 
color matching of the raster catalog on the fly to explore the color correction options and choose one that works best 
for your data. Once the color correction parameters are decided, you can mosaic images using the Mosaic Raster 
Catalog command from the raster catalog layer context menu, or the new Raster Catalog to Raster Dataset 
geoprocessing tool. 
 

 
 

The Workspace to Raster Dataset tool and Mosaic tool have also been enhanced to include the new color matching 
options. 
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Clipping rasters 
 

A new option on the Export Raster Data dialog box allows you to define the extent of your exported data by using 
the currently selected graphic(s) to clip the raster. This is very convenient as you can draw any shape and use it as the 
extent for clipping a raster dataset. 
 

Another new option on the Export Data dialog box is the addition of a NoData input box. When clipping graphics 
using an irregular shape, pixels outside of the clipping geometry will be filled with a NoData value. When saving to file-
based raster datasets, it is recommended that you enter a proper NoData value.  
 

 
 
 

The raster Clip tool has been enhanced with an Enable Clipping Geometry check box. This box becomes available 
when an existing feature class is chosen as the Output Extent. If the Enable Clipping Geometry box is checked, then 
the actual geometry of that feature class will be used to clip the raster instead of using the feature class’s extent. 
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Image server or WCS layer as raster inputs 
 

Raster Geoprocessing tools and Spatial Analyst tools now support an image service layer or a WCS service layer 
as a raster input. 
 

You can now export from an image service or a WCS service to a raster dataset using the Export Data dialog. 
 
 
Discrete Color renderer 
 
A Discrete Color renderer has been added to the Symbology tab of the Layer Properties page. The discrete color 
renderer uses a set of colors to display any integer type of raster dataset. When using the discrete color renderer you 
can specify the number of colors you wish to use in the rendering as opposed to having the Unique Values renderer 
calculate the total number of unique values in the raster dataset. The discrete color renderer will repeatedly cycle 
through the selected color scheme for the amount of colors specified. Since the discrete color renderer uses a set of 
colors repetitively instead of a single color for each unique value, the raster will be displayed with a similar look as 
when using a unique value renderer, but will display much faster. 
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New tools for unmanaged raster catalogs 
 
For an unmanaged raster catalog, when referenced raster datasets are moved, the associated raster catalog items will 
become invalid because the links to the referenced raster datasets are broken. In order to repair the unmanaged raster 
catalog without reloading data, 9.3 provides two new geoprocessing tools:  
 
The Export Unmanaged Raster Catalog Path tool will output the paths of the referenced raster dataset to a .dbf file. 
You can choose to export paths for all the raster catalog items or to export only those that have broken links. 
 
The Repair Unmanaged Raster Catalog Path tool allows you to update the path for the invalid raster catalog items or 
remove the invalid raster catalog items.  
 
 
Export Raster World File tool 
 

A new tool called the Export Raster World File tool has been added to the raster toolbox with the purpose of 
exporting world files that can be used in non-ArcGIS applications. This tool will export a standard world file if the 
transformation in the raster dataset is a first order polynomial transformation, but since a world file cannot store a 2nd or 
3rd order polynomial, or a non-polynomial transformation, the tool will instead export what is called an “approximate 
world file” signified by adding an x to the file extension. These approximate world files can be used in other non-
ArcGIS applications by removing the x from the extension name. 
 
Other raster enhancements 
 

A check box has been added on the raster option page to control the default stretch behavior for the raster stretch 
renderer. The default is to have this box checked but it can be turned off if you do not want to use the standard 
deviation stretch as the default stretch type when displaying a raster. 
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 A new dropdown menu has been added next to the Source Type property on the raster properties page in 
ArcCatalog. The menu is labeled Switch to and is used to change the data source type for rasters saved in a file-based 
format. For most file-based raster formats, the resampling method used in building pyramids is based on the data 
source type. If a raster dataset has only a few unique values, the nearest neighbor resampling method should be used 
to build pyramids. Therefore, if your dataset only has a few unique values it is recommended that you click the Switch 
to button to change the data source type to discrete before you build pyramids. 
 

The Unique Values renderer now supports floating point data at ArcGIS 9.3. Since floating point raster datasets do 
not have a raster attribute table a dialog will prompt you to compute unique values when the Unique Values renderer is 
selected. 
 

The raster toolset has been reorganized for easier access. It is now based on raster functionality. 
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Mapping 

Working with graphics 

New Convert Graphics To Features dialog makes it easy to create features without editing 
 

New dialog lets you convert graphics drawn on your map into shapefiles or feature classes, making it easy to 
quickly create study areas, clipping extents, simple datasets, etc, without going to ArcCatalog. You can access this in 
the data frame context menu and the Drawing pulldown menu. The dialog lets you convert point, line, and polygon 
graphics drawn on your map into a new shapefile or feature class. Text graphic support is being added too so that 
annotation feature classes can be created from text.  
 

 
 

An example workflow is adding specific xy point or address locations to a map with Go To XY or Find dialog, and then 
using Convert Graphics To Features to create a feature class containing these points, and then buffering this feature 
class. It supports all the graphic types you can draw with the tools in the graphics palette in the Draw toolbar, including 
circles, curved lines and freehand lines.  
 
Convert Graphics To Features also supports 3D graphics, such as contour lines drawn on the map using the Contour 
tool in the 3D Analyst toolbar: If any of the graphics you convert are 3D, the output shapefile or feature class is 
automatically 3D (Z values are enabled).  
 
1. Use drawing tool to draw a couple of polygons. 
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2. (Optionally) double-click each polygon to give it a name (type into the ElementName in the Size and Position tab in 
graphics properties) 
     
3. With both polygons selected, choose Drawing > Convert Graphics To Features. Check the option to delete the 
graphics after conversion. Add the layer to the map. 
    
 4. Turn on labeling for the layer: the features are labelled with the names you specified. Open the attribute table. The 
graphics names you specified are in the Name field. 
 

Tip: This also makes it really easy to quickly add transparent shapes to your map. We still don't support transparent 
graphics, but draw a graphic, use Convert Graphics To Features, then make the resulting layer transparent. 
  
Convert Graphics To Features also makes it easy to create features from features you find:  
  
1. Use the Find dialog Places tab or Addresses tab 
  
2. Right-click results and add some point graphics to your map 
     
3. With the points selected, choose Drawing > Convert Graphics To Features. Check the option 
to delete the graphics after conversion. Add the layer to the map. 
    
4. Turn on labeling for the layer: the point features are labelled with their places/addresses. 
Open the attribute table. The place/address names you specified are in the Name field. 
 
 

Easy to find the length of line graphics 
 

When you draw a line graphic on a map, you can now get its length from its properties dialog in the units of your 
choice. This is supported for all line types (straight lines, curves, freehand). The new Length tab in the graphic 
properties dialog makes it easy to get the length of any line graphic that you've drawn on the map or that has been 
added to the map by a command (such as the Contour tool in the Spatial Analyst toolbar, Find Steepest Slope in the 
3D Analyst toolbar, a route added with Find Route, etc). Like in the existing Area tab for polygon graphics, you can 
choose the units for the reported length. The Start and End points of the line are also listed in map units (or page units 
if you are working with a line drawn on the map layout).  
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When you draw a line graphic, the length of each segment is now displayed in the status bar in addition to the total 
length of the line.  
 

If your data frame is unprojected, i.e. it is using a geographic coordinate system (GCS) rather than a projected 
coordinate system (PCS), the line lengths displayed in the status bar and in the new Length tab listed above is 
calculated in true geodesic distance on the spheroid. In other words, when your map is not projected, the length of line 
graphics, and the perimeter of polygon graphics are the correct length on the surface of the earth.  
 
 
Easy to find the coordinates of point graphics 
 

You can now find the coordinates of any point graphic drawn on your map in the units of your choice by opening its 
properties dialog and looking in the new Location tab. The units you can choose include US National Grid (USNG) and 
Military Grid Reference System (MGRS). 
 
If the point graphic is a 3D point, you will also see the height of the point shown in the Location tab. 
 
 
More use made of the name property of a graphic 
 

In 9.2 we exposed the Element Name property of graphics in the Size and Position tab in the graphic properties 
dialog. At 9.3 we now take more advantage of this property to store names for graphics you draw on the map: 
 
- If you use the Find dialog Places tab or Addresses tab to add a point to your map, the Element Name property of 

that point graphic is now automatically populated with the place name or address that you specified. In this way for 
example you can easily find out which address a particular point graphic represents after you added it to a map 
simply by opening the properties dialog of the point: The Element Name property of a graphic is automatically shown 
in the title bar of its properties dialog in addition to in its Size and Position tab. 

 
- If you use the Go To XY dialog to add a point to your map at a particular coordinate location, the Element Name 

property of that point graphic is now automatically populated with the coordinates you entered, giving you a record of 
the exact coordinates that were specified. 

 
- If you use the Contour tool on the Spatial Analyst toolbar or the 3D Analyst toolbar, the Element Name property of 

that point graphic is now automatically populated with the height of this contour. Similarly if you use the Interpolate 
Point tool on the 3D Analyst toolbar, the height of the resulting 3D point graphic is entered into its Element Name 
property. 

 
- If you add places from the Tools > My Places dialog onto the map as graphics, the Element Name property of each 

of the resulting graphics is now automatically populated with the name of the place as it appeared in your My Places 
dialog. 

 
- If you add a graphic from your map into the Tools > My Places dialog as a place, the name of that place is 

automatically obtained from the Element Name of the graphic. If the graphic's Element Name is not populated, the 
new place defaults to being called 'My Place'.  

 
These additional uses of the name property for graphics are especially useful in these scenarios: 
 
-  When you use the new Convert Graphics To Features dialog (see above). When you convert graphics to features, 

the Element Name of each graphic is used to automatically populate a name field in the resulting shapefile or feature 
class.  

 
- If you have added a point graphic to a map showing, say, a particular address, and you decide you would like to 

label this point with its address, you can simply open its properties dialog, copy its Element Name property, close the 
properties dialog, click with the Text tool and paste the text onto the map. 
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Bookmarks 

Easier to access bookmarks 
 

Previously, bookmarks were accessed via the Bookmarks pullright in the View pulldown menu. This pullright has 
been removed and turned into a Bookmarks pulldown menu, making it much easier and quicker to access bookmarks. 
This new Bookmarks pulldown menu is also in ArcGlobe, ArcScene and ArcReader. 
 

 
  
 
Better bookmark management 
 

The Bookmarks Manager dialog now lets you sort bookmarks and also manually reorder them. You can also import 
and export bookmarks to share them with other people, copy them between different data frames in the same map 
document, copy them between different ArcMap, ArcGlobe and ArcScene documents. You can also use the Bookmark 
Manager to pan to bookmarks (i.e. recenter the map without changing its scale.  
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The Bookmarks Manager is now 'non-modal', so you can keep it open while you work on your map to provide easy 
access to bookmarks. You can double-click a bookmark to zoom to it in the Bookmarks Manager. 
 

In the Bookmarks Manager, you can right-click a bookmark and choose Update Extent to update its extent to match 
the current extent of your map. This makes it easy to   
 

 
 

The file used for saving and loading bookmarks is the same file format used for saving and loading places in the 
Tools > My Places dialog. This makes it easy to copy bookmarks into the My Places dialog so that they are available 
irrespective of which map document you are using. The My Places dialog was introduced in 9.2 to enable you to 
access a useful set of spatial extents. locations, addresses, etc at any time irrespective of which document you are 
using. Unlike bookmarks, the places in the My Places dialog are stored centrally, not in the map document you are 
using. When you load bookmarks into the My Places dialog they become spatial extent places.  
 
You can go the other way too: you can save one or more places from your My Places dialog and load them into the 
Bookmark Manager. For example, you may have created a set of places and now you want to add them into the map 
as bookmarks so that they can be used by the people you share the map document with. When you load line or 
polygon places into the Bookmark Manager, their envelope extent becomes the bookmark. When you load point 
places into the Bookmark Manager, an extent is automatically generated for the resulting bookmark. 
 

Tip: This functionality makes it easy to create bookmarks from features. For example, you may have a number of 
counties in your map and want to create a bookmark for each county: 
 
1. Select the county features in ArcMap using any selection method. 
 
2. Open Tools > My Places and add the counties into the dialog by choosing Add From > Selected Features 
 
3. If desired, rename the places that were added (their name defaults to their value for their primary display field).  
 
4. Choose Save > Save Selected and save the places you just created to a file. 
 
5. Choose Bookmarks > Manage and in the Bookmarks Manager dialog load the places in as bookmarks. Each 
county becomes a bookmark. You can sort or reorder the bookmarks in any way you like. 
 
Tip: You can also use this functionality to add graphic rectangles to your map showing the location of bookmarks, 
which can also be converted into polygon features: 
 
1. Choose Bookmarks > Manage and save the bookmarks you want to draw on the map to a file 
 
2. Choose Tools > My Places and load the bookmarks in that you just saved. 
 
3. In the My Places dialog, select the bookmarks and then choose Add To Map > As Graphics. They are drawn on 
your map using the current polygon symbology specified in Drawing > Default Symbol Properties. 
 
4. To convert the graphics you have added to features, choose Drawing > Convert Graphics To Features 
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Symbology 

Symbols in legends now automatically reflect layer transparency 
 

Symbols in legend on the map and in the Table Of Contents are automatically drawn with a lighter colors if you 
make the layer partially transparent, so they look more like the actual symbols drawn on the map. 
 
This is a new setting in the Data Frame Properties dialog General tab. It is turned on by default for new data frames 
you create in 9.3. It is turned off for existing data frames (so the legends of your existing maps look the same until you 
manually choose to use this option): 
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Advanced symbology and symbol editing with cartographic representations 
 

Two new line symbols have been added to the ESRI style and serverstyle. They are: Arrow Right Middle and Arrow 
Left Middle: 
 

 
 
The arrows will always be placed in the center of the line segment regardless of length, excluding those lines that are 
too short for the decoration. While you will not be able to change the position of the marker on the line, other common 
properties such as the marker symbol, marker color, marker angle, marker size, line color, line width and dash 
template can still be edited. 
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Navigating and viewing maps 

Ability to use the ArcMap viewer window to work with multiple data frames 
 

You can now work with multiple data frames side-by-side on-screen in the same map document. Previously, if your 
map document contained more than one data frame, the only way to work with the contents of multiple data frames 
simultaneously was to switch to Layout view and arrange the data frames on the layout page, or to open two or more 
map documents on screen. (This enhancement was originally introduced in 9.2 Service Pack 2). 
 
The viewer window was introduced at 9.2 to enable you to work with one data frame at multiple scales. In the 9.2 
release if you opened a viewer window and then activated a different data frame in your map document, the viewer 
window was automatically closed. We have now enhanced viewer windows so that you can use them to view inactive 
data frames. Now if you activate a different data frame while a viewer window is open, that viewer window remains on-
screen, enabling you to work with multiple data frames side by side.  
 
In this example, a viewer window is being used to compare two data frames showing different data for the same area: 
 

 
 
When you work with an inactive data frame in a viewer window, you can easily make the viewer show the same 
location that is currently displayed in the active data frame in the main ArcMap window. Similarly, you can update the 
location shown in the active data frame in the main ArcMap window to match the location shown in any of your viewer 
windows. Commands in the viewer window's menu let you pan or zoom the viewer or the main ArcMap window so that 
both displays show the same location: 
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There are some restrictions on which operations you can perform inside a viewer window that is displaying an inactive 
data frame. You can generally perform map navigation, query, and selection, but you can't edit graphics or features. If 
a tool can't be used on an inactive data frame displayed in a viewer window, the cursor will change when you hover 
over the viewer to show you that the tool is not available. There are no restrictions on the operations that can be 
performed inside a viewer window displaying the active data frame. 
 
In this example, four viewer windows have been arranged on-screen so that four different sources of street data for the 
same area can be compared. Each viewer window is showing the contents of one data frame in the map document: 
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The ability to work with multiple data frames side-by-side in ArcMap can be useful for analysis, historical change 
assessment, data evaluation, and other applications where you want to be able to see different datasets for the same 
area side by side, as opposed to working with all the data in one data frame, or working with multiple map documents.  
 
In the photo below, two different map services in separate data frames in a map document are being compared for the 
same location. A viewer window showing the inactive data frame has been maximized on the second monitor: 
 

 
 
 
Tip: There are two shortcuts that make it easy to work with multiple data frames:  
 

CTRL + TAB switches between the data frames making each one active in turn. (If you want to be able to do the 
same thing by pressing a button on-screen, add the Activate Next Data Frame command into any toolbar from the 
View category in the Tools > Customize dialog). 
 
ALT + click on the name of a data frame in the Table Of Contents activates that data frame. 

 
If you use the Schematics extension, you can use a viewer window to work with a schematic side-by-side with the 
geography it represents without having to work in Layout view. ( See the 'Schematics' section of this document). 
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Easier to share places defined in the My Places dialog in ArcMap, ArcGlobe & ArcReader  
 

In the dialog launched by the My Places command  in the Tools pulldown menu, you now have the option to save 
a subset of your places into a separate file. Starting with Service Pack 2, the Save button is now a menu button 
containing two commands, one for saving the currently selected places, and the other for saving all the places: 
 

 
 
By using the option to save just the selected places, you can save a subset of places as a file you can share with 
others or move between different machines. You can load the file that is created into the new Bookmarks Manager 
dialog in 9.3 in order to turn extent places (places shown with yellow rectangle icon in the picture above) into 
bookmarks saved in your map document. When you load a places file into the Bookmarks Manager, any places in the 
file that are not extent places are skipped. Similarly, you can save bookmarks to a file from the Bookmarks Manager 
and load them into the My Places dialog so you can use them to navigate all your maps.  
 
 
Zoom To Layer command now respects definition queries 
 

When you use the Zoom To Layer command on a layer containing a definition query, you now get taken to the 
actual extent of the data defined by that query. Previously Zoom To Layer didn't respect definition queries and always 
took you to the full extent of the layer.  
 
Similarly, when you use the Zoom To Layer command on a selection layer, you now get taken to the extent of the data 
in that selection layer. Previously zooming to the extent of a selection layer took you to the full extent of the data 
source referenced by the layer and didn't take into account the subset of features represented by the layer. (These 
enhancements were originally introduced in 9.2 Service Pack 4). 
 
Tip: In the Table Of Contents, hold down ALT and click on the name of any layer in the active data frame to zoom to 
that layer's extent. This was added in 9.2. 
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Option to make rolling the mouse wheel in ArcMap scroll instead of zoom 
 

By default, rolling the mouse wheel in ArcMap 9.2 zooms in and out. This behaviour makes it easy to zoom 
irrespective of which tool you are currently using. However, some users prefer the pre-9.2 behaviour where rolling the 
mouse wheel scrolls the map up and down. For example, some people were using ArcMap 9.1 with a mouse with a 'tilt' 
wheel that can be tilted from side to side in addition to being rolled forward and back, enabling them to pan in four 
directions. Using a tilt wheel mouse to pan to doesn't work as expected in ArcMap at 9.2 because rolling the mouse 
wheel forward and back zooms instead of scrolling up and down. We have therefore introduced a new registry setting 
that you can specify to override the default mouse wheel behaviour introduced at 9.2: 
 
HKEY_CURRENT_USER\Software\ESRI\ArcMap\Settings\MouseWheelScroll 
  
Giving this DWORD registry key a value of 1 tells ArcMap to scroll the map when you roll the mouse wheel. When this 
registry setting has not been specified, or when it has a value of 0, rolling the mouse wheel will zoom in/out, the default 
behaviour at 9.2.  
 
Behaviour involving single-clicking or holding down the mouse wheel is unaffected by this registry setting. So 
irrespective of the value of this registry setting, you can still drag with the mouse wheel held down to pan, drag and 
hold down CTRL to zoom to a box, single-click the mouse wheel to re-center, and CTRL+single-click to zoom in. 
 
This registry settings is documented in the final section of the ArcGIS Desktop Advanced Settings Registry Keys.doc 
document in your arcgis/utilties folder. The final section of this document contains information about registry settings 
that are not set from inside the application's user interface or in the  AdvancedArcMapSettings.exe program in the 
arcgis/utilties folder. (This enhancement was originally introduced in 9.2 Service Pack 3). 
 
 
Mutually exclusive viewing shortcut for layers 
 

In the ArcMap Table Of Contents, if you hold down ALT and click on the check box next to a layer, that layer will be 
turned on (if it is not already on) and all the other layers at that level in the TOC hierarchy will be turned off. For 
example, you may be comparing a number of different data sources, such as different sources of imagery, to see 
which one best meets your needs. Great for demos and presentations too. 
 
 
 
 

Geocoding 

Improved progress reporting when geocoding 
 

 When you geocode it is now easier to see the progress, and the new progress dialog also more clearly shows you 
the results: 
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New user interface for rematching geocoding results 
 

 The Rematch dialog has been completely reworked to make it easier to use. It is now a modeless dialog so you 
can keep working on the map while it is open. You can also hide/show different parts of the dialog to make it more 
compact. You can create and store your own result set definitions to filter which results are listed for rematching. A 
new Pick Address From Map tool on the dialog lets you click on the map to choose the address location directly: 
 

 
In this example, the top portion of the window has been hidden. You can work through the addresses that will be 
rematched by using the controls in the top left hand corner: 
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New reverse geocoding tool lets you click on map to get the address of a location 
 

 You can find the new  Address Inspector tool in the Tools > Customize dialog Commands tab in the Geocoding 
category. Once you've added this onto a toolbar, and selected it, you can hold down the left mouse button over any 
street location to see the address. Right-click with the tool to access additional options. 
 
1. In Tools > Customize > Geocoding, add the Address Inspector tool into a toolbar in a map containing streets data 
and a local address locator. 
  
2. Click the tool and then click on the map..Keep mouse button held down and move 
mouse to see addresses 
  
3.  Use the keys listed in the status bar to copy the current address, add a point/labelled point or call out for it. 
  
4. If now do a Convert Graphics To Features, that address will automatically appear in the Name field of the output 
feature class as described earlier. 
 

 
 
 
 
 
 
StreetMap Premium Address Locators 
 

 WHAT'S NEW IN ARCGIS 9.3 - PAGE  50 



You can geocode addresses using StreetMap Premium address locators that were created based on the RouteServer 
technology. The address locators are provided in the StreetMap Premium data set. 
 

 
 
See http://www.esri.com/data/streetmap/index.html for more information about StreetMap Premium. 
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Scale  

Full support for entering and displaying scale in relative format throughout ArcMap 
 
At 9.2 we introduced the ability to specify scale in relative format (e.g. 1 inch = 100 miles). Relative scales entered into 
scale controls anywhere in the ArcMap user interface were automatically converted to the equivalent absolute scale. At 
9.3 we have added the ability for ArcMap to report scales in relative format. You can now customize the scale control 
throughout the ArcMap user interface to use relative scale instead of absolute format.  
 
Remember that you can enter scale in any format irrespective of what format the scale control is currently using. So 
you can still enter scales in relative format even if the scale control still uses absolute format. 
 

 
 
 

In the scale text map element you can now specify the text used to separate the different sides of the scale text as a 
property of the element. Previously if you added scale text to your map in relative format, the separator text always 
said 'equals' and so if you wanted the text to say '1 inch = 100 miles' instead of '1 inch equals 100 miles' you had to 
convert the scale text element to graphics. In scale text, the separator used for both relative scales and absolute 
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scales can now be specified: the default separator is '=' for relative scales and ':' for absolute scales. We have also 
updated the default set of scale text styles so that most of them use the '=' separator. 
 
 

Measuring  

Measure tool enhancements  
 

In the Measure tool , the units that you choose for measuring distances and areas are now persisted between 
your sessions, so you no longer have to specify your preferred units whenever you use the tool in a new session. 
When you use the Measure tool it will default to the units that you used previously. This enhancement also applies to 
ArcReader and ArcGIS Engine applications that feature the Measure tool. (This enhancement was originally 
introduced in 9.2 Service Pack 3). 
 
 
 

Labeling 

New Pause Labeling command 
 

You can now temporarily turn labeling off with the new Pause Labeling command in the Labeling toolbar. 
 

Labeling enhancements include new contour labeling options for complex maps such as geology, street address 
labeling, new polygon placement options, support for Asian language vertical text placement, and the ability to 
automatically place text within various parts of a polygon (i.e., offset from center, in a corner, etc.). 

 
 

CAD data 

 
Transformations tab added back into CAD layer properties  
 

The Transformations tab has been fully restored to the Layer Properties dialog for CAD feature class layers and 
CAD drawing layers. The tab was removed in 9.2 with the introduction of CAD support in the Georeferencing toolbar, 
but this made it hard to specify certain transformations like scaling by entering the parameters: 
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(This Transformations tab was originally restored in 9.2 Service Pack 2). 
 
 

Raster data 

Easier to export raster data for specific area 
 

When you use the Export Raster Data dialog in ArcMap, there's a new option been added recently that lets you clip 
the output to the extent of the currently selected graphic(s) in your map. This makes it much easier than before to clip 
out a part of a raster to a new raster because you can just draw a box on the map.  
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The GP Clip tool for rasters (Data Management>Raster toolset) has also been enhanced to add the option to clip the 
output raster to the extent of a particular layer in your map (and its selected features if any are selected). You can also 
choose to use the rectangular extent of those features as the clip or actually use the geometry of those features to clip 
out irregularly shaped rasters. 
 
Both of these options support exporting irregular shaped rasters. They clip to the boundaries of any graphics or 
features used to define the area to export, and fill the outside pixels with nodata. When saving to file-based raster 
datasets, you will need to select a proper NoData value so it can be saved.  
 

 
 

Adding data  

Speed up the Add Data dialog the first time you use it in a new session 
 

When you use the Add Data command  in ArcMap for the first time in a new session, it automatically returns to 
the last location you added data from. A new option in the Tools > Options dialog General tab lets you control this 
behavior. By unchecking the new 'Return to last used location' option you can tell ArcMap that you don't want the Add 
Data command to default to the last used location. When this option is unchecked, the dialog will instead default to the 
top level of the ArcCatalog tree.  
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This improves the performance of the Add Data command because you don't have to wait while it reconnects to the 
network drive, database location or GIS Server that you accessed in your previous session. It is useful if you typically 
add data from a variety of different data locations, and are not likely to add data from the same location whenever you 
start ArcMap. Another example is that you may be about to give a presentation or demonstration using ArcMap with a 
map containing ArcSDE geodatabase data, and you want to make sure that if you press the Add Data button during 
the demo, you won't have to wait while the Add Data dialog reconnects to the ArcSDE geodatabase that you accessed 
when you created the demo. 
 
This option doesn't affect the location that the Add Data dialog defaults to if you launch it from a geoprocessing tool 
when you are using the current workspace setting in your geoprocessing environment (Tools > Options dialog > 
Geoprocessing tab). If you have set the current workspace for geoprocessing, then the Add Data dialog will default to 
the location of that workspace the first time you use it in a new ArcMap session, irrespective of whether or not this 
option is checked. It also doesn't affect the location that the Catalog Browser dialog defaults to when you save or 
export data from ArcMap. 

Technical note for devs only: the Add Data dialog uses the following key in the registry to determine the last used 
location: HKEY_CURRENT_USER\Software\ESRI\ArcCatalog\Settings\LastBrowseLocation. If you uncheck this new 
option, ArcMap will automatically erase the contents of the LastBrowseLocation key when it starts up, thus ensuring 
that the Add Data dialog will default to the top level of the Catalog tree the first time it is opened in the session. This 
option doesn't affect the locations that the Catalog Browser dialog returns to when you save data (the 
LastSaveToLocation registry key) or when you export data (the LastExportLocation registry key). 

 
 
 

ESRI 'Data & Maps'  

In the StreetMap USA data, the TIGER-based streets have been replaced with the Tele Atlas 2003 streets. 
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Animation 

New Create Time Layer Animation dialog added to make it easier to create temporal animation. The dialog basically 
takes an input layer or table, a field with time values and the interval and units to use to display time slices. It creates a 
time layer animation that can be played immediately via the Animation Controls dialog on the Animation toolbar. 
 

 
 
 

Other 

Option for setting the amount of densification for graticules  
 

Graticule lines have vertices added every 1 degree by default to allow the lines to bend to better fit the curvature of 
the graticule. In some cases, such as large scale maps or precise data the amount of densification needs to be 
increased to better fit the graticule to the data. In 9.2 Service Pack 4, we have therefore introduced a new registry 
setting that you can specify to increase the amount of densification. You won't see this setting in the registry after 
installing the service pack. You have to create the registry setting manually yourself. 
 
HKEY_CURRENT_USER\Software\ESRI\ArcMap\Settings\Graticule\DensificationDistanceInDegrees 
 
Giving this REG_SZ registry key a value of 0.1, for example, tells ArcMap to place vertices every 10th of a degree. 
Valid values are from 0.01 to 5. 0.01 means the graticule gets vertices placed every 100th of a degree and can 
seriously impact performance when working with a map that covers a large area, such as a world map. For this reason 
we recommend that you use finer levels of densification only when you can see on the map that the graticule doesn’t 
quite line up with your data. When this registry setting has not been specified, or when it has a value of 1, graticules 
will appear the same as they do in 9.2.  (This enhancement was originally introduced in 9.2 Service Pack 4). 
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Cartographic representations 

Editing 
 

WYSIWYG feedback for all representation editing tool operations 
 

Representation tool dialogs accept entry of multiple units of measurement 
 

Vertices of selected features are now larger in size 
 

Shortcut keys to switch between Representation tools 
 

Context menus in Marker Editor for size and shape of new features 
 
 
Display 
 

Option to control the display of rules in the Table of Contents 
 

Added new geometric effects: Move, Rotate, Scale, Wave, Tapered Polygon, Regular Polygon 
 

Added new marker placement style: On Vertices 
 
 
Geoprocessing 
 

New Disperse Markers tools: Spreads markers symbols apart if they are coincident or nearly coincident 
 

Set Representation Control Points At Intersect tool. You can now add a control point where coincident features 
share vertices 
 
 
Geodatabase 
 

Improved XML export of feature representations 
 
 
 

Accessing GIS data on the web 

 
Support added for OGC WCS  
 

The OGC WCS (Web Coverage Service) is a standard for distributing raster data collections on the Internet. An 
'Add WCS Server' command has been added into the GIS Servers folder in ArcCatalog. WCS Server connections are 
shown with a light green server icon in ArcCatalog, and the service they contain, such as SanDiego in the example 
below is also shown with a green icon: 
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Improved support for OGC WMS 
 

Support has been added for WMS 1.3.0. 
 

In ArcCatalog you can now expand WMS services to access the various layers and layer collections they contain. 
This makes it easier to work with WMS services with a large number of layers because you can drill down to the layer 
or layer collections you want to work with and drag them directly into your map or globes: 
 

 
 

A new command has been added into the WMS layer context menu in ArcMap that enables you to open the legend 
of any WMS service in a separate window. 
 

Support for WMS styled legends. 
 
 
 
Easier to specify proxy server information in ArcCatalog 
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 In 9.3 you simply use the Internet Options in the Windows Control Panel to specify proxy server and https/SSL 
connection information, and ArcCatalog automatically uses these settings for all your GIS Server connections. 
 
 The Tools > Options dialog Proxy Server tab has been renamed to be the Connections tab.You only need to enter 
information into the Connections tab if your proxy server requires authentication, in which case you simply specify the 
user name and password in those two fields in the tab. (This enhancement was originally introduced in 9.2 Service 
Pack 2). 
 

 
 
 
Working with ArcGIS Server map services 
 

When you work with cached ArcGIS map services in ArcMap, it is now easier to zoom your map to one of the 
resolutions at which the service has been cached. The new Zoom To Nearest Cache Resolution in the context menu 
for a cached ArcGIS map service layer will automatically zoom to the cached resolution that is closest to your current 
scale. Cached map services are cached at different resolutions, defined on the server as a scale + a Dots Per Inch 
(DPI) setting. You can think of this command as letting you 'sharpen up' the appearance of a cached map service, if 
you are finding that it appears slightly blurred or fuzzy at your current map's scale. This command is disabled if you are 
working with an ArcGIS map service that has not been cached.  
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Tip: To see if the ArcGIS Server map service layer you are working with is cached or non-cached, you can go to the 
Layer Properties dialog Source tab for the layer and look at the 'Map Service Type' field in the data source details. 
You can also look at the properties of a service in ArcCatalog to see if it is cached or not before you add it into 
ArcMap. 
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Geoprocessing & analysis 

General improvements 

New ”Start ModelBuilder” button on the Standard toolbar lets you open ModelBuilder without having to first create a 
model tool. 

 
All error and warning messages have been standardized and given a unique number.  When a warning or error 
occurs, you will see this unique number and standardized text.   

 
Each error is documented to give you insights into the cause of the error and possible solutions, as well as links to 
relevant documentation. 
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The progress dialog has been modified so that tools can indicate percentage complete. 

 
A new option for automatically controlling the lifespan of tool results is available on the Tools > Options dialog 
Geoprocessing tab of any ArcGIS application. Previously, results were always saved until you explicitly deleted or 
removed.  This new option helps prevent the build-up of unneeded results, which caused desktop applications to 
take longer opening and closing. 

 
The system default is to keep results that are younger than two weeks. A side effect of this is that results that are older 
than two weeks will be removed when any existing document is opened and then saved. If you have older results that 
you want to keep, you must change the default setting or copy your result into a model that can be saved. If you open 
a document containing results older than 2 weeks, the following pop-up message appears: 
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Model and script tool improvements 

Python script tools now have the option of running in-process.  Running in-process makes your tools run 
significantly faster. 

 
You have more options for model and script tool parameters. For models, you can change optional parameters to 
required parameters and apply various filters for inputs and outputs. 
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For scripts, you can also apply various filters and set symbology for output features.  

 
Script tools can contain custom validation code. Validation code allows your tool to behave just like a system tool by 
providing you ways to: 

 Enable or disable parameters based on values contained in other parameters. 
 Dynamically update a parameter filter. 
 Dynamically update default values for parameters. 
 Customize warning and error messages. 
 Put parameters in categories. 
 Update the description of output datasets for use in ModelBuilder. 
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Within Python, you now have better access to Python data structures. The arcgisscripting method now takes a 
version number argument that tells geoprocessing to return lists instead of enumerators, as illustrated below.  

 
 

You can access the new tool progress dialog to show percent complete. 
Within your script, you have access to the new repository of error codes and messages. 
NumPy (Numerical Python) is included in the ArcGIS install. 
Tools return a result object. 
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Server enhancements 

The Feature Set and Record Set data types now accept a feature class and table, as illustrated below 
 

 
Better error checking when publishing a geoprocessing service.  At 9.2, toolboxes published even if they had errors.  
At 9.3, toolboxes will not publish if they contain errors and you’ll receive an error message, as illustrated below. 

 
 

Improved performance. 
Raster rendering information for geoprocessing service raster result. 

 
 
 

New and enhanced tools 

 

General 

 Several key tools including Near, Summary Statistics, Combine, Fill, and Buffer have been enhanced to improve 
performance and expanded capabilities.  
 Summary Statistics now has multiple case fields 
 ModelBuilder supports TIN layer symbology 
 Calculate Field now supports unit conversion 
 Feature & record set controls include dataset input 
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 Buffer tool improvements 
 More robust implementation using the topology engine to clean-up offsets  
 Support of geodesic buffers  

 Contour tool for Spatial Analyst 
 Toolbox Save As 9.2 
 New time animation wizard 

 
 

Spatial Statistics 

 New Regression Analysis Tools 
 Geographically Weighted Regression  
 Ordinary Least Squares Regression  

 New Make Spatial Weights Matrix tool  
 New scatter-plot matrix graph  

 
 

Proximity Analysis 

 Improved Near tool 
• Additional feature types (point, line & polygon) and multiple Near feature classes  

 New Generate Near Table tool – allows you to find nearest features in a set of feature classes. 
 Improved Spatial Join tool  
• New option for joining to the closest feature 

  
 

3D Analysis  

 Enhancement of analysis tools to work with terrains 
 New pyramid type for terrains  
 New Point Info tool  
 New 3D Geometry COM operators 

 
 

Geostatistical and Spatial Analyst 

 Contour tool for Spatial Analyst 
 Geostatistical Simulation 
 Performance improvements for 
• Fill  
• Combine  
• Moving Window Kriging  
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Putting GIS on the Web 

ArcGIS Image Server integrated into ArcGIS Server 

The ArcGIS Image Server product has been integrated into ArcGIS Server. ArcGIS Image Server enables 
organizations to serve large raster data collections as ArcGIS image services. Unlike raster data served as dynamic or 
cached ArcGIS map services, which you can think of as being snapshots of raster data displayed on the source map 
being served, image services contain the complete raster data content and so they can be manipulated by client 
applications to perform image processing and analysis.  
 
If you want to serve raster data with the fastest possible draw time, for example to serve your imagery to web clients, 
then creating cached map services continues to be the best solution. However, if you want to serve your raster data so 
that it can be image-processed on-the-fly by client programs to create any number of different displays and analytical 
renderings of the raster data, then you should use an ArcGIS image service. 
 
In this example, an ArcGIS Server containing ArcGIS image services has been accessed in ArcCatalog. Image 
services are shown with a blue icon: 
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Improved documentation 

 
ArcGIS Server 9.2 was released with comparatively basic documentation, particularly for developers. Since the 

release of ArcGIS Server 9.2, our goal has been to incrementally release more help content. We have been making a 
large number of improvements and additions to the ArcGIS Server help, and continue to add new topics every week. 
When you install a service pack, it updates your local ArcGIS Server documentation with the new content. But be sure 
to check the documentation resources online to get the very latest material. 
 
- For a sampling of the key topics that have been added to the ArcGIS Server documentation since 9.2, see this ESRI 

KnowledgeBase article: 
 
 http://support.esri.com/index.cfm?fa=knowledgebase.documentation.viewDoc&PID=66&MetaID=1294
 
- ArcGIS Server Help Online at: http://support.esri.com/index.cfm?fa=knowledgebase.webHelp.agServer
 
- The developer documentation and examples for customizing ArcGIS Server with both .NET and Java on the ESRI 

Developer Network (EDN) website: 
 

Start page for .NET developers: 
http://edndoc.esri.com/arcobjects/9.2/NET_Server_Doc/developer/getting_started.htm
 
Start page for Java developers: 
http://edndoc.esri.com/arcobjects/9.2/Java/java/server/getting_started_oview.htm

 
- Check out the new ArcGIS Server Development blog. It includes tips and best practices that will help you become 

more effective using and customizing ArcGIS Server: http://blogs.esri.com/Dev/blogs/arcgisserver
 
- We have also enhanced the topics on how to publish ArcGIS services using ArcCatalog and ArcMap in the ArcGIS 

Desktop Help Online: http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=welcome under the 'GIS 
Servers and services' section.  

 
 

Caching services 

Support for caching maps in PNG8, PNG32 and JPG formats 
 

9.2 Service Pack 1 introduced the option to create your map cache in PNG8, PNG32, and JPG formats in addition 
to the default format of PNG24. You can select the image format for your cache when you generate it in ArcCatalog. 
Use the Cache Tile Format dropdown when you fill out the caching tool’s parameters. 
 
Since Internet Explorer 6 has limitations relating to displaying PNG24 transparency, PNG8 may now be a better option 
for caching overlay features such as boundaries and roads. The JPG format is a good way to greatly reduce the size of 
your base map caches, especially if they contain raster imagery. The smaller cache tile size has more than a storage 
benefit; the tiles load faster inside Web applications, providing for a more seamless navigation experience.  
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ArcGIS Server for the Microsoft .NET framework 

Improved support for blending cached services  
 

Prior to 9.2 Service Pack 2, overlaying two cached map services in the .NET Web ADF required that both caches 
be created with the exact same tiling scheme. Starting with 9.2 Service Pack 2, the criteria is less rigid: caches can be 
overlaid if they have the same coordinate system, tile size, and tile origin. All scale levels do not need to match, 
although it’s a good idea to match as many as possible. Also, cached map services included in the Web Mapping 
Application are automatically disabled in the Table Of Contents if they have not been cached at the scale at which you 
are currently viewing your map. For details about what’s required to overlay two caches, see the topic 'Overlaying map 
caches in the .NET Web ADF' in the ArcGIS Server Online Help. For details about what’s required to overlay two 
caches, see the topic 'Overlaying map caches in the .NET Web ADF' in the ArcGIS Server Online Help. 
 
 
The Editor task can now edit pooled resources 
 

9.2 Service Pack 2 contains the option to edit pooled resources inside the Editor task. When you use pooled 
services, your server can support a larger number of concurrent users because the server does not have to create a 
dedicated service instance for each user during his or her application session. Instead, users can share service 
instances from a pool. When you configure the Editor Task, the Web ADF will determine if you are using a pooled or 
non-pooled service and will provide the appropriate options for configuring the task. Pooled editing is for non-versioned 
geodatabases. Your edits are committed directly to the geodatabase. 
 
 
The Editor task can now be customized 
 

When the Editor task was released at version 9.2 of the Web ADF for the .NET Framework, a common question 
was "How can I customize the Editor task?". Service Pack 2 provides an answer to this question. You can now 
customize the Editor task with custom tools and Editor Panels and more events have been added that allow you to 
hook into the Editor task. The ArcGIS Server Developer Help contains instructions to get you started with customizing 
the task: http://edndoc.esri.com/arcobjects/9.2/NET_Server_Doc/developer/ADF/control_editortask.htm
 
 
Other ArcGIS Server enhancements 
 

9.2 Service Pack 1 also added: 
 
- Full support for Internet Explorer 7. 
- Improved performance for ArcWeb Services, ArcGIS Services, and the display of task results. 
 

9.2 Service Pack 2 also added: 
 
- Client side JavaScript is now supported by the Java Web ADF. 
- Improved support for Microsoft Visual Web Express. 
- Support for Web ADF application deployment inside WebSphere 6.1 on UNIX platforms. 
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Mobile GIS 
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Application development 

ArcGIS Engine Developer kit 

Engine's Add Data dialog now supports ArcSDE geodatabases 
 

Starting with 9.2 Service Pack 2, the Add Data dialog in ArcGIS Engine supports connections to ArcSDE 
geodatabases. This enables users of your ArcGIS Engine applications to connect to any ArcSDE geodatabase 
(including Personal ArcSDE, Workgroup ArcSDE and Enterprise ArcSDE) to access data. With the Geodatabases tab 
on the left hand side of the Add Data dialog selected, choose the 'Database Connections' folder from the dropdown list 
and the two new buttons on the dialog will become enabled, the first for making an ArcSDE connection, the other for 
editing the properties of an existing connection. The dialog that appears to let you make a connection is the same one 
that Desktop users see when they make a connection to ArcSDE in ArcCatalog: 
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Improved dynamic display capabilities 
 

The dynamic display capabilities added in 9.2 have been considerably enhanced in 9.3, starting at Service Pack 3. 
With these enhancements, pan, zoom, and roaming are much smoother. Dynamic display is only available via ArcGIS 
Engine, which is part of the ESRI Developer Network (EDN). It can be used and configured using ArcObjects by 
developers on all supported ArcGIS Engine development environments, including ArcMap and the MapControl. 
 

At 9.3 dynamic display has been further improved with better display caching: 
 
- Background tiles loading thread 
- Reused during dynamic sessions (activate and deactivate) 
- Reused between dynamic sessions (Layer files and Map documents) 
- Generate before use 
- Invalidate areas 
-  Tiles compression format 
-  Layer drawing characteristics 
 
It now also supports feature selection, adds new continuous zoom/pan and roam tools, and has enhanced 
performance. 
 
For updated information on implementing dynamic display, along with sample code, see the ESRI Developer Network 
(EDN) SDK documentation and look under Building solutions with ArcGIS Engine using .NET > Working with ArcGIS 
Components > Mapping and Visualization > Working with the map display > Dynamic Display. 
 
 
Personal ArcSDE included in ArcGIS Engine Developer Kit 
 

ArcGIS Engine 9.3 includes the SQL Server 2005 Express installation and the ArcSDE Personal geodatabase Post 
Installation wizard. This allows Engine developers to use Personal ArcSDE geodatabases as a data source.  
 
Personal ArcSDE was introduced in ArcGIS Desktop at 9.2 and is included free with ArcEditor and ArcInfo licenses. 
Personal ArcSDE allows you to set up and administer your own ArcSDE database server and create multi-user 
geodatabases. Personal ArcSDE supports all the advanced features found in ArcSDE such as versioning, archival 
history, multi-generational replication, and advanced dataset-level security. Personal ArcSDE uses the free SQL 
Server Express DBMS, so no additional software or database administration expertise is required. All database 
administration is performed using a new set of dialogs in ArcCatalog.  

 
Personal ArcSDE database servers support up to 4 concurrent users, 1 of who can edit the data at any time. Use 
Personal ArcSDE to try out ArcSDE if you've not used it before. Or put it to work immediately on your small team 
projects or to start on projects that will eventually be moved up to Workgroup ArcSDE and Enterprise ArcSDE. As with 
all ArcSDE geodatabases, ArcView users can view but not edit Personal ArcSDE geodatabases 
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Extensions 

3D Analyst (includes ArcGlobe and ArcScene) 

ArcGlobe 
 
Ability to consume online content as the default layers in ArcGlobe 

- Content similar to that provided in ArcGIS Explorer 

 
 
Stars, Halo and Fog as background display in ArcGlobe 
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Improved Pan functionality that works like ArcGIS Explorer 
- The Globe Pan tool (exposed as a standalone tool, or through the middle-mouse button of the standard 

Navigate tool) will now keep the observer position the same elevation as the camera moves. This is the same 
experience as in ArcGIS Explorer. 

- Improvements were also made with gesturing, so that if animated rotations are enabled then the user can 
'throw' the view and 'drift' across the Globe as though flying.  Again, this is the same experience as ArcGIS 
Explorer 

 
Ability to use images as billboarded marker symbols (ArcGlobe and ArcScene) 

- 3D Marker symbols can now directly consume an image file as a symbol.  
- The image is added as a texture on to a flat piece of geometry and is added as a 3D Marker symbol. 
- The image file types supported include: png, jpg, jpeg, bmp, tif, gif, cel, tga, rgb, rgba, int, and inta. 

 
 
New marker-based '3D Billboards' style (for use in ArcGlobe and ArcScene) 

- A set of PNG-based images to use as point symbology 
- Particularly effective for large point feature classes 
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New tutorial on building realistic 3D views (eg: virtual cities) 

- A tutorial that follows a standard workflow for creating a realistic 3D view using symbology and display options 
available with ArcGlobe and ArcScene. 

 
Display improvements in ArcGlobe 

- General improvements to stability and performance, particularly elevation layers 
- Improvements for handling data that crosses the date line and the north/south 45 latitudes 
- Support for multiple caches for raster catalogs, to better support time animations for overlapping data  
- Minimum transparency threshold manipulation for textured 3D objects with partial transparency 

o Sometimes seen as 'halos', particularly around tree symbols 
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KML improvements in ArcGlobe 

- Many improvements in display and tags supported 
o Improved support for KML 2.0 and 2.1 tags 

- COLLADA support (in KML, symbology and import) 
- Screen Overlays 
- KML Network Links auto-refresh behavior (for navigation and duration) 
-  

 
Textured COLLADA     Screen Overlays 
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Globe Graphics improvements 

- Improved access to setting default graphic properties 
- Auto-calculated sizes for adding text elements (based on distance) 
- Ability to pin graphics to the Globe surface 
- Addition of draped and billboarded text graphics 

 

 
The 3 options for text elements (3D, draped and billboarded) 
 
New perimeter-based extrusion option for lines / polygons (ArcGlobe and ArcScene) 

- Description: ArcGIS 3D Analyst now supports a new perimeter-based extrusion option for polygons, where 
the exterior of the polgyon is extruded on a per-vertex basis, creating an exterior wall that is stitched 
together such that it follows the elevation (or z-aware profile) of the perimeter.  The top of the extruded 
polygon is then calculated using opposing vertices, creating a best-fit top that does not necessarily match 
the underlying elevation surface for the interior of the polygon.  This extrusion option is also available for 
polylines, and is supported in both ArcGlobe and ArcScene. 

- The option is exposed as the ‘adding it to each feature’s base height’ item in the ‘Apply extrusion by:’ 
combobox on the Globe Extrusion tab of the Layer Properties dialog. 

 

 
 
 
Other UI enhancements in ArcGlobe 
 -  

- Bookmarks in ArcGlobe and ArcScene  - Similar to ArcMap, there is a new Bookmarks menu in ArcGlobe 
and ArcScene. Besides this, the Bookamrks Manager dialog is modeless and allows the user to create and 
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manage bookmarks while interacting with the 3D scene. The users can also save and load bookmarks from 
the disk. 

- Location of Cache of a layer added to ArcGlobe - The location of the cache of a layer added to ArcGlobe is 
now exposed on the Cache tab of Globe Layer Properties dialog. Making the user’s aware of the cache 
location will allow them to manage the cache better. 

 
 
 
3D Analyst functionality 
 
The terrain dataset supports a new pyramid type called Window Size.  
 

• The window size pyramid type thins point data for each pyramid level by partitioning the data into 
equal areas (windows) and selecting just one or two points from each window as representatives of 
the surface. Point selection is based on one of the following: point with the minimum z-value, point 
with the maximum z –value, both the z minimum and maximum, or the point closest to the mean z-
value.   

• Building a terrain with the Window Size pyramid type is 5 to 10 times faster than the Z Tolerance based 
pyramid type.    

• In addition to the performance gain the window size pyramid type is more effective at dealing with all/first 
return lidar data (i.e., tree canopy, vegetation, buildings, etc.). The Z Tolerance pyramid type works best with 
bare earth data.   

• The Z Tolerance pyramiding algorithm was the individual pyramid type available at ArcGIS 9.2, allowing 
ArcGIS to handle mass amounts of clean bare earth data extremely well.  In this latest release, ArcGIS utilizes 
a Window Size pyramiding algorithm to generate surfaces that include features such as buildings and 
vegetation.   

• A new window has been added to the Terrain Wizard in order to specify the appropriate pyramid type for 
terrain datasets.   
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The Interpolate Shape and Line Of Sight functional surface geoprocessing tools now support terrain datasets 
as an input surface.   

 
• Previously these geoprocessing tools would perform such analysis on only either a raster or TIN surface. At 

ArcGIS 9.3, these tools now have the capability to use a terrain datasets as an input surface. 
 

 
 
 

A new Point File Information geoprocessing tool scans folders of 3D point files and writes out an polygon 
feature class containing one record in the attribute table for each 3D file present in the selected folders.   

 
• Folders containing LAS and/or ASCII files can be used to generate a polygon feature class.  The feature class 

includes a bounding box extent as a polygon or 3D multipatch for each 3D file encountered,  
• The attribute table contains valuable statistical information for each 3D point file found.    

The statistical information provided includes: the file name, the number of points, the estimated point spacing, 
and z minimum and z maximum for each file.  

• The point file information tool allows users to get an overall understanding of each 3D point file for QA/QC 
purposes before loading the 3D point files into the geodatabase. 

• The average point spacing of a 3D point dataset is the basis for the tiling scheme of a terrain dataset.   
Previously, users would have to rely primarily on a venders descripions of the dataset.  Now users can use the 
point file information tool to confirm the average point spacing of the data prior to building a terrain dataset.   

• The point file information tool can be found in the 3D Analyst toolbox, under Conversion, and then in the From 
File toolset. 
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The Lidar intensity attribute commonly contained within ASCII lidar files is now supported.  This new 
functionality is focused on importing ASCII lidar data into the geodatabase using the ASCII 3D To Feature 
Class geoprocessing tool. 
 

• XYZI format (I represents the lidar intensity) is a new Input File Format found on the ASCII 3D To Feature 
Class geoprocessing tool.   

• The lidar intensity attribute is automatically stored as BLOB attributes and accessed only through Arc Objects.  
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Decimal delimiter (‘.’ or ‘,’) in a text file can now be declared in the ASCII 3D To Feature Class and Feature 
Class Z to ASCII geoprocessing tools.  

 
• This enhancement is a significant change for international users. Previously users requiring a comma delimiter 

in text files would have to convert the text file to a decimal delimiter 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Profile Graph tool can now profile multiple lines in one graphical plot. 
 

• Previously the profile graph tool would generate one profile graph for only one line at a time.   
• More detailed analysis can now be completed with several lines shown in one single profile graph.    
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The Profile Graph tool can now graph line of sight results. 

 
• Profile graphs provide detailed analysis with line of sight results.  Until now, a line of sight analysis was not 

able to be plotted with the profile graph tool.  At ArcGIS 9.3, even multiple results from a line of sight study can 
be analyzed with the profile graph tool. 
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New 3D geometry COM interfaces have been added for developers for 3D analysis: IRelationalOperator3D, 
IProximity3D, ICurve3D, IVolume. 

 
IRelationalOperator3D 
 
This interface provides a method to determine whether two z aware geometries intersect in 3D space.  
 

• Disjoint3D 
Determines whether two z aware geometries intersect one another in 3D space.  Two geometries are disjoint if 
their intersection is empty.  Two geometries intersect if disjoint is "false". 

 
IProximityOperator3D 
 
3D proximity operators are used to find the 3D distance between two z aware geometries or the distance from a given 
point to the nearest point on another geometry. 
 

• QueryNearestPoint3D 
Queries the nearest point on a z aware geometry to the input point in 3D space.  Depending on the method of 
segment extension, the nearest point can also be found on an extension of the geometry. 

 
• ReturnNearestPoint3D 

Finds and returns the nearest point, in 3D space, on a z aware geometry to the input point.  Depending on the 
method of segment extension, the nearest point can also be found on an extension of the geometry. 

 
 

• ReturnDistance3D 
Returns the minimum distance between two z aware geometries in 3D space.  If the geometries intersect, the 
minimum distance is 0.  Only returns the distance, and not the nearest points. 
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ICurve3D 
 
A curve is an abstract one-dimensional geometry between specific From and To points.  A curve can be composed of 
a single Segment, a Path of connected segments, or a Polycurve containing many paths of segments.  The properties 
and methods of the curve allow the user to query information about the entire curve or points along the curve.  The 
distance along the curve can be specified in a fixed unit of measure or as a ratio of the Length of the curve.  The user 
can obtain information about Tangents, Normals, Subcurves, and Points along the curve. 
 

• GetSubCurve3D 
Gets the subcurve between the specified points along the original curve and creates a new curve. The 
elements in the new subcurve are the same type and have the same properties as the elements of the original 
curve. 

 
• IsClosed3D 

Indicates if 'from' and 'to' points (of each part) are identical. 
 

• Length3D 
Returns the 3D length of the entire curve.  The length of the curve is the sum of the lengths along each 
parameterized Segment between vertices along the curve.   

 
 

• QueryPoint3D 
Returns the Point at a given 3D distance along the curve or extended curve.  If the distance is less than the 
length of the curve, then the returned point is the point at that distance along the curve.  If the distance is less 
than zero, or greater than the length of the curve, then the returned point is on the curve specified by the 
extension method.  The distance may be specified as a fixed unit of measure or a ratio of the 3D length of the 
curve. 

 
 

• QueryPointAndDistance3D 
Finds the Point on the specified extended curve nearest to the input point and the distance between those 
points.  Also returns information about the side of the curve the input point is on as well as the distance along 
the curve that the nearest point occurs. The operation is performed in 3D space. 

 
IPolycurve3D 
 
A polycurve is a collection of many curves that form a single curve.  A polycurve can be composed of single segments, 
connected paths, closed rings, or a combination of various curve types.  The paths and segments within a polycurve 
do not need to be connected to each other.  A polycurve may also contain a single segment or path. 
 
 

• Densify3D 
Converts Polycurve into a Polycurve composed of Line segments with 3D length maxSegmentLength (or less) 
that are within maxDeviation of the original polycurve.  If maxDeviation = 0, maxDeviation is ignored and Line 
segments with length maxSegmentLength are constructed with vertices laying on the original curve.  All of the 
segments in the final polyline will be 3D Lines. 

 
 

• Generalize3D 
Generalizes each part of a Polycurve into a generalized collection of Line segments.  Generalize3D performs a 
Douglas-Poiker Generalization algorithm, extended to operate in 3D space, with a specified maximum offset 
tolerance, given in 3D, as input. For Line segments, the Generalized output is a subset of the original input 
vertices.  For non-Linear segments, the Generalized output contains points along all parts of the curve, not 
necessarily only the vertices. 

 
 

• Smooth3D 
Converts the Polycurve into a Polycurve containing only BezierCurve segments. If the maxAllowableOffset 
parameter is zero, each segment of the input Polycurve becomes a separate Bezier curve. If 
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maxAllowableOffset if greater than zero, the polycurve is generalized first by the Douglas-Poiker method using 
the maxAllowableOffset value. Bezier curves are then created for each of the remaining segments. The 
created BezierCurve polycurve is an approximation of the original polycurve. At each vertex, the adjoining 
BezierCurves have complementary tangents which creates a continuous (smooth) transition between 
segments. 

 
 

• Weed3D 
Weed Generalizes each part of a Polycurve into a generalized collection of z aware Line segments.  Weed 
performs a Douglas-Poiker Generalization algorithm, extended to operate in 3D space, with a specified 
multiple of the internal tolerance given as input.  For Line segments, the Generalized output is a subset of the 
original input vertices.  For non-Linear segments, the Generalized output contains points along all parts of the 
curve, not necessarily only the vertices. 

 
 
 
IVolume 
 
Used to calculate volume. 
 

• Volume 
Returns the bounded 3D area of a closed multipatch. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Geostatistical Analyst 

New tool for performing simulations 
 

A new Gaussian Geostatistical Simulations (GGS) tool has been added to the Geostatistical Analyst Toolbox. This 
tool creates surfaces that reproduce the local variability better than the smoothed surfaces kriging produces.   
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The GGS tool produces multiple surfaces that are all equally probable. These surfaces can be used in risk analysis 
(e.g. calculating the probability that an environmental threshold is exceeded) or as input to a model in order to evaluate 
variation in the model’s output (e.g. produce a distribution of economic results for a resource exploitation plan).   
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ArcGIS 9.2 

Input points Geostatistical model 

 
The GGS tool is capable of performing conditional or unconditional simulation, creating predicted surfaces, and 
generating summary statistics for the entire region or for areas of specific interest.  
 
 
We’ve gone parallel! 
 

Several steps in the calculation of geostatistical layers can now take advantage of multiple CPUs in order to 
increase performance. This enhancement includes all Kriging and Inverse Distance Weighting models that are created 
within the Geostatistical Wizard, as well as cross-validation and the validate and predict functions for geostatistical 
layers. Additionally, the following tools in the Geostatistical Analyst Toolbox take advantage of multiple-CPUs:  
 
- GA Layer to Grid 
- GA Layer To Points 
- Gaussian Geostatistical Simulations (for conditional simulation) 
 
Increased processing speed is most noticeable in complex models (e.g. involving data transformations, large 
neighborhoods, etc.), and in repeated use of the tools (as in models and scripts).  
 

Geostatistical Simulation Interpolation 

ArcGIS 9.3 

One single smooth surface. 

Multiple surfaces that  
represent local variability 
better than kriging. 
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Network Analyst 

 
New vehicle routing problem (VRP) solver 
 

The vehicle routing problem solver provides the ability to generate routes for a fleet of vehicles.  This solver assigns 
and sequences orders on routes, taking into consideration multiple constraints and objectives, such as time windows, 
vehicle capacities, route zones, and operating costs.  This solver can be used to generate routing solutions for 
pickup/delivery, para-transit, or other applications that require optimizing the routes of multiple vehicles servicing a set 
of orders. 
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New evaluators for network dataset attributes 
 

Function evaluator—The function evaluator calculates attribute values by performing a multiplicative or logical 
function on another attribute value or parameter value. For numeric attribute types, the values are derived from an 
expression that multiplies the value of another attribute by some value. For example: DriveTime * 1.25. For Boolean 
attribute types, the values are derived from an expression that compares another attribute value to a parameter value. 
For example: MaxHeight > VehicleHeight.  
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Global turn delay evaluator—The global turn delay evaluator assigns a cost value for transitioning between two 
edge elements based on the deflection angle between the two edges and the hierarchy attribute value of each edge. 
For example, it may take longer to make a left turn from a local road on to a secondary road than it does to go straight 
through an intersection on a secondary road.  
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Publisher and ArcReader 

ArcReader 
 

It is now easier to access bookmarks: The bookmarks pullright has been moved out of the View pulldown menu and 
is now a separate Bookmarks pulldown menu 
 

You can now export ink markups created in ArcReader so that they can be loaded into ArcMap. Markup tools were 
added into ArcReader at 9.2 for annotating and adding notes and updates to maps, especially in the field when 
working on Tablet PCs. With 9.3 your ArcReader users can create markups which can then be loaded into ArcMap so 
that data can be edited to reflect the changes noted in the markup. 
 

ArcReader users can now access standard address locators (file-based locators and locators stored in 
geodatabases in ArcReader when they use the Find dialog.. This has been frequently requested so that ArcReader 
users can work with same custom address locators that are used in ArcMap. ArcReader users can browse to the 
address locator they wish to use directly from the Find dialog. The address locator does not need to be added into the 
published map by the map publisher. 
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Schematics 

Working with schematic diagrams in ArcMap 
 

As described in the ArcMap chapter of this document, the viewer windows introduced in 9.2 have been enhanced 
so that you can use them to work with the contents of inactive data frames side-by-side on-screen with the active data 
frame shown in the main ArcMap window. This enables you to work with a schematic diagram side-by-side with the 
geography it represents without having to work in Layout view.  
 
In the example below, two schematic diagrams have been created to represent the features in the data frame called 
Geography shown in the main ArcMap window. Each schematic is in its own separate data frame displayed inside a 
viewer window: 
 

 
 
The Schematics commands and tools have been updated in Service Pack 2 so that you can use them to perform 
operations on schematics displayed inside inactive data frames in viewer windows.  
 
To work with geography and a schematic side-by-side, first activate the data frame containing the data you want to see 
in a viewer window. Now choose the Viewer command from the Window pulldown menu to open a viewer window. 
Finally, activate the data frame you want to work with in the main ArcMap window. The viewer window you opened will 
remain on-screen, allowing you to work with both data frames. (In the Desktop Help, see: Extensions > Schematics > 
Working with ArcGIS Schematics > Viewing schematic diagrams > Viewing schematic diagrams in ArcMap). 
 
Tip: There are two shortcuts that make it easy to work with multiple data frames: CTRL + TAB switches between the 
data frames making each one active in turn. (If you want to be able to do the same thing by pressing a button on-
screen, add the Activate Next Data Frame command into any toolbar from the View category in the Tools > Customize 
dialog). ALT + click on the name of a data frame in the Table Of Contents activates that data frame. 

 
(This enhancement was originally introduced in 9.2 Service Pack 2). 
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Improved layout algorithms 
 

New layout algorithm: Geo-Partial Overlapping Links. As shown in the figure below, this new layout algorithm is 
used when links are organized in a set of parallel routes and when the offsets are too small resulting in a lack of 
visibility related to the scale (This enhancement was originally introduced in 9.2 Service Pack 3): 
 

 

                        
                                    Before                                                After     
 

The Geo-Linear Dispatch layout algorithm has been enhanced by moving leaves with one link. To get the clearest 
diagrams, the layout is enhanced to include the leaves having one link in the repositioning process. This function is 
useful to manage secondary networks in the field of water, gas and electrical distribution:  (This enhancement was 
originally introduced in 9.2 Service Pack 3): 
 

     
                       Before                            After (9.2)                          After (starting at 9.2 SP3) 
 
Schematics extension: Improved diagram to feature export  
 

When you export a schematic diagram as shapefiles or feature classes, it will now automatically export all the 
attributes of the features. Previously it only exported a small subset of attributes for Schematics to track internally. This 
allows you to link the exported diagram features back to the original geographic features to access other field 
information. (This enhancement was originally introduced in 9.2 Service Pack 4). 
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Spatial Analyst 

Improved performance for the Combine geoprocessing tool 
 

Beginning with Service Pack 2, the performance of the Spatial Analyst extension's Combine geoprocessing tool has 
been improved so it is up to 40 times faster than before. The Combine tool, in the Spatial Analyst Tools > Local toolset, 
lets you combine multiple rasters together. For example, a use of Combine on 250,000 combinations that used to take 
1 hr, and now only takes 1.5 minutes. It can now also handle millions of combinations. 
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Survey Analyst 

New Cadastral Editor 
 

The goal of the Survey Analyst extension is to improve the spatial accuracy of GIS data and to provide information 
about the accuracy of this data. We are now introducing a major enhancement to this extension: the Cadastral Editor. 
The Cadastral Editor introduces a new cadastral fabric data model, new workflows, and a completely new set of 
cadastral tools. The Survey Analyst includes the existing Survey Editor, but now also includes the Cadastral Editor. 
 
- The Survey Editor is the same technology as was available at 9.2. The Survey Editor includes a set of focused tools 

for defining and maintaining accurately measured coordinates based on field observations from total station 
equipment. 

 
- The Cadastral Editor includes the functionality, standard data model, and common workflows you need for building 

and maintaining a cadastral land records system (a cadastral fabric). 
 
Many geographic information systems use cadastral records to build the base map for the other layers within the GIS. 
Parcel and cadastral databases are built through coordinate geometry and plan data entry. The accurate coordinate 
data available from new technologies and techniques can be combined with recorded land descriptions to improve 
spatial accuracy in the geodatabase. The new Cadastral Editor provides a framework and data model for efficiently 
performing these workflows.  
 

The Survey Analyst product license covers both the existing Survey Editor and the new Cadastral Editor. They can 
be installed separately or together, and can also be used separately or together as complementary survey 
technologies. You will see the name of the editor(s) you install listed under the Survey Analyst entry in the Tools > 
Extensions dialog. Checking the box next to the Survey Analyst extension in that dialog enables whichever editors 
have been installed. In the example below, both editors have been installed: 
 

 
 

The Cadastral Editor works with a new type of parcel dataset, called a cadastral fabric. A cadastral fabric is a 
continuous integrated surface of connected parcels, representing the complete survey record for an area of land.  
 
Dimensions in the cadastral fabric are edited in response to a change in the survey record, for example, a parcel split 
or resurvey. Parcel boundary line dimensions in the cadastral fabric match the dimensions on the survey record. 
Parcels that are edited or replaced by new survey records are retained as historic, thus always preserving the original 
survey record. Parcel polygons are also linked to each other by connection lines, for example, connection lines across 
roads. Because each and every parcel is either linked or connected, a seamless network of connected parcel 
boundaries, or cadastral fabric, is formed. Parcel lines have endpoints, which are the parcel corners. Parcel corner 
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points are common between adjacent parcel boundaries, establishing connectivity and maintaining topological integrity 
in the network. In the geodatabase, topology is the arrangement that defines how point, line, and polygon features 
share coincident geometry. 
 
Cadastral fabrics are stored in feature datasets: 
 

 
 
The cadastral fabric acts as a basemap for overlying GIS feature classes. Feature classes such as building polygons 
and utility lines are constructed in relation to parcel boundaries. The result is that GIS features are correctly aligned 
with the cadastral fabric. 
 

Here are the key elements of the new cadastral technology: 
 
- Provides a base-map for parcels as recorded by cadastral surveyors through deeds and subdivisions. 
 
- Improves the spatial accuracy of the fabric by processing the legal record information from parcels using a least 

squares algorithm designed by surveyors.  
 
- Spatially update GIS feature layers that coincide with the fabric on demand. 
 
- Extensible data model familiar to ArcGIS users.  
 
- Provides a COGO coverage equivalent in the geodatabase. 
 
- Tracks the lineage of parcels based on their legal record end & start dates. 
 
- Manage subsets of the data as cadastral jobs.  
 
- New set of interactive tools, including parcel construction tools: 
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In the Desktop Help, see: Extensions > Survey Analyst > Cadastral Editor 
 
(The Cadastral Editor was originally introduced in 9.2 Service Pack 3. In 9.3 we have continued to improve the quality 
of this new editor and data model). 
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Tracking Analyst 

A number of enhancements have been made to Tracking Analyst in 9.3. 
 
Tracking Analyst enters the third dimension 
 

You can now display and analyze your real-time and historical data in 3D Analyst’s ArcGlobe using your favorite 
Tracking Analyst tools and commands.  Make your analysis more immersive by using 3D models to symbolize your 
data.  Keep tabs on your planes in the air, subway trains under ground, or automobiles on the roads.  Using the 
Playback Manager you can pause and rewind time to relive the excitement.   
 
 

New Purge Rule support 
 
The purge rule defines how real-time data is stored in the geodatabase.  Tracking Analyst stores real-time data 
completely in-memory in order to eliminate the performance bottleneck of reading and writing data to disk.  In order to 
limit the maximum amount of memory consumed data must be removed, or purged, from the geodatabase periodically.  
The mechanism for specifying which data is removed and how often is called the purge rule. 
 
You have always had the ability to purge a percentage of the oldest records in the in-memory database, but now you 
have the option to keep only the most recent record for every entity you might be tracking.  This is great for situations 
where you have thousands of separate tracks coming in and you want to see where they all currently are.   
 
 
It’s dynamic 
 

Accelerate your 2D Tracking Analyst data with Dynamic Display.  Dynamic Display support allows you to display 
more features on the screen while using less processing power.   
 
 
Real-time data statistics 
 

Developers should be sure to check out the new temporal statistics features in the Tracking Analyst API.  Use the 
statistics to monitor data rates, total message counts, track counts, and connection status.   
 
 
Actions on servers now supported 
 

Actions on tracking servers ('service actions') can now be accessed, edited and defined. The Actions tab in the 
tracking layer properties dialog has been enhanced to expose service actions. 
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Summary of map navigation shortcuts in ArcMap  (*New* = added in 9.3) 

Panning  
Click mouse wheel: Center map at location you clicked 
Hold down mouse wheel: Pan map 

Hold down  Temporarily switch to Pan tool. Single click centers. Drag pans 

 
Page map left / right / up / down 

 
Scroll map left / right / up / down 

Single-click with any pan tool: Center map at location you clicked 
 

Zooming  
Roll mouse wheel: Zoom in / out. Direction can be customized in Tools>Options dialog. 
CTRL + roll mouse wheel: Zoom in / out at finer rate 
CTRL + click mouse wheel: Center map and zoom in at location you clicked 

CTRL + drag mouse wheel: Zoom in on box you define 

Hold down  or  Temporarily switch to Zoom In or Zoom Out tool 

Hold down  
Temporarily switch to Continuous Zoom / Pan tool. Drag up / down 
with left mouse button to zoom in / out. Right mouse button pans 

 
Zoom out / in 

 
Other  
Right-click map in Data View: Access new context menu of shortcuts to commands 
Hold down SHIFT while in 
Layout view: 

Apply map navigation with mouse wheel, Z X C B keys, or 
Continuous Zoom/Pan tool to data frame instead of layout page 

 Put keyboard focus onto map from Table Of Contents 

 Put keyboard focus onto Table Of Contents from map 

 Refresh map 

 Toggle between Zoom In, Zoom Out, & Pan tools when one is active 

 Toggle Pause Drawing mode 

 Activate selected data frame in Table Of Contents 

 Full extent 

 Previous extent / next extent 

CTRL + TAB: Switches between data frames when there is more than one 
CTRL + click check box in TOC: Turn all layers on and off 
ALT + click check box in TOC: Turn layer you clicked on and all others off   *New* 
ALT + click layer name in TOC: Zoom to this layer's extent  
ALT + click data frame in TOC: Activate this data frame 
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Summary of tables shortcuts  (*New* = added in 9.3) 
  
Opening and closing tables 

CTRL + double-click layer or table Open table window for the layer or table you clicked in Table Of Contents. 
CTRL + T or CTRL + ENTER  Open table window for currently selected layer/table(s) in Table Of Contents.  
CTRL + T in table window  Minimizes the window.  
CTRL + SHIFT + T  Toggle all tables between displayed and minimized state (show/hide all) 
CTRL + SHIFT + TAB   Toggles between the tables you currently have open.  
CTRL + SHIFT + F4  Close all currently open tables.  

 
Working with fields 

Right-click field name Get context menu of field commands. 
CTRL + Double-click field name Turn field off. Same as unchecking it in the Layer Properties Fields tab. 
CTRL + SHIFT + Double-click  Hide this field (same as dragging its column so it has no width). 
Double-click column divider Reveals hidden field if the divider is next to a hidden field.   
ALT + Double-click field name *New* Open properties dialog for field (lets you set the alias, number format, etc). 
CTRL + SHIFT + P *New* Open properties dialog for the selected field. 
CTRL + Right-click field name *New* Toggle showing aliases on/off for all fields in the table  
CTRL + SHIFT + N *New* Toggle showing aliases on/off for all fields in the table  
 

 
Navigating around a map from a table 

Right-click grey cell Get context menu of navigation and other commands. 
Double-click grey cell Zoom to this feature and select it exclusively. 
CTRL + Double-click grey cell  Pan to this feature and select it exclusively. 
CTRL + 8  Flash current feature. 
CTRL + =  Zoom to current feature. 
CTRL + P Pan to current feature. 
CTRL + I Identify the current record. 
CTRL + SHIFT + = Zoom to selected features. 
 

Navigating around inside a table 
   Go left or right. Wrap back to start of same record at end of row. 
 or ENTER  Go to the cell below. 
 or SHIFT + ENTER  Go to the cell above. 

HOME or END Go to the first or last cell in the current row 
CTRL +  or  Go to the first or last cell in the current row. 
TAB  Go to the cell to the right. Wraps around to next record below at end of row. 
SHIFT + TAB  Go to the cell to the left. Wraps around to next record above at start of row. 
CTRL +  or  Go to the first or last cell in the current column. 
CTRL + HOME or END Go to first cell in first row or last row in last row.  
CTRL + F  Launch Find dialog. 
CTRL + G Go to a record number.   
Application key  Open the row context menu.  
CTRL + Application key  Open the Options menu. 
Right-click bottom part of table Open the Options menu. 
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Copying data from a table 
CTRL + C or CTRL + INSERT  Copy the value in the current cell to clipboard. 
CTRL + SHIFT + C Copy selected records to clipboard. 
 

Sorting records 
Double-click field name Sort on table on field A - Z. Double-click again to sort Z - A. 
SHIFT + Double-click field name *New* Opens the Advanced Sorting dialog so you can sort table on up to 4 fields. 
 

Selecting and unselecting records 
CTRL + click on a record Add it to the selected set (or remove it if it is already selected). 
SHIFT + click on a record Extend the selection from currently selected record(s) to the record you click. 
SHIFT + SPACEBAR or  or  Make block selection. 
CTRL + TAB  Switch between Show All Records and Show Selected Records mode. 
SPACEBAR Select or unselect the current record (highlights or unhighlights if in Show 

Selected Records Mode). In editing mode shortcut is CTRL + SPACEBAR. 
BACKSPACE Remove the current record from the selection in Show All or Show Selected 

Records Mode. Not available if you are editing the table. 
CTRL + SHIFT + R  *New* Reselect highlighted records in Show Selected Records mode. 
CTRL + ENTER Go to next record and select it. Unselects the one you began on if it was 

selected. Lets you work sequentially through a table selecting each record. 
CTRL + SHIFT + ENTER  Go the previous record and select it. 
Click top left corner of table  Clear the selected set (highlighted set in Show Selected Records). 
SHIFT + click top left corner  Select all records. 
CTRL + click top left corner Switch selection. 
CTRL + BACKSPACE  Clear the selected set. 
CTRL + A Select all records. 
CTRL + SHIFT + A Clear the selected set. 
CTRL + U Switch selection. 

 
Editing the data in a table 

CTRL + SHIFT + E Start or stop editing . 
F2 Edit contents of current cell. Press again to finish editing cell. 
ESC Cancels editing the current cell and restores the original value. 
ENTER Finish editing cell and go down to the next cell below in same field. 
TAB Finish editing cell and go across to next cell to the right in same record. 

Wraps around to next record below when you get to the end of the row.  
CTRL + ENTER Same as ENTER but selects the next record too so you can see it on map.  
CTRL + V or SHIFT + INSERT  Paste the contents of the clipboard into the current cell.  
CTRL + Z and CTRL + Y Undo/Redo edits to a record. 
DELETE  Delete currently selected record(s). 
CTRL + D In Show All Records mode, deletes currently selected records(s). In Show 

Selected Records mode, deletes the currently highlighted (yellow) records in 
your selection. 

SHIFT + ENTER Inserts a line feed into a text string when you are editing it (for example, to 
use as stacked text for labeling or annotation).  
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